blob: 18f899adc570093713cf1d20ef9e4d22b4fd229c [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<configuration>
<!-- Package Description information to be picked up by www.eclipse.org/packages -->
<!-- PackageName is the title of your package
maintainer is the project or persons that are maintaining the package
iconurl is the fully qualified URL to the icon you wish to use on the site (48x48)
bugzillaComponentID is used to gather bugzilla information about your package. This should be given to you after provisioning of the package is finished
testPlan is the fully qualified URL to the test plan for this package
-->
<packageMetaData
packageName="Eclipse IDE for Java EE Developers"
maintainer="Eclipse Packaging Project"
iconurl="http://www.eclipse.org/downloads/images/jee.jpg"
bugzillaComponentId="jee-package"
testPlan="http://www.eclipse.org/epp/testplan.php" >
<!-- Description is wrapped in CDATA tags to allow you to insert HTML code if necessary -->
<description><![CDATA[Tools for Java developers creating JEE and Web applications, including a Java IDE, tools for JEE and JSF, Mylyn and others.]]></description>
<!-- packageTesters is a list of the people that are testing the package -->
<packageTesters>
<tester>David Williams</tester>
<tester>Markus Knauer</tester>
<tester>Mik Kersten</tester>
<tester>Martin Oberhuber</tester>
</packageTesters>
</packageMetaData>
<!-- version, the RCP version to build. This is used to determine the file
name of the root file archives -->
<rcp version="3.4M7" />
<!-- name, the name of the product, used in naming the created files. -->
<product
name="eclipse-jee-ganymede-M7"
eclipseProductId="org.eclipse.platform.ide"
initialPerspectiveId="org.eclipse.jst.j2ee.J2EEPerspective" />
<!-- url, pointing to an update site. -->
<updateSites>
<!-- local mirrors -->
<updateSite url="file:///home/data/httpd/download.eclipse.org/eclipse/updates/3.4/" />
<updateSite url="file:///home/data/httpd/download.eclipse.org/eclipse/updates/3.4milestones/" />
<updateSite url="file:///home/data/httpd/download.eclipse.org/releases/ganymede/staging/" />
<updateSite url="file:///home/data/httpd/download.eclipse.org/technology/epp/updates/0.5milestones/" />
<!-- eclipse.org update sites -->
<!--
<updateSite url="http://download.eclipse.org/eclipse/updates/3.4/" />
<updateSite url="http://download.eclipse.org/eclipse/updates/3.4milestones/" />
<updateSite url="http://download.eclipse.org/releases/ganymede/" />
<updateSite url="http://download.eclipse.org/releases/ganymede/staging/" />
-->
</updateSites>
<!-- id, a feature id. -->
<!-- version, the feature version. -->
<requiredFeatures>
<feature
id="org.eclipse.platform"
version="latest">
</feature>
<feature
id="org.eclipse.cvs"
version="latest">
</feature>
<feature
id="org.eclipse.jdt"
version="latest">
</feature>
<feature
id="org.eclipse.pde"
version="latest">
</feature>
<feature
id="org.eclipse.mylyn_feature"
version="latest">
</feature>
<feature
id="org.eclipse.mylyn.context_feature"
version="latest">
</feature>
<feature
id="org.eclipse.mylyn.ide_feature"
version="latest">
</feature>
<feature
id="org.eclipse.mylyn.java_feature"
version="latest">
</feature>
<feature
id="org.eclipse.mylyn.pde_feature"
version="latest">
</feature>
<feature
id="org.eclipse.mylyn.bugzilla_feature"
version="latest">
</feature>
<feature
id="org.eclipse.emf.common"
version="latest">
</feature>
<feature
id="org.eclipse.emf.common.ui"
version="latest">
</feature>
<feature
id="org.eclipse.emf.ecore"
version="latest">
</feature>
<feature
id="org.eclipse.emf.edit"
version="latest">
</feature>
<feature
id="org.eclipse.emf.ecore.edit"
version="latest">
</feature>
<feature
id="org.eclipse.emf.edit.ui"
version="latest">
</feature>
<feature
id="org.eclipse.xsd"
version="latest">
</feature>
<feature
id="org.eclipse.xsd.edit"
version="latest">
</feature>
<feature
id="org.eclipse.gef"
version="latest">
</feature>
<feature
id="org.eclipse.wst.common_ui.feature"
version="latest">
</feature>
<feature
id="org.eclipse.wst.xml_ui.feature"
version="latest">
</feature>
<feature
id="org.eclipse.emf"
version="latest">
</feature>
<feature
id="org.eclipse.emf.ecore.sdo"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.connectivity.oda.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.doc.user"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.connectivity.oda.designer.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.modelbase.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.connectivity.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.sqldevtools.results.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.sqldevtools.ddlgen.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.sqldevtools.ddl.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.sqldevtools.data.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.sqldevtools.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.enablement.jdbc.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.sqldevtools.parsers.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.enablement.feature"
version="latest">
</feature>
<!-- optional DB/SQL features -->
<feature
id="org.eclipse.datatools.enablement.apache.derby.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.enablement.hsqldb.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.enablement.ibm.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.enablement.msft.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.enablement.mysql.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.enablement.oda.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.enablement.oda.designer.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.enablement.oracle.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.enablement.postgresql.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.enablement.sap.feature"
version="latest">
</feature>
<feature
id="org.eclipse.datatools.enablement.sybase.feature"
version="latest">
</feature>
<!-- optional DB/SQL features / END -->
<feature
id="org.eclipse.wst"
version="latest">
</feature>
<feature
id="org.eclipse.jst"
version="latest">
</feature>
<feature
id="org.eclipse.jpt.feature"
version="latest">
</feature>
<feature
id="org.eclipse.rse"
version="latest">
</feature>
<feature
id="org.eclipse.epp.usagedata.feature"
version="latest">
</feature>
</requiredFeatures>
<!-- folder, pointing to a folder containing the zipped root files for each of
the target platforms. -->
<rootFileFolder folder="/home/data/httpd/download.eclipse.org/eclipse/downloads/drops/S-3.4M7-200805020100" />
<!-- relativeFolder, names the subfolder of the base folder where the update site will be created.
This is configurable so that working areas, especially root files, are reusable. -->
<extensionSite relativeFolder="extension_site"></extensionSite>
<!-- Create archives for win32, linux, macosx platforms, antZip is default format -->
<targetPlatforms>
<platform
os="win32"
ws="win32"
arch="x86">
<archiveFormat format="antZip"></archiveFormat>
<eclipseIniFileContent path="/eclipse/">-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256M
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m</eclipseIniFileContent>
</platform>
<platform
os="linux"
ws="gtk"
arch="x86">
<archiveFormat format="tar" />
<eclipseIniFileContent path="/eclipse/">-showsplash
org.eclipse.platform
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m</eclipseIniFileContent>
</platform>
<platform
os="linux"
ws="gtk"
arch="x86_64">
<archiveFormat format="tar" />
<eclipseIniFileContent path="/eclipse/">-showsplash
org.eclipse.platform
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m</eclipseIniFileContent>
</platform>
<platform
os="macosx"
ws="carbon"
arch="ppc">
<archiveFormat format="tar" />
<eclipseIniFileContent path="/eclipse/Eclipse.app/Contents/MacOS/">-showsplash
org.eclipse.platform
-startup
../../../plugins/org.eclipse.equinox.launcher_1.0.100.v20080501.jar
--launcher.library
../../../plugins/org.eclipse.equinox.launcher.carbon.macosx_1.0.100.v20080428-1330
-vmargs
-Xdock:icon=../Resources/Eclipse.icns
-XstartOnFirstThread
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-Dosgi.requiredJavaVersion=1.5
-Dorg.eclipse.swt.internal.carbon.smallFonts</eclipseIniFileContent>
</platform>
</targetPlatforms>
</configuration>