use 1.5 (to avoid minor warning)
diff --git a/org.eclipse.wtp.releng.versionchecker/.classpath b/org.eclipse.wtp.releng.versionchecker/.classpath
index 3b88e36..27cfeb4 100644
--- a/org.eclipse.wtp.releng.versionchecker/.classpath
+++ b/org.eclipse.wtp.releng.versionchecker/.classpath
@@ -1,8 +1,8 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <classpath>
-	<classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
+	<classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
 	<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
 	<classpathentry kind="src" path="src"/>
-	<classpathentry kind="src" path="referenceData"/>
+	<classpathentry kind="src" path="referenceData/"/>
 	<classpathentry kind="output" path="bin"/>
 </classpath>
diff --git a/org.eclipse.wtp.releng.versionchecker/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.wtp.releng.versionchecker/.settings/org.eclipse.jdt.core.prefs
index ae75691..e7b26f4 100644
--- a/org.eclipse.wtp.releng.versionchecker/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.wtp.releng.versionchecker/.settings/org.eclipse.jdt.core.prefs
@@ -1,6 +1,6 @@
-#Sun Sep 14 20:47:31 EDT 2008
+#Sun Sep 14 21:13:28 EDT 2008
 org.eclipse.jdt.core.incompatibleJDKLevel=warning
-org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.compliance=1.5
 org.eclipse.jdt.core.builder.duplicateResourceTask=warning
 org.eclipse.jdt.core.compiler.problem.fatalOptionalError=disabled
 org.eclipse.jdt.core.builder.recreateModifiedClassFileInOutputFolder=enabled
@@ -15,10 +15,10 @@
 org.eclipse.jdt.core.compiler.debug.sourceFile=generate
 org.eclipse.jdt.core.compiler.debug.lineNumber=generate
 org.eclipse.jdt.core.circularClasspath=error
-org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
 org.eclipse.jdt.core.builder.invalidClasspath=ignore
-org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
-org.eclipse.jdt.core.compiler.source=1.3
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.source=1.5
 org.eclipse.jdt.core.incompleteClasspath=error
 org.eclipse.jdt.core.builder.cleanOutputFolder=clean
diff --git a/org.eclipse.wtp.releng.versionchecker/META-INF/MANIFEST.MF b/org.eclipse.wtp.releng.versionchecker/META-INF/MANIFEST.MF
index 0927a0c..83b71ca 100644
--- a/org.eclipse.wtp.releng.versionchecker/META-INF/MANIFEST.MF
+++ b/org.eclipse.wtp.releng.versionchecker/META-INF/MANIFEST.MF
@@ -9,4 +9,4 @@
 Eclipse-LazyStart: true
 Export-Package: org.eclipse.wtp.releng.tools.versionchecker
 Bundle-Vendor: %Bundle-Vendor.0
-Bundle-RequiredExecutionEnvironment: J2SE-1.4
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/org.eclipse.wtp.releng.versionchecker/build.properties b/org.eclipse.wtp.releng.versionchecker/build.properties
index 7e6fae1..d1ae68d 100644
--- a/org.eclipse.wtp.releng.versionchecker/build.properties
+++ b/org.eclipse.wtp.releng.versionchecker/build.properties
@@ -5,5 +5,7 @@
                .,\
                plugin.xml,\
                plugin.properties,\
-               referenceData/
+               referenceData/,\
+               doc/,\
+               runVersionLister.bat
 src.includes = doc/