ASSIGNED - bug 223526: require-bundle should specify ranges
https://bugs.eclipse.org/bugs/show_bug.cgi?id=223526
diff --git a/bundles/org.eclipse.wst.xsl.core/META-INF/MANIFEST.MF b/bundles/org.eclipse.wst.xsl.core/META-INF/MANIFEST.MF
index 6aed468..582259f 100644
--- a/bundles/org.eclipse.wst.xsl.core/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.wst.xsl.core/META-INF/MANIFEST.MF
@@ -4,15 +4,15 @@
 Bundle-SymbolicName: org.eclipse.wst.xsl.core;singleton:=true
 Bundle-Version: 0.5.0.qualifier
 Bundle-Activator: org.eclipse.wst.xsl.core.internal.XSLCorePlugin
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.wst.common.uriresolver,
- org.eclipse.wst.xml.core,
- org.eclipse.core.resources,
- org.eclipse.wst.sse.core,
- org.apache.xalan;bundle-version="2.7.0",
- org.apache.ant;bundle-version="1.7.0";resolution:=optional,
- org.eclipse.ant.core;bundle-version="3.1.300",
- org.eclipse.wst.validation;bundle-version="1.1.103"
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.wst.common.uriresolver;bundle-version="[1.1.301,2.0.0)",
+ org.eclipse.wst.xml.core;bundle-version="[1.1.300,2.0.0)",
+ org.eclipse.core.resources;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.wst.sse.core;bundle-version="[1.1.300,2.0.0)",
+ org.apache.xalan;bundle-version="[2.7.0,2.8.0)",
+ org.apache.ant;bundle-version="[1.7.0,2.0.0)";resolution:=optional,
+ org.eclipse.ant.core;bundle-version="[3.1.300,4.0.0)",
+ org.eclipse.wst.validation;bundle-version="[1.1.103,2.0.0)"
 Bundle-ActivationPolicy: lazy
 Bundle-RequiredExecutionEnvironment: J2SE-1.5
 Bundle-ClassPath: .
diff --git a/bundles/org.eclipse.wst.xsl.debug.ui/META-INF/MANIFEST.MF b/bundles/org.eclipse.wst.xsl.debug.ui/META-INF/MANIFEST.MF
index e69f4ba..0bd282d 100644
--- a/bundles/org.eclipse.wst.xsl.debug.ui/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.wst.xsl.debug.ui/META-INF/MANIFEST.MF
@@ -4,22 +4,22 @@
 Bundle-SymbolicName: org.eclipse.wst.xsl.debug.ui;singleton:=true
 Bundle-Version: 0.5.0.qualifier
 Bundle-Activator: org.eclipse.wst.xsl.internal.debug.ui.XSLDebugUIPlugin
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.core.resources,
- org.eclipse.core.variables,
- org.eclipse.debug.core,
- org.eclipse.debug.ui,
- org.eclipse.jdt.debug.ui,
- org.eclipse.jdt.launching,
- org.eclipse.jface.text,
- org.eclipse.ui.editors,
- org.eclipse.ui.ide,
- org.eclipse.ui.workbench.texteditor,
- org.eclipse.wst.sse.ui,
- org.eclipse.wst.xsl.launching,
- org.eclipse.wst.xsl.debug,
- org.eclipse.ui.console
+Require-Bundle: org.eclipse.ui;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.resources;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.variables;bundle-version="[3.2.0,4.0.0)",
+ org.eclipse.debug.core;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.debug.ui;bundle-version="[3.3.100,4.0.0)",
+ org.eclipse.jdt.debug.ui;bundle-version="[3.3.0,4.0.0)",
+ org.eclipse.jdt.launching;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.jface.text;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui.editors;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui.ide;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui.workbench.texteditor;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.wst.sse.ui;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.wst.xsl.launching;bundle-version="[0.5.0,1.0.0)",
+ org.eclipse.wst.xsl.debug;bundle-version="[0.5.0,1.0.0)",
+ org.eclipse.ui.console;bundle-version="[3.2.0,4.0.0)"
 Eclipse-LazyStart: true
 Bundle-RequiredExecutionEnvironment: J2SE-1.5
 Bundle-Localization: plugin
diff --git a/bundles/org.eclipse.wst.xsl.launching/META-INF/MANIFEST.MF b/bundles/org.eclipse.wst.xsl.launching/META-INF/MANIFEST.MF
index 55bf104..200bf3b 100644
--- a/bundles/org.eclipse.wst.xsl.launching/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.wst.xsl.launching/META-INF/MANIFEST.MF
@@ -4,17 +4,17 @@
 Bundle-SymbolicName: org.eclipse.wst.xsl.launching;singleton:=true
 Bundle-Version: 0.5.0.qualifier
 Bundle-Activator: org.eclipse.wst.xsl.internal.launching.LaunchingPlugin
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.core.expressions,
- org.eclipse.core.filesystem,
- org.eclipse.core.resources,
- org.eclipse.core.variables,
- org.eclipse.debug.core,
- org.eclipse.ui,
- org.eclipse.ui.ide,
- org.eclipse.jdt.core,
- org.eclipse.jdt.launching,
- org.eclipse.wst.xsl.debug
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.expressions;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.filesystem;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.core.resources;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.variables;bundle-version="[3.2.0,4.0.0)",
+ org.eclipse.debug.core;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui.ide;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.jdt.core;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.jdt.launching;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.wst.xsl.debug;bundle-version="[0.5.0,1.0.0)"
 Eclipse-LazyStart: true
 Bundle-RequiredExecutionEnvironment: J2SE-1.5
 Bundle-ClassPath: .
diff --git a/bundles/org.eclipse.wst.xsl.ui/META-INF/MANIFEST.MF b/bundles/org.eclipse.wst.xsl.ui/META-INF/MANIFEST.MF
index 6851fbe..a2b7f99 100644
--- a/bundles/org.eclipse.wst.xsl.ui/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.wst.xsl.ui/META-INF/MANIFEST.MF
@@ -5,24 +5,23 @@
 Bundle-Version: 0.5.0.qualifier
 Bundle-Activator: org.eclipse.wst.xsl.ui.internal.XSLTUIPlugin
 Bundle-Localization: plugin
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.ui.editors,
- org.eclipse.wst.xml.core,
- org.eclipse.ui.console,
- org.eclipse.debug.ui,
- org.eclipse.search,
- org.eclipse.ui.navigator.resources,
- org.eclipse.wst.xml.xpath.ui,
- org.eclipse.wst.sse.ui,
- org.apache.xalan;bundle-version="2.7.0",
- org.eclipse.jface.text,
- org.eclipse.wst.xml.ui,
- org.eclipse.wst.sse.core,
- org.eclipse.wst.xsl.core,
- org.eclipse.xsd;bundle-version="2.4.0",
- org.eclipse.ui.workbench.texteditor,
- org.eclipse.wst.validation;bundle-version="1.1.103",
- org.eclipse.ui.ide;bundle-version="3.4.0"
+Require-Bundle: org.eclipse.ui;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui.editors;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.wst.xml.core;bundle-version="[1.1.300,2.0.0)",
+ org.eclipse.ui.console;bundle-version="[3.2.0,4.0.0)",
+ org.eclipse.debug.ui;bundle-version="[3.3.100,4.0.0)",
+ org.eclipse.search;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui.navigator.resources;bundle-version="[3.3.0,4.0.0)",
+ org.eclipse.wst.xml.xpath.ui;bundle-version="[0.5.0,1.0.0)",
+ org.eclipse.wst.sse.ui;bundle-version="[1.1.0,2.0.0)",
+ org.apache.xalan;bundle-version="[2.7.0,2.8.0)",
+ org.eclipse.jface.text;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.wst.xml.ui;bundle-version="[1.0.400,2.0.0)",
+ org.eclipse.wst.sse.core;bundle-version="[1.1.300,2.0.0)",
+ org.eclipse.wst.xsl.core;bundle-version="[0.5.0,1.0.0)",
+ org.eclipse.ui.workbench.texteditor;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.wst.validation;bundle-version="[1.1.103,2.0.0)",
+ org.eclipse.ui.ide;bundle-version="[3.4.0,4.0.0)"
 Bundle-Vendor: %providerName
 Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/bundles/org.eclipse.wst.xsl.xalan/META-INF/MANIFEST.MF b/bundles/org.eclipse.wst.xsl.xalan/META-INF/MANIFEST.MF
index 0f6de1a..383e74b 100644
--- a/bundles/org.eclipse.wst.xsl.xalan/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.wst.xsl.xalan/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@
 Bundle-Localization: plugin
 Bundle-Vendor: %Bundle-Vendor.0
 Export-Package: org.eclipse.wst.xsl.xalan.debugger
-Require-Bundle: org.apache.xalan;bundle-version="2.7.0",
+Require-Bundle: org.apache.xalan;bundle-version="[2.7.0,2.8.0)",
  org.apache.commons.logging;bundle-version="1.1.1",
- org.eclipse.wst.xsl.debug;bundle-version="0.5.0"
+ org.eclipse.wst.xsl.debug;bundle-version="[0.5.0,1.0.0)"
 Bundle-ClassPath: xalan-debugger.jar