update to JDT/Core v_B61
diff --git a/org.eclipse.jdt.core/batch/org/eclipse/jdt/internal/compiler/batch/messages.properties b/org.eclipse.jdt.core/batch/org/eclipse/jdt/internal/compiler/batch/messages.properties
index 6bf93e7..e13ced0 100644
--- a/org.eclipse.jdt.core/batch/org/eclipse/jdt/internal/compiler/batch/messages.properties
+++ b/org.eclipse.jdt.core/batch/org/eclipse/jdt/internal/compiler/batch/messages.properties
@@ -1,7 +1,7 @@
 #Format: compiler.name = word1 word2 word3
 compiler.name = Eclipse Compiler for Java(TM)
 #Format: compiler.version = 0.XXX[, other words (don't forget the comma if adding other words)]
-compiler.version = 0.B60, 3.7.0 RC2
+compiler.version = 0.B61, 3.7.0
 compiler.copyright = Copyright IBM Corp 2000, 2010. All rights reserved.
 
 ###{ObjectTeams:
diff --git a/org.eclipse.jdt.core/buildnotes_jdt-core.html b/org.eclipse.jdt.core/buildnotes_jdt-core.html
index 6bc4a15..a90e2ac 100644
--- a/org.eclipse.jdt.core/buildnotes_jdt-core.html
+++ b/org.eclipse.jdt.core/buildnotes_jdt-core.html
@@ -41,6 +41,19 @@
 	</td>
   </tr>
 </table>
+<a name="v_B61"></a>
+<hr><h1>
+Eclipse Platform Build Notes<br>
+Java development tools core</h1>
+Eclipse SDK 3.7 - May 25, 2011 - 3.7.0
+<br>Project org.eclipse.jdt.core v_B61
+(<a href="http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.jdt.core/?only_with_tag=v_B61">cvs</a>).
+<h2>What's new in this drop</h2>
+<ul>
+<li>Update batch compiler version to refer to 3.7.0 and not 3.7.0 RC2</li>
+</ul>
+<h3>Problem Reports Fixed</h3>
+
 <a name="v_B60"></a>
 <hr><h1>
 Eclipse Platform Build Notes<br>
diff --git a/org.eclipse.jdt.core/model/org/eclipse/jdt/core/JavaCore.java b/org.eclipse.jdt.core/model/org/eclipse/jdt/core/JavaCore.java
index b69a6c7..00c6df3 100644
--- a/org.eclipse.jdt.core/model/org/eclipse/jdt/core/JavaCore.java
+++ b/org.eclipse.jdt.core/model/org/eclipse/jdt/core/JavaCore.java
@@ -2233,7 +2233,8 @@
 	 */
 	public static final String VERSION_1_6 = "1.6"; //$NON-NLS-1$
 	/**
-	 * Configurable option value: {@value}.
+	 * Configurable option value: {@value}.<br>
+	 * <i>Note: The compiler currently does not support 1.7 compliance level</i>
 	 * @since 3.3
 	 * @category OptionValue
 	 */