Build against S-4.15M1-202001100905

+ update of Eclipse test versions
diff --git a/features/org.eclipse.objectteams.otdt.core.patch/feature.xml b/features/org.eclipse.objectteams.otdt.core.patch/feature.xml
index 9571a42..9874672 100644
--- a/features/org.eclipse.objectteams.otdt.core.patch/feature.xml
+++ b/features/org.eclipse.objectteams.otdt.core.patch/feature.xml
@@ -59,7 +59,7 @@
    </url>
 
    <requires>
-      <import feature="org.eclipse.jdt" version="3.18.200.v20191210-0610" patch="true"/>
+      <import feature="org.eclipse.jdt" version="3.18.300.v20200110-0905" patch="true"/>
    </requires>
 
    <plugin
diff --git a/releng/build-scripts/build/otdt_prerequisites-hipp.sh b/releng/build-scripts/build/otdt_prerequisites-hipp.sh
index a0a3fb6..d681dcf 100644
--- a/releng/build-scripts/build/otdt_prerequisites-hipp.sh
+++ b/releng/build-scripts/build/otdt_prerequisites-hipp.sh
@@ -56,11 +56,11 @@
 
 # VERSIONS:
 # Eclipse SDK build identifier (used for substitution in otdt.map.in etc.):
-SDK_QUALIFIER=${SDK_QUALIFIER:="I20191210-0610"}
+SDK_QUALIFIER=${SDK_QUALIFIER:="I20200110-0905"}
 
 # used only locally (components of the ECLIPSE_SDK_TGZ path):
-EVERSION=${EVERSION:="4.14RC2a"}
-DROP=${DROPS4}/${DROP:="S-4.14RC2a-201912100610"}
+EVERSION=${EVERSION:="4.15M1"}
+DROP=${DROPS4}/${DROP:="S-4.15M1-202001100905"}
 
 # EXPORT: archive file of the base eclipse SDK build:
 ECLIPSE_SDK_TGZ=${DROP}/eclipse-SDK-${EVERSION}-linux-gtk-${ARCH}.tar.gz
diff --git a/releng/build-scripts/build/run.properties b/releng/build-scripts/build/run.properties
index 077e677..b9289e3 100644
--- a/releng/build-scripts/build/run.properties
+++ b/releng/build-scripts/build/run.properties
@@ -19,12 +19,12 @@
 
 # ------------- insert current versions here ---------------
 # Details of the Eclipse SDK built upon:
-run.eclipseScriptDir=plugins/org.eclipse.pde.build_3.10.600.v20191011-0535/scripts
-org.eclipse.equinox.launcher_jar=org.eclipse.equinox.launcher_1.5.600.v20191014-2022.jar
+run.eclipseScriptDir=plugins/org.eclipse.pde.build_3.10.700.v20191228-1214/scripts
+org.eclipse.equinox.launcher_jar=org.eclipse.equinox.launcher_1.5.700.v20200107-1357.jar
 
 # for patching our patch feature to match this version with any suffix:
-jdt.feature.version=3.18.200.v20191210-0610
-jdt.feature.version.next=3.18.200.v20191210-0611
+jdt.feature.version=3.18.300.v20200110-0905
+jdt.feature.version.next=3.18.300.v20200110-0906
 
 # jdt.core fragments for extracting pre-built classes and properties:
 jdt.compiler.apt=org.eclipse.jdt.compiler.apt_1.3.800.v20190919-0948.jar
diff --git a/releng/build-scripts/build/test.properties.in b/releng/build-scripts/build/test.properties.in
index dc68747..768c8a0 100644
--- a/releng/build-scripts/build/test.properties.in
+++ b/releng/build-scripts/build/test.properties.in
@@ -1,11 +1,11 @@
 # versions of test plugins:
 
 # ---- versions of test bundles compiled from an existing GIT tag: ----
-#org.eclipse.jdt.core.tests.builder=3.10.700.@SDK_QUALIFIER@
-org.eclipse.jdt.debug.tests=3.11.700.@SDK_QUALIFIER@
-org.eclipse.jdt.ui.tests=3.13.800.@SDK_QUALIFIER@
-org.eclipse.jdt.ui.tests.refactoring=3.13.700.@SDK_QUALIFIER@
-org.eclipse.test.performance=3.14.0.@SDK_QUALIFIER@
+#org.eclipse.jdt.core.tests.builder=3.10.750.@SDK_QUALIFIER@
+org.eclipse.jdt.debug.tests=3.11.800.@SDK_QUALIFIER@
+org.eclipse.jdt.ui.tests=3.13.900.@SDK_QUALIFIER@
+org.eclipse.jdt.ui.tests.refactoring=3.13.800.@SDK_QUALIFIER@
+org.eclipse.test.performance=3.14.100.@SDK_QUALIFIER@
 # ----
 
 # versions for test bundles not listed here are taken from build-root/src/finalPluginsVersions.properties