Releng: build against I20210217-0600 with asm 9.1.0 from latest orbit
diff --git a/features/org.eclipse.objectteams.otdt.core.patch/feature.xml b/features/org.eclipse.objectteams.otdt.core.patch/feature.xml
index 0c994b4..752e79e 100644
--- a/features/org.eclipse.objectteams.otdt.core.patch/feature.xml
+++ b/features/org.eclipse.objectteams.otdt.core.patch/feature.xml
@@ -59,7 +59,7 @@
    </url>
 
    <requires>
-      <import feature="org.eclipse.jdt" version="3.18.600.v20201202-1800" patch="true"/>
+      <import feature="org.eclipse.jdt" version="3.18.700.v20210217-0600" patch="true"/>
    </requires>
 
    <plugin
diff --git a/releng/build-scripts/build/otdt_prerequisites-hipp.sh b/releng/build-scripts/build/otdt_prerequisites-hipp.sh
index 11d439e..6633c5d 100644
--- a/releng/build-scripts/build/otdt_prerequisites-hipp.sh
+++ b/releng/build-scripts/build/otdt_prerequisites-hipp.sh
@@ -58,11 +58,11 @@
 
 # VERSIONS:
 # Eclipse SDK build identifier (used for substitution in otdt.map.in etc.):
-SDK_QUALIFIER=${SDK_QUALIFIER:="I20201202-1800"}
+SDK_QUALIFIER=${SDK_QUALIFIER:="I20210217-0600"}
 
 # used only locally (components of the ECLIPSE_SDK_TGZ path):
-EVERSION=${EVERSION:="4.18"}
-DROP=${DROPS4}/${DROP:="R-4.18-202012021800"}
+EVERSION=${EVERSION:="I20210217-0600"}
+DROP=${DROPS4}/${DROP:="I20210217-0600"}
 
 # EXPORT: archive file of the base eclipse SDK build:
 ECLIPSE_SDK_TGZ=${DROP}/eclipse-SDK-${EVERSION}-linux-gtk-${ARCH}.tar.gz
diff --git a/releng/build-scripts/build/run.properties b/releng/build-scripts/build/run.properties
index 6350067..76a43e7 100644
--- a/releng/build-scripts/build/run.properties
+++ b/releng/build-scripts/build/run.properties
@@ -21,12 +21,12 @@
 
 # ------------- insert current versions here ---------------
 # Details of the Eclipse SDK built upon:
-run.eclipseScriptDir=plugins/org.eclipse.pde.build_3.10.900.v20201111-1557/scripts
-org.eclipse.equinox.launcher_jar=org.eclipse.equinox.launcher_1.6.0.v20200915-1508.jar
+run.eclipseScriptDir=plugins/org.eclipse.pde.build_3.10.1000.v20210130-0813/scripts
+org.eclipse.equinox.launcher_jar=org.eclipse.equinox.launcher_1.6.100.v20201223-0822.jar
 
 # for patching our patch feature to match this version with any suffix:
-jdt.feature.version=3.18.600.v20201202-1800
-jdt.feature.version.next=3.18.600.v20201202-1801
+jdt.feature.version=3.18.700.v20210217-0600
+jdt.feature.version.next=3.18.700.v20210217-0601
 
 # jdt.core fragments for extracting pre-built classes and properties:
 jdt.compiler.apt=org.eclipse.jdt.compiler.apt_1.3.1200.v20200916-0645.jar
diff --git a/releng/map/otdt.map.in b/releng/map/otdt.map.in
index 0eb7cf9..4739bd1 100644
--- a/releng/map/otdt.map.in
+++ b/releng/map/otdt.map.in
@@ -45,17 +45,17 @@
 plugin@org.eclipse.objectteams.otdt.samples=GIT,repo=git://git.eclipse.org/gitroot/objectteams/org.eclipse.objectteams.git,path=plugins/org.eclipse.objectteams.otdt.samples

 

 !** Consume BCEL from Orbit: **!

-plugin@org.apache.bcel,5.2.0=p2IU,id=org.apache.bcel,version=5.2.0.v201005080400,repository=https://download.eclipse.org/tools/orbit/downloads/drops/R20200529191137/repository

+plugin@org.apache.bcel,5.2.0=p2IU,id=org.apache.bcel,version=5.2.0.v201005080400,repository=https://download.eclipse.org/tools/orbit/downloads/drops/I20210216201023/repository

 !** ASM from Orbit: **!

-plugin@org.objectweb.asm,8.0.1=p2IU,id=org.objectweb.asm,version=8.0.1.v20200420-1007,repository=https://download.eclipse.org/tools/orbit/downloads/drops/R20200529191137/repository/

-plugin@org.objectweb.asm.tree,8.0.1=p2IU,id=org.objectweb.asm.tree,version=8.0.1.v20200420-1007,repository=https://download.eclipse.org/tools/orbit/downloads/drops/R20200529191137/repository/

-plugin@org.objectweb.asm.commons,8.0.1=p2IU,id=org.objectweb.asm.commons,version=8.0.1.v20200420-1007,repository=https://download.eclipse.org/tools/orbit/downloads/drops/R20200529191137/repository/

-plugin@org.objectweb.asm.util,8.0.1=p2IU,id=org.objectweb.asm.util,version=8.0.1.v20200420-1007,repository=https://download.eclipse.org/tools/orbit/downloads/drops/R20200529191137/repository/

-plugin@org.objectweb.asm.analysis,8.0.1=p2IU,id=org.objectweb.asm.analysis,version=8.0.1.v20200420-1007,repository=https://download.eclipse.org/tools/orbit/downloads/drops/R20200529191137/repository/

+plugin@org.objectweb.asm,9.1.0=p2IU,id=org.objectweb.asm,version=9.1.0.v20210209-1849,repository=https://download.eclipse.org/tools/orbit/downloads/drops/I20210216201023/repository/

+plugin@org.objectweb.asm.tree,9.1.0=p2IU,id=org.objectweb.asm.tree,version=9.1.0.v20210209-1849,repository=https://download.eclipse.org/tools/orbit/downloads/drops/I20210216201023/repository/

+plugin@org.objectweb.asm.commons,9.1.0=p2IU,id=org.objectweb.asm.commons,version=9.1.0.v20210209-1849,repository=https://download.eclipse.org/tools/orbit/downloads/drops/I20210216201023/repository/

+plugin@org.objectweb.asm.util,9.1.0=p2IU,id=org.objectweb.asm.util,version=9.1.0.v20210209-1849,repository=https://download.eclipse.org/tools/orbit/downloads/drops/I20210216201023/repository/

+plugin@org.objectweb.asm.analysis,9.1.0=p2IU,id=org.objectweb.asm.analysis,version=9.1.0.v20210209-1849,repository=https://download.eclipse.org/tools/orbit/downloads/drops/I20210216201023/repository/

 

-plugin@org.mockito,1.9.5=p2IU,id=org.mockito,version=1.9.5.v201605172210,repository=https://download.eclipse.org/tools/orbit/downloads/drops/R20200529191137/repository/

-plugin@org.hamcrest.core,1.3.0=p2IU,id=org.hamcrest.core,version=1.3.0.v20180420-1519,repository=https://download.eclipse.org/tools/orbit/downloads/drops/R20200529191137/repository/

-plugin@org.hamcrest.library,1.3.0=p2IU,id=org.hamcrest.library,version=1.3.0.v20180524-2246,repository=https://download.eclipse.org/tools/orbit/downloads/drops/R20200529191137/repository/

+plugin@org.mockito,1.9.5=p2IU,id=org.mockito,version=1.9.5.v201605172210,repository=https://download.eclipse.org/tools/orbit/downloads/drops/I20210216201023/repository/

+plugin@org.hamcrest.core,1.3.0=p2IU,id=org.hamcrest.core,version=1.3.0.v20180420-1519,repository=https://download.eclipse.org/tools/orbit/downloads/drops/I20210216201023/repository/

+plugin@org.hamcrest.library,1.3.0=p2IU,id=org.hamcrest.library,version=1.3.0.v20180524-2246,repository=https://download.eclipse.org/tools/orbit/downloads/drops/I20210216201023/repository/

 

 !========== JDT/UI: ==========!

 plugin@org.eclipse.jdt.ui=GIT,tag=@SDK_QUALIFIER@,repo=git://git.eclipse.org/gitroot/jdt/eclipse.jdt.ui.git,path=org.eclipse.jdt.ui