Missing dependency ranges.
diff --git a/sourceediting/plugins/org.eclipse.wst.xml.vex.core/META-INF/MANIFEST.MF b/sourceediting/plugins/org.eclipse.wst.xml.vex.core/META-INF/MANIFEST.MF
index d36693c..49c8b88 100644
--- a/sourceediting/plugins/org.eclipse.wst.xml.vex.core/META-INF/MANIFEST.MF
+++ b/sourceediting/plugins/org.eclipse.wst.xml.vex.core/META-INF/MANIFEST.MF
@@ -4,8 +4,8 @@
 Bundle-Version: 0.5.0.qualifier
 Bundle-Vendor: Eclipse
 Bundle-SymbolicName: org.eclipse.wst.xml.vex.core;singleton:=true
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.ui,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui;bundle-version="[3.4.0,4.0.0)",
  org.w3c.css.sac;bundle-version="[1.3.0,2.0.0)",
  org.apache.xerces;bundle-version="[2.9.0,3.0.0)",
  org.eclipse.wst.sse.core;bundle-version="[1.1.400,2.0.0)",
diff --git a/sourceediting/plugins/org.eclipse.wst.xml.vex.ui/META-INF/MANIFEST.MF b/sourceediting/plugins/org.eclipse.wst.xml.vex.ui/META-INF/MANIFEST.MF
index 1f5bdc2..19f2369 100644
--- a/sourceediting/plugins/org.eclipse.wst.xml.vex.ui/META-INF/MANIFEST.MF
+++ b/sourceediting/plugins/org.eclipse.wst.xml.vex.ui/META-INF/MANIFEST.MF
@@ -5,15 +5,14 @@
 Bundle-Activator: org.eclipse.wst.xml.vex.ui.internal.VexPlugin
 Bundle-Vendor: %Bundle-Vendor.0
 Bundle-SymbolicName: org.eclipse.wst.xml.vex.ui;singleton:=true
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.ui,
- org.eclipse.core.expressions,
- org.eclipse.ui.views,
- org.eclipse.core.resources,
- org.eclipse.ui.ide,
- org.eclipse.ui.editors,
- org.junit,
- org.eclipse.wst.xml.vex.core;bundle-version="0.5.0",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.expressions;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui.views;bundle-version="[3.3.0,4.0.0)",
+ org.eclipse.core.resources;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui.ide;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui.editors;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.wst.xml.vex.core;bundle-version="[0.5.0,1.0.0)",
  org.w3c.css.sac;bundle-version="1.3.0",
  org.eclipse.jface.text;bundle-version="[3.4.0,4.0.0)",
  org.eclipse.wst.sse.core;bundle-version="[1.1.400,2.0.0)",