Change version to 5.1 for Luna
diff --git a/core/features/org.eclipse.dltk.core-feature/feature.xml b/core/features/org.eclipse.dltk.core-feature/feature.xml
index 87610b9..c7a19fd 100644
--- a/core/features/org.eclipse.dltk.core-feature/feature.xml
+++ b/core/features/org.eclipse.dltk.core-feature/feature.xml
@@ -2,7 +2,7 @@
 <feature
       id="org.eclipse.dltk.core"
       label="%featureName"
-      version="5.0.0.qualifier"
+      version="5.1.0.qualifier"
       provider-name="%providerName"
       plugin="org.eclipse.dltk"
       image="eclipse_update_120.jpg">
diff --git a/core/features/org.eclipse.dltk.core-feature/pom.xml b/core/features/org.eclipse.dltk.core-feature/pom.xml
index ad7ac58..4756a09 100644
--- a/core/features/org.eclipse.dltk.core-feature/pom.xml
+++ b/core/features/org.eclipse.dltk.core-feature/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.features</groupId>
   <artifactId>org.eclipse.dltk.core</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/core/features/org.eclipse.dltk.core.index-feature/feature.xml b/core/features/org.eclipse.dltk.core.index-feature/feature.xml
index aaabe4a..0d987dd 100644
--- a/core/features/org.eclipse.dltk.core.index-feature/feature.xml
+++ b/core/features/org.eclipse.dltk.core.index-feature/feature.xml
@@ -2,7 +2,7 @@
 <feature
       id="org.eclipse.dltk.core.index"
       label="%featureName"
-      version="5.0.0.qualifier"
+      version="5.1.0.qualifier"
       provider-name="%providerName"
       plugin="org.eclipse.dltk.core.index"
       image="eclipse_update_120.jpg">
diff --git a/core/features/org.eclipse.dltk.core.index-feature/pom.xml b/core/features/org.eclipse.dltk.core.index-feature/pom.xml
index d281b88..eccbbf2 100644
--- a/core/features/org.eclipse.dltk.core.index-feature/pom.xml
+++ b/core/features/org.eclipse.dltk.core.index-feature/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.features</groupId>
   <artifactId>org.eclipse.dltk.core.index</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/core/features/org.eclipse.dltk.core.index.sdk/feature.xml b/core/features/org.eclipse.dltk.core.index.sdk/feature.xml
index 97cf0aa..2cff56c 100644
--- a/core/features/org.eclipse.dltk.core.index.sdk/feature.xml
+++ b/core/features/org.eclipse.dltk.core.index.sdk/feature.xml
@@ -2,7 +2,7 @@
 <feature
       id="org.eclipse.dltk.core.index.sdk"
       label="%featureName"
-      version="5.0.0.qualifier"
+      version="5.1.0.qualifier"
       provider-name="%providerName"
       image="eclipse_update_120.jpg">
 
diff --git a/core/features/org.eclipse.dltk.core.index.sdk/pom.xml b/core/features/org.eclipse.dltk.core.index.sdk/pom.xml
index f6c1403..67a2a7d 100644
--- a/core/features/org.eclipse.dltk.core.index.sdk/pom.xml
+++ b/core/features/org.eclipse.dltk.core.index.sdk/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.core.index.sdk</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/core/features/org.eclipse.dltk.core.sdk/feature.xml b/core/features/org.eclipse.dltk.core.sdk/feature.xml
index 7cc5a68..cc31121 100644
--- a/core/features/org.eclipse.dltk.core.sdk/feature.xml
+++ b/core/features/org.eclipse.dltk.core.sdk/feature.xml
@@ -2,7 +2,7 @@
 <feature
       id="org.eclipse.dltk.core.sdk"
       label="%featureName"
-      version="5.0.0.qualifier"
+      version="5.1.0.qualifier"
       provider-name="%providerName"
       image="eclipse_update_120.jpg">
 
diff --git a/core/features/org.eclipse.dltk.core.sdk/pom.xml b/core/features/org.eclipse.dltk.core.sdk/pom.xml
index 0a89f5f..e991c3a 100644
--- a/core/features/org.eclipse.dltk.core.sdk/pom.xml
+++ b/core/features/org.eclipse.dltk.core.sdk/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.core.sdk</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/core/features/org.eclipse.dltk.core.tests/feature.xml b/core/features/org.eclipse.dltk.core.tests/feature.xml
index 5721f52..a652fdd 100644
--- a/core/features/org.eclipse.dltk.core.tests/feature.xml
+++ b/core/features/org.eclipse.dltk.core.tests/feature.xml
@@ -2,7 +2,7 @@
 <feature
       id="org.eclipse.dltk.core.tests"
       label="%featureName"
-      version="5.0.0.qualifier"
+      version="5.1.0.qualifier"
       provider-name="%featureProvider">
 
    <description>
diff --git a/core/features/org.eclipse.dltk.core.tests/pom.xml b/core/features/org.eclipse.dltk.core.tests/pom.xml
index 85d9445..8792d26 100644
--- a/core/features/org.eclipse.dltk.core.tests/pom.xml
+++ b/core/features/org.eclipse.dltk.core.tests/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.features</groupId>
   <artifactId>org.eclipse.dltk.core.tests</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.annotations/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.annotations/META-INF/MANIFEST.MF
index 8e3426e..82ffe68 100644
--- a/core/plugins/org.eclipse.dltk.annotations/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.annotations/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.annotations
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Export-Package: org.eclipse.dltk.annotations
 Bundle-Vendor: %pluginProvider
diff --git a/core/plugins/org.eclipse.dltk.annotations/pom.xml b/core/plugins/org.eclipse.dltk.annotations/pom.xml
index 6f30f16..1587f32 100644
--- a/core/plugins/org.eclipse.dltk.annotations/pom.xml
+++ b/core/plugins/org.eclipse.dltk.annotations/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.annotations</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.console.ui/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.console.ui/META-INF/MANIFEST.MF
index 7d96c36..afeb9b0 100644
--- a/core/plugins/org.eclipse.dltk.console.ui/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.console.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.console.ui;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.console.ui.ScriptConsoleUIPlugin
 Bundle-Vendor: %pluginProvider
 Bundle-Localization: plugin
diff --git a/core/plugins/org.eclipse.dltk.console.ui/pom.xml b/core/plugins/org.eclipse.dltk.console.ui/pom.xml
index 15ef21d..36eacf6 100644
--- a/core/plugins/org.eclipse.dltk.console.ui/pom.xml
+++ b/core/plugins/org.eclipse.dltk.console.ui/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.console.ui</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.console/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.console/META-INF/MANIFEST.MF
index 2feb059..daa1d09 100644
--- a/core/plugins/org.eclipse.dltk.console/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.console/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.console;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.console.ScriptConsolePlugin
 Bundle-Vendor: %pluginProvider
 Bundle-Localization: plugin
diff --git a/core/plugins/org.eclipse.dltk.console/pom.xml b/core/plugins/org.eclipse.dltk.console/pom.xml
index 3b6e023..476dad0 100644
--- a/core/plugins/org.eclipse.dltk.console/pom.xml
+++ b/core/plugins/org.eclipse.dltk.console/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.console</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.core.doc.isv/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.core.doc.isv/META-INF/MANIFEST.MF
index 910398b..0bdff87 100644
--- a/core/plugins/org.eclipse.dltk.core.doc.isv/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.core.doc.isv/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.core.doc.isv;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Localization: plugin
 Require-Bundle: org.eclipse.ui,
  org.eclipse.core.runtime
diff --git a/core/plugins/org.eclipse.dltk.core.doc.isv/pom.xml b/core/plugins/org.eclipse.dltk.core.doc.isv/pom.xml
index 88465b4..887aaf5 100644
--- a/core/plugins/org.eclipse.dltk.core.doc.isv/pom.xml
+++ b/core/plugins/org.eclipse.dltk.core.doc.isv/pom.xml
@@ -11,7 +11,7 @@
 	</parent>
 	<groupId>org.eclipse.dltk.core</groupId>
 	<artifactId>org.eclipse.dltk.core.doc.isv</artifactId>
-	<version>5.0.0-SNAPSHOT</version>
+	<version>5.1.0-SNAPSHOT</version>
 	<packaging>eclipse-plugin</packaging>
 	<build>
 		<plugins>
diff --git a/core/plugins/org.eclipse.dltk.core.index.sql.h2/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.core.index.sql.h2/META-INF/MANIFEST.MF
index 12336c0..1dbe928 100644
--- a/core/plugins/org.eclipse.dltk.core.index.sql.h2/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.core.index.sql.h2/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: DLTK H2-based Indexer
 Bundle-SymbolicName: org.eclipse.dltk.core.index.sql.h2;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.core.index.sql.h2.H2Index
 Bundle-Vendor: Eclipse.org
 Require-Bundle: org.eclipse.core.runtime,
diff --git a/core/plugins/org.eclipse.dltk.core.index.sql.h2/pom.xml b/core/plugins/org.eclipse.dltk.core.index.sql.h2/pom.xml
index ee0da1a..77ae65e 100644
--- a/core/plugins/org.eclipse.dltk.core.index.sql.h2/pom.xml
+++ b/core/plugins/org.eclipse.dltk.core.index.sql.h2/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.core.index.sql.h2</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.core.index.sql/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.core.index.sql/META-INF/MANIFEST.MF
index 6f75ed3..a8a494a 100644
--- a/core/plugins/org.eclipse.dltk.core.index.sql/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.core.index.sql/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: DLTK Abstract SQL-based Indexer
 Bundle-SymbolicName: org.eclipse.dltk.core.index.sql;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.core.index.sql.SqlIndex
 Bundle-Vendor: Eclipse.org
 Require-Bundle: org.eclipse.core.runtime,
diff --git a/core/plugins/org.eclipse.dltk.core.index.sql/pom.xml b/core/plugins/org.eclipse.dltk.core.index.sql/pom.xml
index f510513..fd78de7 100644
--- a/core/plugins/org.eclipse.dltk.core.index.sql/pom.xml
+++ b/core/plugins/org.eclipse.dltk.core.index.sql/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.core.index.sql</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.core.index/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.core.index/META-INF/MANIFEST.MF
index 9c9a99b..71ae41f 100644
--- a/core/plugins/org.eclipse.dltk.core.index/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.core.index/META-INF/MANIFEST.MF
@@ -2,6 +2,6 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.core.index
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Vendor: %providerName
 Bundle-Localization: plugin
diff --git a/core/plugins/org.eclipse.dltk.core.index/pom.xml b/core/plugins/org.eclipse.dltk.core.index/pom.xml
index 05288e2..c52f937 100644
--- a/core/plugins/org.eclipse.dltk.core.index/pom.xml
+++ b/core/plugins/org.eclipse.dltk.core.index/pom.xml
@@ -11,7 +11,7 @@
 	</parent>
 	<groupId>org.eclipse.dltk.core</groupId>
 	<artifactId>org.eclipse.dltk.core.index</artifactId>
-	<version>5.0.0-SNAPSHOT</version>
+	<version>5.1.0-SNAPSHOT</version>
 	<packaging>eclipse-plugin</packaging>
 	<build>
 		<plugins>
diff --git a/core/plugins/org.eclipse.dltk.core.manipulation/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.core.manipulation/META-INF/MANIFEST.MF
index d147e30..fbe1479 100644
--- a/core/plugins/org.eclipse.dltk.core.manipulation/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.core.manipulation/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@
 Bundle-Localization: plugin
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.core.manipulation;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.internal.core.manipulation.ScriptManipulationPlugin
 Bundle-Vendor: %pluginProvider
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/core/plugins/org.eclipse.dltk.core.manipulation/pom.xml b/core/plugins/org.eclipse.dltk.core.manipulation/pom.xml
index 49f2458..6f0c0cb 100644
--- a/core/plugins/org.eclipse.dltk.core.manipulation/pom.xml
+++ b/core/plugins/org.eclipse.dltk.core.manipulation/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.core.manipulation</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.core.tools.ui/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.core.tools.ui/META-INF/MANIFEST.MF
index 41600bb..2f0485a 100644
--- a/core/plugins/org.eclipse.dltk.core.tools.ui/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.core.tools.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.core.tools.ui;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.core.tools.ui.DLTKToolsUI
 Bundle-Vendor: %providerName
 Require-Bundle: org.eclipse.ui,
diff --git a/core/plugins/org.eclipse.dltk.core.tools.ui/pom.xml b/core/plugins/org.eclipse.dltk.core.tools.ui/pom.xml
index b172023..0672ede 100644
--- a/core/plugins/org.eclipse.dltk.core.tools.ui/pom.xml
+++ b/core/plugins/org.eclipse.dltk.core.tools.ui/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.core.tools.ui</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.core/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.core/META-INF/MANIFEST.MF
index 5908cb9..f50d0a6 100644
--- a/core/plugins/org.eclipse.dltk.core/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.core/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.core;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.core.DLTKCore
 Bundle-Vendor: %pluginProvider
 Bundle-Localization: plugin
diff --git a/core/plugins/org.eclipse.dltk.core/pom.xml b/core/plugins/org.eclipse.dltk.core/pom.xml
index d9b1cc9..80c4f2a 100644
--- a/core/plugins/org.eclipse.dltk.core/pom.xml
+++ b/core/plugins/org.eclipse.dltk.core/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.core</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.debug.ui/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.debug.ui/META-INF/MANIFEST.MF
index 55a821f..4faea6c 100644
--- a/core/plugins/org.eclipse.dltk.debug.ui/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.debug.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.debug.ui;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.debug.ui.DLTKDebugUIPlugin
 Bundle-Vendor: %pluginProvider
 Bundle-Localization: plugin
diff --git a/core/plugins/org.eclipse.dltk.debug.ui/pom.xml b/core/plugins/org.eclipse.dltk.debug.ui/pom.xml
index 61cf56e..e4407b9 100644
--- a/core/plugins/org.eclipse.dltk.debug.ui/pom.xml
+++ b/core/plugins/org.eclipse.dltk.debug.ui/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.debug.ui</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.debug/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.debug/META-INF/MANIFEST.MF
index 2660c71..f5b674d 100644
--- a/core/plugins/org.eclipse.dltk.debug/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.debug/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.debug; singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.debug.core.DLTKDebugPlugin
 Bundle-Vendor: %pluginProvider
 Bundle-Localization: plugin
diff --git a/core/plugins/org.eclipse.dltk.debug/pom.xml b/core/plugins/org.eclipse.dltk.debug/pom.xml
index 8bab9e5..48eb505 100644
--- a/core/plugins/org.eclipse.dltk.debug/pom.xml
+++ b/core/plugins/org.eclipse.dltk.debug/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.debug</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.formatter/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.formatter/META-INF/MANIFEST.MF
index ccaaf46..d4c8068 100644
--- a/core/plugins/org.eclipse.dltk.formatter/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.formatter/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.formatter;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Bundle-Vendor: %pluginProvider
 Bundle-Localization: plugin
diff --git a/core/plugins/org.eclipse.dltk.formatter/pom.xml b/core/plugins/org.eclipse.dltk.formatter/pom.xml
index af8088f..9164771 100644
--- a/core/plugins/org.eclipse.dltk.formatter/pom.xml
+++ b/core/plugins/org.eclipse.dltk.formatter/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.formatter</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.launching/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.launching/META-INF/MANIFEST.MF
index cbf82db..07fb780 100644
--- a/core/plugins/org.eclipse.dltk.launching/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.launching/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.launching;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.internal.launching.DLTKLaunchingPlugin
 Bundle-Vendor: %pluginProvider
 Bundle-Localization: plugin
diff --git a/core/plugins/org.eclipse.dltk.launching/pom.xml b/core/plugins/org.eclipse.dltk.launching/pom.xml
index 4b3b7fc..ce62be5 100644
--- a/core/plugins/org.eclipse.dltk.launching/pom.xml
+++ b/core/plugins/org.eclipse.dltk.launching/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.launching</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.logconsole.ui/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.logconsole.ui/META-INF/MANIFEST.MF
index 61d5e8c..90575f7 100644
--- a/core/plugins/org.eclipse.dltk.logconsole.ui/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.logconsole.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.logconsole.ui;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Vendor: %pluginProvider
 Bundle-Localization: plugin
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/core/plugins/org.eclipse.dltk.logconsole.ui/pom.xml b/core/plugins/org.eclipse.dltk.logconsole.ui/pom.xml
index 1318bc9..b086d51 100644
--- a/core/plugins/org.eclipse.dltk.logconsole.ui/pom.xml
+++ b/core/plugins/org.eclipse.dltk.logconsole.ui/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.logconsole.ui</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.logconsole/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.logconsole/META-INF/MANIFEST.MF
index 8eb0502..1d80577 100644
--- a/core/plugins/org.eclipse.dltk.logconsole/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.logconsole/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.logconsole;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Bundle-Activator: org.eclipse.dltk.logconsole.LogConsolePlugin
 Bundle-Vendor: %pluginProvider
diff --git a/core/plugins/org.eclipse.dltk.logconsole/pom.xml b/core/plugins/org.eclipse.dltk.logconsole/pom.xml
index 96b6939..6a9f667 100644
--- a/core/plugins/org.eclipse.dltk.logconsole/pom.xml
+++ b/core/plugins/org.eclipse.dltk.logconsole/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.logconsole</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.testing/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.testing/META-INF/MANIFEST.MF
index ff477a8..3d7ebbc 100755
--- a/core/plugins/org.eclipse.dltk.testing/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.testing/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.testing;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.testing.DLTKTestingPlugin
 Bundle-Vendor: %providerName
 Bundle-Localization: plugin
diff --git a/core/plugins/org.eclipse.dltk.testing/pom.xml b/core/plugins/org.eclipse.dltk.testing/pom.xml
index fcd20be..d4a96c3 100644
--- a/core/plugins/org.eclipse.dltk.testing/pom.xml
+++ b/core/plugins/org.eclipse.dltk.testing/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.testing</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.ui/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.ui/META-INF/MANIFEST.MF
index beb177b..6d43b22 100644
--- a/core/plugins/org.eclipse.dltk.ui/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.ui;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.ui.DLTKUIPlugin
 Bundle-Vendor: %pluginProvider
 Bundle-Localization: plugin
diff --git a/core/plugins/org.eclipse.dltk.ui/pom.xml b/core/plugins/org.eclipse.dltk.ui/pom.xml
index 2b4cc99..df47afd 100644
--- a/core/plugins/org.eclipse.dltk.ui/pom.xml
+++ b/core/plugins/org.eclipse.dltk.ui/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.ui</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.validators.core/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.validators.core/META-INF/MANIFEST.MF
index ad96526..052d515 100644
--- a/core/plugins/org.eclipse.dltk.validators.core/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.validators.core/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.validators.core;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.validators.internal.core.ValidatorsCore
 Require-Bundle: org.eclipse.core.runtime,
  org.eclipse.dltk.core;bundle-version="0.0.0",
diff --git a/core/plugins/org.eclipse.dltk.validators.core/pom.xml b/core/plugins/org.eclipse.dltk.validators.core/pom.xml
index 0ab2927..d572964 100644
--- a/core/plugins/org.eclipse.dltk.validators.core/pom.xml
+++ b/core/plugins/org.eclipse.dltk.validators.core/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.validators.core</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.validators.externalchecker/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.validators.externalchecker/META-INF/MANIFEST.MF
index 96b5874..249ffdb 100644
--- a/core/plugins/org.eclipse.dltk.validators.externalchecker/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.validators.externalchecker/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.validators.externalchecker;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.validators.internal.externalchecker.core.ExternalCheckerPlugin
 Bundle-Localization: plugin
 Require-Bundle: org.eclipse.ui,
diff --git a/core/plugins/org.eclipse.dltk.validators.externalchecker/pom.xml b/core/plugins/org.eclipse.dltk.validators.externalchecker/pom.xml
index 8d812ba..8f33e12 100644
--- a/core/plugins/org.eclipse.dltk.validators.externalchecker/pom.xml
+++ b/core/plugins/org.eclipse.dltk.validators.externalchecker/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.validators.externalchecker</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk.validators.ui/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk.validators.ui/META-INF/MANIFEST.MF
index 80be591..88dedb6 100644
--- a/core/plugins/org.eclipse.dltk.validators.ui/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk.validators.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.validators.ui;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.validators.internal.ui.ValidatorsUI
 Require-Bundle: org.eclipse.core.runtime,
  org.eclipse.core.resources,
diff --git a/core/plugins/org.eclipse.dltk.validators.ui/pom.xml b/core/plugins/org.eclipse.dltk.validators.ui/pom.xml
index 494f3eb..5bbfb18 100644
--- a/core/plugins/org.eclipse.dltk.validators.ui/pom.xml
+++ b/core/plugins/org.eclipse.dltk.validators.ui/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.core</groupId>
   <artifactId>org.eclipse.dltk.validators.ui</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/core/plugins/org.eclipse.dltk/META-INF/MANIFEST.MF b/core/plugins/org.eclipse.dltk/META-INF/MANIFEST.MF
index 744c525..d088c5b 100644
--- a/core/plugins/org.eclipse.dltk/META-INF/MANIFEST.MF
+++ b/core/plugins/org.eclipse.dltk/META-INF/MANIFEST.MF
@@ -2,6 +2,6 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Vendor: %providerName
 Bundle-Localization: plugin
diff --git a/core/plugins/org.eclipse.dltk/pom.xml b/core/plugins/org.eclipse.dltk/pom.xml
index b23af1c..c3718fc 100644
--- a/core/plugins/org.eclipse.dltk/pom.xml
+++ b/core/plugins/org.eclipse.dltk/pom.xml
@@ -11,7 +11,7 @@
 	</parent>
 	<groupId>org.eclipse.dltk.core</groupId>
 	<artifactId>org.eclipse.dltk</artifactId>
-	<version>5.0.0-SNAPSHOT</version>
+	<version>5.1.0-SNAPSHOT</version>
 	<packaging>eclipse-plugin</packaging>
 	<build>
 		<plugins>
diff --git a/core/releng/org.eclipse.dltk.core.targetplatform/DLTK-Luna-4.4.target b/core/releng/org.eclipse.dltk.core.targetplatform/DLTK-Luna-4.4.target
new file mode 100644
index 0000000..41eb6c6
--- /dev/null
+++ b/core/releng/org.eclipse.dltk.core.targetplatform/DLTK-Luna-4.4.target
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<?pde version="3.8"?><target name="DLTK-Luna-4.4" sequenceNumber="11">
+<locations>
+<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="false" type="InstallableUnit">
+<unit id="org.h2.source" version="1.3.168.v201212121212"/>
+<unit id="org.h2" version="1.3.168.v201212121212"/>
+<unit id="com.google.guava" version="12.0.0.v201212092141"/>
+<unit id="com.google.guava.source" version="12.0.0.v201212092141"/>
+<unit id="org.antlr.runtime" version="3.0.0.v200803061811"/>
+<unit id="org.antlr.runtime.source" version="3.0.0.v200803061811"/>
+<unit id="org.junit" version="4.11.0.v201303080030"/>
+<unit id="org.junit.source" version="4.11.0.v201303080030"/>
+<unit id="org.hamcrest.core" version="1.3.0.v201303031735"/>
+<unit id="org.hamcrest.core.source" version="1.3.0.v201303031735"/>
+<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20140114142710/repository/"/>
+</location>
+<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="false" type="InstallableUnit">
+<unit id="org.eclipse.emf.sdk.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.sdk.ide" version="0.0.0"/>
+<unit id="org.eclipse.mylyn.context.sdk.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.mylyn.commons.sdk.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.mylyn.sdk_feature.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.rse.feature.group" version="0.0.0"/>
+<repository location="http://download.eclipse.org/releases/luna"/>
+</location>
+</locations>
+</target>
diff --git a/core/releng/org.eclipse.dltk.core.targetplatform/org.eclipse.dltk.core.targetplatform.target b/core/releng/org.eclipse.dltk.core.targetplatform/org.eclipse.dltk.core.targetplatform.target
index 471360e..65f2c90 100644
--- a/core/releng/org.eclipse.dltk.core.targetplatform/org.eclipse.dltk.core.targetplatform.target
+++ b/core/releng/org.eclipse.dltk.core.targetplatform/org.eclipse.dltk.core.targetplatform.target
@@ -6,7 +6,7 @@
 <location includeAllPlatforms="false" includeMode="planner" includeSource="true" type="InstallableUnit">
 <unit id="com.google.guava" version="12.0.0.v201212092141"/>
 <unit id="org.junit" version="4.11.0.v201303080030"/>
-<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20130517111416/repository/"/>
+<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20140114142710/repository/"/>
 </location>
 </locations>
 </target>
diff --git a/core/releng/org.eclipse.dltk.core.targetplatform/pom.xml b/core/releng/org.eclipse.dltk.core.targetplatform/pom.xml
index 50a5b75..9c51f95 100644
--- a/core/releng/org.eclipse.dltk.core.targetplatform/pom.xml
+++ b/core/releng/org.eclipse.dltk.core.targetplatform/pom.xml
@@ -12,7 +12,7 @@
 
 	<groupId>org.eclipse.dltk.core</groupId>
 	<artifactId>org.eclipse.dltk.core.targetplatform</artifactId>
-	<version>5.0.0-SNAPSHOT</version>
+	<version>5.1.0-SNAPSHOT</version>
 	<packaging>eclipse-target-definition</packaging>
 
 </project>
diff --git a/core/tests/org.eclipse.dltk.core.tests/META-INF/MANIFEST.MF b/core/tests/org.eclipse.dltk.core.tests/META-INF/MANIFEST.MF
index 308790c..50666eb 100644
--- a/core/tests/org.eclipse.dltk.core.tests/META-INF/MANIFEST.MF
+++ b/core/tests/org.eclipse.dltk.core.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.core.tests;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.core.tests.model.ModelTestsPlugin
 Bundle-Vendor: %pluginProvider
 Bundle-Localization: plugin
diff --git a/core/tests/org.eclipse.dltk.core.tests/pom.xml b/core/tests/org.eclipse.dltk.core.tests/pom.xml
index a95455d..7700bfe 100644
--- a/core/tests/org.eclipse.dltk.core.tests/pom.xml
+++ b/core/tests/org.eclipse.dltk.core.tests/pom.xml
@@ -11,7 +11,7 @@
 	</parent>
 	<groupId>org.eclipse.dltk.core</groupId>
 	<artifactId>org.eclipse.dltk.core.tests</artifactId>
-	<version>5.0.0-SNAPSHOT</version>
+	<version>5.1.0-SNAPSHOT</version>
 	<packaging>eclipse-test-plugin</packaging>
 	<build>
 		<plugins>
@@ -24,7 +24,7 @@
 						<artifact>
 							<groupId>org.eclipse.dltk.core</groupId>
 							<artifactId>org.eclipse.dltk.core.targetplatform</artifactId>
-							<version>5.0.0-SNAPSHOT</version>
+							<version>5.1.0-SNAPSHOT</version>
 						</artifact>
 					</target>
 				</configuration>
diff --git a/core/tests/org.eclipse.dltk.debug.tests/META-INF/MANIFEST.MF b/core/tests/org.eclipse.dltk.debug.tests/META-INF/MANIFEST.MF
index a30a03b..4d7c4e3 100644
--- a/core/tests/org.eclipse.dltk.debug.tests/META-INF/MANIFEST.MF
+++ b/core/tests/org.eclipse.dltk.debug.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.debug.tests
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.debug.tests.Activator
 Bundle-Vendor: %pluginProvider
 Bundle-Localization: plugin
diff --git a/core/tests/org.eclipse.dltk.debug.tests/pom.xml b/core/tests/org.eclipse.dltk.debug.tests/pom.xml
index 07f419b..2d746c4 100644
--- a/core/tests/org.eclipse.dltk.debug.tests/pom.xml
+++ b/core/tests/org.eclipse.dltk.debug.tests/pom.xml
@@ -10,7 +10,7 @@
 	</parent>
 	<groupId>org.eclipse.dltk.core</groupId>
 	<artifactId>org.eclipse.dltk.debug.tests</artifactId>
-	<version>5.0.0-SNAPSHOT</version>
+	<version>5.1.0-SNAPSHOT</version>
 	<packaging>eclipse-test-plugin</packaging>
 	<build>
 		<plugins>
diff --git a/core/tests/org.eclipse.dltk.debug.ui.tests/META-INF/MANIFEST.MF b/core/tests/org.eclipse.dltk.debug.ui.tests/META-INF/MANIFEST.MF
index ec567d7..51588e3 100644
--- a/core/tests/org.eclipse.dltk.debug.ui.tests/META-INF/MANIFEST.MF
+++ b/core/tests/org.eclipse.dltk.debug.ui.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.debug.ui.tests;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.debug.ui.tests.DLTKDebugUITestsPlugin
 Bundle-Vendor: %pluginProvider
 Bundle-Localization: plugin
diff --git a/core/tests/org.eclipse.dltk.debug.ui.tests/pom.xml b/core/tests/org.eclipse.dltk.debug.ui.tests/pom.xml
index d269fbe..c857dcc 100644
--- a/core/tests/org.eclipse.dltk.debug.ui.tests/pom.xml
+++ b/core/tests/org.eclipse.dltk.debug.ui.tests/pom.xml
@@ -11,7 +11,7 @@
 	</parent>
 	<groupId>org.eclipse.dltk.core</groupId>
 	<artifactId>org.eclipse.dltk.debug.ui.tests</artifactId>
-	<version>5.0.0-SNAPSHOT</version>
+	<version>5.1.0-SNAPSHOT</version>
 	<packaging>eclipse-test-plugin</packaging>
 	<properties>
 		<os-jvm-flags></os-jvm-flags>
diff --git a/core/tests/org.eclipse.dltk.formatter.tests/META-INF/MANIFEST.MF b/core/tests/org.eclipse.dltk.formatter.tests/META-INF/MANIFEST.MF
index 9d5e3e2..cdf575e 100644
--- a/core/tests/org.eclipse.dltk.formatter.tests/META-INF/MANIFEST.MF
+++ b/core/tests/org.eclipse.dltk.formatter.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.formatter.tests
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Vendor: %pluginProvider
 Bundle-Localization: plugin
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/core/tests/org.eclipse.dltk.formatter.tests/pom.xml b/core/tests/org.eclipse.dltk.formatter.tests/pom.xml
index 1e40a37..cc2aca5 100644
--- a/core/tests/org.eclipse.dltk.formatter.tests/pom.xml
+++ b/core/tests/org.eclipse.dltk.formatter.tests/pom.xml
@@ -10,7 +10,7 @@
 	</parent>
 	<groupId>org.eclipse.dltk.core</groupId>
 	<artifactId>org.eclipse.dltk.formatter.tests</artifactId>
-	<version>5.0.0-SNAPSHOT</version>
+	<version>5.1.0-SNAPSHOT</version>
 	<packaging>eclipse-test-plugin</packaging>
 	<build>
 		<plugins>
diff --git a/core/tests/org.eclipse.dltk.ui.tests/META-INF/MANIFEST.MF b/core/tests/org.eclipse.dltk.ui.tests/META-INF/MANIFEST.MF
index c0def9e..4c66b4f 100644
--- a/core/tests/org.eclipse.dltk.ui.tests/META-INF/MANIFEST.MF
+++ b/core/tests/org.eclipse.dltk.ui.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.ui.tests;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.ui.tests.DLTKUITestsPlugin
 Bundle-Vendor: %providerName
 Bundle-Localization: plugin
diff --git a/core/tests/org.eclipse.dltk.ui.tests/pom.xml b/core/tests/org.eclipse.dltk.ui.tests/pom.xml
index 041b3a9..1f82e03 100644
--- a/core/tests/org.eclipse.dltk.ui.tests/pom.xml
+++ b/core/tests/org.eclipse.dltk.ui.tests/pom.xml
@@ -11,7 +11,7 @@
 	</parent>
 	<groupId>org.eclipse.dltk.core</groupId>
 	<artifactId>org.eclipse.dltk.ui.tests</artifactId>
-	<version>5.0.0-SNAPSHOT</version>
+	<version>5.1.0-SNAPSHOT</version>
 	<packaging>eclipse-test-plugin</packaging>
 	<properties>
 		<os-jvm-flags></os-jvm-flags>
diff --git a/core/tests/org.eclipse.dltk.validators.core.tests/META-INF/MANIFEST.MF b/core/tests/org.eclipse.dltk.validators.core.tests/META-INF/MANIFEST.MF
index fb8cafe..c1e2076 100644
--- a/core/tests/org.eclipse.dltk.validators.core.tests/META-INF/MANIFEST.MF
+++ b/core/tests/org.eclipse.dltk.validators.core.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.validators.core.tests;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.validators.core.tests.Activator
 Bundle-Vendor: %providerName
 Bundle-Localization: plugin
diff --git a/core/tests/org.eclipse.dltk.validators.core.tests/pom.xml b/core/tests/org.eclipse.dltk.validators.core.tests/pom.xml
index aa5bc1d..779539f 100644
--- a/core/tests/org.eclipse.dltk.validators.core.tests/pom.xml
+++ b/core/tests/org.eclipse.dltk.validators.core.tests/pom.xml
@@ -11,7 +11,7 @@
 	</parent>
 	<groupId>org.eclipse.dltk.core</groupId>
 	<artifactId>org.eclipse.dltk.validators.core.tests</artifactId>
-	<version>5.0.0-SNAPSHOT</version>
+	<version>5.1.0-SNAPSHOT</version>
 	<packaging>eclipse-test-plugin</packaging>
 	<build>
 		<plugins>
diff --git a/mylyn/features/org.eclipse.dltk.mylyn-feature/feature.xml b/mylyn/features/org.eclipse.dltk.mylyn-feature/feature.xml
index 06bb6c5..b8034f2 100644
--- a/mylyn/features/org.eclipse.dltk.mylyn-feature/feature.xml
+++ b/mylyn/features/org.eclipse.dltk.mylyn-feature/feature.xml
@@ -16,7 +16,7 @@
 <feature
       id="org.eclipse.dltk.mylyn"
       label="%featureName"
-      version="5.0.0.qualifier"
+      version="5.1.0.qualifier"
       provider-name="%providerName"
       image="eclipse_update_120.jpg">
 
diff --git a/mylyn/features/org.eclipse.dltk.mylyn-feature/pom.xml b/mylyn/features/org.eclipse.dltk.mylyn-feature/pom.xml
index ed0e5cc..eba64d0 100644
--- a/mylyn/features/org.eclipse.dltk.mylyn-feature/pom.xml
+++ b/mylyn/features/org.eclipse.dltk.mylyn-feature/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.features</groupId>
   <artifactId>org.eclipse.dltk.mylyn</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/mylyn/features/org.eclipse.dltk.mylyn.sdk/feature.xml b/mylyn/features/org.eclipse.dltk.mylyn.sdk/feature.xml
index 72c0a45..2a793e0 100644
--- a/mylyn/features/org.eclipse.dltk.mylyn.sdk/feature.xml
+++ b/mylyn/features/org.eclipse.dltk.mylyn.sdk/feature.xml
@@ -2,7 +2,7 @@
 <feature
       id="org.eclipse.dltk.mylyn.sdk"
       label="%featureName"
-      version="5.0.0.qualifier"
+      version="5.1.0.qualifier"
       provider-name="%providerName"
       image="eclipse_update_120.jpg">
 
diff --git a/mylyn/features/org.eclipse.dltk.mylyn.sdk/pom.xml b/mylyn/features/org.eclipse.dltk.mylyn.sdk/pom.xml
index 3a2489a..90cbaba 100644
--- a/mylyn/features/org.eclipse.dltk.mylyn.sdk/pom.xml
+++ b/mylyn/features/org.eclipse.dltk.mylyn.sdk/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.mylyn</groupId>
   <artifactId>org.eclipse.dltk.mylyn.sdk</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/mylyn/plugins/org.eclipse.dltk.mylyn/META-INF/MANIFEST.MF b/mylyn/plugins/org.eclipse.dltk.mylyn/META-INF/MANIFEST.MF
index 5f5bd32..2ca15f6 100644
--- a/mylyn/plugins/org.eclipse.dltk.mylyn/META-INF/MANIFEST.MF
+++ b/mylyn/plugins/org.eclipse.dltk.mylyn/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %Bundle-Name
 Bundle-SymbolicName: org.eclipse.dltk.mylyn;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.internal.mylyn.DLTKUiBridgePlugin
 Bundle-Localization: plugin
 Require-Bundle: org.eclipse.core.runtime,
diff --git a/mylyn/plugins/org.eclipse.dltk.mylyn/pom.xml b/mylyn/plugins/org.eclipse.dltk.mylyn/pom.xml
index d181422..ace5e6c 100644
--- a/mylyn/plugins/org.eclipse.dltk.mylyn/pom.xml
+++ b/mylyn/plugins/org.eclipse.dltk.mylyn/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.mylyn</groupId>
   <artifactId>org.eclipse.dltk.mylyn</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/rse/features/org.eclipse.dltk.rse-feature/feature.xml b/rse/features/org.eclipse.dltk.rse-feature/feature.xml
index d3e3760..81eff18 100644
--- a/rse/features/org.eclipse.dltk.rse-feature/feature.xml
+++ b/rse/features/org.eclipse.dltk.rse-feature/feature.xml
@@ -16,7 +16,7 @@
 <feature
       id="org.eclipse.dltk.rse"
       label="%featureName"
-      version="5.0.0.qualifier"
+      version="5.1.0.qualifier"
       provider-name="%providerName"
       image="eclipse_update_120.jpg">
 
diff --git a/rse/features/org.eclipse.dltk.rse-feature/pom.xml b/rse/features/org.eclipse.dltk.rse-feature/pom.xml
index 12abef8..f354386 100644
--- a/rse/features/org.eclipse.dltk.rse-feature/pom.xml
+++ b/rse/features/org.eclipse.dltk.rse-feature/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.features</groupId>
   <artifactId>org.eclipse.dltk.rse</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/rse/features/org.eclipse.dltk.rse.sdk/feature.xml b/rse/features/org.eclipse.dltk.rse.sdk/feature.xml
index 3298644..fe4995a 100644
--- a/rse/features/org.eclipse.dltk.rse.sdk/feature.xml
+++ b/rse/features/org.eclipse.dltk.rse.sdk/feature.xml
@@ -2,7 +2,7 @@
 <feature
       id="org.eclipse.dltk.rse.sdk"
       label="%featureName"
-      version="5.0.0.qualifier"
+      version="5.1.0.qualifier"
       provider-name="%providerName"
       image="eclipse_update_120.jpg">
 
diff --git a/rse/features/org.eclipse.dltk.rse.sdk/pom.xml b/rse/features/org.eclipse.dltk.rse.sdk/pom.xml
index 27e8eb2..c4ee358 100644
--- a/rse/features/org.eclipse.dltk.rse.sdk/pom.xml
+++ b/rse/features/org.eclipse.dltk.rse.sdk/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.rse</groupId>
   <artifactId>org.eclipse.dltk.rse.sdk</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/rse/plugins/org.eclipse.dltk.rse.core/META-INF/MANIFEST.MF b/rse/plugins/org.eclipse.dltk.rse.core/META-INF/MANIFEST.MF
index 2be8764..e334844 100644
--- a/rse/plugins/org.eclipse.dltk.rse.core/META-INF/MANIFEST.MF
+++ b/rse/plugins/org.eclipse.dltk.rse.core/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.rse.core;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.core.internal.rse.DLTKRSEPlugin
 Bundle-Vendor: %pluginProvider
 Bundle-Localization: plugin
diff --git a/rse/plugins/org.eclipse.dltk.rse.core/pom.xml b/rse/plugins/org.eclipse.dltk.rse.core/pom.xml
index 76fc13c..e13108e 100644
--- a/rse/plugins/org.eclipse.dltk.rse.core/pom.xml
+++ b/rse/plugins/org.eclipse.dltk.rse.core/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.rse</groupId>
   <artifactId>org.eclipse.dltk.rse.core</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/rse/plugins/org.eclipse.dltk.rse.ui/META-INF/MANIFEST.MF b/rse/plugins/org.eclipse.dltk.rse.ui/META-INF/MANIFEST.MF
index 2e450bb..dd776cf 100644
--- a/rse/plugins/org.eclipse.dltk.rse.ui/META-INF/MANIFEST.MF
+++ b/rse/plugins/org.eclipse.dltk.rse.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.rse.ui;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.internal.ui.rse.DLTKRSEUI
 Bundle-Vendor: %providerName
 Bundle-Localization: plugin
diff --git a/rse/plugins/org.eclipse.dltk.rse.ui/pom.xml b/rse/plugins/org.eclipse.dltk.rse.ui/pom.xml
index 3639679..ada3bf8 100644
--- a/rse/plugins/org.eclipse.dltk.rse.ui/pom.xml
+++ b/rse/plugins/org.eclipse.dltk.rse.ui/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.rse</groupId>
   <artifactId>org.eclipse.dltk.rse.ui</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/rse/plugins/org.eclipse.dltk.rse/META-INF/MANIFEST.MF b/rse/plugins/org.eclipse.dltk.rse/META-INF/MANIFEST.MF
index 6c21515..9f9bf38 100644
--- a/rse/plugins/org.eclipse.dltk.rse/META-INF/MANIFEST.MF
+++ b/rse/plugins/org.eclipse.dltk.rse/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.rse
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Vendor: %providerName
 Bundle-Localization: plugin
 Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/rse/plugins/org.eclipse.dltk.rse/pom.xml b/rse/plugins/org.eclipse.dltk.rse/pom.xml
index 4479b78..09e62da 100644
--- a/rse/plugins/org.eclipse.dltk.rse/pom.xml
+++ b/rse/plugins/org.eclipse.dltk.rse/pom.xml
@@ -11,7 +11,7 @@
 	</parent>
 	<groupId>org.eclipse.dltk.rse</groupId>
 	<artifactId>org.eclipse.dltk.rse</artifactId>
-	<version>5.0.0-SNAPSHOT</version>
+	<version>5.1.0-SNAPSHOT</version>
 	<packaging>eclipse-plugin</packaging>
 	<build>
 		<plugins>
diff --git a/rse/plugins/org.eclipse.dltk.ssh.core/META-INF/MANIFEST.MF b/rse/plugins/org.eclipse.dltk.ssh.core/META-INF/MANIFEST.MF
index af0adca..2febed6 100644
--- a/rse/plugins/org.eclipse.dltk.ssh.core/META-INF/MANIFEST.MF
+++ b/rse/plugins/org.eclipse.dltk.ssh.core/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %pluginName
 Bundle-SymbolicName: org.eclipse.dltk.ssh.core;singleton:=true
-Bundle-Version: 5.0.0.qualifier
+Bundle-Version: 5.1.0.qualifier
 Bundle-Activator: org.eclipse.dltk.ssh.internal.core.Activator
 Bundle-Vendor: %providerName
 Require-Bundle: org.eclipse.core.runtime,
diff --git a/rse/plugins/org.eclipse.dltk.ssh.core/pom.xml b/rse/plugins/org.eclipse.dltk.ssh.core/pom.xml
index 93ccf19..1192edf 100644
--- a/rse/plugins/org.eclipse.dltk.ssh.core/pom.xml
+++ b/rse/plugins/org.eclipse.dltk.ssh.core/pom.xml
@@ -10,6 +10,6 @@
   </parent>
   <groupId>org.eclipse.dltk.rse</groupId>
   <artifactId>org.eclipse.dltk.ssh.core</artifactId>
-  <version>5.0.0-SNAPSHOT</version>
+  <version>5.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>