1. 74cac89 fix 551591: bump versions by Stephane Bouchet · 4 years, 7 months ago
  2. f27802e Bug 547183: Compilation errors since 2019-06.M2 by Jeff MAURY · 5 years ago
  3. 5c2ceec move to tycho 1.4; bump update site version to 1.14.105-SNAPSHOT by nickboldt · 5 years ago
  4. 7a58262 build against Eclipse 4.12 by nickboldt · 5 years ago
  5. 0cdebb8 move up to tycho 1.3 by nickboldt · 5 years ago
  6. c9c5b0c fix parent pom: use http://download.eclipse.org/eclipse/updates/4.11-I-builds/ instead of 4.10 by nickboldt · 5 years ago
  7. 922069e [539434] use latest I build composite by nickboldt · 6 years ago
  8. e97ae5f remove linux x86 from TP by nickboldt · 6 years ago
  9. 901c014 build against http://download.eclipse.org/eclipse/updates/4.10-I-builds/ instead of http://download.eclipse.org/eclipse/updates/4.9-I-builds/ by nickboldt · 6 years ago
  10. 2689b59 Bug 538546 - move up to latest Orbit R20180905201904 (fix for Lucene Queryparser 7.1) by nickboldt · 6 years ago
  11. dfc8ff0 should use tycho-extras-version var for org.eclipse.tycho.extras version by nickboldt · 6 years ago
  12. 22a5002 upversion org.eclipse.datatools.sqltools.result to 1.3.200; use lucene 7.1 instead of 6.1; use Orbit build I20180829144012 by nickboldt · 6 years ago
  13. 9d55dfe build with tycho 1.2 by nickboldt · 6 years ago
  14. c16936e revert to tycho 1.1 by nickboldt · 6 years ago
  15. 56428d0 bump up to Tycho 1.2 by nickboldt · 6 years ago
  16. 4050e31 upversion to 1.14.101-SNAPSHOT [everywhere] by nickboldt · 6 years ago
  17. c9b406a move up to http://download.eclipse.org/eclipse/updates/4.9-I-builds/ since 4.8 milestone site gone by nickboldt · 6 years ago
  18. b46153d Revert "bump more things to 1.14.101 to hopefully fix signing/baseline issue in Jenkins" - didn't work -- issue is that we can't re-pack previously signed artifacts from the baseline. So instead work around build problem with -Dtycho.baseline.replace=none -DskipBaselineComparison=true -Dtycho.baseline=disable by nickboldt · 6 years ago
  19. ad3303e bump more things to 1.14.101 to hopefully fix signing/baseline issue in Jenkins by nickboldt · 6 years ago
  20. 14a7175 Bug 536202 - org.eclipse.datatools.sqltools.result should depend on lucene 6.1/7.1, not just any version (like 3.5); bump plugins/features to accomodate this change; use more final Photon URLs to build (Eclipse 4.8 milestones, Orbit R build) by nickboldt · 6 years ago
  21. 0a87029 update build to use latest Eclipse platform and Orbit I builds by nickboldt · 6 years ago
  22. 0ad7241 add TP support for osx and replace win32-x86 with win32-x86_64; remove restrictions on org.apache.commons.net and org.apache.commons.net.source by nickboldt · 6 years ago
  23. d780bf8 move up to Tycho 1.1 (needed to build with Photon.0.M5) by nickboldt · 6 years ago
  24. f565288 enable baseline checks by nickboldt · 6 years ago
  25. fa7cc9a move tycho-p2-plugin and tycho-source-feature-plugin to the features/pom.xml so it actually runs by nickboldt · 6 years ago
  26. ebefcf2 bind p2-metadata to package, not verify by nickboldt · 6 years ago
  27. a2aeb13 remove unused maven plugins; move USED ones out of pluginManagement and into plugins, so they're actually active by nickboldt · 6 years ago
  28. c92525e refactoring: remove plugins/connectivity/org.eclipse.datatools.connectivity.nl to DEPRECATED folder; add intermediate poms so we can build smaller reactors (eg., just the plugins) by nickboldt · 6 years ago
  29. b0d2719 move up baseline checks so they can actually run; switch to use individual upstream repos as TP instead of last Photon site, so we don't get circular resolution against the DTP in that site by nickboldt · 6 years ago
  30. e77ffdc enable baseline checks; remove win32-win32 TP by nickboldt · 6 years ago
  31. 9c20be5 re-enable building features/org.eclipse.datatools.enablement.sdk.feature features/org.eclipse.datatools.sdk.feature and plugins/org.eclipse.datatools.sdk; remove other commented items as they're not in the dtp 1.14.1 update site by nickboldt · 6 years ago
  32. c387245 derp de derp. copy and paste error because every project uses a different variation on tycho.version, tycho-version, or tychoVersion by nickboldt · 6 years ago
  33. 8f58dc1 add eclipse-sign profile by nickboldt · 6 years ago
  34. 19cb98b move examples/org.eclipse.datatools.connectivity.repository.uri and examples/org.eclipse.datatools.connectivity.sample.cp to DEPRECATED since require DTP 1.4 or earlier by nickboldt · 6 years ago
  35. 942c32f move org.eclipse.datatools.connectivity.repository.file to DEPRECATED since it requires DTP 1.4 or earlier by nickboldt · 6 years ago
  36. 04934f2 some old tests require JUnit3 so add site for that; remove tests/org.eclipse.datatools.sqltools.test because it depends on org.eclipse.hyades.test.tools.core from TPTP, which is archived and doesn't exist anymore by nickboldt · 6 years ago
  37. f84cc68 use Photon instead of Eclipse platform site to be able to resolve more deps (eg., draw2d) by nickboldt · 6 years ago
  38. 0a4cd14 comment out plugins/connectivity/org.eclipse.datatools.connectivity.nl for now; use newer Orbit to resolve lucene.queryparser; add more compiler options; add win32 TP by nickboldt · 6 years ago
  39. b88ee35 update root pom w/ target platform and other needed stuff; remove plugins/org.eclipse.datatools.releng.builder/extras and releng.new/releng; add site by nickboldt · 6 years ago
  40. dd58cc6 add generated root pom, minus some features/plugins by nickboldt · 6 years ago