Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEd Merks2020-07-23 08:20:52 +0000
committerEd Merks2020-07-23 08:20:52 +0000
commitfb49bcb503405277a759389c19a23f04c8fd560a (patch)
tree02ff4655e524184be1556c4fd627f9abe3a45c65
parentc99b32abd8190af6380b88a246bf9da133747330 (diff)
downloadorg.eclipse.xsd-fb49bcb503405277a759389c19a23f04c8fd560a.tar.gz
org.eclipse.xsd-fb49bcb503405277a759389c19a23f04c8fd560a.tar.xz
org.eclipse.xsd-fb49bcb503405277a759389c19a23f04c8fd560a.zip
[565408] Use of XSD as a library, avoiding transitive dependenciesR2_23_0
-rw-r--r--features/org.eclipse.xsd.edit-feature/feature.xml2
-rw-r--r--features/org.eclipse.xsd.edit-feature/pom.xml2
-rw-r--r--features/org.eclipse.xsd.mapping-feature/feature.xml2
-rw-r--r--features/org.eclipse.xsd.mapping-feature/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.mapping.xsd2ecore/META-INF/MANIFEST.MF14
-rw-r--r--plugins/org.eclipse.emf.mapping.xsd2ecore/pom.xml2
-rw-r--r--plugins/org.eclipse.xsd.edit/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.xsd.edit/pom.xml2
-rw-r--r--plugins/org.eclipse.xsd/META-INF/MANIFEST.MF2
9 files changed, 18 insertions, 18 deletions
diff --git a/features/org.eclipse.xsd.edit-feature/feature.xml b/features/org.eclipse.xsd.edit-feature/feature.xml
index 2ca171d3..7e8f39a3 100644
--- a/features/org.eclipse.xsd.edit-feature/feature.xml
+++ b/features/org.eclipse.xsd.edit-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.xsd.edit"
label="%featureName"
- version="2.12.0.qualifier"
+ version="2.13.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.xsd.license"
license-feature-version="2.11.0">
diff --git a/features/org.eclipse.xsd.edit-feature/pom.xml b/features/org.eclipse.xsd.edit-feature/pom.xml
index 4893363c..f2650533 100644
--- a/features/org.eclipse.xsd.edit-feature/pom.xml
+++ b/features/org.eclipse.xsd.edit-feature/pom.xml
@@ -12,7 +12,7 @@
<groupId>org.eclipse.emf.features</groupId>
<artifactId>org.eclipse.xsd.edit</artifactId>
- <version>2.12.0-SNAPSHOT</version>
+ <version>2.13.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/features/org.eclipse.xsd.mapping-feature/feature.xml b/features/org.eclipse.xsd.mapping-feature/feature.xml
index 21d01a03..35d05952 100644
--- a/features/org.eclipse.xsd.mapping-feature/feature.xml
+++ b/features/org.eclipse.xsd.mapping-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.xsd.mapping"
label="%featureName"
- version="2.12.0.qualifier"
+ version="2.13.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.xsd.license"
license-feature-version="2.11.0">
diff --git a/features/org.eclipse.xsd.mapping-feature/pom.xml b/features/org.eclipse.xsd.mapping-feature/pom.xml
index f1e05ccf..0239543a 100644
--- a/features/org.eclipse.xsd.mapping-feature/pom.xml
+++ b/features/org.eclipse.xsd.mapping-feature/pom.xml
@@ -12,7 +12,7 @@
<groupId>org.eclipse.emf.features</groupId>
<artifactId>org.eclipse.xsd.mapping</artifactId>
- <version>2.12.0-SNAPSHOT</version>
+ <version>2.13.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.mapping.xsd2ecore/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.mapping.xsd2ecore/META-INF/MANIFEST.MF
index 59655f3b..e37f2fde 100644
--- a/plugins/org.eclipse.emf.mapping.xsd2ecore/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.mapping.xsd2ecore/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.mapping.xsd2ecore; singleton:=true
-Bundle-Version: 2.8.0.qualifier
+Bundle-Version: 2.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.emf.mapping.xsd2ecore.XSD2EcorePlugin$Implementation
Bundle-Vendor: %providerName
@@ -12,12 +12,12 @@ Export-Package: org.eclipse.emf.mapping.xsd2ecore,
org.eclipse.emf.mapping.xsd2ecore.impl,
org.eclipse.emf.mapping.xsd2ecore.provider,
org.eclipse.emf.mapping.xsd2ecore.util
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.6.0,4.0.0)",
- org.eclipse.emf.ecore.xmi;bundle-version="[2.14.0,3.0.0)";visibility:=reexport,
- org.eclipse.emf.ecore.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.emf.mapping;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.xsd;bundle-version="[2.15.0,3.0.0)";visibility:=reexport,
- org.eclipse.xsd.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.6.0,4.0.0)";resolution:=optional;x-installation:=greedy,
+ org.eclipse.emf.ecore.xmi;bundle-version="[2.16.0,3.0.0)";visibility:=reexport,
+ org.eclipse.emf.ecore.edit;bundle-version="[2.13.0,3.0.0)";visibility:=reexport,
+ org.eclipse.emf.mapping;bundle-version="[2.12.0,3.0.0)";visibility:=reexport,
+ org.eclipse.xsd;bundle-version="[2.18.0,3.0.0)";visibility:=reexport,
+ org.eclipse.xsd.edit;bundle-version="[2.11.0,3.0.0)";visibility:=reexport
Eclipse-LazyStart: true
Bundle-ActivationPolicy: lazy
Automatic-Module-Name: org.eclipse.emf.mapping.xsd2ecore
diff --git a/plugins/org.eclipse.emf.mapping.xsd2ecore/pom.xml b/plugins/org.eclipse.emf.mapping.xsd2ecore/pom.xml
index f4f2747b..4244d424 100644
--- a/plugins/org.eclipse.emf.mapping.xsd2ecore/pom.xml
+++ b/plugins/org.eclipse.emf.mapping.xsd2ecore/pom.xml
@@ -12,7 +12,7 @@
<groupId>org.eclipse.emf</groupId>
<artifactId>org.eclipse.emf.mapping.xsd2ecore</artifactId>
- <version>2.8.0-SNAPSHOT</version>
+ <version>2.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.xsd.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.xsd.edit/META-INF/MANIFEST.MF
index f6c44ecc..21600099 100644
--- a/plugins/org.eclipse.xsd.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.xsd.edit/META-INF/MANIFEST.MF
@@ -2,16 +2,16 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.xsd.edit; singleton:=true
-Bundle-Version: 2.10.0.qualifier
+Bundle-Version: 2.11.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.xsd.provider.XSDEditPlugin$Implementation
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.xsd.provider
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.6.0,4.0.0)",
- org.eclipse.emf.edit;bundle-version="[2.13.0,3.0.0)";visibility:=reexport,
- org.eclipse.xsd;bundle-version="[2.15.0,3.0.0)";visibility:=reexport
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.6.0,4.0.0)";resolution:=optional;x-installation:=greedy,
+ org.eclipse.emf.edit;bundle-version="[2.16.0,3.0.0)";visibility:=reexport,
+ org.eclipse.xsd;bundle-version="[2.18.0,3.0.0)";visibility:=reexport
Eclipse-LazyStart: true
Bundle-ActivationPolicy: lazy
Automatic-Module-Name: org.eclipse.xsd.edit
diff --git a/plugins/org.eclipse.xsd.edit/pom.xml b/plugins/org.eclipse.xsd.edit/pom.xml
index 1fa087bc..be7f6bd6 100644
--- a/plugins/org.eclipse.xsd.edit/pom.xml
+++ b/plugins/org.eclipse.xsd.edit/pom.xml
@@ -12,7 +12,7 @@
<groupId>org.eclipse.emf</groupId>
<artifactId>org.eclipse.xsd.edit</artifactId>
- <version>2.10.0-SNAPSHOT</version>
+ <version>2.11.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.xsd/META-INF/MANIFEST.MF b/plugins/org.eclipse.xsd/META-INF/MANIFEST.MF
index fc84c496..53b52166 100644
--- a/plugins/org.eclipse.xsd/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.xsd/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Export-Package: org.eclipse.xsd,
org.eclipse.xsd.impl,
org.eclipse.xsd.impl.type,
org.eclipse.xsd.util
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.6.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.6.0,4.0.0)";resolution:=optional;x-installation:=greedy,
org.eclipse.emf.ecore;bundle-version="[2.23.0,3.0.0)";visibility:=reexport
Eclipse-LazyStart: true
Bundle-ActivationPolicy: lazy

Back to the top