Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'core/org.eclipse.emf.texo')
-rwxr-xr-xcore/org.eclipse.emf.texo/.classpath12
-rwxr-xr-xcore/org.eclipse.emf.texo/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--core/org.eclipse.emf.texo/.settings/org.eclipse.wst.common.project.facet.core.xml2
-rwxr-xr-xcore/org.eclipse.emf.texo/META-INF/MANIFEST.MF2
4 files changed, 15 insertions, 8 deletions
diff --git a/core/org.eclipse.emf.texo/.classpath b/core/org.eclipse.emf.texo/.classpath
index 64c5e31b..91659e04 100755
--- a/core/org.eclipse.emf.texo/.classpath
+++ b/core/org.eclipse.emf.texo/.classpath
@@ -1,7 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
- <classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
+ <classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
+ <attributes>
+ <attribute name="org.eclipse.jst.component.nondependency" value=""/>
+ </attributes>
+ </classpathentry>
<classpathentry kind="src" path="src"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/jdk1.7.0">
+ <attributes>
+ <attribute name="owner.project.facets" value="java"/>
+ </attributes>
+ </classpathentry>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/core/org.eclipse.emf.texo/.settings/org.eclipse.jdt.core.prefs b/core/org.eclipse.emf.texo/.settings/org.eclipse.jdt.core.prefs
index f578e6d5..d452002b 100755
--- a/core/org.eclipse.emf.texo/.settings/org.eclipse.jdt.core.prefs
+++ b/core/org.eclipse.emf.texo/.settings/org.eclipse.jdt.core.prefs
@@ -1,9 +1,8 @@
-#Thu Mar 29 22:20:19 CEST 2012
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -72,7 +71,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.formatter.align_type_members_on_columns=false
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_allocation_expression=16
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_annotation=0
diff --git a/core/org.eclipse.emf.texo/.settings/org.eclipse.wst.common.project.facet.core.xml b/core/org.eclipse.emf.texo/.settings/org.eclipse.wst.common.project.facet.core.xml
index 7a1c5688..77fedc87 100644
--- a/core/org.eclipse.emf.texo/.settings/org.eclipse.wst.common.project.facet.core.xml
+++ b/core/org.eclipse.emf.texo/.settings/org.eclipse.wst.common.project.facet.core.xml
@@ -3,6 +3,6 @@
<runtime name="Apache Tomcat v7.0"/>
<fixed facet="java"/>
<fixed facet="jst.utility"/>
- <installed facet="java" version="1.5"/>
<installed facet="jst.utility" version="1.0"/>
+ <installed facet="java" version="1.7"/>
</faceted-project>
diff --git a/core/org.eclipse.emf.texo/META-INF/MANIFEST.MF b/core/org.eclipse.emf.texo/META-INF/MANIFEST.MF
index 647c8a20..70f2cd13 100755
--- a/core/org.eclipse.emf.texo/META-INF/MANIFEST.MF
+++ b/core/org.eclipse.emf.texo/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Version: 0.1.0.qualifier
Bundle-Vendor: %providerName
Bundle-ClassPath: .
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Require-Bundle: org.eclipse.emf.ecore;bundle-version="[2.5.0,3.0.0)",
org.eclipse.emf.ecore.xmi;bundle-version="[2.5.0,3.0.0)"
Export-Package: org.eclipse.emf.texo.component;version="0.1.0",

Back to the top