Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Tasse2017-06-07 18:17:25 +0000
committerPatrick Tasse2017-06-07 20:23:08 +0000
commit091470009e20f710ab01a5f13ba722be71a86035 (patch)
tree3ba10620f908ff3a8f1e3d2113f9fe9553dab0b4
parentf3b3afe450c82cbf75c1b7ddc9f3823c3839f1af (diff)
downloadorg.eclipse.swtbot-091470009e20f710ab01a5f13ba722be71a86035.tar.gz
org.eclipse.swtbot-091470009e20f710ab01a5f13ba722be71a86035.tar.xz
org.eclipse.swtbot-091470009e20f710ab01a5f13ba722be71a86035.zip
Change minimum Execution Environment to JavaSE-1.6 for all plug-ins
Some plug-ins were set to J2SE-1.5 but were using JavaSE-1.6 APIs. Change-Id: I44117c00702b85e00051b58b5b024da59dc1fb28 Signed-off-by: Patrick Tasse <patrick.tasse@gmail.com>
-rw-r--r--examples/gef/org.eclipse.gef.examples.logic.test/.classpath2
-rw-r--r--examples/gef/org.eclipse.gef.examples.logic.test/.settings/org.eclipse.jdt.core.prefs8
-rw-r--r--examples/gef/org.eclipse.gef.examples.logic.test/META-INF/MANIFEST.MF2
-rw-r--r--examples/gef/org.eclipse.gef.examples.logic/.classpath2
-rw-r--r--examples/gef/org.eclipse.gef.examples.logic/.settings/org.eclipse.jdt.core.prefs10
-rw-r--r--examples/gef/org.eclipse.gef.examples.logic/META-INF/MANIFEST.MF2
-rw-r--r--examples/rcp/org.rcpmail.test/.classpath2
-rw-r--r--examples/rcp/org.rcpmail.test/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--examples/rcp/org.rcpmail.test/META-INF/MANIFEST.MF2
-rw-r--r--examples/rcp/org.rcpmail/.classpath2
-rw-r--r--examples/rcp/org.rcpmail/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--examples/rcp/org.rcpmail/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swt.examples/.classpath2
-rw-r--r--org.eclipse.swt.examples/.settings/org.eclipse.jdt.core.prefs8
-rw-r--r--org.eclipse.swt.examples/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.e4.finder/.classpath2
-rw-r--r--org.eclipse.swtbot.e4.finder/.settings/org.eclipse.jdt.core.prefs11
-rw-r--r--org.eclipse.swtbot.e4.finder/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.eclipse.core/.classpath2
-rw-r--r--org.eclipse.swtbot.eclipse.core/.settings/org.eclipse.jdt.core.prefs12
-rw-r--r--org.eclipse.swtbot.eclipse.core/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.eclipse.dsl/.classpath2
-rw-r--r--org.eclipse.swtbot.eclipse.dsl/.settings/org.eclipse.jdt.core.prefs12
-rw-r--r--org.eclipse.swtbot.eclipse.dsl/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.eclipse.finder.test/.classpath2
-rw-r--r--org.eclipse.swtbot.eclipse.finder.test/.settings/org.eclipse.jdt.core.prefs12
-rw-r--r--org.eclipse.swtbot.eclipse.finder.test/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.eclipse.finder/.classpath2
-rw-r--r--org.eclipse.swtbot.eclipse.finder/.settings/org.eclipse.jdt.core.prefs12
-rw-r--r--org.eclipse.swtbot.eclipse.finder/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.eclipse.gef.finder/.classpath2
-rw-r--r--org.eclipse.swtbot.eclipse.gef.finder/.settings/org.eclipse.jdt.core.prefs8
-rw-r--r--org.eclipse.swtbot.eclipse.gef.finder/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.eclipse.junit.headless/.classpath2
-rw-r--r--org.eclipse.swtbot.eclipse.junit.headless/.settings/org.eclipse.jdt.core.prefs12
-rw-r--r--org.eclipse.swtbot.eclipse.junit.headless/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.eclipse.spy/.classpath2
-rw-r--r--org.eclipse.swtbot.eclipse.spy/.settings/org.eclipse.jdt.core.prefs12
-rw-r--r--org.eclipse.swtbot.eclipse.spy/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.eclipse.ui.test/.classpath2
-rw-r--r--org.eclipse.swtbot.eclipse.ui.test/.settings/org.eclipse.jdt.core.prefs12
-rw-r--r--org.eclipse.swtbot.eclipse.ui.test/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.eclipse.ui.test/functional/org/eclipse/swtbot/eclipse/ui/functional/ProjectCreationWizardTest.java6
-rw-r--r--org.eclipse.swtbot.eclipse.ui.test/src/org/eclipse/swtbot/eclipse/ui/project/TemplatizerTest.java6
-rw-r--r--org.eclipse.swtbot.eclipse.ui/.classpath2
-rw-r--r--org.eclipse.swtbot.eclipse.ui/.settings/org.eclipse.jdt.core.prefs12
-rw-r--r--org.eclipse.swtbot.eclipse.ui/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.eclipse.ui/src/org/eclipse/swtbot/eclipse/ui/project/_MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.eclipse.ui/src/org/eclipse/swtbot/eclipse/ui/project/_classpath2
-rw-r--r--org.eclipse.swtbot.forms.finder.test/.classpath2
-rw-r--r--org.eclipse.swtbot.forms.finder.test/.settings/org.eclipse.jdt.core.prefs12
-rw-r--r--org.eclipse.swtbot.forms.finder.test/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.forms.finder/.classpath2
-rw-r--r--org.eclipse.swtbot.forms.finder/.settings/org.eclipse.jdt.core.prefs12
-rw-r--r--org.eclipse.swtbot.forms.finder/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.generator.jdt.test/.classpath4
-rw-r--r--org.eclipse.swtbot.generator.jdt.test/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--org.eclipse.swtbot.generator.jdt.test/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.generator.jdt/.classpath4
-rw-r--r--org.eclipse.swtbot.generator.jdt/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--org.eclipse.swtbot.generator.jdt/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.generator.test/.classpath2
-rw-r--r--org.eclipse.swtbot.generator.test/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--org.eclipse.swtbot.generator.test/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.generator/.classpath2
-rw-r--r--org.eclipse.swtbot.generator/.settings/org.eclipse.jdt.core.prefs8
-rw-r--r--org.eclipse.swtbot.generator/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.go/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.junit4_x/.classpath2
-rw-r--r--org.eclipse.swtbot.junit4_x/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--org.eclipse.swtbot.junit4_x/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.nebula.gallery.finder.test/.classpath2
-rw-r--r--org.eclipse.swtbot.nebula.gallery.finder.test/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--org.eclipse.swtbot.nebula.gallery.finder.test/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.nebula.gallery.finder/.classpath2
-rw-r--r--org.eclipse.swtbot.nebula.gallery.finder/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--org.eclipse.swtbot.nebula.gallery.finder/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.swt.demo/.classpath2
-rw-r--r--org.eclipse.swtbot.swt.demo/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--org.eclipse.swtbot.swt.demo/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.swt.finder.test.keyboards/.classpath2
-rw-r--r--org.eclipse.swtbot.swt.finder.test.keyboards/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--org.eclipse.swtbot.swt.finder.test.keyboards/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.swt.finder.test/.classpath2
-rw-r--r--org.eclipse.swtbot.swt.finder.test/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--org.eclipse.swtbot.swt.finder.test/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.swt.finder/.classpath2
-rw-r--r--org.eclipse.swtbot.swt.finder/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--org.eclipse.swtbot.swt.finder/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.swtbot.swt.finder/src/org/eclipse/swtbot/swt/finder/widgets/AbstractSWTBot.java6
-rw-r--r--org.eclipse.swtbot.swt.finder/src/org/eclipse/swtbot/swt/finder/widgets/SWTBotLink.java2
-rwxr-xr-xorg.eclipse.ui.forms.examples/.classpath2
-rwxr-xr-xorg.eclipse.ui.forms.examples/.settings/org.eclipse.jdt.core.prefs13
-rw-r--r--org.eclipse.ui.forms.examples/META-INF/MANIFEST.MF2
94 files changed, 225 insertions, 187 deletions
diff --git a/examples/gef/org.eclipse.gef.examples.logic.test/.classpath b/examples/gef/org.eclipse.gef.examples.logic.test/.classpath
index 304e8618..121e527a 100644
--- a/examples/gef/org.eclipse.gef.examples.logic.test/.classpath
+++ b/examples/gef/org.eclipse.gef.examples.logic.test/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/examples/gef/org.eclipse.gef.examples.logic.test/.settings/org.eclipse.jdt.core.prefs b/examples/gef/org.eclipse.gef.examples.logic.test/.settings/org.eclipse.jdt.core.prefs
index 27ac0168..ef8a789c 100644
--- a/examples/gef/org.eclipse.gef.examples.logic.test/.settings/org.eclipse.jdt.core.prefs
+++ b/examples/gef/org.eclipse.gef.examples.logic.test/.settings/org.eclipse.jdt.core.prefs
@@ -1,12 +1,12 @@
-#Tue Jun 23 16:28:55 CEST 2009
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/examples/gef/org.eclipse.gef.examples.logic.test/META-INF/MANIFEST.MF b/examples/gef/org.eclipse.gef.examples.logic.test/META-INF/MANIFEST.MF
index c51cc715..6537828d 100644
--- a/examples/gef/org.eclipse.gef.examples.logic.test/META-INF/MANIFEST.MF
+++ b/examples/gef/org.eclipse.gef.examples.logic.test/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: SWTBot Graphical Editing Framework Logic Editor Example Tests Plug-in
Bundle-SymbolicName: org.eclipse.gef.examples.logic.test
Bundle-Version: 2.1.0.qualifier
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Require-Bundle: org.eclipse.gef.examples.logic,
org.eclipse.swtbot.eclipse.gef.finder,
org.eclipse.swtbot.eclipse.finder,
diff --git a/examples/gef/org.eclipse.gef.examples.logic/.classpath b/examples/gef/org.eclipse.gef.examples.logic/.classpath
index 665ef574..c87f4822 100644
--- a/examples/gef/org.eclipse.gef.examples.logic/.classpath
+++ b/examples/gef/org.eclipse.gef.examples.logic/.classpath
@@ -3,6 +3,6 @@
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="src" path="src-notgen"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/examples/gef/org.eclipse.gef.examples.logic/.settings/org.eclipse.jdt.core.prefs b/examples/gef/org.eclipse.gef.examples.logic/.settings/org.eclipse.jdt.core.prefs
index 34a0bd6c..d964087b 100644
--- a/examples/gef/org.eclipse.gef.examples.logic/.settings/org.eclipse.jdt.core.prefs
+++ b/examples/gef/org.eclipse.gef.examples.logic/.settings/org.eclipse.jdt.core.prefs
@@ -1,16 +1,18 @@
-#Thu Nov 05 18:26:18 CET 2009
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.deprecation=ignore
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
org.eclipse.jdt.core.compiler.problem.missingOverrideAnnotation=ignore
org.eclipse.jdt.core.compiler.problem.missingSerialVersion=ignore
org.eclipse.jdt.core.compiler.problem.rawTypeReference=ignore
org.eclipse.jdt.core.compiler.problem.staticAccessReceiver=ignore
org.eclipse.jdt.core.compiler.problem.uncheckedTypeOperation=ignore
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/examples/gef/org.eclipse.gef.examples.logic/META-INF/MANIFEST.MF b/examples/gef/org.eclipse.gef.examples.logic/META-INF/MANIFEST.MF
index 528c6e06..6e8ecf7d 100644
--- a/examples/gef/org.eclipse.gef.examples.logic/META-INF/MANIFEST.MF
+++ b/examples/gef/org.eclipse.gef.examples.logic/META-INF/MANIFEST.MF
@@ -69,5 +69,5 @@ Import-Package: org.eclipse.core.commands,
org.eclipse.ui.views.properties,
org.osgi.framework
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/examples/rcp/org.rcpmail.test/.classpath b/examples/rcp/org.rcpmail.test/.classpath
index 64c5e31b..ad32c83a 100644
--- a/examples/rcp/org.rcpmail.test/.classpath
+++ b/examples/rcp/org.rcpmail.test/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/examples/rcp/org.rcpmail.test/.settings/org.eclipse.jdt.core.prefs b/examples/rcp/org.rcpmail.test/.settings/org.eclipse.jdt.core.prefs
index d1a8d27d..c537b630 100644
--- a/examples/rcp/org.rcpmail.test/.settings/org.eclipse.jdt.core.prefs
+++ b/examples/rcp/org.rcpmail.test/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Tue Dec 16 23:22:26 IST 2008
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/examples/rcp/org.rcpmail.test/META-INF/MANIFEST.MF b/examples/rcp/org.rcpmail.test/META-INF/MANIFEST.MF
index 0129cadd..e126f792 100644
--- a/examples/rcp/org.rcpmail.test/META-INF/MANIFEST.MF
+++ b/examples/rcp/org.rcpmail.test/META-INF/MANIFEST.MF
@@ -10,5 +10,5 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.swtbot.swt.finder,
org.junit;bundle-version="4.5.0",
org.eclipse.swtbot.junit4_x
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-Vendor: Eclipse.org - SWTBot
diff --git a/examples/rcp/org.rcpmail/.classpath b/examples/rcp/org.rcpmail/.classpath
index 64c5e31b..ad32c83a 100644
--- a/examples/rcp/org.rcpmail/.classpath
+++ b/examples/rcp/org.rcpmail/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/examples/rcp/org.rcpmail/.settings/org.eclipse.jdt.core.prefs b/examples/rcp/org.rcpmail/.settings/org.eclipse.jdt.core.prefs
index a835e59b..c537b630 100644
--- a/examples/rcp/org.rcpmail/.settings/org.eclipse.jdt.core.prefs
+++ b/examples/rcp/org.rcpmail/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Tue Dec 16 23:22:29 IST 2008
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/examples/rcp/org.rcpmail/META-INF/MANIFEST.MF b/examples/rcp/org.rcpmail/META-INF/MANIFEST.MF
index 945c781d..2b00e456 100644
--- a/examples/rcp/org.rcpmail/META-INF/MANIFEST.MF
+++ b/examples/rcp/org.rcpmail/META-INF/MANIFEST.MF
@@ -7,5 +7,5 @@ Bundle-Activator: org.rcpmail.Activator
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-Vendor: Eclipse.org - SWTBot
diff --git a/org.eclipse.swt.examples/.classpath b/org.eclipse.swt.examples/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swt.examples/.classpath
+++ b/org.eclipse.swt.examples/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swt.examples/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swt.examples/.settings/org.eclipse.jdt.core.prefs
index f4223f2f..21cf812e 100644
--- a/org.eclipse.swt.examples/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swt.examples/.settings/org.eclipse.jdt.core.prefs
@@ -1,9 +1,9 @@
-#Thu Nov 20 22:52:54 IST 2008
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -82,4 +82,4 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=ignore
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=ignore
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=ignore
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swt.examples/META-INF/MANIFEST.MF b/org.eclipse.swt.examples/META-INF/MANIFEST.MF
index 63579aea..f09c88d7 100644
--- a/org.eclipse.swt.examples/META-INF/MANIFEST.MF
+++ b/org.eclipse.swt.examples/META-INF/MANIFEST.MF
@@ -21,7 +21,7 @@ Export-Package: org.eclipse.jface.snippets.viewers,
org.eclipse.swt.examples.paint,
org.eclipse.swt.examples.texteditor
Bundle-Vendor: Eclipse.org - SWTBot
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Import-Package: org.eclipse.core.commands.common,
org.eclipse.jface.action,
org.eclipse.jface.resource,
diff --git a/org.eclipse.swtbot.e4.finder/.classpath b/org.eclipse.swtbot.e4.finder/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.e4.finder/.classpath
+++ b/org.eclipse.swtbot.e4.finder/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.e4.finder/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.e4.finder/.settings/org.eclipse.jdt.core.prefs
index af0f20f9..ef8a789c 100644
--- a/org.eclipse.swtbot.e4.finder/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.e4.finder/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,12 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
+org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.debug.lineNumber=generate
+org.eclipse.jdt.core.compiler.debug.localVariable=generate
+org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.e4.finder/META-INF/MANIFEST.MF b/org.eclipse.swtbot.e4.finder/META-INF/MANIFEST.MF
index 3dc906e3..beda1225 100644
--- a/org.eclipse.swtbot.e4.finder/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.e4.finder/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: SWTBot Eclipse E4 Control Finder Plug-in
Bundle-SymbolicName: org.eclipse.swtbot.e4.finder
Bundle-Version: 2.6.0.qualifier
Bundle-Activator: org.eclipse.swtbot.e4.finder.Activator
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Import-Package: javax.inject;version="1.0.0",
org.apache.log4j;version="[1.2.13,1.3.0)",
org.osgi.framework
diff --git a/org.eclipse.swtbot.eclipse.core/.classpath b/org.eclipse.swtbot.eclipse.core/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.eclipse.core/.classpath
+++ b/org.eclipse.swtbot.eclipse.core/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.eclipse.core/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.eclipse.core/.settings/org.eclipse.jdt.core.prefs
index 4b379fd2..ef8a789c 100644
--- a/org.eclipse.swtbot.eclipse.core/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.eclipse.core/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,12 @@
-#Thu Dec 18 01:12:33 IST 2008
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
+org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.debug.lineNumber=generate
+org.eclipse.jdt.core.compiler.debug.localVariable=generate
+org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.eclipse.core/META-INF/MANIFEST.MF b/org.eclipse.swtbot.eclipse.core/META-INF/MANIFEST.MF
index c9621beb..5dc79cfc 100644
--- a/org.eclipse.swtbot.eclipse.core/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.eclipse.core/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: SWTBot Test Launcher Application Plug-in
Bundle-SymbolicName: org.eclipse.swtbot.eclipse.core;singleton:=true
Bundle-Version: 2.6.0.qualifier
Bundle-Vendor: Eclipse.org - SWTBot
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Import-Package: org.eclipse.core.runtime;version="3.4.0",
org.eclipse.equinox.app;version="1.0.0",
org.eclipse.jdt.internal.junit.runner,
diff --git a/org.eclipse.swtbot.eclipse.dsl/.classpath b/org.eclipse.swtbot.eclipse.dsl/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.eclipse.dsl/.classpath
+++ b/org.eclipse.swtbot.eclipse.dsl/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.eclipse.dsl/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.eclipse.dsl/.settings/org.eclipse.jdt.core.prefs
index 990faffa..ef8a789c 100644
--- a/org.eclipse.swtbot.eclipse.dsl/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.eclipse.dsl/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,12 @@
-#Tue Jan 13 09:05:29 IST 2009
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
+org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.debug.lineNumber=generate
+org.eclipse.jdt.core.compiler.debug.localVariable=generate
+org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.eclipse.dsl/META-INF/MANIFEST.MF b/org.eclipse.swtbot.eclipse.dsl/META-INF/MANIFEST.MF
index 78c0d4fb..cb44906a 100644
--- a/org.eclipse.swtbot.eclipse.dsl/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.eclipse.dsl/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Bundle-SymbolicName: org.eclipse.swtbot.eclipse.dsl
Bundle-Version: 2.6.0.qualifier
Bundle-Activator: org.eclipse.swtbot.eclipse.dsl.Activator
Bundle-Vendor: Eclipse.org - SWTBot
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ActivationPolicy: lazy
Import-Package: org.apache.log4j;version="[1.2.13,1.3.0)",
org.eclipse.core.runtime;version="3.4.0",
diff --git a/org.eclipse.swtbot.eclipse.finder.test/.classpath b/org.eclipse.swtbot.eclipse.finder.test/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.eclipse.finder.test/.classpath
+++ b/org.eclipse.swtbot.eclipse.finder.test/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.eclipse.finder.test/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.eclipse.finder.test/.settings/org.eclipse.jdt.core.prefs
index cc75fa25..488bf406 100644
--- a/org.eclipse.swtbot.eclipse.finder.test/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.eclipse.finder.test/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,12 @@
-#Tue Dec 16 23:22:50 IST 2008
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
+org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.debug.lineNumber=generate
+org.eclipse.jdt.core.compiler.debug.localVariable=generate
+org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.doc.comment.support=enabled
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
@@ -18,4 +22,4 @@ org.eclipse.jdt.core.compiler.problem.missingJavadocTagDescription=all_tags
org.eclipse.jdt.core.compiler.problem.missingJavadocTags=ignore
org.eclipse.jdt.core.compiler.problem.missingJavadocTagsOverriding=disabled
org.eclipse.jdt.core.compiler.problem.missingJavadocTagsVisibility=default
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.eclipse.finder.test/META-INF/MANIFEST.MF b/org.eclipse.swtbot.eclipse.finder.test/META-INF/MANIFEST.MF
index 108fceaf..99c39dff 100644
--- a/org.eclipse.swtbot.eclipse.finder.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.eclipse.finder.test/META-INF/MANIFEST.MF
@@ -21,6 +21,6 @@ Require-Bundle: org.eclipse.jface.text,
org.eclipse.ui.intro,
org.eclipse.ui.intro.universal,
org.eclipse.platform
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-Vendor: Eclipse.org - SWTBot
Eclipse-RegisterBuddy: org.apache.log4j
diff --git a/org.eclipse.swtbot.eclipse.finder/.classpath b/org.eclipse.swtbot.eclipse.finder/.classpath
index 41098a31..c43082f0 100644
--- a/org.eclipse.swtbot.eclipse.finder/.classpath
+++ b/org.eclipse.swtbot.eclipse.finder/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="**"/>
diff --git a/org.eclipse.swtbot.eclipse.finder/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.eclipse.finder/.settings/org.eclipse.jdt.core.prefs
index 770ca553..ef8a789c 100644
--- a/org.eclipse.swtbot.eclipse.finder/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.eclipse.finder/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,12 @@
-#Tue Dec 16 23:22:52 IST 2008
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
+org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.debug.lineNumber=generate
+org.eclipse.jdt.core.compiler.debug.localVariable=generate
+org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.eclipse.finder/META-INF/MANIFEST.MF b/org.eclipse.swtbot.eclipse.finder/META-INF/MANIFEST.MF
index 747f2b50..faa5a717 100644
--- a/org.eclipse.swtbot.eclipse.finder/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.eclipse.finder/META-INF/MANIFEST.MF
@@ -11,7 +11,7 @@ Export-Package: org.eclipse.swtbot.eclipse.finder,
org.eclipse.swtbot.eclipse.finder.matchers,
org.eclipse.swtbot.eclipse.finder.waits,
org.eclipse.swtbot.eclipse.finder.widgets
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ClassPath: .
Import-Package: javax.swing.text,
junit.framework;version="4.5.0",
diff --git a/org.eclipse.swtbot.eclipse.gef.finder/.classpath b/org.eclipse.swtbot.eclipse.gef.finder/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.eclipse.gef.finder/.classpath
+++ b/org.eclipse.swtbot.eclipse.gef.finder/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.eclipse.gef.finder/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.eclipse.gef.finder/.settings/org.eclipse.jdt.core.prefs
index 73e09f32..2a0cc213 100644
--- a/org.eclipse.swtbot.eclipse.gef.finder/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.eclipse.gef.finder/.settings/org.eclipse.jdt.core.prefs
@@ -1,9 +1,9 @@
-#Sun Mar 22 08:44:42 CET 2009
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -67,4 +67,4 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.eclipse.gef.finder/META-INF/MANIFEST.MF b/org.eclipse.swtbot.eclipse.gef.finder/META-INF/MANIFEST.MF
index 859f2790..843e3cf3 100644
--- a/org.eclipse.swtbot.eclipse.gef.finder/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.eclipse.gef.finder/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: SWTBot Graphical Editing Framework Plug-in
Bundle-SymbolicName: org.eclipse.swtbot.eclipse.gef.finder;singleton:=true
Bundle-Version: 2.6.0.qualifier
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Export-Package: org.eclipse.swtbot.eclipse.gef.finder,
org.eclipse.swtbot.eclipse.gef.finder.finders,
org.eclipse.swtbot.eclipse.gef.finder.matchers,
diff --git a/org.eclipse.swtbot.eclipse.junit.headless/.classpath b/org.eclipse.swtbot.eclipse.junit.headless/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.eclipse.junit.headless/.classpath
+++ b/org.eclipse.swtbot.eclipse.junit.headless/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.eclipse.junit.headless/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.eclipse.junit.headless/.settings/org.eclipse.jdt.core.prefs
index c7ff7f4e..ef8a789c 100644
--- a/org.eclipse.swtbot.eclipse.junit.headless/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.eclipse.junit.headless/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,12 @@
-#Tue Dec 16 23:22:49 IST 2008
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
+org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.debug.lineNumber=generate
+org.eclipse.jdt.core.compiler.debug.localVariable=generate
+org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.eclipse.junit.headless/META-INF/MANIFEST.MF b/org.eclipse.swtbot.eclipse.junit.headless/META-INF/MANIFEST.MF
index 97601acd..25f1c918 100644
--- a/org.eclipse.swtbot.eclipse.junit.headless/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.eclipse.junit.headless/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Bundle-SymbolicName: org.eclipse.swtbot.eclipse.junit.headless;singleton:=true
Bundle-Version: 2.6.0.qualifier
Bundle-Vendor: Eclipse.org - SWTBot
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Export-Package: org.eclipse.swtbot.eclipse.junit.headless
Import-Package: junit.framework;version="4.5.0",
org.apache.tools.ant,
diff --git a/org.eclipse.swtbot.eclipse.spy/.classpath b/org.eclipse.swtbot.eclipse.spy/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.eclipse.spy/.classpath
+++ b/org.eclipse.swtbot.eclipse.spy/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.eclipse.spy/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.eclipse.spy/.settings/org.eclipse.jdt.core.prefs
index c61b5715..ef8a789c 100644
--- a/org.eclipse.swtbot.eclipse.spy/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.eclipse.spy/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,12 @@
-#Tue Dec 16 23:22:48 IST 2008
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
+org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.debug.lineNumber=generate
+org.eclipse.jdt.core.compiler.debug.localVariable=generate
+org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.eclipse.spy/META-INF/MANIFEST.MF b/org.eclipse.swtbot.eclipse.spy/META-INF/MANIFEST.MF
index 509a4b99..acce9a99 100644
--- a/org.eclipse.swtbot.eclipse.spy/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.eclipse.spy/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Version: 2.6.0.qualifier
Bundle-Activator: org.eclipse.swtbot.eclipse.spy.Activator
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-Vendor: Eclipse.org - SWTBot
Export-Package: org.eclipse.swtbot.eclipse.spy,
org.eclipse.swtbot.eclipse.spy.views
diff --git a/org.eclipse.swtbot.eclipse.ui.test/.classpath b/org.eclipse.swtbot.eclipse.ui.test/.classpath
index ba349240..394e58fd 100644
--- a/org.eclipse.swtbot.eclipse.ui.test/.classpath
+++ b/org.eclipse.swtbot.eclipse.ui.test/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="src" path="functional"/>
diff --git a/org.eclipse.swtbot.eclipse.ui.test/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.eclipse.ui.test/.settings/org.eclipse.jdt.core.prefs
index 0c8b3d5e..1db781d4 100644
--- a/org.eclipse.swtbot.eclipse.ui.test/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.eclipse.ui.test/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,12 @@
-#Tue Dec 16 23:22:43 IST 2008
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
+org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.debug.lineNumber=generate
+org.eclipse.jdt.core.compiler.debug.localVariable=generate
+org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.doc.comment.support=disabled
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
@@ -18,4 +22,4 @@ org.eclipse.jdt.core.compiler.problem.missingJavadocTagDescription=all_standard_
org.eclipse.jdt.core.compiler.problem.missingJavadocTags=warning
org.eclipse.jdt.core.compiler.problem.missingJavadocTagsOverriding=disabled
org.eclipse.jdt.core.compiler.problem.missingJavadocTagsVisibility=protected
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.eclipse.ui.test/META-INF/MANIFEST.MF b/org.eclipse.swtbot.eclipse.ui.test/META-INF/MANIFEST.MF
index 07ea4dea..959e77d4 100644
--- a/org.eclipse.swtbot.eclipse.ui.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.eclipse.ui.test/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: SWTBot Eclipse UI Tests Plug-in
Bundle-SymbolicName: org.eclipse.swtbot.eclipse.ui.test
Bundle-Version: 2.6.0.qualifier
Bundle-Vendor: Eclipse.org - SWTBot
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Fragment-Host: org.eclipse.swtbot.eclipse.ui
Require-Bundle: org.eclipse.swtbot.go,
org.hamcrest.library
diff --git a/org.eclipse.swtbot.eclipse.ui.test/functional/org/eclipse/swtbot/eclipse/ui/functional/ProjectCreationWizardTest.java b/org.eclipse.swtbot.eclipse.ui.test/functional/org/eclipse/swtbot/eclipse/ui/functional/ProjectCreationWizardTest.java
index 46663be4..61434a0e 100644
--- a/org.eclipse.swtbot.eclipse.ui.test/functional/org/eclipse/swtbot/eclipse/ui/functional/ProjectCreationWizardTest.java
+++ b/org.eclipse.swtbot.eclipse.ui.test/functional/org/eclipse/swtbot/eclipse/ui/functional/ProjectCreationWizardTest.java
@@ -1,5 +1,5 @@
/*******************************************************************************
- * Copyright (c) 2010 Ketan Padegaonkar and others.
+ * Copyright (c) 2010, 2017 Ketan Padegaonkar and others.
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License v1.0
* which accompanies this distribution, and is available at
@@ -48,7 +48,7 @@ public class ProjectCreationWizardTest {
"Bundle-Version: 1.0.0.qualifier\n" +
"Bundle-ActivationPolicy: lazy\n" +
"Bundle-Vendor: ACME Corp.\n" +
- "Bundle-RequiredExecutionEnvironment: J2SE-1.5\n" +
+ "Bundle-RequiredExecutionEnvironment: JavaSE-1.6\n" +
"Require-Bundle: org.eclipse.swtbot.go\n" +
"", contentsOf(project, "META-INF/MANIFEST.MF"));
@@ -95,7 +95,7 @@ public class ProjectCreationWizardTest {
"<classpath>\n" +
" <classpathentry kind=\"con\" " +
"path=\"org.eclipse.jdt.launching.JRE_CONTAINER/" +
- "org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5\"/>\n" +
+ "org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6\"/>\n" +
" <classpathentry kind=\"con\" path=\"org.eclipse.pde.core.requiredPlugins\"/>\n" +
" <classpathentry kind=\"src\" path=\"src\"/>\n" +
" <classpathentry kind=\"output\" path=\"bin\"/>\n" +
diff --git a/org.eclipse.swtbot.eclipse.ui.test/src/org/eclipse/swtbot/eclipse/ui/project/TemplatizerTest.java b/org.eclipse.swtbot.eclipse.ui.test/src/org/eclipse/swtbot/eclipse/ui/project/TemplatizerTest.java
index 9dfe20c0..5a922169 100644
--- a/org.eclipse.swtbot.eclipse.ui.test/src/org/eclipse/swtbot/eclipse/ui/project/TemplatizerTest.java
+++ b/org.eclipse.swtbot.eclipse.ui.test/src/org/eclipse/swtbot/eclipse/ui/project/TemplatizerTest.java
@@ -1,5 +1,5 @@
/*******************************************************************************
- * Copyright (c) 2010 Ketan Padegaonkar and others.
+ * Copyright (c) 2010, 2017 Ketan Padegaonkar and others.
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License v1.0
* which accompanies this distribution, and is available at
@@ -27,7 +27,7 @@ public class TemplatizerTest {
"Bundle-Version: @PLUGIN_VERSION@\n" +
"Bundle-ActivationPolicy: lazy\n" +
"Bundle-Vendor: @PLUGIN_PROVIDER@\n" +
- "Bundle-RequiredExecutionEnvironment: J2SE-1.5\n" +
+ "Bundle-RequiredExecutionEnvironment: JavaSE-1.6\n" +
"Require-Bundle: org.eclipse.swtbot.go\n" +
"");
assertEquals("" +
@@ -38,7 +38,7 @@ public class TemplatizerTest {
"Bundle-Version: 1.2.3.4\n" +
"Bundle-ActivationPolicy: lazy\n" +
"Bundle-Vendor: Eclipse.org\n" +
- "Bundle-RequiredExecutionEnvironment: J2SE-1.5\n" +
+ "Bundle-RequiredExecutionEnvironment: JavaSE-1.6\n" +
"Require-Bundle: org.eclipse.swtbot.go\n" +
"", templatize);
}
diff --git a/org.eclipse.swtbot.eclipse.ui/.classpath b/org.eclipse.swtbot.eclipse.ui/.classpath
index 41098a31..c43082f0 100644
--- a/org.eclipse.swtbot.eclipse.ui/.classpath
+++ b/org.eclipse.swtbot.eclipse.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="**"/>
diff --git a/org.eclipse.swtbot.eclipse.ui/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.eclipse.ui/.settings/org.eclipse.jdt.core.prefs
index 6c31064d..ef8a789c 100644
--- a/org.eclipse.swtbot.eclipse.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.eclipse.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,12 @@
-#Tue Dec 16 23:22:44 IST 2008
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
+org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.debug.lineNumber=generate
+org.eclipse.jdt.core.compiler.debug.localVariable=generate
+org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.eclipse.ui/META-INF/MANIFEST.MF b/org.eclipse.swtbot.eclipse.ui/META-INF/MANIFEST.MF
index 727667a1..35a211f0 100644
--- a/org.eclipse.swtbot.eclipse.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.eclipse.ui/META-INF/MANIFEST.MF
@@ -11,7 +11,7 @@ Export-Package: org.eclipse.swtbot.eclipse.ui,
org.eclipse.swtbot.eclipse.ui.preferences,
org.eclipse.swtbot.eclipse.ui.project,
org.eclipse.swtbot.eclipse.ui.wizards
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Import-Package: org.eclipse.core.resources,
org.eclipse.core.runtime,
org.eclipse.core.runtime.jobs,
diff --git a/org.eclipse.swtbot.eclipse.ui/src/org/eclipse/swtbot/eclipse/ui/project/_MANIFEST.MF b/org.eclipse.swtbot.eclipse.ui/src/org/eclipse/swtbot/eclipse/ui/project/_MANIFEST.MF
index b4631e69..0ede45ff 100644
--- a/org.eclipse.swtbot.eclipse.ui/src/org/eclipse/swtbot/eclipse/ui/project/_MANIFEST.MF
+++ b/org.eclipse.swtbot.eclipse.ui/src/org/eclipse/swtbot/eclipse/ui/project/_MANIFEST.MF
@@ -5,5 +5,5 @@ Bundle-SymbolicName: @PLUGIN_ID@;singleton:=true
Bundle-Version: @PLUGIN_VERSION@
Bundle-ActivationPolicy: lazy
Bundle-Vendor: @PLUGIN_PROVIDER@
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Require-Bundle: org.eclipse.swtbot.go
diff --git a/org.eclipse.swtbot.eclipse.ui/src/org/eclipse/swtbot/eclipse/ui/project/_classpath b/org.eclipse.swtbot.eclipse.ui/src/org/eclipse/swtbot/eclipse/ui/project/_classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.eclipse.ui/src/org/eclipse/swtbot/eclipse/ui/project/_classpath
+++ b/org.eclipse.swtbot.eclipse.ui/src/org/eclipse/swtbot/eclipse/ui/project/_classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.forms.finder.test/.classpath b/org.eclipse.swtbot.forms.finder.test/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.forms.finder.test/.classpath
+++ b/org.eclipse.swtbot.forms.finder.test/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.forms.finder.test/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.forms.finder.test/.settings/org.eclipse.jdt.core.prefs
index ff6e5253..ef8a789c 100644
--- a/org.eclipse.swtbot.forms.finder.test/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.forms.finder.test/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,12 @@
-#Tue Mar 01 22:21:58 PST 2011
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
+org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.debug.lineNumber=generate
+org.eclipse.jdt.core.compiler.debug.localVariable=generate
+org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.forms.finder.test/META-INF/MANIFEST.MF b/org.eclipse.swtbot.forms.finder.test/META-INF/MANIFEST.MF
index 52176841..81d6707a 100644
--- a/org.eclipse.swtbot.forms.finder.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.forms.finder.test/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: SWTBot Forms Tests Plug-in
Bundle-SymbolicName: org.eclipse.swtbot.forms.finder.test;singleton:=true
Bundle-Version: 2.6.0.qualifier
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Require-Bundle: org.eclipse.swt,
org.eclipse.jface,
org.eclipse.swt.examples,
diff --git a/org.eclipse.swtbot.forms.finder/.classpath b/org.eclipse.swtbot.forms.finder/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.forms.finder/.classpath
+++ b/org.eclipse.swtbot.forms.finder/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.forms.finder/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.forms.finder/.settings/org.eclipse.jdt.core.prefs
index 7f611272..ef8a789c 100644
--- a/org.eclipse.swtbot.forms.finder/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.forms.finder/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,12 @@
-#Mon May 03 03:39:51 CDT 2010
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
+org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.debug.lineNumber=generate
+org.eclipse.jdt.core.compiler.debug.localVariable=generate
+org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.forms.finder/META-INF/MANIFEST.MF b/org.eclipse.swtbot.forms.finder/META-INF/MANIFEST.MF
index cef83922..04f71bb2 100644
--- a/org.eclipse.swtbot.forms.finder/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.forms.finder/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.swtbot.forms.finder
Bundle-Version: 2.6.0.qualifier
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Require-Bundle: org.eclipse.swtbot.swt.finder,
org.hamcrest.core;bundle-version="1.1.0"
Import-Package: org.apache.log4j;version="[1.2.13,1.3.0)",
diff --git a/org.eclipse.swtbot.generator.jdt.test/.classpath b/org.eclipse.swtbot.generator.jdt.test/.classpath
index e721d0c4..ad32c83a 100644
--- a/org.eclipse.swtbot.generator.jdt.test/.classpath
+++ b/org.eclipse.swtbot.generator.jdt.test/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
- <classpathentry kind="src" path="src/"/>
+ <classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/org.eclipse.swtbot.generator.jdt.test/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.generator.jdt.test/.settings/org.eclipse.jdt.core.prefs
index eb1cb4cf..ef8a789c 100644
--- a/org.eclipse.swtbot.generator.jdt.test/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.generator.jdt.test/.settings/org.eclipse.jdt.core.prefs
@@ -1,12 +1,12 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.generator.jdt.test/META-INF/MANIFEST.MF b/org.eclipse.swtbot.generator.jdt.test/META-INF/MANIFEST.MF
index 9c54fcf7..55d00344 100644
--- a/org.eclipse.swtbot.generator.jdt.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.generator.jdt.test/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: SWTBot Test Recorder & Code Generator JDT Tests Plug-in
Bundle-SymbolicName: org.eclipse.swtbot.generator.jdt.test
Bundle-Version: 2.6.0.qualifier
Bundle-Vendor: Eclipse.org - SWTBot
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Require-Bundle: org.junit;bundle-version="4.7.0",
org.eclipse.swt,
org.eclipse.swtbot.swt.finder;bundle-version="2.1.2",
diff --git a/org.eclipse.swtbot.generator.jdt/.classpath b/org.eclipse.swtbot.generator.jdt/.classpath
index 246ed015..be5416be 100644
--- a/org.eclipse.swtbot.generator.jdt/.classpath
+++ b/org.eclipse.swtbot.generator.jdt/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
- <classpathentry kind="src" path="src/"/>
+ <classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin/"/>
</classpath>
diff --git a/org.eclipse.swtbot.generator.jdt/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.generator.jdt/.settings/org.eclipse.jdt.core.prefs
index eb1cb4cf..ef8a789c 100644
--- a/org.eclipse.swtbot.generator.jdt/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.generator.jdt/.settings/org.eclipse.jdt.core.prefs
@@ -1,12 +1,12 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.generator.jdt/META-INF/MANIFEST.MF b/org.eclipse.swtbot.generator.jdt/META-INF/MANIFEST.MF
index 30910571..85762167 100644
--- a/org.eclipse.swtbot.generator.jdt/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.generator.jdt/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: SWTBot Test Recorder & Code Generator JDT Plug-in
Bundle-SymbolicName: org.eclipse.swtbot.generator.jdt;singleton:=true
Bundle-Version: 2.6.0.qualifier
Bundle-Vendor: Eclipse.org - SWTBot
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ClassPath: .
Import-Package: org.eclipse.ui.texteditor
Require-Bundle: org.eclipse.ui,
diff --git a/org.eclipse.swtbot.generator.test/.classpath b/org.eclipse.swtbot.generator.test/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.generator.test/.classpath
+++ b/org.eclipse.swtbot.generator.test/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.generator.test/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.generator.test/.settings/org.eclipse.jdt.core.prefs
index af0f20f9..c537b630 100644
--- a/org.eclipse.swtbot.generator.test/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.generator.test/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,7 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.generator.test/META-INF/MANIFEST.MF b/org.eclipse.swtbot.generator.test/META-INF/MANIFEST.MF
index 5d8152a7..de4894d1 100644
--- a/org.eclipse.swtbot.generator.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.generator.test/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: SWTBot Test Recorder & Code Generator Tests Plug-in
Bundle-SymbolicName: org.eclipse.swtbot.generator.test
Bundle-Version: 2.6.0.qualifier
Bundle-Vendor: Eclipse.org - SWTBot
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Require-Bundle: org.junit;bundle-version="4.7.0",
org.eclipse.swt,
org.eclipse.swtbot.swt.finder;bundle-version="2.1.1",
diff --git a/org.eclipse.swtbot.generator/.classpath b/org.eclipse.swtbot.generator/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.generator/.classpath
+++ b/org.eclipse.swtbot.generator/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.generator/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.generator/.settings/org.eclipse.jdt.core.prefs
index 6fbfbca7..1db781d4 100644
--- a/org.eclipse.swtbot.generator/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.generator/.settings/org.eclipse.jdt.core.prefs
@@ -1,9 +1,9 @@
-#Mon Oct 06 09:51:29 IST 2008
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -22,4 +22,4 @@ org.eclipse.jdt.core.compiler.problem.missingJavadocTagDescription=all_standard_
org.eclipse.jdt.core.compiler.problem.missingJavadocTags=warning
org.eclipse.jdt.core.compiler.problem.missingJavadocTagsOverriding=disabled
org.eclipse.jdt.core.compiler.problem.missingJavadocTagsVisibility=protected
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.generator/META-INF/MANIFEST.MF b/org.eclipse.swtbot.generator/META-INF/MANIFEST.MF
index 88dda16a..7b59164b 100644
--- a/org.eclipse.swtbot.generator/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.generator/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: SWTBot Test Recorder & Code Generator Plug-in
Bundle-SymbolicName: org.eclipse.swtbot.generator;singleton:=true
Bundle-Version: 2.6.0.qualifier
Bundle-Vendor: Eclipse.org - SWTBot
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ClassPath: .
Export-Package: org.eclipse.swtbot.generator,
org.eclipse.swtbot.generator.framework,
diff --git a/org.eclipse.swtbot.go/META-INF/MANIFEST.MF b/org.eclipse.swtbot.go/META-INF/MANIFEST.MF
index b59ff8cc..4e71f1d6 100644
--- a/org.eclipse.swtbot.go/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.go/META-INF/MANIFEST.MF
@@ -13,5 +13,5 @@ Require-Bundle: org.eclipse.swtbot.eclipse.core;visibility:=reexport,
org.apache.log4j;visibility:=reexport,
org.eclipse.swt;visibility:=reexport,
org.eclipse.ui;visibility:=reexport
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-Vendor: Eclipse.org - SWTBot
diff --git a/org.eclipse.swtbot.junit4_x/.classpath b/org.eclipse.swtbot.junit4_x/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.junit4_x/.classpath
+++ b/org.eclipse.swtbot.junit4_x/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.junit4_x/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.junit4_x/.settings/org.eclipse.jdt.core.prefs
index 1c7ffd54..c537b630 100644
--- a/org.eclipse.swtbot.junit4_x/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.junit4_x/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Tue Feb 03 01:22:08 IST 2009
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.junit4_x/META-INF/MANIFEST.MF b/org.eclipse.swtbot.junit4_x/META-INF/MANIFEST.MF
index ec69077b..c36861e7 100644
--- a/org.eclipse.swtbot.junit4_x/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.junit4_x/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: SWTBot JUnit 4.x Runners Plug-in
Bundle-SymbolicName: org.eclipse.swtbot.junit4_x
Bundle-Version: 2.6.0.qualifier
Bundle-Vendor: Eclipse.org - SWTBot
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Export-Package: org.eclipse.swtbot.swt.finder.junit
Import-Package: org.apache.log4j;version="1.2.12",
org.eclipse.swt.widgets,
diff --git a/org.eclipse.swtbot.nebula.gallery.finder.test/.classpath b/org.eclipse.swtbot.nebula.gallery.finder.test/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.nebula.gallery.finder.test/.classpath
+++ b/org.eclipse.swtbot.nebula.gallery.finder.test/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.nebula.gallery.finder.test/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.nebula.gallery.finder.test/.settings/org.eclipse.jdt.core.prefs
index af0f20f9..c537b630 100644
--- a/org.eclipse.swtbot.nebula.gallery.finder.test/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.nebula.gallery.finder.test/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,7 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.nebula.gallery.finder.test/META-INF/MANIFEST.MF b/org.eclipse.swtbot.nebula.gallery.finder.test/META-INF/MANIFEST.MF
index 838e7b89..f4469e19 100644
--- a/org.eclipse.swtbot.nebula.gallery.finder.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.nebula.gallery.finder.test/META-INF/MANIFEST.MF
@@ -12,5 +12,5 @@ Require-Bundle: org.eclipse.ui,
org.junit;bundle-version="4.8.1",
org.eclipse.swtbot.junit4_x;bundle-version="2.0.0",
org.eclipse.swtbot.swt.finder;bundle-version="2.0.0"
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ActivationPolicy: lazy
diff --git a/org.eclipse.swtbot.nebula.gallery.finder/.classpath b/org.eclipse.swtbot.nebula.gallery.finder/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.nebula.gallery.finder/.classpath
+++ b/org.eclipse.swtbot.nebula.gallery.finder/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.nebula.gallery.finder/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.nebula.gallery.finder/.settings/org.eclipse.jdt.core.prefs
index b49ecdc5..c537b630 100644
--- a/org.eclipse.swtbot.nebula.gallery.finder/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.nebula.gallery.finder/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Fri Sep 10 23:26:19 CEST 2010
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.nebula.gallery.finder/META-INF/MANIFEST.MF b/org.eclipse.swtbot.nebula.gallery.finder/META-INF/MANIFEST.MF
index b2854de1..395c5e0a 100644
--- a/org.eclipse.swtbot.nebula.gallery.finder/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.nebula.gallery.finder/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Require-Bundle: org.eclipse.swtbot.swt.finder;bundle-version="2.0.0",
org.eclipse.swtbot.eclipse.finder;bundle-version="2.0.3",
org.hamcrest.core;bundle-version="1.1.0"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Import-Package: org.apache.log4j;version="1.2.15",
org.eclipse.jface.bindings.keys,
org.eclipse.swt,
diff --git a/org.eclipse.swtbot.swt.demo/.classpath b/org.eclipse.swtbot.swt.demo/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.swt.demo/.classpath
+++ b/org.eclipse.swtbot.swt.demo/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.swt.demo/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.swt.demo/.settings/org.eclipse.jdt.core.prefs
index 957d3a23..5b334014 100644
--- a/org.eclipse.swtbot.swt.demo/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.swt.demo/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Tue Dec 16 23:22:39 IST 2008
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.doc.comment.support=disabled
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
@@ -18,4 +17,4 @@ org.eclipse.jdt.core.compiler.problem.missingJavadocTagDescription=all_tags
org.eclipse.jdt.core.compiler.problem.missingJavadocTags=warning
org.eclipse.jdt.core.compiler.problem.missingJavadocTagsOverriding=disabled
org.eclipse.jdt.core.compiler.problem.missingJavadocTagsVisibility=default
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.swt.demo/META-INF/MANIFEST.MF b/org.eclipse.swtbot.swt.demo/META-INF/MANIFEST.MF
index 645c34f8..7d6c6e04 100644
--- a/org.eclipse.swtbot.swt.demo/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.swt.demo/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Bundle-SymbolicName: org.eclipse.swtbot.swt.demo;singleton:=true
Bundle-Version: 2.6.0.qualifier
Bundle-Vendor: Eclipse.org - SWTBot
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ClassPath: .
Export-Package: org.eclipse.swtbot.swt.demo
Import-Package: org.eclipse.swt,
diff --git a/org.eclipse.swtbot.swt.finder.test.keyboards/.classpath b/org.eclipse.swtbot.swt.finder.test.keyboards/.classpath
index 64c5e31b..ad32c83a 100644
--- a/org.eclipse.swtbot.swt.finder.test.keyboards/.classpath
+++ b/org.eclipse.swtbot.swt.finder.test.keyboards/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.swtbot.swt.finder.test.keyboards/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.swt.finder.test.keyboards/.settings/org.eclipse.jdt.core.prefs
index 5ce59190..c537b630 100644
--- a/org.eclipse.swtbot.swt.finder.test.keyboards/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.swt.finder.test.keyboards/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Fri Oct 07 13:26:08 CEST 2011
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.swt.finder.test.keyboards/META-INF/MANIFEST.MF b/org.eclipse.swtbot.swt.finder.test.keyboards/META-INF/MANIFEST.MF
index 82c763d6..e2ee971c 100644
--- a/org.eclipse.swtbot.swt.finder.test.keyboards/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.swt.finder.test.keyboards/META-INF/MANIFEST.MF
@@ -5,4 +5,4 @@ Bundle-SymbolicName: org.eclipse.swtbot.swt.finder.test.keyboards
Bundle-Version: 2.6.0.qualifier
Bundle-Vendor: Eclipse.org - SWTBot
Fragment-Host: org.eclipse.swtbot.swt.finder;bundle-version="2.1.0"
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/org.eclipse.swtbot.swt.finder.test/.classpath b/org.eclipse.swtbot.swt.finder.test/.classpath
index 41098a31..c43082f0 100644
--- a/org.eclipse.swtbot.swt.finder.test/.classpath
+++ b/org.eclipse.swtbot.swt.finder.test/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="**"/>
diff --git a/org.eclipse.swtbot.swt.finder.test/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.swt.finder.test/.settings/org.eclipse.jdt.core.prefs
index 48730ae4..b1560e87 100644
--- a/org.eclipse.swtbot.swt.finder.test/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.swt.finder.test/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Tue Dec 16 23:22:37 IST 2008
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.doc.comment.support=enabled
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
@@ -18,4 +17,4 @@ org.eclipse.jdt.core.compiler.problem.missingJavadocTagDescription=all_tags
org.eclipse.jdt.core.compiler.problem.missingJavadocTags=ignore
org.eclipse.jdt.core.compiler.problem.missingJavadocTagsOverriding=disabled
org.eclipse.jdt.core.compiler.problem.missingJavadocTagsVisibility=default
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.swt.finder.test/META-INF/MANIFEST.MF b/org.eclipse.swtbot.swt.finder.test/META-INF/MANIFEST.MF
index 169467f1..81ce6828 100644
--- a/org.eclipse.swtbot.swt.finder.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.swt.finder.test/META-INF/MANIFEST.MF
@@ -15,4 +15,4 @@ Require-Bundle: org.eclipse.swt,
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
Bundle-Vendor: Eclipse.org - SWTBot
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/org.eclipse.swtbot.swt.finder/.classpath b/org.eclipse.swtbot.swt.finder/.classpath
index 41098a31..c43082f0 100644
--- a/org.eclipse.swtbot.swt.finder/.classpath
+++ b/org.eclipse.swtbot.swt.finder/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="**"/>
diff --git a/org.eclipse.swtbot.swt.finder/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.swtbot.swt.finder/.settings/org.eclipse.jdt.core.prefs
index 59bd17f2..c537b630 100644
--- a/org.eclipse.swtbot.swt.finder/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.swtbot.swt.finder/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Tue Dec 16 23:22:38 IST 2008
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.swtbot.swt.finder/META-INF/MANIFEST.MF b/org.eclipse.swtbot.swt.finder/META-INF/MANIFEST.MF
index d585d462..2f9a099b 100644
--- a/org.eclipse.swtbot.swt.finder/META-INF/MANIFEST.MF
+++ b/org.eclipse.swtbot.swt.finder/META-INF/MANIFEST.MF
@@ -17,7 +17,7 @@ Export-Package: org.eclipse.swtbot.swt.finder,
org.eclipse.swtbot.swt.finder.waits,
org.eclipse.swtbot.swt.finder.widgets
Bundle-Vendor: Eclipse.org - SWTBot
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Eclipse-BuddyPolicy: registered
Import-Package: junit.framework;version="4.12.0",
org.apache.log4j;version="[1.2.13,1.3.0)",
diff --git a/org.eclipse.swtbot.swt.finder/src/org/eclipse/swtbot/swt/finder/widgets/AbstractSWTBot.java b/org.eclipse.swtbot.swt.finder/src/org/eclipse/swtbot/swt/finder/widgets/AbstractSWTBot.java
index 02d46163..29063028 100644
--- a/org.eclipse.swtbot.swt.finder/src/org/eclipse/swtbot/swt/finder/widgets/AbstractSWTBot.java
+++ b/org.eclipse.swtbot.swt.finder/src/org/eclipse/swtbot/swt/finder/widgets/AbstractSWTBot.java
@@ -1088,7 +1088,7 @@ public abstract class AbstractSWTBot<T extends Widget> {
dndEvent.widget = widget;
dndEvent.display = display;
return dndEvent;
- } catch (ReflectiveOperationException e) {
+ } catch (Exception e) {
throw new UnsupportedOperationException(e);
}
}
@@ -1115,7 +1115,7 @@ public abstract class AbstractSWTBot<T extends Widget> {
Field field = clazz.getDeclaredField(fieldName);
field.setAccessible(true);
field.set(dndEvent, value);
- } catch (ReflectiveOperationException e) {
+ } catch (Exception e) {
throw new UnsupportedOperationException(e);
}
}
@@ -1126,7 +1126,7 @@ public abstract class AbstractSWTBot<T extends Widget> {
Field field = clazz.getDeclaredField(fieldName);
field.setAccessible(true);
return field.get(dndEvent);
- } catch (ReflectiveOperationException e) {
+ } catch (Exception e) {
throw new UnsupportedOperationException(e);
}
}
diff --git a/org.eclipse.swtbot.swt.finder/src/org/eclipse/swtbot/swt/finder/widgets/SWTBotLink.java b/org.eclipse.swtbot.swt.finder/src/org/eclipse/swtbot/swt/finder/widgets/SWTBotLink.java
index 38fde412..5f795321 100644
--- a/org.eclipse.swtbot.swt.finder/src/org/eclipse/swtbot/swt/finder/widgets/SWTBotLink.java
+++ b/org.eclipse.swtbot.swt.finder/src/org/eclipse/swtbot/swt/finder/widgets/SWTBotLink.java
@@ -83,7 +83,7 @@ public class SWTBotLink extends AbstractSWTBotControl<Link> {
if (linkIndex >= 0 && linkIndex < ids.length) {
hyperlinkText = ids[linkIndex];
}
- } catch (ReflectiveOperationException e) {
+ } catch (Exception e) {
throw new UnsupportedOperationException(e);
}
notify(SWT.MouseEnter, createMouseEvent(0, 0, 0, SWT.NONE, 0));
diff --git a/org.eclipse.ui.forms.examples/.classpath b/org.eclipse.ui.forms.examples/.classpath
index 2fbb7a23..ad32c83a 100755
--- a/org.eclipse.ui.forms.examples/.classpath
+++ b/org.eclipse.ui.forms.examples/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/org.eclipse.ui.forms.examples/.settings/org.eclipse.jdt.core.prefs b/org.eclipse.ui.forms.examples/.settings/org.eclipse.jdt.core.prefs
index 9d6b2a2f..ffee535e 100755
--- a/org.eclipse.ui.forms.examples/.settings/org.eclipse.jdt.core.prefs
+++ b/org.eclipse.ui.forms.examples/.settings/org.eclipse.jdt.core.prefs
@@ -1,17 +1,16 @@
-#Mon Nov 30 14:26:46 PST 2009
eclipse.preferences.version=1
-org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=disabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
-org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.problem.annotationSuperInterface=warning
-org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.autoboxing=ignore
org.eclipse.jdt.core.compiler.problem.deprecation=warning
org.eclipse.jdt.core.compiler.problem.deprecationInDeprecatedCode=disabled
org.eclipse.jdt.core.compiler.problem.deprecationWhenOverridingDeprecatedMethod=disabled
org.eclipse.jdt.core.compiler.problem.discouragedReference=warning
org.eclipse.jdt.core.compiler.problem.emptyStatement=ignore
-org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
org.eclipse.jdt.core.compiler.problem.fieldHiding=ignore
org.eclipse.jdt.core.compiler.problem.finalParameterBound=warning
org.eclipse.jdt.core.compiler.problem.finallyBlockNotCompletingNormally=warning
@@ -50,4 +49,4 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenImplementingAbstract=di
org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disabled
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=error
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.3
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/org.eclipse.ui.forms.examples/META-INF/MANIFEST.MF b/org.eclipse.ui.forms.examples/META-INF/MANIFEST.MF
index a5ffb000..90906758 100644
--- a/org.eclipse.ui.forms.examples/META-INF/MANIFEST.MF
+++ b/org.eclipse.ui.forms.examples/META-INF/MANIFEST.MF
@@ -17,4 +17,4 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.ui.ide
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.4
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6

Back to the top