Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Charles David2017-04-03 07:53:50 +0000
committerPierre-Charles David2017-04-11 07:40:12 +0000
commit804aafa0862320435715b22100054bc4ddbfd8ed (patch)
tree4d719910e7a7275b09c45c36363874a84ff08b87 /plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF
parent98564daf468c2ee448efe0637c545218c6c9f2d9 (diff)
downloadorg.eclipse.sirius-804aafa0862320435715b22100054bc4ddbfd8ed.tar.gz
org.eclipse.sirius-804aafa0862320435715b22100054bc4ddbfd8ed.tar.xz
org.eclipse.sirius-804aafa0862320435715b22100054bc4ddbfd8ed.zip
[507474] Make sure Sirius 5.0 is compatible with Guava 21
Eclipse Oxygen may switch to Guava 21 as the default (only?) version in the SimRel, so we need to make sure we're compatible with it. * Open the version ranges to include Guava 21. * Remove all usages of Objects.firstNonNull(), which does not exist anymore in Guava 21. Not that at this point, other dependencies of Sirius have different version constraints, so it's not enough to ensure v21 is the one resolved: * org.eclipse.xtext.xbase.lib 2.11.0.v20170124-1424: [14.0.0,19.0.0) * org.eclipse.xtext.util 2.11.0.v20170130-0808: [14.0.0,19.0.0) Xtext considers moving to Guava 21 for v2.12, see https://github.com/eclipse/xtext-lib/issues/30. In the meantime, the build still resolves to Guava 15, but a test was made by removing Xtext from the build, and Sirius builds fine when forcing Guava 21 to be really used. Bug: 507474 Change-Id: I178bcd70fe3fba95cda247473d1ed18f5206acc9 Signed-off-by: Pierre-Charles David <pierre-charles.david@obeo.fr>
Diffstat (limited to 'plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF')
-rw-r--r--plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF2
1 files changed, 1 insertions, 1 deletions
diff --git a/plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF
index 67caf497c0..b9230852c5 100644
--- a/plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF
@@ -44,7 +44,7 @@ Export-Package: org.eclipse.sirius.diagram.sequence;version="2.1.0",
org.eclipse.sirius.diagram.sequence.util;version="3.0.0"
Require-Bundle: org.eclipse.sirius.common;bundle-version="4.0.0",
org.eclipse.sirius.ecore.extender;bundle-version="4.0.0",
- com.google.guava;bundle-version="[11.0.2,16.0)",
+ com.google.guava;bundle-version="[11.0.2,22.0)",
org.eclipse.gmf.runtime.notation;bundle-version="1.5.0",
org.eclipse.draw2d;bundle-version="3.9.0",
org.eclipse.sirius.diagram;bundle-version="4.0.0";visibility:=reexport,

Back to the top