Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Charles David2013-12-12 11:34:23 +0000
committerPierre-Charles David2013-12-23 20:39:13 +0000
commit0598ec95050b7744fd406ac39433d2d2b52b2a10 (patch)
tree367dc6bf1e1b9849f58c3e47a483b0416ca9d310 /plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF
parent8f17d131225445b76fac0951e2e800e798438538 (diff)
downloadorg.eclipse.sirius-0598ec95050b7744fd406ac39433d2d2b52b2a10.tar.gz
org.eclipse.sirius-0598ec95050b7744fd406ac39433d2d2b52b2a10.tar.xz
org.eclipse.sirius-0598ec95050b7744fd406ac39433d2d2b52b2a10.zip
[423562] Tighten the PDE configuration of all plug-ins
All Sirius plug-ins now have the same project-specific PDE settings, which were made more strict. All the errors resulting from the new rules were fixed. The (many) new warnings were left for now. The most visible change is that all the Require-Bundle dependencies in Sirius plug-ins are now versioned, using the version available at this time in the sirius_juno.target target platform as the minimum version. Change-Id: Icc4f69139f7735719f158c14b6e8d5a0bb5582f3 Signed-off-by: Pierre-Charles David <pierre-charles.david@obeo.fr>
Diffstat (limited to 'plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF')
-rw-r--r--plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF16
1 files changed, 8 insertions, 8 deletions
diff --git a/plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF
index a31a2fa5c9..a6b290fa36 100644
--- a/plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF
@@ -41,17 +41,17 @@ Export-Package: org.eclipse.sirius.diagram.sequence,
org.eclipse.sirius.diagram.sequence.template.util,
org.eclipse.sirius.diagram.sequence.tool.internal.action.repair;x-internal:=true,
org.eclipse.sirius.diagram.sequence.util
-Require-Bundle: org.eclipse.sirius.common,
- org.eclipse.sirius.ecore.extender,
+Require-Bundle: org.eclipse.sirius.common;bundle-version="1.0.0",
+ org.eclipse.sirius.ecore.extender;bundle-version="1.0.0",
com.google.guava;bundle-version="[11.0.0,12.0.0)",
- org.eclipse.gmf.runtime.notation,
+ org.eclipse.gmf.runtime.notation;bundle-version="1.5.0",
org.eclipse.gmf.runtime.draw2d.ui;bundle-version="1.0.101",
- org.eclipse.draw2d,
- org.eclipse.sirius.diagram;visibility:=reexport;bundle-version="1.0.0",
+ org.eclipse.draw2d;bundle-version="3.9.0",
+ org.eclipse.sirius.diagram;bundle-version="1.0.0";visibility:=reexport,
org.eclipse.emf.transaction;bundle-version="1.1.2",
- org.eclipse.core.runtime,
- org.eclipse.emf.ecore;visibility:=reexport,
- org.eclipse.sirius;visibility:=reexport
+ org.eclipse.core.runtime;bundle-version="3.8.0",
+ org.eclipse.emf.ecore;bundle-version="2.8.3";visibility:=reexport,
+ org.eclipse.sirius;bundle-version="1.0.0";visibility:=reexport
Eclipse-LazyStart: true
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.6

Back to the top