Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Charles David2016-02-04 09:36:28 +0000
committerPierre-Charles David2016-02-10 16:26:58 +0000
commit07a55b276354df57870fde3f1640207287d890f2 (patch)
tree98ecb4ad76487c5ea124019bb4c19c689567bd48
parentbc5989607c7b6815e7742cc279a4985dc1a731f8 (diff)
downloadorg.eclipse.sirius-07a55b276354df57870fde3f1640207287d890f2.tar.gz
org.eclipse.sirius-07a55b276354df57870fde3f1640207287d890f2.tar.xz
org.eclipse.sirius-07a55b276354df57870fde3f1640207287d890f2.zip
[version] Move to Java 1.7 as minimum required version
Change-Id: I5d14403e693ab23483f89b75142cb46afc61ec04 Signed-off-by: Pierre-Charles David <pierre-charles.david@obeo.fr>
-rw-r--r--incubation/org.eclipse.sirius.properties.edit/META-INF/MANIFEST.MF2
-rw-r--r--incubation/org.eclipse.sirius.properties/.classpath2
-rw-r--r--incubation/org.eclipse.sirius.properties/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--incubation/org.eclipse.sirius.properties/META-INF/MANIFEST.MF2
-rw-r--r--incubation/org.eclipse.sirius.sample.properties.checkbox/META-INF/MANIFEST.MF2
-rw-r--r--incubation/org.eclipse.sirius.sample.properties/META-INF/MANIFEST.MF2
-rw-r--r--incubation/org.eclipse.sirius.ui.properties/.classpath2
-rw-r--r--incubation/org.eclipse.sirius.ui.properties/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--incubation/org.eclipse.sirius.ui.properties/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.common.acceleo.aql.ide/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.common.acceleo.aql.ide/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.common.acceleo.aql.ide/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.common.acceleo.aql/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.common.acceleo.aql/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.common.acceleo.aql/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.common.acceleo.mtl.ide/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.common.acceleo.mtl.ide/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.common.acceleo.mtl.ide/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.common.acceleo.mtl/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.common.acceleo.mtl/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.common.acceleo.mtl/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.common.ocl/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.common.ocl/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.common.ocl/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.common.ui.ext/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.common.ui.ext/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.common.ui.ext/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.common.ui/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.common.ui/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.common.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.common.xtext/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.common.xtext/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.common.xtext/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.common/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.common/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.common/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.diagram.layoutdata/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.diagram.layoutdata/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.diagram.layoutdata/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.diagram.sequence.edit/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.diagram.sequence.edit/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.diagram.sequence.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.diagram.sequence.ui/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.diagram.sequence.ui/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.diagram.sequence.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.diagram.sequence/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.diagram.sequence/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.diagram.ui.ext/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.diagram.ui.ext/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.diagram.ui.ext/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.diagram.ui/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.diagram.ui/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.diagram.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.diagram/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.diagram/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.diagram/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ecore.extender/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ecore.extender/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ecore.extender/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.editor.diagram/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.editor.diagram/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.editor.diagram/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.editor.sequence/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.editor.sequence/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.editor.sequence/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.editor.table/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.editor.table/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.editor.table/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.editor.tree/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.editor.tree/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.editor.tree/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.editor/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.editor/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.editor/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.eef.adapters/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.eef.adapters/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.eef.adapters/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ext.base/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ext.base/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ext.base/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ext.draw2d/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ext.draw2d/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ext.draw2d/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ext.e3.ui/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ext.e3.ui/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ext.e3.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ext.e3/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ext.e3/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ext.e3/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ext.emf.edit/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ext.emf.edit/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ext.emf.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ext.emf.tx/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ext.emf.tx/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ext.emf.tx/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ext.emf.ui/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ext.emf.ui/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ext.emf.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ext.emf/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ext.emf/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ext.emf/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ext.gef/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ext.gef/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ext.gef/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ext.gmf.notation/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ext.gmf.notation/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ext.gmf.notation/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ext.gmf.runtime/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ext.gmf.runtime/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ext.gmf.runtime/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ext.jface/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ext.jface/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ext.jface/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ext.swt/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ext.swt/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ext.swt/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.interpreter/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.interpreter/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.interpreter/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.sample.ecore.design/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.sample.ecore.design/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.sample.ecore.design/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.sample.interactions.design/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.sample.interactions.design/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.sample.interactions.design/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.sample.interactions.edit/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.sample.interactions.edit/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.sample.interactions.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.sample.interactions.editor/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.sample.interactions.editor/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.sample.interactions.editor/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.sample.interactions/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.sample.interactions/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.sample.interactions/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.samples.family/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.design/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.edit/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.edit/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.editor/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.editor/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.editor/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.synchronizer/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.synchronizer/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.synchronizer/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.table.ui.ext/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.table.ui.ext/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.table.ui.ext/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.table.ui/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.table.ui/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.table.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.table/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.table/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.table/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.junit.support/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.junit.support/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.tests.junit.support/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.junit/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.junit/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.tests.junit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.junit/data/unit/project/modeling/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.benchmark/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.benchmark/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.benchmark/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.component.design/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.component.design/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.component.design/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.component/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.component/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.docbook.design/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.docbook.design/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.docbook.design/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.docbook.edit/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.docbook.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.docbook.editor/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.docbook.editor/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.docbook/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.docbook/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.docbook/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.migration.design/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.migration.design/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.migration.design/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.migration/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.migration/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.migration/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.scxml.design/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.scxml.design/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.scxml/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.sample.scxml/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.swtbot.support/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.swtbot.support/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.tests.swtbot.support/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.swtbot/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.swtbot/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.tests.swtbot/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.swtbot/data/unit/editor/vsm/completion/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tests.tree/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tests.tree/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.tests.tree/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tree.ui.ext/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tree.ui.ext/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.tree.ui.ext/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tree.ui/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tree.ui/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.tree.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.tree/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.tree/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.tree/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ui.debug/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ui.debug/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ui.debug/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ui.ext/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ui.ext/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ui.ext/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ui/.classpath2
-rw-r--r--plugins/org.eclipse.sirius.ui/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius.ui/resources/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.sirius/.classpath2
-rw-r--r--plugins/org.eclipse.sirius/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.sirius/META-INF/MANIFEST.MF2
-rwxr-xr-xreleng/org.eclipse.sirius.releng/checks.sh4
-rw-r--r--releng/org.eclipse.sirius.settings/Sirius.setup6
227 files changed, 368 insertions, 368 deletions
diff --git a/incubation/org.eclipse.sirius.properties.edit/META-INF/MANIFEST.MF b/incubation/org.eclipse.sirius.properties.edit/META-INF/MANIFEST.MF
index 6481afc76d..7e3f5b7bfa 100644
--- a/incubation/org.eclipse.sirius.properties.edit/META-INF/MANIFEST.MF
+++ b/incubation/org.eclipse.sirius.properties.edit/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Bundle-ClassPath: .
Bundle-Activator: org.eclipse.sirius.properties.provider.PropertiesEditPlugin$Implementation
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.properties.provider
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.sirius.properties;visibility:=reexport,
diff --git a/incubation/org.eclipse.sirius.properties/.classpath b/incubation/org.eclipse.sirius.properties/.classpath
index ffed9ceca8..32258f1e0f 100644
--- a/incubation/org.eclipse.sirius.properties/.classpath
+++ b/incubation/org.eclipse.sirius.properties/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src-gen"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/incubation/org.eclipse.sirius.properties/.settings/org.eclipse.jdt.core.prefs b/incubation/org.eclipse.sirius.properties/.settings/org.eclipse.jdt.core.prefs
index c537b63063..f42de363af 100644
--- a/incubation/org.eclipse.sirius.properties/.settings/org.eclipse.jdt.core.prefs
+++ b/incubation/org.eclipse.sirius.properties/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,7 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
diff --git a/incubation/org.eclipse.sirius.properties/META-INF/MANIFEST.MF b/incubation/org.eclipse.sirius.properties/META-INF/MANIFEST.MF
index 39bc91f6c7..3647d31d54 100644
--- a/incubation/org.eclipse.sirius.properties/META-INF/MANIFEST.MF
+++ b/incubation/org.eclipse.sirius.properties/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Version: 1.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.properties,
org.eclipse.sirius.properties.impl,
org.eclipse.sirius.properties.util
diff --git a/incubation/org.eclipse.sirius.sample.properties.checkbox/META-INF/MANIFEST.MF b/incubation/org.eclipse.sirius.sample.properties.checkbox/META-INF/MANIFEST.MF
index 053e157f79..f7d16ebeec 100644
--- a/incubation/org.eclipse.sirius.sample.properties.checkbox/META-INF/MANIFEST.MF
+++ b/incubation/org.eclipse.sirius.sample.properties.checkbox/META-INF/MANIFEST.MF
@@ -10,4 +10,4 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.sirius,
org.eclipse.sirius.common.acceleo.aql
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
diff --git a/incubation/org.eclipse.sirius.sample.properties/META-INF/MANIFEST.MF b/incubation/org.eclipse.sirius.sample.properties/META-INF/MANIFEST.MF
index cff31d6da2..da61a590d6 100644
--- a/incubation/org.eclipse.sirius.sample.properties/META-INF/MANIFEST.MF
+++ b/incubation/org.eclipse.sirius.sample.properties/META-INF/MANIFEST.MF
@@ -10,4 +10,4 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.sirius,
org.eclipse.sirius.common.acceleo.aql
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
diff --git a/incubation/org.eclipse.sirius.ui.properties/.classpath b/incubation/org.eclipse.sirius.ui.properties/.classpath
index ad32c83a78..098194ca4b 100644
--- a/incubation/org.eclipse.sirius.ui.properties/.classpath
+++ b/incubation/org.eclipse.sirius.ui.properties/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/incubation/org.eclipse.sirius.ui.properties/.settings/org.eclipse.jdt.core.prefs b/incubation/org.eclipse.sirius.ui.properties/.settings/org.eclipse.jdt.core.prefs
index c537b63063..f42de363af 100644
--- a/incubation/org.eclipse.sirius.ui.properties/.settings/org.eclipse.jdt.core.prefs
+++ b/incubation/org.eclipse.sirius.ui.properties/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,7 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
diff --git a/incubation/org.eclipse.sirius.ui.properties/META-INF/MANIFEST.MF b/incubation/org.eclipse.sirius.ui.properties/META-INF/MANIFEST.MF
index 3f5454c89f..8112da8428 100644
--- a/incubation/org.eclipse.sirius.ui.properties/META-INF/MANIFEST.MF
+++ b/incubation/org.eclipse.sirius.ui.properties/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.ui.properties;singleton:=true
Bundle-Version: 1.0.0.qualifier
Bundle-Vendor: %providerName
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Require-Bundle: org.eclipse.eef;bundle-version="1.6.0",
org.eclipse.sirius,
org.eclipse.sirius.ext.emf;bundle-version="3.1.2",
diff --git a/plugins/org.eclipse.sirius.common.acceleo.aql.ide/.classpath b/plugins/org.eclipse.sirius.common.acceleo.aql.ide/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.common.acceleo.aql.ide/.classpath
+++ b/plugins/org.eclipse.sirius.common.acceleo.aql.ide/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.common.acceleo.aql.ide/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.common.acceleo.aql.ide/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.common.acceleo.aql.ide/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.common.acceleo.aql.ide/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.common.acceleo.aql.ide/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.common.acceleo.aql.ide/META-INF/MANIFEST.MF
index 98342b6974..e727c1391a 100644
--- a/plugins/org.eclipse.sirius.common.acceleo.aql.ide/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.common.acceleo.aql.ide/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Require-Bundle: org.eclipse.sirius.common;bundle-version="2.0.0",
org.eclipse.sirius.common.acceleo.aql;bundle-version="2.0.0",
com.google.guava;bundle-version="[11.0.2,16.0)",
org.eclipse.emf.ecore;bundle-version="2.8.0"
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Vendor: %providerName
Export-Package: org.eclipse.sirius.common.acceleo.aql.ide;version="3.1.0",
org.eclipse.sirius.common.acceleo.aql.ide.proposal;version="3.0.0";x-internal:=true
diff --git a/plugins/org.eclipse.sirius.common.acceleo.aql/.classpath b/plugins/org.eclipse.sirius.common.acceleo.aql/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.common.acceleo.aql/.classpath
+++ b/plugins/org.eclipse.sirius.common.acceleo.aql/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.common.acceleo.aql/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.common.acceleo.aql/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.common.acceleo.aql/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.common.acceleo.aql/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.common.acceleo.aql/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.common.acceleo.aql/META-INF/MANIFEST.MF
index 66297ab691..4d33191522 100644
--- a/plugins/org.eclipse.sirius.common.acceleo.aql/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.common.acceleo.aql/META-INF/MANIFEST.MF
@@ -11,7 +11,7 @@ Require-Bundle: org.eclipse.sirius.common;bundle-version="2.0.0",
org.eclipse.sirius.ecore.extender;bundle-version="2.0.0",
org.eclipse.emf.ecore;bundle-version="2.8.0",
org.eclipse.sirius.ext.base;bundle-version="3.1.0"
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Vendor: %providerName
Export-Package: org.eclipse.sirius.common.acceleo.aql.business;version="3.0.0",
org.eclipse.sirius.common.acceleo.aql.business.api;version="3.0.0",
diff --git a/plugins/org.eclipse.sirius.common.acceleo.mtl.ide/.classpath b/plugins/org.eclipse.sirius.common.acceleo.mtl.ide/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.common.acceleo.mtl.ide/.classpath
+++ b/plugins/org.eclipse.sirius.common.acceleo.mtl.ide/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.common.acceleo.mtl.ide/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.common.acceleo.mtl.ide/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.common.acceleo.mtl.ide/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.common.acceleo.mtl.ide/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.common.acceleo.mtl.ide/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.common.acceleo.mtl.ide/META-INF/MANIFEST.MF
index ad9ce8ff43..7e5d2f7d91 100644
--- a/plugins/org.eclipse.sirius.common.acceleo.mtl.ide/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.common.acceleo.mtl.ide/META-INF/MANIFEST.MF
@@ -19,7 +19,7 @@ Require-Bundle: org.eclipse.sirius.common.acceleo.mtl;bundle-version="2.0.0",
org.eclipse.core.filebuffers;bundle-version="3.5.200",
org.eclipse.swt;bundle-version="2.0.0"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Vendor: %providerName
Export-Package: org.eclipse.sirius.common.acceleo.mtl.ide;x-internal:=true;version="3.0.0"
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.sirius.common.acceleo.mtl/.classpath b/plugins/org.eclipse.sirius.common.acceleo.mtl/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.common.acceleo.mtl/.classpath
+++ b/plugins/org.eclipse.sirius.common.acceleo.mtl/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.common.acceleo.mtl/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.common.acceleo.mtl/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.common.acceleo.mtl/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.common.acceleo.mtl/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.common.acceleo.mtl/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.common.acceleo.mtl/META-INF/MANIFEST.MF
index bec6fdea55..67963df99b 100644
--- a/plugins/org.eclipse.sirius.common.acceleo.mtl/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.common.acceleo.mtl/META-INF/MANIFEST.MF
@@ -12,7 +12,7 @@ Require-Bundle: org.eclipse.sirius.common;bundle-version="2.0.0",
org.eclipse.core.runtime;bundle-version="3.4.0",
com.google.guava;bundle-version="[11.0.2,16.0)"
Eclipse-LazyStart: true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Vendor: %providerName
Export-Package: org.eclipse.sirius.common.acceleo.mtl;version="3.0.0",
org.eclipse.sirius.common.acceleo.mtl.business.api;version="2.0.4",
diff --git a/plugins/org.eclipse.sirius.common.ocl/.classpath b/plugins/org.eclipse.sirius.common.ocl/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.common.ocl/.classpath
+++ b/plugins/org.eclipse.sirius.common.ocl/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.common.ocl/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.common.ocl/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.common.ocl/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.common.ocl/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.common.ocl/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.common.ocl/META-INF/MANIFEST.MF
index 07f527ad5b..54a3b61179 100644
--- a/plugins/org.eclipse.sirius.common.ocl/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.common.ocl/META-INF/MANIFEST.MF
@@ -9,7 +9,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.8.0",
org.eclipse.ocl.ecore;bundle-version="3.2.0",
org.eclipse.sirius.ecore.extender;bundle-version="2.0.0"
Eclipse-LazyStart: true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.sirius.common.ui.ext/.classpath b/plugins/org.eclipse.sirius.common.ui.ext/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.common.ui.ext/.classpath
+++ b/plugins/org.eclipse.sirius.common.ui.ext/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.common.ui.ext/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.common.ui.ext/.settings/org.eclipse.jdt.core.prefs
index ebee6d68ae..85dde556c0 100644
--- a/plugins/org.eclipse.sirius.common.ui.ext/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.common.ui.ext/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.common.ui.ext/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.common.ui.ext/META-INF/MANIFEST.MF
index d949c27e3b..b5359e7bd7 100644
--- a/plugins/org.eclipse.sirius.common.ui.ext/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.common.ui.ext/META-INF/MANIFEST.MF
@@ -9,5 +9,5 @@ Require-Bundle: org.eclipse.sirius.common.ui;bundle-version="3.0.0",
org.eclipse.osgi;bundle-version="0.0.0"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.sirius.common.ui.ext.Activator
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.common.ui.ext;version="3.0.0"
diff --git a/plugins/org.eclipse.sirius.common.ui/.classpath b/plugins/org.eclipse.sirius.common.ui/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.common.ui/.classpath
+++ b/plugins/org.eclipse.sirius.common.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.common.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.common.ui/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.common.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.common.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.common.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.common.ui/META-INF/MANIFEST.MF
index 03b7b8cfe7..353c109d51 100644
--- a/plugins/org.eclipse.sirius.common.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.common.ui/META-INF/MANIFEST.MF
@@ -38,7 +38,7 @@ Export-Package: org.eclipse.sirius.common.ui;version="2.1.0",
org.eclipse.sirius.common.ui.tools.internal.util;x-internal:=true;version="2.0.4"
Bundle-Activator: org.eclipse.sirius.common.ui.SiriusTransPlugin$Implementation
Eclipse-LazyStart: true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
Import-Package: org.eclipse.sirius.ext.base;version="2.1.0",
diff --git a/plugins/org.eclipse.sirius.common.xtext/.classpath b/plugins/org.eclipse.sirius.common.xtext/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.common.xtext/.classpath
+++ b/plugins/org.eclipse.sirius.common.xtext/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.common.xtext/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.common.xtext/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.common.xtext/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.common.xtext/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.common.xtext/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.common.xtext/META-INF/MANIFEST.MF
index c4f77cc1e5..6c80ab0200 100644
--- a/plugins/org.eclipse.sirius.common.xtext/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.common.xtext/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.common.xtext;singleton:=true
Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %providerName
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Require-Bundle: org.eclipse.xtext.ui;bundle-version="2.1.1",
org.eclipse.sirius.common;bundle-version="2.0.0",
org.eclipse.jdt.core;bundle-version="3.8.1",
diff --git a/plugins/org.eclipse.sirius.common/.classpath b/plugins/org.eclipse.sirius.common/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.common/.classpath
+++ b/plugins/org.eclipse.sirius.common/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.common/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.common/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.common/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.common/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.common/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.common/META-INF/MANIFEST.MF
index 4871a4e169..f804776418 100644
--- a/plugins/org.eclipse.sirius.common/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.common/META-INF/MANIFEST.MF
@@ -25,7 +25,7 @@ Export-Package: org.eclipse.sirius.common.tools;version="3.0.0",
org.eclipse.sirius.common.tools.internal.resource;x-internal:=true;version="2.0.4"
Bundle-Activator: org.eclipse.sirius.common.tools.DslCommonPlugin$Implementation
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
Import-Package: org.eclipse.sirius.ext.base;version="2.1.0",
org.eclipse.sirius.ext.base.cache;version="2.0.0",
diff --git a/plugins/org.eclipse.sirius.diagram.layoutdata/.classpath b/plugins/org.eclipse.sirius.diagram.layoutdata/.classpath
index b4943ea08a..e644e859af 100644
--- a/plugins/org.eclipse.sirius.diagram.layoutdata/.classpath
+++ b/plugins/org.eclipse.sirius.diagram.layoutdata/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.diagram.layoutdata/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.diagram.layoutdata/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.diagram.layoutdata/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.diagram.layoutdata/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.diagram.layoutdata/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.diagram.layoutdata/META-INF/MANIFEST.MF
index 0f240ad8c6..5f6a76db1d 100644
--- a/plugins/org.eclipse.sirius.diagram.layoutdata/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.diagram.layoutdata/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Version: 4.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.diagram.layoutdata;
uses:="org.eclipse.emf.ecore,org.eclipse.emf.common.util";version="2.1.0",
org.eclipse.sirius.diagram.layoutdata.impl;
diff --git a/plugins/org.eclipse.sirius.diagram.sequence.edit/.classpath b/plugins/org.eclipse.sirius.diagram.sequence.edit/.classpath
index 39e99f43a7..75888f314e 100644
--- a/plugins/org.eclipse.sirius.diagram.sequence.edit/.classpath
+++ b/plugins/org.eclipse.sirius.diagram.sequence.edit/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.diagram.sequence.edit/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.diagram.sequence.edit/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.diagram.sequence.edit/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.diagram.sequence.edit/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.diagram.sequence.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.diagram.sequence.edit/META-INF/MANIFEST.MF
index d4aafa1e66..737673b787 100644
--- a/plugins/org.eclipse.sirius.diagram.sequence.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.diagram.sequence.edit/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Bundle-ClassPath: .
Bundle-Activator: org.eclipse.sirius.diagram.sequence.description.provider.SequenceEditPlugin$Implementation
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.diagram.sequence.description.provider;version="3.0.0",
org.eclipse.sirius.diagram.sequence.description.tool.provider;version="2.1.0",
org.eclipse.sirius.diagram.sequence.ordering.provider;version="2.0.4",
diff --git a/plugins/org.eclipse.sirius.diagram.sequence.ui/.classpath b/plugins/org.eclipse.sirius.diagram.sequence.ui/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.diagram.sequence.ui/.classpath
+++ b/plugins/org.eclipse.sirius.diagram.sequence.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.diagram.sequence.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.diagram.sequence.ui/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.diagram.sequence.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.diagram.sequence.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.diagram.sequence.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.diagram.sequence.ui/META-INF/MANIFEST.MF
index 1639641b97..85e1952968 100644
--- a/plugins/org.eclipse.sirius.diagram.sequence.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.diagram.sequence.ui/META-INF/MANIFEST.MF
@@ -16,7 +16,7 @@ Require-Bundle: com.google.guava;bundle-version="[11.0.2,16.0)",
org.eclipse.emf.common.ui;bundle-version="2.7.0"
Bundle-Localization: plugin
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.diagram.sequence.ui;version="3.0.0",
org.eclipse.sirius.diagram.sequence.ui.business.api.diagramtype;version="2.1.0",
org.eclipse.sirius.diagram.sequence.ui.business.internal;x-internal:=true;version="2.0.4",
diff --git a/plugins/org.eclipse.sirius.diagram.sequence/.classpath b/plugins/org.eclipse.sirius.diagram.sequence/.classpath
index b4943ea08a..e644e859af 100644
--- a/plugins/org.eclipse.sirius.diagram.sequence/.classpath
+++ b/plugins/org.eclipse.sirius.diagram.sequence/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.diagram.sequence/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.diagram.sequence/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.diagram.sequence/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.diagram.sequence/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF
index af61a903c7..288d534f2e 100644
--- a/plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.diagram.sequence/META-INF/MANIFEST.MF
@@ -56,7 +56,7 @@ Require-Bundle: org.eclipse.sirius.common;bundle-version="2.0.0",
org.eclipse.sirius.diagram.ui.ext;bundle-version="3.0.0"
Eclipse-LazyStart: true
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Import-Package: org.eclipse.sirius.ext.base;version="2.1.0",
org.eclipse.sirius.ext.emf;version="2.0.0"
Bundle-Activator: org.eclipse.sirius.diagram.sequence.SequenceDiagramPlugin$Implementation
diff --git a/plugins/org.eclipse.sirius.diagram.ui.ext/.classpath b/plugins/org.eclipse.sirius.diagram.ui.ext/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.diagram.ui.ext/.classpath
+++ b/plugins/org.eclipse.sirius.diagram.ui.ext/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.diagram.ui.ext/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.diagram.ui.ext/.settings/org.eclipse.jdt.core.prefs
index ebee6d68ae..85dde556c0 100644
--- a/plugins/org.eclipse.sirius.diagram.ui.ext/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.diagram.ui.ext/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.diagram.ui.ext/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.diagram.ui.ext/META-INF/MANIFEST.MF
index a0a11c735f..6e18582762 100644
--- a/plugins/org.eclipse.sirius.diagram.ui.ext/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.diagram.ui.ext/META-INF/MANIFEST.MF
@@ -9,5 +9,5 @@ Require-Bundle: org.eclipse.sirius.diagram.ui;bundle-version="3.0.0",
org.eclipse.osgi;bundle-version="0.0.0"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.sirius.diagram.ui.ext.Activator
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.diagram.ui.ext;version="3.0.0"
diff --git a/plugins/org.eclipse.sirius.diagram.ui/.classpath b/plugins/org.eclipse.sirius.diagram.ui/.classpath
index 59ec757b47..ac46107077 100644
--- a/plugins/org.eclipse.sirius.diagram.ui/.classpath
+++ b/plugins/org.eclipse.sirius.diagram.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.diagram.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.diagram.ui/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.diagram.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.diagram.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.diagram.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.diagram.ui/META-INF/MANIFEST.MF
index cd5590aa48..f077cc88c5 100644
--- a/plugins/org.eclipse.sirius.diagram.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.diagram.ui/META-INF/MANIFEST.MF
@@ -191,7 +191,7 @@ Export-Package: org.eclipse.sirius.diagram.description.concern.provider;version=
org.eclipse.sirius.diagram.ui.tools.internal.views.providers.filters;x-internal:=true;version="2.0.4",
org.eclipse.sirius.diagram.ui.tools.internal.views.providers.layers;x-internal:=true;version="2.0.4",
org.eclipse.sirius.diagram.ui.tools.internal.views.providers.outline;x-internal:=true;version="2.0.4"
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-ActivationPolicy: lazy
Import-Package: org.eclipse.sirius.ext.base;version="2.1.0",
org.eclipse.sirius.ext.draw2d.figure;version="2.0.0",
diff --git a/plugins/org.eclipse.sirius.diagram/.classpath b/plugins/org.eclipse.sirius.diagram/.classpath
index 8e89a620be..643e7f62dc 100644
--- a/plugins/org.eclipse.sirius.diagram/.classpath
+++ b/plugins/org.eclipse.sirius.diagram/.classpath
@@ -2,7 +2,7 @@
<classpath>
<classpathentry kind="src" path="src-gen"/>
<classpathentry kind="src" path="src-core"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.diagram/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.diagram/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.diagram/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.diagram/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.diagram/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.diagram/META-INF/MANIFEST.MF
index d07adb4616..fab5f7c978 100644
--- a/plugins/org.eclipse.sirius.diagram/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.diagram/META-INF/MANIFEST.MF
@@ -92,7 +92,7 @@ Export-Package: org.eclipse.sirius.diagram;version="4.0.0",
org.eclipse.sirius.diagram.tools.internal.validation.constraints;x-internal:=true;version="2.0.4",
org.eclipse.sirius.diagram.tools.internal.validation.description.constraints;x-internal:=true;version="3.0.0",
org.eclipse.sirius.diagram.util;version="4.0.0"
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-ActivationPolicy: lazy
Import-Package: org.eclipse.sirius.ext.base;version="2.1.0",
org.eclipse.sirius.ext.base.cache;version="2.0.0",
diff --git a/plugins/org.eclipse.sirius.ecore.extender/.classpath b/plugins/org.eclipse.sirius.ecore.extender/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.ecore.extender/.classpath
+++ b/plugins/org.eclipse.sirius.ecore.extender/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.ecore.extender/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ecore.extender/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.ecore.extender/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ecore.extender/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ecore.extender/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ecore.extender/META-INF/MANIFEST.MF
index ddac2fc2dc..696ed40a90 100644
--- a/plugins/org.eclipse.sirius.ecore.extender/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ecore.extender/META-INF/MANIFEST.MF
@@ -21,7 +21,7 @@ Export-Package: org.eclipse.sirius.ecore.extender.business.api.accessor;version=
org.eclipse.sirius.ecore.extender.tool.internal;x-internal:=true;version="3.0.0"
Bundle-Activator: org.eclipse.sirius.ecore.extender.business.internal.ExtenderPlugin$Implementation
Eclipse-LazyStart: true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
Import-Package: org.eclipse.sirius.ext.base;version="2.1.0",
diff --git a/plugins/org.eclipse.sirius.editor.diagram/.classpath b/plugins/org.eclipse.sirius.editor.diagram/.classpath
index c6ea5895ab..262b0fee4d 100644
--- a/plugins/org.eclipse.sirius.editor.diagram/.classpath
+++ b/plugins/org.eclipse.sirius.editor.diagram/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.editor.diagram/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.editor.diagram/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.editor.diagram/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.editor.diagram/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.editor.diagram/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.editor.diagram/META-INF/MANIFEST.MF
index 493a52f44f..02ff97b32c 100644
--- a/plugins/org.eclipse.sirius.editor.diagram/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.editor.diagram/META-INF/MANIFEST.MF
@@ -15,7 +15,7 @@ Require-Bundle: com.google.guava;bundle-version="[11.0.2,16.0)",
org.eclipse.ui.ide;bundle-version="3.5.200",
org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.300",
org.eclipse.ui.workbench.texteditor;bundle-version="3.8.0"
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Eclipse-LazyStart: true
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.sirius.editor.sequence/.classpath b/plugins/org.eclipse.sirius.editor.sequence/.classpath
index b4943ea08a..e644e859af 100644
--- a/plugins/org.eclipse.sirius.editor.sequence/.classpath
+++ b/plugins/org.eclipse.sirius.editor.sequence/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.editor.sequence/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.editor.sequence/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.editor.sequence/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.editor.sequence/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.editor.sequence/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.editor.sequence/META-INF/MANIFEST.MF
index c9d41f1da3..727014dd71 100644
--- a/plugins/org.eclipse.sirius.editor.sequence/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.editor.sequence/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Version: 4.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Require-Bundle: org.eclipse.sirius.editor;bundle-version="2.0.0",
org.eclipse.sirius.common;bundle-version="2.0.0",
org.eclipse.sirius.diagram.sequence.edit;bundle-version="2.0.0",
diff --git a/plugins/org.eclipse.sirius.editor.table/.classpath b/plugins/org.eclipse.sirius.editor.table/.classpath
index c6ea5895ab..262b0fee4d 100644
--- a/plugins/org.eclipse.sirius.editor.table/.classpath
+++ b/plugins/org.eclipse.sirius.editor.table/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.editor.table/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.editor.table/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.editor.table/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.editor.table/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.editor.table/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.editor.table/META-INF/MANIFEST.MF
index 2d42bd6a2e..8c13d8bff7 100644
--- a/plugins/org.eclipse.sirius.editor.table/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.editor.table/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.editor.table;singleton:=true
Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %providerName
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Require-Bundle: org.eclipse.sirius.editor;bundle-version="2.0.0",
org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.300",
org.eclipse.emf.edit.ui;bundle-version="2.8.0",
diff --git a/plugins/org.eclipse.sirius.editor.tree/.classpath b/plugins/org.eclipse.sirius.editor.tree/.classpath
index c6ea5895ab..262b0fee4d 100644
--- a/plugins/org.eclipse.sirius.editor.tree/.classpath
+++ b/plugins/org.eclipse.sirius.editor.tree/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.editor.tree/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.editor.tree/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.editor.tree/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.editor.tree/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.editor.tree/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.editor.tree/META-INF/MANIFEST.MF
index 8724643fc0..b34ac80759 100644
--- a/plugins/org.eclipse.sirius.editor.tree/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.editor.tree/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.8.0",
org.eclipse.sirius.common;bundle-version="2.0.0",
com.google.guava;bundle-version="[11.0.2,16.0)",
org.eclipse.ui.workbench.texteditor;bundle-version="3.8.0"
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Eclipse-LazyStart: true
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.sirius.editor/.classpath b/plugins/org.eclipse.sirius.editor/.classpath
index c6ea5895ab..262b0fee4d 100644
--- a/plugins/org.eclipse.sirius.editor/.classpath
+++ b/plugins/org.eclipse.sirius.editor/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.editor/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.editor/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.editor/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.editor/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.editor/META-INF/MANIFEST.MF
index c52d4c2cf4..eb6bc3a7e5 100644
--- a/plugins/org.eclipse.sirius.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.editor/META-INF/MANIFEST.MF
@@ -20,7 +20,7 @@ Require-Bundle: org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.300",
org.eclipse.jface.text;bundle-version="3.8.2",
org.eclipse.pde.core;bundle-version="3.8.1",
org.eclipse.equinox.frameworkadmin;bundle-version="2.0.100"
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Eclipse-LazyStart: true
Export-Package: org.eclipse.sirius.editor.assist.content;version="2.0.4",
org.eclipse.sirius.editor.editorPlugin;version="2.1.0",
diff --git a/plugins/org.eclipse.sirius.eef.adapters/.classpath b/plugins/org.eclipse.sirius.eef.adapters/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.eef.adapters/.classpath
+++ b/plugins/org.eclipse.sirius.eef.adapters/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.eef.adapters/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.eef.adapters/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.eef.adapters/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.eef.adapters/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.eef.adapters/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.eef.adapters/META-INF/MANIFEST.MF
index 560f71a842..127025d6eb 100644
--- a/plugins/org.eclipse.sirius.eef.adapters/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.eef.adapters/META-INF/MANIFEST.MF
@@ -14,7 +14,7 @@ Require-Bundle: org.eclipse.ui;bundle-version="3.8.2",
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.6.0",
org.eclipse.sirius.table;bundle-version="2.0.0"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Vendor: %providerName
Export-Package: org.eclipse.sirius.eef.actions;x-internal:=true;version="2.0.4",
org.eclipse.sirius.eef.adapters;x-internal:=true;version="3.0.0",
diff --git a/plugins/org.eclipse.sirius.ext.base/.classpath b/plugins/org.eclipse.sirius.ext.base/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.ext.base/.classpath
+++ b/plugins/org.eclipse.sirius.ext.base/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.ext.base/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ext.base/.settings/org.eclipse.jdt.core.prefs
index 08a3c7721c..e1529ef31f 100644
--- a/plugins/org.eclipse.sirius.ext.base/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ext.base/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ext.base/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ext.base/META-INF/MANIFEST.MF
index ed4e093f22..6290d55cef 100644
--- a/plugins/org.eclipse.sirius.ext.base/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ext.base/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.ext.base
Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %providerName
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
Import-Package: com.google.common.base;version="[11.0.2,16.0)",
com.google.common.collect;version="[11.0.2,16.0)"
diff --git a/plugins/org.eclipse.sirius.ext.draw2d/.classpath b/plugins/org.eclipse.sirius.ext.draw2d/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.ext.draw2d/.classpath
+++ b/plugins/org.eclipse.sirius.ext.draw2d/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.ext.draw2d/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ext.draw2d/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.ext.draw2d/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ext.draw2d/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ext.draw2d/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ext.draw2d/META-INF/MANIFEST.MF
index f14dc2b8e0..7a6f789534 100644
--- a/plugins/org.eclipse.sirius.ext.draw2d/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ext.draw2d/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.ext.draw2d
Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %providerName
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
Import-Package: org.eclipse.draw2d,
org.eclipse.draw2d.geometry,
diff --git a/plugins/org.eclipse.sirius.ext.e3.ui/.classpath b/plugins/org.eclipse.sirius.ext.e3.ui/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.ext.e3.ui/.classpath
+++ b/plugins/org.eclipse.sirius.ext.e3.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.ext.e3.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ext.e3.ui/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.ext.e3.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ext.e3.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ext.e3.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ext.e3.ui/META-INF/MANIFEST.MF
index 4b3600d7c1..9fec58ce51 100644
--- a/plugins/org.eclipse.sirius.ext.e3.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ext.e3.ui/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.ext.e3.ui
Bundle-Version: 4.0.0.qualifier
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Import-Package: com.ibm.icu.text;version="4.4.2.2"
diff --git a/plugins/org.eclipse.sirius.ext.e3/.classpath b/plugins/org.eclipse.sirius.ext.e3/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.ext.e3/.classpath
+++ b/plugins/org.eclipse.sirius.ext.e3/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.ext.e3/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ext.e3/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.ext.e3/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ext.e3/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ext.e3/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ext.e3/META-INF/MANIFEST.MF
index a37e61e270..f8c8c2a21f 100644
--- a/plugins/org.eclipse.sirius.ext.e3/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ext.e3/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.ext.e3
Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %providerName
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
Import-Package: com.google.common.base;version="11.0.2",
org.eclipse.sirius.ext.base;version="2.0.0"
diff --git a/plugins/org.eclipse.sirius.ext.emf.edit/.classpath b/plugins/org.eclipse.sirius.ext.emf.edit/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.ext.emf.edit/.classpath
+++ b/plugins/org.eclipse.sirius.ext.emf.edit/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.ext.emf.edit/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ext.emf.edit/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.ext.emf.edit/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ext.emf.edit/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ext.emf.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ext.emf.edit/META-INF/MANIFEST.MF
index c3c82f184b..24c31f6db3 100644
--- a/plugins/org.eclipse.sirius.ext.emf.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ext.emf.edit/META-INF/MANIFEST.MF
@@ -4,5 +4,5 @@ Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.ext.emf.edit
Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %providerName
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.sirius.ext.emf.tx/.classpath b/plugins/org.eclipse.sirius.ext.emf.tx/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.ext.emf.tx/.classpath
+++ b/plugins/org.eclipse.sirius.ext.emf.tx/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.ext.emf.tx/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ext.emf.tx/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.ext.emf.tx/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ext.emf.tx/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ext.emf.tx/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ext.emf.tx/META-INF/MANIFEST.MF
index 43b144df9f..6283fe6b50 100644
--- a/plugins/org.eclipse.sirius.ext.emf.tx/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ext.emf.tx/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.ext.emf.tx
Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %providerName
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
Require-Bundle: org.eclipse.emf.transaction;bundle-version="1.4.0"
Export-Package: org.eclipse.sirius.ext.emf.tx;version="3.0.0"
diff --git a/plugins/org.eclipse.sirius.ext.emf.ui/.classpath b/plugins/org.eclipse.sirius.ext.emf.ui/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.ext.emf.ui/.classpath
+++ b/plugins/org.eclipse.sirius.ext.emf.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.ext.emf.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ext.emf.ui/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.ext.emf.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ext.emf.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ext.emf.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ext.emf.ui/META-INF/MANIFEST.MF
index 8f6a54a0b3..27632d6dd0 100644
--- a/plugins/org.eclipse.sirius.ext.emf.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ext.emf.ui/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.ext.emf.ui;singleton:=true
Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %providerName
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
Require-Bundle: org.eclipse.emf.edit.ui;bundle-version="2.8.0"
Export-Package: org.eclipse.sirius.ext.emf.ui;version="3.0.0",
diff --git a/plugins/org.eclipse.sirius.ext.emf/.classpath b/plugins/org.eclipse.sirius.ext.emf/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.ext.emf/.classpath
+++ b/plugins/org.eclipse.sirius.ext.emf/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.ext.emf/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ext.emf/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.ext.emf/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ext.emf/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ext.emf/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ext.emf/META-INF/MANIFEST.MF
index 4b420497e5..9d20875e0b 100644
--- a/plugins/org.eclipse.sirius.ext.emf/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ext.emf/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.ext.emf
Bundle-Version: 4.0.0.qualifier
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
Require-Bundle: com.google.guava;bundle-version="[11.0.2,16.0)",
org.eclipse.emf;bundle-version="2.6.0",
diff --git a/plugins/org.eclipse.sirius.ext.gef/.classpath b/plugins/org.eclipse.sirius.ext.gef/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.ext.gef/.classpath
+++ b/plugins/org.eclipse.sirius.ext.gef/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.ext.gef/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ext.gef/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.ext.gef/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ext.gef/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ext.gef/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ext.gef/META-INF/MANIFEST.MF
index ec9c66750f..5bd5284f28 100644
--- a/plugins/org.eclipse.sirius.ext.gef/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ext.gef/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.ext.gef
Bundle-Version: 4.0.0.qualifier
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Require-Bundle: org.eclipse.gef;bundle-version="3.9.0",
diff --git a/plugins/org.eclipse.sirius.ext.gmf.notation/.classpath b/plugins/org.eclipse.sirius.ext.gmf.notation/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.ext.gmf.notation/.classpath
+++ b/plugins/org.eclipse.sirius.ext.gmf.notation/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.ext.gmf.notation/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ext.gmf.notation/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.ext.gmf.notation/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ext.gmf.notation/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ext.gmf.notation/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ext.gmf.notation/META-INF/MANIFEST.MF
index 9d161c8fe6..6eeb2d348d 100644
--- a/plugins/org.eclipse.sirius.ext.gmf.notation/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ext.gmf.notation/META-INF/MANIFEST.MF
@@ -3,6 +3,6 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.ext.gmf.notation
Bundle-Version: 4.0.0.qualifier
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Vendor: %providerName
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.sirius.ext.gmf.runtime/.classpath b/plugins/org.eclipse.sirius.ext.gmf.runtime/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.ext.gmf.runtime/.classpath
+++ b/plugins/org.eclipse.sirius.ext.gmf.runtime/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.ext.gmf.runtime/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ext.gmf.runtime/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.ext.gmf.runtime/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ext.gmf.runtime/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ext.gmf.runtime/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ext.gmf.runtime/META-INF/MANIFEST.MF
index 8ec798be3a..9f61fe635b 100644
--- a/plugins/org.eclipse.sirius.ext.gmf.runtime/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ext.gmf.runtime/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.ext.gmf.runtime
Bundle-Version: 4.0.0.qualifier
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Import-Package: com.google.common.base;version="10.0.1",
diff --git a/plugins/org.eclipse.sirius.ext.jface/.classpath b/plugins/org.eclipse.sirius.ext.jface/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.ext.jface/.classpath
+++ b/plugins/org.eclipse.sirius.ext.jface/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.ext.jface/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ext.jface/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.ext.jface/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ext.jface/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ext.jface/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ext.jface/META-INF/MANIFEST.MF
index 8194ced665..7c0fcb953b 100644
--- a/plugins/org.eclipse.sirius.ext.jface/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ext.jface/META-INF/MANIFEST.MF
@@ -4,6 +4,6 @@ Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.ext.jface
Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %providerName
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
Export-Package: org.eclipse.sirius.ext.jface.viewers;version="3.1.0"
diff --git a/plugins/org.eclipse.sirius.ext.swt/.classpath b/plugins/org.eclipse.sirius.ext.swt/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.ext.swt/.classpath
+++ b/plugins/org.eclipse.sirius.ext.swt/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.ext.swt/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ext.swt/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.ext.swt/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ext.swt/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ext.swt/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ext.swt/META-INF/MANIFEST.MF
index 86d92f1e04..7aaff1a0a3 100644
--- a/plugins/org.eclipse.sirius.ext.swt/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ext.swt/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.ext.swt
Bundle-Version: 4.0.0.qualifier
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Import-Package: org.eclipse.sirius.ext.base.cache;version="2.0.0",
diff --git a/plugins/org.eclipse.sirius.interpreter/.classpath b/plugins/org.eclipse.sirius.interpreter/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.interpreter/.classpath
+++ b/plugins/org.eclipse.sirius.interpreter/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.interpreter/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.interpreter/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.interpreter/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.interpreter/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.interpreter/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.interpreter/META-INF/MANIFEST.MF
index fa8498c18c..9545a556ab 100644
--- a/plugins/org.eclipse.sirius.interpreter/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.interpreter/META-INF/MANIFEST.MF
@@ -15,7 +15,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.8.0",
org.eclipse.ui.editors;bundle-version="3.8.0",
org.eclipse.emf.common.ui;bundle-version="2.7.0"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Import-Package: com.google.common.base;version="2.0.0",
diff --git a/plugins/org.eclipse.sirius.sample.ecore.design/.classpath b/plugins/org.eclipse.sirius.sample.ecore.design/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.sample.ecore.design/.classpath
+++ b/plugins/org.eclipse.sirius.sample.ecore.design/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.sample.ecore.design/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.sample.ecore.design/.settings/org.eclipse.jdt.core.prefs
index fc8c7f3ddc..7f47cfad75 100644
--- a/plugins/org.eclipse.sirius.sample.ecore.design/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.sample.ecore.design/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.sample.ecore.design/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.sample.ecore.design/META-INF/MANIFEST.MF
index ed7c77b636..446a53b0a5 100644
--- a/plugins/org.eclipse.sirius.sample.ecore.design/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.sample.ecore.design/META-INF/MANIFEST.MF
@@ -30,7 +30,7 @@ Bundle-Activator: org.eclipse.sirius.ecore.design.service.EcoreSamplePlugin
Export-Package: org.eclipse.sirius.ecore.design.service;version="3.0.0",
org.eclipse.sirius.sample.ecore.design.action;version="3.0.0",
org.eclipse.sirius.sample.ecore.design.editor;version="3.0.0"
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-ActivationPolicy: lazy
Import-Package: org.eclipse.sirius.ext.base;version="2.0.0",
org.eclipse.sirius.ext.emf;version="2.0.0"
diff --git a/plugins/org.eclipse.sirius.sample.interactions.design/.classpath b/plugins/org.eclipse.sirius.sample.interactions.design/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.sample.interactions.design/.classpath
+++ b/plugins/org.eclipse.sirius.sample.interactions.design/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.sample.interactions.design/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.sample.interactions.design/.settings/org.eclipse.jdt.core.prefs
index 8000cd6ca6..7341ab1683 100644
--- a/plugins/org.eclipse.sirius.sample.interactions.design/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.sample.interactions.design/.settings/org.eclipse.jdt.core.prefs
@@ -1,11 +1,11 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
diff --git a/plugins/org.eclipse.sirius.sample.interactions.design/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.sample.interactions.design/META-INF/MANIFEST.MF
index 0044e63f45..fd70c829d9 100644
--- a/plugins/org.eclipse.sirius.sample.interactions.design/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.sample.interactions.design/META-INF/MANIFEST.MF
@@ -12,7 +12,7 @@ Require-Bundle: org.eclipse.ui,
com.google.guava;bundle-version="11.0.2",
org.eclipse.sirius.ext.base;bundle-version="1.0.0"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Activator: org.eclipse.sirius.sample.interactions.Activator
Export-Package: org.eclipse.sirius.sample.interactions,org.eclipse.sirius.sample.interactions.services
Bundle-Vendor: %providerName
diff --git a/plugins/org.eclipse.sirius.sample.interactions.edit/.classpath b/plugins/org.eclipse.sirius.sample.interactions.edit/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.sample.interactions.edit/.classpath
+++ b/plugins/org.eclipse.sirius.sample.interactions.edit/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.sample.interactions.edit/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.sample.interactions.edit/.settings/org.eclipse.jdt.core.prefs
index d6ebb635e3..5d58c9bd1d 100644
--- a/plugins/org.eclipse.sirius.sample.interactions.edit/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.sample.interactions.edit/.settings/org.eclipse.jdt.core.prefs
@@ -1,12 +1,12 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.problem.nonExternalizedStringLiteral=error
diff --git a/plugins/org.eclipse.sirius.sample.interactions.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.sample.interactions.edit/META-INF/MANIFEST.MF
index eff8741d56..772f215854 100644
--- a/plugins/org.eclipse.sirius.sample.interactions.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.sample.interactions.edit/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Bundle-ClassPath: .
Bundle-Activator: org.eclipse.sirius.sample.interactions.provider.InteractionsEditPlugin$Implementation
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.sample.interactions.provider
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.sirius.sample.interactions;visibility:=reexport,
diff --git a/plugins/org.eclipse.sirius.sample.interactions.editor/.classpath b/plugins/org.eclipse.sirius.sample.interactions.editor/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.sample.interactions.editor/.classpath
+++ b/plugins/org.eclipse.sirius.sample.interactions.editor/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.sample.interactions.editor/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.sample.interactions.editor/.settings/org.eclipse.jdt.core.prefs
index d6ebb635e3..5d58c9bd1d 100644
--- a/plugins/org.eclipse.sirius.sample.interactions.editor/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.sample.interactions.editor/.settings/org.eclipse.jdt.core.prefs
@@ -1,12 +1,12 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.problem.nonExternalizedStringLiteral=error
diff --git a/plugins/org.eclipse.sirius.sample.interactions.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.sample.interactions.editor/META-INF/MANIFEST.MF
index 7c6abddf1b..5be7fc09f1 100644
--- a/plugins/org.eclipse.sirius.sample.interactions.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.sample.interactions.editor/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Bundle-ClassPath: .
Bundle-Activator: org.eclipse.sirius.sample.interactions.presentation.InteractionsEditorPlugin$Implementation
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.sample.interactions.presentation
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.core.resources;visibility:=reexport,
diff --git a/plugins/org.eclipse.sirius.sample.interactions/.classpath b/plugins/org.eclipse.sirius.sample.interactions/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.sample.interactions/.classpath
+++ b/plugins/org.eclipse.sirius.sample.interactions/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.sample.interactions/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.sample.interactions/.settings/org.eclipse.jdt.core.prefs
index d6ebb635e3..5d58c9bd1d 100644
--- a/plugins/org.eclipse.sirius.sample.interactions/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.sample.interactions/.settings/org.eclipse.jdt.core.prefs
@@ -1,12 +1,12 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.problem.nonExternalizedStringLiteral=error
diff --git a/plugins/org.eclipse.sirius.sample.interactions/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.sample.interactions/META-INF/MANIFEST.MF
index c4e2bb8538..0042caa638 100644
--- a/plugins/org.eclipse.sirius.sample.interactions/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.sample.interactions/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Version: 4.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.sample.interactions,
org.eclipse.sirius.sample.interactions.impl,
org.eclipse.sirius.sample.interactions.util
diff --git a/plugins/org.eclipse.sirius.samples.family/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.samples.family/META-INF/MANIFEST.MF
index ea316fac69..b9f31bd139 100644
--- a/plugins/org.eclipse.sirius.samples.family/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.samples.family/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-SymbolicName: org.eclipse.sirius.samples.family;singleton:=true
Bundle-Version: 4.0.0.qualifier
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
Require-Bundle: org.eclipse.ui,
org.eclipse.emf.common.ui;bundle-version="2.6.0"
diff --git a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.design/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.design/META-INF/MANIFEST.MF
index 08d22017eb..96b6dcb520 100644
--- a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.design/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.design/META-INF/MANIFEST.MF
@@ -12,4 +12,4 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.sirius.common.acceleo.aql;bundle-version="3.1.0",
org.eclipse.sirius.sample.basicfamily;bundle-version="1.0.0"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
diff --git a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.edit/.classpath b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.edit/.classpath
index 121e527a93..3bc247511f 100644
--- a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.edit/.classpath
+++ b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.edit/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.edit/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.edit/.settings/org.eclipse.jdt.core.prefs
index e2ab5d74f5..032a8c79e7 100644
--- a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.edit/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.edit/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.problem.nonExternalizedStringLiteral=error
diff --git a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.edit/META-INF/MANIFEST.MF
index 9e19f830fc..ad7fba6ee0 100644
--- a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.edit/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Bundle-ClassPath: .
Bundle-Activator: org.eclipse.sirius.sample.basicfamily.provider.BasicfamilyEditPlugin$Implementation
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.sample.basicfamily.provider
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.sirius.sample.basicfamily;visibility:=reexport,
diff --git a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.editor/.classpath b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.editor/.classpath
index 121e527a93..3bc247511f 100644
--- a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.editor/.classpath
+++ b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.editor/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.editor/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.editor/.settings/org.eclipse.jdt.core.prefs
index e2ab5d74f5..032a8c79e7 100644
--- a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.editor/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.editor/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.problem.nonExternalizedStringLiteral=error
diff --git a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.editor/META-INF/MANIFEST.MF
index ea6ad78432..cae453bedf 100644
--- a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily.editor/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Bundle-ClassPath: .
Bundle-Activator: org.eclipse.sirius.sample.basicfamily.presentation.BasicfamilyEditorPlugin$Implementation
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.sample.basicfamily.presentation
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.core.resources;visibility:=reexport,
diff --git a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily/.classpath b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily/.classpath
index 121e527a93..3bc247511f 100644
--- a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily/.classpath
+++ b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily/.settings/org.eclipse.jdt.core.prefs
index e2ab5d74f5..032a8c79e7 100644
--- a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.problem.nonExternalizedStringLiteral=error
diff --git a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily/META-INF/MANIFEST.MF
index 91fc6d79b2..000abe089c 100644
--- a/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.samples.family/samples/org.eclipse.sirius.sample.basicfamily/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Version: 1.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.sample.basicfamily,
org.eclipse.sirius.sample.basicfamily.impl,
org.eclipse.sirius.sample.basicfamily.util
diff --git a/plugins/org.eclipse.sirius.synchronizer/.classpath b/plugins/org.eclipse.sirius.synchronizer/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.synchronizer/.classpath
+++ b/plugins/org.eclipse.sirius.synchronizer/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.synchronizer/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.synchronizer/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.synchronizer/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.synchronizer/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.synchronizer/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.synchronizer/META-INF/MANIFEST.MF
index c685c237c2..a2b5f663af 100644
--- a/plugins/org.eclipse.sirius.synchronizer/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.synchronizer/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.synchronizer
Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %providerName
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
Export-Package: org.eclipse.sirius.synchronizer;version="3.1.0",
org.eclipse.sirius.synchronizer.internal;x-internal:=true;version="2.1.0"
diff --git a/plugins/org.eclipse.sirius.table.ui.ext/.classpath b/plugins/org.eclipse.sirius.table.ui.ext/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.table.ui.ext/.classpath
+++ b/plugins/org.eclipse.sirius.table.ui.ext/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.table.ui.ext/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.table.ui.ext/.settings/org.eclipse.jdt.core.prefs
index ebee6d68ae..85dde556c0 100644
--- a/plugins/org.eclipse.sirius.table.ui.ext/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.table.ui.ext/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.table.ui.ext/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.table.ui.ext/META-INF/MANIFEST.MF
index f6c57f6dbf..c466f0591f 100644
--- a/plugins/org.eclipse.sirius.table.ui.ext/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.table.ui.ext/META-INF/MANIFEST.MF
@@ -10,5 +10,5 @@ Require-Bundle: org.eclipse.sirius.table.ui;bundle-version="3.0.0",
org.eclipse.emf.common.ui;bundle-version="2.7.0"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.sirius.table.ui.ext.TableUIExtPlugin$Implementation
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.table.ui.ext;version="3.0.0"
diff --git a/plugins/org.eclipse.sirius.table.ui/.classpath b/plugins/org.eclipse.sirius.table.ui/.classpath
index f8026ce733..7ea04c0294 100644
--- a/plugins/org.eclipse.sirius.table.ui/.classpath
+++ b/plugins/org.eclipse.sirius.table.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.table.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.table.ui/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.table.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.table.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.table.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.table.ui/META-INF/MANIFEST.MF
index 82d65163d6..38631eca9b 100644
--- a/plugins/org.eclipse.sirius.table.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.table.ui/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Bundle-ClassPath: .
Bundle-Activator: org.eclipse.sirius.table.metamodel.table.provider.TableUIPlugin$Implementation
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.table.metamodel.table.description.provider;version="3.0.0",
org.eclipse.sirius.table.metamodel.table.provider;version="3.2.0",
org.eclipse.sirius.table.ui.business.api.helper;version="2.0.2",
diff --git a/plugins/org.eclipse.sirius.table/.classpath b/plugins/org.eclipse.sirius.table/.classpath
index b4943ea08a..e644e859af 100644
--- a/plugins/org.eclipse.sirius.table/.classpath
+++ b/plugins/org.eclipse.sirius.table/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.table/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.table/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.table/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.table/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.table/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.table/META-INF/MANIFEST.MF
index 9311736602..ef1102844b 100644
--- a/plugins/org.eclipse.sirius.table/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.table/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Version: 4.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.table.business.api.helper;version="3.0.0",
org.eclipse.sirius.table.business.api.query;version="2.0.4",
org.eclipse.sirius.table.business.api.refresh;version="2.0.4",
diff --git a/plugins/org.eclipse.sirius.tests.junit.support/.classpath b/plugins/org.eclipse.sirius.tests.junit.support/.classpath
index 39819a3af8..ed6b2676d4 100644
--- a/plugins/org.eclipse.sirius.tests.junit.support/.classpath
+++ b/plugins/org.eclipse.sirius.tests.junit.support/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.tests.junit.support/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.tests.junit.support/.settings/org.eclipse.jdt.core.prefs
index c537b63063..f42de363af 100644
--- a/plugins/org.eclipse.sirius.tests.junit.support/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.tests.junit.support/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,7 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
diff --git a/plugins/org.eclipse.sirius.tests.junit.support/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.junit.support/META-INF/MANIFEST.MF
index df050af882..8f0b5ddbd7 100644
--- a/plugins/org.eclipse.sirius.tests.junit.support/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.junit.support/META-INF/MANIFEST.MF
@@ -17,7 +17,7 @@ Require-Bundle: org.junit;bundle-version="[4.0.0,5.0.0)",
org.eclipse.ui.ide,
org.eclipse.sirius.diagram.ui,
org.eclipse.emf.edit.ui
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
Bundle-ActivationPolicy: lazy
Export-Package: org.eclipse.sirius.tests.support.api;version="1.2.0",
diff --git a/plugins/org.eclipse.sirius.tests.junit/.classpath b/plugins/org.eclipse.sirius.tests.junit/.classpath
index 39819a3af8..ed6b2676d4 100644
--- a/plugins/org.eclipse.sirius.tests.junit/.classpath
+++ b/plugins/org.eclipse.sirius.tests.junit/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.tests.junit/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.tests.junit/.settings/org.eclipse.jdt.core.prefs
index 811584fd02..b1cf2b4283 100644
--- a/plugins/org.eclipse.sirius.tests.junit/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.tests.junit/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -74,4 +74,4 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenImplementingAbstract=di
org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disabled
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
diff --git a/plugins/org.eclipse.sirius.tests.junit/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.junit/META-INF/MANIFEST.MF
index b84221db23..5a6605e3a8 100644
--- a/plugins/org.eclipse.sirius.tests.junit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.junit/META-INF/MANIFEST.MF
@@ -77,7 +77,7 @@ Require-Bundle: org.eclipse.sirius.tests.sample.benchmark,
Bundle-Activator: org.eclipse.sirius.tests.SiriusTestsPlugin
Eclipse-LazyStart: true
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Vendor: %providerName
Export-Package: org.eclipse.sirius.tests,
org.eclipse.sirius.tests.suite,
diff --git a/plugins/org.eclipse.sirius.tests.junit/data/unit/project/modeling/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.junit/data/unit/project/modeling/MANIFEST.MF
index 450c446323..fb6b34f982 100644
--- a/plugins/org.eclipse.sirius.tests.junit/data/unit/project/modeling/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.junit/data/unit/project/modeling/MANIFEST.MF
@@ -7,4 +7,4 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.sirius
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
diff --git a/plugins/org.eclipse.sirius.tests.sample.benchmark/.classpath b/plugins/org.eclipse.sirius.tests.sample.benchmark/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.tests.sample.benchmark/.classpath
+++ b/plugins/org.eclipse.sirius.tests.sample.benchmark/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.tests.sample.benchmark/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.tests.sample.benchmark/.settings/org.eclipse.jdt.core.prefs
index d6ebb635e3..5d58c9bd1d 100644
--- a/plugins/org.eclipse.sirius.tests.sample.benchmark/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.tests.sample.benchmark/.settings/org.eclipse.jdt.core.prefs
@@ -1,12 +1,12 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.problem.nonExternalizedStringLiteral=error
diff --git a/plugins/org.eclipse.sirius.tests.sample.benchmark/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.sample.benchmark/META-INF/MANIFEST.MF
index 9b4b825b7b..d5cfc546fa 100644
--- a/plugins/org.eclipse.sirius.tests.sample.benchmark/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.sample.benchmark/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Version: 4.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.tests.sample.benchmark,
org.eclipse.sirius.tests.sample.benchmark.impl,
org.eclipse.sirius.tests.sample.benchmark.util
diff --git a/plugins/org.eclipse.sirius.tests.sample.component.design/.classpath b/plugins/org.eclipse.sirius.tests.sample.component.design/.classpath
index 5d0495ecf1..bf640fa75a 100644
--- a/plugins/org.eclipse.sirius.tests.sample.component.design/.classpath
+++ b/plugins/org.eclipse.sirius.tests.sample.component.design/.classpath
@@ -2,7 +2,7 @@
<classpath>
<classpathentry kind="src" path="src"/>
<classpathentry kind="src" path="src-gen"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.sirius.tests.sample.component.design/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.tests.sample.component.design/.settings/org.eclipse.jdt.core.prefs
index c537b63063..f42de363af 100644
--- a/plugins/org.eclipse.sirius.tests.sample.component.design/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.tests.sample.component.design/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,7 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
diff --git a/plugins/org.eclipse.sirius.tests.sample.component.design/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.sample.component.design/META-INF/MANIFEST.MF
index 71ca1b54a0..2a50ca36f9 100644
--- a/plugins/org.eclipse.sirius.tests.sample.component.design/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.sample.component.design/META-INF/MANIFEST.MF
@@ -17,6 +17,6 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.sirius.tests.sample.component,
org.eclipse.sirius.common
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.tests.sample.component.presentation
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.sirius.tests.sample.component/.classpath b/plugins/org.eclipse.sirius.tests.sample.component/.classpath
index 121e527a93..3bc247511f 100644
--- a/plugins/org.eclipse.sirius.tests.sample.component/.classpath
+++ b/plugins/org.eclipse.sirius.tests.sample.component/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.sirius.tests.sample.component/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.sample.component/META-INF/MANIFEST.MF
index 0a3152a0b8..955d9f50fd 100644
--- a/plugins/org.eclipse.sirius.tests.sample.component/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.sample.component/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Version: 4.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.tests.sample.component,
org.eclipse.sirius.tests.sample.component.impl,
org.eclipse.sirius.tests.sample.component.util
diff --git a/plugins/org.eclipse.sirius.tests.sample.docbook.design/.classpath b/plugins/org.eclipse.sirius.tests.sample.docbook.design/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.tests.sample.docbook.design/.classpath
+++ b/plugins/org.eclipse.sirius.tests.sample.docbook.design/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.tests.sample.docbook.design/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.tests.sample.docbook.design/.settings/org.eclipse.jdt.core.prefs
index 8000cd6ca6..7341ab1683 100644
--- a/plugins/org.eclipse.sirius.tests.sample.docbook.design/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.tests.sample.docbook.design/.settings/org.eclipse.jdt.core.prefs
@@ -1,11 +1,11 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
diff --git a/plugins/org.eclipse.sirius.tests.sample.docbook.design/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.sample.docbook.design/META-INF/MANIFEST.MF
index a09434f00e..65961eb30e 100644
--- a/plugins/org.eclipse.sirius.tests.sample.docbook.design/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.sample.docbook.design/META-INF/MANIFEST.MF
@@ -10,7 +10,7 @@ Require-Bundle: org.eclipse.sirius.tests.sample.docbook,
Bundle-Vendor: %providerName
Bundle-Activator: org.eclipse.sirius.tests.sample.docbook.design.tool.SampleDocbookPlugin
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
Export-Package: org.eclipse.sirius.tests.sample.docbook.design.business.internal;x-internal:=true,
org.eclipse.sirius.tests.sample.docbook.design.tool
diff --git a/plugins/org.eclipse.sirius.tests.sample.docbook.edit/.classpath b/plugins/org.eclipse.sirius.tests.sample.docbook.edit/.classpath
index e4dad7e73e..75556083f6 100644
--- a/plugins/org.eclipse.sirius.tests.sample.docbook.edit/.classpath
+++ b/plugins/org.eclipse.sirius.tests.sample.docbook.edit/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src-gen"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.sirius.tests.sample.docbook.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.sample.docbook.edit/META-INF/MANIFEST.MF
index 7c909b18af..8b2e0e32e8 100644
--- a/plugins/org.eclipse.sirius.tests.sample.docbook.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.sample.docbook.edit/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Bundle-ClassPath: .
Bundle-Activator: org.eclipse.sirius.tests.sample.docbook.provider.DocbookEditPlugin$Implementation
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.tests.sample.docbook.provider,
org.eclipse.sirius.tests.sample.docbook.providers
Require-Bundle: org.eclipse.core.runtime,
diff --git a/plugins/org.eclipse.sirius.tests.sample.docbook.editor/.classpath b/plugins/org.eclipse.sirius.tests.sample.docbook.editor/.classpath
index e4dad7e73e..75556083f6 100644
--- a/plugins/org.eclipse.sirius.tests.sample.docbook.editor/.classpath
+++ b/plugins/org.eclipse.sirius.tests.sample.docbook.editor/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src-gen"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.sirius.tests.sample.docbook.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.sample.docbook.editor/META-INF/MANIFEST.MF
index fc24046574..40e2d5b970 100644
--- a/plugins/org.eclipse.sirius.tests.sample.docbook.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.sample.docbook.editor/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Bundle-ClassPath: .
Bundle-Activator: org.eclipse.sirius.tests.sample.docbook.presentation.DocbookEditorPlugin$Implementation
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.tests.sample.docbook.presentation
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.core.resources;visibility:=reexport,
diff --git a/plugins/org.eclipse.sirius.tests.sample.docbook/.classpath b/plugins/org.eclipse.sirius.tests.sample.docbook/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.tests.sample.docbook/.classpath
+++ b/plugins/org.eclipse.sirius.tests.sample.docbook/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.tests.sample.docbook/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.tests.sample.docbook/.settings/org.eclipse.jdt.core.prefs
index 8000cd6ca6..7341ab1683 100644
--- a/plugins/org.eclipse.sirius.tests.sample.docbook/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.tests.sample.docbook/.settings/org.eclipse.jdt.core.prefs
@@ -1,11 +1,11 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
diff --git a/plugins/org.eclipse.sirius.tests.sample.docbook/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.sample.docbook/META-INF/MANIFEST.MF
index 5704fdd326..cf25e013ea 100644
--- a/plugins/org.eclipse.sirius.tests.sample.docbook/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.sample.docbook/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Version: 4.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.tests.sample.docbook,
org.eclipse.sirius.tests.sample.docbook.impl,
org.eclipse.sirius.tests.sample.docbook.util
diff --git a/plugins/org.eclipse.sirius.tests.sample.migration.design/.classpath b/plugins/org.eclipse.sirius.tests.sample.migration.design/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.tests.sample.migration.design/.classpath
+++ b/plugins/org.eclipse.sirius.tests.sample.migration.design/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.tests.sample.migration.design/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.tests.sample.migration.design/.settings/org.eclipse.jdt.core.prefs
index c537b63063..f42de363af 100644
--- a/plugins/org.eclipse.sirius.tests.sample.migration.design/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.tests.sample.migration.design/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,7 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
diff --git a/plugins/org.eclipse.sirius.tests.sample.migration.design/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.sample.migration.design/META-INF/MANIFEST.MF
index d9b9c327dd..7e1531b699 100644
--- a/plugins/org.eclipse.sirius.tests.sample.migration.design/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.sample.migration.design/META-INF/MANIFEST.MF
@@ -15,7 +15,7 @@ Require-Bundle: org.eclipse.gmf.runtime.diagram.ui,
org.eclipse.sirius.diagram.ui;bundle-version="1.0.0",
org.eclipse.emf.common.ui;bundle-version="2.7.0"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
Export-Package: org.eclipse.sirius.tests.sample.migration.design
Bundle-Vendor: %providerName
diff --git a/plugins/org.eclipse.sirius.tests.sample.migration/.classpath b/plugins/org.eclipse.sirius.tests.sample.migration/.classpath
index c1f31893de..664b52ed75 100644
--- a/plugins/org.eclipse.sirius.tests.sample.migration/.classpath
+++ b/plugins/org.eclipse.sirius.tests.sample.migration/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src-gen"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.tests.sample.migration/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.tests.sample.migration/.settings/org.eclipse.jdt.core.prefs
index c537b63063..f42de363af 100644
--- a/plugins/org.eclipse.sirius.tests.sample.migration/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.tests.sample.migration/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,7 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
diff --git a/plugins/org.eclipse.sirius.tests.sample.migration/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.sample.migration/META-INF/MANIFEST.MF
index 60de6c234e..34855c9b50 100644
--- a/plugins/org.eclipse.sirius.tests.sample.migration/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.sample.migration/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Version: 4.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.tests.sample.migration.migrationmodeler,
org.eclipse.sirius.tests.sample.migration.migrationmodeler.impl,
org.eclipse.sirius.tests.sample.migration.migrationmodeler.util
diff --git a/plugins/org.eclipse.sirius.tests.sample.scxml.design/.classpath b/plugins/org.eclipse.sirius.tests.sample.scxml.design/.classpath
index 121e527a93..3bc247511f 100644
--- a/plugins/org.eclipse.sirius.tests.sample.scxml.design/.classpath
+++ b/plugins/org.eclipse.sirius.tests.sample.scxml.design/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.sirius.tests.sample.scxml.design/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.sample.scxml.design/META-INF/MANIFEST.MF
index b2b620e58c..0010d2707a 100644
--- a/plugins/org.eclipse.sirius.tests.sample.scxml.design/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.sample.scxml.design/META-INF/MANIFEST.MF
@@ -14,5 +14,5 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.sirius.tests.sample.scxml,
org.eclipse.sirius.common
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.sirius.tests.sample.scxml/.classpath b/plugins/org.eclipse.sirius.tests.sample.scxml/.classpath
index e4dad7e73e..75556083f6 100644
--- a/plugins/org.eclipse.sirius.tests.sample.scxml/.classpath
+++ b/plugins/org.eclipse.sirius.tests.sample.scxml/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src-gen"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.sirius.tests.sample.scxml/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.sample.scxml/META-INF/MANIFEST.MF
index d5cd6992c6..4e784958e8 100644
--- a/plugins/org.eclipse.sirius.tests.sample.scxml/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.sample.scxml/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Version: 4.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.tests.sample.scxml,
org.eclipse.sirius.tests.sample.scxml.impl,
org.eclipse.sirius.tests.sample.scxml.util
diff --git a/plugins/org.eclipse.sirius.tests.swtbot.support/.classpath b/plugins/org.eclipse.sirius.tests.swtbot.support/.classpath
index 39819a3af8..ed6b2676d4 100644
--- a/plugins/org.eclipse.sirius.tests.swtbot.support/.classpath
+++ b/plugins/org.eclipse.sirius.tests.swtbot.support/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.tests.swtbot.support/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.tests.swtbot.support/.settings/org.eclipse.jdt.core.prefs
index c47f91c28e..4c97ea80cf 100644
--- a/plugins/org.eclipse.sirius.tests.swtbot.support/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.tests.swtbot.support/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -21,4 +21,4 @@ org.eclipse.jdt.core.compiler.problem.missingJavadocTagDescription=all_standard_
org.eclipse.jdt.core.compiler.problem.missingJavadocTags=warning
org.eclipse.jdt.core.compiler.problem.missingJavadocTagsOverriding=disabled
org.eclipse.jdt.core.compiler.problem.missingJavadocTagsVisibility=protected
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
diff --git a/plugins/org.eclipse.sirius.tests.swtbot.support/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.swtbot.support/META-INF/MANIFEST.MF
index e47d3a15e0..522ab89d88 100644
--- a/plugins/org.eclipse.sirius.tests.swtbot.support/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.swtbot.support/META-INF/MANIFEST.MF
@@ -37,7 +37,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.ui.views.log,
org.eclipse.sirius.diagram.ui
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.tests.swtbot.support.api;
uses:="org.eclipse.sirius.tests.swtbot.support.api.business,org.eclipse.sirius.tests.swtbot.support.api.perspective,org.eclipse.swtbot.eclipse.gef.finder";version="1.0.0",
org.eclipse.sirius.tests.swtbot.support.api.bot;version="3.0.0",
diff --git a/plugins/org.eclipse.sirius.tests.swtbot/.classpath b/plugins/org.eclipse.sirius.tests.swtbot/.classpath
index 39819a3af8..ed6b2676d4 100644
--- a/plugins/org.eclipse.sirius.tests.swtbot/.classpath
+++ b/plugins/org.eclipse.sirius.tests.swtbot/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.tests.swtbot/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.tests.swtbot/.settings/org.eclipse.jdt.core.prefs
index 637ec21bc0..22bc713ae2 100644
--- a/plugins/org.eclipse.sirius.tests.swtbot/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.tests.swtbot/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,7 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.doc.comment.support=enabled
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
@@ -17,4 +17,4 @@ org.eclipse.jdt.core.compiler.problem.missingJavadocTagDescription=all_standard_
org.eclipse.jdt.core.compiler.problem.missingJavadocTags=warning
org.eclipse.jdt.core.compiler.problem.missingJavadocTagsOverriding=disabled
org.eclipse.jdt.core.compiler.problem.missingJavadocTagsVisibility=protected
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
diff --git a/plugins/org.eclipse.sirius.tests.swtbot/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.swtbot/META-INF/MANIFEST.MF
index d69f182b18..712123c57b 100644
--- a/plugins/org.eclipse.sirius.tests.swtbot/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.swtbot/META-INF/MANIFEST.MF
@@ -52,7 +52,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.sdk,
org.eclipse.platform
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Eclipse-RegisterBuddy: org.apache.log4j
Bundle-Vendor: %providerName
Export-Package: org.eclipse.sirius.tests.swtbot,
diff --git a/plugins/org.eclipse.sirius.tests.swtbot/data/unit/editor/vsm/completion/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.swtbot/data/unit/editor/vsm/completion/MANIFEST.MF
index 821e2d71a2..48a62c1180 100644
--- a/plugins/org.eclipse.sirius.tests.swtbot/data/unit/editor/vsm/completion/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.swtbot/data/unit/editor/vsm/completion/MANIFEST.MF
@@ -9,4 +9,4 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.sirius.common.acceleo.mtl,
org.eclipse.emf.ecore
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
diff --git a/plugins/org.eclipse.sirius.tests.tree/.classpath b/plugins/org.eclipse.sirius.tests.tree/.classpath
index 39819a3af8..ed6b2676d4 100644
--- a/plugins/org.eclipse.sirius.tests.tree/.classpath
+++ b/plugins/org.eclipse.sirius.tests.tree/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.tests.tree/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.tests.tree/.settings/org.eclipse.jdt.core.prefs
index 5c92e23f56..4408280549 100644
--- a/plugins/org.eclipse.sirius.tests.tree/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.tests.tree/.settings/org.eclipse.jdt.core.prefs
@@ -1,14 +1,14 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.formatter.align_type_members_on_columns=false
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_allocation_expression=16
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_annotation=0
diff --git a/plugins/org.eclipse.sirius.tests.tree/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tests.tree/META-INF/MANIFEST.MF
index fcd712052d..6bb9ac7091 100644
--- a/plugins/org.eclipse.sirius.tests.tree/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tests.tree/META-INF/MANIFEST.MF
@@ -38,7 +38,7 @@ Require-Bundle: org.eclipse.sirius,
org.eclipse.platform
Bundle-Activator: org.eclipse.sirius.tests.SiriusTreeTestsPlugin
Eclipse-LazyStart: true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Export-Package: org.eclipse.sirius.tests,
diff --git a/plugins/org.eclipse.sirius.tree.ui.ext/.classpath b/plugins/org.eclipse.sirius.tree.ui.ext/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.tree.ui.ext/.classpath
+++ b/plugins/org.eclipse.sirius.tree.ui.ext/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.tree.ui.ext/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.tree.ui.ext/.settings/org.eclipse.jdt.core.prefs
index ebee6d68ae..85dde556c0 100644
--- a/plugins/org.eclipse.sirius.tree.ui.ext/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.tree.ui.ext/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.tree.ui.ext/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tree.ui.ext/META-INF/MANIFEST.MF
index 955a6d9d8e..0bfdd1d22e 100644
--- a/plugins/org.eclipse.sirius.tree.ui.ext/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tree.ui.ext/META-INF/MANIFEST.MF
@@ -9,5 +9,5 @@ Require-Bundle: org.eclipse.sirius.tree.ui;bundle-version="3.0.0",
org.eclipse.osgi;bundle-version="0.0.0"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.sirius.tree.ui.ext.TreeUIExtPlugin$Implementation
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.tree.ui.ext;version="3.0.0"
diff --git a/plugins/org.eclipse.sirius.tree.ui/.classpath b/plugins/org.eclipse.sirius.tree.ui/.classpath
index b4943ea08a..e644e859af 100644
--- a/plugins/org.eclipse.sirius.tree.ui/.classpath
+++ b/plugins/org.eclipse.sirius.tree.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.tree.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.tree.ui/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.tree.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.tree.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.tree.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tree.ui/META-INF/MANIFEST.MF
index ca5836fac7..5baa15a23c 100644
--- a/plugins/org.eclipse.sirius.tree.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tree.ui/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Bundle-ClassPath: .
Bundle-Activator: org.eclipse.sirius.tree.ui.provider.TreeUIPlugin$Implementation
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.tree.description.provider;version="3.0.0",
org.eclipse.sirius.tree.provider;version="3.0.0",
org.eclipse.sirius.tree.ui.business.api.helper;version="2.0.4",
diff --git a/plugins/org.eclipse.sirius.tree/.classpath b/plugins/org.eclipse.sirius.tree/.classpath
index b4943ea08a..e644e859af 100644
--- a/plugins/org.eclipse.sirius.tree/.classpath
+++ b/plugins/org.eclipse.sirius.tree/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.tree/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.tree/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.tree/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.tree/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.tree/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.tree/META-INF/MANIFEST.MF
index 34b0426904..7b47f110dc 100644
--- a/plugins/org.eclipse.sirius.tree/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.tree/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Version: 4.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.tree;version="3.1.0",
org.eclipse.sirius.tree.business.api.command;version="2.1.0",
org.eclipse.sirius.tree.business.api.interaction;version="3.0.0",
diff --git a/plugins/org.eclipse.sirius.ui.debug/.classpath b/plugins/org.eclipse.sirius.ui.debug/.classpath
index ad32c83a78..098194ca4b 100644
--- a/plugins/org.eclipse.sirius.ui.debug/.classpath
+++ b/plugins/org.eclipse.sirius.ui.debug/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.sirius.ui.debug/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ui.debug/.settings/org.eclipse.jdt.core.prefs
index 8000cd6ca6..7341ab1683 100644
--- a/plugins/org.eclipse.sirius.ui.debug/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ui.debug/.settings/org.eclipse.jdt.core.prefs
@@ -1,11 +1,11 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
diff --git a/plugins/org.eclipse.sirius.ui.debug/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ui.debug/META-INF/MANIFEST.MF
index 2b4154bbef..ec50d76cbb 100644
--- a/plugins/org.eclipse.sirius.ui.debug/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ui.debug/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.sirius.ui.debug;singleton:=true
Bundle-Version: 3.0.0.qualifier
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-Localization: plugin
Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.properties,
org.eclipse.sirius.common,
diff --git a/plugins/org.eclipse.sirius.ui.ext/.classpath b/plugins/org.eclipse.sirius.ui.ext/.classpath
index f8c0202604..af46b84c1e 100644
--- a/plugins/org.eclipse.sirius.ui.ext/.classpath
+++ b/plugins/org.eclipse.sirius.ui.ext/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.ui.ext/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ui.ext/.settings/org.eclipse.jdt.core.prefs
index ebee6d68ae..85dde556c0 100644
--- a/plugins/org.eclipse.sirius.ui.ext/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ui.ext/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ui.ext/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ui.ext/META-INF/MANIFEST.MF
index ba063d3702..1fe5eca0e2 100644
--- a/plugins/org.eclipse.sirius.ui.ext/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ui.ext/META-INF/MANIFEST.MF
@@ -11,5 +11,5 @@ Require-Bundle: org.eclipse.sirius.ui;bundle-version="3.0.0",
org.eclipse.emf.common.ui;bundle-version="2.7.0"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.sirius.ui.ext.SiriusUIExtPlugin$Implementation
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Export-Package: org.eclipse.sirius.ui.ext;version="3.0.0"
diff --git a/plugins/org.eclipse.sirius.ui/.classpath b/plugins/org.eclipse.sirius.ui/.classpath
index b4943ea08a..e644e859af 100644
--- a/plugins/org.eclipse.sirius.ui/.classpath
+++ b/plugins/org.eclipse.sirius.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclipse/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius.ui/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius.ui/META-INF/MANIFEST.MF
index 5d1d4203ed..50f391fa23 100644
--- a/plugins/org.eclipse.sirius.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ui/META-INF/MANIFEST.MF
@@ -115,7 +115,7 @@ Require-Bundle: com.google.guava;bundle-version="[11.0.2,16.0)",
org.eclipse.ui.editors;bundle-version="3.8.0",
org.eclipse.core.filesystem;bundle-version="1.3.200"
Eclipse-LazyStart: true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-ActivationPolicy: lazy
Import-Package: org.eclipse.sirius.ext.base;version="2.1.0",
org.eclipse.sirius.ext.base.relations;version="2.0.0",
diff --git a/plugins/org.eclipse.sirius.ui/resources/MANIFEST.MF b/plugins/org.eclipse.sirius.ui/resources/MANIFEST.MF
index f609fc8208..d4256031a1 100644
--- a/plugins/org.eclipse.sirius.ui/resources/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius.ui/resources/MANIFEST.MF
@@ -10,4 +10,4 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.sirius,
org.eclipse.sirius.common.acceleo.aql
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
diff --git a/plugins/org.eclipse.sirius/.classpath b/plugins/org.eclipse.sirius/.classpath
index e86465ebb5..d691c3936f 100644
--- a/plugins/org.eclipse.sirius/.classpath
+++ b/plugins/org.eclipse.sirius/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins">
<accessrules>
<accessrule kind="accessible" pattern="org/eclise/sirius/**"/>
diff --git a/plugins/org.eclipse.sirius/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.sirius/.settings/org.eclipse.jdt.core.prefs
index 39e1d0d4d4..1a45a66fa2 100644
--- a/plugins/org.eclipse.sirius/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.sirius/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -66,7 +66,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core.compiler.source=1.7
org.eclipse.jdt.core.compiler.taskCaseSensitive=enabled
org.eclipse.jdt.core.compiler.taskPriorities=NORMAL,HIGH,NORMAL,NORMAL,NORMAL,NORMAL,NORMAL,HIGH
org.eclipse.jdt.core.compiler.taskTags=TODO,FIXME,XXX,TODOCBR,TODOMCH,TODOYMO,OPTIMISATION_POSSIBLE,TODONEWMM
diff --git a/plugins/org.eclipse.sirius/META-INF/MANIFEST.MF b/plugins/org.eclipse.sirius/META-INF/MANIFEST.MF
index 47a97bfa60..158fb27f6e 100644
--- a/plugins/org.eclipse.sirius/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.sirius/META-INF/MANIFEST.MF
@@ -132,5 +132,5 @@ Import-Package: org.eclipse.sirius.ext.base;version="2.0.0",
org.eclipse.sirius.ext.emf.tx;version="2.0.0"
Eclipse-LazyStart: true
Bundle-Activator: org.eclipse.sirius.viewpoint.SiriusPlugin$Implementation
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-ActivationPolicy: lazy
diff --git a/releng/org.eclipse.sirius.releng/checks.sh b/releng/org.eclipse.sirius.releng/checks.sh
index d0929d3eac..c0adf78b16 100755
--- a/releng/org.eclipse.sirius.releng/checks.sh
+++ b/releng/org.eclipse.sirius.releng/checks.sh
@@ -51,10 +51,10 @@ done
# All the about.html should be identical
# find . -name "about.html" -exec md5sum {} \; | sort | cut -d' ' -f1 | sort -u
-readonly BREE="JavaSE-1.6"
+readonly BREE="JavaSE-1.7"
check "All plug-ins have a consistent BREE ($BREE)"
BREES=$(git grep Bundle-RequiredExecutionEnvironment -- '**/MANIFEST.MF' | awk '{print $2}' | sort -u)
-[ "$BREES" = "JavaSE-1.6" ] || {
+[ "$BREES" = "JavaSE-1.7" ] || {
error "Inconsistent BREE detected: " $(echo "$BREES")
}
diff --git a/releng/org.eclipse.sirius.settings/Sirius.setup b/releng/org.eclipse.sirius.settings/Sirius.setup
index b6711c0727..19d6db808c 100644
--- a/releng/org.eclipse.sirius.settings/Sirius.setup
+++ b/releng/org.eclipse.sirius.settings/Sirius.setup
@@ -17,8 +17,8 @@
label="Sirius">
<setupTask
xsi:type="jdt:JRETask"
- version="JavaSE-1.6"
- location="${jre.location-1.6}">
+ version="JavaSE-1.7"
+ location="${jre.location-1.7}">
<description>Define the JRE needed to compile and run the Java projects of ${scope.project.label}</description>
</setupTask>
<setupTask
@@ -31,7 +31,7 @@
<setupTask
xsi:type="setup:EclipseIniTask"
option="-Dosgi.requiredJavaVersion"
- value="1.6"
+ value="1.7"
vm="true"/>
<setupTask
xsi:type="setup:ResourceCreationTask"

Back to the top