Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRalf Sternberg2012-07-21 15:56:33 +0000
committerRalf Sternberg2012-07-21 15:56:33 +0000
commit843853a3c04716817166516f03dc544fc89a71db (patch)
treefca3f70ba3de99ee8e4bc5c01d373559bbeedfb8 /bundles
parent0782514d04d58c2e8f3690b5dd610b8a54d22dec (diff)
downloadorg.eclipse.rap-843853a3c04716817166516f03dc544fc89a71db.tar.gz
org.eclipse.rap-843853a3c04716817166516f03dc544fc89a71db.tar.xz
org.eclipse.rap-843853a3c04716817166516f03dc544fc89a71db.zip
Raise version of rap.jface and rap.ui to 2.0.0
These bundles re-export RWT 2.0 which includes breaking changes, so their major version number must be increased, too.
Diffstat (limited to 'bundles')
-rw-r--r--bundles/org.eclipse.rap.demo.databinding/META-INF/MANIFEST.MF4
-rw-r--r--bundles/org.eclipse.rap.demo/META-INF/MANIFEST.MF2
-rw-r--r--bundles/org.eclipse.rap.design.example/META-INF/MANIFEST.MF2
-rw-r--r--bundles/org.eclipse.rap.examples.pages/META-INF/MANIFEST.MF2
-rw-r--r--bundles/org.eclipse.rap.jface.databinding/META-INF/MANIFEST.MF4
-rw-r--r--bundles/org.eclipse.rap.jface.databinding/pom.xml1
-rwxr-xr-xbundles/org.eclipse.rap.jface/META-INF/MANIFEST.MF2
-rw-r--r--bundles/org.eclipse.rap.jface/pom.xml1
-rw-r--r--bundles/org.eclipse.rap.junit.runtime/META-INF/MANIFEST.MF2
-rw-r--r--bundles/org.eclipse.rap.ui.cheatsheets/META-INF/MANIFEST.MF2
-rw-r--r--bundles/org.eclipse.rap.ui.forms/META-INF/MANIFEST.MF4
-rw-r--r--bundles/org.eclipse.rap.ui.views/META-INF/MANIFEST.MF2
-rwxr-xr-xbundles/org.eclipse.rap.ui.workbench/META-INF/MANIFEST.MF4
-rwxr-xr-xbundles/org.eclipse.rap.ui/META-INF/MANIFEST.MF4
-rw-r--r--bundles/org.eclipse.rap.ui/pom.xml1
15 files changed, 17 insertions, 20 deletions
diff --git a/bundles/org.eclipse.rap.demo.databinding/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.demo.databinding/META-INF/MANIFEST.MF
index 7f1f9fa7ae..2d2667312a 100644
--- a/bundles/org.eclipse.rap.demo.databinding/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.demo.databinding/META-INF/MANIFEST.MF
@@ -5,10 +5,10 @@ Bundle-SymbolicName: org.eclipse.rap.demo.databinding;singleton:=true
Bundle-Version: 1.5.100.qualifier
Bundle-Vendor: %Bundle-Vendor
Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.rap.jface.databinding;bundle-version="[1.5.100,2.0.0)",
+ org.eclipse.rap.jface.databinding;bundle-version="[2.0.0,3.0.0)",
org.eclipse.core.databinding,
org.eclipse.core.databinding.beans,
- org.eclipse.rap.ui;bundle-version="[1.5.100,2.0.0)"
+ org.eclipse.rap.ui;bundle-version="[2.0.0,3.0.0)"
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-Localization: plugin
Export-Package: org.eclipse.rap.demo.databinding;version="1.5.100";x-internal:=true,
diff --git a/bundles/org.eclipse.rap.demo/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.demo/META-INF/MANIFEST.MF
index aeea8e8087..45cb0a3d06 100644
--- a/bundles/org.eclipse.rap.demo/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.demo/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Bundle-Vendor: %Bundle-Vendor
Bundle-SymbolicName: org.eclipse.rap.demo;singleton:=true
Bundle-Version: 1.5.100.qualifier
Bundle-Localization: plugin
-Require-Bundle: org.eclipse.rap.ui;bundle-version="[1.5.100,2.0.0)",
+Require-Bundle: org.eclipse.rap.ui;bundle-version="[2.0.0,3.0.0)",
org.eclipse.rap.ui.views;bundle-version="[1.5.100,2.0.0)"
Import-Package: javax.servlet.http;version="[2.3.0,4.0.0)"
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/bundles/org.eclipse.rap.design.example/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.design.example/META-INF/MANIFEST.MF
index b8a448460e..97dcd0c283 100644
--- a/bundles/org.eclipse.rap.design.example/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.design.example/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Bundle-SymbolicName: org.eclipse.rap.design.example;singleton:=true
Bundle-Version: 1.5.100.qualifier
Bundle-Vendor: %Bundle-Vendor
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.rap.ui;bundle-version="[1.5.100,2.0.0)"
+Require-Bundle: org.eclipse.rap.ui;bundle-version="[2.0.0,3.0.0)"
Bundle-Localization: plugin
Export-Package: org.eclipse.rap.internal.design.example;version="1.5.100";x-internal:=true,
org.eclipse.rap.internal.design.example.builder;version="1.5.100";x-internal:=true,
diff --git a/bundles/org.eclipse.rap.examples.pages/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.examples.pages/META-INF/MANIFEST.MF
index 53120e37ff..b6ebb6535c 100644
--- a/bundles/org.eclipse.rap.examples.pages/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.examples.pages/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Bundle-Vendor: Eclipse.org - RAP
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ActivationPolicy: lazy
Require-Bundle: org.eclipse.rap.rwt;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.rap.jface;bundle-version="[1.5.100,2.0.0)",
+ org.eclipse.rap.jface;bundle-version="[2.0.0,3.0.0)",
org.eclipse.core.runtime;bundle-version="[3.8.0,4.0.0)"
Export-Package: org.eclipse.rap.examples.pages;version="1.5.100",
org.eclipse.rap.examples.pages.internal;version="1.5.100";x-internal:=true
diff --git a/bundles/org.eclipse.rap.jface.databinding/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.jface.databinding/META-INF/MANIFEST.MF
index 23d9fe13f0..d7c7080404 100644
--- a/bundles/org.eclipse.rap.jface.databinding/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.jface.databinding/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.rap.jface.databinding
-Bundle-Version: 1.5.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-ClassPath: patch.jar,
.
Bundle-Vendor: %providerName
@@ -20,7 +20,7 @@ Export-Package: org.eclipse.jface.databinding.dialog,
org.eclipse.jface.internal.databinding.util;x-internal:=true,
org.eclipse.jface.internal.databinding.viewers;x-internal:=true
Require-Bundle: org.eclipse.rap.rwt;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.rap.jface;bundle-version="[1.5.100,2.0.0)",
+ org.eclipse.rap.jface;bundle-version="[2.0.0,3.0.0)",
org.eclipse.equinox.common;bundle-version="[3.2.0,4.0.0)",
org.eclipse.core.databinding.observable;bundle-version="[1.3.0,2.0.0)",
org.eclipse.core.databinding.property;bundle-version="[1.3.0,2.0.0)",
diff --git a/bundles/org.eclipse.rap.jface.databinding/pom.xml b/bundles/org.eclipse.rap.jface.databinding/pom.xml
index beceae1767..777fae65e5 100644
--- a/bundles/org.eclipse.rap.jface.databinding/pom.xml
+++ b/bundles/org.eclipse.rap.jface.databinding/pom.xml
@@ -22,7 +22,6 @@
</parent>
<artifactId>org.eclipse.rap.jface.databinding</artifactId>
- <version>1.5.100-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/bundles/org.eclipse.rap.jface/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.jface/META-INF/MANIFEST.MF
index 267895399b..f5b7bed140 100755
--- a/bundles/org.eclipse.rap.jface/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.jface/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.rap.jface
-Bundle-Version: 1.5.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-ClassPath: patch.jar,
.
Eclipse-ExtensibleAPI: true
diff --git a/bundles/org.eclipse.rap.jface/pom.xml b/bundles/org.eclipse.rap.jface/pom.xml
index dc88f08ff0..cfc65248a4 100644
--- a/bundles/org.eclipse.rap.jface/pom.xml
+++ b/bundles/org.eclipse.rap.jface/pom.xml
@@ -22,7 +22,6 @@
</parent>
<artifactId>org.eclipse.rap.jface</artifactId>
- <version>1.5.100-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/bundles/org.eclipse.rap.junit.runtime/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.junit.runtime/META-INF/MANIFEST.MF
index aa1d5cc96f..296b1848d5 100644
--- a/bundles/org.eclipse.rap.junit.runtime/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.junit.runtime/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Bundle-Vendor: %Bundle-Vendor
Bundle-SymbolicName: org.eclipse.rap.junit.runtime; singleton:=true
Bundle-Version: 1.5.100.qualifier
Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.rap.ui;bundle-version="[1.5.100,2.0.0)",
+ org.eclipse.rap.ui;bundle-version="[2.0.0,3.0.0)",
org.eclipse.jdt.junit.runtime,
org.junit;bundle-version="[3.8.2,4.0.0)"
Import-Package: javax.servlet;version="[2.3.0,4.0.0)",
diff --git a/bundles/org.eclipse.rap.ui.cheatsheets/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.ui.cheatsheets/META-INF/MANIFEST.MF
index f985014cd0..56ec5514c6 100644
--- a/bundles/org.eclipse.rap.ui.cheatsheets/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.ui.cheatsheets/META-INF/MANIFEST.MF
@@ -22,7 +22,7 @@ Export-Package: org.eclipse.ui.cheatsheets,
org.eclipse.ui.internal.provisional.cheatsheets;x-friends:="org.eclipse.ua.tests"
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.1.0,4.0.0)",
org.eclipse.core.expressions;bundle-version="3.4.0",
- org.eclipse.rap.ui;bundle-version="[1.5.100,2.0.0)",
+ org.eclipse.rap.ui;bundle-version="[2.0.0,3.0.0)",
org.eclipse.rap.ui.forms;bundle-version="[1.5.100,2.0.0)",
org.eclipse.help;bundle-version="[3.2.0,4.0.0)"
Eclipse-LazyStart: true
diff --git a/bundles/org.eclipse.rap.ui.forms/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.ui.forms/META-INF/MANIFEST.MF
index 0aebe36425..0c956bf738 100644
--- a/bundles/org.eclipse.rap.ui.forms/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.ui.forms/META-INF/MANIFEST.MF
@@ -13,8 +13,8 @@ Export-Package: org.eclipse.ui.forms,
org.eclipse.ui.internal.forms;x-internal:=true,
org.eclipse.ui.internal.forms.widgets;x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.1.0,4.0.0)",
- org.eclipse.rap.jface;bundle-version="[1.5.100,2.0.0)",
- org.eclipse.rap.ui;bundle-version="[1.5.100,2.0.0)";resolution:=optional
+ org.eclipse.rap.jface;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.rap.ui;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Eclipse-LazyStart: true
Import-Package: com.ibm.icu.text,
javax.xml.parsers,
diff --git a/bundles/org.eclipse.rap.ui.views/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.ui.views/META-INF/MANIFEST.MF
index ae01a85971..63d7ade618 100644
--- a/bundles/org.eclipse.rap.ui.views/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.ui.views/META-INF/MANIFEST.MF
@@ -15,7 +15,7 @@ Export-Package: org.eclipse.ui.internal.views;x-internal:=true,
org.eclipse.ui.views.contentoutline,
org.eclipse.ui.views.properties; ui.views="split"; mandatory:="ui.views"
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.2.0,4.0.0)",
- org.eclipse.rap.ui;bundle-version="[1.5.100,4.0.0)",
+ org.eclipse.rap.ui;bundle-version="[2.0.0,3.0.0)",
org.eclipse.help;bundle-version="[3.2.0,4.0.0)"
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Eclipse-LazyStart: true
diff --git a/bundles/org.eclipse.rap.ui.workbench/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.ui.workbench/META-INF/MANIFEST.MF
index fa8f590bf7..5d6562143a 100755
--- a/bundles/org.eclipse.rap.ui.workbench/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.ui.workbench/META-INF/MANIFEST.MF
@@ -98,13 +98,13 @@ Export-Package: org.eclipse.rap.ui.branding;version="1.5.100",
org.eclipse.ui.views,
org.eclipse.ui.wizards
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.6.0,4.0.0)";visibility:=reexport,
- org.eclipse.rap.jface;bundle-version="[1.5.100,2.0.0)",
+ org.eclipse.rap.jface;bundle-version="[2.0.0,3.0.0)",
org.eclipse.rap.rwt;bundle-version="[2.0.0,3.0.0)",
org.eclipse.help;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.expressions;bundle-version="[3.4.0,4.0.0)",
org.eclipse.equinox.http.registry,
org.eclipse.osgi.services,
- org.eclipse.rap.jface.databinding;bundle-version="[1.4.0,2.0.0)",
+ org.eclipse.rap.jface.databinding;bundle-version="[2.0.0,3.0.0)",
org.eclipse.core.databinding.property;bundle-version="[1.2.0,2.0.0)",
org.eclipse.core.databinding.observable;bundle-version="[1.2.0,2.0.0)"
Import-Package: com.ibm.icu.text,
diff --git a/bundles/org.eclipse.rap.ui/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.ui/META-INF/MANIFEST.MF
index 8bb2c5b10c..59f1ed0027 100755
--- a/bundles/org.eclipse.rap.ui/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Plugin.name
Bundle-SymbolicName: org.eclipse.rap.ui; singleton:=true
-Bundle-Version: 1.5.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-ClassPath: patch.jar,
.
Eclipse-ExtensibleAPI: true
@@ -14,7 +14,7 @@ Import-Package: javax.servlet.http;version="2.3.0"
Export-Package: org.eclipse.ui.internal;x-friends:="org.eclipse.rap.ui"
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.6.0,4.0.0)",
org.eclipse.rap.rwt;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
- org.eclipse.rap.jface;bundle-version="[1.5.100,2.0.0)";visibility:=reexport,
+ org.eclipse.rap.jface;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
org.eclipse.rap.ui.workbench;bundle-version="[1.5.100,2.0.0)";visibility:=reexport,
org.eclipse.core.expressions;bundle-version="[3.4.0,4.0.0)",
org.eclipse.osgi.services;bundle-version="[3.2.0,4.0.0)"
diff --git a/bundles/org.eclipse.rap.ui/pom.xml b/bundles/org.eclipse.rap.ui/pom.xml
index 340f6b5fd5..33676ba7ac 100644
--- a/bundles/org.eclipse.rap.ui/pom.xml
+++ b/bundles/org.eclipse.rap.ui/pom.xml
@@ -22,7 +22,6 @@
</parent>
<artifactId>org.eclipse.rap.ui</artifactId>
- <version>1.5.100-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>

Back to the top