Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Staudacher2011-05-30 15:35:21 +0000
committerHolger Staudacher2011-05-30 15:35:21 +0000
commit4507af186aecbf51c61e4b5acc199a16a0d8ef5d (patch)
treec5cb35b9ebada7cf38875b053e8b265f1f229df7 /bundles
parent0fa7d6addab3d3c72720590ad14af0bb7167e9a1 (diff)
downloadorg.eclipse.rap-4507af186aecbf51c61e4b5acc199a16a0d8ef5d.tar.gz
org.eclipse.rap-4507af186aecbf51c61e4b5acc199a16a0d8ef5d.tar.xz
org.eclipse.rap-4507af186aecbf51c61e4b5acc199a16a0d8ef5d.zip
RESOLVED 340310: Consider changing the minimum required execution environment to J2SE-1.5
https://bugs.eclipse.org/bugs/show_bug.cgi?id=340310
Diffstat (limited to 'bundles')
-rw-r--r--bundles/org.eclipse.rap.demo.databinding/.classpath2
-rw-r--r--bundles/org.eclipse.rap.demo.databinding/.settings/org.eclipse.jdt.core.prefs15
-rw-r--r--bundles/org.eclipse.rap.demo.databinding/META-INF/MANIFEST.MF4
-rw-r--r--bundles/org.eclipse.rap.demo/.classpath2
-rw-r--r--bundles/org.eclipse.rap.demo/.settings/org.eclipse.jdt.core.prefs15
-rw-r--r--bundles/org.eclipse.rap.demo/META-INF/MANIFEST.MF4
-rw-r--r--bundles/org.eclipse.rap.design.example/.classpath2
-rw-r--r--bundles/org.eclipse.rap.design.example/.settings/org.eclipse.jdt.core.prefs13
-rw-r--r--bundles/org.eclipse.rap.design.example/META-INF/MANIFEST.MF4
-rw-r--r--bundles/org.eclipse.rap.examples/.classpath2
-rw-r--r--bundles/org.eclipse.rap.examples/.settings/org.eclipse.jdt.core.prefs15
-rw-r--r--bundles/org.eclipse.rap.examples/META-INF/MANIFEST.MF2
-rw-r--r--bundles/org.eclipse.rap.jettycustomizer/.classpath2
-rw-r--r--bundles/org.eclipse.rap.jettycustomizer/.settings/org.eclipse.jdt.core.prefs15
-rw-r--r--bundles/org.eclipse.rap.jettycustomizer/META-INF/MANIFEST.MF4
-rw-r--r--bundles/org.eclipse.rap.jface.databinding/META-INF/MANIFEST.MF2
-rwxr-xr-xbundles/org.eclipse.rap.jface/META-INF/MANIFEST.MF2
-rw-r--r--bundles/org.eclipse.rap.junit/.classpath2
-rw-r--r--bundles/org.eclipse.rap.junit/.settings/org.eclipse.jdt.core.prefs13
-rw-r--r--bundles/org.eclipse.rap.junit/META-INF/MANIFEST.MF4
-rw-r--r--bundles/org.eclipse.rap.rwt.q07/.classpath2
-rw-r--r--bundles/org.eclipse.rap.rwt.q07/.settings/org.eclipse.jdt.core.prefs15
-rw-r--r--bundles/org.eclipse.rap.rwt.q07/META-INF/MANIFEST.MF4
-rw-r--r--bundles/org.eclipse.rap.rwt.theme.classic/.classpath2
-rw-r--r--bundles/org.eclipse.rap.rwt.theme.classic/.settings/org.eclipse.jdt.core.prefs13
-rw-r--r--bundles/org.eclipse.rap.rwt.theme.classic/META-INF/MANIFEST.MF4
-rw-r--r--bundles/org.eclipse.rap.rwt/.classpath2
-rw-r--r--bundles/org.eclipse.rap.rwt/.settings/org.eclipse.jdt.core.prefs15
-rw-r--r--bundles/org.eclipse.rap.rwt/META-INF/MANIFEST.MF4
-rw-r--r--bundles/org.eclipse.rap.ui.cheatsheets/META-INF/MANIFEST.MF2
-rw-r--r--bundles/org.eclipse.rap.ui.forms/META-INF/MANIFEST.MF2
-rw-r--r--bundles/org.eclipse.rap.ui.views/META-INF/MANIFEST.MF2
-rwxr-xr-xbundles/org.eclipse.rap.ui.workbench/META-INF/MANIFEST.MF2
-rwxr-xr-xbundles/org.eclipse.rap.ui/META-INF/MANIFEST.MF2
34 files changed, 94 insertions, 101 deletions
diff --git a/bundles/org.eclipse.rap.demo.databinding/.classpath b/bundles/org.eclipse.rap.demo.databinding/.classpath
index 2fbb7a23e1..5e4c1fe99c 100644
--- a/bundles/org.eclipse.rap.demo.databinding/.classpath
+++ b/bundles/org.eclipse.rap.demo.databinding/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/bundles/org.eclipse.rap.demo.databinding/.settings/org.eclipse.jdt.core.prefs b/bundles/org.eclipse.rap.demo.databinding/.settings/org.eclipse.jdt.core.prefs
index 40fff0bf4d..73b2846eb8 100644
--- a/bundles/org.eclipse.rap.demo.databinding/.settings/org.eclipse.jdt.core.prefs
+++ b/bundles/org.eclipse.rap.demo.databinding/.settings/org.eclipse.jdt.core.prefs
@@ -1,14 +1,14 @@
-#Tue Mar 08 23:05:59 CET 2011
+#Mon May 30 17:01:01 CEST 2011
eclipse.preferences.version=1
-org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=disabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.compliance=1.5
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.annotationSuperInterface=warning
-org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.autoboxing=error
org.eclipse.jdt.core.compiler.problem.comparingIdentical=warning
org.eclipse.jdt.core.compiler.problem.deadCode=warning
@@ -17,7 +17,7 @@ org.eclipse.jdt.core.compiler.problem.deprecationInDeprecatedCode=disabled
org.eclipse.jdt.core.compiler.problem.deprecationWhenOverridingDeprecatedMethod=disabled
org.eclipse.jdt.core.compiler.problem.discouragedReference=warning
org.eclipse.jdt.core.compiler.problem.emptyStatement=warning
-org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
org.eclipse.jdt.core.compiler.problem.fallthroughCase=warning
org.eclipse.jdt.core.compiler.problem.fatalOptionalError=enabled
org.eclipse.jdt.core.compiler.problem.fieldHiding=ignore
@@ -78,7 +78,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.3
+org.eclipse.jdt.core.compiler.source=1.5
org.eclipse.jdt.core.formatter.align_type_members_on_columns=false
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_allocation_expression=82
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_annotation=0
@@ -160,7 +160,6 @@ org.eclipse.jdt.core.formatter.indent_switchstatements_compare_to_switch=true
org.eclipse.jdt.core.formatter.indentation.size=4
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_field=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_local_variable=insert
-org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_member=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_method=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_package=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_parameter=do not insert
diff --git a/bundles/org.eclipse.rap.demo.databinding/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.demo.databinding/META-INF/MANIFEST.MF
index 89372dc2bd..61704de620 100644
--- a/bundles/org.eclipse.rap.demo.databinding/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.demo.databinding/META-INF/MANIFEST.MF
@@ -2,11 +2,11 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.rap.demo.databinding;singleton:=true
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Bundle-Vendor: %Bundle-Vendor
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.rap.jface.databinding,
org.eclipse.core.databinding,
org.eclipse.core.databinding.beans,
org.eclipse.rap.ui
-Bundle-RequiredExecutionEnvironment: J2SE-1.4
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/bundles/org.eclipse.rap.demo/.classpath b/bundles/org.eclipse.rap.demo/.classpath
index 2fbb7a23e1..5e4c1fe99c 100644
--- a/bundles/org.eclipse.rap.demo/.classpath
+++ b/bundles/org.eclipse.rap.demo/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/bundles/org.eclipse.rap.demo/.settings/org.eclipse.jdt.core.prefs b/bundles/org.eclipse.rap.demo/.settings/org.eclipse.jdt.core.prefs
index a3cd945f4b..054fcefb0b 100644
--- a/bundles/org.eclipse.rap.demo/.settings/org.eclipse.jdt.core.prefs
+++ b/bundles/org.eclipse.rap.demo/.settings/org.eclipse.jdt.core.prefs
@@ -1,14 +1,14 @@
-#Tue Mar 08 23:05:49 CET 2011
+#Mon May 30 16:59:41 CEST 2011
eclipse.preferences.version=1
-org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=disabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.compliance=1.5
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.annotationSuperInterface=warning
-org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.autoboxing=error
org.eclipse.jdt.core.compiler.problem.comparingIdentical=warning
org.eclipse.jdt.core.compiler.problem.deadCode=warning
@@ -17,7 +17,7 @@ org.eclipse.jdt.core.compiler.problem.deprecationInDeprecatedCode=disabled
org.eclipse.jdt.core.compiler.problem.deprecationWhenOverridingDeprecatedMethod=disabled
org.eclipse.jdt.core.compiler.problem.discouragedReference=warning
org.eclipse.jdt.core.compiler.problem.emptyStatement=warning
-org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
org.eclipse.jdt.core.compiler.problem.fallthroughCase=warning
org.eclipse.jdt.core.compiler.problem.fatalOptionalError=enabled
org.eclipse.jdt.core.compiler.problem.fieldHiding=ignore
@@ -78,7 +78,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.3
+org.eclipse.jdt.core.compiler.source=1.5
org.eclipse.jdt.core.formatter.align_type_members_on_columns=false
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_allocation_expression=82
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_annotation=0
@@ -160,7 +160,6 @@ org.eclipse.jdt.core.formatter.indent_switchstatements_compare_to_switch=true
org.eclipse.jdt.core.formatter.indentation.size=4
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_field=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_local_variable=insert
-org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_member=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_method=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_package=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_parameter=do not insert
diff --git a/bundles/org.eclipse.rap.demo/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.demo/META-INF/MANIFEST.MF
index adbfe0f0a2..927df739ac 100644
--- a/bundles/org.eclipse.rap.demo/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.demo/META-INF/MANIFEST.MF
@@ -2,13 +2,13 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.rap.demo; singleton := true
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Bundle-Localization: plugin
Require-Bundle: org.eclipse.rap.ui,
org.eclipse.rap.ui.views
Import-Package: javax.servlet.http;version="2.3.0"
Bundle-Vendor: %Bundle-Vendor
-Bundle-RequiredExecutionEnvironment: J2SE-1.4
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.rap.demo;x-internal:=true,
org.eclipse.rap.demo.actions;x-internal:=true,
org.eclipse.rap.demo.controls;x-internal:=true,
diff --git a/bundles/org.eclipse.rap.design.example/.classpath b/bundles/org.eclipse.rap.design.example/.classpath
index 2fbb7a23e1..5e4c1fe99c 100644
--- a/bundles/org.eclipse.rap.design.example/.classpath
+++ b/bundles/org.eclipse.rap.design.example/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/bundles/org.eclipse.rap.design.example/.settings/org.eclipse.jdt.core.prefs b/bundles/org.eclipse.rap.design.example/.settings/org.eclipse.jdt.core.prefs
index 6d5b24840c..173fce939f 100644
--- a/bundles/org.eclipse.rap.design.example/.settings/org.eclipse.jdt.core.prefs
+++ b/bundles/org.eclipse.rap.design.example/.settings/org.eclipse.jdt.core.prefs
@@ -1,14 +1,14 @@
-#Tue Mar 08 23:06:10 CET 2011
+#Mon May 30 17:03:13 CEST 2011
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.compliance=1.5
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.annotationSuperInterface=warning
-org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.autoboxing=error
org.eclipse.jdt.core.compiler.problem.comparingIdentical=warning
org.eclipse.jdt.core.compiler.problem.deadCode=warning
@@ -17,7 +17,7 @@ org.eclipse.jdt.core.compiler.problem.deprecationInDeprecatedCode=disabled
org.eclipse.jdt.core.compiler.problem.deprecationWhenOverridingDeprecatedMethod=disabled
org.eclipse.jdt.core.compiler.problem.discouragedReference=warning
org.eclipse.jdt.core.compiler.problem.emptyStatement=warning
-org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
org.eclipse.jdt.core.compiler.problem.fallthroughCase=warning
org.eclipse.jdt.core.compiler.problem.fatalOptionalError=enabled
org.eclipse.jdt.core.compiler.problem.fieldHiding=ignore
@@ -78,7 +78,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.3
+org.eclipse.jdt.core.compiler.source=1.5
org.eclipse.jdt.core.formatter.align_type_members_on_columns=false
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_allocation_expression=82
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_annotation=0
@@ -160,7 +160,6 @@ org.eclipse.jdt.core.formatter.indent_switchstatements_compare_to_switch=true
org.eclipse.jdt.core.formatter.indentation.size=4
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_field=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_local_variable=insert
-org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_member=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_method=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_package=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_parameter=do not insert
diff --git a/bundles/org.eclipse.rap.design.example/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.design.example/META-INF/MANIFEST.MF
index 7c991c48a6..e8155868c0 100644
--- a/bundles/org.eclipse.rap.design.example/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.design.example/META-INF/MANIFEST.MF
@@ -2,9 +2,9 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.rap.design.example;singleton:=true
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Bundle-Vendor: %Bundle-Vendor
-Bundle-RequiredExecutionEnvironment: J2SE-1.4
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: org.eclipse.rap.ui;bundle-version="1.2.0"
Bundle-Localization: plugin
Export-Package: org.eclipse.rap.internal.design.example.builder;x-internal:=true,
diff --git a/bundles/org.eclipse.rap.examples/.classpath b/bundles/org.eclipse.rap.examples/.classpath
index 2fbb7a23e1..5e4c1fe99c 100644
--- a/bundles/org.eclipse.rap.examples/.classpath
+++ b/bundles/org.eclipse.rap.examples/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/bundles/org.eclipse.rap.examples/.settings/org.eclipse.jdt.core.prefs b/bundles/org.eclipse.rap.examples/.settings/org.eclipse.jdt.core.prefs
index 29f4097268..aa1a761bf9 100644
--- a/bundles/org.eclipse.rap.examples/.settings/org.eclipse.jdt.core.prefs
+++ b/bundles/org.eclipse.rap.examples/.settings/org.eclipse.jdt.core.prefs
@@ -1,14 +1,14 @@
-#Tue Mar 08 23:06:20 CET 2011
+#Mon May 30 17:03:52 CEST 2011
eclipse.preferences.version=1
-org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=disabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.compliance=1.5
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.annotationSuperInterface=warning
-org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.autoboxing=error
org.eclipse.jdt.core.compiler.problem.comparingIdentical=warning
org.eclipse.jdt.core.compiler.problem.deadCode=warning
@@ -17,7 +17,7 @@ org.eclipse.jdt.core.compiler.problem.deprecationInDeprecatedCode=disabled
org.eclipse.jdt.core.compiler.problem.deprecationWhenOverridingDeprecatedMethod=disabled
org.eclipse.jdt.core.compiler.problem.discouragedReference=warning
org.eclipse.jdt.core.compiler.problem.emptyStatement=warning
-org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
org.eclipse.jdt.core.compiler.problem.fallthroughCase=warning
org.eclipse.jdt.core.compiler.problem.fatalOptionalError=enabled
org.eclipse.jdt.core.compiler.problem.fieldHiding=ignore
@@ -78,7 +78,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.3
+org.eclipse.jdt.core.compiler.source=1.5
org.eclipse.jdt.core.formatter.align_type_members_on_columns=false
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_allocation_expression=82
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_annotation=0
@@ -160,7 +160,6 @@ org.eclipse.jdt.core.formatter.indent_switchstatements_compare_to_switch=true
org.eclipse.jdt.core.formatter.indentation.size=4
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_field=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_local_variable=insert
-org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_member=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_method=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_package=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_parameter=do not insert
diff --git a/bundles/org.eclipse.rap.examples/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.examples/META-INF/MANIFEST.MF
index b4f1be103f..2f52231b86 100644
--- a/bundles/org.eclipse.rap.examples/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.examples/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Require-Bundle: org.eclipse.rap.ui;bundle-version="[1.2.0,2.0.0)",
org.eclipse.rap.design.example;bundle-version="[1.2.0,2.0.0)",
org.eclipse.equinox.http.registry;bundle-version="1.0.200"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.4
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
Import-Package: javax.servlet;version="2.4.0",
javax.servlet.http;version="2.4.0"
Export-Package: org.eclipse.rap.examples,
diff --git a/bundles/org.eclipse.rap.jettycustomizer/.classpath b/bundles/org.eclipse.rap.jettycustomizer/.classpath
index 2fbb7a23e1..5e4c1fe99c 100644
--- a/bundles/org.eclipse.rap.jettycustomizer/.classpath
+++ b/bundles/org.eclipse.rap.jettycustomizer/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/bundles/org.eclipse.rap.jettycustomizer/.settings/org.eclipse.jdt.core.prefs b/bundles/org.eclipse.rap.jettycustomizer/.settings/org.eclipse.jdt.core.prefs
index 0eb2e378c5..e929e5f9a6 100644
--- a/bundles/org.eclipse.rap.jettycustomizer/.settings/org.eclipse.jdt.core.prefs
+++ b/bundles/org.eclipse.rap.jettycustomizer/.settings/org.eclipse.jdt.core.prefs
@@ -1,14 +1,14 @@
-#Tue Mar 08 23:06:39 CET 2011
+#Mon May 30 17:05:20 CEST 2011
eclipse.preferences.version=1
-org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=disabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.compliance=1.5
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.annotationSuperInterface=warning
-org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.autoboxing=error
org.eclipse.jdt.core.compiler.problem.comparingIdentical=warning
org.eclipse.jdt.core.compiler.problem.deadCode=warning
@@ -17,7 +17,7 @@ org.eclipse.jdt.core.compiler.problem.deprecationInDeprecatedCode=disabled
org.eclipse.jdt.core.compiler.problem.deprecationWhenOverridingDeprecatedMethod=disabled
org.eclipse.jdt.core.compiler.problem.discouragedReference=warning
org.eclipse.jdt.core.compiler.problem.emptyStatement=warning
-org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
org.eclipse.jdt.core.compiler.problem.fallthroughCase=warning
org.eclipse.jdt.core.compiler.problem.fatalOptionalError=enabled
org.eclipse.jdt.core.compiler.problem.fieldHiding=ignore
@@ -78,7 +78,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.3
+org.eclipse.jdt.core.compiler.source=1.5
org.eclipse.jdt.core.formatter.align_type_members_on_columns=false
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_allocation_expression=82
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_annotation=0
@@ -160,7 +160,6 @@ org.eclipse.jdt.core.formatter.indent_switchstatements_compare_to_switch=true
org.eclipse.jdt.core.formatter.indentation.size=4
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_field=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_local_variable=insert
-org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_member=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_method=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_package=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_parameter=do not insert
diff --git a/bundles/org.eclipse.rap.jettycustomizer/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.jettycustomizer/META-INF/MANIFEST.MF
index 33ff3bed02..3d0c1cc4f4 100644
--- a/bundles/org.eclipse.rap.jettycustomizer/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.jettycustomizer/META-INF/MANIFEST.MF
@@ -2,9 +2,9 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.rap.jettycustomizer
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Fragment-Host: org.eclipse.equinox.http.jetty;bundle-version="[2.0.0,2.9.9)"
-Bundle-RequiredExecutionEnvironment: J2SE-1.4
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-Vendor: %Bundle-Vendor
Export-Package: org.eclipse.rap.jettycustomizer.internal;x-internal:=true
Bundle-Localization: plugin
diff --git a/bundles/org.eclipse.rap.jface.databinding/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.jface.databinding/META-INF/MANIFEST.MF
index 9a19d8ae99..059f2ec36b 100644
--- a/bundles/org.eclipse.rap.jface.databinding/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.jface.databinding/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.rap.jface.databinding
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Bundle-ClassPath: patch.jar,
.
Bundle-Vendor: %providerName
diff --git a/bundles/org.eclipse.rap.jface/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.jface/META-INF/MANIFEST.MF
index 2187cba946..927c103235 100755
--- a/bundles/org.eclipse.rap.jface/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.jface/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.rap.jface
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Bundle-ClassPath: patch.jar,
.
Eclipse-ExtensibleAPI: true
diff --git a/bundles/org.eclipse.rap.junit/.classpath b/bundles/org.eclipse.rap.junit/.classpath
index 2fbb7a23e1..5e4c1fe99c 100644
--- a/bundles/org.eclipse.rap.junit/.classpath
+++ b/bundles/org.eclipse.rap.junit/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/bundles/org.eclipse.rap.junit/.settings/org.eclipse.jdt.core.prefs b/bundles/org.eclipse.rap.junit/.settings/org.eclipse.jdt.core.prefs
index 24fdbc5bee..a3b92a1dd6 100644
--- a/bundles/org.eclipse.rap.junit/.settings/org.eclipse.jdt.core.prefs
+++ b/bundles/org.eclipse.rap.junit/.settings/org.eclipse.jdt.core.prefs
@@ -1,14 +1,14 @@
-#Tue Mar 08 23:06:55 CET 2011
+#Mon May 30 17:08:17 CEST 2011
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.compliance=1.5
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.annotationSuperInterface=warning
-org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.autoboxing=error
org.eclipse.jdt.core.compiler.problem.comparingIdentical=warning
org.eclipse.jdt.core.compiler.problem.deadCode=warning
@@ -17,7 +17,7 @@ org.eclipse.jdt.core.compiler.problem.deprecationInDeprecatedCode=disabled
org.eclipse.jdt.core.compiler.problem.deprecationWhenOverridingDeprecatedMethod=disabled
org.eclipse.jdt.core.compiler.problem.discouragedReference=warning
org.eclipse.jdt.core.compiler.problem.emptyStatement=warning
-org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
org.eclipse.jdt.core.compiler.problem.fallthroughCase=warning
org.eclipse.jdt.core.compiler.problem.fatalOptionalError=enabled
org.eclipse.jdt.core.compiler.problem.fieldHiding=ignore
@@ -78,7 +78,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.3
+org.eclipse.jdt.core.compiler.source=1.5
org.eclipse.jdt.core.formatter.align_type_members_on_columns=false
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_allocation_expression=82
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_annotation=0
@@ -160,7 +160,6 @@ org.eclipse.jdt.core.formatter.indent_switchstatements_compare_to_switch=true
org.eclipse.jdt.core.formatter.indentation.size=4
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_field=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_local_variable=insert
-org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_member=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_method=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_package=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_parameter=do not insert
diff --git a/bundles/org.eclipse.rap.junit/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.junit/META-INF/MANIFEST.MF
index 34d6f144fc..249a3990dd 100644
--- a/bundles/org.eclipse.rap.junit/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.junit/META-INF/MANIFEST.MF
@@ -2,8 +2,8 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Junit Plug-in
Bundle-SymbolicName: org.eclipse.rap.junit
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Require-Bundle: org.junit;bundle-version="[3.8.2,4.0.0)";visibility:=reexport,
org.eclipse.rap.rwt
Export-Package: org.eclipse.rap.junit
-Bundle-RequiredExecutionEnvironment: J2SE-1.4
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/bundles/org.eclipse.rap.rwt.q07/.classpath b/bundles/org.eclipse.rap.rwt.q07/.classpath
index c036bec074..034cb9dd7f 100644
--- a/bundles/org.eclipse.rap.rwt.q07/.classpath
+++ b/bundles/org.eclipse.rap.rwt.q07/.classpath
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="src" path="js"/>
<classpathentry kind="src" path="resources"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/bundles/org.eclipse.rap.rwt.q07/.settings/org.eclipse.jdt.core.prefs b/bundles/org.eclipse.rap.rwt.q07/.settings/org.eclipse.jdt.core.prefs
index fe666e1018..94582a0826 100644
--- a/bundles/org.eclipse.rap.rwt.q07/.settings/org.eclipse.jdt.core.prefs
+++ b/bundles/org.eclipse.rap.rwt.q07/.settings/org.eclipse.jdt.core.prefs
@@ -1,15 +1,15 @@
-#Mon Mar 07 14:09:11 CET 2011
+#Mon May 30 17:11:57 CEST 2011
eclipse.preferences.version=1
instance/org.eclipse.core.net/org.eclipse.core.net.hasMigrated=true
-org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=disabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.compliance=1.5
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.annotationSuperInterface=warning
-org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.autoboxing=error
org.eclipse.jdt.core.compiler.problem.comparingIdentical=warning
org.eclipse.jdt.core.compiler.problem.deadCode=warning
@@ -18,7 +18,7 @@ org.eclipse.jdt.core.compiler.problem.deprecationInDeprecatedCode=disabled
org.eclipse.jdt.core.compiler.problem.deprecationWhenOverridingDeprecatedMethod=disabled
org.eclipse.jdt.core.compiler.problem.discouragedReference=warning
org.eclipse.jdt.core.compiler.problem.emptyStatement=warning
-org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
org.eclipse.jdt.core.compiler.problem.fallthroughCase=warning
org.eclipse.jdt.core.compiler.problem.fatalOptionalError=enabled
org.eclipse.jdt.core.compiler.problem.fieldHiding=ignore
@@ -79,7 +79,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.3
+org.eclipse.jdt.core.compiler.source=1.5
org.eclipse.jdt.core.formatter.align_type_members_on_columns=false
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_allocation_expression=82
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_annotation=0
@@ -161,7 +161,6 @@ org.eclipse.jdt.core.formatter.indent_switchstatements_compare_to_switch=true
org.eclipse.jdt.core.formatter.indentation.size=4
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_field=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_local_variable=insert
-org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_member=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_method=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_package=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_parameter=do not insert
diff --git a/bundles/org.eclipse.rap.rwt.q07/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.rwt.q07/META-INF/MANIFEST.MF
index d0f1212374..5639ba2b41 100644
--- a/bundles/org.eclipse.rap.rwt.q07/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.rwt.q07/META-INF/MANIFEST.MF
@@ -3,8 +3,8 @@ Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-Vendor: %Bundle-Vendor
Bundle-SymbolicName: org.eclipse.rap.rwt.q07
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Fragment-Host: org.eclipse.rap.rwt;bundle-version="[1.2.0,2.0.0)"
Bundle-Localization: fragment
-Bundle-RequiredExecutionEnvironment: J2SE-1.4
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
Import-Package: javax.servlet.http;version="2.3.0"
diff --git a/bundles/org.eclipse.rap.rwt.theme.classic/.classpath b/bundles/org.eclipse.rap.rwt.theme.classic/.classpath
index 826cc86d02..aa6955d139 100644
--- a/bundles/org.eclipse.rap.rwt.theme.classic/.classpath
+++ b/bundles/org.eclipse.rap.rwt.theme.classic/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="theme"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/bundles/org.eclipse.rap.rwt.theme.classic/.settings/org.eclipse.jdt.core.prefs b/bundles/org.eclipse.rap.rwt.theme.classic/.settings/org.eclipse.jdt.core.prefs
index 7190a2d026..70c7bf7fa5 100644
--- a/bundles/org.eclipse.rap.rwt.theme.classic/.settings/org.eclipse.jdt.core.prefs
+++ b/bundles/org.eclipse.rap.rwt.theme.classic/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,8 @@
-#Sat Sep 11 12:42:05 CEST 2010
+#Mon May 30 17:12:53 CEST 2011
eclipse.preferences.version=1
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
-org.eclipse.jdt.core.compiler.compliance=1.4
-org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
-org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
-org.eclipse.jdt.core.compiler.source=1.3
+org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
+org.eclipse.jdt.core.compiler.source=1.5
diff --git a/bundles/org.eclipse.rap.rwt.theme.classic/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.rwt.theme.classic/META-INF/MANIFEST.MF
index fd2d3753a2..8419578657 100644
--- a/bundles/org.eclipse.rap.rwt.theme.classic/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.rwt.theme.classic/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Localization: plugin
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.rap.rwt.theme.classic;singleton:=true
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Bundle-Vendor: %Bundle-Vendor
-Bundle-RequiredExecutionEnvironment: J2SE-1.4
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: org.eclipse.rap.ui;bundle-version="1.4.0"
diff --git a/bundles/org.eclipse.rap.rwt/.classpath b/bundles/org.eclipse.rap.rwt/.classpath
index 22062b82b0..bd6eb12754 100644
--- a/bundles/org.eclipse.rap.rwt/.classpath
+++ b/bundles/org.eclipse.rap.rwt/.classpath
@@ -1,10 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="src" path="css"/>
<classpathentry kind="src" path="yui"/>
<classpathentry exported="true" kind="lib" path="rhino"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/bundles/org.eclipse.rap.rwt/.settings/org.eclipse.jdt.core.prefs b/bundles/org.eclipse.rap.rwt/.settings/org.eclipse.jdt.core.prefs
index f1ff27134d..14744b6b0f 100644
--- a/bundles/org.eclipse.rap.rwt/.settings/org.eclipse.jdt.core.prefs
+++ b/bundles/org.eclipse.rap.rwt/.settings/org.eclipse.jdt.core.prefs
@@ -1,14 +1,14 @@
-#Tue Mar 08 22:43:06 CET 2011
+#Mon May 30 17:10:20 CEST 2011
eclipse.preferences.version=1
-org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=disabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.compliance=1.5
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.annotationSuperInterface=warning
-org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.autoboxing=error
org.eclipse.jdt.core.compiler.problem.comparingIdentical=warning
org.eclipse.jdt.core.compiler.problem.deadCode=warning
@@ -17,7 +17,7 @@ org.eclipse.jdt.core.compiler.problem.deprecationInDeprecatedCode=disabled
org.eclipse.jdt.core.compiler.problem.deprecationWhenOverridingDeprecatedMethod=disabled
org.eclipse.jdt.core.compiler.problem.discouragedReference=warning
org.eclipse.jdt.core.compiler.problem.emptyStatement=warning
-org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
org.eclipse.jdt.core.compiler.problem.fallthroughCase=warning
org.eclipse.jdt.core.compiler.problem.fatalOptionalError=enabled
org.eclipse.jdt.core.compiler.problem.fieldHiding=ignore
@@ -78,7 +78,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.3
+org.eclipse.jdt.core.compiler.source=1.5
org.eclipse.jdt.core.formatter.align_type_members_on_columns=false
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_allocation_expression=82
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_annotation=0
@@ -160,7 +160,6 @@ org.eclipse.jdt.core.formatter.indent_switchstatements_compare_to_switch=true
org.eclipse.jdt.core.formatter.indentation.size=4
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_field=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_local_variable=insert
-org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_member=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_method=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_package=insert
org.eclipse.jdt.core.formatter.insert_new_line_after_annotation_on_parameter=do not insert
diff --git a/bundles/org.eclipse.rap.rwt/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.rwt/META-INF/MANIFEST.MF
index 8a138c615b..946c283772 100644
--- a/bundles/org.eclipse.rap.rwt/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.rwt/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.rap.rwt
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Bundle-ClassPath: patch.jar,
.,
rhino/
@@ -96,4 +96,4 @@ Export-Package: com.yahoo.platform.yui.compressor;x-internal:=true,
org.eclipse.swt.layout,
org.eclipse.swt.widgets,
org.w3c.css.sac;version="1.1.0";x-internal:=true
-Bundle-RequiredExecutionEnvironment: J2SE-1.4
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/bundles/org.eclipse.rap.ui.cheatsheets/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.ui.cheatsheets/META-INF/MANIFEST.MF
index 474dddc7ae..edba139ee9 100644
--- a/bundles/org.eclipse.rap.ui.cheatsheets/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.ui.cheatsheets/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %PLUGIN_NAME
Bundle-SymbolicName: org.eclipse.rap.ui.cheatsheets;singleton:=true
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Bundle-Activator: org.eclipse.ui.internal.cheatsheets.CheatSheetPlugin
Bundle-Vendor: %PROVIDER_NAME
Bundle-Localization: plugin
diff --git a/bundles/org.eclipse.rap.ui.forms/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.ui.forms/META-INF/MANIFEST.MF
index 79711ba971..6b4bceaa55 100644
--- a/bundles/org.eclipse.rap.ui.forms/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.ui.forms/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Eclipse-ExtensibleAPI: true
Bundle-ManifestVersion: 2
Bundle-Name: %name
Bundle-SymbolicName: org.eclipse.rap.ui.forms;singleton:=true
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Bundle-Vendor: %provider-name
Bundle-Localization: plugin
Export-Package: org.eclipse.ui.forms,
diff --git a/bundles/org.eclipse.rap.ui.views/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.ui.views/META-INF/MANIFEST.MF
index 6e39871fde..69092e564c 100644
--- a/bundles/org.eclipse.rap.ui.views/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.ui.views/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.rap.ui.views; singleton:=true
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Bundle-ClassPath: patch.jar,
.
Eclipse-ExtensibleAPI: true
diff --git a/bundles/org.eclipse.rap.ui.workbench/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.ui.workbench/META-INF/MANIFEST.MF
index 849ebb87fc..0e47660b07 100755
--- a/bundles/org.eclipse.rap.ui.workbench/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.ui.workbench/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Eclipse-ExtensibleAPI: true
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.rap.ui.workbench;singleton:=true
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Bundle-ClassPath: patch.jar,
.
Bundle-Activator: org.eclipse.ui.internal.WorkbenchPlugin
diff --git a/bundles/org.eclipse.rap.ui/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.ui/META-INF/MANIFEST.MF
index 61066c0eac..cd773f9a29 100755
--- a/bundles/org.eclipse.rap.ui/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Plugin.name
Bundle-SymbolicName: org.eclipse.rap.ui; singleton:=true
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Bundle-ClassPath: patch.jar,
.
Eclipse-ExtensibleAPI: true

Back to the top