Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRalf Sternberg2012-07-21 15:56:33 +0000
committerRalf Sternberg2012-07-21 15:56:33 +0000
commit843853a3c04716817166516f03dc544fc89a71db (patch)
treefca3f70ba3de99ee8e4bc5c01d373559bbeedfb8 /bundles/org.eclipse.rap.ui
parent0782514d04d58c2e8f3690b5dd610b8a54d22dec (diff)
downloadorg.eclipse.rap-843853a3c04716817166516f03dc544fc89a71db.tar.gz
org.eclipse.rap-843853a3c04716817166516f03dc544fc89a71db.tar.xz
org.eclipse.rap-843853a3c04716817166516f03dc544fc89a71db.zip
Raise version of rap.jface and rap.ui to 2.0.0
These bundles re-export RWT 2.0 which includes breaking changes, so their major version number must be increased, too.
Diffstat (limited to 'bundles/org.eclipse.rap.ui')
-rwxr-xr-xbundles/org.eclipse.rap.ui/META-INF/MANIFEST.MF4
-rw-r--r--bundles/org.eclipse.rap.ui/pom.xml1
2 files changed, 2 insertions, 3 deletions
diff --git a/bundles/org.eclipse.rap.ui/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.ui/META-INF/MANIFEST.MF
index 8bb2c5b10c..59f1ed0027 100755
--- a/bundles/org.eclipse.rap.ui/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Plugin.name
Bundle-SymbolicName: org.eclipse.rap.ui; singleton:=true
-Bundle-Version: 1.5.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-ClassPath: patch.jar,
.
Eclipse-ExtensibleAPI: true
@@ -14,7 +14,7 @@ Import-Package: javax.servlet.http;version="2.3.0"
Export-Package: org.eclipse.ui.internal;x-friends:="org.eclipse.rap.ui"
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.6.0,4.0.0)",
org.eclipse.rap.rwt;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
- org.eclipse.rap.jface;bundle-version="[1.5.100,2.0.0)";visibility:=reexport,
+ org.eclipse.rap.jface;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
org.eclipse.rap.ui.workbench;bundle-version="[1.5.100,2.0.0)";visibility:=reexport,
org.eclipse.core.expressions;bundle-version="[3.4.0,4.0.0)",
org.eclipse.osgi.services;bundle-version="[3.2.0,4.0.0)"
diff --git a/bundles/org.eclipse.rap.ui/pom.xml b/bundles/org.eclipse.rap.ui/pom.xml
index 340f6b5fd5..33676ba7ac 100644
--- a/bundles/org.eclipse.rap.ui/pom.xml
+++ b/bundles/org.eclipse.rap.ui/pom.xml
@@ -22,7 +22,6 @@
</parent>
<artifactId>org.eclipse.rap.ui</artifactId>
- <version>1.5.100-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>

Back to the top