Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Knauer2017-06-06 15:56:43 +0000
committerMarkus Knauer2017-06-07 07:39:42 +0000
commit20765cf9941fc94f1f1e88e0d808b528160b7c97 (patch)
tree72e4d3651e7ee5f36ac6ec4fe33a7280c3b03361 /bundles/org.eclipse.rap.e4/META-INF/MANIFEST.MF
parent952fdc52290c584e71da79d314b0ba347a07ca1d (diff)
downloadorg.eclipse.rap-20765cf9941fc94f1f1e88e0d808b528160b7c97.tar.gz
org.eclipse.rap-20765cf9941fc94f1f1e88e0d808b528160b7c97.tar.xz
org.eclipse.rap-20765cf9941fc94f1f1e88e0d808b528160b7c97.zip
Prepare RAP e4 components for release and increment version3.2.0-RC3
- Increment version to 3.2.0 for migrated RAP e4 components - Harmonize RAP e4 features (include legal files, order and content of feature.xml, p2.inf, ...) - Externalize strings, fix copyright. - Prepend version qualifier of forked bundles with 'rap-' Change-Id: Iefa8bcbb199a985cafc44ae9a20a98627a3221b5 Signed-off-by: Markus Knauer <mknauer@eclipsesource.com>
Diffstat (limited to 'bundles/org.eclipse.rap.e4/META-INF/MANIFEST.MF')
-rw-r--r--bundles/org.eclipse.rap.e4/META-INF/MANIFEST.MF15
1 files changed, 9 insertions, 6 deletions
diff --git a/bundles/org.eclipse.rap.e4/META-INF/MANIFEST.MF b/bundles/org.eclipse.rap.e4/META-INF/MANIFEST.MF
index 98578df824..f0505c7eeb 100644
--- a/bundles/org.eclipse.rap.e4/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.rap.e4/META-INF/MANIFEST.MF
@@ -1,8 +1,13 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
-Bundle-Name: E4
+Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.rap.e4
-Bundle-Version: 0.9.0.qualifier
+Bundle-Version: 3.2.0.qualifier
+Bundle-ClassPath: .
+Bundle-Localization: plugin
+Bundle-Vendor: %Bundle-Vendor
+Bundle-ActivationPolicy: lazy
+Bundle-Activator: org.eclipse.rap.e4.internal.Activator
Require-Bundle: org.eclipse.rap.rwt,
org.eclipse.e4.ui.workbench.swt;bundle-version="0.12.100",
org.eclipse.e4.ui.workbench,
@@ -18,12 +23,10 @@ Require-Bundle: org.eclipse.rap.rwt,
org.eclipse.e4.core.di.extensions.supplier;bundle-version="0.15.0",
org.eclipse.equinox.preferences,
org.eclipse.equinox.common;bundle-version="3.6.200"
-Export-Package: org.eclipse.rap.e4,
- org.eclipse.rap.e4.preferences
Import-Package: javax.annotation;version="1.2.0",
javax.inject;version="1.0.0"
+Export-Package: org.eclipse.rap.e4;version="3.2.0",
+ org.eclipse.rap.e4.preferences;version="3.2.0"
Service-Component: OSGI-INF/rapeventbroker.xml,OSGI-INF/rapeventobjectsupplier.xml,OSGI-INF/rapuieventobjectsupplier.xml,OSGI-INF/rappreferenceobjectsupplier.xml,
OSGI-INF/preferenceserviceCF.xml
-Bundle-ActivationPolicy: lazy
-Bundle-Activator: org.eclipse.rap.e4.internal.Activator
Bundle-RequiredExecutionEnvironment: JavaSE-1.6

Back to the top