Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLakshmi Shanmugam2019-07-24 02:24:22 -0400
committerLakshmi Shanmugam2019-07-24 02:58:34 -0400
commit84817fbd40be2e84c2254b1eb8552d3e5fa8b567 (patch)
treebdf9c680688aed4cd808ee525b221b296ab93c1d /bundles/org.eclipse.swt/.settings/org.eclipse.pde.api.tools.prefs
parent0fbce60b619198abd01d3be9ad0761b1e7f2bcd9 (diff)
downloadeclipse.platform.swt-84817fbd40be2e84c2254b1eb8552d3e5fa8b567.tar.gz
eclipse.platform.swt-84817fbd40be2e84c2254b1eb8552d3e5fa8b567.tar.xz
eclipse.platform.swt-84817fbd40be2e84c2254b1eb8552d3e5fa8b567.zip
Bug 549481 - [Mac]API Tools error in Display.java
Putback the filter for MANIFEST.MF removed by previous commit as it causes API tools warning in official build (Windows). The API tools filters is common for all platforms. Some filters may be platform specific. So, don't enable automatically remove unused filters. Also, set unused problem filters to warning. Change-Id: I15bfe4952a6fb47d7913d0074878aef00a924301
Diffstat (limited to 'bundles/org.eclipse.swt/.settings/org.eclipse.pde.api.tools.prefs')
-rw-r--r--bundles/org.eclipse.swt/.settings/org.eclipse.pde.api.tools.prefs4
1 files changed, 2 insertions, 2 deletions
diff --git a/bundles/org.eclipse.swt/.settings/org.eclipse.pde.api.tools.prefs b/bundles/org.eclipse.swt/.settings/org.eclipse.pde.api.tools.prefs
index e11abc214e..47fac8aaff 100644
--- a/bundles/org.eclipse.swt/.settings/org.eclipse.pde.api.tools.prefs
+++ b/bundles/org.eclipse.swt/.settings/org.eclipse.pde.api.tools.prefs
@@ -88,8 +88,8 @@ TYPE_PARAMETER_ELEMENT_TYPE_CHANGED_CLASS_BOUND=Error
TYPE_PARAMETER_ELEMENT_TYPE_CHANGED_INTERFACE_BOUND=Error
TYPE_PARAMETER_ELEMENT_TYPE_REMOVED_CLASS_BOUND=Error
TYPE_PARAMETER_ELEMENT_TYPE_REMOVED_INTERFACE_BOUND=Error
-UNUSED_PROBLEM_FILTERS=Error
-automatically_removed_unused_problem_filters=Enabled
+UNUSED_PROBLEM_FILTERS=Warning
+automatically_removed_unused_problem_filters=Disabled
changed_execution_env=Error
eclipse.preferences.version=1
incompatible_api_component_version=Error

Back to the top