Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'production/createReports.sh')
-rwxr-xr-xproduction/createReports.sh16
1 files changed, 8 insertions, 8 deletions
diff --git a/production/createReports.sh b/production/createReports.sh
index c192a002c..5483f4bfc 100755
--- a/production/createReports.sh
+++ b/production/createReports.sh
@@ -36,7 +36,7 @@ echo -e "\tbuildIdToTest: ${BUILD_ID}"
# TODO: we could have a "previous_release" sort of variable that
# would be defined in parent pom or build_eclipse_org.shsource so that
# we do not need to change this source.
-buildIdToCompare="4.8/R-4.8-201806110500"
+buildIdToCompare="4.9/R-4.9-201809060745"
build_type=${buildIdToTest:0:1}
echo -e "\tbuild_type: ${build_type}"
@@ -66,22 +66,22 @@ function latestSimpleRepo
if [[ ${build_type} == "I" ]]
then
- update_dir_segment="4.9-I-builds"
- buildIdToCompare="4.8/R-4.8-201806110500"
- echo -e "\tlatest_R_build: R-4.8-201806110500"
+ update_dir_segment="4.10-I-builds"
+ buildIdToCompare="4.9/R-4.9-201809060745"
+ echo -e "\tlatest_R_build: R-4.9-201809060745"
elif [[ ${build_type} == "Y" ]]
then
update_dir_segment="4.9-Y-builds"
# Note: we use same value for Y-builds as for I-builds, since conceptually
- # they are the same, except that Y-builds use some code from BETA_JAVA9 branch.
- latest_I_build=$(latestSimpleRepo "${repo_root}/4.8-I-builds" "I20*")
+ # they are the same, except that Y-builds use some code from BETA_JAVA11 branch.
+ latest_I_build=$(latestSimpleRepo "${repo_root}/4.9-I-builds" "I20*")
RC=$?
if [[ $RC != 0 ]]
then
exit $RC
fi
echo -e "\tlatest_I_build: $latest_I_build"
- buildIdToCompare="4.8-I-builds/${latest_I_build}"
+ buildIdToCompare="4.9-I-builds/${latest_I_build}"
else
echo -e "\nERROR: Unhandled build type: ${build_type} so update_dir_segment undefined: $update_dir_segment"
echo -e "\n\tand repo reports not produced."
@@ -107,7 +107,7 @@ then
mkdir -p ${output_dir}
# This analyzersBuildId can (currently) be found by "drilling down" at
- # http://download.eclipse.org/cbi/updates/analyzers/4.8/
+ # http://download.eclipse.org/cbi/updates/analyzers/4.9/
# analyzersBuildId=I20161201-1633
# We use analyzer from hipp this way we have one less version to track
tar_name=org.eclipse.cbi.p2repo.analyzers.product-linux.gtk.x86_64.tar.gz

Back to the top