Skip to main content
aboutsummaryrefslogtreecommitdiffstats
blob: 2fc2ea3c244a7b1591edddde818dacca2a38fe59 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
Manifest-Version: 1.0
Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
 org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
 org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
 org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
 org.eclipse.papyrus.toolsmiths.validation.common;bundle-version="[2.0.0,3.0.0)",
 org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
 org.eclipse.pde.core;bundle-version="[3.13.0,4.0.0)",
 org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
 org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
 org.eclipse.papyrus.uml.tools.utils;bundle-version="[4.0.0,5.0.0)",
 org.eclipse.emf.codegen.ecore;bundle-version="[2.22.0,3.0.0)",
 org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
 org.eclipse.ui.ide;bundle-version="[3.18.0,4.0.0)",
 org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
 org.eclipse.papyrus.toolsmiths.plugin.builder;bundle-version="[1.1.0,2.0.0)",
 org.eclipse.papyrus.infra.core;bundle-version="[4.1.0,5.0.0)",
 org.eclipse.uml2.uml.resources;bundle-version="[5.5.0,6.0.0)"
Export-Package: org.eclipse.papyrus.toolsmiths.validation.profile,
 org.eclipse.papyrus.toolsmiths.validation.profile.checkers,
 org.eclipse.papyrus.toolsmiths.validation.profile.constants,
 org.eclipse.papyrus.toolsmiths.validation.profile.internal.checkers;x-internal:=true,
 org.eclipse.papyrus.toolsmiths.validation.profile.internal.quickfix;x-internal:=true
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
Bundle-Version: 2.1.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.toolsmiths.validation.profile.Activator
Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.toolsmiths.validation.profile;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-11
Automatic-Module-Name: org.eclipse.papyrus.toolsmiths.validation.profile
Import-Package: com.google.common.collect;version="[30.1.0,31.0.0)",
 org.osgi.service.component.annotations;version="[1.3.0,2.0.0)";resolution:=optional
Service-Component: OSGI-INF/org.eclipse.papyrus.toolsmiths.validation.profile.internal.checkers.ProfileBuilderProvider.xml

Back to the top