Skip to main content
aboutsummaryrefslogtreecommitdiffstats
blob: 34605d352dab920ec842ea43b7f9e0c50d3b7d87 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
<?xml version="1.0" encoding="UTF-8" standalone="no"?><feature id="org.eclipse.papyrus.layers.feature" label="%featureName" provider-name="%providerName" version="1.1.0.qualifier">

   <description url="http://www.eclipse.com/papyrus">
      This plugins add Layers capapbilities to Papyrus diagrams.
   </description>

   <copyright url="http://www.eclipse.org/legal/epl-v10.html">
      Copyright (c) 2013 CEA LIST.
All rights reserved.   This program and the accompanying materials
are made available under the terms of the Eclipse Public License
v1.0 which accompanies this distribution, and is available at
http://www.eclipse.org/legal/epl-v10.html.
   </copyright>

   <license url="%licenseURL">
      %license
   </license>

   <requires>
      <import plugin="org.eclipse.ui"/>
      <import plugin="org.eclipse.core.runtime"/>
      <import match="greaterOrEqual" plugin="org.eclipse.gmf.runtime.notation" version="1.5.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.gmf.runtime.notation.edit" version="1.4.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.gmf.runtime.notation.providers" version="1.7.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.emf.edit" version="2.9.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.emf.ecore.edit" version="2.8.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.papyrus.layers.stackmodel" version="0.10.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.emf.ecore" version="2.9.0"/>
      <import plugin="org.junit"/>
      <import plugin="org.eclipse.papyrus.infra.core"/>
      <import match="greaterOrEqual" plugin="org.eclipse.core.resources" version="3.8.100"/>
      <import match="greaterOrEqual" plugin="org.eclipse.papyrus.infra.gmfdiag.common" version="0.10.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.emf.ecore.xmi" version="2.9.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.uml2.uml" version="4.1.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.papyrus.infra.emf" version="0.10.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.papyrus.infra.emf.diagram.common" version="0.10.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.papyrus.layers.stackmodel.editor" version="1.0.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.emf.transaction" version="1.4.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.papyrus.infra.core.log" version="0.10.0"/>
      <import plugin="org.eclipse.core.expressions"/>
      <import plugin="org.eclipse.gmf.runtime.diagram.ui.resources.editor"/>
      <import match="greaterOrEqual" plugin="org.eclipse.gmf.runtime.diagram.ui" version="1.7.0"/>
      <import plugin="org.eclipse.uml2.common.edit"/>
      <import plugin="org.eclipse.emf.edit.ui"/>
      <import plugin="org.eclipse.ui.ide"/>
      <import match="greaterOrEqual" plugin="org.eclipse.papyrus.infra.core.sasheditor" version="0.10.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.ui.forms" version="3.5.200"/>
      <import match="greaterOrEqual" plugin="org.eclipse.emf" version="2.6.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.papyrus.infra.core" version="0.10.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.papyrus.layers.runtime" version="0.10.0"/>
      <import plugin="org.eclipse.core.databinding"/>
      <import plugin="org.eclipse.core.databinding.beans"/>
      <import plugin="org.eclipse.core.databinding.observable"/>
      <import plugin="org.eclipse.core.databinding.property"/>
      <import plugin="com.ibm.icu"/>
      <import plugin="org.eclipse.emf.databinding"/>
      <import match="greaterOrEqual" plugin="org.eclipse.uml2.uml.edit" version="4.0.100"/>
      <import match="greaterOrEqual" plugin="org.eclipse.emf.databinding.edit" version="1.3.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.jface.databinding" version="1.6.200"/>
      <import plugin="org.eclipse.gmf.runtime.diagram.ui.properties"/>
      <import match="greaterOrEqual" plugin="org.eclipse.ui.ide" version="3.9.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.gmf.runtime.diagram.ui.resources.editor" version="1.7.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.core.expressions" version="3.4.500"/>
      <import match="greaterOrEqual" plugin="org.eclipse.papyrus.layers.notationmodel.edit" version="0.11.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.papyrus.views.modelexplorer" version="0.10.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.papyrus.views.properties" version="0.10.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.papyrus.infra.widgets" version="0.10.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.ui.navigator" version="3.5.300"/>
      <import match="greaterOrEqual" plugin="org.eclipse.gmf.runtime.notation.edit" version="1.7.0"/>
      <import match="greaterOrEqual" plugin="org.eclipse.papyrus.infra.services.labelprovider" version="0.10.1"/>
      <import match="greaterOrEqual" plugin="org.eclipse.papyrus.infra.gmfdiag.hyperlink" version="0.10.1"/>
   </requires>

   <plugin download-size="0" id="org.eclipse.papyrus.layers.notationmodel.edit" install-size="0" unpack="false" version="0.0.0"/>

   <plugin download-size="0" id="org.eclipse.papyrus.layers.runtime" install-size="0" unpack="false" version="0.0.0"/>

   <plugin download-size="0" id="org.eclipse.papyrus.layers.stackmodel" install-size="0" unpack="false" version="0.0.0"/>

   <plugin download-size="0" id="org.eclipse.papyrus.layers.stackmodel.diagram" install-size="0" unpack="false" version="0.0.0"/>

   <plugin download-size="0" id="org.eclipse.papyrus.layers.stackmodel.edit" install-size="0" unpack="false" version="0.0.0"/>

   <plugin download-size="0" id="org.eclipse.papyrus.layers.stackmodel.editor" install-size="0" unpack="false" version="0.0.0"/>

   <plugin download-size="0" id="org.eclipse.papyrus.layers.ui" install-size="0" unpack="false" version="0.0.0"/>

</feature>

Back to the top