Skip to main content
aboutsummaryrefslogtreecommitdiffstats
blob: aef5b3381268180ea96ef22d809be49337936978 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
<?xml version="1.0" encoding="UTF-8"?>
<feature
      id="org.eclipse.papyrus.developer.feature"
      label="MDT Papyrus Developer Feature"
      version="0.7.0.qualifier">

   <description url="http://www.example.com/description">
      The MDT Papyrus Developer feature. 

This feature contains the specialized generator used by Papyrus
   </description>

   <copyright url="http://www.example.com/copyright">
      [Enter Copyright Description here.]
   </copyright>

   <license url="http://www.example.com/license">
      [Enter License Description here.]
   </license>

   <url>
      <discovery label="MDT Papyrus" url="http://www.eclipse.org/modeling/mdt/?project=papyrus#papyrus"/>
      <discovery label="Developer Wiki" url="http://wiki.eclipse.org/Papyrus_Developer_Guide"/>
   </url>

   <requires>
      <import plugin="org.eclipse.ui"/>
      <import plugin="org.eclipse.core.runtime"/>
      <import plugin="org.eclipse.emf.ecore" version="2.4.0" match="greaterOrEqual"/>
      <import plugin="org.eclipse.emf.codegen.ecore" version="2.4.0" match="greaterOrEqual"/>
      <import plugin="org.eclipse.gmf.codegen" version="2.1.0" match="greaterOrEqual"/>
      <import plugin="org.eclipse.gmf.codegen.ui" version="1.1.0" match="greaterOrEqual"/>
      <import plugin="org.eclipse.m2m.qvt.oml" version="2.0.0" match="greaterOrEqual"/>
      <import plugin="org.eclipse.ui" version="3.5.0" match="greaterOrEqual"/>
   </requires>

   <plugin
         id="org.eclipse.papyrus.def"
         download-size="0"
         install-size="0"
         version="0.7.0.qualifier"
         unpack="false"/>

   <plugin
         id="org.eclipse.papyrus.codegen"
         download-size="0"
         install-size="0"
         version="0.7.0.qualifier"
         unpack="false"/>

   <plugin
         id="org.eclipse.papyrus.gmfgenextension"
         download-size="0"
         install-size="0"
         version="0.7.0.qualifier"
         unpack="false"/>

</feature>

Back to the top