Skip to main content
aboutsummaryrefslogtreecommitdiffstats
AgeCommit message (Collapse)AuthorFilesLines
2014-01-21386118: [EMF Facet] Papyrus should progressively support EMF Facet 0.2ptessier46-3560/+0
https://bugs.eclipse.org/bugs/show_bug.cgi?id=386118
2013-11-13263430: [General] Add relengCamille Letavernier1-10/+10
https://bugs.eclipse.org/bugs/show_bug.cgi?id=263430 Luna: Update plug-in version numbers to 1.0.0
2013-07-04[Releng] Update Papyrus version to 0.10.1cletavernie1-10/+10
2013-02-18398712: [Core] Multiple issues with the PageManagercletavernie1-1/+0
https://bugs.eclipse.org/bugs/show_bug.cgi?id=398712 360243: [ModelExplorer] Undo/Redo on delete for Diagrams and Tables https://bugs.eclipse.org/bugs/show_bug.cgi?id=360243
2013-02-04Remove EMF Facet builder from Eclipse Plug-inscletavernie1-5/+0
2013-01-22391945: [Refactoring] Part 2: Refactoring on Kepler (0.10)cletavernie4-7/+8
https://bugs.eclipse.org/bugs/show_bug.cgi?id=391945
2012-12-07396019: [SysML] & [Facet Generation] The generated FacetReference are not ↵vlorenzo1-8/+8
unsettable https://bugs.eclipse.org/bugs/show_bug.cgi?id=396019
2012-12-06395931: [SysML] & [Facet Generation] The generated Queryset is false for ↵vlorenzo1-10/+10
monovalued reference https://bugs.eclipse.org/bugs/show_bug.cgi?id=395931
2012-11-28394747: New features developped on EFacet Table should be backported on the ↵vlorenzo2-0/+864
old version of the EMF Facet table https://bugs.eclipse.org/bugs/show_bug.cgi?id=394747 Commit on the trunk the file sysml_profilefacet.facetSet and querySet in oep.sysml.facets
2012-09-18378990: [Tests] Add JUnit tests to test informations of built plugins and ↵cletavernie1-1/+1
features - Update the bundle tests to 0.10.0 (Kepler - Fix some plug-ins metadata to match the tests
2012-09-18Kepler: Update plug-in versions to 0.10.0cletavernie1-9/+9
2012-09-17380517: [Papyrus] We should use explicit plug-in dependencies whenever possiblecletavernie5-9/+7
https://bugs.eclipse.org/bugs/show_bug.cgi?id=380517 + removed some unused dependencies and imports
2012-04-27Fix plug-in and feature namescletavernie1-1/+1
2012-03-22357348: [Build] Papyrus shall provide a source buildcletavernie1-1/+1
https://bugs.eclipse.org/bugs/show_bug.cgi?id=357348 Fixed illformed build.properties files
2012-01-25NEW - bug 369500: [SysML] Update to UML2.4 - Fix models and generators ytanguy2-2/+2
https://bugs.eclipse.org/bugs/show_bug.cgi?id=369500
2012-01-25RESOLVED - bug 369505: [Refactor] Update to UML2.4 - Use ↵ytanguy22-62/+60
getStereotypeApplication from UML plug-in https://bugs.eclipse.org/bugs/show_bug.cgi?id=369505
2012-01-25NEW - bug 369501: [SysML] Update to UML2.4 - Use standard profile ↵ytanguy3-7/+8
implementation from UML plug-in https://bugs.eclipse.org/bugs/show_bug.cgi?id=369501
2011-12-15366527: [All diagram][refactoring] update papyrus to UML2.4cletavernie2-38/+38
https://bugs.eclipse.org/bugs/show_bug.cgi?id=366527
2011-12-15366527: [All diagram][refactoring] update papyrus to UML2.4cletavernie2-8/+9
https://bugs.eclipse.org/bugs/show_bug.cgi?id=366527
2011-12-09365919: [Architecture - SVN - Build] Rewrite the Buildcletavernie1-1/+3
https://bugs.eclipse.org/bugs/show_bug.cgi?id=365919 Removed some reexported dependencies.
2011-11-10362162: [Architecture - Refactoring] The plug-ins should be renamed to match ↵cletavernie10-30/+30
their layer's qualified name https://bugs.eclipse.org/bugs/show_bug.cgi?id=362162
2011-11-04362162: [Architecture - Refactoring] The plug-ins should be renamed to match ↵cletavernie1-4/+4
their layer's qualified name https://bugs.eclipse.org/bugs/show_bug.cgi?id=362162
2011-10-27359057: [Architecture - SVN - Build] The Papyrus architecture should be ↵cletavernie1-9/+10
refactored https://bugs.eclipse.org/bugs/show_bug.cgi?id=359057 Update the plug-in versions and dependencies over Papyrus plug-ins to 0.9.0
2011-09-19NEW - bug 357827: [General] CommandWrappers classes are duplicated all over ↵vhemery10-10/+10
various plugins https://bugs.eclipse.org/bugs/show_bug.cgi?id=357827 Use command wrappers from adequate plugin. Mark other implementation as deprecated and make them extend the correct one in order to avoid Class Cast exceptions.
2011-09-12NEW - bug 357049: [Table Editor][SysM] Direction for Facet FlowPort is not ↵vhemery1-1/+0
correctly displayed https://bugs.eclipse.org/bugs/show_bug.cgi?id=357049 Remove erratic @override annotation
2011-09-12357348: [Build] Papyrus shall provide a source buildcletavernie1-11/+7
https://bugs.eclipse.org/bugs/show_bug.cgi?id=357348
2011-09-08Merged Branch 0.8.X changes 5111::5401 for oep.sysml.facetsvlorenzo14-24/+797
NEW - bug 357049: [Table Editor][SysM] Direction for Facet FlowPort is not correctly displayed https://bugs.eclipse.org/bugs/show_bug.cgi?id=357049
2011-07-22Merged Branch 0.8.X changes 5098::5109 for the plugin oep.sysml.facetsvlorenzo6-1/+154
NEW - bug 352852: [Table Editor] The SysML profile should be represented by Facets for the table https://bugs.eclipse.org/bugs/show_bug.cgi?id=352852
2011-07-21NEW - bug 351681: [Requirement Table] Papyrus should provides specific ↵vlorenzo8-16/+53
celleditors to edit derived values https://bugs.eclipse.org/bugs/show_bug.cgi?id=351681
2011-07-20Merge Branch 0.8.X changes 5089::5096 for the plugin oep.sysml.facetsvlorenzo24-63/+1029
NEW - bug 351681: [Requirement Table] Papyrus should provides specific celleditors to edit derived values https://bugs.eclipse.org/bugs/show_bug.cgi?id=351681
2011-07-20NEW - bug 352331: [SysML Static Profile] Deprecated constraint on Verify ↵vlorenzo2-9/+7
ends is still used (client is not necessarily a TestCase) https://bugs.eclipse.org/bugs/show_bug.cgi?id=352331
2011-06-29NEW - bug 344465: [Table Editor] Papyrus should provide Facets and Queries ↵ytanguy13-140/+119
to edit the element stereotyped with SysML https://bugs.eclipse.org/bugs/show_bug.cgi?id=344465
2011-06-23[releng] Update trunk from 0.8.0.qualifier to 0.9.0.qualifiercmraidha1-1/+1
2011-05-13NEW - bug 345698: Add Table Plugins to relengvlorenzo22-0/+799
https://bugs.eclipse.org/bugs/show_bug.cgi?id=345698 NEW - bug 334240: [Enhancement] [TableEditor] Papyrus shall support Tabular Editors https://bugs.eclipse.org/bugs/show_bug.cgi?id=334240

    Back to the top