Skip to main content
aboutsummaryrefslogtreecommitdiffstats
AgeCommit message (Collapse)AuthorFilesLines
2016-02-24Bug 485220: [Architecture] Provide a more modular architectureChristian W. Damus4-404/+436
https://bugs.eclipse.org/bugs/show_bug.cgi?id=485220 Implement version management: PDE API Tooling and Oomph Version Management. Introduce two new plug-in projects to manage versioning using Oomph: * org.eclipse.papyrus.releng.main.release for the Main bundles and features * org.eclipse.papyrus.releng.dev.release for the Dev Tools Add new menu actions to the Dev Tools: * main menu bar: * synchronize POM and manifest versions * "Configure" context menu on bundle projects and MANIFEST.MF * optimize bundle dependencies and re-exports * update dependency version ranges to match current workspace and PDE target Remove obsolete menu actions from the Dev Tools: * main menu bar: * Set all Papyrus feature versions * Set all Papyrus plug-in versions * Set versions of all Papyrus dependencies in Papyrus plug-ins Fix versioning errors reported by PDE and Oomph. Ensure proper version ranges consistent with latest build target. Optimize the dependencies of all Papyrus Main bundles and Dev Tools. Remove version- and reexport-checking tests in the BundlesTests that are now not needed because, on the one hand, we now implement discrete bundle versioning (managed by PDE/Oomph) and on the other, we now use re-exports properly to ensure classpath consistency in clients of a bundle's API. Thorough overhaul of the "project editors" API, including: * rationalize the API interfaces * refactor the all-in-one PluginEditor class from the customization bundle to the project-editors bundle * update clients in the Customization and DSML Validation components * fix a bunch of operations that didn't work * add missing operations required by the new Dev Tools actions * complete some unimplemented APIs * add a comprehensive JUnit test suite covering all of the project-editors API Change-Id: I6a699d93909f61099226ceb994140f03ea99a70f
2016-02-13Revert "Bug 485220: [Architecture] Provide a more modular architecture ↵Christian W. Damus1-1/+0
https://bugs.eclipse.org/bugs/show_bug.cgi?id=485220" This reverts commit f050d4119a2316b27588076d4fc90152773fc019.
2016-02-13Bug 485220: [Architecture] Provide a more modular architectureChristian W. Damus1-0/+1
https://bugs.eclipse.org/bugs/show_bug.cgi?id=485220 Fix build failure to resolve bundles in referenced p2 repositories by restoring the missing <groupId> elements in the POMs which, as it turns out, are not inherited from the parent module, despite what the m2e validator says. Change-Id: I62dacc9c70c940d28c3c02e1e35c8f874a7d3df0
2016-02-12Bug 485220: [Architecture] Provide a more modular architectureChristian W. Damus1-5/+3
https://bugs.eclipse.org/bugs/show_bug.cgi?id=485220 Factor UI dependencies out of the UML Element Types bundle. This includes moving some advices that interact with the user into a new org.eclipse.papyrus.uml.service.types.ui bundle. Pull up the PasteCommandService and IPasteCommandProvider API into the Infra Diagram layer where the extension point is defined. Deprecate the old API in the UML layer. Introduce a service for participation of languages in CSS styling: * styling reset actions in the Reset Style command * access to semantic model classes and properties to make available to CSS Factor PapyrusObservableValue and cohorts out of the UML Tools bundle into the Infra Layer for more general reuse and to relieve the Diagram Infrastructure layer of UML dependencies. The old API remains as deprecated. Remove the Infra Diagram Layer dependency on UML Layer for property testers governing deletion in the diagram. Includes introduction of a new IGraphicalDeletionHelper OSGi service for delegation of the determination of whether an element can be deleted from the diagram and replacement of the XML expression properties * org.eclipse.papyrus.uml.diagram.common.isSemanticDeletion * org.eclipse.papyrus.uml.diagram.common.isReadOnly by * org.eclipse.papyrus.infra.gmfdiag.common.isSemanticDeletion * org.eclipse.papyrus.infra.gmfdiag.common.canDelete (where the latter is the negation of the property that it supersedes) Extract UML dependencies from the Diagram Outline and CSS Editor bundles. Remove unused MDTUtil APIs that referenced a UML-specific annotation. Move the Diagram Infrastructure CSS Palette bundle into the UML layer because it serves to provide extensions on the Palette Service, which is an overtly UML-specific capability. All client APIs for the Properties View are moved from org.eclipse.papyrus.views.properties bundle to a new org.eclipse.papyrus.infra.properties.ui bundle. This includes renaming of: * extension points * label-provider contexts * XWT namespaces Add an "all UI tests" suite. Define a componentized hierarchical build layout of the main plug-ins Change-Id: I43f8f3644857a18b69715f5a2f1da9b1cf286d67
2016-01-19Bug 486090: [Facet Metamodel] Regeneration does not work wellCamille Letavernier16-1800/+84
https://bugs.eclipse.org/bugs/show_bug.cgi?id=486090 - Regenerate all metamodels related to/depending on the Facet metamodel to ensure consistency Change-Id: I4687d17fd117df8f4b62bc4090cec955674fbd27 Signed-off-by: Camille Letavernier <camille.letavernier@cea.fr>
2016-01-18485539: [Performances - Facet Manager] FacetManager recomputes theCamille Letavernier41-2622/+1763
Facets for a given element too many times https://bugs.eclipse.org/bugs/show_bug.cgi?id=485539 - Add derived properties Facet#allFacetElements, Facet#allFacetOperations and Facet#allTypedElements, to avoid recomputing the hierarchy of facets
2015-08-21[releng] Neon-1.2.0 modification step by stepQuentin Le Menez2-9/+6
Change-Id: I9126d707fecad85c9b5384b35074deba995b6527 Signed-off-by: Quentin Le Menez <quentin.lemenez@cea.fr>
2015-06-11469953: [Releng] Update the build to support a global POMCamille Letavernier1-2/+2
https://bugs.eclipse.org/bugs/show_bug.cgi?id=469953 Change-Id: I050cf9dbbdd5705aaf8d45f2db3458226d148002 Signed-off-by: Camille Letavernier <camille.letavernier@cea.fr>
2014-09-15[Releng] Update feature versions to 1.1.0Camille Letavernier1-2/+2
2014-09-15[Releng] Change plug-ins version to 1.1.0Camille Letavernier1-2/+2
2014-08-26[Code Style] Configure code style in the projectsChristian W. Damus2-0/+352
Configure the master settings for Code Style in the org.eclipse.papyrus.infra.core plug-in, including: - Code Formatter - Code Clean-up - Code Templates - Import Sort Order Employ the Oomph Project Configuration tooling to propagate these settings to all other Papyrus main, test, and developer plug-ins, plus the CDO Integration plug-ins. Update the Papyrus Oomph model to remove the workspace-wide code style settings. Change-Id: Id1c7c7fb94c82974a9f1c7cafcfcf32b71ce6c1f
2014-08-25[Code style] Apply clean-up profile to Papyrus Main plug-insCamille Letavernier41-562/+541
2014-08-21[Code style] Apply clean-up and formatter on Main plug-insCamille Letavernier41-2134/+2722
2014-08-20[Releng] Update Papyrus version to 1.0.1 in pom.xmlCamille Letavernier1-2/+2
2014-08-20[Releng] Update versions to 1.0.1Camille Letavernier1-7/+7
2014-06-04[Releng] Remove the (Incubation) suffix from all (main) plug-ins andCamille Letavernier1-1/+1
features Update the Bundle test accordingly
2014-04-17[releng] Generated all the pom.xml files for the plugins and featuresLaurent Wouters1-0/+14
Command: python releng/toolkit/tycho-genertor.py Signed-off-by: Laurent Wouters <laurent.wouters@cea.fr>
2014-03-14[Releng] Fix dependency versionsCamille Letavernier1-14/+15
2014-03-07Bug 386118 - [EMF Facet] Papyrus should progressively support EMF Facetptessier1-6/+0
0.2 update .projects
2014-03-07Bug 386118 - [EMF Facet] Papyrus should progressively support EMF Facetptessier1-1/+1
0.2 set plugins version to 1.0.0
2014-02-24[EMF Facet] Papyrus should progressively support EMF Facet 0.2ptessier1-4/+4
2014-02-21Bug 386118 - [EMF Facet] Papyrus should progressively support EMF Facetptessier43-259/+259
0.2 impact of package renaming
2014-02-21Bug 386118 - [EMF Facet] Papyrus should progressively support EMF Facetptessier41-0/+0
0.2 change the name of each imported packages
2014-02-14386118: [EMF Facet] Papyrus should progressively support EMF Facet 0.2ptessier263-0/+10939
https://bugs.eclipse.org/bugs/show_bug.cgi?id=386118

    Back to the top