Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'tests/junit/plugins')
-rwxr-xr-xtests/junit/plugins/bundlestests/org.eclipse.papyrus.developer.suite.tests/META-INF/MANIFEST.MF15
-rwxr-xr-xtests/junit/plugins/bundlestests/org.eclipse.papyrus.developer.suite.tests/pom.xml11
-rw-r--r--tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/META-INF/MANIFEST.MF11
-rw-r--r--tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/pom.xml11
-rw-r--r--tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF67
-rw-r--r--tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/pom.xml7
-rwxr-xr-xtests/junit/plugins/editor/org.eclipse.papyrus.editors.suite.tests/META-INF/MANIFEST.MF18
-rwxr-xr-xtests/junit/plugins/editor/org.eclipse.papyrus.editors.suite.tests/pom.xml11
-rwxr-xr-xtests/junit/plugins/facet/org.eclipse.papyrus.emf.facet.architecture.tests/META-INF/MANIFEST.MF19
-rwxr-xr-xtests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.clipboard.tests/META-INF/MANIFEST.MF18
-rwxr-xr-xtests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.clipboard.tests/pom.xml27
-rw-r--r--tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di.tests/META-INF/MANIFEST.MF17
-rw-r--r--tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di.tests/pom.xml27
-rw-r--r--tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.tests/META-INF/MANIFEST.MF24
-rw-r--r--tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.tests/pom.xml27
-rwxr-xr-xtests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.suite.tests/META-INF/MANIFEST.MF21
-rwxr-xr-xtests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.suite.tests/pom.xml11
-rw-r--r--tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.tests/META-INF/MANIFEST.MF19
-rw-r--r--tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.tests/pom.xml27
-rw-r--r--tests/junit/plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.tests/META-INF/MANIFEST.MF35
-rw-r--r--tests/junit/plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.tests/pom.xml25
-rwxr-xr-xtests/junit/plugins/infra/emf/expressions/org.eclipse.papyrus.infra.emf.expressions.tests/META-INF/MANIFEST.MF10
-rwxr-xr-xtests/junit/plugins/infra/emf/expressions/org.eclipse.papyrus.infra.emf.expressions.tests/pom.xml27
-rw-r--r--tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf.tests/META-INF/MANIFEST.MF15
-rw-r--r--tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf.tests/pom.xml27
-rw-r--r--tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/META-INF/MANIFEST.MF23
-rw-r--r--tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/pom.xml25
-rw-r--r--tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/META-INF/MANIFEST.MF23
-rw-r--r--tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/pom.xml25
-rw-r--r--tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/META-INF/MANIFEST.MF26
-rw-r--r--tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/pom.xml25
-rw-r--r--tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/META-INF/MANIFEST.MF40
-rw-r--r--tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/pom.xml13
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/META-INF/MANIFEST.MF40
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/pom.xml13
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/META-INF/MANIFEST.MF21
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/pom.xml25
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/META-INF/MANIFEST.MF49
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/pom.xml25
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.tests/META-INF/MANIFEST.MF46
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.tests/pom.xml25
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu.tests/META-INF/MANIFEST.MF18
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu.tests/pom.xml25
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF22
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/pom.xml25
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome.tests/META-INF/MANIFEST.MF37
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome.tests/pom.xml27
-rw-r--r--tests/junit/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.tests/META-INF/MANIFEST.MF26
-rw-r--r--tests/junit/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.tests/pom.xml7
-rw-r--r--tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common.tests/META-INF/MANIFEST.MF35
-rw-r--r--tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common.tests/pom.xml27
-rw-r--r--tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model.tests/META-INF/MANIFEST.MF15
-rw-r--r--tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model.tests/pom.xml27
-rwxr-xr-xtests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.suite.tests/META-INF/MANIFEST.MF20
-rwxr-xr-xtests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.suite.tests/pom.xml11
-rw-r--r--tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.tests/META-INF/MANIFEST.MF37
-rw-r--r--tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.tests/pom.xml27
-rwxr-xr-xtests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.tests/META-INF/MANIFEST.MF47
-rw-r--r--tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.tests/pom.xml27
-rw-r--r--tests/junit/plugins/infra/org.eclipse.papyrus.infra.architecture.tests/META-INF/MANIFEST.MF11
-rw-r--r--tests/junit/plugins/infra/org.eclipse.papyrus.infra.architecture.tests/pom.xml11
-rw-r--r--tests/junit/plugins/infra/org.eclipse.papyrus.infra.filters.tests/META-INF/MANIFEST.MF13
-rw-r--r--tests/junit/plugins/infra/org.eclipse.papyrus.infra.filters.tests/pom.xml11
-rw-r--r--tests/junit/plugins/infra/org.eclipse.papyrus.infra.newchild.tests/META-INF/MANIFEST.MF16
-rw-r--r--tests/junit/plugins/infra/org.eclipse.papyrus.infra.newchild.tests/models/NewChildExtensionPointTests.creationmenumodel2
-rw-r--r--tests/junit/plugins/infra/org.eclipse.papyrus.infra.newchild.tests/pom.xml11
-rwxr-xr-xtests/junit/plugins/infra/org.eclipse.papyrus.infra.suite.tests/META-INF/MANIFEST.MF69
-rwxr-xr-xtests/junit/plugins/infra/org.eclipse.papyrus.infra.suite.tests/pom.xml11
-rw-r--r--tests/junit/plugins/infra/org.eclipse.papyrus.infra.tools.tests/META-INF/MANIFEST.MF17
-rw-r--r--tests/junit/plugins/infra/org.eclipse.papyrus.infra.tools.tests/pom.xml25
-rw-r--r--tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.architecture.tests/META-INF/MANIFEST.MF34
-rw-r--r--tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.architecture.tests/pom.xml13
-rw-r--r--tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.tests/META-INF/MANIFEST.MF23
-rw-r--r--tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.tests/pom.xml25
-rw-r--r--tests/junit/plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui.tests/META-INF/MANIFEST.MF19
-rw-r--r--tests/junit/plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui.tests/pom.xml25
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/META-INF/MANIFEST.MF34
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/pom.xml23
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.tests/META-INF/MANIFEST.MF27
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.tests/pom.xml23
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui.tests/META-INF/MANIFEST.MF16
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui.tests/pom.xml25
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider.tests/META-INF/MANIFEST.MF30
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider.tests/pom.xml25
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.tests/META-INF/MANIFEST.MF18
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.tests/pom.xml23
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.semantic.tests/META-INF/MANIFEST.MF23
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.semantic.tests/pom.xml23
-rw-r--r--tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.tests/META-INF/MANIFEST.MF27
-rw-r--r--tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.tests/pom.xml23
-rw-r--r--tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.ui.tests/META-INF/MANIFEST.MF22
-rw-r--r--tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.ui.tests/pom.xml25
-rw-r--r--tests/junit/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy.tests/META-INF/MANIFEST.MF25
-rw-r--r--tests/junit/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy.tests/pom.xml11
-rw-r--r--tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.profilemigration.tests/META-INF/MANIFEST.MF20
-rw-r--r--tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.profilemigration.tests/pom.xml25
-rwxr-xr-xtests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.suite.tests/META-INF/MANIFEST.MF15
-rwxr-xr-xtests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.suite.tests/pom.xml11
-rw-r--r--tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests/META-INF/MANIFEST.MF17
-rw-r--r--tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests/pom.xml27
-rw-r--r--tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests/resources/org.eclipse.papyrus.toolsmiths.validation.elementtypes.example/META-INF/MANIFEST.MF4
-rw-r--r--tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.profile.tests/META-INF/MANIFEST.MF17
-rw-r--r--tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.profile.tests/pom.xml27
-rw-r--r--tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.profile.tests/resources/org.eclipse.papyrus.toolsmiths.validation.profile.example/META-INF/MANIFEST.MF7
-rw-r--r--tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.backend.tests/META-INF/MANIFEST.MF28
-rw-r--r--tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.backend.tests/pom.xml13
-rw-r--r--tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.tests/META-INF/MANIFEST.MF45
-rw-r--r--tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.tests/pom.xml2
-rwxr-xr-xtests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.tests/META-INF/MANIFEST.MF35
-rw-r--r--tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.tests/pom.xml13
-rw-r--r--tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.tests/META-INF/MANIFEST.MF33
-rw-r--r--tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.tests/pom.xml13
-rw-r--r--tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode.tests/META-INF/MANIFEST.MF33
-rw-r--r--tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode.tests/pom.xml13
-rw-r--r--tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/META-INF/MANIFEST.MF35
-rw-r--r--tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/pom.xml13
-rw-r--r--tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/src/org/eclipse/papyrus/uml/decoratormodel/helper/tests/Activator.java68
-rw-r--r--tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/src/org/eclipse/papyrus/uml/decoratormodel/internal/resource/tests/DecoratorModelIndexTest.java6
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity.tests/META-INF/MANIFEST.MF46
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity.tests/pom.xml36
-rwxr-xr-xtests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/META-INF/MANIFEST.MF61
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/pom.xml33
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/test/org/eclipse/papyrus/uml/diagram/clazz/test/canonical/TestClassDiagramAssociationClass.java15
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.tests/META-INF/MANIFEST.MF59
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.tests/pom.xml25
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.tests/src/org/eclipse/papyrus/uml/diagram/common/tests/Activator.java10
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication.tests/META-INF/MANIFEST.MF28
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication.tests/pom.xml36
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component.tests/META-INF/MANIFEST.MF32
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component.tests/pom.xml36
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite.tests/META-INF/MANIFEST.MF41
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite.tests/pom.xml33
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment.tests/META-INF/MANIFEST.MF29
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment.tests/pom.xml36
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd.tests/META-INF/MANIFEST.MF40
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd.tests/pom.xml25
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview.tests/META-INF/MANIFEST.MF36
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview.tests/pom.xml27
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile.tests/META-INF/MANIFEST.MF35
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile.tests/pom.xml33
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.properties.tests/META-INF/MANIFEST.MF32
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.properties.tests/pom.xml23
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence.tests/META-INF/MANIFEST.MF53
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence.tests/pom.xml33
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine.tests/META-INF/MANIFEST.MF35
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine.tests/pom.xml33
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests/META-INF/MANIFEST.MF48
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests/pom.xml25
-rwxr-xr-xtests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.suite.tests/META-INF/MANIFEST.MF41
-rwxr-xr-xtests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.suite.tests/pom.xml11
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.tests/META-INF/MANIFEST.MF76
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.tests/pom.xml27
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing.tests/META-INF/MANIFEST.MF40
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing.tests/pom.xml36
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase.tests/META-INF/MANIFEST.MF43
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase.tests/pom.xml33
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/META-INF/MANIFEST.MF26
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/pom.xml27
-rwxr-xr-xtests/junit/plugins/uml/expressions/org.eclipse.papyrus.uml.expressions.tests/META-INF/MANIFEST.MF18
-rwxr-xr-xtests/junit/plugins/uml/expressions/org.eclipse.papyrus.uml.expressions.tests/pom.xml7
-rw-r--r--tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.controlmode.tests/META-INF/MANIFEST.MF32
-rw-r--r--tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.controlmode.tests/pom.xml7
-rw-r--r--tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.tests/META-INF/MANIFEST.MF28
-rw-r--r--tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.tests/pom.xml7
-rw-r--r--tests/junit/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.tests/META-INF/MANIFEST.MF44
-rw-r--r--tests/junit/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.tests/pom.xml27
-rw-r--r--tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config.tests/META-INF/MANIFEST.MF63
-rw-r--r--tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config.tests/pom.xml7
-rwxr-xr-xtests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/META-INF/MANIFEST.MF52
-rw-r--r--tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/pom.xml7
-rwxr-xr-xtests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/src/org/eclipse/papyrus/uml/nattable/generic/tests/Activator.java7
-rwxr-xr-xtests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.matrix.tests/META-INF/MANIFEST.MF36
-rwxr-xr-xtests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.matrix.tests/pom.xml7
-rw-r--r--tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display.tests/META-INF/MANIFEST.MF45
-rw-r--r--tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display.tests/pom.xml11
-rw-r--r--tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/META-INF/MANIFEST.MF45
-rw-r--r--tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/pom.xml21
-rw-r--r--tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/src/org/eclipse/papyrus/uml/nattable/stereotyped/elements/tests/Activator.java10
-rwxr-xr-xtests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/META-INF/MANIFEST.MF23
-rwxr-xr-xtests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/pom.xml11
-rw-r--r--tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.tests/META-INF/MANIFEST.MF39
-rw-r--r--tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.tests/pom.xml19
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.architecture.tests/META-INF/MANIFEST.MF8
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.architecture.tests/pom.xml11
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/.classpath1
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/META-INF/MANIFEST.MF9
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/build.properties2
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/pom.xml25
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/src/org/eclipse/papyrus/uml/dynamic/profile/tests/Activator.java69
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.filters.tests/META-INF/MANIFEST.MF21
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.filters.tests/pom.xml11
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/META-INF/MANIFEST.MF20
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/pom.xml23
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.properties.tests/META-INF/MANIFEST.MF31
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.properties.tests/pom.xml23
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/META-INF/MANIFEST.MF35
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/pom.xml23
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.ui.tests/META-INF/MANIFEST.MF31
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.ui.tests/pom.xml23
-rwxr-xr-xtests/junit/plugins/uml/org.eclipse.papyrus.uml.suite.tests/META-INF/MANIFEST.MF62
-rwxr-xr-xtests/junit/plugins/uml/org.eclipse.papyrus.uml.suite.tests/pom.xml11
-rw-r--r--tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/META-INF/MANIFEST.MF31
-rw-r--r--tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/pom.xml13
-rw-r--r--tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.tests/META-INF/MANIFEST.MF15
-rw-r--r--tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.tests/pom.xml23
-rw-r--r--tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.tests/META-INF/MANIFEST.MF18
-rw-r--r--tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.tests/pom.xml7
-rw-r--r--tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.tests/META-INF/MANIFEST.MF17
-rw-r--r--tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.tests/pom.xml7
-rw-r--r--tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.tests/META-INF/MANIFEST.MF20
-rw-r--r--tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.tests/pom.xml7
-rwxr-xr-xtests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.suite.tests/META-INF/MANIFEST.MF20
-rwxr-xr-xtests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.suite.tests/pom.xml11
-rw-r--r--tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.tests/META-INF/MANIFEST.MF24
-rw-r--r--tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.tests/pom.xml23
-rw-r--r--tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.tests/META-INF/MANIFEST.MF22
-rw-r--r--tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.tests/pom.xml7
-rw-r--r--tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.tests/META-INF/MANIFEST.MF39
-rw-r--r--tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.tests/pom.xml23
-rw-r--r--tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils.tests/META-INF/MANIFEST.MF23
-rw-r--r--tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils.tests/pom.xml25
-rw-r--r--tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils.tests/src/org/eclipse/papyrus/uml/tools/utils/tests/tests/Activator.java68
-rw-r--r--tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/META-INF/MANIFEST.MF13
-rw-r--r--tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/pom.xml27
-rw-r--r--tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/src/org/eclipse/papyrus/uml/validation/tests/genvalidation/Activator.java8
-rw-r--r--tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.staticprofile/META-INF/MANIFEST.MF11
-rw-r--r--tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.staticprofile/pom.xml25
-rw-r--r--tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/META-INF/MANIFEST.MF32
-rw-r--r--tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/pom.xml25
-rw-r--r--tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/src/org/eclipse/papyrus/uml/validation/tests/Activator.java9
-rw-r--r--tests/junit/plugins/views/documentation/org.eclipse.papyrus.views.documentation.tests/META-INF/MANIFEST.MF21
-rw-r--r--tests/junit/plugins/views/documentation/org.eclipse.papyrus.views.documentation.tests/pom.xml7
-rw-r--r--tests/junit/plugins/views/org.eclipse.papyrus.views.modelexplorer.tests/META-INF/MANIFEST.MF48
-rw-r--r--tests/junit/plugins/views/org.eclipse.papyrus.views.modelexplorer.tests/pom.xml25
-rw-r--r--tests/junit/plugins/views/org.eclipse.papyrus.views.properties.toolsmiths.tests/META-INF/MANIFEST.MF32
-rw-r--r--tests/junit/plugins/views/org.eclipse.papyrus.views.properties.toolsmiths.tests/pom.xml13
-rwxr-xr-xtests/junit/plugins/views/org.eclipse.papyrus.views.suite.tests/META-INF/MANIFEST.MF19
-rwxr-xr-xtests/junit/plugins/views/org.eclipse.papyrus.views.suite.tests/pom.xml11
238 files changed, 3167 insertions, 2718 deletions
diff --git a/tests/junit/plugins/bundlestests/org.eclipse.papyrus.developer.suite.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/bundlestests/org.eclipse.papyrus.developer.suite.tests/META-INF/MANIFEST.MF
index 46271f821fe..3434e19f69b 100755
--- a/tests/junit/plugins/bundlestests/org.eclipse.papyrus.developer.suite.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/bundlestests/org.eclipse.papyrus.developer.suite.tests/META-INF/MANIFEST.MF
@@ -1,6 +1,6 @@
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 0.0.1.qualifier
+Bundle-Version: 1.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
@@ -8,10 +8,11 @@ Bundle-Activator: org.eclipse.papyrus.developer.suite.tests.Activator
Bundle-SymbolicName: org.eclipse.papyrus.developer.suite.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.bundles.tests;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.bundles.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.developer.suite.tests
diff --git a/tests/junit/plugins/bundlestests/org.eclipse.papyrus.developer.suite.tests/pom.xml b/tests/junit/plugins/bundlestests/org.eclipse.papyrus.developer.suite.tests/pom.xml
index c2c2ef640c6..b63f36e173c 100755
--- a/tests/junit/plugins/bundlestests/org.eclipse.papyrus.developer.suite.tests/pom.xml
+++ b/tests/junit/plugins/bundlestests/org.eclipse.papyrus.developer.suite.tests/pom.xml
@@ -1,8 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus</groupId>
@@ -12,7 +11,7 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.developer.suite.tests</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <version>1.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
<plugins>
@@ -54,4 +53,4 @@
</plugin>
</plugins>
</build>
-</project>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/META-INF/MANIFEST.MF
index d6b6f292536..2ad0551ca57 100644
--- a/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/META-INF/MANIFEST.MF
@@ -1,10 +1,15 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.eclipse.project.editors;bundle-version="[2.0.0,3.0.0)"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.eclipse.project.editors;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.pde.core;bundle-version="[3.13.0,4.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.eclipse.project.editors.tests
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.1.0.qualifier
+Bundle-Version: 3.0.0.qualifier
Bundle-Name: Papyrus Project Editor Tests
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.eclipse.project.editors.tests;singleton:=true
diff --git a/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/pom.xml b/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/pom.xml
index c5af081bb2e..0c881a4c4cb 100644
--- a/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/pom.xml
+++ b/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/pom.xml
@@ -1,8 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus.tests</groupId>
@@ -11,6 +10,6 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.eclipse.project.editors.tests</artifactId>
- <version>2.1.0-SNAPSHOT</version>
+ <version>3.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
-</project>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF
index 1dfa8ffc81f..20755be72bd 100644
--- a/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF
@@ -1,45 +1,38 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.timing;bundle-version="[1.3.0,2.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.notation;bundle-version="[1.10.0,2.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.ui.ide;bundle-version="3.9.0",
- org.eclipse.emf.transaction;bundle-version="1.4.0",
- org.eclipse.gmf.runtime.common.core;bundle-version="1.7.0",
- org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.7.0",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.7.0",
- org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="1.7.0",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.ui.navigator;bundle-version="3.5.0",
- org.eclipse.papyrus.infra.services.validation;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.service.validation;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.papyrus.infra.nattable.common;bundle-version="[5.0.0,6.0.0)",
- org.eclipse.papyrus.infra.nattable;bundle-version="[6.0.0,7.0.0)",
- org.eclipse.papyrus.uml.nattable.menu;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.sequence;bundle-version="[5.0.0,6.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.architecture;bundle-version="[2.0.0,3.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.architecture;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.nattable;bundle-version="[7.0.0,8.0.0)",
+ org.eclipse.papyrus.infra.nattable.common;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.validation;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.sequence;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.uml.diagram.timing;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.nattable.menu;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.ui.navigator;bundle-version="[3.9.0,4.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.editor.integration.tests,
org.eclipse.papyrus.editor.integration.tests.tests
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.5.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: Papyrus Editor Integration Tests
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.editor.integration.tests.Activator
diff --git a/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/pom.xml b/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/pom.xml
index 16b763e21a7..be28547347f 100644
--- a/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/pom.xml
+++ b/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/pom.xml
@@ -1,4 +1,7 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus.tests</groupId>
@@ -7,6 +10,6 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.editor.integration.tests</artifactId>
- <version>1.5.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/editor/org.eclipse.papyrus.editors.suite.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/editor/org.eclipse.papyrus.editors.suite.tests/META-INF/MANIFEST.MF
index 986590b4919..7ba7975bc36 100755
--- a/tests/junit/plugins/editor/org.eclipse.papyrus.editors.suite.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/editor/org.eclipse.papyrus.editors.suite.tests/META-INF/MANIFEST.MF
@@ -1,6 +1,6 @@
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 0.0.1.qualifier
+Bundle-Version: 1.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
@@ -8,12 +8,12 @@ Bundle-Activator: org.eclipse.papyrus.editors.suite.tests.Activator
Bundle-SymbolicName: org.eclipse.papyrus.editors.suite.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.bundles.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.eclipse.project.editors.tests;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.editor.integration.tests;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.eclipse.project.editors.tests;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.editor.integration.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.editors.suite.tests
diff --git a/tests/junit/plugins/editor/org.eclipse.papyrus.editors.suite.tests/pom.xml b/tests/junit/plugins/editor/org.eclipse.papyrus.editors.suite.tests/pom.xml
index 158de6aaa9e..084a19d78e2 100755
--- a/tests/junit/plugins/editor/org.eclipse.papyrus.editors.suite.tests/pom.xml
+++ b/tests/junit/plugins/editor/org.eclipse.papyrus.editors.suite.tests/pom.xml
@@ -1,8 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus</groupId>
@@ -12,7 +11,7 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.editors.suite.tests</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <version>1.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
<plugins>
@@ -55,4 +54,4 @@
</plugins>
</build>
-</project>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/facet/org.eclipse.papyrus.emf.facet.architecture.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/facet/org.eclipse.papyrus.emf.facet.architecture.tests/META-INF/MANIFEST.MF
index 9753aa0fe42..614c85668cb 100755
--- a/tests/junit/plugins/facet/org.eclipse.papyrus.emf.facet.architecture.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/facet/org.eclipse.papyrus.emf.facet.architecture.tests/META-INF/MANIFEST.MF
@@ -7,8 +7,17 @@ Bundle-Vendor: Eclipse Modeling Project
Automatic-Module-Name: org.eclipse.papyrus.emf.facet.architecture.tests
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.papyrus.emf.facet.architecture;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.infra.architecture;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.1.0,4.0.0)",
- org.eclipse.papyrus.infra.core.architecture;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.3.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.4.0,3.0.0)"
+ org.eclipse.papyrus.infra.architecture;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.architecture;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.emf;bundle-version="[2.8.0,3.0.0)",
+ org.eclipse.emf.common;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.emf.ecore;bundle-version="[2.0.0,3.0.0)",
+ org.junit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.emf.facet.custom.metamodel;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.osgi;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.emf.transaction;bundle-version="[1.9.1,2.0.0)",
+ org.eclipse.papyrus.emf.facet.efacet.metamodel;bundle-version="[2.0.0,3.0.0)"
diff --git a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.clipboard.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.clipboard.tests/META-INF/MANIFEST.MF
index ee4387200c1..78830025dd7 100755
--- a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.clipboard.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.clipboard.tests/META-INF/MANIFEST.MF
@@ -1,14 +1,18 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui;bundle-version="3.107.0",
- org.eclipse.core.runtime;bundle-version="3.11.0",
- org.junit,
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
+ org.eclipse.uml2.types;bundle-version="[2.5.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.core.clipboard.tests
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.clipboard.tests/pom.xml b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.clipboard.tests/pom.xml
index e6bc93601f1..9b759f6e9b5 100755
--- a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.clipboard.tests/pom.xml
+++ b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.clipboard.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.core.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.core.clipboard.tests</artifactId>
- <version>1.3.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.core.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.core.clipboard.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di.tests/META-INF/MANIFEST.MF
index 02fdb3e87f1..9c1419340f5 100644
--- a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di.tests/META-INF/MANIFEST.MF
@@ -1,15 +1,20 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.emf.ecore.xmi;bundle-version="[2.12.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor.di;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor.tests;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.ecore.xmi;bundle-version="[2.16.0,3.0.0)",
+ org.eclipse.emf.transaction;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core.sasheditor.di;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core.sasheditor.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.ui;bundle-version="[3.117.0,4.0.0)",
+ org.eclipse.uml2.types;bundle-version="[2.5.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.core.sasheditor.di.contentprovider,
org.eclipse.papyrus.infra.core.sasheditor.di.contentprovider.internal,
org.eclipse.papyrus.infra.core.sasheditor.di.sashmodel.query,
org.eclipse.papyrus.infra.core.sasheditor.di.tests
Bundle-Vendor: %Bundle-Vendor
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.core.sasheditor.di.tests;singleton:=true
diff --git a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di.tests/pom.xml b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di.tests/pom.xml
index ce52959a589..fd788e1864f 100644
--- a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di.tests/pom.xml
+++ b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.core.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.core.sasheditor.di.tests</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.core.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.core.sasheditor.di.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.tests/META-INF/MANIFEST.MF
index 64707041841..8756f846e86 100644
--- a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.tests/META-INF/MANIFEST.MF
@@ -1,16 +1,14 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui.editors;bundle-version="3.8.0",
- org.eclipse.jface.text;bundle-version="3.8.0",
- org.eclipse.ui.ide;bundle-version="3.8.0",
- org.eclipse.core.resources;bundle-version="3.8.0",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.ui;bundle-version="3.106.0",
- org.eclipse.ui.workbench.texteditor;bundle-version="3.9.0",
- org.eclipse.core.runtime;bundle-version="3.10.0",
- org.eclipse.emf.ecore;bundle-version="2.11.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)"
+Require-Bundle: org.eclipse.core.resources;bundle-version="[3.13.0,4.0.0)",
+ org.eclipse.core.runtime;bundle-version="[3.18.0,4.0.0)",
+ org.eclipse.emf.ecore;bundle-version="[2.22.0,3.0.0)",
+ org.eclipse.jface.text;bundle-version="[3.16.300,4.0.0)",
+ org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.ui;bundle-version="[3.117.0,4.0.0)",
+ org.eclipse.ui.editors;bundle-version="[3.13.0,4.0.0)",
+ org.eclipse.ui.ide;bundle-version="[3.17.0,4.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.core.sasheditor.contentprovider,
org.eclipse.papyrus.infra.core.sasheditor.contentprovider.simple,
org.eclipse.papyrus.infra.core.sasheditor.editor,
@@ -23,7 +21,7 @@ Export-Package: org.eclipse.papyrus.infra.core.sasheditor.contentprovider,
org.eclipse.papyrus.infra.core.sasheditor.tests.utils.trace,
org.eclipse.papyrus.infra.core.sasheditor.utils
Bundle-Vendor: %providerName
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.tests/pom.xml b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.tests/pom.xml
index 6086cd61695..1779bf0e97a 100644
--- a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.tests/pom.xml
+++ b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.core.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.core.sasheditor.tests</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.core.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.core.sasheditor.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.suite.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.suite.tests/META-INF/MANIFEST.MF
index 77df819e2ea..e0b91a7eb04 100755
--- a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.suite.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.suite.tests/META-INF/MANIFEST.MF
@@ -1,20 +1,21 @@
Manifest-Version: 1.0
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 0.0.1.qualifier
+Bundle-Version: 1.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.core.suite.tests.Activator
Bundle-SymbolicName: org.eclipse.papyrus.infra.core.suite.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.tests;bundle-version="[3.0.1,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor.di.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core.clipboard.tests;bundle-version="[1.3.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core.clipboard.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sasheditor.di.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sasheditor.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.tests;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.core.suite.tests
diff --git a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.suite.tests/pom.xml b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.suite.tests/pom.xml
index a7bed2e3447..0c1621e572a 100755
--- a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.suite.tests/pom.xml
+++ b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.suite.tests/pom.xml
@@ -1,8 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus</groupId>
@@ -12,7 +11,7 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.infra.core.suite.tests</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <version>1.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
<plugins>
@@ -55,4 +54,4 @@
</plugins>
</build>
-</project>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.tests/META-INF/MANIFEST.MF
index e82cb05caa9..a5bdae3f94b 100644
--- a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.tests/META-INF/MANIFEST.MF
@@ -1,14 +1,21 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.100,4.0.0)",
- org.eclipse.papyrus.infra.emf.gmf;bundle-version="[1.3.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.tools;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
+ org.eclipse.uml2.types;bundle-version="[2.5.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.core.resource,
org.eclipse.papyrus.infra.core.services,
org.eclipse.papyrus.infra.core.tests
Bundle-Vendor: %providerName
-Bundle-Version: 3.1.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.tests/pom.xml b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.tests/pom.xml
index 0009d60ed75..fe1a1723305 100644
--- a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.tests/pom.xml
+++ b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.core.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.core.tests</artifactId>
- <version>3.1.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.core.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.core.tests</artifactId>
+ <version>4.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.tests/META-INF/MANIFEST.MF
index 03f519a7a0c..4dcbc50d178 100644
--- a/tests/junit/plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.tests/META-INF/MANIFEST.MF
@@ -1,26 +1,23 @@
Manifest-Version: 1.0
Export-Package: org.eclipse.papyrus.infra.editor.welcome.tests
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.editor.welcome;visibility:=reexport;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.types;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
- org.eclipse.emf.ecore.xmi;bundle-version="2.8.0";visibility:=reexport,
- org.junit;bundle-version="4.12.0";visibility:=reexport,
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.tools;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.properties.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.properties;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.core.databinding;bundle-version="1.6.0",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.8.0",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor.di;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core.sasheditor.di;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.editor.welcome;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.properties.ui;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.tools;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-Vendor: %providerName
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-ClassPath: .
Bundle-Name: %pluginName
Bundle-Localization: plugin
diff --git a/tests/junit/plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.tests/pom.xml b/tests/junit/plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.tests/pom.xml
index 88fd4a794b7..e4ec3cb5425 100644
--- a/tests/junit/plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.tests/pom.xml
+++ b/tests/junit/plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.editor.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.editor.welcome.tests</artifactId>
- <version>1.2.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.editor.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.editor.welcome.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/emf/expressions/org.eclipse.papyrus.infra.emf.expressions.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/emf/expressions/org.eclipse.papyrus.infra.emf.expressions.tests/META-INF/MANIFEST.MF
index 768804cdaec..b37e411beef 100755
--- a/tests/junit/plugins/infra/emf/expressions/org.eclipse.papyrus.infra.emf.expressions.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/emf/expressions/org.eclipse.papyrus.infra.emf.expressions.tests/META-INF/MANIFEST.MF
@@ -2,13 +2,13 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.papyrus.infra.emf.expressions.tests
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Vendor: %Bundle-Vendor
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.papyrus.infra.emf.expressions;bundle-version="[1.0.0,2.0.0)",
- org.junit;bundle-version="[4.12.0,5.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,3.0.0)",
- org.eclipse.emf.ecore;bundle-version="[2.12.0,3.0.0)"
+Require-Bundle: org.eclipse.emf.ecore;bundle-version="[2.22.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf.expressions;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.emf.expressions.tests
Bundle-Description: JUnits Tests for the EMF Expressions Framework.
Automatic-Module-Name: org.eclipse.papyrus.infra.emf.expressions.tests
diff --git a/tests/junit/plugins/infra/emf/expressions/org.eclipse.papyrus.infra.emf.expressions.tests/pom.xml b/tests/junit/plugins/infra/emf/expressions/org.eclipse.papyrus.infra.emf.expressions.tests/pom.xml
index d8eb12255be..f9babdc0342 100755
--- a/tests/junit/plugins/infra/emf/expressions/org.eclipse.papyrus.infra.emf.expressions.tests/pom.xml
+++ b/tests/junit/plugins/infra/emf/expressions/org.eclipse.papyrus.infra.emf.expressions.tests/pom.xml
@@ -1,15 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.emf.expressions.main.tests</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.emf.expressions.tests</artifactId>
- <version>1.0.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
- <description>JUnits Tests for the EMF Expressions Framework.</description>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.emf.expressions.main.tests</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.emf.expressions.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+ <description>JUnits Tests for the EMF Expressions Framework.</description>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf.tests/META-INF/MANIFEST.MF
index eddaf3f27dd..9baa84ac06d 100644
--- a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf.tests/META-INF/MANIFEST.MF
@@ -1,12 +1,17 @@
Manifest-Version: 1.0
Export-Package: org.eclipse.papyrus.infra.emf.gmf.tests,
org.eclipse.papyrus.infra.emf.gmf.util.tests
-Require-Bundle: org.junit;bundle-version="4.12.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.emf.gmf;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
+ org.eclipse.uml2.types;bundle-version="[2.5.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-Vendor: %providerName
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf.tests/pom.xml b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf.tests/pom.xml
index ad4e643a461..735b812240c 100644
--- a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf.tests/pom.xml
+++ b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.emf.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.emf.gmf.tests</artifactId>
- <version>1.2.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.emf.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.emf.gmf.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/META-INF/MANIFEST.MF
index 4929754ed35..d334af397f0 100644
--- a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/META-INF/MANIFEST.MF
@@ -1,16 +1,23 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.services.controlmode;bundle-version="[2.0.0,3.0.0)",
+Require-Bundle: org.eclipse.core.expressions;bundle-version="[3.6.0,4.0.0)",
+ org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
org.eclipse.gmf.runtime.notation;bundle-version="[1.10.0,2.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.9.0",
- org.eclipse.papyrus.infra.emf.readonly;bundle-version="[3.0.0,4.0.0)"
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.readonly;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.emf.readonly,
org.eclipse.papyrus.infra.emf.readonly.tests
Bundle-Vendor: %providerName
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/pom.xml b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/pom.xml
index 62b3597d87b..ebaac029b0c 100644
--- a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/pom.xml
+++ b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.emf.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.emf.readonly.tests</artifactId>
- <version>1.4.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.emf.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.emf.readonly.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/META-INF/MANIFEST.MF
index 45a3395ded7..07c242406df 100644
--- a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/META-INF/MANIFEST.MF
@@ -4,17 +4,20 @@ Export-Package: org.eclipse.papyrus.infra.emf.advice,
org.eclipse.papyrus.infra.emf.resource.index,
org.eclipse.papyrus.infra.emf.tests,
org.eclipse.papyrus.infra.emf.utils
-Require-Bundle: org.eclipse.emf.ecore.xmi;bundle-version="2.8.0",
- org.junit;bundle-version="4.10.0",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.types.core;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.emf.gmf;bundle-version="[1.3.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.types.core;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml.edit;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-Vendor: %providerName
-Bundle-Version: 1.5.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: fragment
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/pom.xml b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/pom.xml
index d95448f2bc8..7eb8f0f789f 100644
--- a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/pom.xml
+++ b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.emf.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.emf.tests</artifactId>
- <version>1.5.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.emf.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.emf.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/META-INF/MANIFEST.MF
index b64892aff4f..856fd866005 100644
--- a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/META-INF/MANIFEST.MF
@@ -1,17 +1,23 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.services.controlmode;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.gmf.runtime.notation;bundle-version="[1.10.0,2.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.9.0",
- org.eclipse.papyrus.infra.ui.emf;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.emf.readonly;bundle-version="[3.0.0,4.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.emf.facet.custom.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.emf.facet.custom.ui;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.readonly;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.controlmode;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.ui.emf;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml.edit;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.labelprovider;bundle-version="3.0.0"
Export-Package: org.eclipse.papyrus.infra.ui.emf.tests,
org.eclipse.papyrus.infra.ui.internal.emf.readonly.handlers
Bundle-Vendor: %providerName
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/pom.xml b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/pom.xml
index 76abcecf3ba..d17c54e4343 100644
--- a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/pom.xml
+++ b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.emf.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.ui.emf.tests</artifactId>
- <version>1.4.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.emf.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.ui.emf.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/META-INF/MANIFEST.MF
index 93f36f1e5ab..e38fc3f18d9 100644
--- a/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/META-INF/MANIFEST.MF
@@ -1,31 +1,25 @@
Manifest-Version: 1.0
Export-Package: org.eclipse.papyrus.infra.gmfdiag.assistant.tests
-Require-Bundle: org.eclipse.core.runtime,
- org.junit;visibility:=reexport,
- org.eclipse.papyrus.infra.gmfdiag.assistant;bundle-version="[1.3.0,2.0.0)";visibility:=reexport,
- org.eclipse.emf.ecore;bundle-version="2.11.0";visibility:=reexport,
- org.eclipse.papyrus.infra.filters;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
- org.eclipse.uml2.types;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
- org.eclipse.emf.ecore.xmi;bundle-version="2.11.0";visibility:=reexport,
- org.eclipse.gmf.runtime.emf.ui;bundle-version="1.7.0",
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.types.core;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.gef;bundle-version="3.10.0",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.8.0",
- org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.usecase;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.types;bundle-version="[4.0.0,5.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.filters;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.assistant;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.types.core;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.service.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 1.3.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/pom.xml b/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/pom.xml
index 3693bd310ab..4f367b71399 100644
--- a/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/pom.xml
+++ b/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.gmfdiag.assistant.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.gmfdiag.assistant.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.infra.gmfdiag.assistant.tests</artifactId>
- <version>1.3.100-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/META-INF/MANIFEST.MF
index 64138cbba99..39ccd017007 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/META-INF/MANIFEST.MF
@@ -1,29 +1,27 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.junit;bundle-version="4.11.0",
- org.eclipse.papyrus.infra.gmfdiag.canonical;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.8.0",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.css.properties;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.css;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.css.model;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.gmf.codegen;bundle-version="2.11.0",
- org.eclipse.papyrus.gmfgenextension;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.emf.gmf;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.codegen;bundle-version="[2.11.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.papyrus.gmfgenextension;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.css;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.css.model;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.css.properties;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.uml2.uml.edit;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.gmfdiag.canonical.tests,
org.eclipse.papyrus.infra.gmfdiag.canonical.tests.internal;x-internal:=true
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/pom.xml b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/pom.xml
index 45b46757279..d340b437d85 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/pom.xml
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.gmfdiag.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.gmfdiag.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.infra.gmfdiag.canonical.tests</artifactId>
- <version>1.3.100-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/META-INF/MANIFEST.MF
index 3b2013a4dd2..8a5055c4a21 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/META-INF/MANIFEST.MF
@@ -1,14 +1,19 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.infra.emf.readonly;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf.readonly;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.service.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.gmfdiag.commands.tests
Bundle-Vendor: %providerName
-Bundle-Version: 1.3.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/pom.xml b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/pom.xml
index fea06904499..17005e40c2a 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/pom.xml
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.gmfdiag.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.gmfdiag.commands.tests</artifactId>
- <version>1.3.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.gmfdiag.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.gmfdiag.commands.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/META-INF/MANIFEST.MF
index 1e5d1ffee86..6ee76774af6 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/META-INF/MANIFEST.MF
@@ -1,23 +1,40 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.assistant;bundle-version="[1.3.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.canonical;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.types.core;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.expansion;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.uml.diagram.composite;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.types;bundle-version="[4.0.0,5.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="1.7.0",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="2.0.0",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.assistant;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.canonical;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.expansion;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.labelprovider;bundle-version="3.0.0",
+ org.eclipse.papyrus.infra.sync;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.tools;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.types.core;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.ui.emf;bundle-version="3.0.0",
+ org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="4.0.0",
+ org.eclipse.papyrus.infra.widgets;bundle-version="4.0.0",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.composite;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.service.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.gmfdiag.common.tests,
org.eclipse.papyrus.infra.gmfdiag.common.utils
Bundle-Vendor: %providerName
-Bundle-Version: 3.1.100.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/pom.xml b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/pom.xml
index 318a6b83ac6..d7a24caccbb 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/pom.xml
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.gmfdiag.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.gmfdiag.common.tests</artifactId>
- <version>3.1.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.gmfdiag.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.gmfdiag.common.tests</artifactId>
+ <version>4.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.tests/META-INF/MANIFEST.MF
index 733ea7dc7d4..9a26cbfcfe7 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.tests/META-INF/MANIFEST.MF
@@ -1,34 +1,28 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.gmfdiag.css;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.css.configuration;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.css.model;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.css.properties;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.css3.xtext;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.css3.xtext.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.gmf.runtime.notation;bundle-version="[1.10.0,2.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.core.resources;bundle-version="3.8.0",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.emf.appearance;bundle-version="[2.0.0,3.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.core.databinding;bundle-version="1.4.1",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[3.0.0,4.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.appearance;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.css;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.css.model;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.widgets;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.uml2.uml.edit;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.eclipse.xtext.xbase;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.gmfdiag.css.tests,
org.eclipse.papyrus.infra.gmfdiag.css.tests.tests
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: CSS Tests
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.css.tests.Activator
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.tests/pom.xml b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.tests/pom.xml
index 0831a8479c0..f65ea391057 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.tests/pom.xml
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.gmfdiag.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.gmfdiag.css.tests</artifactId>
- <version>1.3.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.gmfdiag.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.gmfdiag.css.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu.tests/META-INF/MANIFEST.MF
index 17a02c8b749..7ddfc0b556d 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu.tests/META-INF/MANIFEST.MF
@@ -1,17 +1,15 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.gmf.runtime.diagram.ui,
- org.junit,
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.menu;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.menu;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.gmfdiag.menu.tests.tests
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: GMF Diagram Menu Tests
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.menu.tests.Activator
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu.tests/pom.xml b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu.tests/pom.xml
index 7c867ab5536..bbf2125b1cd 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu.tests/pom.xml
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.gmfdiag.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.gmfdiag.menu.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.gmfdiag.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.gmfdiag.menu.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF
index 2a54e8a67fe..916169541ce 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF
@@ -1,21 +1,13 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.core.resources;bundle-version="3.8.0",
- org.eclipse.papyrus.infra.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.8.0",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.100,3.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.junit;bundle-version="4.11.0",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration;bundle-version="5.0.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="4.0.0"
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests.Activator
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/pom.xml b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/pom.xml
index 02a8c34cbb7..db70892a60c 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/pom.xml
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.gmfdiag.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests</artifactId>
- <version>1.3.100-SNAPSHOT</version>
- <packaging>eclipse-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.gmfdiag.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome.tests/META-INF/MANIFEST.MF
index 151acef5d8a..509fd590454 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome.tests/META-INF/MANIFEST.MF
@@ -1,25 +1,26 @@
Manifest-Version: 1.0
Export-Package: org.eclipse.papyrus.infra.gmfdiag.welcome.tests
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.editor.welcome;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
- org.junit;bundle-version="4.12.0";visibility:=reexport,
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.tools;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.properties.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.properties;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.core.databinding;bundle-version="1.6.0",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.8.0",
- org.eclipse.papyrus.infra.gmfdiag.welcome;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.editor.welcome.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.representation;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.architecture.representation;bundle-version="[2.0.0,3.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.architecture;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.architecture.representation,
+ org.eclipse.papyrus.infra.core.tests,
+ org.eclipse.papyrus.infra.core.architecture;bundle-version="3.0.0",
+ org.eclipse.papyrus.infra.editor.welcome;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.editor.welcome.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.representation;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.welcome;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.properties.ui;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.tools;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-Vendor: %providerName
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-ClassPath: .
Bundle-Name: %pluginName
Bundle-Localization: plugin
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome.tests/pom.xml b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome.tests/pom.xml
index f4a0ba4c565..df115de497b 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome.tests/pom.xml
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.gmfdiag.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.gmfdiag.welcome.tests</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.gmfdiag.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.gmfdiag.welcome.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.tests/META-INF/MANIFEST.MF
index 0ac4c765dc6..23c8405d6af 100644
--- a/tests/junit/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.tests/META-INF/MANIFEST.MF
@@ -2,23 +2,27 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.papyrus.infra.internationalization.tests;singleton:=true
-Bundle-Version: 1.100.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.papyrus.infra.internationalization.tests,
org.eclipse.papyrus.infra.internationalization.tests.tests
-Require-Bundle: org.junit;bundle-version="[4.11.0,5.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.internationalization;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.infra.internationalization.utils;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.ui.workbench;bundle-version="[3.108.0,4.0.0)",
- org.eclipse.papyrus.infra.internationalization.common;bundle-version="[1.100.0,2.0.0)",
- org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.tests;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.internationalization.common;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.ui.navigator;bundle-version="[3.9.0,4.0.0)",
+ org.eclipse.uml2.types;bundle-version="[2.5.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.papyrus.infra.internationalization.tests.Activator
Automatic-Module-Name: org.eclipse.papyrus.infra.internationalization.tests
diff --git a/tests/junit/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.tests/pom.xml b/tests/junit/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.tests/pom.xml
index 95334c0b2f3..d75683f19b1 100644
--- a/tests/junit/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.tests/pom.xml
+++ b/tests/junit/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.tests/pom.xml
@@ -1,4 +1,7 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus.tests</groupId>
@@ -7,6 +10,6 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.infra.internationalization.tests</artifactId>
- <version>1.100.100-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common.tests/META-INF/MANIFEST.MF
index 0f79f1ecf2a..b1b179912e5 100644
--- a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common.tests/META-INF/MANIFEST.MF
@@ -2,26 +2,25 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.papyrus.infra.nattable.common.tests;singleton:=true
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Activator: org.eclipse.papyrus.infra.nattable.common.tests.Activator
Bundle-Vendor: %Bundle-Vendor
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.nattable.common;bundle-version="[5.0.0,6.0.0)",
- org.eclipse.papyrus.infra.nattable.model;bundle-version="[4.0.0,5.0.0)",
- org.junit;bundle-version="4.12.0",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.emf.transaction,
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.architecture;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.nattable.representation;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.architecture.representation;bundle-version="[2.0.0,3.0.0)";visibility:=reexport
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.architecture;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.architecture.representation;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.architecture;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.nattable;bundle-version="[7.0.0,8.0.0)",
+ org.eclipse.papyrus.infra.nattable.common;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.nattable.representation;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml.edit;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-ActivationPolicy: lazy
Bundle-Description: %Bundle-Description
diff --git a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common.tests/pom.xml b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common.tests/pom.xml
index 686c2beb117..9695972669d 100644
--- a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common.tests/pom.xml
+++ b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.nattable.main.test</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.nattable.common.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.nattable.main.test</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.nattable.common.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model.tests/META-INF/MANIFEST.MF
index 11aac58682e..c160b4bbe16 100644
--- a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model.tests/META-INF/MANIFEST.MF
@@ -1,15 +1,16 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit,
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.nattable.model;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.nattable.model.tests,
org.eclipse.papyrus.infra.nattable.model.tests.tests
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %Bundle-Name
Bundle-Activator: org.eclipse.papyrus.infra.nattable.model.tests.Activator
diff --git a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model.tests/pom.xml b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model.tests/pom.xml
index a6c6e42fc05..c14d69b778b 100644
--- a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model.tests/pom.xml
+++ b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.nattable.main.test</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.nattable.model.tests</artifactId>
- <version>1.2.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.nattable.main.test</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.nattable.model.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.suite.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.suite.tests/META-INF/MANIFEST.MF
index 93cb454e36a..140679d7908 100755
--- a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.suite.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.suite.tests/META-INF/MANIFEST.MF
@@ -1,21 +1,19 @@
Manifest-Version: 1.0
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 0.0.1.qualifier
+Bundle-Version: 1.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.nattable.suite.tests.Activator
Bundle-SymbolicName: org.eclipse.papyrus.infra.nattable.suite.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.nattable.views.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.nattable.common.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.nattable.model.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.nattable.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.editor.integration.tests;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.papyrus.infra.nattable.common.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.nattable.model.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.nattable.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.nattable.views.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.nattable.suite.tests
diff --git a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.suite.tests/pom.xml b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.suite.tests/pom.xml
index 588fe154da8..0b04f21e6f1 100755
--- a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.suite.tests/pom.xml
+++ b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.suite.tests/pom.xml
@@ -1,8 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus</groupId>
@@ -12,7 +11,7 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.infra.nattable.suite.tests</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <version>1.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
<plugins>
@@ -55,4 +54,4 @@
</plugins>
</build>
-</project>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.tests/META-INF/MANIFEST.MF
index 2d01b5e8234..744b8d34fa5 100644
--- a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.tests/META-INF/MANIFEST.MF
@@ -1,27 +1,26 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit,
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.emf.ecore,
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.nattable.model;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.nattable;bundle-version="[6.0.0,7.0.0)",
+Require-Bundle: org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.5.0,2.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.architecture;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.nattable.representation;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.architecture.representation;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[3.0.0,4.0.0)"
+ org.eclipse.papyrus.infra.architecture;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.architecture.representation;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core.architecture;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.nattable;bundle-version="[7.0.0,8.0.0)",
+ org.eclipse.papyrus.infra.nattable.common;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.nattable.representation;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.labelprovider;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.nattable.tests.tests
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %Bundle-Name
Bundle-Activator: org.eclipse.papyrus.infra.nattable.tests.Activator
diff --git a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.tests/pom.xml b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.tests/pom.xml
index 3db0be9abfb..7eba0fbf1aa 100644
--- a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.tests/pom.xml
+++ b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.nattable.main.test</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.nattable.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.nattable.main.test</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.nattable.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.tests/META-INF/MANIFEST.MF
index ddd897361f3..9dae3ded626 100755
--- a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.tests/META-INF/MANIFEST.MF
@@ -1,34 +1,31 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.nattable;bundle-version="[6.0.0,7.0.0)",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.5.0,2.0.0)",
- org.junit,
- org.eclipse.papyrus.infra.nattable.model;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.emf.transaction;bundle-version="1.8.0",
- org.eclipse.gmf.runtime.notation;bundle-version="[1.10.0,2.0.0)",
- org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.nattable.common;bundle-version="[5.0.0,6.0.0)",
- org.eclipse.gmf.runtime.emf.commands.core;bundle-version="1.7.0",
- org.eclipse.papyrus.editor.integration.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.ui.navigator;bundle-version="3.5.500",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[1.2.0,2.0.0)"
+ org.eclipse.papyrus.editor.integration.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.nattable;bundle-version="[7.0.0,8.0.0)",
+ org.eclipse.papyrus.infra.nattable.common;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.widgets;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.nattable.views.tests,
org.eclipse.papyrus.infra.nattable.views.tests.tests
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %Bundle-Name
Bundle-Activator: org.eclipse.papyrus.infra.nattable.views.tests.Activator
diff --git a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.tests/pom.xml b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.tests/pom.xml
index 7bf0930d851..14f8f1a3f47 100644
--- a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.tests/pom.xml
+++ b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.nattable.main.test</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.nattable.views.tests</artifactId>
- <version>1.2.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.nattable.main.test</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.nattable.views.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.architecture.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.architecture.tests/META-INF/MANIFEST.MF
index 4f2f7342e51..e96d6d59255 100644
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.architecture.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.architecture.tests/META-INF/MANIFEST.MF
@@ -4,14 +4,15 @@ Bundle-SymbolicName: org.eclipse.papyrus.infra.architecture.tests
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Automatic-Module-Name: org.eclipse.papyrus.infra.architecture.tests
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.junit;bundle-version="4.12.0",
- org.eclipse.papyrus.junit.utils;bundle-version="2.2.0",
- org.eclipse.papyrus.infra.architecture;bundle-version="2.0.0",
- org.eclipse.papyrus.infra.core.architecture
+Require-Bundle: org.eclipse.emf.common;bundle-version="[2.19.0,3.0.0)",
+ org.eclipse.papyrus.infra.architecture;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core.architecture;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.architecture.tests,
org.eclipse.papyrus.infra.architecture.tests.merged
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.architecture.tests/pom.xml b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.architecture.tests/pom.xml
index 9fa6009f3c1..becd96dc649 100644
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.architecture.tests/pom.xml
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.architecture.tests/pom.xml
@@ -1,13 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.architecture.tests</artifactId>
- <version>1.0.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.filters.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.filters.tests/META-INF/MANIFEST.MF
index 05fc8d82972..6457550dbe7 100644
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.filters.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.filters.tests/META-INF/MANIFEST.MF
@@ -1,15 +1,14 @@
Manifest-Version: 1.0
Export-Package: org.eclipse.papyrus.infra.filters.tests
-Require-Bundle: org.eclipse.core.runtime,
- org.junit;visibility:=reexport,
- org.eclipse.papyrus.infra.filters;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
- org.eclipse.uml2.types;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
- org.eclipse.emf.ecore.xmi;bundle-version="2.11.0";visibility:=reexport,
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.common;bundle-version="[2.19.0,3.0.0)",
+ org.eclipse.emf.ecore;bundle-version="[2.22.0,3.0.0)",
+ org.eclipse.papyrus.infra.filters;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.filters.tests/pom.xml b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.filters.tests/pom.xml
index 17afc9dc6bc..7e50882563d 100644
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.filters.tests/pom.xml
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.filters.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.infra.filters.tests</artifactId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.newchild.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.newchild.tests/META-INF/MANIFEST.MF
index 069b7394ce1..bea5756da57 100644
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.newchild.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.newchild.tests/META-INF/MANIFEST.MF
@@ -1,16 +1,16 @@
Manifest-Version: 1.0
Export-Package: org.eclipse.papyrus.infra.newchild.tests
-Require-Bundle: org.eclipse.core.runtime;bundle-version="3.12.0",
- org.junit;bundle-version="4.12.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.newchild;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.emf.transaction;bundle-version="1.9.0"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.newchild;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.types;bundle-version="[2.5.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.newchild.tests/models/NewChildExtensionPointTests.creationmenumodel b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.newchild.tests/models/NewChildExtensionPointTests.creationmenumodel
index 0f0ce6ce348..2908c1500eb 100644
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.newchild.tests/models/NewChildExtensionPointTests.creationmenumodel
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.newchild.tests/models/NewChildExtensionPointTests.creationmenumodel
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="ASCII"?>
-<ElementCreationMenuModel:Folder xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ElementCreationMenuModel="http://www.eclipse.org/papyrus/infra/newchild/elementcreationmenumodel" xmlns:elementtypesconfigurations="http://www.eclipse.org/papyrus/infra/elementtypesconfigurations/1.2" xmlns:elementtypesconfigurations="http://www.eclipse.org/papyrus/infra/elementtypesconfigurations/1.2" label="NewChildExtensionPointTest">
+<ElementCreationMenuModel:Folder xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ElementCreationMenuModel="http://www.eclipse.org/papyrus/infra/newchild/elementcreationmenumodel" xmlns:elementtypesconfigurations="http://www.eclipse.org/papyrus/infra/elementtypesconfigurations/1.2" label="NewChildExtensionPointTest">
<menu xsi:type="ElementCreationMenuModel:CreationMenu" label="MyComponent" icon="">
<elementType xsi:type="elementtypesconfigurations:MetamodelTypeConfiguration" href="pathmap:/resource/org.eclipse.papyrus.uml.service.types/model/uml.elementtypesconfigurations#org.eclipse.papyrus.uml.Component"/>
</menu>
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.newchild.tests/pom.xml b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.newchild.tests/pom.xml
index bce08894c6b..40310402242 100644
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.newchild.tests/pom.xml
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.newchild.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.infra.newchild.tests</artifactId>
- <version>1.2.100-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.suite.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.suite.tests/META-INF/MANIFEST.MF
index d1d22517d56..77911b18e79 100755
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.suite.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.suite.tests/META-INF/MANIFEST.MF
@@ -1,45 +1,44 @@
Manifest-Version: 1.0
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 0.0.1.qualifier
+Bundle-Version: 1.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.suite.tests.Activator
Bundle-SymbolicName: org.eclipse.papyrus.infra.suite.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.tools.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.ui.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.services.edit.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.services.edit.ui.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.services.labelprovider.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.services.semantic.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.emf.tests;bundle-version="[1.4.0,2.0.0)",
- org.eclipse.papyrus.infra.emf.gmf.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.ui.emf.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.types.tests;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.types.ui.tests;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common.tests;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.canonical.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.emf.readonly.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.editor.welcome.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.welcome.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.properties.ui.tests;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.filters.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.assistant.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.services.resourceloading.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.services.controlmode.tests;bundle-version="[1.4.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.menu.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.css.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.emf.expressions.tests;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.infra.internationalization.tests;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.infra.viewpoints.policy.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.architecture.tests;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.infra.ui.architecture.tests;bundle-version="[1.0.0,2.0.0)"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.papyrus.infra.architecture.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.editor.welcome.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf.expressions.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf.readonly.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.filters.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.assistant.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.canonical.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common.tests;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.css.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.menu.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.welcome.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.internationalization.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.properties.ui.tests;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.services.controlmode.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.services.edit.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.services.edit.ui.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.services.labelprovider.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.services.resourceloading.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.services.semantic.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.tools.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.types.tests;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.types.ui.tests;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui.architecture.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.ui.emf.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.ui.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.viewpoints.policy.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.suite.tests
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.suite.tests/pom.xml b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.suite.tests/pom.xml
index 5116d3095c6..2a750795e23 100755
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.suite.tests/pom.xml
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.suite.tests/pom.xml
@@ -1,8 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus</groupId>
@@ -12,7 +11,7 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.infra.suite.tests</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <version>1.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
<plugins>
@@ -55,4 +54,4 @@
</plugins>
</build>
-</project>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.tools.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.tools.tests/META-INF/MANIFEST.MF
index ea025b7ab6b..3f40d251c01 100644
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.tools.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.tools.tests/META-INF/MANIFEST.MF
@@ -1,17 +1,14 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.tools;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.swt;bundle-version="3.100.0",
- org.eclipse.core.runtime;bundle-version="3.10.0",
- org.eclipse.core.databinding;bundle-version="1.4.0",
- org.eclipse.core.databinding.beans;bundle-version="1.2.0",
- org.eclipse.core.databinding.property;bundle-version="1.4.0",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)"
+Require-Bundle: org.eclipse.core.databinding.beans;bundle-version="[1.6.0,2.0.0)",
+ org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.papyrus.infra.tools;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.tools.databinding,
org.eclipse.papyrus.infra.tools.tests
Bundle-Vendor: Eclipse Modeling Project
-Bundle-Version: 1.3.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: Papyrus Infrastructure Tools Tests
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.tools.tests;singleton:=true
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.tools.tests/pom.xml b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.tools.tests/pom.xml
index 8d20047039c..d8b4a4b2120 100644
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.tools.tests/pom.xml
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.tools.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.tools.tests</artifactId>
- <version>1.3.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+ <artifactId>org.eclipse.papyrus.infra.tools.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.architecture.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.architecture.tests/META-INF/MANIFEST.MF
index 7f3da580fa7..c927f08eb52 100644
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.architecture.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.architecture.tests/META-INF/MANIFEST.MF
@@ -4,20 +4,32 @@ Bundle-SymbolicName: org.eclipse.papyrus.infra.ui.architecture.tests
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 1.0.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Automatic-Module-Name: org.eclipse.papyrus.infra.ui.architecture.tests
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.junit;bundle-version="4.12.0",
- org.eclipse.papyrus.junit.utils;bundle-version="2.2.0",
- org.eclipse.papyrus.infra.architecture;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.ui.architecture;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.1.0,4.0.0)",
- org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.1.0,4.0.0)",
- org.eclipse.papyrus.views.modelexplorer.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[3.1.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.103.0,4.0.0)",
- org.eclipse.papyrus.infra.architecture.representation;bundle-version="[2.1.0,3.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.architecture;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.architecture.representation;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.ui.architecture;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.widgets;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.views.modelexplorer.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.ui.ide;bundle-version="[3.17.0,4.0.0)",
+ org.eclipse.ui.navigator;bundle-version="[3.9.0,4.0.0)",
+ org.eclipse.uml2.common.edit;bundle-version="[2.5.0,3.0.0)",
+ org.eclipse.uml2.types;bundle-version="[2.5.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.ui.architecture.tests
Bundle-Activator: org.eclipse.papyrus.infra.ui.architecture.tests.Activator
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.architecture.tests/pom.xml b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.architecture.tests/pom.xml
index 63df801b9a2..9218e20a5b9 100644
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.architecture.tests/pom.xml
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.architecture.tests/pom.xml
@@ -1,11 +1,14 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.ui.architecture.tests</artifactId>
- <version>1.0.100-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.tests/META-INF/MANIFEST.MF
index 47503486d44..59cb1b04554 100644
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.tests/META-INF/MANIFEST.MF
@@ -1,20 +1,21 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.ui;bundle-version="3.100.0",
- org.eclipse.core.runtime;bundle-version="3.10.0",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.tools;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.emf.ecore;bundle-version="2.12.0"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.tools;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.widgets;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml.edit;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.ui.lifecycleevents,
org.eclipse.papyrus.infra.ui.providers,
org.eclipse.papyrus.infra.ui.tests,
org.eclipse.papyrus.infra.ui.util
Bundle-Vendor: Eclipse Modeling Project
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: Papyrus Infrastructure UI Tests
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.ui.tests;singleton:=true
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.tests/pom.xml b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.tests/pom.xml
index eed0edc9369..2a542bb3a83 100644
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.tests/pom.xml
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.ui.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.ui.tests</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+ <artifactId>org.eclipse.papyrus.infra.ui.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui.tests/META-INF/MANIFEST.MF
index dc575b40d72..32f4025ee4a 100644
--- a/tests/junit/plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui.tests/META-INF/MANIFEST.MF
@@ -1,12 +1,19 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.properties.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)"
+Require-Bundle: org.eclipse.draw2d;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.properties.ui;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.properties.ui.tests
Bundle-Vendor: Eclipse Modeling Project
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 3.0.0.qualifier
Bundle-Name: Papyrus Properties UI Tests
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.properties.ui.tests;singleton:=true
diff --git a/tests/junit/plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui.tests/pom.xml b/tests/junit/plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui.tests/pom.xml
index d7212347b21..c312bf122f0 100644
--- a/tests/junit/plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui.tests/pom.xml
+++ b/tests/junit/plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.properties.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.properties.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.properties.ui.tests</artifactId>
- <version>2.0.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+ <artifactId>org.eclipse.papyrus.infra.properties.ui.tests</artifactId>
+ <version>3.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/META-INF/MANIFEST.MF
index 8d1296bebaf..32ee754ba31 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/META-INF/MANIFEST.MF
@@ -1,27 +1,25 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui;bundle-version="3.106.0",
- org.junit;bundle-version="4.11.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.services.controlmode;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.emf.transaction,
- org.eclipse.papyrus.infra.services.resourceloading;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.ui.navigator;bundle-version="3.5.500",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.emf.gmf;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.controlmode;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.services.resourceloading;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.services.controlmode.tests,
org.eclipse.papyrus.infra.services.controlmode.tests.control,
org.eclipse.papyrus.infra.services.controlmode.tests.uncontrol
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.5.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.services.controlmode.tests.control.Activator
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/pom.xml b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/pom.xml
index 72def1aa410..14f95d6655a 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/pom.xml
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.services.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.services.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.services.controlmode.tests</artifactId>
- <version>1.5.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+ <artifactId>org.eclipse.papyrus.infra.services.controlmode.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.tests/META-INF/MANIFEST.MF
index 47ded2fba71..6e9ce0baae8 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.tests/META-INF/MANIFEST.MF
@@ -1,16 +1,17 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui.ide;bundle-version="3.8.0",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.services.validation;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.7.0",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.validation;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.ui.ide;bundle-version="[3.17.0,4.0.0)",
+ org.eclipse.uml2.uml.edit;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.services.edit.tests,
org.eclipse.papyrus.infra.services.edit.tests.commands,
org.eclipse.papyrus.infra.services.edit.tests.context,
@@ -20,7 +21,7 @@ Export-Package: org.eclipse.papyrus.infra.services.edit.tests,
org.eclipse.papyrus.infra.services.edit.tests.suites,
org.eclipse.papyrus.infra.services.edit.tests.utils
Bundle-Vendor: %providerName
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.tests/pom.xml b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.tests/pom.xml
index c894c5fd46d..54f56090408 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.tests/pom.xml
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.services.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.services.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.services.edit.tests</artifactId>
- <version>1.2.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+ <artifactId>org.eclipse.papyrus.infra.services.edit.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui.tests/META-INF/MANIFEST.MF
index 55177f61325..f3bc6d41a7f 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui.tests/META-INF/MANIFEST.MF
@@ -1,14 +1,16 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.services.edit.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.7.0",
- org.eclipse.papyrus.infra.services.edit.tests;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.services.edit.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.services.edit.ui;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.services.edit.ui.dialogs.tests,
org.eclipse.papyrus.infra.services.edit.ui.tests
Bundle-Vendor: %providerName
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui.tests/pom.xml b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui.tests/pom.xml
index ec860b43d5a..3007435be0c 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui.tests/pom.xml
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.services.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.services.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.services.edit.ui.tests</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+ <artifactId>org.eclipse.papyrus.infra.services.edit.ui.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider.tests/META-INF/MANIFEST.MF
index 36fc1a50af5..f04dce919e5 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider.tests/META-INF/MANIFEST.MF
@@ -1,23 +1,21 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.services.labelprovider;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.emf.ecore;bundle-version="2.8.1",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.emf.facet.custom.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.emf.facet.custom.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.ui.emf;bundle-version="[2.0.0,3.0.0)"
+Require-Bundle: org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.emf.facet.custom.core;bundle-version="4.0.0",
+ org.eclipse.papyrus.emf.facet.custom.ui;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.services.labelprovider;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.ui.emf;bundle-version="3.0.0",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.services.labelprovider.tests
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: LabelProvider Service Tests
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.services.labelprovider.tests.Activator
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider.tests/pom.xml b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider.tests/pom.xml
index 29658ab2147..c654a5b6459 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider.tests/pom.xml
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.services.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.services.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.services.labelprovider.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+ <artifactId>org.eclipse.papyrus.infra.services.labelprovider.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.tests/META-INF/MANIFEST.MF
index a59d9e69f16..3bd4be641f3 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.tests/META-INF/MANIFEST.MF
@@ -1,16 +1,20 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.uml.resourceloading.profile;bundle-version="[1.2.0,2.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
org.eclipse.gmf.runtime.notation;bundle-version="[1.10.0,2.0.0)",
- org.eclipse.papyrus.infra.services.resourceloading;bundle-version="[3.0.0,4.0.0)"
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.resourceloading;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.services.resourceloading.tests,
org.eclipse.papyrus.infra.services.resourceloading.tests.testModel1,
org.eclipse.papyrus.infra.services.resourceloading.tests.testModel2
Bundle-Vendor: %providerName
-Bundle-Version: 1.3.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %fragmentName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.tests/pom.xml b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.tests/pom.xml
index f587eb93063..0036174ece9 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.tests/pom.xml
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.services.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.services.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.services.resourceloading.tests</artifactId>
- <version>1.3.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+ <artifactId>org.eclipse.papyrus.infra.services.resourceloading.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.semantic.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.semantic.tests/META-INF/MANIFEST.MF
index dbb8ec0ec91..9c3f2492225 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.semantic.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.semantic.tests/META-INF/MANIFEST.MF
@@ -1,16 +1,19 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.services.semantic;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.nattable.model;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.services.semantic;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.services.semantic.tests
Bundle-Vendor: %providerName
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.semantic.tests/pom.xml b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.semantic.tests/pom.xml
index 6a75cc951c4..b9813ad2df1 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.semantic.tests/pom.xml
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.semantic.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.services.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.services.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.services.semantic.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+ <artifactId>org.eclipse.papyrus.infra.services.semantic.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.tests/META-INF/MANIFEST.MF
index 36cbcdb9517..c1efc7f6841 100644
--- a/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.tests/META-INF/MANIFEST.MF
@@ -1,20 +1,21 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.types.core;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.newchild;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.8.0",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.types;bundle-version="[4.0.0,5.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.types.core;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.infra.types.tests
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.0.200.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.tests/pom.xml b/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.tests/pom.xml
index b1369af18f7..726ecfefaf9 100644
--- a/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.tests/pom.xml
+++ b/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.types.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.types.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.types.tests</artifactId>
- <version>3.0.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+ <artifactId>org.eclipse.papyrus.infra.types.tests</artifactId>
+ <version>4.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.ui.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.ui.tests/META-INF/MANIFEST.MF
index a7611d50218..00b2f739805 100644
--- a/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.ui.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.ui.tests/META-INF/MANIFEST.MF
@@ -1,19 +1,17 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.8.0",
- org.eclipse.papyrus.infra.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.types.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.types.tests;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.emf.type.core,
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.types.core;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.types.tests;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)",
+ org.eclipse.papyrus.infra.newchild;bundle-version="5.0.0"
Export-Package: org.eclipse.papyrus.infra.types.ui.tests
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.0.100.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.ui.tests/pom.xml b/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.ui.tests/pom.xml
index 4892e5c1a9e..48ba4c754cb 100644
--- a/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.ui.tests/pom.xml
+++ b/tests/junit/plugins/infra/types/org.eclipse.papyrus.infra.types.ui.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.types.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.types.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.types.ui.tests</artifactId>
- <version>3.0.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+ <artifactId>org.eclipse.papyrus.infra.types.ui.tests</artifactId>
+ <version>4.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy.tests/META-INF/MANIFEST.MF
index 4852cd1c1e2..2fadfa57a32 100644
--- a/tests/junit/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy.tests/META-INF/MANIFEST.MF
@@ -1,19 +1,22 @@
Manifest-Version: 1.0
Export-Package: org.eclipse.papyrus.infra.viewpoints.policy.tests
-Require-Bundle: org.eclipse.core.runtime;bundle-version="3.11.0",
- org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.emf.ecore.xmi;bundle-version="2.11.0";visibility:=reexport,
- org.junit;bundle-version="4.11.0";visibility:=reexport,
- org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.9.0",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.architecture;bundle-version="2.0.0",
- org.eclipse.papyrus.infra.architecture.representation;bundle-version="2.0.0",
- org.eclipse.papyrus.infra.gmfdiag.representation;bundle-version="2.0.0"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.architecture;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.architecture.representation;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.architecture;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.representation;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy.tests/pom.xml b/tests/junit/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy.tests/pom.xml
index f722a63e982..8a0b77aa259 100644
--- a/tests/junit/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy.tests/pom.xml
+++ b/tests/junit/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy.tests/pom.xml
@@ -1,13 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.infra.viewpoints.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.infra.viewpoints.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.viewpoints.policy.tests</artifactId>
<packaging>eclipse-test-plugin</packaging>
- <version>1.2.100-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.profilemigration.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.profilemigration.tests/META-INF/MANIFEST.MF
index ae9e24025a9..6382d4633d5 100644
--- a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.profilemigration.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.profilemigration.tests/META-INF/MANIFEST.MF
@@ -2,16 +2,18 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Test
Bundle-SymbolicName: org.eclipse.papyrus.toolsmiths.profilemigration.tests;singleton:=true
-Bundle-Version: 0.7.100.qualifier
+Bundle-Version: 1.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.junit;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.toolsmiths.profilemigration;bundle-version="[0.7.0,1.0.0)",
- org.eclipse.papyrus.toolsmiths.profilemigration.ui;bundle-version="[0.7.0,1.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.emf.compare;bundle-version="[3.0.0,4.0.0)"
+Require-Bundle: org.eclipse.emf.compare;bundle-version="[3.5.0,4.0.0)",
+ org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.toolsmiths.profilemigration;bundle-version="[1.0.0,2.0.0)",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-Activator: org.eclipse.papyrus.toolsmiths.profilemigration.tests.Activator
Export-Package: org.eclipse.papyrus.toolsmiths.profilemigration.tests
Automatic-Module-Name: org.eclipse.papyrus.toolsmiths.profilemigration.tests
diff --git a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.profilemigration.tests/pom.xml b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.profilemigration.tests/pom.xml
index fd99b09b358..d91023ad04f 100644
--- a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.profilemigration.tests/pom.xml
+++ b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.profilemigration.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.toolsmiths.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.toolsmiths.profilemigration.tests</artifactId>
- <version>0.7.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.toolsmiths.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.toolsmiths.profilemigration.tests</artifactId>
+ <version>1.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.suite.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.suite.tests/META-INF/MANIFEST.MF
index a652a9be002..0a56c23f1a5 100755
--- a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.suite.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.suite.tests/META-INF/MANIFEST.MF
@@ -1,6 +1,6 @@
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 0.0.1.qualifier
+Bundle-Version: 1.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
@@ -8,11 +8,12 @@ Bundle-Activator: org.eclipse.papyrus.toolsmiths.suite.tests.Activator
Bundle-SymbolicName: org.eclipse.papyrus.toolsmiths.suite.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.toolsmiths.profilemigration.tests;bundle-version="[0.7.0,1.0.0)"
+Require-Bundle: org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.toolsmiths.profilemigration.tests;bundle-version="[1.0.0,2.0.0)",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.toolsmiths.suite.tests
Automatic-Module-Name: org.eclipse.papyrus.toolsmiths.suite.tests
diff --git a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.suite.tests/pom.xml b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.suite.tests/pom.xml
index af9f6e74e26..8f865a5897a 100755
--- a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.suite.tests/pom.xml
+++ b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.suite.tests/pom.xml
@@ -1,8 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus</groupId>
@@ -12,7 +11,7 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.toolsmiths.suite.tests</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <version>1.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
<plugins>
@@ -54,4 +53,4 @@
</plugin>
</plugins>
</build>
-</project>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests/META-INF/MANIFEST.MF
index 98810e74496..fbee0bebb60 100644
--- a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests/META-INF/MANIFEST.MF
@@ -2,14 +2,17 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests;singleton:=true
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.junit;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.toolsmiths.validation.elementtypes;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.toolsmiths.validation.common;bundle-version="[1.0.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.toolsmiths.validation.elementtypes;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-Activator: org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests.Activator
Export-Package: org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests
Automatic-Module-Name: org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests
diff --git a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests/pom.xml b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests/pom.xml
index 71bc3877c5e..f3b8dcb6ee9 100644
--- a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests/pom.xml
+++ b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.toolsmiths.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests</artifactId>
- <version>1.0.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.toolsmiths.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests/resources/org.eclipse.papyrus.toolsmiths.validation.elementtypes.example/META-INF/MANIFEST.MF b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests/resources/org.eclipse.papyrus.toolsmiths.validation.elementtypes.example/META-INF/MANIFEST.MF
index 8b7321ab77b..d5e17672c6b 100644
--- a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests/resources/org.eclipse.papyrus.toolsmiths.validation.elementtypes.example/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.elementtypes.tests/resources/org.eclipse.papyrus.toolsmiths.validation.elementtypes.example/META-INF/MANIFEST.MF
@@ -2,12 +2,12 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.papyrus.toolsmiths.validation.elementtypes.example;singleton:=true
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.papyrus.toolsmiths.validation.elementtypes.example.Activator
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)"
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.18.0,4.0.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Automatic-Module-Name: org.eclipse.papyrus.toolsmiths.validation.elementtypes.example
Bundle-ActivationPolicy: lazy
diff --git a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.profile.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.profile.tests/META-INF/MANIFEST.MF
index a2881d21a31..e8b8f6c6311 100644
--- a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.profile.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.profile.tests/META-INF/MANIFEST.MF
@@ -2,14 +2,17 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.papyrus.toolsmiths.validation.profile.tests;singleton:=true
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.junit;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.toolsmiths.validation.profile;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.toolsmiths.validation.common;bundle-version="[1.0.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.toolsmiths.validation.profile;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-Activator: org.eclipse.papyrus.toolsmiths.validation.profile.tests.Activator
Export-Package: org.eclipse.papyrus.toolsmiths.validation.profile.tests
Automatic-Module-Name: org.eclipse.papyrus.toolsmiths.validation.profile.tests
diff --git a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.profile.tests/pom.xml b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.profile.tests/pom.xml
index fdcc19a8979..4fecb151c66 100644
--- a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.profile.tests/pom.xml
+++ b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.profile.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.toolsmiths.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.toolsmiths.validation.profile.tests</artifactId>
- <version>1.0.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.toolsmiths.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.toolsmiths.validation.profile.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.profile.tests/resources/org.eclipse.papyrus.toolsmiths.validation.profile.example/META-INF/MANIFEST.MF b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.profile.tests/resources/org.eclipse.papyrus.toolsmiths.validation.profile.example/META-INF/MANIFEST.MF
index 77d3f3d0c6f..e02fe332f89 100644
--- a/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.profile.tests/resources/org.eclipse.papyrus.toolsmiths.validation.profile.example/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/toolsmiths/org.eclipse.papyrus.toolsmiths.validation.profile.tests/resources/org.eclipse.papyrus.toolsmiths.validation.profile.example/META-INF/MANIFEST.MF
@@ -2,15 +2,12 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.papyrus.toolsmiths.validation.profile.example;singleton:=true
-Bundle-Version: 1.0.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.papyrus.toolsmiths.validation.profile.example.Activator
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
- org.eclipse.emf.ecore;visibility:=reexport,
- org.eclipse.uml2.types;visibility:=reexport,
- org.eclipse.uml2.uml;visibility:=reexport
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.18.0,4.0.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Automatic-Module-Name: org.eclipse.papyrus.toolsmiths.validation.profile.example
Bundle-ActivationPolicy: lazy
diff --git a/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.backend.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.backend.tests/META-INF/MANIFEST.MF
index 4df63925f7b..f2aad6d9624 100644
--- a/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.backend.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.backend.tests/META-INF/MANIFEST.MF
@@ -2,23 +2,19 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: ALF Backend Tests
Bundle-SymbolicName: org.eclipse.papyrus.uml.alf.backend.tests;singleton:=true
-Bundle-Version: 1.1.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Activator: org.eclipse.papyrus.uml.alf.backend.tests.Activator
-Require-Bundle: org.eclipse.core.runtime,
- org.junit,
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.emf.ecore;bundle-version="2.11.0",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.emf.edit;bundle-version="2.11.0",
- org.eclipse.core.commands;bundle-version="3.7.0",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.emf.transaction;bundle-version="1.9.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.alf.libraries;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.common.core;bundle-version="1.7.0",
- org.eclipse.gmf.runtime.emf.commands.core;bundle-version="1.7.0",
- org.eclipse.papyrus.uml.extensionpoints;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core.tests;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.alf.libraries;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.extensionpoints;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Bundle-ActivationPolicy: lazy
Bundle-Vendor: Eclipse Modeling Project
diff --git a/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.backend.tests/pom.xml b/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.backend.tests/pom.xml
index 3924fab6517..07826dec2a6 100644
--- a/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.backend.tests/pom.xml
+++ b/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.backend.tests/pom.xml
@@ -1,13 +1,16 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.alf.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.alf.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.alf.backend.tests</artifactId>
- <version>1.1.100-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
<plugins>
diff --git a/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.tests/META-INF/MANIFEST.MF
index 748e5dddd0d..011e773e739 100644
--- a/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.tests/META-INF/MANIFEST.MF
@@ -1,32 +1,19 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.xtext.junit4,
- org.eclipse.ui.workbench;resolution:=optional,
- org.eclipse.m2m.qvt.oml;bundle-version="3.3.0",
- org.eclipse.emf.common,
- org.eclipse.emf.ecore,
- org.eclipse.m2m.qvt.oml.common;bundle-version="3.3.0",
- org.eclipse.m2m.qvt.oml.emf.util;bundle-version="3.3.0",
- org.eclipse.m2m.qvt.oml.ocl;bundle-version="3.3.0",
- org.eclipse.m2m.qvt.oml.runtime;bundle-version="3.3.0",
- org.eclipse.xtend.lib,
- org.eclipse.xtext.xbase.lib,
- org.eclipse.xtend;bundle-version="1.4.0",
- org.eclipse.emf.ecore.xmi;visibility:=reexport,
- org.junit;visibility:=reexport,
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.objectweb.asm;bundle-version="[5.0.1,6.0.0)";resolution:=optional,
- org.eclipse.ocl.uml;bundle-version="5.0.0",
- org.eclipse.uml2.uml.resources;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.uml.alf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.alf.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.alf.to.fuml;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.extensionpoints;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.xtext,
- org.eclipse.ocl.pivot,
- org.eclipse.ocl,
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core.log
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.ocl.pivot;bundle-version="[1.12.0,2.0.0)",
+ org.eclipse.ocl.uml;bundle-version="[5.10.0,6.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.alf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.alf.ui;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.extensionpoints;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.resources;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtend;bundle-version="[2.2.0,3.0.0)",
+ org.eclipse.xtext.junit4;bundle-version="[2.22.0,3.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.eclipse.xtext.xbase;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.alf,
org.eclipse.papyrus.uml.alf.tests
Bundle-Vendor: Eclipse Modeling Project
@@ -34,7 +21,7 @@ Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .,
Alf/,
UML/
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: ALF Tests
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.alf.tests;singleton:=true
diff --git a/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.tests/pom.xml b/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.tests/pom.xml
index 3addc98ef4c..b771efeed9c 100644
--- a/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.tests/pom.xml
+++ b/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.tests/pom.xml
@@ -11,7 +11,7 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.alf.tests</artifactId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
<plugins>
diff --git a/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.tests/META-INF/MANIFEST.MF
index 6c5e36bc3b6..6cc6132ec7b 100755
--- a/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.tests/META-INF/MANIFEST.MF
@@ -1,28 +1,23 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- org.junit;bundle-version="4.11.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.emf.ecore;bundle-version="2.11.0",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.types.core;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.7.0",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.profile.types.generator;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.profile.assistants.generator;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.assistant;bundle-version="[1.3.0,2.0.0)",
- com.google.inject;bundle-version="3.0.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
- org.eclipse.papyrus.uml.profile.types.generator.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.8.0",
- org.eclipse.papyrus.uml.diagram.usecase;bundle-version="[4.0.0,5.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.filters;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.assistant;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.usecase;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.profile.assistants.generator;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.profile.types.generator;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.profile.types.generator.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.xbase.lib;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.profile.assistants.generator.tests
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.tests/pom.xml b/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.tests/pom.xml
index ade1a7aed62..82964182f88 100644
--- a/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.tests/pom.xml
+++ b/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.assistants.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.assistants.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.profile.assistants.generator.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.tests/META-INF/MANIFEST.MF
index dbc40728747..a9594ac4e10 100644
--- a/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.tests/META-INF/MANIFEST.MF
@@ -1,26 +1,23 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- org.junit;bundle-version="4.11.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.emf.ecore;bundle-version="2.11.0",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.types.core;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.7.0",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.profile.types.generator;bundle-version="[2.0.0,3.0.0)",
- com.google.inject;bundle-version="3.0.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.8.0",
- org.eclipse.papyrus.uml.diagram.usecase;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.types.core;bundle-version="[4.0.0,5.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.types.core;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.usecase;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.profile.types.generator;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.service.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.types.core;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.xbase.lib;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.profile.types.generator.tests
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.tests/pom.xml b/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.tests/pom.xml
index e73eb4ab3a2..858cfb883ed 100644
--- a/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.tests/pom.xml
+++ b/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.assistants.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.assistants.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.profile.types.generator.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode.tests/META-INF/MANIFEST.MF
index 54a7fc8c88f..6045d4fe55b 100644
--- a/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode.tests/META-INF/MANIFEST.MF
@@ -1,27 +1,20 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit;bundle-version="4.10.0",
- org.eclipse.emf.ecore;bundle-version="2.10.0",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.core.resources;bundle-version="3.8.100",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.ui.ide;bundle-version="3.9.0",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.pde;bundle-version="3.8.100",
- org.eclipse.papyrus.uml.decoratormodel;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.gmf.runtime.emf.commands.core;bundle-version="1.7.0",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.core.expressions;bundle-version="3.4.600",
- org.eclipse.papyrus.infra.services.controlmode;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.decoratormodel.controlmode;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.controlmode;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.decoratormodel;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.decoratormodel.controlmode;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.decoratormodel.controlmode.tests
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode.tests/pom.xml b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode.tests/pom.xml
index 9ed34575c2a..f2d30285194 100644
--- a/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode.tests/pom.xml
+++ b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.decoratormodel.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.decoratormodel.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.decoratormodel.controlmode.tests</artifactId>
- <version>1.3.100-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/META-INF/MANIFEST.MF
index c283041f2b1..0fa85aca5b7 100644
--- a/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/META-INF/MANIFEST.MF
@@ -1,29 +1,26 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit;bundle-version="4.10.0",
- org.eclipse.emf.ecore;bundle-version="2.10.0",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.core.resources;bundle-version="3.8.100",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.ui.ide;bundle-version="3.9.0",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.pde;bundle-version="3.8.100",
- org.eclipse.papyrus.uml.decoratormodel;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.gmf.runtime.emf.commands.core;bundle-version="1.7.0",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.core.expressions;bundle-version="3.4.600",
- org.eclipse.papyrus.uml.modelrepair;bundle-version="[2.0.0,3.0.0)"
+Require-Bundle: org.eclipse.core.expressions;bundle-version="[3.6.0,4.0.0)",
+ org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.decoratormodel;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.modelrepair;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)",
+ org.eclipse.papyrus.uml.dynamic.profile.tests;bundle-version="[2.0.0,3.0.0)"
Export-Package: org.eclipse.papyrus.uml.decoratormodel.helper.tests,
org.eclipse.papyrus.uml.decoratormodel.internal.expressions.tests,
org.eclipse.papyrus.uml.decoratormodel.internal.resource.tests,
org.eclipse.papyrus.uml.decoratormodel.tests
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/pom.xml b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/pom.xml
index e885d5ec1fc..7c12a11fc83 100644
--- a/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/pom.xml
+++ b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.decoratormodel.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.decoratormodel.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.decoratormodel.tests</artifactId>
- <version>1.3.100-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/src/org/eclipse/papyrus/uml/decoratormodel/helper/tests/Activator.java b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/src/org/eclipse/papyrus/uml/decoratormodel/helper/tests/Activator.java
new file mode 100644
index 00000000000..10b84a7d24f
--- /dev/null
+++ b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/src/org/eclipse/papyrus/uml/decoratormodel/helper/tests/Activator.java
@@ -0,0 +1,68 @@
+/*****************************************************************************
+ * Copyright (c) 2020 CEA LIST.
+ *
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License 2.0
+ * which accompanies this distribution, and is available at
+ * https://www.eclipse.org/legal/epl-2.0/
+ *
+ * SPDX-License-Identifier: EPL-2.0
+ *
+ * Contributors:
+ * Patrick Tessier (CEA LIST) - Initial API and implementation
+ /*****************************************************************************/
+package org.eclipse.papyrus.uml.decoratormodel.helper.tests;
+
+import org.eclipse.ui.plugin.AbstractUIPlugin;
+import org.osgi.framework.BundleContext;
+
+/**
+ * The activator class controls the plug-in life cycle
+ */
+public class Activator extends AbstractUIPlugin {
+
+ // The plug-in ID
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.uml.decoratormodel.tests"; //$NON-NLS-1$
+
+ // The shared instance
+ private static Activator plugin;
+
+ /**
+ * The constructor
+ */
+ public Activator() {
+ }
+
+ /*
+ * (non-Javadoc)
+ *
+ * @see org.eclipse.ui.plugin.AbstractUIPlugin#start(org.osgi.framework.BundleContext)
+ */
+ @Override
+ public void start(BundleContext context) throws Exception {
+ super.start(context);
+ plugin = this;
+ org.eclipse.papyrus.uml.dynamic.profile.tests.Activator.getDefault();// I add this reference to explicit dependencies between models
+ }
+
+ /*
+ * (non-Javadoc)
+ *
+ * @see org.eclipse.ui.plugin.AbstractUIPlugin#stop(org.osgi.framework.BundleContext)
+ */
+ @Override
+ public void stop(BundleContext context) throws Exception {
+ plugin = null;
+ super.stop(context);
+ }
+
+ /**
+ * Returns the shared instance
+ *
+ * @return the shared instance
+ */
+ public static Activator getDefault() {
+ return plugin;
+ }
+}
diff --git a/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/src/org/eclipse/papyrus/uml/decoratormodel/internal/resource/tests/DecoratorModelIndexTest.java b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/src/org/eclipse/papyrus/uml/decoratormodel/internal/resource/tests/DecoratorModelIndexTest.java
index 356d47ff84c..f6ed61502da 100644
--- a/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/src/org/eclipse/papyrus/uml/decoratormodel/internal/resource/tests/DecoratorModelIndexTest.java
+++ b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/src/org/eclipse/papyrus/uml/decoratormodel/internal/resource/tests/DecoratorModelIndexTest.java
@@ -1,6 +1,6 @@
/*****************************************************************************
* Copyright (c) 2014, 2017 Christian W. Damus and others.
- *
+ *
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License 2.0
* which accompanies this distribution, and is available at
@@ -10,7 +10,7 @@
*
* Contributors:
* Christian W. Damus - Initial API and implementation
- *
+ *
*****************************************************************************/
package org.eclipse.papyrus.uml.decoratormodel.internal.resource.tests;
@@ -37,6 +37,7 @@ import org.eclipse.papyrus.uml.decoratormodel.internal.resource.DecoratorModelIn
import org.eclipse.papyrus.uml.decoratormodel.internal.resource.IDecoratorModelIndexListener;
import org.eclipse.papyrus.uml.decoratormodel.tests.AbstractProfileExternalizationTest;
import org.eclipse.uml2.uml.Package;
+import org.junit.Ignore;
import org.junit.Rule;
import org.junit.Test;
@@ -185,6 +186,7 @@ public class DecoratorModelIndexTest extends AbstractProfileExternalizationTest
}
@Test
+ @Ignore("time out")
public void decoratorModelsForPackage_none() throws CoreException {
Set<URI> decorators = fixture.getDecoratorModelsForPackage(EcoreUtil.getURI(getPackage1()));
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity.tests/META-INF/MANIFEST.MF
index 108b63ecef1..ca892ef7399 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity.tests/META-INF/MANIFEST.MF
@@ -1,32 +1,30 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,3.0.0)",
- org.eclipse.papyrus.uml.diagram.activity;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.uml2.uml.editor;bundle-version="[5.2.0,6.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.xtend.lib;bundle-version="2.8.1",
- org.eclipse.papyrus.uml.types.core;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.uml.diagram.activity;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.types.core;bundle-version="[4.0.0,5.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.validation.ocl;bundle-version="[1.4.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.tooling.runtime;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.types.core;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.activity;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.service.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.types.core;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.activity.tests,
org.eclipse.papyrus.uml.diagram.activity.tests.canonical;x-friends:="org.eclipse.papyrus.uml.diagram.interactionoverview.tests"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity.tests/pom.xml
index 20d91bb8a2f..885aa40df70 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity.tests/pom.xml
@@ -1,19 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.activity.tests</artifactId>
- <version>1.2.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-
- <properties>
- <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.activity.tests.generation.ActivityDiagramGenerateTestsWorkflow</generator.workflow.main.class>
- </properties>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.activity.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+
+ <properties>
+ <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.activity.tests.generation.ActivityDiagramGenerateTestsWorkflow</generator.workflow.main.class>
+ </properties>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/META-INF/MANIFEST.MF
index cd239f4cef2..6fb10afaeac 100755
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/META-INF/MANIFEST.MF
@@ -1,36 +1,31 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.ui.ide;bundle-version="3.10.0",
- org.eclipse.emf.common.ui;bundle-version="2.9.0",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.services.openelement;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.core.expressions,
- org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.xtend.lib;bundle-version="2.8.3",
- org.eclipse.xtext.xbase.lib;bundle-version="2.8.3",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.types.core;bundle-version="[4.0.0,5.0.0)"
+Require-Bundle: org.eclipse.core.expressions;bundle-version="[3.6.0,4.0.0)",
+ org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.tooling.runtime;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.openelement;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.types.core;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.service.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.clazz.test,
org.eclipse.papyrus.uml.diagram.clazz.test.canonical,
org.eclipse.papyrus.uml.diagram.clazz.test.copyPaste,
@@ -41,7 +36,7 @@ Export-Package: org.eclipse.papyrus.uml.diagram.clazz.test,
org.eclipse.papyrus.uml.diagram.clazz.test.tests
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/pom.xml
index f416a31c75b..b6964cfc875 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/pom.xml
@@ -1,16 +1,19 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.clazz.tests</artifactId>
- <version>1.3.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-
- <properties>
- <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.clazz.tests.generation.ClassDiagramGenerateTestsWorkflow</generator.workflow.main.class>
- </properties>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.clazz.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+
+ <properties>
+ <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.clazz.tests.generation.ClassDiagramGenerateTestsWorkflow</generator.workflow.main.class>
+ </properties>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/test/org/eclipse/papyrus/uml/diagram/clazz/test/canonical/TestClassDiagramAssociationClass.java b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/test/org/eclipse/papyrus/uml/diagram/clazz/test/canonical/TestClassDiagramAssociationClass.java
index 08ec5d3d34b..9dcd7d127f3 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/test/org/eclipse/papyrus/uml/diagram/clazz/test/canonical/TestClassDiagramAssociationClass.java
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/test/org/eclipse/papyrus/uml/diagram/clazz/test/canonical/TestClassDiagramAssociationClass.java
@@ -1,3 +1,18 @@
+/*****************************************************************************
+ * Copyright (c) 2015 CEA LIST and others.
+ *
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License 2.0
+ * which accompanies this distribution, and is available at
+ * https://www.eclipse.org/legal/epl-2.0/
+ *
+ * SPDX-License-Identifier: EPL-2.0
+ *
+ * Contributors:
+ * A. Shatilov (Montages) ashatilov <shatilov@montages.com - Initial API and implementation
+ *
+ *****************************************************************************/
package org.eclipse.papyrus.uml.diagram.clazz.test.canonical;
import org.eclipse.gmf.runtime.emf.type.core.IElementType;
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.tests/META-INF/MANIFEST.MF
index 7469e4e74ca..0d6153583d7 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.tests/META-INF/MANIFEST.MF
@@ -1,39 +1,40 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit,
- org.eclipse.emf.transaction,
- org.eclipse.ui.ide,
- org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.notation;bundle-version="[1.10.0,2.0.0)",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.css;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.canonical.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.css.model;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.css.properties;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.dynamic.profile.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.emf.gmf;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.types.core;bundle-version="[4.0.0,5.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.codegen;bundle-version="[2.11.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.canonical;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.canonical.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.css;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.css.model;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.menu;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.tools;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.widgets;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.types.core;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.tooling.runtime;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.dynamic.profile.tests;bundle-version="[2.0.0,3.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.common.tests,
org.eclipse.papyrus.uml.diagram.common.tests.css,
org.eclipse.papyrus.uml.diagram.common.tests.parser,
org.eclipse.papyrus.uml.diagram.common.tests.tests
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %Bundle-Name
Bundle-Activator: org.eclipse.papyrus.uml.diagram.common.tests.Activator
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.tests/pom.xml
index 9166d7c3f6d..40f04e551ac 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.common.tests</artifactId>
- <version>1.4.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.common.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.tests/src/org/eclipse/papyrus/uml/diagram/common/tests/Activator.java b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.tests/src/org/eclipse/papyrus/uml/diagram/common/tests/Activator.java
index 0c5867e4ebb..f190b297976 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.tests/src/org/eclipse/papyrus/uml/diagram/common/tests/Activator.java
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.tests/src/org/eclipse/papyrus/uml/diagram/common/tests/Activator.java
@@ -1,7 +1,7 @@
/*****************************************************************************
* Copyright (c) 2014 CEA LIST.
*
- *
+ *
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License 2.0
* which accompanies this distribution, and is available at
@@ -37,18 +37,20 @@ public class Activator extends AbstractUIPlugin {
/*
* (non-Javadoc)
- *
+ *
* @see org.eclipse.ui.plugin.AbstractUIPlugin#start(org.osgi.framework.BundleContext)
*/
@Override
public void start(BundleContext context) throws Exception {
super.start(context);
plugin = this;
+ // this line is added because this plugin uses the plugin org.eclipse.papyrus.uml.dynamic.profile.tests
+ org.eclipse.papyrus.uml.dynamic.profile.tests.Activator.getDefault();
}
/*
* (non-Javadoc)
- *
+ *
* @see org.eclipse.ui.plugin.AbstractUIPlugin#stop(org.osgi.framework.BundleContext)
*/
@Override
@@ -59,7 +61,7 @@ public class Activator extends AbstractUIPlugin {
/**
* Returns the shared instance
- *
+ *
* @return the shared instance
*/
public static Activator getDefault() {
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication.tests/META-INF/MANIFEST.MF
index 090646d55bf..55ae32b8244 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication.tests/META-INF/MANIFEST.MF
@@ -1,26 +1,18 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.diagram.communication;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.xtext.xbase.lib;bundle-version="2.8.1"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.communication;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.diagram.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.communication.tests,
org.eclipse.papyrus.uml.diagram.communication.tests.canonical
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication.tests/pom.xml
index 1950878f611..f3988e5d547 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication.tests/pom.xml
@@ -1,19 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.communication.tests</artifactId>
- <version>1.2.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-
- <properties>
- <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.communication.tests.generation.CommunicationDiagramGenerateTestsWorkflow</generator.workflow.main.class>
- </properties>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.communication.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+
+ <properties>
+ <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.communication.tests.generation.CommunicationDiagramGenerateTestsWorkflow</generator.workflow.main.class>
+ </properties>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component.tests/META-INF/MANIFEST.MF
index 9b2fec85680..e541a557ead 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component.tests/META-INF/MANIFEST.MF
@@ -1,27 +1,23 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.uml.diagram.component;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.xtend.lib;bundle-version="2.8.1"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.menu;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.component;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.component.test,
org.eclipse.papyrus.uml.diagram.component.test.canonical,
org.eclipse.papyrus.uml.diagram.component.test.load
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component.tests/pom.xml
index 1b24d65b25b..d26a67f259f 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component.tests/pom.xml
@@ -1,19 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.component.tests</artifactId>
- <version>1.2.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-
- <properties>
- <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.component.test.generation.ComponentDiagramGenerateTestsWorkflow</generator.workflow.main.class>
- </properties>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.component.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+
+ <properties>
+ <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.component.test.generation.ComponentDiagramGenerateTestsWorkflow</generator.workflow.main.class>
+ </properties>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite.tests/META-INF/MANIFEST.MF
index 0a2fd1eab99..026347d4e93 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite.tests/META-INF/MANIFEST.MF
@@ -1,24 +1,23 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.composite;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.xtend.lib;bundle-version="2.8.1",
- org.eclipse.core.expressions,
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.core.expressions;bundle-version="[3.6.0,4.0.0)",
+ org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.internationalization.common;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.composite;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.composite.test,
org.eclipse.papyrus.uml.diagram.composite.test.canonical,
org.eclipse.papyrus.uml.diagram.composite.test.model,
@@ -26,7 +25,7 @@ Export-Package: org.eclipse.papyrus.uml.diagram.composite.test,
org.eclipse.papyrus.uml.diagram.composite.tests.copyPaste
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite.tests/pom.xml
index 48f2e8c1754..eaad1088ebf 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite.tests/pom.xml
@@ -1,16 +1,19 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.composite.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-
- <properties>
- <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.composite.test.generation.CompositeDiagramGenerateTestsWorkflow</generator.workflow.main.class>
- </properties>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.composite.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+
+ <properties>
+ <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.composite.test.generation.CompositeDiagramGenerateTestsWorkflow</generator.workflow.main.class>
+ </properties>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment.tests/META-INF/MANIFEST.MF
index e312e9afdfe..0bef5a82878 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment.tests/META-INF/MANIFEST.MF
@@ -1,27 +1,20 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.uml.diagram.deployment;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.xtend.lib;bundle-version="2.8.1"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.deployment;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.deployment.test,
org.eclipse.papyrus.uml.diagram.deployment.test.canonical,
org.eclipse.papyrus.uml.diagram.deployment.test.load
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment.tests/pom.xml
index 11db6693319..4baddda4056 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment.tests/pom.xml
@@ -1,19 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.deployment.tests</artifactId>
- <version>1.2.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-
- <properties>
- <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.deployment.test.generation.DeploymentDiagramGenerateTestsWorkflow</generator.workflow.main.class>
- </properties>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.deployment.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+
+ <properties>
+ <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.deployment.test.generation.DeploymentDiagramGenerateTestsWorkflow</generator.workflow.main.class>
+ </properties>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd.tests/META-INF/MANIFEST.MF
index 7286ac37462..a6911ddaa2e 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd.tests/META-INF/MANIFEST.MF
@@ -1,31 +1,23 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.ui,
- org.eclipse.emf.ecore;bundle-version="2.8.0",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.6.0",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.dnd;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.dnd;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.ui.ide;bundle-version="3.8.0",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.dnd;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.widgets;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.dnd;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.uml2.uml.edit;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.dnd.tests.tests
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: DND Tests
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.diagram.dnd.tests.Activator
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd.tests/pom.xml
index 3755db19e93..5972819f55c 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.dnd.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.dnd.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview.tests/META-INF/MANIFEST.MF
index b9ca1daae77..93d62f98bc2 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview.tests/META-INF/MANIFEST.MF
@@ -1,24 +1,26 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.uml.diagram.interactionoverview;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.activity;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.timing;bundle-version="[1.3.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.gmf.runtime.diagram.ui,
- org.eclipse.gmf.runtime.diagram.ui,
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.diagram.activity.tests;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.validation.ocl;bundle-version="[1.4.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.tooling.runtime;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.activity;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.activity.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.interactionoverview;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.timing;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.interactionoverview.tests
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: IODiagram Tests
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.diagram.interactionoverview.tests.Activator
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview.tests/pom.xml
index ffc5e147617..ae97a06dc75 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.interactionoverview.tests</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.interactionoverview.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile.tests/META-INF/MANIFEST.MF
index 13795215e90..d1efb7ca015 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile.tests/META-INF/MANIFEST.MF
@@ -1,26 +1,25 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.diagram.profile;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.xtend.lib;bundle-version="2.8.1",
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.profile;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.service.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.profile.tests,
org.eclipse.papyrus.uml.diagram.profile.tests.canonical
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: Profile Diagram Tests
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.diagram.profile.tests.Activator
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile.tests/pom.xml
index 8eabc0f1708..9369840e5b9 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile.tests/pom.xml
@@ -1,16 +1,19 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.profile.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-
- <properties>
- <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.profile.tests.generation.ProfileDiagramGenerateTestsWorkflow</generator.workflow.main.class>
- </properties>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.profile.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+
+ <properties>
+ <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.profile.tests.generation.ProfileDiagramGenerateTestsWorkflow</generator.workflow.main.class>
+ </properties>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.properties.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.properties.tests/META-INF/MANIFEST.MF
index 1c9c641507b..e3f7084c7e7 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.properties.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.properties.tests/META-INF/MANIFEST.MF
@@ -1,19 +1,27 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0";visibility:=reexport,
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.properties;bundle-version="[3.1.100,4.0.0)",
- org.eclipse.papyrus.infra.properties.ui;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.1.0,5.0.0)",
- org.eclipse.papyrus.uml.properties.tests;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.properties;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.uml.diagram.activity;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.sequence;bundle-version="[5.2.0,6.0.0)",
- org.eclipse.papyrus.infra.internationalization.utils;bundle-version="[1.0.100,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.validation.ocl;bundle-version="[1.4.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.tests;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.properties;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.internationalization.utils;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.properties;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.properties.ui;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.activity;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.properties.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.properties.databinding.tests,
org.eclipse.papyrus.uml.diagram.properties.tests
Bundle-Vendor: %providerName
-Bundle-Version: 1.0.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.properties.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.properties.tests/pom.xml
index b405bd2f66c..0b73d45b09d 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.properties.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.properties.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.properties.tests</artifactId>
- <version>1.0.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+ <artifactId>org.eclipse.papyrus.uml.diagram.properties.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence.tests/META-INF/MANIFEST.MF
index 37dd517d3d1..c212c636454 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence.tests/META-INF/MANIFEST.MF
@@ -1,33 +1,34 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- org.junit;bundle-version="4.11.0",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui.render;bundle-version="1.7.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.sequence;bundle-version="[5.0.0,6.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.emf.appearance;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.2.0,3.0.0)",
- org.eclipse.papyrus.infra.properties.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.xtend.lib;bundle-version="2.8.1",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.preferences,
- org.eclipse.ui.workbench,
- org.eclipse.papyrus.uml.services.decoration;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.oclconstraintevaluation;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.types.core;bundle-version="[4.0.0,5.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.render;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.menu;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.preferences;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.tooling.runtime;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.internationalization.common;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.types.core;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.sequence;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.uml.diagram.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.sequence.tests
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.diagram.sequence.tests.Activator
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence.tests/pom.xml
index 5caeff23c65..1f3558441a8 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence.tests/pom.xml
@@ -1,16 +1,19 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.sequence.tests</artifactId>
- <version>1.3.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-
- <properties>
- <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.sequence.tests.generation.SequenceDiagramGenerateTestsWorkflow</generator.workflow.main.class>
- </properties>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.sequence.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+
+ <properties>
+ <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.sequence.tests.generation.SequenceDiagramGenerateTestsWorkflow</generator.workflow.main.class>
+ </properties>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine.tests/META-INF/MANIFEST.MF
index a5dd9f9818b..7dc151e8302 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine.tests/META-INF/MANIFEST.MF
@@ -1,27 +1,24 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.diagram.statemachine;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.xtend.lib;bundle-version="2.8.1",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.validation.ocl;bundle-version="[1.4.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.tooling.runtime;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.statemachine;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.statemachine.tests,
org.eclipse.papyrus.uml.diagram.statemachine.tests.canonical
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine.tests/pom.xml
index 9a7cbe14f1c..ca6deeace0b 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine.tests/pom.xml
@@ -1,16 +1,19 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.statemachine.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-
- <properties>
- <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.statemachine.tests.generation.StateMachineDiagramGenerateTestsWorkflow</generator.workflow.main.class>
- </properties>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.statemachine.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+
+ <properties>
+ <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.statemachine.tests.generation.StateMachineDiagramGenerateTestsWorkflow</generator.workflow.main.class>
+ </properties>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests/META-INF/MANIFEST.MF
index 7a85f6811c0..c7f5408a332 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests/META-INF/MANIFEST.MF
@@ -1,32 +1,30 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.extensionpoints;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.ui.ide;bundle-version="3.8.0",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.stereotype.edition;bundle-version="[2.0.0,3.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.uml.appearance;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.3.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.tooling.runtime;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.stereotype.edition;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.extensionpoints;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.stereotypeproperty
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests/pom.xml
index 1469a410a2b..cf83b7657ad 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.suite.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.suite.tests/META-INF/MANIFEST.MF
index 64429fce0dd..a9a9655bb02 100755
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.suite.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.suite.tests/META-INF/MANIFEST.MF
@@ -1,33 +1,28 @@
Manifest-Version: 1.0
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 0.0.1.qualifier
+Bundle-Version: 1.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.diagram.suite.tests.Activator
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.suite.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.diagram.common.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.clazz.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.activity.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.deployment.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.component.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.timing.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.usecase.tests;bundle-version="[4.0.100,5.0.0)",
- org.eclipse.papyrus.uml.diagram.composite.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.statemachine.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.communication.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.profile.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.sequence.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.interactionoverview.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.canonical.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.dynamic.profile.tests;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.activity.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.clazz.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.common.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.communication.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.component.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.composite.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.deployment.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.interactionoverview.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.profile.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.sequence.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.statemachine.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.timing.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.usecase.tests;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.suite.tests
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.suite.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.suite.tests/pom.xml
index 264bf982f8a..ea9d90df70c 100755
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.suite.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.suite.tests/pom.xml
@@ -1,8 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus</groupId>
@@ -12,7 +11,7 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.diagram.suite.tests</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <version>1.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
<plugins>
@@ -55,4 +54,4 @@
</plugins>
</build>
-</project>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.tests/META-INF/MANIFEST.MF
index 21ac4d59e39..83717dc5492 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.tests/META-INF/MANIFEST.MF
@@ -1,44 +1,38 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.ui.ide;bundle-version="3.8.0",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.gmf.runtime.common.core,
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.diagram.profile;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.emf.appearance;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.xtend.lib,
- org.eclipse.xtend.lib.macro,
- org.eclipse.xtext.xbase.lib,
- org.eclipse.papyrus.infra.gmfdiag.css;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.css.model;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.css.properties;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.core.expressions;bundle-version="3.5.0",
- org.eclipse.papyrus.infra.gmfdiag.dnd;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.preferences;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.service.types.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.architecture;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.wizards;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.architecture;bundle-version="[2.0.0,3.0.0)"
+Require-Bundle: org.eclipse.core.expressions;bundle-version="[3.6.0,4.0.0)",
+ org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.architecture;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.appearance;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.css;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.css.model;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.css.properties;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.dnd;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.preferences;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.tooling.runtime;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.internationalization.common;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.architecture;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.profile;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.service.types.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtend.lib;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.tests.appearance,
org.eclipse.papyrus.uml.diagram.tests.canonical,
org.eclipse.papyrus.uml.diagram.tests.createFromPalette,
@@ -49,7 +43,7 @@ Export-Package: org.eclipse.papyrus.uml.diagram.tests.appearance,
org.eclipse.papyrus.uml.diagram.tests.synchronization
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.tests/pom.xml
index d5346e865b1..246fe0a9dbb 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests</artifactId>
- <version>1.3.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing.tests/META-INF/MANIFEST.MF
index 711558b1138..bc092067fd3 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing.tests/META-INF/MANIFEST.MF
@@ -1,30 +1,28 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.diagram.timing;bundle-version="[1.3.0,2.0.0)",
- org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="1.4.1",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.4.0",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.6.0",
- org.eclipse.ui.ide;bundle-version="3.8.0",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.xtend.lib;bundle-version="2.8.1",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.editor;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.tooling.runtime;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.internationalization.common;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.timing;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.timing.tests,
org.eclipse.papyrus.uml.diagram.timing.tests.canonical,
org.eclipse.papyrus.uml.diagram.timing.tests.generic
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: Papyrus Timing Diagram Tests
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.diagram.timing.tests.Activator
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing.tests/pom.xml
index b331afdb6a4..9bc7cb5099f 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing.tests/pom.xml
@@ -1,19 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.timing.tests</artifactId>
- <version>1.2.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-
- <properties>
- <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.timing.tests.generation.TimingDiagramGenerateTestsWorkflow</generator.workflow.main.class>
- </properties>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.timing.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+
+ <properties>
+ <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.timing.tests.generation.TimingDiagramGenerateTestsWorkflow</generator.workflow.main.class>
+ </properties>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase.tests/META-INF/MANIFEST.MF
index ee44040294e..0e5a6d6a8a8 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase.tests/META-INF/MANIFEST.MF
@@ -1,32 +1,27 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.usecase;bundle-version="[4.0.100,5.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.xtend.lib;bundle-version="2.8.1",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.2.0,3.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.dnd
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.dnd;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.diagram.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.usecase;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.service.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml.edit;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtend.lib;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.usecase.tests,
org.eclipse.papyrus.uml.diagram.usecase.tests.canonical
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 4.0.200.qualifier
+Bundle-Version: 5.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase.tests/pom.xml
index 3fa58f696a0..0b69a855d46 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase.tests/pom.xml
@@ -1,16 +1,19 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.usecase.tests</artifactId>
- <version>4.0.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-
- <properties>
- <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.usecase.tests.generation.UseCaseDiagramGenerateTestsWorkflow</generator.workflow.main.class>
- </properties>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.usecase.tests</artifactId>
+ <version>5.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+
+ <properties>
+ <generator.workflow.main.class>org.eclipse.papyrus.uml.diagram.usecase.tests.generation.UseCaseDiagramGenerateTestsWorkflow</generator.workflow.main.class>
+ </properties>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/META-INF/MANIFEST.MF
index 14b148a7a4e..f8d6468981f 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/META-INF/MANIFEST.MF
@@ -1,21 +1,17 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.uml.diagram.wizards;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.diagram.profile;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.ui.workbench;bundle-version="3.103.1",
- org.eclipse.ui.ide;bundle-version="3.8.1",
- org.eclipse.jface;bundle-version="3.8.101",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.core.resources,
- org.eclipse.core.runtime;bundle-version="3.10.0",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.junit;bundle-version="4.11.0",
- org.eclipse.papyrus.uml.architecture;bundle-version="[1.0.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.architecture;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.wizards;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.diagram.wizards
Bundle-Vendor: %providerName
-Bundle-Version: 1.3.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/pom.xml b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/pom.xml
index 411df3890b5..8992ecd03be 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/pom.xml
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.diagram.wizards.tests</artifactId>
- <version>1.3.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.tests.releng</artifactId>
+ <version>1.2.0-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.diagram.wizards.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/expressions/org.eclipse.papyrus.uml.expressions.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/expressions/org.eclipse.papyrus.uml.expressions.tests/META-INF/MANIFEST.MF
index 666d07b8897..b1363c2085e 100755
--- a/tests/junit/plugins/uml/expressions/org.eclipse.papyrus.uml.expressions.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/expressions/org.eclipse.papyrus.uml.expressions.tests/META-INF/MANIFEST.MF
@@ -2,16 +2,18 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.papyrus.uml.expressions.tests
-Bundle-Version: 1.1.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Vendor: %Bundle-Vendor
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.emf.expressions;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.uml.expressions;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.editor.integration.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.junit;bundle-version="[4.12.0,5.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.emf.expressions;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.expressions;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.expressions.tests
Bundle-Description: Tests for the UML Expressions Framework.
Automatic-Module-Name: org.eclipse.papyrus.uml.expressions.tests
diff --git a/tests/junit/plugins/uml/expressions/org.eclipse.papyrus.uml.expressions.tests/pom.xml b/tests/junit/plugins/uml/expressions/org.eclipse.papyrus.uml.expressions.tests/pom.xml
index 8aa8d4f2deb..7ed84185ea1 100755
--- a/tests/junit/plugins/uml/expressions/org.eclipse.papyrus.uml.expressions.tests/pom.xml
+++ b/tests/junit/plugins/uml/expressions/org.eclipse.papyrus.uml.expressions.tests/pom.xml
@@ -1,4 +1,7 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus.tests</groupId>
@@ -6,7 +9,7 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.expressions.tests</artifactId>
- <version>1.1.100-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<description>Tests for the UML Expressions Framework.</description>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.controlmode.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.controlmode.tests/META-INF/MANIFEST.MF
index 81f08deed18..760878475af 100644
--- a/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.controlmode.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.controlmode.tests/META-INF/MANIFEST.MF
@@ -2,26 +2,30 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.papyrus.uml.internationalization.controlmode.tests;singleton:=true
-Bundle-Version: 1.1.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.papyrus.uml.internationalization.controlmode.tests,
org.eclipse.papyrus.uml.internationalization.controlmode.tests.tests
-Require-Bundle: org.junit;bundle-version="[4.11.0,5.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.ui.workbench;bundle-version="[3.108.0,4.0.0)",
- org.eclipse.papyrus.infra.emf.tests;bundle-version="[1.4.0,2.0.0)",
- org.eclipse.papyrus.uml.internationalization.tests;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.infra.services.controlmode;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.emf.gmf;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.internationalization.common;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.internationalization.common;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.services.controlmode;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.internationalization.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.ui.navigator;bundle-version="[3.9.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.papyrus.uml.internationalization.controlmode.tests.Activator
Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)"
diff --git a/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.controlmode.tests/pom.xml b/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.controlmode.tests/pom.xml
index 3fc9ec315ea..f23eae9a53f 100644
--- a/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.controlmode.tests/pom.xml
+++ b/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.controlmode.tests/pom.xml
@@ -1,4 +1,7 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus.tests</groupId>
@@ -7,6 +10,6 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.internationalization.controlmode.tests</artifactId>
- <version>1.1.100-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.tests/META-INF/MANIFEST.MF
index 239c2bdfd0f..5d1b41ae08d 100644
--- a/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.tests/META-INF/MANIFEST.MF
@@ -2,26 +2,26 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.papyrus.uml.internationalization.tests;singleton:=true
-Bundle-Version: 1.100.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.papyrus.uml.internationalization.tests,
org.eclipse.papyrus.uml.internationalization.tests.tests
-Require-Bundle: org.junit;bundle-version="[4.11.0,5.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.internationalization;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.uml.internationalization.utils;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.ui.workbench;bundle-version="[3.108.0,4.0.0)",
- org.eclipse.papyrus.infra.emf.tests;bundle-version="[1.4.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.internationalization.common;bundle-version="[1.100.0,2.0.0)",
- org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.internationalization.edit;bundle-version="[1.100.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.internationalization.common;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.internationalization.edit;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.ui.navigator;bundle-version="[3.9.0,4.0.0)",
+ org.eclipse.uml2.uml.edit;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.papyrus.uml.internationalization.tests.Activator
Automatic-Module-Name: org.eclipse.papyrus.uml.internationalization.tests
diff --git a/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.tests/pom.xml b/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.tests/pom.xml
index 29fe9eb1c81..fc1ddd07617 100644
--- a/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.tests/pom.xml
+++ b/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.tests/pom.xml
@@ -1,4 +1,7 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus.tests</groupId>
@@ -7,6 +10,6 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.internationalization.tests</artifactId>
- <version>1.100.100-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.tests/META-INF/MANIFEST.MF
index 2905e4fdf24..7407e36024d 100644
--- a/tests/junit/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.tests/META-INF/MANIFEST.MF
@@ -1,31 +1,29 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.views.modelexplorer.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.emf.ecore,
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.ui.navigator,
- org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.200",
- org.eclipse.ui.ide;bundle-version="3.8.0",
- org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.emf.transaction;bundle-version="1.4.0",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.emf.facet.custom.metamodel;bundle-version="[1.3.0,2.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.nattable.model;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.emf.facet.custom.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.emf.facet.custom.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.emf.facet.custom.metamodel;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.emf.facet.efacet.metamodel;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.tests;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.views.modelexplorer.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.ui.ide;bundle-version="[3.17.0,4.0.0)",
+ org.eclipse.ui.navigator;bundle-version="[3.9.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.modelexplorer.tests,
org.eclipse.papyrus.uml.modelexplorer.tests.paste
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.tests/pom.xml b/tests/junit/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.tests/pom.xml
index 58ea5d77cd1..b7732366e9c 100644
--- a/tests/junit/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.tests/pom.xml
+++ b/tests/junit/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.modelexplorer.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.modelexplorer.tests</artifactId>
- <version>1.3.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.modelexplorer.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.modelexplorer.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config.tests/META-INF/MANIFEST.MF
index 46500a08286..3a37341a781 100644
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config.tests/META-INF/MANIFEST.MF
@@ -1,41 +1,40 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.nattable;bundle-version="[6.0.0,7.0.0)",
- org.eclipse.papyrus.uml.nattable.clazz.config;bundle-version="[5.0.0,6.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.junit;bundle-version="4.11.0",
- org.eclipse.papyrus.editor.integration.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.nattable.model;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.emf.transaction;bundle-version="1.8.0",
- org.eclipse.papyrus.infra.nattable.common;bundle-version="[5.0.0,6.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- ca.odell.glazedlists;bundle-version="1.9.0",
+Require-Bundle: ca.odell.glazedlists;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.5.0,2.0.0)",
- org.eclipse.papyrus.infra.tools;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.ui.navigator,
- org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.ui.ide,
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.emf.facet.custom.metamodel;bundle-version="[1.3.0,2.0.0)",
- org.eclipse.papyrus.infra.services.validation;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.swt,
- org.eclipse.papyrus.uml.dynamic.profile.tests;bundle-version="[1.2.0,2.0.0)"
+ org.eclipse.papyrus.editor.integration.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.emf.facet.custom.metamodel;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.nattable;bundle-version="[7.0.0,8.0.0)",
+ org.eclipse.papyrus.infra.nattable.common;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.validation;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.tools;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.widgets;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.nattable.clazz.config;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.uml.service.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.ui.navigator;bundle-version="[3.9.0,4.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.nattable.clazz.config.tests,
org.eclipse.papyrus.uml.nattable.clazz.config.tests.tests
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.300.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %Bundle-Name
Bundle-Activator: org.eclipse.papyrus.uml.nattable.clazz.config.tests.Activator
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config.tests/pom.xml b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config.tests/pom.xml
index 90e32ba784b..7bb18b5f6fc 100644
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config.tests/pom.xml
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config.tests/pom.xml
@@ -1,4 +1,7 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus.tests</groupId>
@@ -7,6 +10,6 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.nattable.clazz.config.tests</artifactId>
- <version>1.2.300-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/META-INF/MANIFEST.MF
index 66830c9757c..f7f0694ce4e 100755
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/META-INF/MANIFEST.MF
@@ -1,35 +1,33 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.11.0",
- org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.emf.ecore,
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.diagram.ui,
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.5.0,2.0.0)",
- org.eclipse.papyrus.infra.nattable;bundle-version="[6.0.0,7.0.0)",
- org.eclipse.papyrus.infra.nattable.model;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.emf.common,
- org.eclipse.papyrus.infra.properties;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor.integration.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.nattable.common;bundle-version="[5.0.0,6.0.0)",
- org.eclipse.papyrus.uml.nattable.generic.config;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.nattable;bundle-version="[5.0.0,6.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.dynamic.profile.tests;bundle-version="[1.2.0,2.0.0)"
+ org.eclipse.papyrus.editor.integration.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.nattable;bundle-version="[7.0.0,8.0.0)",
+ org.eclipse.papyrus.infra.nattable.common;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.tools;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.widgets;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.nattable;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.uml.nattable.generic.config;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)",
+ org.eclipse.papyrus.uml.dynamic.profile.tests;bundle-version="[2.0.0,3.0.0)"
Export-Package: org.eclipse.papyrus.uml.nattable.generic.tests.tests
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.300.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/pom.xml b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/pom.xml
index 1f0fccb2061..3af4ab5625f 100644
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/pom.xml
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/pom.xml
@@ -1,4 +1,7 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus.tests</groupId>
@@ -7,6 +10,6 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.nattable.generic.tests</artifactId>
- <version>1.2.300-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/src/org/eclipse/papyrus/uml/nattable/generic/tests/Activator.java b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/src/org/eclipse/papyrus/uml/nattable/generic/tests/Activator.java
index f89b66f7f53..a18b5b4bcb0 100755
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/src/org/eclipse/papyrus/uml/nattable/generic/tests/Activator.java
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/src/org/eclipse/papyrus/uml/nattable/generic/tests/Activator.java
@@ -1,7 +1,7 @@
/*****************************************************************************
* Copyright (c) 2014 CEA LIST.
*
- *
+ *
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License 2.0
* which accompanies this distribution, and is available at
@@ -30,7 +30,7 @@ public class Activator extends AbstractUIPlugin {
// The shared instance
private static Activator plugin;
-
+
public static LogHelper log;
/**
@@ -41,6 +41,7 @@ public class Activator extends AbstractUIPlugin {
/*
* (non-Javadoc)
+ *
* @see org.eclipse.ui.plugin.AbstractUIPlugin#start(org.osgi.framework.BundleContext)
*/
@Override
@@ -48,10 +49,12 @@ public class Activator extends AbstractUIPlugin {
super.start(context);
plugin = this;
log = new LogHelper(this);
+ org.eclipse.papyrus.uml.dynamic.profile.tests.Activator.getDefault();
}
/*
* (non-Javadoc)
+ *
* @see org.eclipse.ui.plugin.AbstractUIPlugin#stop(org.osgi.framework.BundleContext)
*/
@Override
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.matrix.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.matrix.tests/META-INF/MANIFEST.MF
index c7635b8109b..e52140951af 100755
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.matrix.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.matrix.tests/META-INF/MANIFEST.MF
@@ -2,19 +2,33 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.papyrus.uml.nattable.matrix.tests
-Bundle-Version: 1.0.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Vendor: %Bundle-Vendor
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.junit;bundle-version="[4.12.0,5.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.uml.expressions;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.emf.expressions;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.gef;bundle-version="[3.11.0,4.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.emf.gmf;bundle-version="[1.2.100,2.0.0)",
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)"
+Require-Bundle: ca.odell.glazedlists,
+ org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.expressions;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.internationalization.common;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.nattable;bundle-version="[7.0.0,8.0.0)",
+ org.eclipse.papyrus.infra.nattable.common;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.tools;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.widgets;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.expressions;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.service.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-Activator: org.eclipse.papyrus.uml.nattable.matrix.tests.Activator
Export-Package: org.eclipse.papyrus.uml.nattable.matrix.tests.tests
Automatic-Module-Name: org.eclipse.papyrus.uml.nattable.matrix.tests
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.matrix.tests/pom.xml b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.matrix.tests/pom.xml
index b5c462f58e2..0bb18c61987 100755
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.matrix.tests/pom.xml
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.matrix.tests/pom.xml
@@ -1,4 +1,7 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus.tests</groupId>
@@ -7,7 +10,7 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.nattable.matrix.tests</artifactId>
- <version>1.0.200-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<description>This plugin provides the specific code used to managed UML Table Matrix</description>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display.tests/META-INF/MANIFEST.MF
index 9a1733995ea..b41e975321a 100644
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display.tests/META-INF/MANIFEST.MF
@@ -1,35 +1,26 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.11.0",
- org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.nattable.clazz.config.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.editor.integration.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.gmf.runtime.notation;bundle-version="[1.10.0,2.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gef,
- org.eclipse.emf.transaction,
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.nattable.common;bundle-version="[5.0.0,6.0.0)",
- org.eclipse.papyrus.infra.nattable;bundle-version="[6.0.0,7.0.0)",
- org.eclipse.papyrus.infra.nattable.model;bundle-version="[4.0.0,5.0.0)",
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.5.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.core.expressions,
- org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[1.2.0,2.0.0)"
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.nattable;bundle-version="[7.0.0,8.0.0)",
+ org.eclipse.papyrus.infra.nattable.common;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.nattable.stereotype.display.tests.tests
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display.tests/pom.xml b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display.tests/pom.xml
index 1fb6d7abdb3..74402089e09 100644
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display.tests/pom.xml
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.nattable.main.test</artifactId>
<version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.nattable.stereotype.display.tests</artifactId>
- <version>1.3.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/META-INF/MANIFEST.MF
index 33c84c18f42..03ebd274902 100644
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/META-INF/MANIFEST.MF
@@ -1,27 +1,34 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui;bundle-version="[3.108.0,4.0.0)",
- org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.junit;bundle-version="[4.12.0,5.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.nattable.common;bundle-version="[5.0.0,6.0.0)",
- org.eclipse.papyrus.infra.nattable;bundle-version="[6.0.0,7.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor.integration.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.nattable;bundle-version="[5.0.0,6.0.0)",
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.uml.dynamic.profile.tests;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.papyrus.editor.integration.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf.nattable;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.nattable;bundle-version="[7.0.0,8.0.0)",
+ org.eclipse.papyrus.infra.nattable.common;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.tools;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.widgets;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.nattable;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.uml.service.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)",
+ org.eclipse.papyrus.uml.dynamic.profile.tests;bundle-version="[2.0.0,3.0.0)"
Export-Package: org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests,
org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests.manager.axis,
org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests.tests
Bundle-Vendor: %providerName
-Bundle-Version: 1.0.300.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/pom.xml b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/pom.xml
index dc0f3e20034..d58473b2256 100644
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/pom.xml
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.nattable.main.test</artifactId>
<version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests</artifactId>
- <version>1.0.300-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/src/org/eclipse/papyrus/uml/nattable/stereotyped/elements/tests/Activator.java b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/src/org/eclipse/papyrus/uml/nattable/stereotyped/elements/tests/Activator.java
index c9bd2e66116..ad932fa0e63 100644
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/src/org/eclipse/papyrus/uml/nattable/stereotyped/elements/tests/Activator.java
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/src/org/eclipse/papyrus/uml/nattable/stereotyped/elements/tests/Activator.java
@@ -1,7 +1,7 @@
/*****************************************************************************
* Copyright (c) 2013 CEA LIST.
*
- *
+ *
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License 2.0
* which accompanies this distribution, and is available at
@@ -29,8 +29,9 @@ public class Activator extends AbstractUIPlugin {
// The shared instance
private static Activator plugin;
-
+
public static LogHelper log;
+
/**
* The constructor
*/
@@ -39,18 +40,23 @@ public class Activator extends AbstractUIPlugin {
/*
* (non-Javadoc)
+ *
* @see org.eclipse.ui.plugin.AbstractUIPlugin#start(org.osgi.framework.BundleContext)
*/
+ @Override
public void start(BundleContext context) throws Exception {
super.start(context);
plugin = this;
log = new LogHelper(this);
+ org.eclipse.papyrus.uml.dynamic.profile.tests.Activator.getDefault();
}
/*
* (non-Javadoc)
+ *
* @see org.eclipse.ui.plugin.AbstractUIPlugin#stop(org.osgi.framework.BundleContext)
*/
+ @Override
public void stop(BundleContext context) throws Exception {
plugin = null;
super.stop(context);
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/META-INF/MANIFEST.MF
index ce167d261ba..4fc7d82a32a 100755
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/META-INF/MANIFEST.MF
@@ -1,23 +1,20 @@
Manifest-Version: 1.0
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 0.0.1.qualifier
+Bundle-Version: 1.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.nattable.suite.tests.Activator
Bundle-SymbolicName: org.eclipse.papyrus.uml.nattable.suite.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.nattable.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.nattable.generic.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.nattable.clazz.config.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.nattable.stereotype.display.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.editor.integration.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.dynamic.profile.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.nattable.matrix.tests;bundle-version="1.0.0"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.nattable.clazz.config.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.nattable.generic.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.nattable.matrix.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.nattable.stereotype.display.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.nattable.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.nattable.suite.tests
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/pom.xml b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/pom.xml
index 06249b022f5..9a1ae6b4f46 100755
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/pom.xml
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/pom.xml
@@ -1,8 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus</groupId>
@@ -12,7 +11,7 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.nattable.suite.tests</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <version>1.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
<plugins>
@@ -55,4 +54,4 @@
</plugins>
</build>
-</project>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.tests/META-INF/MANIFEST.MF
index 84efe4e18e1..3ced129977f 100644
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.tests/META-INF/MANIFEST.MF
@@ -1,27 +1,28 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit;bundle-version="4.11.0",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.nattable;bundle-version="[6.0.0,7.0.0)",
- org.eclipse.papyrus.infra.nattable.model;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.uml.nattable;bundle-version="[5.0.0,6.0.0)",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.emf.transaction,
- org.eclipse.papyrus.infra.nattable.common;bundle-version="[5.0.0,6.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.tests;bundle-version="4.0.0",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.nattable;bundle-version="[7.0.0,8.0.0)",
+ org.eclipse.papyrus.infra.nattable.common;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.widgets;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.nattable;bundle-version="[6.0.0,7.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.nattable.tests,
org.eclipse.papyrus.uml.nattable.tests.tests
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.nattable.tests.Activator
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.tests/pom.xml b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.tests/pom.xml
index 6615856ae4f..c44d2e46ced 100644
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.tests/pom.xml
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.nattable.main.test</artifactId>
<version>1.2.0-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.nattable.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.nattable.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.architecture.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.architecture.tests/META-INF/MANIFEST.MF
index c2ce45eff1d..1603dd89322 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.architecture.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.architecture.tests/META-INF/MANIFEST.MF
@@ -1,14 +1,14 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.architecture.tests
-Bundle-Version: 1.1.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Automatic-Module-Name: org.eclipse.papyrus.uml.architecture.tests
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.junit;bundle-version="4.12.0",
- org.eclipse.emf.ecore,
- org.eclipse.papyrus.junit.framework;bundle-version="1.2.0"
+Require-Bundle: org.eclipse.emf.ecore;bundle-version="[2.22.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.architecture.tests,
org.eclipse.papyrus.uml.architecture.tests.resources
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.architecture.tests/pom.xml b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.architecture.tests/pom.xml
index d2c1d172879..a1d4610ed2c 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.architecture.tests/pom.xml
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.architecture.tests/pom.xml
@@ -1,13 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.architecture.tests</artifactId>
- <version>1.1.200-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/.classpath b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/.classpath
index 075009d7745..22f30643cba 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/.classpath
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/.classpath
@@ -1,5 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
+ <classpathentry kind="src" path="src"/>
<classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/META-INF/MANIFEST.MF
index 3215c61e791..d0b5ad55271 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/META-INF/MANIFEST.MF
@@ -2,13 +2,12 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.papyrus.uml.dynamic.profile.tests;singleton:=true
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Vendor: %Bundle-Vendor
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.emf.ecore,
- org.eclipse.papyrus.uml.extensionpoints;bundle-version="[1.2.0,2.0.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Bundle-Description: %Bundle-Description
Automatic-Module-Name: org.eclipse.papyrus.uml.dynamic.profile.tests
+Require-Bundle: org.eclipse.ui.workbench,
+ org.eclipse.core.runtime;bundle-version="3.18.0"
+Export-Package: org.eclipse.papyrus.uml.dynamic.profile.tests
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/build.properties b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/build.properties
index c5c3881f088..e95658fbdf7 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/build.properties
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/build.properties
@@ -1,3 +1,5 @@
+source.. = src/
+output.. = bin/
bin.includes = META-INF/,\
.,\
OSGI-INF/,\
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/pom.xml b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/pom.xml
index cebfcfadad6..25e5b9885d4 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/pom.xml
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.dynamic.profile.tests</artifactId>
- <version>1.2.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.dynamic.profile.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/src/org/eclipse/papyrus/uml/dynamic/profile/tests/Activator.java b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/src/org/eclipse/papyrus/uml/dynamic/profile/tests/Activator.java
new file mode 100644
index 00000000000..b29e3d51a11
--- /dev/null
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.dynamic.profile.tests/src/org/eclipse/papyrus/uml/dynamic/profile/tests/Activator.java
@@ -0,0 +1,69 @@
+/*****************************************************************************
+ * Copyright (c) 2020 CEA LIST.
+ *
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License 2.0
+ * which accompanies this distribution, and is available at
+ * https://www.eclipse.org/legal/epl-2.0/
+ *
+ * SPDX-License-Identifier: EPL-2.0
+ *
+ * Contributors:
+ * Patrick Tessier (CEA LIST) vincent.lorenzo@cea.fr - Initial API and implementation
+ *
+ *****************************************************************************/
+package org.eclipse.papyrus.uml.dynamic.profile.tests;
+
+import org.eclipse.ui.plugin.AbstractUIPlugin;
+import org.osgi.framework.BundleContext;
+
+/**
+ * The activator class controls the plug-in life cycle
+ */
+public class Activator extends AbstractUIPlugin {
+
+ // The plug-in ID
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.uml.dynamic.profile.tests"; //$NON-NLS-1$
+
+ // The shared instance
+ private static Activator plugin;
+
+ /**
+ * The constructor
+ */
+ public Activator() {
+ }
+
+ /*
+ * (non-Javadoc)
+ *
+ * @see org.eclipse.ui.plugin.AbstractUIPlugin#start(org.osgi.framework.BundleContext)
+ */
+ @Override
+ public void start(BundleContext context) throws Exception {
+ super.start(context);
+ plugin = this;
+ }
+
+ /*
+ * (non-Javadoc)
+ *
+ * @see org.eclipse.ui.plugin.AbstractUIPlugin#stop(org.osgi.framework.BundleContext)
+ */
+ @Override
+ public void stop(BundleContext context) throws Exception {
+ plugin = null;
+ super.stop(context);
+ }
+
+ /**
+ * Returns the shared instance
+ *
+ * @return the shared instance
+ */
+ public static Activator getDefault() {
+ return plugin;
+ }
+
+}
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.filters.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.filters.tests/META-INF/MANIFEST.MF
index 417d8af39f3..344990a29ff 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.filters.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.filters.tests/META-INF/MANIFEST.MF
@@ -1,19 +1,18 @@
Manifest-Version: 1.0
Export-Package: org.eclipse.papyrus.uml.filters.tests
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.papyrus.uml.filters;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
- org.eclipse.emf.ecore;bundle-version="2.11.0";visibility:=reexport,
- org.eclipse.papyrus.infra.filters;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
- org.eclipse.uml2.types;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)";visibility:=reexport,
- org.eclipse.emf.ecore.xmi;bundle-version="2.11.0";visibility:=reexport,
- org.junit;visibility:=reexport,
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.filters;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.filters;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.filters.tests/pom.xml b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.filters.tests/pom.xml
index 8fd968bbfcd..8e287a113bd 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.filters.tests/pom.xml
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.filters.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.filters.tests</artifactId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/META-INF/MANIFEST.MF
index b6c28e23ae3..ce4c09f3ced 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/META-INF/MANIFEST.MF
@@ -1,15 +1,21 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.modelrepair;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.emf.readonly;bundle-version="[3.0.0,4.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.readonly;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.tools;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.modelrepair;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.modelrepair.internal.stereotypes,
org.eclipse.papyrus.uml.modelrepair.internal.uripattern,
org.eclipse.papyrus.uml.modelrepair.tests
Bundle-Vendor: %providerName
-Bundle-Version: 1.3.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/pom.xml b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/pom.xml
index 757d2c7eaf1..c5ab850a7ab 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/pom.xml
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.modelrepair.tests</artifactId>
- <version>1.3.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+ <artifactId>org.eclipse.papyrus.uml.modelrepair.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.properties.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.properties.tests/META-INF/MANIFEST.MF
index aee608be347..561227e54cd 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.properties.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.properties.tests/META-INF/MANIFEST.MF
@@ -1,17 +1,30 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0";visibility:=reexport,
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.hamcrest.core,
- org.eclipse.papyrus.uml.properties;bundle-version="[3.1.100,4.0.0)",
- org.eclipse.papyrus.infra.properties.ui;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.papyrus.infra.internationalization.utils;bundle-version="[1.0.100,2.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.1.0,5.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.tests;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.internationalization.utils;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.properties.ui;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.edit.ui;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.tools;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.ui.emf;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.widgets;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.extensionpoints;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.properties;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.properties.databinding.tests,
org.eclipse.papyrus.uml.properties.modelelement.tests,
org.eclipse.papyrus.uml.properties.tests
Bundle-Vendor: %providerName
-Bundle-Version: 1.1.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.properties.tests/pom.xml b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.properties.tests/pom.xml
index dd898cc011f..8ff389d5655 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.properties.tests/pom.xml
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.properties.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.properties.tests</artifactId>
- <version>1.1.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+ <artifactId>org.eclipse.papyrus.uml.properties.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/META-INF/MANIFEST.MF
index 77af16986ee..34e5b052832 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/META-INF/MANIFEST.MF
@@ -1,21 +1,32 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.hamcrest.core,
- org.eclipse.papyrus.uml.extensionpoints;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.newchild;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.uml2.uml.profile.standard;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.infra.types.core;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.types;bundle-version="[4.0.0,5.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.menu;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.tooling.runtime;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.types.core;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.service.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.uml2.uml.profile.standard;bundle-version="[1.5.0,2.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.service.types.tests.creation,
org.eclipse.papyrus.uml.service.types.tests.deletion,
org.eclipse.papyrus.uml.service.types.tests.registry,
org.eclipse.papyrus.uml.service.types.tests.suites
Bundle-Vendor: %providerName
-Bundle-Version: 1.3.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/pom.xml b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/pom.xml
index b2edfdd7ff7..4ff41204559 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/pom.xml
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.service.types.tests</artifactId>
- <version>1.3.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+ <artifactId>org.eclipse.papyrus.uml.service.types.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.ui.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.ui.tests/META-INF/MANIFEST.MF
index a51a0bdfdd7..8bc933e04d9 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.ui.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.ui.tests/META-INF/MANIFEST.MF
@@ -1,21 +1,26 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.hamcrest.core,
- org.eclipse.papyrus.uml.extensionpoints;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.service.types.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.newchild;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.emf.gmf;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.infra.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.types.core;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.newchild;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.types.core;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.widgets;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.service.types;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.service.types.ui.tests.creation,
org.eclipse.papyrus.uml.service.types.ui.tests.deletion,
org.eclipse.papyrus.uml.service.types.ui.tests.suites
Bundle-Vendor: %providerName
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.ui.tests/pom.xml b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.ui.tests/pom.xml
index 732e6359e70..f58a9c853da 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.ui.tests/pom.xml
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.ui.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.service.types.ui.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+ <artifactId>org.eclipse.papyrus.uml.service.types.ui.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.suite.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.suite.tests/META-INF/MANIFEST.MF
index ceef5622cde..f9b05c00eab 100755
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.suite.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.suite.tests/META-INF/MANIFEST.MF
@@ -1,43 +1,39 @@
Manifest-Version: 1.0
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 0.0.1.qualifier
+Bundle-Version: 1.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.suite.tests.Activator
Bundle-SymbolicName: org.eclipse.papyrus.uml.suite.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.service.types.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.service.types.ui.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.modelexplorer.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.dnd.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.tools.tests;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.tools.utils.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.wizards.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.modelrepair.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.profile.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.decoratormodel.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.decoratormodel.controlmode.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.validation.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.filters.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.profile.assistants.generator.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.profile.types.generator.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.profile.drafter.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.views.modelexplorer.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.validation.tests.staticprofile;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.dynamic.profile.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.internationalization.tests;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.uml.alf.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.expressions.tests;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.uml.architecture.tests;bundle-version="1.1.200",
- org.eclipse.papyrus.uml.properties.tests;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.properties.tests;bundle-version="[1.0.0,2.0.0)"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.alf.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.architecture.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.decoratormodel.controlmode.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.decoratormodel.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.dnd.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.properties.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.wizards.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.expressions.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.filters.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.internationalization.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.modelexplorer.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.modelrepair.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.profile.assistants.generator.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.profile.drafter.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.profile.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.profile.types.generator.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.properties.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.service.types.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.service.types.ui.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.tools.tests;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.uml.tools.utils.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.validation.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.suite.tests
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.suite.tests/pom.xml b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.suite.tests/pom.xml
index 59009effbd4..8b489bbbb07 100755
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.suite.tests/pom.xml
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.suite.tests/pom.xml
@@ -1,8 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus</groupId>
@@ -12,7 +11,7 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.suite.tests</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <version>1.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
<plugins>
@@ -55,4 +54,4 @@
</plugins>
</build>
-</project>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/META-INF/MANIFEST.MF
index b3e0e2a5b8d..aabc01ef7ac 100644
--- a/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/META-INF/MANIFEST.MF
@@ -2,25 +2,22 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.papyrus.uml.profile.drafter.tests;singleton:=true
-Bundle-Version: 1.3.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Activator: org.eclipse.papyrus.uml.profile.drafter.tests.Activator
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Require-Bundle: org.eclipse.papyrus.uml.profile.drafter;bundle-version="[1.3.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.core.databinding,
- org.eclipse.core.databinding.beans,
- org.eclipse.core.databinding.observable,
- org.eclipse.core.databinding.property,
- org.eclipse.jface.databinding,
- com.ibm.icu,
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.core.runtime
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.jface.databinding;bundle-version="[1.11.0,2.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.profile.drafter;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.profile.drafter.tests,
org.eclipse.papyrus.uml.profile.drafter.tests.exception
Bundle-Vendor: %providerName
diff --git a/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/pom.xml b/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/pom.xml
index 5aabd9fb56d..f6cc2dbefd2 100644
--- a/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/pom.xml
+++ b/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.profile.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.profile.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.profile.drafter.tests</artifactId>
- <version>1.3.100-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.tests/META-INF/MANIFEST.MF
index 2b477138a3a..8569688ea94 100644
--- a/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.tests/META-INF/MANIFEST.MF
@@ -1,12 +1,17 @@
Manifest-Version: 1.0
-Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.profile;bundle-version="[3.0.0,4.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.common.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.profile;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="[3.8.0,4.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.profile.service,
org.eclipse.papyrus.uml.profile.tests
Bundle-Vendor: %providerName
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.tests/pom.xml b/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.tests/pom.xml
index f7fcd7b1219..f9047b34ae8 100644
--- a/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.tests/pom.xml
+++ b/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.profile.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.profile.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.profile.tests</artifactId>
- <version>1.2.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+ <artifactId>org.eclipse.papyrus.uml.profile.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.tests/META-INF/MANIFEST.MF
index ee9453fd098..a1737f26258 100644
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.tests/META-INF/MANIFEST.MF
@@ -1,16 +1,18 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.papyrus.uml.xtext.integration.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.4.0,3.0.0)",
- org.junit;bundle-version="4.11.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.textedit.parameter.xtext.ui;bundle-version="[2.1.0,3.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.textedit.parameter.xtext.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.xtext.integration.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.textedit.parameter.tests,
org.eclipse.papyrus.uml.textedit.parameter.tests.suites
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: UML Textedit Parameter Tests
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.textedit.parameter.tests.Activator
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.tests/pom.xml b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.tests/pom.xml
index 52f15c9b475..3a5fd1fe068 100644
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.tests/pom.xml
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.tests/pom.xml
@@ -1,4 +1,7 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus.tests</groupId>
@@ -8,6 +11,6 @@
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.textedit.parameter.tests
</artifactId>
- <version>1.2.200-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.tests/META-INF/MANIFEST.MF
index 1ace485045f..3c2e16928c9 100644
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.tests/META-INF/MANIFEST.MF
@@ -1,15 +1,16 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.junit;bundle-version="4.11.0",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.4.0,3.0.0)",
- org.eclipse.papyrus.uml.textedit.port.xtext.ui;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.papyrus.uml.xtext.integration.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.textedit.port.xtext.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.xtext.integration.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.textedit.port.tests.suites
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: XText Port Editor Tests
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.textedit.port.tests.Activator
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.tests/pom.xml b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.tests/pom.xml
index f4a69671301..e30f467cc36 100644
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.tests/pom.xml
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.tests/pom.xml
@@ -1,4 +1,7 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus.tests</groupId>
@@ -7,6 +10,6 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.textedit.port.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.tests/META-INF/MANIFEST.MF
index dfa1a8739c4..38c8edf4fb9 100644
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.tests/META-INF/MANIFEST.MF
@@ -1,18 +1,16 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.junit;bundle-version="4.11.0",
- org.eclipse.papyrus.uml.textedit.property.xtext.ui;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.papyrus.uml.xtext.integration.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.4.0,3.0.0)"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.textedit.property.xtext.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.xtext.integration.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.textedit.property.tests.suites
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.300.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: XText Property editor Tests
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.textedit.property.tests.Activator
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.tests/pom.xml b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.tests/pom.xml
index 697470aa785..dc22a0763bc 100644
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.tests/pom.xml
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.tests/pom.xml
@@ -1,4 +1,7 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus.tests</groupId>
@@ -8,6 +11,6 @@
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.textedit.property.tests
</artifactId>
- <version>1.2.300-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.suite.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.suite.tests/META-INF/MANIFEST.MF
index 1460994f128..812ece9186c 100755
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.suite.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.suite.tests/META-INF/MANIFEST.MF
@@ -1,21 +1,19 @@
Manifest-Version: 1.0
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 0.0.1.qualifier
+Bundle-Version: 1.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.textedit.suite.tests.Activator
Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.suite.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.textedit.port.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.textedit.property.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.textedit.parameter.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.textedit.valuespecification.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.textedit.tests;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.textedit.parameter.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.textedit.port.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.textedit.property.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.textedit.valuespecification.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.textedit.suite.tests
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.suite.tests/pom.xml b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.suite.tests/pom.xml
index 8924e59fd8f..99f40a51422 100755
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.suite.tests/pom.xml
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.suite.tests/pom.xml
@@ -1,8 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus</groupId>
@@ -12,7 +11,7 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.textedit.suite.tests</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <version>1.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
<plugins>
@@ -55,4 +54,4 @@
</plugins>
</build>
-</project>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.tests/META-INF/MANIFEST.MF
index 6c966c2d025..538e2493454 100644
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.tests/META-INF/MANIFEST.MF
@@ -1,22 +1,18 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.papyrus.uml.xtext.integration.core;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.xtext.integration.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.emf.ecore;bundle-version="2.11.0",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.gmf.runtime.common.ui.services;bundle-version="1.7.0",
- org.eclipse.gmf.runtime.emf.core;bundle-version="1.7.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.junit;bundle-version="4.11.0",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.4.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.extensionpoints.editors;bundle-version="[1.0.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.extensionpoints.editors;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.xtext.integration.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.textedit.tests,
org.eclipse.papyrus.uml.textedit.tests.editor
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: Textedit Tests
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.textedit.tests.Activator
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.tests/pom.xml b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.tests/pom.xml
index 56b5b064941..699d02a76a2 100644
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.tests/pom.xml
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.textedit.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.textedit.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.textedit.tests</artifactId>
- <version>1.3.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+ <artifactId>org.eclipse.papyrus.uml.textedit.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.tests/META-INF/MANIFEST.MF
index 79619582444..11c861abb3b 100644
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.tests/META-INF/MANIFEST.MF
@@ -1,19 +1,17 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.junit;bundle-version="4.11.0",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.4.0,3.0.0)",
- org.eclipse.papyrus.uml.xtext.integration.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.textedit.valuespecification.xtext.ui;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.gmf.runtime.common.ui.services,
- org.eclipse.gmf.runtime.emf.core,
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.textedit.valuespecification.xtext.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.xtext.integration.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.textedit.valuespecification.tests.suites
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-Activator: org.eclipse.papyrus.uml.textedit.valuespecification.tests.Activator
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.tests/pom.xml b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.tests/pom.xml
index 03db0cd18e1..548d9755f2e 100644
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.tests/pom.xml
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.tests/pom.xml
@@ -1,4 +1,7 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus.tests</groupId>
@@ -8,6 +11,6 @@
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.uml.textedit.valuespecification.tests
</artifactId>
- <version>1.2.200-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.tests/META-INF/MANIFEST.MF
index caf124f145a..1d36df383d4 100644
--- a/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.tests/META-INF/MANIFEST.MF
@@ -1,28 +1,27 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.emf.ecore;bundle-version="2.8.0",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.emf.transaction;bundle-version="1.4.0",
- org.eclipse.papyrus.emf.facet.custom.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.emf.facet.custom.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.extensionpoints;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.jface.text;bundle-version="3.10.0",
- org.eclipse.papyrus.infra.ui.emf;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.emf.facet.custom.ui;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.services.labelprovider;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.ui.emf;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.widgets;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.uml.tools.tests,
org.eclipse.papyrus.uml.tools.tests.tests
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.1.100.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Name: UML Tools Tests
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.tools.tests.Activator
diff --git a/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.tests/pom.xml b/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.tests/pom.xml
index 071fd8d262e..955a3d86089 100644
--- a/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.tests/pom.xml
+++ b/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.tools.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.tools.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.tools.tests</artifactId>
- <version>3.1.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+ <artifactId>org.eclipse.papyrus.uml.tools.tests</artifactId>
+ <version>4.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils.tests/META-INF/MANIFEST.MF
index 8b2d23e4d6f..4cafe531f5f 100644
--- a/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils.tests/META-INF/MANIFEST.MF
@@ -1,21 +1,22 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.emf.transaction;bundle-version="1.4.0",
- org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.dynamic.profile.tests;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.transaction;bundle-version="[1.9.1,2.0.0)",
+ org.eclipse.jface;bundle-version="[3.20.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.tools;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.ui.workbench;bundle-version="[3.119.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)",
+ org.eclipse.papyrus.uml.dynamic.profile.tests;bundle-version="[2.0.0,3.0.0)"
Export-Package: org.eclipse.papyrus.uml.tools.utils.tests.tests
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.tools.utils.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Automatic-Module-Name: org.eclipse.papyrus.uml.tools.utils.tests
+Bundle-Activator: org.eclipse.papyrus.uml.tools.utils.tests.tests.Activator
diff --git a/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils.tests/pom.xml b/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils.tests/pom.xml
index e5f2385349d..afacc56b76c 100644
--- a/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils.tests/pom.xml
+++ b/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils.tests/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.tools.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.tools.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
<groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.tools.utils.tests</artifactId>
- <version>1.3.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+ <artifactId>org.eclipse.papyrus.uml.tools.utils.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils.tests/src/org/eclipse/papyrus/uml/tools/utils/tests/tests/Activator.java b/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils.tests/src/org/eclipse/papyrus/uml/tools/utils/tests/tests/Activator.java
new file mode 100644
index 00000000000..7b0dae06d58
--- /dev/null
+++ b/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils.tests/src/org/eclipse/papyrus/uml/tools/utils/tests/tests/Activator.java
@@ -0,0 +1,68 @@
+/*****************************************************************************
+ * Copyright (c) 2020 CEA LIST.
+ *
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License 2.0
+ * which accompanies this distribution, and is available at
+ * https://www.eclipse.org/legal/epl-2.0/
+ *
+ * SPDX-License-Identifier: EPL-2.0
+ *
+ * Contributors:
+ * Patrick Tessier (CEA LIST) - Initial API and implementation
+ /*****************************************************************************/
+package org.eclipse.papyrus.uml.tools.utils.tests.tests;
+
+import org.eclipse.ui.plugin.AbstractUIPlugin;
+import org.osgi.framework.BundleContext;
+
+/**
+ * The activator class controls the plug-in life cycle
+ */
+public class Activator extends AbstractUIPlugin {
+
+ // The plug-in ID
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.uml.tools.utils.tests"; //$NON-NLS-1$
+
+ // The shared instance
+ private static Activator plugin;
+
+ /**
+ * The constructor
+ */
+ public Activator() {
+ }
+
+ /*
+ * (non-Javadoc)
+ *
+ * @see org.eclipse.ui.plugin.AbstractUIPlugin#start(org.osgi.framework.BundleContext)
+ */
+ @Override
+ public void start(BundleContext context) throws Exception {
+ super.start(context);
+ plugin = this;
+ org.eclipse.papyrus.uml.dynamic.profile.tests.Activator.getDefault();// I add this reference to explicit dependencies between models
+ }
+
+ /*
+ * (non-Javadoc)
+ *
+ * @see org.eclipse.ui.plugin.AbstractUIPlugin#stop(org.osgi.framework.BundleContext)
+ */
+ @Override
+ public void stop(BundleContext context) throws Exception {
+ plugin = null;
+ super.stop(context);
+ }
+
+ /**
+ * Returns the shared instance
+ *
+ * @return the shared instance
+ */
+ public static Activator getDefault() {
+ return plugin;
+ }
+}
diff --git a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/META-INF/MANIFEST.MF
index 0891834026e..51bff09dcb0 100644
--- a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/META-INF/MANIFEST.MF
@@ -1,13 +1,12 @@
Manifest-Version: 1.0
Bundle-SymbolicName: org.eclipse.papyrus.uml.validation.tests.genvalidation;singleton:=true
Bundle-Name: %pluginName
-Bundle-Version: 1.2.0.qualifier
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.emf.validation,
- org.eclipse.papyrus.uml.service.validation;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.papyrus.uml.validation.tests.staticprofile;bundle-version="[1.2.0,2.0.0)"
+Bundle-Version: 2.0.0.qualifier
+Require-Bundle: org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.uml.service.validation;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.validation.tests.staticprofile;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)"
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.validation.tests.genvalidation.Activator
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/pom.xml b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/pom.xml
index 0cd7343f0eb..126a364c3e4 100644
--- a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/pom.xml
+++ b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/pom.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.validation.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.validation.tests.genvalidation</artifactId>
- <version>1.2.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
-</project>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.validation.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.validation.tests.genvalidation</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/src/org/eclipse/papyrus/uml/validation/tests/genvalidation/Activator.java b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/src/org/eclipse/papyrus/uml/validation/tests/genvalidation/Activator.java
index cd9c5b56c8a..b3863e6624a 100644
--- a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/src/org/eclipse/papyrus/uml/validation/tests/genvalidation/Activator.java
+++ b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/src/org/eclipse/papyrus/uml/validation/tests/genvalidation/Activator.java
@@ -13,7 +13,7 @@ public class Activator extends AbstractUIPlugin {
// The shared instance
private static Activator plugin;
-
+
/**
* The constructor
*/
@@ -22,17 +22,23 @@ public class Activator extends AbstractUIPlugin {
/*
* (non-Javadoc)
+ *
* @see org.eclipse.ui.plugin.AbstractUIPlugin#start(org.osgi.framework.BundleContext)
*/
+ @Override
public void start(BundleContext context) throws Exception {
super.start(context);
plugin = this;
+ org.eclipse.papyrus.uml.validation.tests.staticprofile.Activator.getDefault();// use because there is an implicit dependency between models
+
}
/*
* (non-Javadoc)
+ *
* @see org.eclipse.ui.plugin.AbstractUIPlugin#stop(org.osgi.framework.BundleContext)
*/
+ @Override
public void stop(BundleContext context) throws Exception {
plugin = null;
super.stop(context);
diff --git a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.staticprofile/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.staticprofile/META-INF/MANIFEST.MF
index c2e2a0041a6..53badaf524e 100644
--- a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.staticprofile/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.staticprofile/META-INF/MANIFEST.MF
@@ -5,14 +5,11 @@ Export-Package: org.eclipse.papyrus.uml.validation.tests.staticprofile,
profile.impl,
profile.util
Bundle-Name: %pluginName
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-ClassPath: .
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.emf.common;bundle-version="2.12.0",
- org.eclipse.emf.ecore;bundle-version="2.12.0";visibility:=reexport,
- org.eclipse.uml2.types;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)";visibility:=reexport
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.18.0,4.0.0)",
+ org.eclipse.ui;bundle-version="[3.117.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)"
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.validation.tests.staticprofile.Activator
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.staticprofile/pom.xml b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.staticprofile/pom.xml
index 026b07c505a..8992b7aaf92 100644
--- a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.staticprofile/pom.xml
+++ b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.staticprofile/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.validation.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.validation.tests.staticprofile</artifactId>
- <version>1.2.100-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.validation.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.validation.tests.staticprofile</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/META-INF/MANIFEST.MF
index d6311f286c2..43643028bf7 100644
--- a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/META-INF/MANIFEST.MF
@@ -1,23 +1,25 @@
Manifest-Version: 1.0
Bundle-Description: Tests for validation rules of the UmlRT profile
Bundle-SymbolicName: org.eclipse.papyrus.uml.validation.tests;singleton:=true
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-ClassPath: .
Bundle-Name: %pluginName
-Require-Bundle: org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.junit,
- org.eclipse.ui.views.properties.tabbed;bundle-version="3.6.0",
- org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.services.validation;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.service.validation;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.gmf.runtime.emf.commands.core;bundle-version="1.7.0",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)";visibility:=reexport,
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.ocl.xtext.completeocl;bundle-version="1.1.0",
- org.eclipse.ocl.pivot.uml;bundle-version="1.1.0",
- org.eclipse.papyrus.uml.validation.tests.staticprofile;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.validation.tests.genvalidation;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.ocl.pivot.uml;bundle-version="[1.12.0,2.0.0)",
+ org.eclipse.ocl.xtext.completeocl;bundle-version="[1.12.0,2.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.services.validation;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)",
+ org.eclipse.papyrus.uml.validation.tests.staticprofile;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.widgets;bundle-version="[4.0.0,5.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.validation.tests.Activator
diff --git a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/pom.xml b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/pom.xml
index d703eb3250e..02b12d1e170 100644
--- a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/pom.xml
+++ b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.validation.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.uml.validation.tests</artifactId>
- <version>1.2.200-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.validation.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.uml.validation.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/src/org/eclipse/papyrus/uml/validation/tests/Activator.java b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/src/org/eclipse/papyrus/uml/validation/tests/Activator.java
index efb77f0a7f4..39e5a2b0579 100644
--- a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/src/org/eclipse/papyrus/uml/validation/tests/Activator.java
+++ b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/src/org/eclipse/papyrus/uml/validation/tests/Activator.java
@@ -15,6 +15,7 @@
*****************************************************************************/
package org.eclipse.papyrus.uml.validation.tests;
+import org.eclipse.papyrus.infra.core.log.LogHelper;
import org.eclipse.ui.plugin.AbstractUIPlugin;
import org.osgi.framework.BundleContext;
@@ -37,18 +38,22 @@ public class Activator extends AbstractUIPlugin {
/*
* (non-Javadoc)
- *
+ *
* @see org.eclipse.ui.plugin.AbstractUIPlugin#start(org.osgi.framework.BundleContext)
*/
@Override
public void start(BundleContext context) throws Exception {
super.start(context);
plugin = this;
+ org.eclipse.papyrus.infra.widgets.Activator.getDefault();// use because there is an implicit dependency
+ org.eclipse.papyrus.uml.validation.tests.staticprofile.Activator.getDefault();// use because there is an implicit dependency between models
+ org.eclipse.papyrus.infra.core.Activator.getDefault();// use because there is an implicit dependency
+ org.eclipse.papyrus.infra.core.log.LogHelper log = new LogHelper();// use because there is an implicit dependency
}
/*
* (non-Javadoc)
- *
+ *
* @see org.eclipse.ui.plugin.AbstractUIPlugin#stop(org.osgi.framework.BundleContext)
*/
@Override
diff --git a/tests/junit/plugins/views/documentation/org.eclipse.papyrus.views.documentation.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/views/documentation/org.eclipse.papyrus.views.documentation.tests/META-INF/MANIFEST.MF
index 6fa165a7a8f..4fc22331b00 100644
--- a/tests/junit/plugins/views/documentation/org.eclipse.papyrus.views.documentation.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/views/documentation/org.eclipse.papyrus.views.documentation.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Export-Package: org.eclipse.papyrus.views.documentation.tests
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.0.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
@@ -10,15 +10,10 @@ Bundle-Activator: org.eclipse.papyrus.views.documentation.tests.Activator
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.views.documentation.tests
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.ui;bundle-version="[3.107.0,4.0.0)",
- org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
- org.eclipse.core.resources;bundle-version="[3.12.0,4.0.0)",
- org.eclipse.ui.ide;bundle-version="[3.12.0,4.0.0)",
- org.eclipse.ui.navigator;bundle-version="[3.6.0,4.0.0)",
- org.eclipse.ui.workbench;bundle-version="[3.109.0,4.0.0)",
- org.eclipse.core.commands;bundle-version="[3.9.0,4.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.equinox.registry;bundle-version="[3.6.200,4.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.2.0,3.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.views.documentation;bundle-version="[1.0.0,2.0.0)"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.views.documentation;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.xtext.ui;bundle-version="[2.22.0,3.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
diff --git a/tests/junit/plugins/views/documentation/org.eclipse.papyrus.views.documentation.tests/pom.xml b/tests/junit/plugins/views/documentation/org.eclipse.papyrus.views.documentation.tests/pom.xml
index 4c91456d097..36c1bed1a3c 100644
--- a/tests/junit/plugins/views/documentation/org.eclipse.papyrus.views.documentation.tests/pom.xml
+++ b/tests/junit/plugins/views/documentation/org.eclipse.papyrus.views.documentation.tests/pom.xml
@@ -1,4 +1,7 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus</groupId>
@@ -8,6 +11,6 @@
</parent>
<groupId>org.eclipse.papyrus</groupId>
<artifactId>org.eclipse.papyrus.views.documentation.tests</artifactId>
- <version>1.0.100-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/views/org.eclipse.papyrus.views.modelexplorer.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/views/org.eclipse.papyrus.views.modelexplorer.tests/META-INF/MANIFEST.MF
index 5972185dddf..2a1d307506e 100644
--- a/tests/junit/plugins/views/org.eclipse.papyrus.views.modelexplorer.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/views/org.eclipse.papyrus.views.modelexplorer.tests/META-INF/MANIFEST.MF
@@ -1,35 +1,27 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.core.resources,
- org.eclipse.ui.ide,
- org.eclipse.ui.navigator,
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.eclipse.gmf.runtime.notation;bundle-version="[1.10.0,2.0.0)",
- org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.200",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.emf.facet.custom.metamodel;bundle-version="[1.3.0,2.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.services.labelprovider;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.emf.facet.custom.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.emf.facet.util.core;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.emf.facet.custom.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.nattable.model;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.tools;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[1.2.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.edit.ui;bundle-version="[2.18.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.emf.facet.custom.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.emf.facet.custom.metamodel;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.emf.facet.efacet.metamodel;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.core.sasheditor;bundle-version="3.0.0",
+ org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.ui.ide;bundle-version="3.17.100",
+ org.eclipse.ui.navigator;bundle-version="[3.9.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.views.modelexplorer.tests
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.0.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
diff --git a/tests/junit/plugins/views/org.eclipse.papyrus.views.modelexplorer.tests/pom.xml b/tests/junit/plugins/views/org.eclipse.papyrus.views.modelexplorer.tests/pom.xml
index 2654b1912e3..95e4092addf 100644
--- a/tests/junit/plugins/views/org.eclipse.papyrus.views.modelexplorer.tests/pom.xml
+++ b/tests/junit/plugins/views/org.eclipse.papyrus.views.modelexplorer.tests/pom.xml
@@ -1,12 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.views.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
- </parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.views.modelexplorer.tests</artifactId>
- <version>1.3.0-SNAPSHOT</version>
- <packaging>eclipse-test-plugin</packaging>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.views.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.views.modelexplorer.tests</artifactId>
+ <version>2.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/views/org.eclipse.papyrus.views.properties.toolsmiths.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/views/org.eclipse.papyrus.views.properties.toolsmiths.tests/META-INF/MANIFEST.MF
index fae6c85f3cc..7ce2fc5d11e 100644
--- a/tests/junit/plugins/views/org.eclipse.papyrus.views.properties.toolsmiths.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/views/org.eclipse.papyrus.views.properties.toolsmiths.tests/META-INF/MANIFEST.MF
@@ -1,26 +1,22 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.views.properties.model.xwt;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.uml.properties.generation;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.emf.ecore;bundle-version="2.8.0",
- org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.views.properties;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.properties;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.uml.properties;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.m2m.qvt.oml;bundle-version="3.2.0",
- org.eclipse.core.resources;bundle-version="3.8.0",
- org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.junit;bundle-version="4.10.0",
- org.eclipse.core.databinding;bundle-version="1.4.1",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.1.0,3.0.0)"
+Require-Bundle: org.eclipse.emf.databinding;bundle-version="[1.5.0,2.0.0)",
+ org.eclipse.emf.ecore.editor;bundle-version="[2.17.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.properties;bundle-version="[4.0.0,5.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.properties.generation;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.views.properties;bundle-version="[5.0.0,6.0.0)",
+ org.eclipse.papyrus.views.properties.model.xwt;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Export-Package: org.eclipse.papyrus.views.properties.toolsmiths.tests,
org.eclipse.papyrus.views.properties.toolsmiths.tests.qvt
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: Properties view customization Tests
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.views.properties.toolsmiths.tests.Activator
diff --git a/tests/junit/plugins/views/org.eclipse.papyrus.views.properties.toolsmiths.tests/pom.xml b/tests/junit/plugins/views/org.eclipse.papyrus.views.properties.toolsmiths.tests/pom.xml
index 872f789e08e..a58b576824e 100644
--- a/tests/junit/plugins/views/org.eclipse.papyrus.views.properties.toolsmiths.tests/pom.xml
+++ b/tests/junit/plugins/views/org.eclipse.papyrus.views.properties.toolsmiths.tests/pom.xml
@@ -1,11 +1,14 @@
-<?xml version="1.0" encoding="UTF-8"?><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus.tests</groupId>
- <artifactId>org.eclipse.papyrus.views.tests.releng</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.views.tests.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.views.properties.toolsmiths.tests</artifactId>
- <version>1.2.100-SNAPSHOT</version>
+ <version>2.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/views/org.eclipse.papyrus.views.suite.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/views/org.eclipse.papyrus.views.suite.tests/META-INF/MANIFEST.MF
index a6ff5fb7674..ff60242add7 100755
--- a/tests/junit/plugins/views/org.eclipse.papyrus.views.suite.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/views/org.eclipse.papyrus.views.suite.tests/META-INF/MANIFEST.MF
@@ -1,6 +1,6 @@
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 0.0.1.qualifier
+Bundle-Version: 1.0.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
@@ -8,13 +8,12 @@ Bundle-Activator: org.eclipse.papyrus.views.suite.tests.Activator
Bundle-SymbolicName: org.eclipse.papyrus.views.suite.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.junit;bundle-version="4.10.0",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.bundles.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.views.properties.toolsmiths.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.views.modelexplorer.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.views.documentation.tests;bundle-version="[1.0.0,2.0.0)"
+Require-Bundle: org.eclipse.emf.ecore.editor;bundle-version="[2.17.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.views.documentation.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.views.modelexplorer.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.views.properties.toolsmiths.tests;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.uml2.uml.editor;bundle-version="[5.5.0,6.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.views.suite.tests
diff --git a/tests/junit/plugins/views/org.eclipse.papyrus.views.suite.tests/pom.xml b/tests/junit/plugins/views/org.eclipse.papyrus.views.suite.tests/pom.xml
index 66fd6e6b7d7..0476b45ffef 100755
--- a/tests/junit/plugins/views/org.eclipse.papyrus.views.suite.tests/pom.xml
+++ b/tests/junit/plugins/views/org.eclipse.papyrus.views.suite.tests/pom.xml
@@ -1,8 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
- xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.papyrus</groupId>
@@ -12,7 +11,7 @@
</parent>
<groupId>org.eclipse.papyrus.tests</groupId>
<artifactId>org.eclipse.papyrus.views.suite.tests</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <version>1.0.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
<plugins>
@@ -55,4 +54,4 @@
</plugins>
</build>
-</project>
+</project> \ No newline at end of file

Back to the top