Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/views')
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/.project2
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/META-INF/MANIFEST.MF7
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/.project2
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/META-INF/MANIFEST.MF5
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation/.project2
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation/META-INF/MANIFEST.MF2
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation/schema/documentationManager.exsd4
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/.project2
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF11
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/.project2
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF11
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/src/org/eclipse/papyrus/modelexplorer/widgets/Activator.java2
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/.project2
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF18
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/src/org/eclipse/papyrus/modelexplorer/Activator.java2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/META-INF/MANIFEST.MF7
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/META-INF/MANIFEST.MF5
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.model/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.model/META-INF/MANIFEST.MF5
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.model/Model/Properties.genmodel12
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/META-INF/MANIFEST.MF7
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/src/org/eclipse/papyrus/properties/runtime/Activator.java2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/META-INF/MANIFEST.MF7
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/src/org/eclipse/papyrus/properties/tabbed/core/Activator.java2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/META-INF/MANIFEST.MF15
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_predefined_fragments.xml2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_wizards_dialogs.xml2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/src/org/eclipse/papyrus/properties/tabbed/customization/Activator.java2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/META-INF/MANIFEST.MF3
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/src/org/eclipse/papyrus/tabbedproperties/core/Activator.java2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF16
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.ecore4
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.genmodel2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/plugin.xml4
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/schema/context.exsd4
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/schema/environment.exsd6
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/schema/labelprovider.exsd4
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/src/org/eclipse/papyrus/properties/Activator.java2
45 files changed, 97 insertions, 108 deletions
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/.project b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/.project
index 28756425437..72e3c5a4396 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/.project
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.documentation.view.papyrus</name>
+ <name>org.eclipse.papyrus.views.documentation.view.papyrus</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/META-INF/MANIFEST.MF b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/META-INF/MANIFEST.MF
index 8d470dcc8e4..970ea47fa29 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/META-INF/MANIFEST.MF
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/META-INF/MANIFEST.MF
@@ -1,6 +1,6 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.documentation.view;bundle-version:="0.9.0",
- org.eclipse.papyrus.modelexplorer;bundle-version="0.9.0",
+Require-Bundle: org.eclipse.papyrus.views.documentation.view;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0",
org.eclipse.papyrus.core.adaptor.gmf;bundle-version="0.9.0",
org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0"
Bundle-Vendor: %providerName
@@ -8,7 +8,6 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.documentation.view.papyrus;si
- ngleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.documentation.view.papyrus;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/.project b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/.project
index 52a6f737c99..60ba04a747c 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/.project
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.documentation.view</name>
+ <name>org.eclipse.papyrus.views.documentation.view</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/META-INF/MANIFEST.MF b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/META-INF/MANIFEST.MF
index e5f6c8c5bb7..428295748fb 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/META-INF/MANIFEST.MF
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/META-INF/MANIFEST.MF
@@ -11,12 +11,11 @@ Require-Bundle: org.eclipse.core.expressions;visibility:=reexport,
org.eclipse.jface.text,
org.eclipse.core.resources,
org.eclipse.epf.richtext,
- org.eclipse.papyrus.documentation;bundle-version="0.9.0";visibility:=reexport
+ org.eclipse.papyrus.views.documentation;bundle-version="0.9.0";visibility:=reexport
Bundle-Vendor: %providerName
Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.documentation.view.DocViewPlugin
-Bundle-SymbolicName: org.eclipse.papyrus.documentation.view;singleton:
- =true
+Bundle-SymbolicName: org.eclipse.papyrus.views.documentation.view;singleton:=true
Import-Package: org.eclipse.ui.views.contentoutline
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation/.project b/plugins/views/documentation/org.eclipse.papyrus.views.documentation/.project
index d8dc4202fb1..6f2cf1dabb3 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation/.project
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.documentation</name>
+ <name>org.eclipse.papyrus.views.documentation</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation/META-INF/MANIFEST.MF b/plugins/views/documentation/org.eclipse.papyrus.views.documentation/META-INF/MANIFEST.MF
index 10fc0c348db..ee26db08f7d 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation/META-INF/MANIFEST.MF
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation/META-INF/MANIFEST.MF
@@ -11,6 +11,6 @@ Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.documentation.Activator
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.documentation;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.documentation;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation/schema/documentationManager.exsd b/plugins/views/documentation/org.eclipse.papyrus.views.documentation/schema/documentationManager.exsd
index 2e0a20b1ece..b9451b00dde 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation/schema/documentationManager.exsd
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation/schema/documentationManager.exsd
@@ -1,9 +1,9 @@
<?xml version='1.0' encoding='UTF-8'?>
<!-- Schema file written by PDE -->
-<schema targetNamespace="org.eclipse.papyrus.documentation" xmlns="http://www.w3.org/2001/XMLSchema">
+<schema targetNamespace="org.eclipse.papyrus.views.documentation" xmlns="http://www.w3.org/2001/XMLSchema">
<annotation>
<appinfo>
- <meta.schema plugin="org.eclipse.papyrus.documentation" id="modelDocumentationManager" name="modelDocumentationManager"/>
+ <meta.schema plugin="org.eclipse.papyrus.views.documentation" id="modelDocumentationManager" name="modelDocumentationManager"/>
</appinfo>
<documentation>
This extension is used to provide a way to get and set a documentation for an element of a specific meta-model.
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/.project b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/.project
index 64436edba9f..6529ae2f1f2 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/.project
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.modelexplorer.resourceloading</name>
+ <name>org.eclipse.papyrus.views.modelexplorer.resourceloading</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF
index 9f68eafb9d4..63bd2418862 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF
@@ -2,12 +2,12 @@ Manifest-Version: 1.0
Require-Bundle: org.eclipse.emf.converter;bundle-version="2.5.0",
org.eclipse.emf.ecore.editor;bundle-version="2.6.0",
org.eclipse.emf.workspace.ui;bundle-version="1.3.0",
- org.eclipse.papyrus.service.edit;bundle-version:="0.9.0",
- org.eclipse.emf.facet.infra.browser;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.browser.custom;bundle-version:="0.1.0",
+ org.eclipse.papyrus.service.edit;bundle-version="0.9.0",
+ org.eclipse.emf.facet.infra.browser;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.browser.custom;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.common.core;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.facet;bundle-version="0.1.0",
- org.eclipse.papyrus.modelexplorer;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0",
org.eclipse.papyrus.controlmode.history;bundle-version="0.9.0",
org.eclipse.papyrus.core.resourceloading;bundle-version="0.9.0"
Export-Package: org.eclipse.papyrus.modelexplorer.resourceloading.hand
@@ -20,7 +20,6 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.modelexplorer.resourceloading.Ac
tivator
-Bundle-SymbolicName: org.eclipse.papyrus.modelexplorer.resourceloading
- ;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.modelexplorer.resourceloading;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/.project b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/.project
index c06b238c31e..e8257602822 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/.project
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.modelexplorer.widgets</name>
+ <name>org.eclipse.papyrus.views.modelexplorer.widgets</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF
index 0de78d32b0b..74d2b9f852f 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF
@@ -2,11 +2,11 @@ Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.papyrus.widgets;bundle-version="0.9.0";visibility:=reexport,
- org.eclipse.papyrus.modelexplorer;bundle-version="0.9.0";visibility:=reexport,
- org.eclipse.emf.facet.infra.browser;bundle-version:="0.1.0";visibility:=reexport,
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0";visibility:=reexport,
+ org.eclipse.emf.facet.infra.browser;bundle-version="0.1.0";visibility:=reexport,
org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0";visibility:=reexport,
- org.eclipse.papyrus.service.edit;bundle-version:="0.9.0",
- org.eclipse.emf.facet.infra.facet;bundle-version:="0.1.0"
+ org.eclipse.papyrus.service.edit;bundle-version="0.9.0",
+ org.eclipse.emf.facet.infra.facet;bundle-version="0.1.0"
Export-Package: org.eclipse.papyrus.modelexplorer.widgets
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
@@ -14,7 +14,6 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.modelexplorer.widgets.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.modelexplorer.widgets;singlet
- on:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.modelexplorer.widgets;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/src/org/eclipse/papyrus/modelexplorer/widgets/Activator.java b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/src/org/eclipse/papyrus/modelexplorer/widgets/Activator.java
index e11b5087f15..15a9396511a 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/src/org/eclipse/papyrus/modelexplorer/widgets/Activator.java
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/src/org/eclipse/papyrus/modelexplorer/widgets/Activator.java
@@ -23,7 +23,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
// The plug-in ID
- public static final String PLUGIN_ID = "org.eclipse.papyrus.modelexplorer.widgets"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.views.modelexplorer.widgets"; //$NON-NLS-1$
// The shared instance
private static Activator plugin;
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/.project b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/.project
index 14e921254d8..af06494370e 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/.project
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.modelexplorer</name>
+ <name>org.eclipse.papyrus.views.modelexplorer</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF
index 5619c45d774..62521142136 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF
@@ -3,22 +3,22 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.ui.navigator;bundle-version="3.4.0",
org.eclipse.papyrus.core;bundle-version="0.9.0";visibility:=reexport,
- org.eclipse.papyrus.log;bundle-version:="0.9.0",
+ org.eclipse.papyrus.log;bundle-version="0.9.0",
org.eclipse.emf.converter;bundle-version="2.5.0",
org.eclipse.papyrus.preferences;bundle-version="0.9.0",
org.eclipse.papyrus.sasheditor.di;bundle-version="0.9.0",
org.eclipse.ltk.core.refactoring;bundle-version="3.5.100",
- org.eclipse.emf.ecore.editor;bundle-version:="2.6.0",
+ org.eclipse.emf.ecore.editor;bundle-version="2.6.0",
org.eclipse.emf.workspace.ui;bundle-version="1.3.0",
org.eclipse.core.expressions;bundle-version="3.4.200",
org.eclipse.papyrus.service.edit;bundle-version="0.9.0",
org.eclipse.papyrus.validation;bundle-version="0.9.0",
- org.eclipse.emf.facet.infra.browser;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.browser.custom;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.browser.custom.core;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.browser.custom.ui;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.browser.uicore;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.common.core;bundle-version:="0.1.0",
+ org.eclipse.emf.facet.infra.browser;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.browser.custom;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.browser.custom.core;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.browser.custom.ui;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.common.core;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.facet;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.facet.core;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.query.ui;bundle-version="0.1.0",
@@ -42,6 +42,6 @@ Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.modelexplorer.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.modelexplorer;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.modelexplorer;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/src/org/eclipse/papyrus/modelexplorer/Activator.java b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/src/org/eclipse/papyrus/modelexplorer/Activator.java
index a2e5568e781..865c542ae0f 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/src/org/eclipse/papyrus/modelexplorer/Activator.java
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/src/org/eclipse/papyrus/modelexplorer/Activator.java
@@ -50,7 +50,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin implements org.eclipse.ui.IStartup {
/** The plug-in ID */
- public static final String PLUGIN_ID = "org.eclipse.papyrus.modelexplorer"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.views.modelexplorer"; //$NON-NLS-1$
/** The plug-in shared instance */
private static Activator plugin;
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/.project
index 1a9997c0c07..831044f61f7 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.model.edit</name>
+ <name>org.eclipse.papyrus.views.properties.model.edit</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/META-INF/MANIFEST.MF
index ec666f4ec1f..7c89f998370 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/META-INF/MANIFEST.MF
@@ -8,14 +8,13 @@ Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.papyrus.properties.model;bundle-version="0.9.0";visibility:=reexport,
+ org.eclipse.papyrus.views.properties.model;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.emf.edit;visibility:=reexport,
- org.eclipse.emf.ecore.edit;bundle-version:="2.7.0"
+ org.eclipse.emf.ecore.edit;bundle-version="2.7.0"
Bundle-Vendor: %providerName
Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.environment.provider.
PropertiesEditPlugin$Implementation
-Bundle-SymbolicName: org.eclipse.papyrus.properties.model.edit;singlet
- on:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties.model.edit;singleton:=true
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/.project
index 3f533233ef3..787e6aa3989 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.model.editor</name>
+ <name>org.eclipse.papyrus.views.properties.model.editor</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/META-INF/MANIFEST.MF
index 970980a3d76..31a98dbcf59 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/META-INF/MANIFEST.MF
@@ -9,7 +9,7 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.core.resources;visibility:=reexport,
- org.eclipse.papyrus.properties.model.edit;bundle-version="0.9.0";visibility:=reexport,
+ org.eclipse.papyrus.views.properties.model.edit;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.emf.ecore.xmi;visibility:=reexport,
org.eclipse.emf.edit.ui;visibility:=reexport,
org.eclipse.ui.ide;visibility:=reexport
@@ -18,6 +18,5 @@ Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.environment.presentat
ion.PropertiesEditorPlugin$Implementation
-Bundle-SymbolicName: org.eclipse.papyrus.properties.model.editor;singl
- eton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties.model.editor;singleton:=true
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.model/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties.model/.project
index 62138ff608c..bed8841d83b 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.model/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.model/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.model</name>
+ <name>org.eclipse.papyrus.views.properties.model</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.model/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.model/META-INF/MANIFEST.MF
index 442680d5a55..53031872320 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.model/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.model/META-INF/MANIFEST.MF
@@ -1,6 +1,6 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.emf.ecore;visibility:=reexport
+ org.eclipse.emf.ecore;bundle-version="2.7.0";visibility:=reexport
Export-Package: org.eclipse.papyrus.properties.contexts,
org.eclipse.papyrus.properties.contexts.impl,
org.eclipse.papyrus.properties.contexts.util,
@@ -17,7 +17,6 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.properties.model;singleton:=t
- rue
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties.model;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.model/Model/Properties.genmodel b/plugins/views/properties/org.eclipse.papyrus.views.properties.model/Model/Properties.genmodel
index 93e2bbf57b0..9a40605c513 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.model/Model/Properties.genmodel
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.model/Model/Properties.genmodel
@@ -1,10 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<genmodel:GenModel xmi:version="2.0"
xmlns:xmi="http://www.omg.org/XMI" xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore"
- xmlns:genmodel="http://www.eclipse.org/emf/2002/GenModel" modelDirectory="/org.eclipse.papyrus.properties.model/src-gen"
- editDirectory="/org.eclipse.papyrus.properties.model.edit/src-gen" editorDirectory="/org.eclipse.papyrus.properties.model.editor/src-gen"
- modelPluginID="org.eclipse.papyrus.properties.model" modelName="Properties" testsDirectory="/org.eclipse.papyrus.properties.model.tests/src-gen"
+ xmlns:genmodel="http://www.eclipse.org/emf/2002/GenModel" modelDirectory="/org.eclipse.papyrus.views.properties.model/src-gen"
+ editDirectory="/org.eclipse.papyrus.views.properties.model.edit/src-gen" editorDirectory="/org.eclipse.papyrus.views.properties.model.editor/src-gen"
+ modelPluginID="org.eclipse.papyrus.views.properties.model" modelName="Properties"
+ editorPluginClass="org.eclipse.papyrus.views.properties.environment.presentation.PropertiesEditorPlugin"
+ testsDirectory="/org.eclipse.papyrus.views.properties.model.tests/src-gen" testSuiteClass="org.eclipse.papyrus.views.properties.environment.tests.PropertiesAllTests"
importerID="org.eclipse.emf.importer.ecore" complianceLevel="5.0" copyrightFields="false"
+ editPluginID="org.eclipse.papyrus.views.properties.model.edit" editorPluginID="org.eclipse.papyrus.views.properties.model.editor"
usedGenPackages="platform:/plugin/org.eclipse.emf.ecore/model/Ecore.genmodel#//ecore">
<foreignModel>Properties.ecore</foreignModel>
<genPackages prefix="Properties" basePackage="org.eclipse.papyrus" disposableProviderFactory="true"
@@ -70,9 +73,6 @@
<genFeatures property="None" children="true" createChild="true" ecoreFeature="ecore:EReference Properties.ecore#//contexts/Context/tabs"/>
<genFeatures property="None" children="true" createChild="true" ecoreFeature="ecore:EReference Properties.ecore#//contexts/Context/views"/>
<genFeatures property="None" children="true" createChild="true" ecoreFeature="ecore:EReference Properties.ecore#//contexts/Context/dataContexts"/>
- <genFeatures createChild="false" ecoreFeature="ecore:EAttribute Properties.ecore#//contexts/Context/author"/>
- <genFeatures createChild="false" ecoreFeature="ecore:EAttribute Properties.ecore#//contexts/Context/description"/>
- <genFeatures createChild="false" ecoreFeature="ecore:EAttribute Properties.ecore#//contexts/Context/version"/>
</genClasses>
<genClasses image="false" ecoreClass="Properties.ecore#//contexts/DisplayUnit">
<genFeatures property="None" children="true" createChild="true" ecoreFeature="ecore:EReference Properties.ecore#//contexts/DisplayUnit/constraints"/>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/.project
index b8e684a66f8..d1fd94213c5 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.runtime</name>
+ <name>org.eclipse.papyrus.views.properties.runtime</name>
<comment></comment>
<projects>
<project>org.eclipse.papyrus.log</project>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/META-INF/MANIFEST.MF
index 963b4e5014e..d92734bbaee 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/META-INF/MANIFEST.MF
@@ -20,12 +20,12 @@ Require-Bundle: org.eclipse.ui;bundle-version="3.5.1",
org.eclipse.gmf.runtime.common.core;bundle-version="1.2.0",
org.eclipse.gmf.runtime.emf.commands.core;bundle-version="1.2.0",
org.eclipse.gmf.runtime.emf.core;bundle-version="1.2.0",
- org.eclipse.papyrus.log;bundle-version:="0.9.0",
+ org.eclipse.papyrus.log;bundle-version="0.9.0",
org.eclipse.gmf.runtime.common.ui;bundle-version="1.2.1",
org.eclipse.gmf.runtime.common.ui.services;bundle-version="1.2.0",
org.eclipse.uml2.uml.resources;bundle-version="3.1.0",
org.eclipse.emf.edit.ui;bundle-version="2.6.0",
- org.eclipse.uml2.uml;bundle-version:="3.1.0",
+ org.eclipse.uml2.uml;bundle-version="3.1.0",
org.eclipse.papyrus.core;bundle-version="0.9.0",
org.eclipse.papyrus.service.edit;bundle-version="0.9.0"
Bundle-Vendor: %providerName
@@ -35,7 +35,6 @@ Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.runtime.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.properties.runtime;singleton:
- =true
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties.runtime;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/src/org/eclipse/papyrus/properties/runtime/Activator.java b/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/src/org/eclipse/papyrus/properties/runtime/Activator.java
index 679b284b8aa..0f6d3a48021 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/src/org/eclipse/papyrus/properties/runtime/Activator.java
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/src/org/eclipse/papyrus/properties/runtime/Activator.java
@@ -13,7 +13,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
/** plugin ID */
- public static final String ID = "org.eclipse.papyrus.properties.runtime";
+ public static final String ID = "org.eclipse.papyrus.views.properties.runtime";
/** shared instance */
private static Activator plugin;
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/.project
index 0abe5f1581c..f09ff415438 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.tabbed.core</name>
+ <name>org.eclipse.papyrus.views.properties.tabbed.core</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/META-INF/MANIFEST.MF
index a60cce97534..8cd21af88ef 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/META-INF/MANIFEST.MF
@@ -6,8 +6,8 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.emf.edit.ui;bundle-version="2.6.0",
org.eclipse.gmf.runtime.common.core;bundle-version="1.2.0",
org.eclipse.gmf.runtime.common.ui;bundle-version="1.3.0",
- org.eclipse.papyrus.core;bundle-version:="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.core;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
org.eclipse.papyrus.log;bundle-version="0.9.0"
Export-Package: org.eclipse.papyrus.properties.tabbed.core,
org.eclipse.papyrus.properties.tabbed.core.provider,
@@ -20,7 +20,6 @@ Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.tabbed.core.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.properties.tabbed.core;single
- ton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties.tabbed.core;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/src/org/eclipse/papyrus/properties/tabbed/core/Activator.java b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/src/org/eclipse/papyrus/properties/tabbed/core/Activator.java
index 4bd0bdb0ba2..808a1978917 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/src/org/eclipse/papyrus/properties/tabbed/core/Activator.java
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/src/org/eclipse/papyrus/properties/tabbed/core/Activator.java
@@ -12,7 +12,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
/** identifier of the plugin */
- public static final String PLUGIN_ID = "org.eclipse.papyrus.properties.tabbed.core"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.views.properties.tabbed.core"; //$NON-NLS-1$
/** singleton instance of this plugin */
private static Activator plugin;
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/.project
index 7c1c7b176cc..c677c8570ab 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.tabbed.customization</name>
+ <name>org.eclipse.papyrus.views.properties.tabbed.customization</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/META-INF/MANIFEST.MF
index a202d783e9f..38ad03d2001 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/META-INF/MANIFEST.MF
@@ -2,17 +2,17 @@ Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.ui.views;bundle-version="3.5.0",
- org.eclipse.papyrus.properties.tabbed.core;bundle-version="0.9.0",
- org.eclipse.papyrus.log;bundle-version:="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.tabbed.core;bundle-version="0.9.0",
+ org.eclipse.papyrus.log;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.0",
org.eclipse.gmf.runtime.common.ui.services;bundle-version="1.3.0",
org.eclipse.emf.ecore;bundle-version="2.6.0",
- org.eclipse.emf.ecore.edit;bundle-version:="2.6.0",
+ org.eclipse.emf.ecore.edit;bundle-version="2.6.0",
org.eclipse.papyrus.core;bundle-version="0.9.0",
org.eclipse.uml2.uml;bundle-version="3.1.0",
- org.eclipse.papyrus.umlutils;bundle-version="0.9.0",
- org.apache.xml.serializer;bundle-version:="2.7.1",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0",
+ org.apache.xml.serializer;bundle-version="2.7.1",
org.apache.batik.xml;bundle-version="1.6.0",
org.apache.xml.resolver;bundle-version="1.2.0",
org.eclipse.emf.facet.infra.browser.custom;bundle-version="0.1.0",
@@ -31,7 +31,6 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.tabbed.customization.
Activator
-Bundle-SymbolicName: org.eclipse.papyrus.properties.tabbed.customizati
- on;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties.tabbed.customization;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_predefined_fragments.xml b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_predefined_fragments.xml
index 029b80b2346..dcb1513c777 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_predefined_fragments.xml
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_predefined_fragments.xml
@@ -1,5 +1,5 @@
<!--UML Basic fragment-->
-<fragments pluginId="org.eclipse.papyrus.properties.tabbed.customization">
+<fragments pluginId="org.eclipse.papyrus.views.properties.tabbed.customization">
<fragment id="fragment_single_ExpandableContainerDescriptorState">
<context enablesFor="1">
<elementClass name="org.eclipse.papyrus.properties.runtime.view.content.ExpandableContainerDescriptor$ExpandableContainerDescriptorState"/>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_wizards_dialogs.xml b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_wizards_dialogs.xml
index 294c4c4873a..e768a10acd5 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_wizards_dialogs.xml
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_wizards_dialogs.xml
@@ -1,5 +1,5 @@
<!-- Generic dialogs for UML elements -->
-<dialogs pluginId="org.eclipse.papyrus.properties.tabbed.customization">
+<dialogs pluginId="org.eclipse.papyrus.views.properties.tabbed.customization">
<dialog id="ControllerDescriptorEditorDialog"><!-- Dialog for single controller descriptor state -->
<context enablesFor="1">
<elementClass
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/src/org/eclipse/papyrus/properties/tabbed/customization/Activator.java b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/src/org/eclipse/papyrus/properties/tabbed/customization/Activator.java
index 2ebaf1ac740..f794d497bed 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/src/org/eclipse/papyrus/properties/tabbed/customization/Activator.java
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/src/org/eclipse/papyrus/properties/tabbed/customization/Activator.java
@@ -20,7 +20,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
/** plugin ID */
- public static final String ID = "org.eclipse.papyrus.properties.tabbed.customization"; //$NON-NLS-1$
+ public static final String ID = "org.eclipse.papyrus.views.properties.tabbed.customization"; //$NON-NLS-1$
/** singleton instance */
private static Activator plugin;
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/.project
index 56801250e50..657890eb11c 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.tabbedproperties.core</name>
+ <name>org.eclipse.papyrus.views.properties.tabbedproperties.core</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/META-INF/MANIFEST.MF
index 27c22735ed7..1fc4607e1b0 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/META-INF/MANIFEST.MF
@@ -10,7 +10,6 @@ Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.tabbedproperties.core.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.tabbedproperties.core;singlet
- on:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties.tabbedproperties.core;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/src/org/eclipse/papyrus/tabbedproperties/core/Activator.java b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/src/org/eclipse/papyrus/tabbedproperties/core/Activator.java
index 6bb38b6d001..d4690d31c61 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/src/org/eclipse/papyrus/tabbedproperties/core/Activator.java
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/src/org/eclipse/papyrus/tabbedproperties/core/Activator.java
@@ -24,7 +24,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
/** Plugin id */
- public static final String PLUGIN_ID = "org.eclipse.papyrus.tabbedproperties.core"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.views.properties.tabbedproperties.core"; //$NON-NLS-1$
/**
* singleton instance of this plugin.
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties/.project
index 32de1ef6467..45a258fc7ba 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties</name>
+ <name>org.eclipse.papyrus.views.properties</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF
index 34dc3e2fd9a..86d621dd72f 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF
@@ -22,7 +22,7 @@ Require-Bundle: com.ibm.icu,
org.eclipse.emf;bundle-version="2.6.0",
org.eclipse.emf.ecore;bundle-version="2.6.0",
org.eclipse.emf.ecore.xmi;bundle-version="2.5.0",
- org.eclipse.emf.databinding;bundle-version:="1.2.0",
+ org.eclipse.emf.databinding;bundle-version="1.2.0",
org.eclipse.equinox.common;bundle-version="3.6.0",
org.eclipse.ui;bundle-version="3.6.0",
org.eclipse.osgi;bundle-version="3.6.0",
@@ -33,20 +33,20 @@ Require-Bundle: com.ibm.icu,
org.eclipse.jface.databinding,
org.eclipse.core.databinding,
org.eclipse.core.databinding.property;bundle-version="1.3.0",
- org.eclipse.e4.xwt;bundle-version:="0.9.1",
+ org.eclipse.e4.xwt;bundle-version="0.9.1",
org.eclipse.e4.xwt.pde;bundle-version="0.9.1",
- org.eclipse.papyrus.properties.model;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.model;bundle-version="0.9.0",
org.eclipse.papyrus.service.edit;bundle-version="0.9.0",
org.eclipse.papyrus.widgets;bundle-version="0.9.0",
- org.eclipse.core.databinding.beans;bundle-version:="1.2.100",
- org.eclipse.emf.facet.infra.query;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.query.core;bundle-version:="0.1.0",
+ org.eclipse.core.databinding.beans;bundle-version="1.2.100",
+ org.eclipse.emf.facet.infra.query;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.query.core;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.common.core;bundle-version="0.1.0",
- org.eclipse.papyrus.modelexplorer.widgets;bundle-version="0.9.0"
+ org.eclipse.papyrus.views.modelexplorer.widgets;bundle-version="0.9.0"
Bundle-Vendor: %Bundle-Vendor
Bundle-Version: 0.9.0.qualifier
Eclipse-BuddyPolicy: dependent
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.properties;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties;singleton:=true
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.ecore b/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.ecore
index 86c708091b9..db6bf4c5e82 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.ecore
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.ecore
@@ -5,8 +5,8 @@
nsURI="http://www.eclipse.org/papyrus/properties/root" nsPrefix="root">
<eClassifiers xsi:type="ecore:EClass" name="PropertiesRoot">
<eStructuralFeatures xsi:type="ecore:EReference" name="environments" upperBound="-1"
- eType="ecore:EClass platform:/plugin/org.eclipse.papyrus.properties.model/Model/Properties.ecore#//environment/Environment"/>
+ eType="ecore:EClass platform:/plugin/org.eclipse.papyrus.views.properties.model/Model/Properties.ecore#//environment/Environment"/>
<eStructuralFeatures xsi:type="ecore:EReference" name="contexts" upperBound="-1"
- eType="ecore:EClass platform:/plugin/org.eclipse.papyrus.properties.model/Model/Properties.ecore#//contexts/Context"/>
+ eType="ecore:EClass platform:/plugin/org.eclipse.papyrus.views.properties.model/Model/Properties.ecore#//contexts/Context"/>
</eClassifiers>
</ecore:EPackage>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.genmodel b/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.genmodel
index 5e625276908..5cc9b093945 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.genmodel
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.genmodel
@@ -5,7 +5,7 @@
editDirectory="/org.eclipse.papyrus.properties.edit/src-gen" editorDirectory="/org.eclipse.papyrus.properties.editor/src-gen"
modelPluginID="org.eclipse.papyrus.properties" modelName="PropertiesRoot" testsDirectory="/org.eclipse.papyrus.properties.tests/src-gen"
importerID="org.eclipse.emf.importer.ecore" complianceLevel="5.0" copyrightFields="false"
- usedGenPackages="platform:/plugin/org.eclipse.papyrus.properties.model/Model/Properties.genmodel#//properties">
+ usedGenPackages="platform:/plugin/org.eclipse.papyrus.views.properties.model/Model/Properties.genmodel#//properties">
<foreignModel>PropertiesRoot.ecore</foreignModel>
<genPackages prefix="Root" basePackage="org.eclipse.papyrus.properties" disposableProviderFactory="true"
ecorePackage="PropertiesRoot.ecore#/">
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/plugin.xml b/plugins/views/properties/org.eclipse.papyrus.views.properties/plugin.xml
index 4b806121eb8..6a713b73446 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/plugin.xml
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/plugin.xml
@@ -25,7 +25,7 @@
point="org.eclipse.emf.ecore.uri_mapping">
<mapping
source="pathmap://PPEResources/"
- target="platform:/plugin/org.eclipse.papyrus.properties/model/">
+ target="platform:/plugin/org.eclipse.papyrus.views.properties/model/">
</mapping>
</extension>
<extension
@@ -33,7 +33,7 @@
<page
category="org.eclipse.papyrus.preferences.generalcategory"
class="org.eclipse.papyrus.properties.preferences.Preferences"
- id="org.eclipse.papyrus.properties.propertyview"
+ id="org.eclipse.papyrus.views.properties.propertyview"
name="%page.name">
</page>
</extension>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/context.exsd b/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/context.exsd
index 3dcdd57d811..deb4b5bbd2f 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/context.exsd
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/context.exsd
@@ -3,10 +3,10 @@
<schema targetNamespace="org.eclipse.papyrus.properties" xmlns="http://www.w3.org/2001/XMLSchema">
<annotation>
<appInfo>
- <meta.schema plugin="org.eclipse.papyrus.properties" id="Context" name="Context"/>
+ <meta.schema plugin="org.eclipse.papyrus.views.properties" id="Context" name="Context"/>
</appInfo>
<documentation>
- Extension point used to provide new Contexts to the Papyrus Property View. A Context is an EMF Model conforming to http://www.eclipse.org/papyrus/properties (From org.eclipse.papyrus.properties.model), defining a set of Constraint descriptors, and the view to display for each.
+ Extension point used to provide new Contexts to the Papyrus Property View. A Context is an EMF Model conforming to http://www.eclipse.org/papyrus/properties (From org.eclipse.papyrus.views.properties.model), defining a set of Constraint descriptors, and the view to display for each.
</documentation>
</annotation>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/environment.exsd b/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/environment.exsd
index 06d69b73b1d..63850650ed9 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/environment.exsd
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/environment.exsd
@@ -1,12 +1,12 @@
<?xml version='1.0' encoding='UTF-8'?>
<!-- Schema file written by PDE -->
-<schema targetNamespace="org.eclipse.papyrus.properties" xmlns="http://www.w3.org/2001/XMLSchema">
+<schema targetNamespace="org.eclipse.papyrus.views.properties" xmlns="http://www.w3.org/2001/XMLSchema">
<annotation>
<appInfo>
- <meta.schema plugin="org.eclipse.papyrus.properties" id="Environment" name="Environment"/>
+ <meta.schema plugin="org.eclipse.papyrus.views.properties" id="Environment" name="Environment"/>
</appInfo>
<documentation>
- Extension point used to provide new Environment to the Papyrus Property View. An Environment is an EMF Model conforming to http://www.eclipse.org/papyrus/properties/environment (From org.eclipse.papyrus.properties.model), defining a set of element descriptors (Widgets, Factories, ...), which can be used by the different Contexts to define new property views.
+ Extension point used to provide new Environment to the Papyrus Property View. An Environment is an EMF Model conforming to http://www.eclipse.org/papyrus/properties/environment (From org.eclipse.papyrus.views.properties.model), defining a set of element descriptors (Widgets, Factories, ...), which can be used by the different Contexts to define new property views.
</documentation>
</annotation>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/labelprovider.exsd b/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/labelprovider.exsd
index 6db00a591bc..da59dafcad0 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/labelprovider.exsd
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/labelprovider.exsd
@@ -1,9 +1,9 @@
<?xml version='1.0' encoding='UTF-8'?>
<!-- Schema file written by PDE -->
-<schema targetNamespace="org.eclipse.papyrus.properties" xmlns="http://www.w3.org/2001/XMLSchema">
+<schema targetNamespace="org.eclipse.papyrus.views.properties" xmlns="http://www.w3.org/2001/XMLSchema">
<annotation>
<appInfo>
- <meta.schema plugin="org.eclipse.papyrus.properties" id="labelprovider" name="labelprovider"/>
+ <meta.schema plugin="org.eclipse.papyrus.views.properties" id="labelprovider" name="labelprovider"/>
</appInfo>
<documentation>
[Enter description of this extension point.]
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/src/org/eclipse/papyrus/properties/Activator.java b/plugins/views/properties/org.eclipse.papyrus.views.properties/src/org/eclipse/papyrus/properties/Activator.java
index 8c6745c4ae2..2570b5461aa 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/src/org/eclipse/papyrus/properties/Activator.java
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/src/org/eclipse/papyrus/properties/Activator.java
@@ -28,7 +28,7 @@ public class Activator extends AbstractUIPlugin {
/**
* The plug-in ID
*/
- public static final String PLUGIN_ID = "org.eclipse.papyrus.properties"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.views.properties"; //$NON-NLS-1$
// The shared instance
private static Activator plugin;

Back to the top