Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/doc')
-rw-r--r--plugins/doc/org.eclipse.papyrus.dsml.validation.doc/META-INF/MANIFEST.MF5
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.doc/META-INF/MANIFEST.MF4
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.doc/build.properties1
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/firststeps.css3
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/graphics/newproject.pngbin3348 -> 0 bytes
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/graphics/newproject_hov.pngbin3348 -> 0 bytes
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/overview.css3
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.doc/intro/firststeps.xml12
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.doc/intro/overview.xml12
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.doc/plugin.xml35
-rw-r--r--plugins/doc/org.eclipse.papyrus.req.reqif.doc/META-INF/MANIFEST.MF4
11 files changed, 15 insertions, 64 deletions
diff --git a/plugins/doc/org.eclipse.papyrus.dsml.validation.doc/META-INF/MANIFEST.MF b/plugins/doc/org.eclipse.papyrus.dsml.validation.doc/META-INF/MANIFEST.MF
index 3a582ffdd47..8586762e356 100644
--- a/plugins/doc/org.eclipse.papyrus.dsml.validation.doc/META-INF/MANIFEST.MF
+++ b/plugins/doc/org.eclipse.papyrus.dsml.validation.doc/META-INF/MANIFEST.MF
@@ -1,8 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui;bundle-version="[3.107.0,4.0.0)",
- org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
- org.eclipse.papyrus.infra.doc;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.diagram.common.doc;bundle-version="[1.2.0,2.0.0)",
+Require-Bundle: org.eclipse.papyrus.infra.doc;bundle-version="[1.2.0,2.0.0)",
org.eclipse.help;bundle-version="[3.7.0,4.0.0)"
Bundle-Vendor: %vendorName
Bundle-ActivationPolicy: lazy
diff --git a/plugins/doc/org.eclipse.papyrus.infra.doc/META-INF/MANIFEST.MF b/plugins/doc/org.eclipse.papyrus.infra.doc/META-INF/MANIFEST.MF
index fe3bbb58da9..12c093c602d 100644
--- a/plugins/doc/org.eclipse.papyrus.infra.doc/META-INF/MANIFEST.MF
+++ b/plugins/doc/org.eclipse.papyrus.infra.doc/META-INF/MANIFEST.MF
@@ -1,7 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.help;bundle-version="[3.7.0,4.0.0)",
- org.eclipse.ui.intro;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.pde.ui;bundle-version="[3.9.0,4.0.0)"
+Require-Bundle: org.eclipse.help;bundle-version="[3.7.0,4.0.0)"
Bundle-Vendor: %Bundle-Vendor
Bundle-Version: 1.2.0.qualifier
Bundle-Name: %Bundle-Name
diff --git a/plugins/doc/org.eclipse.papyrus.infra.doc/build.properties b/plugins/doc/org.eclipse.papyrus.infra.doc/build.properties
index dcb5ebc16cd..7243208e2c4 100644
--- a/plugins/doc/org.eclipse.papyrus.infra.doc/build.properties
+++ b/plugins/doc/org.eclipse.papyrus.infra.doc/build.properties
@@ -1,7 +1,6 @@
bin.includes = META-INF/,\
plugin.xml,\
OSGI-INF/,\
- intro/,\
toc.xml,\
about.html,\
resource/
diff --git a/plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/firststeps.css b/plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/firststeps.css
deleted file mode 100644
index 74f9c98b8e7..00000000000
--- a/plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/firststeps.css
+++ /dev/null
@@ -1,3 +0,0 @@
-
-a#newpapyrusproject-introLink img { background-image : url(graphics/newproject.png); }
-a#newpapyrusproject-introLink:hover img { background-image : url(graphics/newproject_hov.png); } \ No newline at end of file
diff --git a/plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/graphics/newproject.png b/plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/graphics/newproject.png
deleted file mode 100644
index 1a6ee9b632f..00000000000
--- a/plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/graphics/newproject.png
+++ /dev/null
Binary files differ
diff --git a/plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/graphics/newproject_hov.png b/plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/graphics/newproject_hov.png
deleted file mode 100644
index 1a6ee9b632f..00000000000
--- a/plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/graphics/newproject_hov.png
+++ /dev/null
Binary files differ
diff --git a/plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/overview.css b/plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/overview.css
deleted file mode 100644
index 74f9c98b8e7..00000000000
--- a/plugins/doc/org.eclipse.papyrus.infra.doc/intro/css/overview.css
+++ /dev/null
@@ -1,3 +0,0 @@
-
-a#newpapyrusproject-introLink img { background-image : url(graphics/newproject.png); }
-a#newpapyrusproject-introLink:hover img { background-image : url(graphics/newproject_hov.png); } \ No newline at end of file
diff --git a/plugins/doc/org.eclipse.papyrus.infra.doc/intro/firststeps.xml b/plugins/doc/org.eclipse.papyrus.infra.doc/intro/firststeps.xml
deleted file mode 100644
index 9d84d6b5484..00000000000
--- a/plugins/doc/org.eclipse.papyrus.infra.doc/intro/firststeps.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="utf-8" ?>
-<introContent>
- <extensionContent id="org.eclipse.team.papyrus.firststeps" name="Papyrus First Steps" style="css/firststeps.css" path="firststeps/@">
- <group label="Papyrus" style-id="content-group" id="org.eclipse.papyrus-firststeps-group">
- <link label="New Papyrus Project"
- url="http://org.eclipse.ui.intro/runAction?pluginId=org.eclipse.papyrus.uml.diagram.wizards&#38;class=org.eclipse.papyrus.uml.diagram.wizards.NewProjectAction"
- id="newpapyrusproject-introLink" style-id="content-link">
- <text>Start with creation of new Papyrus project</text>
- </link>
- </group>
- </extensionContent>
-</introContent> \ No newline at end of file
diff --git a/plugins/doc/org.eclipse.papyrus.infra.doc/intro/overview.xml b/plugins/doc/org.eclipse.papyrus.infra.doc/intro/overview.xml
deleted file mode 100644
index 6d8ef3b5184..00000000000
--- a/plugins/doc/org.eclipse.papyrus.infra.doc/intro/overview.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="utf-8" ?>
-<introContent>
- <extensionContent id="org.eclipse.team.papyrus.overview" name="Papyrus overview" style="css/overview.css" path="overview/@">
- <group style-id="content-group" id="org.eclipse.papyrus-firststeps-group">
- <link label="New Papyrus Project"
- url="http://org.eclipse.ui.intro/runAction?pluginId=org.eclipse.papyrus.uml.diagram.wizards&#38;class=org.eclipse.papyrus.uml.diagram.wizards.NewProjectAction"
- id="newpapyrusproject-introLink" style-id="content-link">
- <text>Start with creation of new Papyrus project</text>
- </link>
- </group>
- </extensionContent>
-</introContent> \ No newline at end of file
diff --git a/plugins/doc/org.eclipse.papyrus.infra.doc/plugin.xml b/plugins/doc/org.eclipse.papyrus.infra.doc/plugin.xml
index fb0251c8839..c3d81ff54f4 100644
--- a/plugins/doc/org.eclipse.papyrus.infra.doc/plugin.xml
+++ b/plugins/doc/org.eclipse.papyrus.infra.doc/plugin.xml
@@ -1,23 +1,12 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.4"?>
-<plugin>
- <extension
- point="org.eclipse.ui.intro.configExtension">
- <configExtension
- configId="org.eclipse.ui.intro.universalConfig"
- content="intro/firststeps.xml">
- </configExtension>
- <configExtension
- configId="org.eclipse.ui.intro.universalConfig"
- content="intro/overview.xml">
- </configExtension>
- </extension>
- <extension
- point="org.eclipse.help.toc">
- <toc
- category="org.eclipse.papyrus"
- file="toc.xml"
- primary="true">
- </toc>
- </extension>
-</plugin>
+<?xml version="1.0" encoding="UTF-8"?>
+<?eclipse version="3.4"?>
+<plugin>
+ <extension
+ point="org.eclipse.help.toc">
+ <toc
+ category="org.eclipse.papyrus"
+ file="toc.xml"
+ primary="true">
+ </toc>
+ </extension>
+</plugin>
diff --git a/plugins/doc/org.eclipse.papyrus.req.reqif.doc/META-INF/MANIFEST.MF b/plugins/doc/org.eclipse.papyrus.req.reqif.doc/META-INF/MANIFEST.MF
index d3cae19b204..2aca4a40292 100644
--- a/plugins/doc/org.eclipse.papyrus.req.reqif.doc/META-INF/MANIFEST.MF
+++ b/plugins/doc/org.eclipse.papyrus.req.reqif.doc/META-INF/MANIFEST.MF
@@ -1,7 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui;bundle-version="[3.107.0,4.0.0)",
- org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
- org.eclipse.help;bundle-version="[3.7.0,4.0.0)",
+Require-Bundle: org.eclipse.help;bundle-version="[3.7.0,4.0.0)",
org.eclipse.papyrus.infra.doc;bundle-version="[1.2.0,2.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy

Back to the top