Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/customization')
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.palette/.project2
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.palette/META-INF/MANIFEST.MF20
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/.project2
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/META-INF/MANIFEST.MF9
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/src/org/eclipse/papyrus/paletteconfiguration/customization/Activator.java6
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties.generation/.project2
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties.generation/META-INF/MANIFEST.MF11
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties.generation/src/org/eclipse/papyrus/properties/generation/Activator.java2
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/.project2
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/META-INF/MANIFEST.MF11
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/src/org/eclipse/papyrus/properties/model/xwt/Activator.java4
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties/.project2
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties/META-INF/MANIFEST.MF19
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties/UICustom/context.uiCustom4
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties/plugin.xml42
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties/src/org/eclipse/papyrus/properties/customization/Activator.java8
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization/META-INF/MANIFEST.MF14
17 files changed, 78 insertions, 82 deletions
diff --git a/plugins/customization/org.eclipse.papyrus.customization.palette/.project b/plugins/customization/org.eclipse.papyrus.customization.palette/.project
index dc69a91d19d..cdc3f107099 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.palette/.project
+++ b/plugins/customization/org.eclipse.papyrus.customization.palette/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.diagram.common.palette.customization</name>
+ <name>org.eclipse.papyrus.customization.palette</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/customization/org.eclipse.papyrus.customization.palette/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.palette/META-INF/MANIFEST.MF
index 0a2f1fa900d..538438716ce 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.palette/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.palette/META-INF/MANIFEST.MF
@@ -1,27 +1,25 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.pde;bundle-version="3.6.0",
org.eclipse.pde.ui;bundle-version="3.6.0",
- org.eclipse.papyrus.paletteconfiguration;bundle-version="0.9.0",
- org.eclipse.emf.facet.infra.browser;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.browser.custom;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.browser.uicore;bundle-version:="0.1.0",
+ org.eclipse.papyrus.uml.diagram.paletteconfiguration;bundle-version="0.9.0",
+ org.eclipse.emf.facet.infra.browser;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.browser.custom;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.facet.core;bundle-version="0.1.0",
- org.eclipse.emf.facet.infra.browser.custom.core;bundle-version:="0.1.0",
- org.eclipse.papyrus.paletteconfiguration.customization;bundle-version:="0.9.0",
- org.eclipse.emf.facet.infra.common.core;bundle-version:="0.1.0"
+ org.eclipse.emf.facet.infra.browser.custom.core;bundle-version="0.1.0",
+ org.eclipse.papyrus.customization.paletteconfiguration;bundle-version="0.9.0",
+ org.eclipse.emf.facet.infra.common.core;bundle-version="0.1.0"
Export-Package: org.eclipse.papyrus.diagram.common.palette.customization,
org.eclipse.papyrus.diagram.common.palette.customization.dialog,
org.eclipse.papyrus.diagram.common.palette.customization.proxies,
org.eclipse.papyrus.diagram.common.part
Bundle-Vendor: %providerName
-Fragment-Host: org.eclipse.papyrus.diagram.common;bundle-version="0.8.
- 0"
+Fragment-Host: org.eclipse.papyrus.uml.diagram.common;bundle-version="0.8.0"
Eclipse-PatchFragment: true
Bundle-ClassPath: .
Bundle-Version: 0.9.0.qualifier
Bundle-Name: %fragmentName
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.diagram.common.palette.custom
- ization;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.customization.palette;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/.project b/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/.project
index 6d5b26d9c7e..31a4c55ab3a 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/.project
+++ b/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.paletteconfiguration.customization</name>
+ <name>org.eclipse.papyrus.customization.paletteconfiguration</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/META-INF/MANIFEST.MF
index 63402da8a50..cc7c66d9dae 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/META-INF/MANIFEST.MF
@@ -1,12 +1,12 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui;bundle-version="3.7.0",
org.eclipse.core.runtime;bundle-version="3.7.0",
- org.eclipse.papyrus.paletteconfiguration;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.diagram.paletteconfiguration;bundle-version="0.9.0",
org.eclipse.uml2.uml;bundle-version="3.2.0",
org.eclipse.emf.facet.infra.query.core;bundle-version="0.1.0",
org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.4.0",
- org.eclipse.papyrus.extendedtypes;bundle-version="0.9.0",
- org.eclipse.papyrus.paletteconfiguration.edit;bundle-version="0.9.0"
+ org.eclipse.papyrus.infra.extendedtypes;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.diagram.paletteconfiguration.edit;bundle-version="0.9.0"
Export-Package: org.eclipse.papyrus.paletteconfiguration.customization,
org.eclipse.papyrus.paletteconfiguration.customization.queries
Bundle-Vendor: %Bundle-Vendor
@@ -16,7 +16,6 @@ Bundle-Name: %Bundle-Name
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.paletteconfiguration.customizati
on.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.paletteconfiguration.customiz
- ation;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.customization.paletteconfiguration;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/src/org/eclipse/papyrus/paletteconfiguration/customization/Activator.java b/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/src/org/eclipse/papyrus/paletteconfiguration/customization/Activator.java
index e1754f0807b..947eea2ca17 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/src/org/eclipse/papyrus/paletteconfiguration/customization/Activator.java
+++ b/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/src/org/eclipse/papyrus/paletteconfiguration/customization/Activator.java
@@ -9,11 +9,11 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
// The plug-in ID
- public static final String PLUGIN_ID = "org.eclipse.papyrus.paletteconfiguration.customization"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.customization.paletteconfiguration"; //$NON-NLS-1$
// The shared instance
private static Activator plugin;
-
+
/**
* The constructor
*/
@@ -24,6 +24,7 @@ public class Activator extends AbstractUIPlugin {
* (non-Javadoc)
* @see org.eclipse.ui.plugin.AbstractUIPlugin#start(org.osgi.framework.BundleContext)
*/
+ @Override
public void start(BundleContext context) throws Exception {
super.start(context);
plugin = this;
@@ -33,6 +34,7 @@ public class Activator extends AbstractUIPlugin {
* (non-Javadoc)
* @see org.eclipse.ui.plugin.AbstractUIPlugin#stop(org.osgi.framework.BundleContext)
*/
+ @Override
public void stop(BundleContext context) throws Exception {
plugin = null;
super.stop(context);
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties.generation/.project b/plugins/customization/org.eclipse.papyrus.customization.properties.generation/.project
index cd8057fbd22..e94613a0d4e 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties.generation/.project
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties.generation/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.generation</name>
+ <name>org.eclipse.papyrus.customization.properties.generation</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties.generation/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.properties.generation/META-INF/MANIFEST.MF
index efdda0a9d71..515951ef732 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties.generation/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties.generation/META-INF/MANIFEST.MF
@@ -15,21 +15,20 @@ Require-Bundle: org.eclipse.ui;bundle-version="3.6.1",
org.eclipse.papyrus.views.properties.model;bundle-version="0.9.0",
org.eclipse.m2m.qvt.oml;bundle-version="3.0.1",
org.eclipse.m2m.qvt.oml.common;bundle-version="2.1.0",
- org.eclipse.papyrus.log;bundle-version:="0.9.0",
- org.eclipse.papyrus.views.properties.model.edit;bundle-version:="0.9.0",
+ org.eclipse.papyrus.infra.log;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.model.edit;bundle-version="0.9.0",
org.eclipse.emf.common.ui;bundle-version="2.6.0",
org.eclipse.core.resources;bundle-version="3.6.0",
- org.eclipse.uml2.uml;bundle-version:="3.1.1",
+ org.eclipse.uml2.uml;bundle-version="3.1.1",
org.eclipse.papyrus.views.properties;bundle-version="0.9.0",
org.eclipse.core.databinding;bundle-version="1.3.100",
org.eclipse.emf.databinding;bundle-version="1.2.0",
org.eclipse.core.databinding.property;bundle-version="1.3.0",
- org.eclipse.papyrus.properties.model.xwt;bundle-version="0.9.0"
+ org.eclipse.papyrus.customization.properties.model.xwt;bundle-version="0.9.0"
Bundle-Vendor: %Bundle-Vendor
Bundle-Version: 0.9.0.qualifier
Eclipse-BuddyPolicy: dependent
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.generation.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.properties.generation;singlet
- on:=true
+Bundle-SymbolicName: org.eclipse.papyrus.customization.properties.generation;singleton:=true
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties.generation/src/org/eclipse/papyrus/properties/generation/Activator.java b/plugins/customization/org.eclipse.papyrus.customization.properties.generation/src/org/eclipse/papyrus/properties/generation/Activator.java
index 6c1b86b7874..158d0312089 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties.generation/src/org/eclipse/papyrus/properties/generation/Activator.java
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties.generation/src/org/eclipse/papyrus/properties/generation/Activator.java
@@ -27,7 +27,7 @@ public class Activator extends AbstractUIPlugin {
public static LogHelper log;
/** The plug-in ID */
- public static final String PLUGIN_ID = "org.eclipse.papyrus.properties.generation"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.customization.properties.generation"; //$NON-NLS-1$
// The shared instance
private static Activator plugin;
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/.project b/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/.project
index 80d74c84a52..c5803e5dca0 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/.project
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.model.xwt</name>
+ <name>org.eclipse.papyrus.customization.properties.model.xwt</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/META-INF/MANIFEST.MF
index dd6e46eb200..020b36c2a7e 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/META-INF/MANIFEST.MF
@@ -2,12 +2,12 @@ Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.m2m.qvt.oml;bundle-version="3.1.0",
- org.eclipse.gmt.modisco.xml;bundle-version:="0.9.0",
- org.eclipse.gmt.modisco.xml.discoverer;bundle-version:="0.9.0",
+ org.eclipse.gmt.modisco.xml;bundle-version="0.9.0",
+ org.eclipse.gmt.modisco.xml.discoverer;bundle-version="0.9.0",
org.eclipse.papyrus.views.properties;bundle-version="0.9.0",
org.eclipse.papyrus.views.properties.model;bundle-version="0.9.0",
- org.eclipse.papyrus.log;bundle-version="0.9.0",
- org.eclipse.wst.xml.core;bundle-version:="1.1.600",
+ org.eclipse.papyrus.infra.log;bundle-version="0.9.0",
+ org.eclipse.wst.xml.core;bundle-version="1.1.600",
org.eclipse.core.resources;bundle-version="3.7.100"
Export-Package: org.eclipse.papyrus.properties.model.xwt.resource
Bundle-Vendor: %Bundle-Vendor
@@ -16,7 +16,6 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.model.xwt.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.properties.model.xwt;singleto
- n:=true
+Bundle-SymbolicName: org.eclipse.papyrus.customization.properties.model.xwt;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/src/org/eclipse/papyrus/properties/model/xwt/Activator.java b/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/src/org/eclipse/papyrus/properties/model/xwt/Activator.java
index 98cc20ffb97..59c1c41c9a2 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/src/org/eclipse/papyrus/properties/model/xwt/Activator.java
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/src/org/eclipse/papyrus/properties/model/xwt/Activator.java
@@ -1,6 +1,6 @@
/*****************************************************************************
* Copyright (c) 2011 CEA LIST.
- *
+ *
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License v1.0
* which accompanies this distribution, and is available at
@@ -23,7 +23,7 @@ public class Activator extends AbstractUIPlugin {
/**
* The plug-in ID
*/
- public static final String PLUGIN_ID = "org.eclipse.papyrus.properties.model.xwt"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.customization.properties.model.xwt"; //$NON-NLS-1$
// The shared instance
private static Activator plugin;
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties/.project b/plugins/customization/org.eclipse.papyrus.customization.properties/.project
index 9df55dfd397..08da554bbc0 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties/.project
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.customization</name>
+ <name>org.eclipse.papyrus.customization.properties</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.properties/META-INF/MANIFEST.MF
index 902e50480de..6b56adb96b4 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties/META-INF/MANIFEST.MF
@@ -1,14 +1,14 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.core.resources;bundle-version:="3.6.0",
- org.eclipse.core.databinding.observable;bundle-version:="1.3.0",
- org.eclipse.ui.views.properties.tabbed;bundle-version:="3.5.100",
- org.eclipse.papyrus.log;bundle-version="0.9.0",
- org.eclipse.papyrus.widgets;bundle-version="0.9.0",
- org.eclipse.papyrus.diagram.common;bundle-version="0.9.0",
+ org.eclipse.core.resources;bundle-version="3.6.0",
+ org.eclipse.core.databinding.observable;bundle-version="1.3.0",
+ org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.100",
+ org.eclipse.papyrus.infra.log;bundle-version="0.9.0",
+ org.eclipse.papyrus.infra.widgets;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="0.9.0",
org.eclipse.papyrus.views.properties;bundle-version:="0.9.0",
org.eclipse.papyrus.views.properties.model;bundle-version:="0.9.0",
- org.eclipse.papyrus.properties.model.xwt;bundle-version:="0.9.0",
+ org.eclipse.papyrus.customization.properties.model.xwt;bundle-version="0.9.0",
org.eclipse.emf.ecore.editor;bundle-version="2.6.0",
org.eclipse.emf.facet.infra.facet.core;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0",
@@ -17,7 +17,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.emf.facet.infra.query.core;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.facet;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.common.core;bundle-version="0.1.0",
- org.eclipse.emf.databinding;bundle-version:="1.2.0"
+ org.eclipse.emf.databinding;bundle-version="1.2.0"
Export-Package: org.eclipse.papyrus.properties.customization.editor,
org.eclipse.papyrus.properties.customization.modelelement,
org.eclipse.papyrus.properties.customization.providers
@@ -30,7 +30,6 @@ Bundle-Name: %Bundle-Name
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.customization.Activat
or
-Bundle-SymbolicName: org.eclipse.papyrus.properties.customization;sing
- leton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.customization.properties;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties/UICustom/context.uiCustom b/plugins/customization/org.eclipse.papyrus.customization.properties/UICustom/context.uiCustom
index 3c8fd121efe..76b5a18db6a 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties/UICustom/context.uiCustom
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties/UICustom/context.uiCustom
@@ -18,7 +18,7 @@
</references>
<references referenceName="views">
<customizedFeatures customizedFeature="icon">
- <defaultValue xsi:type="uicustom:StaticFeatureValue" value="/org.eclipse.papyrus.properties.customization/icons/MultiView.gif"/>
+ <defaultValue xsi:type="uicustom:StaticFeatureValue" value="/org.eclipse.papyrus.customization.properties/icons/MultiView.gif"/>
</customizedFeatures>
<customizedFeatures customizedFeature="label">
<defaultValue xsi:type="uicustom:StaticFeatureValue" value="Views"/>
@@ -36,7 +36,7 @@
</defaultValue>
</customizedFeatures>
<customizedFeatures customizedFeature="icon">
- <defaultValue xsi:type="uicustom:StaticFeatureValue" value="/org.eclipse.papyrus.properties.customization/icons/DataContexts.gif"/>
+ <defaultValue xsi:type="uicustom:StaticFeatureValue" value="/org.eclipse.papyrus.customization.properties/icons/DataContexts.gif"/>
</customizedFeatures>
<customizedFeatures customizedFeature="label">
<defaultValue xsi:type="uicustom:StaticFeatureValue" value="Data contexts"/>
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties/plugin.xml b/plugins/customization/org.eclipse.papyrus.customization.properties/plugin.xml
index f093ff622c5..4e60d371c66 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties/plugin.xml
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties/plugin.xml
@@ -22,11 +22,11 @@
</modelqueryset>
</extension>
<extension point="org.eclipse.ui.editors">
- <editor class="org.eclipse.papyrus.properties.customization.editor.UIEditor" contributorClass="org.eclipse.papyrus.properties.customization.editor.ContextEditorActionBarContributor" default="true" extensions="ctx" icon="platform:/plugin/org.eclipse.papyrus.views.properties.model.edit/icons/full/obj16/Context.gif" id="org.eclipse.papyrus.property.customization.UIEditor" name="%editor.name">
+ <editor class="org.eclipse.papyrus.properties.customization.editor.UIEditor" contributorClass="org.eclipse.papyrus.properties.customization.editor.ContextEditorActionBarContributor" default="true" extensions="ctx" icon="platform:/plugin/org.eclipse.papyrus.views.properties.model.edit/icons/full/obj16/Context.gif" id="org.eclipse.papyrus.customization.properties.UIEditor" name="%editor.name">
</editor>
</extension>
<extension point="org.eclipse.emf.ecore.uri_mapping">
- <mapping source="pathmap://PPECustom/" target="platform:/plugin/org.eclipse.papyrus.properties.customization/Model/">
+ <mapping source="pathmap://PPECustom/" target="platform:/plugin/org.eclipse.papyrus.customization.properties/Model/">
</mapping>
</extension>
<extension point="org.eclipse.papyrus.properties.environment">
@@ -48,7 +48,7 @@
category="org.eclipse.papyrus.views.category"
class="org.eclipse.papyrus.properties.customization.editor.preview.Preview"
icon="icons/preview.png"
- id="org.eclipse.papyrus.properties.customization.preview"
+ id="org.eclipse.papyrus.customization.properties.preview"
name="%view.name"
restorable="true">
</view>
@@ -58,7 +58,7 @@
<perspective
class="org.eclipse.papyrus.properties.customization.perspective.CustomizationPerspectiveFactory"
icon="icons/Customization.gif"
- id="org.eclipse.papyrus.properties.customization.perspective"
+ id="org.eclipse.papyrus.customization.properties.perspective"
name="%perspective.name">
</perspective>
</extension>
@@ -73,7 +73,7 @@
<page
category="org.eclipse.papyrus.preferences.generalcategory"
class="org.eclipse.papyrus.properties.customization.preferences.CustomizationPreferencePage"
- id="org.eclipse.papyrus.properties.customization.preferences"
+ id="org.eclipse.papyrus.customization.properties.preferences"
name="%page.name">
</page>
</extension>
@@ -81,27 +81,27 @@
point="org.eclipse.ui.handlers">
<handler
class="org.eclipse.papyrus.properties.customization.ui.OpenCustomization"
- commandId="org.eclipse.papyrus.properties.customization.customize">
+ commandId="org.eclipse.papyrus.customization.properties.customize">
</handler>
<handler
class="org.eclipse.papyrus.properties.customization.editor.actions.TogglePreviewAction"
- commandId="org.eclipse.papyrus.properties.customization.TogglePreview">
+ commandId="org.eclipse.papyrus.customization.properties.TogglePreview">
</handler>
<handler
class="org.eclipse.papyrus.properties.customization.editor.actions.ToggleDataContextAction"
- commandId="org.eclipse.papyrus.properties.customization.ToggleDataContext">
+ commandId="org.eclipse.papyrus.customization.properties.ToggleDataContext">
</handler>
</extension>
<extension
point="org.eclipse.ui.commands">
<command
description="%command.description"
- id="org.eclipse.papyrus.properties.customization.customize"
+ id="org.eclipse.papyrus.customization.properties.customize"
name="%command.name">
</command>
<command
description="%command.description.0"
- id="org.eclipse.papyrus.properties.customization.TogglePreview"
+ id="org.eclipse.papyrus.customization.properties.TogglePreview"
name="%command.name.0">
<state
class="org.eclipse.papyrus.properties.customization.editor.actions.TogglePreviewState"
@@ -110,11 +110,11 @@
</command>
<command
description="%command.description.1"
- id="org.eclipse.papyrus.properties.customization.ToggleDataContext"
+ id="org.eclipse.papyrus.customization.properties.ToggleDataContext"
name="%command.name.1">
<state
class="org.eclipse.papyrus.properties.customization.editor.actions.ToggleDataContextState"
- id="org.eclipse.papyrus.properties.customization.displayContextState">
+ id="org.eclipse.papyrus.customizatio.propertiesn.displayContextState">
</state>
</command>
</extension>
@@ -124,9 +124,9 @@
allPopups="false"
locationURI="menu:org.eclipse.ui.views.PropertySheet">
<command
- commandId="org.eclipse.papyrus.properties.customization.customize"
+ commandId="org.eclipse.papyrus.customization.properties.customize"
icon="icons/Customization.gif"
- id="org.eclipse.papyrus.properties.customization.customizehandler"
+ id="org.eclipse.papyrus.customization.properties.customizehandler"
label="%customize.command.label"
mnemonic="%customize.command.mnemonic"
mode="FORCE_TEXT"
@@ -141,12 +141,12 @@
allPopups="false"
locationURI="toolbar:org.eclipse.ui.main.toolbar">
<toolbar
- id="org.eclipes.papyrus.properties.customization"
+ id="org.eclipes.papyrus.customization.properties"
label="%toolbar.label">
<command
- commandId="org.eclipse.papyrus.properties.customization.TogglePreview"
+ commandId="org.eclipse.papyrus.customization.properties.TogglePreview"
icon="icons/preview.png"
- id="org.eclipse.papyrus.properties.customization.togglePreview"
+ id="org.eclipse.papyrus.customization.properties.togglePreview"
label="%command.label"
style="toggle"
tooltip="%command.tooltip">
@@ -154,15 +154,15 @@
<with
variable="activeEditorId">
<equals
- value="org.eclipse.papyrus.property.customization.UIEditor">
+ value="org.eclipse.papyrus.customization.properties.UIEditor">
</equals>
</with>
</visibleWhen>
</command>
<command
- commandId="org.eclipse.papyrus.properties.customization.ToggleDataContext"
+ commandId="org.eclipse.papyrus.customization.properties.ToggleDataContext"
icon="icons/DataContexts.gif"
- id="org.eclipse.papyrus.properties.customization.toggleDataContext"
+ id="org.eclipse.papyrus.customization.properties.toggleDataContext"
label="%command.label.0"
style="toggle"
tooltip="%command.tooltip.0">
@@ -170,7 +170,7 @@
<with
variable="activeEditorId">
<equals
- value="org.eclipse.papyrus.property.customization.UIEditor">
+ value="org.eclipse.papyrus.customization.properties.UIEditor">
</equals>
</with>
</visibleWhen>
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties/src/org/eclipse/papyrus/properties/customization/Activator.java b/plugins/customization/org.eclipse.papyrus.customization.properties/src/org/eclipse/papyrus/properties/customization/Activator.java
index a029c48212a..6724079c389 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties/src/org/eclipse/papyrus/properties/customization/Activator.java
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties/src/org/eclipse/papyrus/properties/customization/Activator.java
@@ -1,6 +1,6 @@
/*****************************************************************************
* Copyright (c) 2010 CEA LIST.
- *
+ *
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License v1.0
* which accompanies this distribution, and is available at
@@ -31,17 +31,17 @@ public class Activator extends AbstractUIPlugin {
/**
* The plug-in ID
*/
- public static final String PLUGIN_ID = "org.eclipse.papyrus.properties.customization"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.customization.properties"; //$NON-NLS-1$
/**
* The Preview view ID
*/
- public static final String PREVIEW_ID = "org.eclipse.papyrus.properties.customization.preview"; //$NON-NLS-1$
+ public static final String PREVIEW_ID = "org.eclipse.papyrus.customization.properties.preview"; //$NON-NLS-1$
/**
* The Customization perspective ID
*/
- public static final String CUSTOMIZATION_PERSPECTIVE_ID = "org.eclipse.papyrus.properties.customization.perspective"; //$NON-NLS-1$
+ public static final String CUSTOMIZATION_PERSPECTIVE_ID = "org.eclipse.papyrus.customization.properties.perspective"; //$NON-NLS-1$
// The shared instance
private static Activator plugin;
diff --git a/plugins/customization/org.eclipse.papyrus.customization/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization/META-INF/MANIFEST.MF
index 91c8744c564..43152e852ce 100644
--- a/plugins/customization/org.eclipse.papyrus.customization/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization/META-INF/MANIFEST.MF
@@ -8,22 +8,22 @@ Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.ui;bundle-version:="3.7.0",
+ org.eclipse.ui;bundle-version="3.7.0",
org.eclipse.emf.ecore,
org.eclipse.pde;bundle-version="3.6.100",
org.eclipse.core.resources;bundle-version="3.7.100",
org.eclipse.pde.core;bundle-version="3.7.0",
- org.eclipse.papyrus.log;bundle-version:="0.9.0",
+ org.eclipse.papyrus.infra.log;bundle-version="0.9.0",
org.eclipse.papyrus.views.properties;bundle-version="0.9.0",
org.eclipse.pde.ui;bundle-version="3.6.100",
- org.eclipse.ui.ide;bundle-version:="3.7.0",
- org.eclipse.papyrus.views.properties.model;bundle-version:="0.9.0",
+ org.eclipse.ui.ide;bundle-version="3.7.0",
org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.200",
- org.eclipse.papyrus.widgets;bundle-version="0.9.0",
+ org.eclipse.papyrus.infra.widgets;bundle-version="0.9.0",
org.eclipse.papyrus.eclipse.project.editors;bundle-version="0.9.0",
org.eclipse.core.databinding;bundle-version="1.4.0",
- org.eclipse.emf.edit;bundle-version:="2.7.0",
- org.eclipse.emf.databinding;bundle-version="1.2.0"
+ org.eclipse.emf.edit;bundle-version="2.7.0",
+ org.eclipse.emf.databinding;bundle-version="1.2.0",
+ org.eclipse.papyrus.views.properties.model;bundle-version="0.9.0"
Bundle-Vendor: %providerName
Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2

Back to the top