Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'features')
-rw-r--r--features/papyrus-main-features/org.eclipse.papyrus.doc.feature/feature.xml6
-rw-r--r--features/papyrus-main-features/org.eclipse.papyrus.sdk.feature/feature.xml8
-rw-r--r--features/papyrus-tests-features/org.eclipse.papyrus.tests.uml.diagram.feature/feature.xml9
-rwxr-xr-xfeatures/papyrus-tests-features/pom.xml2
-rw-r--r--features/papyrus-toolsmiths-features/org.eclipse.papyrus.toolsmiths.feature/feature.xml2
5 files changed, 23 insertions, 4 deletions
diff --git a/features/papyrus-main-features/org.eclipse.papyrus.doc.feature/feature.xml b/features/papyrus-main-features/org.eclipse.papyrus.doc.feature/feature.xml
index fb48eed6a7a..e3db0ad11ac 100644
--- a/features/papyrus-main-features/org.eclipse.papyrus.doc.feature/feature.xml
+++ b/features/papyrus-main-features/org.eclipse.papyrus.doc.feature/feature.xml
@@ -168,6 +168,12 @@
version="0.0.0"/>
<plugin
+ id="org.eclipse.papyrus.uml.profile.customization.doc"
+ download-size="0"
+ install-size="0"
+ version="0.0.0"/>
+
+ <plugin
id="org.eclipse.papyrus.uml.search.ui.doc"
download-size="0"
install-size="0"
diff --git a/features/papyrus-main-features/org.eclipse.papyrus.sdk.feature/feature.xml b/features/papyrus-main-features/org.eclipse.papyrus.sdk.feature/feature.xml
index b94238197b6..e96e99bda4f 100644
--- a/features/papyrus-main-features/org.eclipse.papyrus.sdk.feature/feature.xml
+++ b/features/papyrus-main-features/org.eclipse.papyrus.sdk.feature/feature.xml
@@ -4,7 +4,7 @@
label="%featureName"
version="5.0.0.qualifier"
provider-name="%providerName"
- plugin="org.eclipse.papyrus.sdk"
+ plugin="org.eclipse.papyrus.sdk"
license-feature="org.eclipse.license"
license-feature-version="2.0.2">
@@ -51,6 +51,12 @@
id="org.eclipse.papyrus.doc.feature"
version="0.0.0"/>
+ <!-- required plugins -->
+
+ <requires>
+ <import plugin="com.ibm.icu"/>
+ <import plugin="com.ibm.icu.source"/>
+ </requires>
<!-- External Dependencies -->
diff --git a/features/papyrus-tests-features/org.eclipse.papyrus.tests.uml.diagram.feature/feature.xml b/features/papyrus-tests-features/org.eclipse.papyrus.tests.uml.diagram.feature/feature.xml
index 4e3ee736fbf..e73a5233839 100644
--- a/features/papyrus-tests-features/org.eclipse.papyrus.tests.uml.diagram.feature/feature.xml
+++ b/features/papyrus-tests-features/org.eclipse.papyrus.tests.uml.diagram.feature/feature.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<feature
id="org.eclipse.papyrus.tests.uml.diagram.feature"
- version="1.2.0.qualifier"
label="%featureName"
+ version="1.2.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.license"
license-feature-version="2.0.2">
@@ -102,4 +102,11 @@
version="0.0.0"
unpack="false"/>
+ <plugin
+ id="org.eclipse.papyrus.uml.dynamic.profile.tests"
+ download-size="0"
+ install-size="0"
+ version="0.0.0"
+ unpack="false"/>
+
</feature>
diff --git a/features/papyrus-tests-features/pom.xml b/features/papyrus-tests-features/pom.xml
index 2277ecd4441..b5cd9cd0cbc 100755
--- a/features/papyrus-tests-features/pom.xml
+++ b/features/papyrus-tests-features/pom.xml
@@ -15,7 +15,7 @@
<description>Container of the Eclipse Tests Features for Papyrus.</description>
<modules>
- <!-- <module>org.eclipse.papyrus.tests.build.feature</module> -->
+<!-- <module>org.eclipse.papyrus.tests.build.feature</module> -->
<module>org.eclipse.papyrus.tests.feature</module>
<module>org.eclipse.papyrus.tests.emf.facet.feature</module>
<module>org.eclipse.papyrus.tests.infra.core.feature</module>
diff --git a/features/papyrus-toolsmiths-features/org.eclipse.papyrus.toolsmiths.feature/feature.xml b/features/papyrus-toolsmiths-features/org.eclipse.papyrus.toolsmiths.feature/feature.xml
index 1fd2cdf23b8..6a6c8e3eb09 100644
--- a/features/papyrus-toolsmiths-features/org.eclipse.papyrus.toolsmiths.feature/feature.xml
+++ b/features/papyrus-toolsmiths-features/org.eclipse.papyrus.toolsmiths.feature/feature.xml
@@ -22,7 +22,7 @@
<requires>
<import feature="org.eclipse.papyrus.sdk.feature" version="5.0.0" match="compatible"/>
<import plugin="org.eclipse.gmf.runtime.emf.ui.properties" version="1.7.0" match="compatible"/>
- <import plugin="org.eclipse.papyrus.views.properties.model.xwt" version="2.0.0" match="compatible"/>
+ <import plugin="org.eclipse.papyrus.views.properties.model.xwt" version="3.0.0" match="compatible"/>
</requires>
<includes

Back to the top