Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'extraplugins/java')
-rw-r--r--extraplugins/java/org.eclipse.papyrus.java.generator.jdtsynchronizer/META-INF/MANIFEST.MF8
-rw-r--r--extraplugins/java/org.eclipse.papyrus.java.generator.metamodel.jdt.edit/META-INF/MANIFEST.MF10
-rw-r--r--extraplugins/java/org.eclipse.papyrus.java.generator.metamodel.jdt.editor/META-INF/MANIFEST.MF10
-rw-r--r--extraplugins/java/org.eclipse.papyrus.java.generator.metamodel.jdt/META-INF/MANIFEST.MF6
-rw-r--r--extraplugins/java/org.eclipse.papyrus.java.generator.transfo.umltojdt/META-INF/MANIFEST.MF4
-rw-r--r--extraplugins/java/org.eclipse.papyrus.java.generator.ui/META-INF/MANIFEST.MF10
-rw-r--r--extraplugins/java/org.eclipse.papyrus.java.profile.edit/META-INF/MANIFEST.MF8
-rw-r--r--extraplugins/java/org.eclipse.papyrus.java.profile.editor/META-INF/MANIFEST.MF8
-rw-r--r--extraplugins/java/org.eclipse.papyrus.java.profile/META-INF/MANIFEST.MF8
-rw-r--r--extraplugins/java/org.eclipse.papyrus.java.reverse.ui/META-INF/MANIFEST.MF10
-rw-r--r--extraplugins/java/org.eclipse.papyrus.java.reverse/META-INF/MANIFEST.MF10
-rw-r--r--extraplugins/java/org.eclipse.papyrus.java.template/META-INF/MANIFEST.MF2
12 files changed, 47 insertions, 47 deletions
diff --git a/extraplugins/java/org.eclipse.papyrus.java.generator.jdtsynchronizer/META-INF/MANIFEST.MF b/extraplugins/java/org.eclipse.papyrus.java.generator.jdtsynchronizer/META-INF/MANIFEST.MF
index 22ecea2d030..63db678427b 100644
--- a/extraplugins/java/org.eclipse.papyrus.java.generator.jdtsynchronizer/META-INF/MANIFEST.MF
+++ b/extraplugins/java/org.eclipse.papyrus.java.generator.jdtsynchronizer/META-INF/MANIFEST.MF
@@ -1,18 +1,18 @@
Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.java.generator.jdtsynchronizer
Require-Bundle: org.eclipse.uml2.uml,
org.eclipse.m2m.qvt.oml,
- org.eclipse.papyrus.java.generator.metamodel.jdt;bundle-version="0.10.1",
+ org.eclipse.papyrus.java.generator.metamodel.jdt;bundle-version="0.10.2",
org.eclipse.core.runtime,
- org.eclipse.papyrus.java.generator.transfo.umltojdt;bundle-version="0.10.1",
+ org.eclipse.papyrus.java.generator.transfo.umltojdt;bundle-version="0.10.2",
org.eclipse.jdt.core,
org.eclipse.jface.text,
org.eclipse.jdt.launching
-Export-Package: org.eclipse.papyrus.java.generator.jdtsynchronizer
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-Version: 0.10.2.qualifier
-Bundle-Localization: plugin
Bundle-Name: %pluginName
+Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.java.generator.jdtsynchronize
r;singleton:=true
diff --git a/extraplugins/java/org.eclipse.papyrus.java.generator.metamodel.jdt.edit/META-INF/MANIFEST.MF b/extraplugins/java/org.eclipse.papyrus.java.generator.metamodel.jdt.edit/META-INF/MANIFEST.MF
index 846a1e4a8a2..26a16b7f16c 100644
--- a/extraplugins/java/org.eclipse.papyrus.java.generator.metamodel.jdt.edit/META-INF/MANIFEST.MF
+++ b/extraplugins/java/org.eclipse.papyrus.java.generator.metamodel.jdt.edit/META-INF/MANIFEST.MF
@@ -1,19 +1,19 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.java.generator.metamodel.jdt;bundle-version="0.10.1";visibility:=reexport,
+Export-Package: org.eclipse.papyrus.java.generator.metamodel.jdt.jdtmm
+ .provider
+Require-Bundle: org.eclipse.papyrus.java.generator.metamodel.jdt;bundle-version="0.10.2";visibility:=reexport,
org.eclipse.emf.edit;visibility:=reexport,
org.eclipse.uml2.common.edit;visibility:=reexport,
org.eclipse.core.runtime
-Export-Package: org.eclipse.papyrus.java.generator.metamodel.jdt.jdtmm
- .provider
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
Bundle-Version: 0.10.2.qualifier
-Bundle-Localization: plugin
Bundle-Name: %pluginName
+Bundle-Localization: plugin
+Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.java.generator.metamodel.jdt.jdt
mm.provider.JdtmmEditPlugin$Implementation
-Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.java.generator.metamodel.jdt.
edit;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/extraplugins/java/org.eclipse.papyrus.java.generator.metamodel.jdt.editor/META-INF/MANIFEST.MF b/extraplugins/java/org.eclipse.papyrus.java.generator.metamodel.jdt.editor/META-INF/MANIFEST.MF
index 4cc1d95e208..c3b3cca9c73 100644
--- a/extraplugins/java/org.eclipse.papyrus.java.generator.metamodel.jdt.editor/META-INF/MANIFEST.MF
+++ b/extraplugins/java/org.eclipse.papyrus.java.generator.metamodel.jdt.editor/META-INF/MANIFEST.MF
@@ -1,21 +1,21 @@
Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.java.generator.metamodel.jdt.jdtmm
+ .presentation
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.core.resources;visibility:=reexport,
- org.eclipse.papyrus.java.generator.metamodel.jdt.edit;bundle-version="0.10.1";visibility:=reexport,
+ org.eclipse.papyrus.java.generator.metamodel.jdt.edit;bundle-version="0.10.2";visibility:=reexport,
org.eclipse.emf.ecore.xmi;visibility:=reexport,
org.eclipse.emf.edit.ui;visibility:=reexport,
org.eclipse.ui.ide;visibility:=reexport
-Export-Package: org.eclipse.papyrus.java.generator.metamodel.jdt.jdtmm
- .presentation
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
Bundle-Version: 0.10.2.qualifier
-Bundle-Localization: plugin
Bundle-Name: %pluginName
+Bundle-Localization: plugin
+Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.java.generator.metamodel.jdt.jdt
mm.presentation.JdtmmEditorPlugin$Implementation
-Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.java.generator.metamodel.jdt.
editor;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/extraplugins/java/org.eclipse.papyrus.java.generator.metamodel.jdt/META-INF/MANIFEST.MF b/extraplugins/java/org.eclipse.papyrus.java.generator.metamodel.jdt/META-INF/MANIFEST.MF
index 55d723b1f7e..64c5a54d98c 100644
--- a/extraplugins/java/org.eclipse.papyrus.java.generator.metamodel.jdt/META-INF/MANIFEST.MF
+++ b/extraplugins/java/org.eclipse.papyrus.java.generator.metamodel.jdt/META-INF/MANIFEST.MF
@@ -1,16 +1,16 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.uml2.common;bundle-version="1.5.0",
- org.eclipse.jdt.core;bundle-version="3.6.0"
Export-Package: org.eclipse.papyrus.java.generator.metamodel.jdt.jdtmm,
org.eclipse.papyrus.java.generator.metamodel.jdt.jdtmm.impl,
org.eclipse.papyrus.java.generator.metamodel.jdt.jdtmm.util,
org.eclipse.papyrus.java.generator.metamodel.jdt.jdtmm.visitor
+Require-Bundle: org.eclipse.uml2.common;bundle-version="1.5.0",
+ org.eclipse.jdt.core;bundle-version="3.6.0"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
Bundle-Version: 0.10.2.qualifier
-Bundle-Localization: plugin
Bundle-Name: %pluginName
+Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.java.generator.metamodel.jdt;
singleton:=true
diff --git a/extraplugins/java/org.eclipse.papyrus.java.generator.transfo.umltojdt/META-INF/MANIFEST.MF b/extraplugins/java/org.eclipse.papyrus.java.generator.transfo.umltojdt/META-INF/MANIFEST.MF
index 5b3f5e06da2..7324ca63c0f 100644
--- a/extraplugins/java/org.eclipse.papyrus.java.generator.transfo.umltojdt/META-INF/MANIFEST.MF
+++ b/extraplugins/java/org.eclipse.papyrus.java.generator.transfo.umltojdt/META-INF/MANIFEST.MF
@@ -1,10 +1,10 @@
Manifest-Version: 1.0
-Export-Package: org.eclipse.papyrus.java.generator.transfo.umltojdt
Require-Bundle: org.eclipse.core.runtime
+Export-Package: org.eclipse.papyrus.java.generator.transfo.umltojdt
Bundle-Vendor: %providerName
Bundle-Version: 0.10.2.qualifier
-Bundle-Localization: plugin
Bundle-Name: %pluginName
+Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.java.generator.transfo.umltoj
dt
diff --git a/extraplugins/java/org.eclipse.papyrus.java.generator.ui/META-INF/MANIFEST.MF b/extraplugins/java/org.eclipse.papyrus.java.generator.ui/META-INF/MANIFEST.MF
index d5c21083acd..e6c087729b0 100644
--- a/extraplugins/java/org.eclipse.papyrus.java.generator.ui/META-INF/MANIFEST.MF
+++ b/extraplugins/java/org.eclipse.papyrus.java.generator.ui/META-INF/MANIFEST.MF
@@ -1,22 +1,22 @@
Manifest-Version: 1.0
-Export-Package: org.eclipse.papyrus.java.generator.ui
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.emf.ecore,
org.eclipse.uml2.uml,
org.eclipse.ui.ide,
org.eclipse.core.resources;bundle-version="3.6.0",
- org.eclipse.papyrus.java.generator.metamodel.jdt;bundle-version="0.10.1",
+ org.eclipse.papyrus.java.generator.metamodel.jdt;bundle-version="0.10.2",
org.eclipse.jdt.core,
org.eclipse.jdt.ui,
- org.eclipse.papyrus.java.generator.jdtsynchronizer;bundle-version="0.10.1"
+ org.eclipse.papyrus.java.generator.jdtsynchronizer;bundle-version="0.10.2"
+Export-Package: org.eclipse.papyrus.java.generator.ui
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-Version: 0.10.2.qualifier
-Bundle-Localization: plugin
Bundle-Name: %pluginName
-Bundle-Activator: org.eclipse.papyrus.java.generator.ui.Activator
+Bundle-Localization: plugin
Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.java.generator.ui.Activator
Bundle-SymbolicName: org.eclipse.papyrus.java.generator.ui;singleton:=
true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/extraplugins/java/org.eclipse.papyrus.java.profile.edit/META-INF/MANIFEST.MF b/extraplugins/java/org.eclipse.papyrus.java.profile.edit/META-INF/MANIFEST.MF
index 91cb9a28c3f..becba8d18cd 100644
--- a/extraplugins/java/org.eclipse.papyrus.java.profile.edit/META-INF/MANIFEST.MF
+++ b/extraplugins/java/org.eclipse.papyrus.java.profile.edit/META-INF/MANIFEST.MF
@@ -1,17 +1,17 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.java.profile;bundle-version="0.10.1";visibility:=reexport,
+Export-Package: org.eclipse.papyrus.java.profile.java.provider
+Require-Bundle: org.eclipse.papyrus.java.profile;bundle-version="0.10.2";visibility:=reexport,
org.eclipse.uml2.uml.edit;visibility:=reexport,
org.eclipse.core.runtime
-Export-Package: org.eclipse.papyrus.java.profile.java.provider
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
Bundle-Version: 0.10.2.qualifier
-Bundle-Localization: plugin
Bundle-Name: %pluginName
+Bundle-Localization: plugin
+Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.java.profile.java.provider.JavaE
ditPlugin$Implementation
-Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.java.profile.edit;singleton:=
true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/extraplugins/java/org.eclipse.papyrus.java.profile.editor/META-INF/MANIFEST.MF b/extraplugins/java/org.eclipse.papyrus.java.profile.editor/META-INF/MANIFEST.MF
index bf21148eadd..dd088375150 100644
--- a/extraplugins/java/org.eclipse.papyrus.java.profile.editor/META-INF/MANIFEST.MF
+++ b/extraplugins/java/org.eclipse.papyrus.java.profile.editor/META-INF/MANIFEST.MF
@@ -1,18 +1,18 @@
Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.java.profile.java.presentation
Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.papyrus.java.profile.edit;bundle-version="0.10.1";visibility:=reexport,
+ org.eclipse.papyrus.java.profile.edit;bundle-version="0.10.2";visibility:=reexport,
org.eclipse.emf.edit.ui;visibility:=reexport,
org.eclipse.ui.ide;visibility:=reexport
-Export-Package: org.eclipse.papyrus.java.profile.java.presentation
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
Bundle-Version: 0.10.2.qualifier
-Bundle-Localization: plugin
Bundle-Name: %pluginName
+Bundle-Localization: plugin
+Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.java.profile.java.presentation.J
avaEditorPlugin$Implementation
-Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.java.profile.editor;singleton
:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/extraplugins/java/org.eclipse.papyrus.java.profile/META-INF/MANIFEST.MF b/extraplugins/java/org.eclipse.papyrus.java.profile/META-INF/MANIFEST.MF
index 984052a8dd4..b39b905bd7d 100644
--- a/extraplugins/java/org.eclipse.papyrus.java.profile/META-INF/MANIFEST.MF
+++ b/extraplugins/java/org.eclipse.papyrus.java.profile/META-INF/MANIFEST.MF
@@ -1,17 +1,17 @@
Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.java.profile.java,
+ org.eclipse.papyrus.java.profile.java.impl,
+ org.eclipse.papyrus.java.profile.java.util
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.emf.ecore;visibility:=reexport,
org.eclipse.emf.ecore.xmi;visibility:=reexport,
org.eclipse.uml2.uml;visibility:=reexport
-Export-Package: org.eclipse.papyrus.java.profile.java,
- org.eclipse.papyrus.java.profile.java.impl,
- org.eclipse.papyrus.java.profile.java.util
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
Bundle-Version: 0.10.2.qualifier
-Bundle-Localization: plugin
Bundle-Name: %pluginName
+Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.java.profile;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/extraplugins/java/org.eclipse.papyrus.java.reverse.ui/META-INF/MANIFEST.MF b/extraplugins/java/org.eclipse.papyrus.java.reverse.ui/META-INF/MANIFEST.MF
index bd2db431e2d..cea272826eb 100644
--- a/extraplugins/java/org.eclipse.papyrus.java.reverse.ui/META-INF/MANIFEST.MF
+++ b/extraplugins/java/org.eclipse.papyrus.java.reverse.ui/META-INF/MANIFEST.MF
@@ -3,16 +3,16 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.emf.transaction;bundle-version="1.2.0",
org.eclipse.gef;bundle-version="3.4.0",
org.eclipse.jdt.core;bundle-version="3.4.0",
- org.eclipse.papyrus.java.reverse;bundle-version="0.10.1",
- org.eclipse.papyrus.infra.core;bundle-version="0.10.1",
- org.eclipse.papyrus.uml.tools;bundle-version="0.10.1"
+ org.eclipse.papyrus.java.reverse;bundle-version="0.10.2",
+ org.eclipse.papyrus.infra.core;bundle-version="0.10.2",
+ org.eclipse.papyrus.uml.tools;bundle-version="0.10.2"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-Version: 0.10.2.qualifier
-Bundle-Localization: plugin
Bundle-Name: %pluginName
-Bundle-Activator: org.eclipse.papyrus.java.reverse.ui.Activator
+Bundle-Localization: plugin
Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.java.reverse.ui.Activator
Bundle-SymbolicName: org.eclipse.papyrus.java.reverse.ui;singleton:=tr
ue
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/extraplugins/java/org.eclipse.papyrus.java.reverse/META-INF/MANIFEST.MF b/extraplugins/java/org.eclipse.papyrus.java.reverse/META-INF/MANIFEST.MF
index 506a714fb71..45f87ebcfc2 100644
--- a/extraplugins/java/org.eclipse.papyrus.java.reverse/META-INF/MANIFEST.MF
+++ b/extraplugins/java/org.eclipse.papyrus.java.reverse/META-INF/MANIFEST.MF
@@ -1,18 +1,18 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.uml2.uml;visibility:=reexport
Export-Package: japa.parser,
japa.parser.ast,
javagen.umlparser,
org.eclipse.papyrus.java.reverse.utils
+Require-Bundle: org.eclipse.ui,
+ org.eclipse.core.runtime,
+ org.eclipse.uml2.uml;visibility:=reexport
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-Version: 0.10.2.qualifier
-Bundle-Localization: plugin
Bundle-Name: %pluginName
-Bundle-Activator: org.eclipse.papyrus.java.reverse.Activator
+Bundle-Localization: plugin
Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.java.reverse.Activator
Bundle-SymbolicName: org.eclipse.papyrus.java.reverse;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/extraplugins/java/org.eclipse.papyrus.java.template/META-INF/MANIFEST.MF b/extraplugins/java/org.eclipse.papyrus.java.template/META-INF/MANIFEST.MF
index c9433ea7a0d..7985de4e7fe 100644
--- a/extraplugins/java/org.eclipse.papyrus.java.template/META-INF/MANIFEST.MF
+++ b/extraplugins/java/org.eclipse.papyrus.java.template/META-INF/MANIFEST.MF
@@ -10,8 +10,8 @@ Bundle-Vendor: Atos Origin
Bundle-ActivationPolicy: lazy
Bundle-Version: 0.10.2.qualifier
Bundle-Name: Java Template
-Bundle-Activator: org.eclipse.papyrus.java.template.Activator
Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.java.template.Activator
Bundle-SymbolicName: org.eclipse.papyrus.java.template;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5

Back to the top