Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/build.properties3
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/.settings/org.eclipse.jdt.core.prefs4
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/META-INF/MANIFEST.MF12
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/META-INF/MANIFEST.MF15
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/build.properties4
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/src/org/eclipse/papyrus/adltool/designer/ArchitectureSnapshotDesigner.java20
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/META-INF/MANIFEST.MF4
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/src/org/eclipse/papyrus/osgi/profile/Activator.java2
9 files changed, 43 insertions, 23 deletions
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/META-INF/MANIFEST.MF b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/META-INF/MANIFEST.MF
index 661d1e9d31f..11e7abb186a 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/META-INF/MANIFEST.MF
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
- org.eclipse.papyrus.osgi.profile;bundle-version="1.0.0"
+ org.eclipse.papyrus.osgi.profile
Export-Package: org.eclipse.papyrus.adl4eclipse.org
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/build.properties b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/build.properties
index 6f20375d6c7..8665ac2ffec 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/build.properties
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/build.properties
@@ -2,4 +2,5 @@ source.. = src/
output.. = bin/
bin.includes = META-INF/,\
.,\
- plugin.xml
+ plugin.xml,\
+ plugin.properties
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/.settings/org.eclipse.jdt.core.prefs b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/.settings/org.eclipse.jdt.core.prefs
index 44217f8c068..060c5ee3d2e 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/.settings/org.eclipse.jdt.core.prefs
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,11 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.debug.lineNumber=generate
+org.eclipse.jdt.core.compiler.debug.localVariable=generate
+org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
org.eclipse.jdt.core.compiler.source=1.5
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/META-INF/MANIFEST.MF b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/META-INF/MANIFEST.MF
index ec3050e108c..7f190f47415 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/META-INF/MANIFEST.MF
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/META-INF/MANIFEST.MF
@@ -1,16 +1,16 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
- org.eclipse.emf;bundle-version="2.6.0",
+ org.eclipse.emf,
org.eclipse.emf.ecore,
org.eclipse.emf.transaction,
org.eclipse.gmf.runtime.diagram.ui,
- org.eclipse.papyrus.editor;bundle-version="1.0.0",
- org.eclipse.papyrus.infra.core;bundle-version="1.0.0",
+ org.eclipse.papyrus.editor,
+ org.eclipse.papyrus.infra.core,
org.eclipse.uml2.uml,
- org.eclipse.papyrus.infra.emf;bundle-version="1.0.0",
- org.eclipse.papyrus.adl4eclipsetool;bundle-version="1.0.0",
- org.eclipse.pde.core;bundle-version="3.9.0"
+ org.eclipse.papyrus.infra.emf,
+ org.eclipse.papyrus.adl4eclipsetool,
+ org.eclipse.pde.core
Export-Package: org.eclipse.papyrus.adltool.assistant
Bundle-Vendor: %providerName
Bundle-Version: 1.0.0.qualifier
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/META-INF/MANIFEST.MF b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/META-INF/MANIFEST.MF
index 8fce2c3509e..0230253ddb4 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/META-INF/MANIFEST.MF
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/META-INF/MANIFEST.MF
@@ -6,13 +6,13 @@ Export-Package: org.eclipse.papyrus.adltool,
org.eclipse.papyrus.adltool.designer.wizard
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
- org.eclipse.emf.transaction;bundle-version="1.4.0",
- org.eclipse.uml2.uml;bundle-version="4.0.100",
+ org.eclipse.emf.transaction,
+ org.eclipse.uml2.uml,
org.eclipse.pde.core,
- org.eclipse.papyrus.uml.extensionpoints;bundle-version="1.0.0",
- org.eclipse.papyrus.uml.tools.utils;bundle-version="1.0.0",
- org.eclipse.papyrus.adl4eclipse.profile;bundle-version="1.0.0",
- org.eclipse.papyrus.osgi.profile;bundle-version="1.0.0"
+ org.eclipse.papyrus.uml.extensionpoints,
+ org.eclipse.papyrus.uml.tools.utils,
+ org.eclipse.papyrus.adl4eclipse.profile,
+ org.eclipse.papyrus.osgi.profile
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-Version: 1.0.0.qualifier
@@ -20,7 +20,6 @@ Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.adltool.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.adl4eclipsetool
-Eclipse-RegisterBuddy:
+Bundle-SymbolicName: org.eclipse.papyrus.adl4eclipsetool;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/build.properties b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/build.properties
index 73a5119ed93..676605b2a1c 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/build.properties
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/build.properties
@@ -3,4 +3,6 @@ output.. = bin/
bin.includes = META-INF/,\
.,\
plugin.properties,\
- plugin.xml
+ about.html,\
+ bin/
+src.includes = about.html
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/src/org/eclipse/papyrus/adltool/designer/ArchitectureSnapshotDesigner.java b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/src/org/eclipse/papyrus/adltool/designer/ArchitectureSnapshotDesigner.java
index 9130528b00d..2f43ecd34d9 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/src/org/eclipse/papyrus/adltool/designer/ArchitectureSnapshotDesigner.java
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/src/org/eclipse/papyrus/adltool/designer/ArchitectureSnapshotDesigner.java
@@ -334,8 +334,8 @@ public abstract class ArchitectureSnapshotDesigner{
protected void modelRelationExtensionBased(Component bundleComponent, IExtension extension, Port clientPort, Port supplierPort) {
Dependency dependency=UMLFactory.eINSTANCE.createDependency();
dependency.setName(extension.getExtensionPointUniqueIdentifier());
- bundleComponent.getNearestPackage().getPackagedElements().add(dependency);
- //bundleComponent.getPackagedElements().add(dependency);
+ //bundleComponent.getNearestPackage().getPackagedElements().add(dependency);
+ bundleComponent.getPackagedElements().add(dependency);
dependency.getClients().add(clientPort);
dependency.getSuppliers().add(supplierPort);
}
@@ -458,7 +458,11 @@ public abstract class ArchitectureSnapshotDesigner{
if(bundleRef.isOptional()||foundBundle!=null){
if (foundBundle!=null){
if((!(createdFeatureIndex.containsKey(bundleRef.getSymbolicName())))&&(!(createdFeatureIndex.containsKey(bundleRef.getSymbolicName())))) {
- modelBundle(library,foundBundle, currentLevel+1);
+ if( isInitialPlugin(bundleRef.getSymbolicName())){
+ modelBundle(library,foundBundle, currentLevel);
+ }
+ else{
+ modelBundle(library,foundBundle, currentLevel+1);}
}
}
else {
@@ -510,5 +514,15 @@ public abstract class ArchitectureSnapshotDesigner{
}
return out;
}
+ protected boolean isInitialPlugin(String name) {
+ Iterator<Object> bundleProjectsIterator= bundleInitialList.iterator();
+ while(bundleProjectsIterator.hasNext()) {
+ Object bundleProject = (Object)bundleProjectsIterator.next();
+ if(name.equals(bundleDesignerRegistry.getSymbolicName(bundleProject))){
+ return true;
+ }
+ }
+ return false;
+ }
}
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/META-INF/MANIFEST.MF b/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/META-INF/MANIFEST.MF
index 4cb5c21c41a..75e53e973c1 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/META-INF/MANIFEST.MF
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/META-INF/MANIFEST.MF
@@ -1,8 +1,8 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
- org.eclipse.papyrus.uml.extensionpoints;bundle-version="1.0.0",
- org.eclipse.emf;bundle-version="2.6.0"
+ org.eclipse.papyrus.uml.extensionpoints,
+ org.eclipse.emf
Export-Package: org.eclipse.papyrus.osgi.profile
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/src/org/eclipse/papyrus/osgi/profile/Activator.java b/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/src/org/eclipse/papyrus/osgi/profile/Activator.java
index 15b5d48dbf8..f6833806e9b 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/src/org/eclipse/papyrus/osgi/profile/Activator.java
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/src/org/eclipse/papyrus/osgi/profile/Activator.java
@@ -21,7 +21,7 @@ import org.osgi.framework.BundleContext;
*/
public class Activator extends AbstractUIPlugin {
- // The plug-in ID
+ /** The plug-in ID**/
public static final String PLUGIN_ID = "org.eclipse.papyrus.osgi.profile"; //$NON-NLS-1$
// The shared instance

Back to the top