Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Le Menez2017-05-31 09:07:16 -0400
committerQuentin Le Menez2017-06-02 05:26:10 -0400
commitd1c8dca9b47fbc27f97ee86b1204a5724c920024 (patch)
treed8e1d14f4b74a4bc03598305165f35a902cd7888 /tests/junit/plugins
parentf16aae7b9d69ab5e594d94c8fd7f550419991d3b (diff)
downloadorg.eclipse.papyrus-d1c8dca9b47fbc27f97ee86b1204a5724c920024.tar.gz
org.eclipse.papyrus-d1c8dca9b47fbc27f97ee86b1204a5724c920024.tar.xz
org.eclipse.papyrus-d1c8dca9b47fbc27f97ee86b1204a5724c920024.zip
Bug 517539 - [All] Update UML2 dependency for all Papyrus plugins
- Update plugins dependencies to uml2 - Add a new test to verify uml2.uml versions during bundle tests - Update plugin versions due to new reexported versions and other manifest changes Change-Id: I524eb4474eb6dd7de6f97ce118f144c28590773b Signed-off-by: Quentin Le Menez <quentin.lemenez@cea.fr>
Diffstat (limited to 'tests/junit/plugins')
-rw-r--r--tests/junit/plugins/developer/org.eclipse.papyrus.bundles.tests/src/org/eclipse/papyrus/bundles/tests/BundlesTests.java12
-rw-r--r--tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.tests/META-INF/MANIFEST.MF4
-rw-r--r--tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/META-INF/MANIFEST.MF4
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.tests/META-INF/MANIFEST.MF2
-rwxr-xr-xtests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/org.eclipse.papyrus.infra.filters.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.semantic.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/junit/org.eclipse.papyrus.junit.utils/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/junit/org.eclipse.papyrus.junit.utils/pom.xml2
-rw-r--r--tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.backend.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.tests/META-INF/MANIFEST.MF4
-rwxr-xr-xtests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity.tests/META-INF/MANIFEST.MF4
-rwxr-xr-xtests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/META-INF/MANIFEST.MF2
-rwxr-xr-xtests/junit/plugins/uml/expressions/org.eclipse.papyrus.uml.expressions.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config.tests/META-INF/MANIFEST.MF2
-rwxr-xr-xtests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.filters.tests/META-INF/MANIFEST.MF4
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.staticprofile/META-INF/MANIFEST.MF4
-rw-r--r--tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/views/org.eclipse.papyrus.views.modelexplorer.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/views/org.eclipse.papyrus.views.properties.toolsmiths.tests/META-INF/MANIFEST.MF2
67 files changed, 83 insertions, 73 deletions
diff --git a/tests/junit/plugins/developer/org.eclipse.papyrus.bundles.tests/src/org/eclipse/papyrus/bundles/tests/BundlesTests.java b/tests/junit/plugins/developer/org.eclipse.papyrus.bundles.tests/src/org/eclipse/papyrus/bundles/tests/BundlesTests.java
index 9d1f198cfbb..552bdd47738 100644
--- a/tests/junit/plugins/developer/org.eclipse.papyrus.bundles.tests/src/org/eclipse/papyrus/bundles/tests/BundlesTests.java
+++ b/tests/junit/plugins/developer/org.eclipse.papyrus.bundles.tests/src/org/eclipse/papyrus/bundles/tests/BundlesTests.java
@@ -17,6 +17,7 @@ package org.eclipse.papyrus.bundles.tests;
import java.lang.reflect.Field;
import java.net.URL;
import java.util.ArrayList;
+import java.util.Arrays;
import java.util.Collection;
import java.util.Collections;
import java.util.List;
@@ -55,6 +56,8 @@ public class BundlesTests extends AbstractPapyrusTest {
private static final String GLAZED_LIST_VERSION = "1.9.0";//$NON-NLS-1$
+ private static final String UML2_UML_VERSION_RANGE = "bundle-version=\"[5.3.0,6.0.0)\")";//$NON-NLS-1$
+
@Condition
public final boolean isAutomatedBuild = JUnitUtils.isAutomatedBuildExecution();
@@ -222,6 +225,13 @@ public class BundlesTests extends AbstractPapyrusTest {
testPapyrusDependencies2("com.google.guava", "21.0.0");//$NON-NLS-1$ //$NON-NLS-2$
}
+ @Test
+ public void uml2umlDependencyVersionTest() {
+ testPapyrusDependencies("org.eclipse.uml2.uml", UML2_UML_VERSION_RANGE, //$NON-NLS-1$
+ new ArrayList<>(Arrays.asList("org.eclipse.uml2.uml.profile.standard", //$NON-NLS-1$
+ "org.eclipse.uml2.uml.validation", "org.eclipse.uml2.uml.editor"))); //$NON-NLS-1$ //$NON-NLS-2$
+ }
+
public final static String REGEX_PACKAGE_WORD = "\\w(?:\\w|\\d)*";// match a //$NON-NLS-1$
// package
// name
@@ -412,7 +422,7 @@ public class BundlesTests extends AbstractPapyrusTest {
public void pluginIDTest() {
StringBuffer errorMessage = new StringBuffer();
StringBuffer warningMessage = new StringBuffer();
- final Collection<String> possibleIds = new ArrayList<String>();
+ final Collection<String> possibleIds = new ArrayList<>();
possibleIds.add("ID");//$NON-NLS-1$
possibleIds.add("PLUGIN_ID");//$NON-NLS-1$
int nbError = 0;
diff --git a/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF
index 68a2d13a6e3..c629dd2d7ca 100644
--- a/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.gmf.runtime.notation;bundle-version="1.5.0",
org.eclipse.papyrus.uml.tools;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.1.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.ui.ide;bundle-version="3.9.0",
diff --git a/tests/junit/plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.tests/META-INF/MANIFEST.MF
index fa033b96d83..4bcec6ce0c5 100644
--- a/tests/junit/plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.tests/META-INF/MANIFEST.MF
@@ -2,10 +2,10 @@ Manifest-Version: 1.0
Export-Package: org.eclipse.papyrus.infra.editor.welcome.tests
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.papyrus.infra.editor.welcome;visibility:=reexport;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.types;visibility:=reexport,
+ org.eclipse.uml2.types;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.ecore.xmi;bundle-version="2.8.0";visibility:=reexport,
org.junit;bundle-version="4.12.0";visibility:=reexport,
- org.eclipse.uml2.uml;bundle-version="5.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
diff --git a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/META-INF/MANIFEST.MF
index cf519473e03..2d9d4852326 100644
--- a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/META-INF/MANIFEST.MF
@@ -1,6 +1,6 @@
Manifest-Version: 1.0
Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.uml2.uml;bundle-version="5.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.services.controlmode;bundle-version="[2.0.0,3.0.0)",
org.eclipse.gmf.runtime.notation;bundle-version="1.7.0",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
diff --git a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/META-INF/MANIFEST.MF
index 999939a966b..0e131ec5114 100644
--- a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Export-Package: org.eclipse.papyrus.infra.emf.advice,
org.eclipse.papyrus.infra.emf.utils
Require-Bundle: org.eclipse.emf.ecore.xmi;bundle-version="2.8.0",
org.junit;bundle-version="4.10.0",
- org.eclipse.uml2.uml;bundle-version="5.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
diff --git a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/META-INF/MANIFEST.MF
index 9b9c37a6df7..76b46800267 100644
--- a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/META-INF/MANIFEST.MF
@@ -1,6 +1,6 @@
Manifest-Version: 1.0
Require-Bundle: org.junit;bundle-version="4.10.0",
- org.eclipse.uml2.uml;bundle-version="5.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.services.controlmode;bundle-version="[2.0.0,3.0.0)",
org.eclipse.gmf.runtime.notation;bundle-version="1.7.0",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
diff --git a/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/META-INF/MANIFEST.MF
index 349234b3d6f..12957585a73 100644
--- a/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/META-INF/MANIFEST.MF
@@ -5,11 +5,11 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.papyrus.infra.gmfdiag.assistant;bundle-version="[1.3.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.ecore;bundle-version="2.11.0";visibility:=reexport,
org.eclipse.papyrus.infra.filters;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
- org.eclipse.uml2.types;bundle-version="2.0.0";visibility:=reexport,
+ org.eclipse.uml2.types;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.ecore.xmi;bundle-version="2.11.0";visibility:=reexport,
org.eclipse.gmf.runtime.emf.ui;bundle-version="1.7.0",
org.eclipse.papyrus.uml.service.types;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.1.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/META-INF/MANIFEST.MF
index a0b0479a743..717f4a06bf4 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.gmfdiag.canonical;bundle-version="[2.0.0,3.0.0)",
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.8.0",
org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.1.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.uml.diagram.clazz;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/META-INF/MANIFEST.MF
index 1b0f9005be5..da21ce31126 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Require-Bundle: org.junit;bundle-version="4.10.0",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.2.0,6.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.uml.service.types;bundle-version="[3.0.0,4.0.0)"
Export-Package: org.eclipse.papyrus.infra.gmfdiag.commands.tests
Bundle-Vendor: %providerName
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/META-INF/MANIFEST.MF
index 88678f6a83a..a2a2e5c7182 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Require-Bundle: org.junit;bundle-version="4.10.0",
org.eclipse.papyrus.infra.gmfdiag.assistant;bundle-version="[1.3.0,2.0.0)",
org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.gmfdiag.canonical;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.1.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.types.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.gmfdiag.expansion;bundle-version="[2.0.0,3.0.0)",
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.tests/META-INF/MANIFEST.MF
index 79a4d6a2952..17b784254dc 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.tests/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
org.eclipse.core.resources;bundle-version="3.8.0",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.emf.appearance;bundle-version="[2.0.0,3.0.0)",
org.junit;bundle-version="4.10.0",
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome.tests/META-INF/MANIFEST.MF
index 433d6a2d640..2168e022fd9 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome.tests/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.8.0",
org.eclipse.papyrus.infra.gmfdiag.welcome;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.infra.editor.welcome.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.1.100",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.infra.gmfdiag.representation;bundle-version="[1.0.0,2.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common.tests/META-INF/MANIFEST.MF
index 7a4cdf7c074..51164182c9f 100644
--- a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common.tests/META-INF/MANIFEST.MF
@@ -12,7 +12,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.nattable.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.nattable.model;bundle-version="[3.0.0,4.0.0)",
org.junit;bundle-version="4.12.0",
- org.eclipse.uml2.uml;bundle-version="5.1.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.emf.transaction,
diff --git a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.tests/META-INF/MANIFEST.MF
index 6e7b13c6a8d..fdaf2277e85 100644
--- a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.tests/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Require-Bundle: org.eclipse.ui,
org.junit,
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
org.eclipse.emf.ecore,
- org.eclipse.uml2.uml,
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.nattable.model;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.nattable;bundle-version="[3.0.0,4.0.0)",
diff --git a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.tests/META-INF/MANIFEST.MF
index a1b8160dcaa..673abe778e3 100755
--- a/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml,
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.nattable;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.filters.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.filters.tests/META-INF/MANIFEST.MF
index d51950887f9..309a89313ba 100644
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.filters.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.filters.tests/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Export-Package: org.eclipse.papyrus.infra.filters.tests
Require-Bundle: org.eclipse.core.runtime,
org.junit;visibility:=reexport,
org.eclipse.papyrus.infra.filters;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
- org.eclipse.uml2.types;bundle-version="2.0.0";visibility:=reexport,
+ org.eclipse.uml2.types;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.ecore.xmi;bundle-version="2.11.0";visibility:=reexport,
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)"
Bundle-Vendor: %providerName
diff --git a/tests/junit/plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui.tests/META-INF/MANIFEST.MF
index 670418648e4..2369c696502 100644
--- a/tests/junit/plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui.tests/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Require-Bundle: org.junit;bundle-version="4.10.0",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.infra.properties.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.2.0"
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)"
Export-Package: org.eclipse.papyrus.infra.properties.ui.tests
Bundle-Vendor: Eclipse Modeling Project
Bundle-Version: 2.0.0.qualifier
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/META-INF/MANIFEST.MF
index 625c9878da1..d5231323e2d 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Require-Bundle: org.eclipse.ui;bundle-version="3.106.0",
org.eclipse.papyrus.infra.services.controlmode;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.emf.transaction,
org.eclipse.papyrus.infra.services.resourceloading;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.tests/META-INF/MANIFEST.MF
index 25387ed8a93..71242bbab2f 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.tests/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Require-Bundle: org.eclipse.ui.ide;bundle-version="3.8.0",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.services.validation;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.7.0",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui.tests/META-INF/MANIFEST.MF
index 5b7ab69c9c4..256320bad4d 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Require-Bundle: org.junit;bundle-version="4.10.0",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.infra.services.edit.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.7.0",
org.eclipse.papyrus.infra.services.edit.tests;bundle-version="[1.2.0,2.0.0)"
Export-Package: org.eclipse.papyrus.infra.services.edit.ui.dialogs.tests,
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider.tests/META-INF/MANIFEST.MF
index c3f830eb533..96a8962e9f5 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider.tests/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.uml.tools;bundle-version="[3.0.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="2.8.1",
org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.junit;bundle-version="4.10.0",
org.eclipse.papyrus.emf.facet.custom.ui;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.emf.facet.custom.core;bundle-version="[3.0.0,4.0.0)",
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.tests/META-INF/MANIFEST.MF
index 5e297db25e4..322058f261b 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.tests/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.uml2.uml;bundle-version="3.1.0",
+Require-Bundle: org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.uml.resourceloading.profile;bundle-version="[1.2.0,2.0.0)",
org.junit;bundle-version="4.10.0",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.semantic.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.semantic.tests/META-INF/MANIFEST.MF
index 883281799a9..5ce211f8c68 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.semantic.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.semantic.tests/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Require-Bundle: org.junit;bundle-version="4.10.0",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.services.semantic;bundle-version="[2.0.0,3.0.0)",
diff --git a/tests/junit/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy.tests/META-INF/MANIFEST.MF
index fe5c81c2b62..0ccfcb9acf8 100644
--- a/tests/junit/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy.tests/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.11.0",
org.junit;bundle-version="4.11.0";visibility:=reexport,
org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.9.0",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.2.0,6.0.0)"
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
diff --git a/tests/junit/plugins/junit/org.eclipse.papyrus.junit.utils/META-INF/MANIFEST.MF b/tests/junit/plugins/junit/org.eclipse.papyrus.junit.utils/META-INF/MANIFEST.MF
index 6e0643ab877..3f49d78238a 100644
--- a/tests/junit/plugins/junit/org.eclipse.papyrus.junit.utils/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/junit/org.eclipse.papyrus.junit.utils/META-INF/MANIFEST.MF
@@ -18,7 +18,7 @@ Export-Package: org.eclipse.papyrus.junit.matchers,
org.eclipse.papyrus.junit.utils.tests
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.0.100.qualifier
+Bundle-Version: 2.1.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.junit.utils.Activator
diff --git a/tests/junit/plugins/junit/org.eclipse.papyrus.junit.utils/pom.xml b/tests/junit/plugins/junit/org.eclipse.papyrus.junit.utils/pom.xml
index 917e5ea90f2..a372a1ddc79 100644
--- a/tests/junit/plugins/junit/org.eclipse.papyrus.junit.utils/pom.xml
+++ b/tests/junit/plugins/junit/org.eclipse.papyrus.junit.utils/pom.xml
@@ -8,6 +8,6 @@
</parent>
<groupId>org.eclipse.papyrus</groupId>
<artifactId>org.eclipse.papyrus.junit.utils</artifactId>
- <version>2.0.100-SNAPSHOT</version>
+ <version>2.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project> \ No newline at end of file
diff --git a/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.backend.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.backend.tests/META-INF/MANIFEST.MF
index 56663553106..a65c98de860 100644
--- a/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.backend.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.backend.tests/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.junit,
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
org.eclipse.emf.ecore;bundle-version="2.11.0",
- org.eclipse.uml2.uml;bundle-version="5.1.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.emf.edit;bundle-version="2.11.0",
org.eclipse.core.commands;bundle-version="3.7.0",
org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
diff --git a/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.tests/META-INF/MANIFEST.MF
index 8532cc6f66c..f9949debc42 100644
--- a/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/alf/org.eclipse.papyrus.uml.alf.tests/META-INF/MANIFEST.MF
@@ -14,10 +14,10 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.xtend;bundle-version="1.4.0",
org.eclipse.emf.ecore.xmi;visibility:=reexport,
org.junit;visibility:=reexport,
- org.eclipse.uml2.uml,
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.objectweb.asm;bundle-version="[5.0.1,6.0.0)";resolution:=optional,
org.eclipse.ocl.uml;bundle-version="5.0.0",
- org.eclipse.uml2.uml.resources;bundle-version="5.0.0",
+ org.eclipse.uml2.uml.resources;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.uml.alf;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.alf.ui;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.alf.to.fuml;bundle-version="[1.2.0,2.0.0)",
diff --git a/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.tests/META-INF/MANIFEST.MF
index 2f587071be9..0694a79ce6b 100755
--- a/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.tests/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.emf.ecore;bundle-version="2.11.0",
org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.uml.types.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.1.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.uml.service.types;bundle-version="[3.0.0,4.0.0)",
org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.7.0",
org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
diff --git a/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.tests/META-INF/MANIFEST.MF
index 479833fcde7..ee9e93011c0 100644
--- a/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.tests/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.emf.ecore;bundle-version="2.11.0",
org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.uml.types.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.1.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.uml.service.types;bundle-version="[3.0.0,4.0.0)",
org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.7.0",
org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity.tests/META-INF/MANIFEST.MF
index c14cb611580..547c6a897b7 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity.tests/META-INF/MANIFEST.MF
@@ -9,13 +9,13 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,3.0.0)",
org.eclipse.papyrus.uml.diagram.activity;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
org.junit;bundle-version="4.10.0",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.uml.service.types;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml.editor,
+ org.eclipse.uml2.uml.editor; bundle-version="[5.2.0,6.0.0)",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.tests.framework;bundle-version="[1.2.0,2.0.0)",
org.eclipse.xtend.lib;bundle-version="2.8.1",
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/META-INF/MANIFEST.MF
index dcd50cebb5c..e5825965058 100755
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz.tests/META-INF/MANIFEST.MF
@@ -9,7 +9,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
org.junit;bundle-version="4.10.0",
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication.tests/META-INF/MANIFEST.MF
index e08e00ac650..35cd25d612d 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication.tests/META-INF/MANIFEST.MF
@@ -9,7 +9,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
org.junit;bundle-version="4.10.0",
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component.tests/META-INF/MANIFEST.MF
index fad21f3642b..2fc480ae26d 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component.tests/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
org.junit;bundle-version="4.10.0",
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite.tests/META-INF/MANIFEST.MF
index 374ee5a09d0..8fd283d190f 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite.tests/META-INF/MANIFEST.MF
@@ -9,7 +9,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
org.junit;bundle-version="4.10.0",
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment.tests/META-INF/MANIFEST.MF
index 5bfad2e47f0..89181b12475 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment.tests/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
org.junit;bundle-version="4.10.0",
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd.tests/META-INF/MANIFEST.MF
index 8a6f2ecaf05..fe54cbdc8c3 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd.tests/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.6.0",
org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.uml.tools;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.gmfdiag.dnd;bundle-version="[1.2.0,2.0.0)",
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview.tests/META-INF/MANIFEST.MF
index 25e5726a791..1d3cc1053f5 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview.tests/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.uml.diagram.activity;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.diagram.timing;bundle-version="[1.3.0,2.0.0)",
org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.0.2",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.gmf.runtime.diagram.ui,
org.eclipse.gmf.runtime.diagram.ui,
org.junit;bundle-version="4.10.0",
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile.tests/META-INF/MANIFEST.MF
index ef74112ca4e..d02f3b3652d 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile.tests/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Require-Bundle: org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
org.junit;bundle-version="4.10.0",
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine.tests/META-INF/MANIFEST.MF
index f3fafd3a06c..893e3629335 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine.tests/META-INF/MANIFEST.MF
@@ -9,7 +9,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
org.junit;bundle-version="4.10.0",
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests/META-INF/MANIFEST.MF
index 4567cf41ed7..b0a92b96582 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotypeproperty.tests/META-INF/MANIFEST.MF
@@ -9,7 +9,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.extensionpoints;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.uml.tools;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.0.0,4.0.0)",
org.eclipse.ui.ide;bundle-version="3.8.0",
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.tests/META-INF/MANIFEST.MF
index dacf909e351..31d4ee4a0af 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.tests/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
org.eclipse.ui.ide;bundle-version="3.8.0",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing.tests/META-INF/MANIFEST.MF
index 6b84cbbadc1..883cb43f7a3 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing.tests/META-INF/MANIFEST.MF
@@ -12,7 +12,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.ui.ide;bundle-version="3.8.0",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.1.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.junit;bundle-version="4.10.0",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase.tests/META-INF/MANIFEST.MF
index 0fed61b1eaf..a134d1faba3 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase.tests/META-INF/MANIFEST.MF
@@ -12,7 +12,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.uml.diagram.usecase;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.diagram.tests;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.uml.service.types;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/META-INF/MANIFEST.MF
index b0f2370f5eb..266be0a2a9a 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.uml2.uml;bundle-version="3.1.0",
+Require-Bundle: org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.uml.diagram.wizards;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.diagram.profile;bundle-version="[3.0.0,4.0.0)",
org.eclipse.ui.workbench;bundle-version="3.103.1",
diff --git a/tests/junit/plugins/uml/expressions/org.eclipse.papyrus.uml.expressions.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/expressions/org.eclipse.papyrus.uml.expressions.tests/META-INF/MANIFEST.MF
index 929a72fbeb5..c3ca066c89b 100755
--- a/tests/junit/plugins/uml/expressions/org.eclipse.papyrus.uml.expressions.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/expressions/org.eclipse.papyrus.uml.expressions.tests/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Bundle-SymbolicName: org.eclipse.papyrus.uml.expressions.tests
Bundle-Version: 1.0.0.qualifier
Bundle-Vendor: %Bundle-Vendor
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.uml2.uml;bundle-version="[5.2.0,6.0.0)",
+Require-Bundle: org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.emf.expressions;bundle-version="[1.0.0,2.0.0)",
org.eclipse.papyrus.uml.expressions;bundle-version="[1.0.0,2.0.0)",
org.eclipse.papyrus.editor.integration.tests;bundle-version="[1.2.0,2.0.0)",
diff --git a/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.tests/META-INF/MANIFEST.MF
index 126c362b8b6..b2d708f5fc2 100644
--- a/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.tests/META-INF/MANIFEST.MF
@@ -18,7 +18,7 @@ Require-Bundle: org.junit;bundle-version="[4.11.0,5.0.0)",
org.eclipse.papyrus.uml.internationalization.utils;bundle-version="[1.0.0,2.0.0)",
org.eclipse.ui.workbench;bundle-version="[3.108.0,4.0.0)",
org.eclipse.papyrus.infra.emf.tests;bundle-version="[1.4.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.2.0,6.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.internationalization.common;bundle-version="[1.0.0,2.0.0)",
org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/tests/junit/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.tests/META-INF/MANIFEST.MF
index af90278bfed..dfd2b7c8cdc 100644
--- a/tests/junit/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.tests/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.views.modelexplorer.tests;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.0.0,4.0.0)",
org.eclipse.emf.ecore,
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.ui.navigator,
org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.200",
org.eclipse.ui.ide;bundle-version="3.8.0",
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config.tests/META-INF/MANIFEST.MF
index 101519735c4..99c44d98a51 100644
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config.tests/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.papyrus.infra.nattable;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.nattable.clazz.config;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.0.1",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
org.junit;bundle-version="4.11.0",
org.eclipse.papyrus.editor.integration.tests;bundle-version="[1.2.0,2.0.0)",
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/META-INF/MANIFEST.MF
index 79b587ea839..5edb2321fba 100755
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.tests/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Require-Bundle: org.junit;bundle-version="4.11.0",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
org.eclipse.emf.ecore,
org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml,
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)",
org.eclipse.gmf.runtime.diagram.ui,
org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.5.0,2.0.0)",
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display.tests/META-INF/MANIFEST.MF
index 899835ea982..85fb89a71c3 100644
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display.tests/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Require-Bundle: org.junit;bundle-version="4.11.0",
org.eclipse.papyrus.editor.integration.tests;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml,
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.gmf.runtime.notation,
org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.gef,
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/META-INF/MANIFEST.MF
index de989da6936..3334ba52aaf 100644
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotyped.elements.tests/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Require-Bundle: org.eclipse.ui;bundle-version="[3.108.0,4.0.0)",
org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
org.junit;bundle-version="[4.12.0,5.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.2.0,6.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.nattable.common;bundle-version="[3.0.0,4.0.0)",
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.tests/META-INF/MANIFEST.MF
index 73c67e92dbf..ff7d5415ca5 100644
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.junit;bundle-version="4.11.0",
- org.eclipse.uml2.uml,
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.nattable;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.nattable.model;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.nattable;bundle-version="[3.0.0,4.0.0)",
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.filters.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.filters.tests/META-INF/MANIFEST.MF
index 95df7569ec3..7140812766d 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.filters.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.filters.tests/META-INF/MANIFEST.MF
@@ -4,8 +4,8 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.papyrus.uml.filters;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.ecore;bundle-version="2.11.0";visibility:=reexport,
org.eclipse.papyrus.infra.filters;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
- org.eclipse.uml2.types;bundle-version="2.0.0";visibility:=reexport,
- org.eclipse.uml2.uml;bundle-version="5.1.0";visibility:=reexport,
+ org.eclipse.uml2.types;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)";visibility:=reexport,
org.eclipse.emf.ecore.xmi;bundle-version="2.11.0";visibility:=reexport,
org.junit;visibility:=reexport,
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/META-INF/MANIFEST.MF
index 78961abb0e8..dc005a5ea4a 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Require-Bundle: org.junit;bundle-version="4.10.0",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.uml.modelrepair;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.2.0,6.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.emf.readonly;bundle-version="[3.0.0,4.0.0)"
Export-Package: org.eclipse.papyrus.uml.modelrepair.internal.stereotypes,
org.eclipse.papyrus.uml.modelrepair.internal.uripattern,
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/META-INF/MANIFEST.MF
index 2b90b849193..8d6bdf7a9f3 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Require-Bundle: org.junit;bundle-version="4.10.0",
org.eclipse.papyrus.uml.extensionpoints;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.uml.service.types;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.newchild;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.2.0,6.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.uml2.uml.profile.standard;bundle-version="[1.0.0,2.0.0)"
Export-Package: org.eclipse.papyrus.uml.service.types.tests.creation,
org.eclipse.papyrus.uml.service.types.tests.deletion,
diff --git a/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/META-INF/MANIFEST.MF
index 08c0faa6686..0a2b8f10b88 100644
--- a/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Require-Bundle: org.eclipse.papyrus.uml.profile.drafter;bundle-version="[1.3.0,2.0.0)",
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
org.eclipse.core.databinding,
org.eclipse.core.databinding.beans,
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.tests/META-INF/MANIFEST.MF
index 4b406c2438b..21ea0a2f8d9 100644
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.papyrus.uml.xtext.integration.ui;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.uml.textedit.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
org.junit;bundle-version="4.11.0",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.tests/META-INF/MANIFEST.MF
index ccce65b13dc..21f043d962b 100644
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.tests/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.papyrus.uml.textedit.tests;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.junit;bundle-version="4.11.0",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.uml.textedit.port.xtext.ui;bundle-version="[2.0.0,3.0.0)",
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.tests/META-INF/MANIFEST.MF
index 3a3fbfcb273..252e75e0e00 100644
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.tests/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.papyrus.uml.textedit.tests;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.uml.textedit.property.xtext.ui;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.uml.xtext.integration.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.uml.tools;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.tests/META-INF/MANIFEST.MF
index ae548648670..dffc3ca41a4 100644
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.tests/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.papyrus.uml.xtext.integration.core;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.uml.xtext.integration.ui;bundle-version="[2.0.0,3.0.0)",
org.eclipse.emf.ecore;bundle-version="2.11.0",
- org.eclipse.uml2.uml;bundle-version="5.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.gmf.runtime.common.ui.services;bundle-version="1.7.0",
org.eclipse.gmf.runtime.emf.core;bundle-version="1.7.0",
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
diff --git a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.tests/META-INF/MANIFEST.MF
index d1893df4008..a6661d95706 100644
--- a/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.tests/META-INF/MANIFEST.MF
@@ -1,6 +1,6 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.uml2.uml;bundle-version="5.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.junit;bundle-version="4.11.0",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.uml.xtext.integration.ui;bundle-version="[2.0.0,3.0.0)",
diff --git a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/META-INF/MANIFEST.MF
index b4409dc4de8..54c06752db9 100644
--- a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.genvalidation/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.emf.validation,
org.eclipse.papyrus.uml.service.validation;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.uml2.uml,
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.uml.validation.tests.staticprofile;bundle-version="[1.2.0,2.0.0)"
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.validation.tests.genvalidation.Activator
diff --git a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.staticprofile/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.staticprofile/META-INF/MANIFEST.MF
index 573e6c73ad2..23fb8229682 100644
--- a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.staticprofile/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests.staticprofile/META-INF/MANIFEST.MF
@@ -11,8 +11,8 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.emf.common;bundle-version="2.12.0",
org.eclipse.emf.ecore;bundle-version="2.12.0";visibility:=reexport,
- org.eclipse.uml2.types;visibility:=reexport,
- org.eclipse.uml2.uml;bundle-version="5.1.100";visibility:=reexport
+ org.eclipse.uml2.types;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)";visibility:=reexport
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.validation.tests.staticprofile.Activator
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/META-INF/MANIFEST.MF
index ab911f192d8..c2a63955e04 100644
--- a/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/validation/org.eclipse.papyrus.uml.validation.tests/META-INF/MANIFEST.MF
@@ -12,7 +12,7 @@ Require-Bundle: org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.uml.service.validation;bundle-version="[2.1.0,3.0.0)",
org.eclipse.gmf.runtime.emf.commands.core;bundle-version="1.7.0",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="5.0.0";visibility:=reexport,
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)";visibility:=reexport,
org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
org.eclipse.ocl.xtext.completeocl;bundle-version="1.1.0",
org.eclipse.ocl.pivot.uml;bundle-version="1.1.0",
diff --git a/tests/junit/plugins/views/org.eclipse.papyrus.views.modelexplorer.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/views/org.eclipse.papyrus.views.modelexplorer.tests/META-INF/MANIFEST.MF
index 6231f3c2e35..5f0a5a045a7 100644
--- a/tests/junit/plugins/views/org.eclipse.papyrus.views.modelexplorer.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/views/org.eclipse.papyrus.views.modelexplorer.tests/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.core.resources,
org.eclipse.ui.ide,
org.eclipse.ui.navigator,
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.gmf.runtime.notation,
org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.0.0,4.0.0)",
org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.200",
diff --git a/tests/junit/plugins/views/org.eclipse.papyrus.views.properties.toolsmiths.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/views/org.eclipse.papyrus.views.properties.toolsmiths.tests/META-INF/MANIFEST.MF
index dfa3049a17d..0245f23dc8a 100644
--- a/tests/junit/plugins/views/org.eclipse.papyrus.views.properties.toolsmiths.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/views/org.eclipse.papyrus.views.properties.toolsmiths.tests/META-INF/MANIFEST.MF
@@ -11,7 +11,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.emf;bundle-version="1.2.0",
org.eclipse.m2m.qvt.oml;bundle-version="3.2.0",
org.eclipse.core.resources;bundle-version="3.8.0",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
+ org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.junit;bundle-version="4.10.0",
org.eclipse.core.databinding;bundle-version="1.4.1",
org.eclipse.papyrus.junit.framework;bundle-version="1.2.0",

Back to the top