Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenoit Maggi2017-03-30 11:34:38 +0000
committerGerrit Code Review @ Eclipse.org2017-04-06 10:11:56 +0000
commit5e003e0b53e1ad9e4cfb10acc96a407324026816 (patch)
tree08a8fcd218cb3ced3a4ae24abb38eb2fc4f79fe4 /tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/META-INF/MANIFEST.MF
parent52394556389df5daa214a659ecae3d12060117c5 (diff)
downloadorg.eclipse.papyrus-5e003e0b53e1ad9e4cfb10acc96a407324026816.tar.gz
org.eclipse.papyrus-5e003e0b53e1ad9e4cfb10acc96a407324026816.tar.xz
org.eclipse.papyrus-5e003e0b53e1ad9e4cfb10acc96a407324026816.zip
Bug 514332 - Papyrus should never reexport non-singleton plugins
- remove Required-Bundle Guava (and their re-export) - use package import for Guava dependencies Change-Id: Ie1e383b6b8ed1d57747345c2788c0c63de1f08bb Signed-off-by: Benoit Maggi <benoit.maggi@cea.fr> Signed-off-by: Florian Noyrit <florian.noyrit@cea.fr>
Diffstat (limited to 'tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/META-INF/MANIFEST.MF')
-rwxr-xr-xtests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/META-INF/MANIFEST.MF2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/META-INF/MANIFEST.MF
index 4081258b261..a46f2fe41a9 100755
--- a/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.suite.tests/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.nattable.suite.tests.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.uml.nattable.suite.tests
+Bundle-SymbolicName: org.eclipse.papyrus.uml.nattable.suite.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,

Back to the top