Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Lorenzo2020-07-15 03:40:50 -0400
committerQuentin Le Menez2020-11-09 03:37:35 -0500
commitcbc2667bb24b2c8e946afeedc904ba3bf718434a (patch)
treee83615bd87a700b068411914f217887e216ce9ef /tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF
parente3b8ccf5f618d96996a9f1b7f64d9a4367861423 (diff)
downloadorg.eclipse.papyrus-cbc2667bb24b2c8e946afeedc904ba3bf718434a.tar.gz
org.eclipse.papyrus-cbc2667bb24b2c8e946afeedc904ba3bf718434a.tar.xz
org.eclipse.papyrus-cbc2667bb24b2c8e946afeedc904ba3bf718434a.zip
Bug 565020: Remove all reexported dependencies
- update pom version - update manifest project version - remove all re-export - add all missing required dependencies (with developped tooling + add many others required handly) - remove the optional attribute (and maybe others) - update target platform - fix 2 features verify manually: - infra.architecture - infra.constraints - infra.core - infra.emf.expression - infra.emf - facet.editor - facet make in ignore org.eclipse.papyrus.uml.decoratormodel.internal.resource.tests.DecoratorModelIndexTest.decoratorModelsForPackage_none() Change-Id: Id83401c9c46ab360214407572c4d5bd35cb8c03e Signed-off-by: Vincent Lorenzo <vincent.lorenzo@cea.fr>
Diffstat (limited to 'tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF')
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF22
1 files changed, 7 insertions, 15 deletions
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF
index 2a54e8a67fe..916169541ce 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF
@@ -1,21 +1,13 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.core.resources;bundle-version="3.8.0",
- org.eclipse.papyrus.infra.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.8.0",
- org.eclipse.papyrus.junit.utils;bundle-version="[2.0.100,3.0.0)",
- org.eclipse.papyrus.junit.framework;bundle-version="[1.2.0,2.0.0)",
- org.junit;bundle-version="4.11.0",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.editor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)"
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.papyrus.junit.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.junit.utils;bundle-version="[3.0.0,4.0.0)",
+ org.junit;bundle-version="[4.13.0,5.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration;bundle-version="5.0.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="4.0.0"
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.100.qualifier
+Bundle-Version: 2.0.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests.Activator

Back to the top