Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenoit Maggi2017-03-30 07:34:38 -0400
committerGerrit Code Review @ Eclipse.org2017-04-06 06:11:56 -0400
commit5e003e0b53e1ad9e4cfb10acc96a407324026816 (patch)
tree08a8fcd218cb3ced3a4ae24abb38eb2fc4f79fe4 /tests/junit/plugins/editor
parent52394556389df5daa214a659ecae3d12060117c5 (diff)
downloadorg.eclipse.papyrus-5e003e0b53e1ad9e4cfb10acc96a407324026816.tar.gz
org.eclipse.papyrus-5e003e0b53e1ad9e4cfb10acc96a407324026816.tar.xz
org.eclipse.papyrus-5e003e0b53e1ad9e4cfb10acc96a407324026816.zip
Bug 514332 - Papyrus should never reexport non-singleton plugins
- remove Required-Bundle Guava (and their re-export) - use package import for Guava dependencies Change-Id: Ie1e383b6b8ed1d57747345c2788c0c63de1f08bb Signed-off-by: Benoit Maggi <benoit.maggi@cea.fr> Signed-off-by: Florian Noyrit <florian.noyrit@cea.fr>
Diffstat (limited to 'tests/junit/plugins/editor')
-rw-r--r--tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/META-INF/MANIFEST.MF23
-rw-r--r--tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/resources/manifest_project/META-INF/MANIFEST.MF1
-rw-r--r--tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF5
3 files changed, 15 insertions, 14 deletions
diff --git a/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/META-INF/MANIFEST.MF
index d194ed496fe..cf15aceb3ac 100644
--- a/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/META-INF/MANIFEST.MF
@@ -1,11 +1,12 @@
-Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.eclipse.project.editors;bundle-version="[2.0.0,3.0.0)"
-Export-Package: org.eclipse.papyrus.eclipse.project.editors.tests
-Bundle-Vendor: Eclipse Modeling Project
-Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.0.0.qualifier
-Bundle-Name: Papyrus Project Editor Tests
-Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.eclipse.project.editors.tests
-Bundle-RequiredExecutionEnvironment: JavaSE-1.8
+Manifest-Version: 1.0
+Require-Bundle: org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.eclipse.project.editors;bundle-version="[2.0.0,3.0.0)"
+Export-Package: org.eclipse.papyrus.eclipse.project.editors.tests
+Bundle-Vendor: Eclipse Modeling Project
+Bundle-ActivationPolicy: lazy
+Bundle-Version: 2.0.0.qualifier
+Bundle-Name: Papyrus Project Editor Tests
+Bundle-ManifestVersion: 2
+Bundle-SymbolicName: org.eclipse.papyrus.eclipse.project.editors.tests;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
+Import-Package: com.google.common.base;version="21.0.0"
diff --git a/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/resources/manifest_project/META-INF/MANIFEST.MF b/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/resources/manifest_project/META-INF/MANIFEST.MF
index f827b91b90e..3ee70470ab6 100644
--- a/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/resources/manifest_project/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/resources/manifest_project/META-INF/MANIFEST.MF
@@ -2,7 +2,6 @@ Manifest-Version: 1.0
Require-Bundle: org.eclipse.papyrus.junit.utils;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.eclipse.project.editors;bundle-version="[2.0.0,3.0.0)",
org.eclipse.ui;bundle-version="3.6.0";resolution:=optional,
- com.google.guava;bundle-version="21.0.0",
org.eclipse.core.resources;visibility:=reexport
Import-Package: com.ibm.icu.text;resolution:=optional,
org.eclipse.emf.ecore;version="2.10.0"
diff --git a/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF
index 28036c59815..68a2d13a6e3 100644
--- a/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF
@@ -24,7 +24,6 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.ui.navigator;bundle-version="3.5.0",
org.eclipse.papyrus.infra.services.validation;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.service.validation;bundle-version="[2.1.0,3.0.0)",
- com.google.guava;bundle-version="21.0.0",
org.eclipse.papyrus.infra.nattable.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.nattable;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.nattable.menu;bundle-version="[1.2.0,2.0.0)",
@@ -43,5 +42,7 @@ Bundle-Version: 1.2.0.qualifier
Bundle-Name: Papyrus Editor Integration Tests
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.editor.integration.tests.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.editor.integration.tests
+Bundle-SymbolicName: org.eclipse.papyrus.editor.integration.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Import-Package: com.google.common.base;version="21.0.0",
+ com.google.common.collect;version="21.0.0"

Back to the top