Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Lorenzo2015-02-18 11:52:29 +0000
committerVincent Lorenzo2015-02-18 14:03:30 +0000
commiteb09607cd4fe5b2545c0adacd0a03f51f19bd083 (patch)
treef722a078102042fa57b0028a865ab0b88e4b129f /plugins
parentc984b4700a718b800a8df6fb401345289c193dc5 (diff)
downloadorg.eclipse.papyrus-eb09607cd4fe5b2545c0adacd0a03f51f19bd083.tar.gz
org.eclipse.papyrus-eb09607cd4fe5b2545c0adacd0a03f51f19bd083.tar.xz
org.eclipse.papyrus-eb09607cd4fe5b2545c0adacd0a03f51f19bd083.zip
460098: [Table 2] Papyrus must use the new nattable release on branch master
Diffstat (limited to 'plugins')
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.emf.nattable/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.properties/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.config/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.editor/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/src/org/eclipse/papyrus/infra/nattable/sort/ColumnSortModel.java13
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.allocation.config/META-INF/MANIFEST.MF2
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.menu/META-INF/MANIFEST.MF2
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.requirement/META-INF/MANIFEST.MF2
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.menu/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.xtext.integration/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable/src/org/eclipse/papyrus/uml/nattable/editor/StereotypeApplierCellEditorWrapper.java14
16 files changed, 44 insertions, 17 deletions
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.emf.nattable/META-INF/MANIFEST.MF b/plugins/infra/nattable/org.eclipse.papyrus.infra.emf.nattable/META-INF/MANIFEST.MF
index de06adb48e1..16ddf03ac7d 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.emf.nattable/META-INF/MANIFEST.MF
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.emf.nattable/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Export-Package: org.eclipse.papyrus.infra.emf.nattable,
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.papyrus.infra.core.log;bundle-version="1.1.0",
- org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.2.0,2.0.0)",
org.eclipse.emf.ecore;bundle-version="2.9.0",
org.eclipse.papyrus.infra.nattable.model;bundle-version="1.1.0",
org.eclipse.papyrus.infra.nattable;bundle-version="1.1.0",
@@ -28,7 +28,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.tools;bundle-version="1.1.0",
ca.odell.glazedlists;bundle-version="1.9.0",
com.google.guava;bundle-version="15.0.0",
- org.eclipse.nebula.widgets.nattable.extension.glazedlists;bundle-version="[1.1.0,2.0.0)"
+ org.eclipse.nebula.widgets.nattable.extension.glazedlists;bundle-version="[1.2.0,2.0.0)"
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
Bundle-Version: 1.1.0.qualifier
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF
index 56c11636031..8e2dd2b4b7b 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF
@@ -14,7 +14,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.emf.edit,
org.eclipse.papyrus.infra.core;bundle-version="1.1.0",
org.eclipse.emf.transaction,
- org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.infra.widgets;bundle-version="1.1.0",
org.eclipse.papyrus.infra.emf;bundle-version="1.1.0",
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.1.0",
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.properties/META-INF/MANIFEST.MF b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.properties/META-INF/MANIFEST.MF
index 9bcaf74113e..e1fe7e03902 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.properties/META-INF/MANIFEST.MF
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.properties/META-INF/MANIFEST.MF
@@ -19,7 +19,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.constraints;bundle-version="1.1.0",
org.eclipse.papyrus.infra.core;bundle-version="1.1.0",
org.eclipse.papyrus.infra.services.edit;bundle-version="1.1.0",
- org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.2.0,2.0.0)",
org.eclipse.emf.databinding,
org.eclipse.core.databinding.property;bundle-version="1.4.200",
org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="1.1.0",
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.config/META-INF/MANIFEST.MF b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.config/META-INF/MANIFEST.MF
index 8cb2a986835..579f68cb61e 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.config/META-INF/MANIFEST.MF
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.config/META-INF/MANIFEST.MF
@@ -14,7 +14,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.emf;bundle-version="1.1.0",
org.eclipse.papyrus.infra.core.log;bundle-version="1.1.0",
org.eclipse.papyrus.infra.nattable;bundle-version="1.1.0",
- org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.infra.emf.nattable;bundle-version="1.1.0",
org.eclipse.emf.edit,
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="1.1.0",
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.editor/META-INF/MANIFEST.MF b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.editor/META-INF/MANIFEST.MF
index e7613a07d07..1e70d29a686 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.editor/META-INF/MANIFEST.MF
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.editor/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.core;bundle-version="1.1.0",
org.eclipse.emf.transaction;bundle-version="1.4.0",
org.eclipse.papyrus.infra.emf;bundle-version="1.1.0",
- org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.infra.emf.nattable;bundle-version="1.1.0",
org.eclipse.papyrus.infra.services.labelprovider;bundle-version="1.1.0",
org.eclipse.gmf.runtime.emf.type.core,
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF
index 427322d4195..19c6bb9099f 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF
@@ -57,14 +57,14 @@ Require-Bundle: org.eclipse.papyrus.infra.widgets;bundle-version="1.1.0",
org.eclipse.papyrus.infra.tools;bundle-version="1.1.0",
org.eclipse.emf.edit.ui,
org.eclipse.papyrus.infra.services.labelprovider;bundle-version="1.1.0",
- org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.2.0,2.0.0)",
org.eclipse.core.expressions,
org.eclipse.papyrus.infra.services.edit;bundle-version="1.1.0",
org.eclipse.papyrus.infra.widgets.toolbox;bundle-version="1.1.0",
com.google.guava;bundle-version="11.0.0",
org.eclipse.papyrus.emf.facet.custom.core;bundle-version="1.1.0",
org.eclipse.papyrus.emf.facet.custom.ui;bundle-version="1.1.0",
- org.eclipse.nebula.widgets.nattable.extension.glazedlists;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.nebula.widgets.nattable.extension.glazedlists;bundle-version="[1.2.0,2.0.0)",
ca.odell.glazedlists;bundle-version="1.9.0",
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.1.0"
Bundle-Vendor: %Bundle-Vendor
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/src/org/eclipse/papyrus/infra/nattable/sort/ColumnSortModel.java b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/src/org/eclipse/papyrus/infra/nattable/sort/ColumnSortModel.java
index 13275fc1464..ebe95a946c4 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/src/org/eclipse/papyrus/infra/nattable/sort/ColumnSortModel.java
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/src/org/eclipse/papyrus/infra/nattable/sort/ColumnSortModel.java
@@ -234,4 +234,17 @@ public class ColumnSortModel implements IPapyrusSortModel {
setAxisComparator();
}
+ /**
+ * @see org.eclipse.nebula.widgets.nattable.sort.ISortModel#getColumnComparator(int)
+ *
+ * @param columnIndex
+ * @return
+ */
+ @Override
+ public Comparator<?> getColumnComparator(int columnIndex) {
+ // TODO Auto-generated method stub
+ //TODO : new method coming from nattable 1.2.0
+ return null;
+ }
+
}
diff --git a/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.allocation.config/META-INF/MANIFEST.MF b/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.allocation.config/META-INF/MANIFEST.MF
index c52f77a07a2..0f4cbdf0f50 100644
--- a/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.allocation.config/META-INF/MANIFEST.MF
+++ b/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.allocation.config/META-INF/MANIFEST.MF
@@ -12,7 +12,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.uml.nattable.menu;bundle-version="1.1.0",
org.eclipse.papyrus.sysml.service.types;bundle-version="1.1.0",
org.eclipse.papyrus.uml.service.types;bundle-version="1.1.0",
- org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.2.0,2.0.0)",
org.eclipse.core.expressions
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
diff --git a/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.menu/META-INF/MANIFEST.MF b/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.menu/META-INF/MANIFEST.MF
index cc94ebeaf69..fad7ce29055 100644
--- a/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.menu/META-INF/MANIFEST.MF
+++ b/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.menu/META-INF/MANIFEST.MF
@@ -15,7 +15,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.core.sasheditor;bundle-version="1.1.0",
org.eclipse.papyrus.infra.core;bundle-version="1.1.0",
org.eclipse.papyrus.infra.nattable.model;bundle-version="1.1.0",
- org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.infra.core.log;bundle-version="1.1.0",
org.eclipse.uml2.uml;bundle-version="4.1.0",
org.eclipse.papyrus.infra.tools;bundle-version="1.1.0"
diff --git a/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.requirement/META-INF/MANIFEST.MF b/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.requirement/META-INF/MANIFEST.MF
index a53fa88d01b..39cdeabbedd 100644
--- a/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.requirement/META-INF/MANIFEST.MF
+++ b/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.requirement/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.sysml.service.types;bundle-version="1.1.0",
org.eclipse.papyrus.infra.core.log;bundle-version="1.1.0",
org.eclipse.papyrus.infra.nattable;bundle-version="1.1.0",
- org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.uml.nattable;bundle-version="1.1.0",
org.eclipse.papyrus.infra.nattable.common;bundle-version="1.1.0",
org.eclipse.uml2.uml;bundle-version="4.1.0",
diff --git a/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable/META-INF/MANIFEST.MF b/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable/META-INF/MANIFEST.MF
index ba84e8a8079..894a5979061 100644
--- a/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable/META-INF/MANIFEST.MF
+++ b/plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.uml.nattable;bundle-version="1.1.0",
org.eclipse.papyrus.infra.nattable;bundle-version="1.1.0",
org.eclipse.papyrus.infra.emf.nattable;bundle-version="1.1.0",
- org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.2.0,2.0.0)",
org.eclipse.uml2.uml;bundle-version="4.1.0",
org.eclipse.papyrus.infra.services.labelprovider;bundle-version="1.1.0",
org.eclipse.papyrus.sysml.service.types;bundle-version="1.1.0",
diff --git a/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config/META-INF/MANIFEST.MF b/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config/META-INF/MANIFEST.MF
index 21866532e31..bad15da2ce1 100644
--- a/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config/META-INF/MANIFEST.MF
+++ b/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config/META-INF/MANIFEST.MF
@@ -12,9 +12,9 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.uml.nattable;bundle-version="1.1.0",
org.eclipse.papyrus.infra.emf.nattable;bundle-version="1.1.0",
ca.odell.glazedlists;bundle-version="1.9.0",
- org.eclipse.nebula.widgets.nattable.extension.glazedlists;bundle-version="1.1.0",
+ org.eclipse.nebula.widgets.nattable.extension.glazedlists;bundle-version="[1.2.0,2.0.0)",
org.eclipse.emf.transaction;bundle-version="1.8.0",
- org.eclipse.nebula.widgets.nattable.core;bundle-version="1.1.0",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.infra.widgets;bundle-version="1.1.0",
org.eclipse.uml2.uml;bundle-version="5.0.1",
org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="1.1.0"
diff --git a/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.menu/META-INF/MANIFEST.MF b/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.menu/META-INF/MANIFEST.MF
index 000ac02c6a9..3bfd8e3af0a 100644
--- a/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.menu/META-INF/MANIFEST.MF
+++ b/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.menu/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.core.log;bundle-version="1.1.0",
org.eclipse.papyrus.infra.emf;bundle-version="1.1.0",
org.eclipse.papyrus.infra.nattable.common;bundle-version="1.1.0",
- org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="1.1.0",
org.eclipse.papyrus.infra.nattable.model;bundle-version="1.1.0",
org.eclipse.core.expressions,
diff --git a/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.xtext.integration/META-INF/MANIFEST.MF b/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.xtext.integration/META-INF/MANIFEST.MF
index 6964ea451be..512074724fd 100644
--- a/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.xtext.integration/META-INF/MANIFEST.MF
+++ b/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.xtext.integration/META-INF/MANIFEST.MF
@@ -11,7 +11,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.nattable.model;bundle-version="1.1.0",
org.eclipse.papyrus.uml.xtext.integration.ui;bundle-version="1.1.0",
org.eclipse.xtext;bundle-version="2.4.2",
- org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.2.0,2.0.0)",
org.eclipse.gmf.runtime.common.core,
org.eclipse.gmf.runtime.common.ui.services
Bundle-Vendor: %Bundle-Vendor
diff --git a/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable/META-INF/MANIFEST.MF b/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable/META-INF/MANIFEST.MF
index a8c9f980a25..1698d90a65c 100644
--- a/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable/META-INF/MANIFEST.MF
+++ b/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable/META-INF/MANIFEST.MF
@@ -15,7 +15,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.uml2.uml;bundle-version="4.1.0",
org.eclipse.papyrus.infra.core.log;bundle-version="1.1.0",
- org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="[1.2.0,2.0.0)",
org.eclipse.papyrus.infra.nattable;bundle-version="1.1.0",
org.eclipse.papyrus.infra.widgets;bundle-version="1.1.0",
org.eclipse.papyrus.uml.tools;bundle-version="1.1.0",
diff --git a/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable/src/org/eclipse/papyrus/uml/nattable/editor/StereotypeApplierCellEditorWrapper.java b/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable/src/org/eclipse/papyrus/uml/nattable/editor/StereotypeApplierCellEditorWrapper.java
index 5b223dc0c67..45eab180657 100644
--- a/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable/src/org/eclipse/papyrus/uml/nattable/editor/StereotypeApplierCellEditorWrapper.java
+++ b/plugins/uml/nattable/org.eclipse.papyrus.uml.nattable/src/org/eclipse/papyrus/uml/nattable/editor/StereotypeApplierCellEditorWrapper.java
@@ -429,4 +429,18 @@ public class StereotypeApplierCellEditorWrapper implements ICellEditor {
return wrappedCellEditor == null ? cellBounds : wrappedCellEditor.calculateControlBounds(cellBounds);
}
+ /**
+ * @see org.eclipse.nebula.widgets.nattable.edit.editor.ICellEditor#activateOnTraversal(org.eclipse.nebula.widgets.nattable.config.IConfigRegistry, java.util.List)
+ *
+ * @param configRegistry
+ * @param configLabels
+ * @return
+ */
+ @Override
+ public boolean activateOnTraversal(IConfigRegistry configRegistry, List<String> configLabels) {
+ // TODO Auto-generated method stub
+ //TODO : new method coming from nattable 1.2.0
+ return false;
+ }
+
}

Back to the top