Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCamille Letavernier2019-12-09 12:42:56 +0000
committerRemi Schnekenburger2020-04-07 09:53:43 +0000
commit373385222ee40e92d1ec436fcd36913b42079dfd (patch)
treef0373af3557295c77d57e01d6c2883ec7352d6e9 /plugins
parent28f97f2babda87ae35aad3756d577e1cd2ebec76 (diff)
downloadorg.eclipse.papyrus-373385222ee40e92d1ec436fcd36913b42079dfd.tar.gz
org.eclipse.papyrus-373385222ee40e92d1ec436fcd36913b42079dfd.tar.xz
org.eclipse.papyrus-373385222ee40e92d1ec436fcd36913b42079dfd.zip
Bug 558024: Unnecessary dependency from core to Eclipse UI
Change-Id: Id4481702b291c7309e218c0aaf195c97f5ba50d6 Signed-off-by: Camille Letavernier <cletavernier@eclipsesource.com>
Diffstat (limited to 'plugins')
-rwxr-xr-xplugins/emf/org.eclipse.papyrus.emf/META-INF/MANIFEST.MF3
-rwxr-xr-xplugins/emf/org.eclipse.papyrus.emf/src/org/eclipse/papyrus/emf/Activator.java18
2 files changed, 12 insertions, 9 deletions
diff --git a/plugins/emf/org.eclipse.papyrus.emf/META-INF/MANIFEST.MF b/plugins/emf/org.eclipse.papyrus.emf/META-INF/MANIFEST.MF
index 994a37108a9..aaadc15031d 100755
--- a/plugins/emf/org.eclipse.papyrus.emf/META-INF/MANIFEST.MF
+++ b/plugins/emf/org.eclipse.papyrus.emf/META-INF/MANIFEST.MF
@@ -5,8 +5,7 @@ Bundle-SymbolicName: org.eclipse.papyrus.emf
Bundle-Version: 1.0.0.qualifier
Bundle-Activator: org.eclipse.papyrus.emf.Activator
Bundle-Vendor: %Bundle-Vendor
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
+Require-Bundle: org.eclipse.core.runtime,
org.eclipse.core.resources;bundle-version="[3.13.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.14.0,3.0.0)",
org.eclipse.emf.ecore.xmi;bundle-version="[2.14.0,3.0.0)"
diff --git a/plugins/emf/org.eclipse.papyrus.emf/src/org/eclipse/papyrus/emf/Activator.java b/plugins/emf/org.eclipse.papyrus.emf/src/org/eclipse/papyrus/emf/Activator.java
index e1328913585..592e23ec31a 100755
--- a/plugins/emf/org.eclipse.papyrus.emf/src/org/eclipse/papyrus/emf/Activator.java
+++ b/plugins/emf/org.eclipse.papyrus.emf/src/org/eclipse/papyrus/emf/Activator.java
@@ -1,6 +1,6 @@
/*****************************************************************************
- * Copyright (c) 2018 CEA LIST and others.
- *
+ * Copyright (c) 2018 - 2019 CEA LIST, EclipseSource and others.
+ *
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License 2.0
* which accompanies this distribution, and is available at
@@ -10,25 +10,25 @@
*
* Contributors:
* Vincent LORENZO (CEA LIST) - Initial API and implementation
- *
+ * Camille Letavernier (EclipseSource) - Bug 558024
+ *
*****************************************************************************/
-
package org.eclipse.papyrus.emf;
-import org.eclipse.ui.plugin.AbstractUIPlugin;
+import org.eclipse.core.runtime.Plugin;
import org.osgi.framework.BundleContext;
/**
* The activator class controls the plug-in life cycle
*/
-public class Activator extends AbstractUIPlugin {
+public class Activator extends Plugin {
// The plug-in ID
public static final String PLUGIN_ID = "org.eclipse.papyrus.emf"; //$NON-NLS-1$
// The shared instance
private static Activator plugin;
-
+
/**
* The constructor
*/
@@ -37,8 +37,10 @@ public class Activator extends AbstractUIPlugin {
/*
* (non-Javadoc)
+ *
* @see org.eclipse.ui.plugin.AbstractUIPlugin#start(org.osgi.framework.BundleContext)
*/
+ @Override
public void start(BundleContext context) throws Exception {
super.start(context);
plugin = this;
@@ -46,8 +48,10 @@ public class Activator extends AbstractUIPlugin {
/*
* (non-Javadoc)
+ *
* @see org.eclipse.ui.plugin.AbstractUIPlugin#stop(org.osgi.framework.BundleContext)
*/
+ @Override
public void stop(BundleContext context) throws Exception {
plugin = null;
super.stop(context);

Back to the top