Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian W. Damus2016-02-11 21:38:52 +0000
committerChristian W. Damus2016-02-24 22:26:27 +0000
commit09fde7a4087685b065b7f1e40375686fb9f19f2a (patch)
tree36668c0515a08586179a74cefcf1dc6197311d70 /plugins
parent2f0dd86c51f8543f56a99cd4371965a01287fcaa (diff)
downloadorg.eclipse.papyrus-09fde7a4087685b065b7f1e40375686fb9f19f2a.tar.gz
org.eclipse.papyrus-09fde7a4087685b065b7f1e40375686fb9f19f2a.tar.xz
org.eclipse.papyrus-09fde7a4087685b065b7f1e40375686fb9f19f2a.zip
Bug 485220: [Architecture] Provide a more modular architecture
https://bugs.eclipse.org/bugs/show_bug.cgi?id=485220 Implement version management: PDE API Tooling and Oomph Version Management. Introduce two new plug-in projects to manage versioning using Oomph: * org.eclipse.papyrus.releng.main.release for the Main bundles and features * org.eclipse.papyrus.releng.dev.release for the Dev Tools Add new menu actions to the Dev Tools: * main menu bar: * synchronize POM and manifest versions * "Configure" context menu on bundle projects and MANIFEST.MF * optimize bundle dependencies and re-exports * update dependency version ranges to match current workspace and PDE target Remove obsolete menu actions from the Dev Tools: * main menu bar: * Set all Papyrus feature versions * Set all Papyrus plug-in versions * Set versions of all Papyrus dependencies in Papyrus plug-ins Fix versioning errors reported by PDE and Oomph. Ensure proper version ranges consistent with latest build target. Optimize the dependencies of all Papyrus Main bundles and Dev Tools. Remove version- and reexport-checking tests in the BundlesTests that are now not needed because, on the one hand, we now implement discrete bundle versioning (managed by PDE/Oomph) and on the other, we now use re-exports properly to ensure classpath consistency in clients of a bundle's API. Thorough overhaul of the "project editors" API, including: * rationalize the API interfaces * refactor the all-in-one PluginEditor class from the customization bundle to the project-editors bundle * update clients in the Customization and DSML Validation components * fix a bunch of operations that didn't work * add missing operations required by the new Dev Tools actions * complete some unimplemented APIs * add a comprehensive JUnit test suite covering all of the project-editors API Change-Id: I6a699d93909f61099226ceb994140f03ea99a70f
Diffstat (limited to 'plugins')
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.extendedtypes.emf/.project74
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.extendedtypes.emf/META-INF/MANIFEST.MF6
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.extendedtypes.uml/.project74
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.extendedtypes.uml/META-INF/MANIFEST.MF6
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.extendedtypes/.project74
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.extendedtypes/META-INF/MANIFEST.MF4
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.palette/.project74
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.palette/META-INF/MANIFEST.MF43
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/.project76
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/META-INF/MANIFEST.MF36
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties.generation/.project94
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties.generation/META-INF/MANIFEST.MF71
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/.project98
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/META-INF/MANIFEST.MF46
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties/.project78
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties/META-INF/MANIFEST.MF58
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization/META-INF/MANIFEST.MF23
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ConstraintEnvironmentExtensionFactory.java86
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ExtensionFactory.java60
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/FileBasedExtensionFactory.java292
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ModelTemplateExtensionFactory.java134
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ProfileExtensionFactory.java216
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/PropertyViewEnvironmentExtensionFactory.java6
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/PropertyViewExtensionFactory.java12
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/UICustomExtensionFactory.java108
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/UMLModelExtensionFactory.java138
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/generator/PluginGenerator.java192
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/plugin/PluginEditor.java257
-rw-r--r--plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.edit/.project74
-rw-r--r--plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.edit/META-INF/MANIFEST.MF32
-rw-r--r--plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.editor/.project74
-rw-r--r--plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.editor/META-INF/MANIFEST.MF34
-rw-r--r--plugins/developer/org.eclipse.papyrus.codegen/.project81
-rw-r--r--plugins/developer/org.eclipse.papyrus.codegen/META-INF/MANIFEST.MF40
-rw-r--r--plugins/developer/org.eclipse.papyrus.def/.project125
-rw-r--r--plugins/developer/org.eclipse.papyrus.def/META-INF/MANIFEST.MF31
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.assistants.codegen/.project15
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.assistants.codegen/META-INF/MANIFEST.MF47
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/.classpath2
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/.project15
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/META-INF/MANIFEST.MF39
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/plugin.xml115
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/AbstractChangeProjectVersionHandler.java129
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/SyncManifestAndPOMVersions.java271
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/features/ChangeFeatureVersionHandler.java59
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/AbstractManifestUpdateHandler.java140
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/ChangeDependencyVersionNumberHandler.java257
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/ChangePluginVersionHandler.java50
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/OptimizeDependenciesHandler.java38
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/UpdateDependencyRangesHandler.java40
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/AbstractManifestUpdateOperation.java68
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/DependencyAnalysisContext.java705
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/DependencyKind.java81
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/OptimizeDependenciesOperation.java104
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/UpdateDependencyRangesOperation.java81
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java221
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.tests.framework.ui/.project21
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.tests.framework.ui/META-INF/MANIFEST.MF32
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.tests.framework/.project25
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.tests.framework/META-INF/MANIFEST.MF31
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.tests.framework/pom.xml4
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.view.services.edit.request/.project69
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.view.services.edit.request/META-INF/MANIFEST.MF29
-rw-r--r--plugins/developer/org.eclipse.papyrus.developer.profile/.project74
-rw-r--r--plugins/developer/org.eclipse.papyrus.developer.profile/META-INF/MANIFEST.MF26
-rw-r--r--plugins/developer/org.eclipse.papyrus.doc/.project62
-rw-r--r--plugins/developer/org.eclipse.papyrus.doc/META-INF/MANIFEST.MF24
-rw-r--r--plugins/developer/org.eclipse.papyrus.domaincodegen.ui/.project18
-rw-r--r--plugins/developer/org.eclipse.papyrus.domaincodegen.ui/META-INF/MANIFEST.MF14
-rw-r--r--plugins/developer/org.eclipse.papyrus.domaincontextcodegen.edit/.project15
-rw-r--r--plugins/developer/org.eclipse.papyrus.domaincontextcodegen.edit/META-INF/MANIFEST.MF10
-rw-r--r--plugins/developer/org.eclipse.papyrus.domaincontextcodegen.editor/.project69
-rw-r--r--plugins/developer/org.eclipse.papyrus.domaincontextcodegen.editor/META-INF/MANIFEST.MF38
-rw-r--r--plugins/developer/org.eclipse.papyrus.domaincontextcodegen/.project81
-rw-r--r--plugins/developer/org.eclipse.papyrus.domaincontextcodegen/META-INF/MANIFEST.MF45
-rw-r--r--plugins/developer/org.eclipse.papyrus.gmf.editpartview/.project69
-rw-r--r--plugins/developer/org.eclipse.papyrus.gmf.editpartview/META-INF/MANIFEST.MF35
-rw-r--r--plugins/developer/org.eclipse.papyrus.gmf.editpoliciesstates/.project69
-rw-r--r--plugins/developer/org.eclipse.papyrus.gmf.editpoliciesstates/META-INF/MANIFEST.MF31
-rw-r--r--plugins/developer/org.eclipse.papyrus.gmf.figureview/.project69
-rw-r--r--plugins/developer/org.eclipse.papyrus.gmf.figureview/META-INF/MANIFEST.MF35
-rw-r--r--plugins/developer/org.eclipse.papyrus.gmfgenextension/.project69
-rw-r--r--plugins/developer/org.eclipse.papyrus.gmfgenextension/META-INF/MANIFEST.MF45
-rw-r--r--plugins/developer/org.eclipse.papyrus.infra.emf.commandstack/.project21
-rw-r--r--plugins/developer/org.eclipse.papyrus.infra.emf.commandstack/META-INF/MANIFEST.MF14
-rw-r--r--plugins/developer/org.eclipse.papyrus.infra.extendedtypes.elementtypeview/.project80
-rw-r--r--plugins/developer/org.eclipse.papyrus.infra.extendedtypes.elementtypeview/META-INF/MANIFEST.MF36
-rw-r--r--plugins/developer/org.eclipse.papyrus.infra.gmfdiag.css.debug/.project69
-rw-r--r--plugins/developer/org.eclipse.papyrus.infra.gmfdiag.css.debug/META-INF/MANIFEST.MF19
-rw-r--r--plugins/developer/org.eclipse.papyrus.mwe2.utils/.project17
-rw-r--r--plugins/developer/org.eclipse.papyrus.mwe2.utils/META-INF/MANIFEST.MF39
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.dev.release/.classpath6
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.dev.release/.project35
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.dev.release/META-INF/MANIFEST.MF7
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.dev.release/OSGI-INF/l10n/bundle.properties14
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.dev.release/about.html28
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.dev.release/build.properties7
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.dev.release/pom.xml13
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.dev.release/release.digestbin0 -> 2279 bytes
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.dev.release/release.properties5
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.dev.release/release.xml80
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.main.release/.classpath6
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.main.release/.project35
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.main.release/META-INF/MANIFEST.MF7
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.main.release/OSGI-INF/l10n/bundle.properties14
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.main.release/about.html28
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.main.release/build.properties7
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.main.release/pom.xml13
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.main.release/release.digestbin0 -> 27551 bytes
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.main.release/release.properties5
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.main.release/release.xml780
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.tools/.project85
-rw-r--r--plugins/developer/org.eclipse.papyrus.releng.tools/META-INF/MANIFEST.MF38
-rw-r--r--plugins/developer/org.eclipse.papyrus.uml.developer.mde/.project69
-rw-r--r--plugins/developer/org.eclipse.papyrus.uml.developer.mde/META-INF/MANIFEST.MF55
-rw-r--r--plugins/doc/org.eclipse.papyrus.cdo.ui.doc/.project18
-rw-r--r--plugins/doc/org.eclipse.papyrus.cdo.ui.doc/META-INF/MANIFEST.MF22
-rw-r--r--plugins/doc/org.eclipse.papyrus.copypaste.ui.doc/.project18
-rw-r--r--plugins/doc/org.eclipse.papyrus.copypaste.ui.doc/META-INF/MANIFEST.MF20
-rw-r--r--plugins/doc/org.eclipse.papyrus.dsml.validation.doc/.project86
-rw-r--r--plugins/doc/org.eclipse.papyrus.dsml.validation.doc/META-INF/MANIFEST.MF28
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.doc/.project92
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.doc/META-INF/MANIFEST.MF20
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.gmfdiag.common.doc/.project86
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.gmfdiag.common.doc/META-INF/MANIFEST.MF18
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.gmfdiag.css.doc/.project18
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.gmfdiag.css.doc/META-INF/MANIFEST.MF16
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.nattable.doc/.project86
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.nattable.doc/META-INF/MANIFEST.MF18
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.newchild.doc/.project92
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.newchild.doc/META-INF/MANIFEST.MF18
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.services.controlmode.doc/.project86
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.services.controlmode.doc/META-INF/MANIFEST.MF18
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.viewpoints.doc/.project18
-rw-r--r--plugins/doc/org.eclipse.papyrus.infra.viewpoints.doc/META-INF/MANIFEST.MF18
-rw-r--r--plugins/doc/org.eclipse.papyrus.layers.documentation/.project18
-rw-r--r--plugins/doc/org.eclipse.papyrus.layers.documentation/META-INF/MANIFEST.MF18
-rw-r--r--plugins/doc/org.eclipse.papyrus.req.reqif.doc/.project86
-rw-r--r--plugins/doc/org.eclipse.papyrus.req.reqif.doc/META-INF/MANIFEST.MF26
-rw-r--r--plugins/doc/org.eclipse.papyrus.uml.decoratormodel.doc/.project18
-rw-r--r--plugins/doc/org.eclipse.papyrus.uml.decoratormodel.doc/META-INF/MANIFEST.MF22
-rw-r--r--plugins/doc/org.eclipse.papyrus.uml.diagram.common.doc/.project86
-rw-r--r--plugins/doc/org.eclipse.papyrus.uml.diagram.common.doc/META-INF/MANIFEST.MF16
-rw-r--r--plugins/doc/org.eclipse.papyrus.uml.diagram.profile.doc/.project86
-rw-r--r--plugins/doc/org.eclipse.papyrus.uml.diagram.profile.doc/META-INF/MANIFEST.MF16
-rw-r--r--plugins/doc/org.eclipse.papyrus.uml.doc/.project86
-rw-r--r--plugins/doc/org.eclipse.papyrus.uml.doc/META-INF/MANIFEST.MF16
-rw-r--r--plugins/doc/org.eclipse.papyrus.uml.modelrepair.doc/.project18
-rw-r--r--plugins/doc/org.eclipse.papyrus.uml.modelrepair.doc/META-INF/MANIFEST.MF22
-rw-r--r--plugins/doc/org.eclipse.papyrus.uml.profile.assistants.doc/.project18
-rw-r--r--plugins/doc/org.eclipse.papyrus.uml.profile.assistants.doc/META-INF/MANIFEST.MF22
-rw-r--r--plugins/doc/org.eclipse.papyrus.uml.search.ui.doc/.project18
-rw-r--r--plugins/doc/org.eclipse.papyrus.uml.search.ui.doc/META-INF/MANIFEST.MF20
-rw-r--r--plugins/doc/org.eclipse.papyrus.views.properties.doc/.project86
-rw-r--r--plugins/doc/org.eclipse.papyrus.views.properties.doc/META-INF/MANIFEST.MF16
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/.classpath6
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/.project24
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/META-INF/MANIFEST.MF16
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/pom.xml4
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/Activator.java37
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/file/AbstractFileEditor.java75
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/file/BuildEditor.java144
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/file/BundlePropertiesEditor.java17
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/file/ClasspathEditor.java83
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/file/ManifestEditor.java713
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/interfaces/IBuildEditor.java8
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/interfaces/IClasspathEditor.java29
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/interfaces/IFeatureProjectEditor.java91
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/interfaces/IFileEditor.java19
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/interfaces/IJavaProjectEditor.java25
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/interfaces/IManifestEditor.java155
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/interfaces/IPluginEditor.java29
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/interfaces/IPluginProjectEditor.java2
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/interfaces/IProjectEditor.java21
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/interfaces/ProjectEditors.java155
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/project/AbstractProjectEditor.java96
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/project/FeatureProjectEditor.java453
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/project/JavaProjectEditor.java149
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/project/PluginEditor.java369
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/project/PluginProjectEditor.java91
-rw-r--r--plugins/editor/org.eclipse.papyrus.eclipse.project.editors/src/org/eclipse/papyrus/eclipse/project/editors/project/ProjectEditor.java40
-rw-r--r--plugins/editor/org.eclipse.papyrus.editor.perspectiveconfiguration/.project80
-rw-r--r--plugins/editor/org.eclipse.papyrus.editor.perspectiveconfiguration/META-INF/MANIFEST.MF25
-rw-r--r--plugins/editor/org.eclipse.papyrus.editor/.project80
-rw-r--r--plugins/editor/org.eclipse.papyrus.editor/META-INF/MANIFEST.MF33
-rw-r--r--plugins/facet/editor/org.eclipse.papyrus.emf.facet.custom.doc/.project62
-rw-r--r--plugins/facet/editor/org.eclipse.papyrus.emf.facet.custom.doc/META-INF/MANIFEST.MF16
-rw-r--r--plugins/facet/editor/org.eclipse.papyrus.emf.facet.custom.metamodel.editor.doc/.project62
-rw-r--r--plugins/facet/editor/org.eclipse.papyrus.emf.facet.custom.metamodel.editor.doc/META-INF/MANIFEST.MF2
-rw-r--r--plugins/facet/editor/org.eclipse.papyrus.emf.facet.custom.metamodel.editor/.project80
-rw-r--r--plugins/facet/editor/org.eclipse.papyrus.emf.facet.custom.metamodel.editor/META-INF/MANIFEST.MF52
-rw-r--r--plugins/facet/editor/org.eclipse.papyrus.emf.facet.doc/.project80
-rw-r--r--plugins/facet/editor/org.eclipse.papyrus.emf.facet.doc/META-INF/MANIFEST.MF16
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.aggregate.doc/.project18
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.aggregate.doc/META-INF/MANIFEST.MF16
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.common.core/.project77
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.common.core/META-INF/MANIFEST.MF26
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.common.sdk.core/.project81
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.common.sdk.core/META-INF/MANIFEST.MF41
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.common.ui/.project73
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.common.ui/META-INF/MANIFEST.MF43
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.custom.core/.project75
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.custom.core/META-INF/MANIFEST.MF46
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.custom.metamodel.edit/.project76
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.custom.metamodel.edit/META-INF/MANIFEST.MF33
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.custom.metamodel/.project75
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.custom.metamodel/.settings/.api_filters26
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.custom.metamodel/META-INF/MANIFEST.MF46
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.custom.metamodel/src/org/eclipse/papyrus/emf/facet/custom/metamodel/v0_2_0/custom/CustomPackage.java1810
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.custom.sdk.core/.project79
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.custom.sdk.core/META-INF/MANIFEST.MF38
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.custom.sdk.ui/.project75
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.custom.sdk.ui/META-INF/MANIFEST.MF48
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.custom.ui/.project75
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.custom.ui/META-INF/MANIFEST.MF53
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.catalog/.project73
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.catalog/META-INF/MANIFEST.MF30
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.core/.project80
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.core/META-INF/MANIFEST.MF49
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.doc/.project18
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.doc/META-INF/MANIFEST.MF16
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.edit/.project73
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.edit/META-INF/MANIFEST.MF30
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.editor/.project75
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.editor/META-INF/MANIFEST.MF40
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel.edit/.project75
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel.edit/.settings/.api_filters11
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel.edit/META-INF/MANIFEST.MF44
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel.edit/src/org/eclipse/papyrus/emf/facet/efacet/metamodel/v0_2_0/efacet/provider/FacetItemProvider.java710
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel/.project75
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel/.settings/.api_filters127
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel/META-INF/MANIFEST.MF62
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel/src/org/eclipse/papyrus/emf/facet/efacet/metamodel/v0_2_0/efacet/EFacetPackage.java4386
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel/src/org/eclipse/papyrus/emf/facet/efacet/metamodel/v0_2_0/efacet/Facet.java426
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel/src/org/eclipse/papyrus/emf/facet/efacet/metamodel/v0_2_0/efacet/impl/EFacetPackageImpl.java1513
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel/src/org/eclipse/papyrus/emf/facet/efacet/metamodel/v0_2_0/efacet/impl/FacetImpl.java1282
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.sdk.ui/.project80
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.sdk.ui/META-INF/MANIFEST.MF60
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.ui/.project80
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.ui/META-INF/MANIFEST.MF66
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet/.project73
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet/META-INF/MANIFEST.MF30
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.java.core/.project73
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.java.core/META-INF/MANIFEST.MF39
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.java.metamodel/.project77
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.java.metamodel/META-INF/MANIFEST.MF27
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.java.sdk.ui/.project79
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.java.sdk.ui/META-INF/MANIFEST.MF46
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.java/.project73
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.java/META-INF/MANIFEST.MF29
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.ocl.core/.project79
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.ocl.core/META-INF/MANIFEST.MF35
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.ocl.metamodel/.project75
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.ocl.metamodel/.settings/.api_filters11
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.ocl.metamodel/META-INF/MANIFEST.MF32
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.ocl.sdk.ui/.project79
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.ocl.sdk.ui/META-INF/MANIFEST.MF42
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.core/.project77
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.core/META-INF/MANIFEST.MF30
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.emf.catalog/.project73
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.emf.catalog/META-INF/MANIFEST.MF26
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.emf.core/.project78
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.emf.core/META-INF/MANIFEST.MF63
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.emf.doc/.project18
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.emf.doc/META-INF/MANIFEST.MF16
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.emf.ui/.project75
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.emf.ui/META-INF/MANIFEST.MF62
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.jface.ui/.options4
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.jface.ui/.project79
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.jface.ui/META-INF/MANIFEST.MF27
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.pde.core/.project79
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.pde.core/META-INF/MANIFEST.MF33
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.swt/.project77
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.swt/META-INF/MANIFEST.MF33
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.ui/.project77
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.ui/META-INF/MANIFEST.MF78
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.widgets.celleditors.ecore/.project73
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.widgets.celleditors.ecore/META-INF/MANIFEST.MF31
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.widgets.celleditors/.project78
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.widgets.celleditors/META-INF/MANIFEST.MF66
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.widgets/.project73
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.widgets/META-INF/MANIFEST.MF34
-rw-r--r--plugins/infra/constraints/org.eclipse.papyrus.infra.constraints.edit/.project24
-rw-r--r--plugins/infra/constraints/org.eclipse.papyrus.infra.constraints.edit/META-INF/MANIFEST.MF8
-rw-r--r--plugins/infra/constraints/org.eclipse.papyrus.infra.constraints.edit/pom.xml2
-rw-r--r--plugins/infra/constraints/org.eclipse.papyrus.infra.constraints.editor/.project24
-rw-r--r--plugins/infra/constraints/org.eclipse.papyrus.infra.constraints.editor/META-INF/MANIFEST.MF14
-rw-r--r--plugins/infra/constraints/org.eclipse.papyrus.infra.constraints.editor/pom.xml2
-rw-r--r--plugins/infra/constraints/org.eclipse.papyrus.infra.constraints.ui/.project24
-rw-r--r--plugins/infra/constraints/org.eclipse.papyrus.infra.constraints.ui/META-INF/MANIFEST.MF9
-rw-r--r--plugins/infra/constraints/org.eclipse.papyrus.infra.constraints/.project24
-rw-r--r--plugins/infra/constraints/org.eclipse.papyrus.infra.constraints/META-INF/MANIFEST.MF9
-rw-r--r--plugins/infra/constraints/org.eclipse.papyrus.infra.constraints/pom.xml2
-rw-r--r--plugins/infra/constraints/org.eclipse.papyrus.infra.constraints/src/org/eclipse/papyrus/infra/constraints/constraints/AbstractConstraint.java5
-rw-r--r--plugins/infra/constraints/org.eclipse.papyrus.infra.constraints/src/org/eclipse/papyrus/infra/constraints/constraints/Constraint.java1
-rw-r--r--plugins/infra/constraints/org.eclipse.papyrus.infra.constraints/src/org/eclipse/papyrus/infra/constraints/runtime/ConstraintEngine.java1
-rw-r--r--plugins/infra/constraints/org.eclipse.papyrus.infra.constraints/src/org/eclipse/papyrus/infra/constraints/runtime/DefaultConstraintEngine.java6
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.log/.project80
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.log/META-INF/MANIFEST.MF24
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.log/src/org/eclipse/papyrus/infra/core/log/LogHelper.java524
-rwxr-xr-xplugins/infra/core/org.eclipse.papyrus.infra.core.pluginexplorer/.project80
-rwxr-xr-xplugins/infra/core/org.eclipse.papyrus.infra.core.pluginexplorer/META-INF/MANIFEST.MF29
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di/.project80
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di/META-INF/MANIFEST.MF47
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di/custom-src/org/eclipse/papyrus/infra/core/sasheditor/di/contentprovider/DiSashModelManager.java668
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di/custom-src/org/eclipse/papyrus/infra/core/sasheditor/di/contentprovider/DiSashModelMngr.java504
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di/custom-src/org/eclipse/papyrus/infra/core/sasheditor/di/contentprovider/IPageModelFactory.java156
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di/custom-src/org/eclipse/papyrus/infra/core/sasheditor/di/contentprovider/internal/PageManagerImpl.java327
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di/custom-src/org/eclipse/papyrus/infra/core/sasheditor/di/contentprovider/utils/IPageUtils.java173
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor.di/pom.xml2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor/.project90
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor/META-INF/MANIFEST.MF54
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor/pom.xml2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor/src/org/eclipse/papyrus/infra/core/sasheditor/editor/ICloseablePart.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sasheditor/src/org/eclipse/papyrus/infra/core/sasheditor/internal/PagePart.java553
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sashwindows.di/.project24
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sashwindows.di/META-INF/MANIFEST.MF12
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sashwindows.di/src-gen/org/eclipse/papyrus/infra/core/sashwindows/di/DiPackage.java11
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sashwindows.di/src-gen/org/eclipse/papyrus/infra/core/sashwindows/di/PageRef.java3
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sashwindows.di/src-gen/org/eclipse/papyrus/infra/core/sashwindows/di/SashModel.java3
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sashwindows.di/src-gen/org/eclipse/papyrus/infra/core/sashwindows/di/TabFolder.java3
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sashwindows.di/src-gen/org/eclipse/papyrus/infra/core/sashwindows/di/impl/DiPackageImpl.java1
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sashwindows.di/src-gen/org/eclipse/papyrus/infra/core/sashwindows/di/impl/PageRefImpl.java4
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sashwindows.di/src-gen/org/eclipse/papyrus/infra/core/sashwindows/di/impl/SashModelImpl.java7
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sashwindows.di/src-gen/org/eclipse/papyrus/infra/core/sashwindows/di/impl/TabFolderImpl.java6
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core.sashwindows.di/src/org/eclipse/papyrus/infra/core/sashwindows/di/util/DiUtils.java1
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/.project80
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/META-INF/MANIFEST.MF73
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/pom.xml2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/Activator.java167
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/language/ILanguage.java1
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/language/ILanguageProvider.java1
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/language/ILanguageService.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/resource/AbstractBaseModel.java4
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/resource/AbstractModel.java4
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/resource/EMFLogicalModel.java8
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/resource/IEMFModel.java3
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/resource/ModelSet.java1
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/resource/ModelsReader.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/resource/ResourceAdapter.java3
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/resource/sasheditor/SashModel.java26
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/resource/sasheditor/SashModelUtils.java303
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/services/ExtensionServicesRegistry.java1
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/services/spi/IContextualServiceRegistryTracker.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/utils/AbstractServiceUtils.java4
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/utils/IPapyrusCallable.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/utils/IPapyrusRunnable.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/utils/IServiceRegistryProvider.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/src/org/eclipse/papyrus/infra/core/utils/TransactionHelper.java11
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/.project28
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/.settings/.api_filters35
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/META-INF/MANIFEST.MF12
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/pom.xml2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/Activator.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/databinding/CommandBasedObservable.java3
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/databinding/CommandBasedObservableValue.java3
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/databinding/TouchableValue.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/databinding/WritableListWithIterator.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/notify/IContext.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/notify/INotification.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/notify/INotificationBuilder.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/notify/LogNotification.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/notify/NotificationBuilder.java1
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/notify/NotificationRunnable.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/notify/Type.java1
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/spi/IExecutorServiceFactory.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/spi/INotificationBuilderFactory.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/util/CompositeServiceTracker.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/util/CoreExecutors.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/util/IExecutorService.java2
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/util/IProgressCallable.java1
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/util/IProgressRunnable.java1
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/src/org/eclipse/papyrus/infra/tools/util/PlatformHelper.java2
-rw-r--r--plugins/infra/core/serviceregistry/org.eclipse.papyrus.infra.core.serviceregistry.edit/.project62
-rw-r--r--plugins/infra/core/serviceregistry/org.eclipse.papyrus.infra.core.serviceregistry.editor/.project62
-rw-r--r--plugins/infra/core/serviceregistry/org.eclipse.papyrus.infra.core.serviceregistry/.project62
-rw-r--r--plugins/infra/discovery/org.eclipse.papyrus.infra.discovery.ui.menu/.project80
-rw-r--r--plugins/infra/discovery/org.eclipse.papyrus.infra.discovery.ui.menu/META-INF/MANIFEST.MF31
-rw-r--r--plugins/infra/discovery/org.eclipse.papyrus.infra.discovery.ui/.project80
-rw-r--r--plugins/infra/discovery/org.eclipse.papyrus.infra.discovery.ui/.settings/.api_filters21
-rw-r--r--plugins/infra/discovery/org.eclipse.papyrus.infra.discovery.ui/META-INF/MANIFEST.MF61
-rw-r--r--plugins/infra/discovery/org.eclipse.papyrus.infra.discovery.ui/pom.xml2
-rw-r--r--plugins/infra/discovery/org.eclipse.papyrus.infra.discovery.ui/src/org/eclipse/papyrus/infra/discovery/ui/wizards/DiscoveryComponent.java168
-rw-r--r--plugins/infra/discovery/org.eclipse.papyrus.infra.discovery/.project80
-rw-r--r--plugins/infra/discovery/org.eclipse.papyrus.infra.discovery/META-INF/MANIFEST.MF34
-rw-r--r--plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.nattable/.project24
-rw-r--r--plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome.nattable/META-INF/MANIFEST.MF26
-rw-r--r--plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome/.project24
-rw-r--r--plugins/infra/editor/org.eclipse.papyrus.infra.editor.welcome/META-INF/MANIFEST.MF26
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.appearance/.project80
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.appearance/.settings/.api_filters11
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.appearance/META-INF/MANIFEST.MF36
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.diagram.common/.project80
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.diagram.common/META-INF/MANIFEST.MF17
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/.project24
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/META-INF/MANIFEST.MF13
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/.project80
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF17
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/pom.xml4
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/src/org/eclipse/papyrus/infra/emf/readonly/ReadOnlyManager.java1179
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/src/org/eclipse/papyrus/infra/emf/readonly/spi/IReadOnlyManagerProcessor.java4
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.types.ui/.project18
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.types.ui/META-INF/MANIFEST.MF23
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.types.ui/pom.xml2
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.types/.project74
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.types/META-INF/MANIFEST.MF70
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.types/pom.xml2
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf/.project80
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF52
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf/pom.xml4
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf/src/org/eclipse/papyrus/infra/emf/Activator.java1
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf/src/org/eclipse/papyrus/infra/emf/spi/resolver/EObjectResolverService.java2
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf/src/org/eclipse/papyrus/infra/emf/spi/resolver/IEObjectResolver.java2
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf/src/org/eclipse/papyrus/infra/emf/utils/EMFHelper.java2246
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/.project24
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/META-INF/MANIFEST.MF30
-rw-r--r--plugins/infra/filters/org.eclipse.papyrus.infra.filters.edit/.classpath4
-rw-r--r--plugins/infra/filters/org.eclipse.papyrus.infra.filters.edit/.project24
-rw-r--r--plugins/infra/filters/org.eclipse.papyrus.infra.filters.edit/META-INF/MANIFEST.MF10
-rw-r--r--plugins/infra/filters/org.eclipse.papyrus.infra.filters/.project24
-rw-r--r--plugins/infra/filters/org.eclipse.papyrus.infra.filters/.settings/.api_filters11
-rw-r--r--plugins/infra/filters/org.eclipse.papyrus.infra.filters/META-INF/MANIFEST.MF9
-rw-r--r--plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.edit/.project18
-rw-r--r--plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.edit/META-INF/MANIFEST.MF37
-rw-r--r--plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.editor/.project18
-rw-r--r--plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.editor/META-INF/MANIFEST.MF37
-rw-r--r--plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/.project18
-rw-r--r--plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/META-INF/MANIFEST.MF38
-rw-r--r--plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/.project22
-rw-r--r--plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/META-INF/MANIFEST.MF65
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.configuration/.project74
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.configuration/META-INF/MANIFEST.MF46
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/.project74
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/META-INF/MANIFEST.MF32
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.theme/.project74
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.theme/META-INF/MANIFEST.MF14
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/.project76
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/META-INF/MANIFEST.MF33
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css3.xtext.ui/.project18
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css3.xtext.ui/META-INF/MANIFEST.MF24
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css3.xtext/.launch/Launch Runtime Eclipse.launch2
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css3.xtext/.project18
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css3.xtext/META-INF/MANIFEST.MF69
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.extensionpoints.editors/.project74
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.extensionpoints.editors/META-INF/MANIFEST.MF46
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/.project74
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/META-INF/MANIFEST.MF46
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands/.project74
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands/META-INF/MANIFEST.MF25
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/.project78
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF59
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.controlmode/.project74
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.controlmode/META-INF/MANIFEST.MF32
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.model/.project76
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.model/META-INF/MANIFEST.MF7
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.dnd/.project74
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.dnd/META-INF/MANIFEST.MF36
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.export/.project18
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.export/META-INF/MANIFEST.MF21
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.gef/.project18
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.gef/META-INF/MANIFEST.MF11
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.gmfmenu.filter/.project74
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.gmfmenu.filter/META-INF/MANIFEST.MF25
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.hyperlink/.project74
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.hyperlink/META-INF/MANIFEST.MF27
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/.project74
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/META-INF/MANIFEST.MF44
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.modelexplorer/.project76
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.modelexplorer/META-INF/MANIFEST.MF31
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.navigation/.project74
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.navigation/META-INF/MANIFEST.MF27
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.outline/.project74
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.outline/META-INF/MANIFEST.MF17
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.preferences/.project78
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.preferences/META-INF/MANIFEST.MF8
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/.project74
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF30
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.viewersearcher/.project74
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.viewersearcher/META-INF/MANIFEST.MF15
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome/.project18
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.welcome/META-INF/MANIFEST.MF34
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.widgets/.project74
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.widgets/META-INF/MANIFEST.MF12
-rw-r--r--plugins/infra/misc/org.eclipse.papyrus.infra.hyperlink/.project24
-rw-r--r--plugins/infra/misc/org.eclipse.papyrus.infra.hyperlink/META-INF/MANIFEST.MF26
-rw-r--r--plugins/infra/misc/org.eclipse.papyrus.infra.hyperlink/pom.xml4
-rw-r--r--plugins/infra/misc/org.eclipse.papyrus.infra.hyperlink/src/org/eclipse/papyrus/infra/hyperlink/Activator.java21
-rw-r--r--plugins/infra/misc/org.eclipse.papyrus.infra.hyperlink/src/org/eclipse/papyrus/infra/hyperlink/helper/ObjectHyperLinkHelper.java4
-rw-r--r--plugins/infra/misc/org.eclipse.papyrus.infra.hyperlink/src/org/eclipse/papyrus/infra/hyperlink/service/HyperlinkContributor.java1
-rw-r--r--plugins/infra/misc/org.eclipse.papyrus.infra.hyperlink/src/org/eclipse/papyrus/infra/hyperlink/service/HyperlinkService.java3
-rw-r--r--plugins/infra/misc/org.eclipse.papyrus.infra.hyperlink/src/org/eclipse/papyrus/infra/hyperlink/ui/AbstractLookForEditorShell.java21
-rw-r--r--plugins/infra/misc/org.eclipse.papyrus.infra.hyperlink/src/org/eclipse/papyrus/infra/hyperlink/ui/HyperLinkManagerShell.java1
-rw-r--r--plugins/infra/misc/org.eclipse.papyrus.infra.hyperlink/src/org/eclipse/papyrus/infra/hyperlink/util/HyperLinkConstants.java6
-rw-r--r--plugins/infra/misc/org.eclipse.papyrus.infra.hyperlink/src/org/eclipse/papyrus/infra/hyperlink/util/HyperLinkLabelProvider.java9
-rw-r--r--plugins/infra/misc/org.eclipse.papyrus.infra.hyperlink/src/org/eclipse/papyrus/infra/hyperlink/util/TreeViewContentProvider.java5
-rw-r--r--plugins/infra/misc/org.eclipse.papyrus.infra.psf/.project24
-rw-r--r--plugins/infra/misc/org.eclipse.papyrus.infra.psf/META-INF/MANIFEST.MF13
-rwxr-xr-xplugins/infra/misc/org.eclipse.papyrus.infra.sync/.project24
-rwxr-xr-xplugins/infra/misc/org.eclipse.papyrus.infra.sync/META-INF/MANIFEST.MF10
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.emf.nattable/.project74
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.emf.nattable/META-INF/MANIFEST.MF26
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/.project74
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF33
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/.project74
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/META-INF/MANIFEST.MF16
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.gmfdiag/.project18
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.gmfdiag/META-INF/MANIFEST.MF31
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model.edit/.project74
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model.edit/META-INF/MANIFEST.MF52
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model.editor/.project74
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model.editor/META-INF/MANIFEST.MF61
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model/.project74
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model/META-INF/MANIFEST.MF93
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.model/src-gen/org/eclipse/papyrus/infra/nattable/model/Activator.java122
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.modelexplorer/.project74
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.modelexplorer/META-INF/MANIFEST.MF23
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.properties/.project74
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.properties/META-INF/MANIFEST.MF32
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.config/.project74
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.config/META-INF/MANIFEST.MF24
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.editor/.project74
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.views.editor/META-INF/MANIFEST.MF18
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/.project74
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF43
-rw-r--r--plugins/infra/newchild/org.eclipse.papyrus.infra.newchild.edit/.project24
-rw-r--r--plugins/infra/newchild/org.eclipse.papyrus.infra.newchild.edit/.settings/.api_filters11
-rw-r--r--plugins/infra/newchild/org.eclipse.papyrus.infra.newchild.edit/META-INF/MANIFEST.MF13
-rw-r--r--plugins/infra/newchild/org.eclipse.papyrus.infra.newchild.editor/.project6
-rw-r--r--plugins/infra/newchild/org.eclipse.papyrus.infra.newchild.editor/META-INF/MANIFEST.MF3
-rw-r--r--plugins/infra/newchild/org.eclipse.papyrus.infra.newchild/.project24
-rw-r--r--plugins/infra/newchild/org.eclipse.papyrus.infra.newchild/.settings/.api_filters11
-rw-r--r--plugins/infra/newchild/org.eclipse.papyrus.infra.newchild/META-INF/MANIFEST.MF23
-rw-r--r--plugins/infra/onefile/org.eclipse.papyrus.infra.onefile/.project24
-rw-r--r--plugins/infra/onefile/org.eclipse.papyrus.infra.onefile/META-INF/MANIFEST.MF9
-rw-r--r--plugins/infra/onefile/org.eclipse.papyrus.infra.onefile/pom.xml4
-rw-r--r--plugins/infra/org.eclipse.papyrus.infra.elementtypesconfigurations/.settings/.api_filters273
-rw-r--r--plugins/infra/properties/org.eclipse.papyrus.infra.properties.edit/.project24
-rw-r--r--plugins/infra/properties/org.eclipse.papyrus.infra.properties.edit/META-INF/MANIFEST.MF14
-rw-r--r--plugins/infra/properties/org.eclipse.papyrus.infra.properties.editor/.project24
-rw-r--r--plugins/infra/properties/org.eclipse.papyrus.infra.properties.editor/META-INF/MANIFEST.MF16
-rw-r--r--plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui/.project24
-rw-r--r--plugins/infra/properties/org.eclipse.papyrus.infra.properties.ui/META-INF/MANIFEST.MF24
-rw-r--r--plugins/infra/properties/org.eclipse.papyrus.infra.properties/.project24
-rw-r--r--plugins/infra/properties/org.eclipse.papyrus.infra.properties/META-INF/MANIFEST.MF8
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.history/.project74
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.history/META-INF/MANIFEST.MF35
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/.project74
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF25
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.decoration/.project74
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.decoration/META-INF/MANIFEST.MF41
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui/.project18
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.edit.ui/META-INF/MANIFEST.MF18
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.edit/.project74
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.edit/META-INF/MANIFEST.MF49
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider/.project74
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.labelprovider/META-INF/MANIFEST.MF32
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/.project18
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/META-INF/MANIFEST.MF35
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.markerlistener/.project74
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.markerlistener/META-INF/MANIFEST.MF41
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.navigation/.project74
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.navigation/META-INF/MANIFEST.MF34
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.openelement/.project74
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.openelement/META-INF/MANIFEST.MF39
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.ui/.project18
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading.ui/META-INF/MANIFEST.MF21
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading/.project74
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.resourceloading/META-INF/MANIFEST.MF17
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.semantic/.project74
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.semantic/META-INF/MANIFEST.MF29
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.validation/.project74
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.validation/META-INF/MANIFEST.MF22
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.viewersearch/.project74
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.viewersearch/META-INF/MANIFEST.MF29
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.viewlabelprovider/.project74
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.viewlabelprovider/META-INF/MANIFEST.MF31
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.core/.project74
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.core/META-INF/MANIFEST.MF53
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.core/pom.xml2
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.edit/.project74
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.edit/META-INF/MANIFEST.MF32
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.edit/pom.xml2
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.editor/.project74
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.editor/META-INF/MANIFEST.MF35
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.editor/pom.xml2
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.rulebased/.project74
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.rulebased/META-INF/MANIFEST.MF48
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.rulebased/pom.xml2
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.ui/.project18
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.ui/META-INF/MANIFEST.MF31
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.ui/pom.xml2
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types/.project18
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types/META-INF/MANIFEST.MF7
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types/pom.xml2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.onefile.ui/.project24
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.onefile.ui/META-INF/MANIFEST.MF27
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/.project24
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/META-INF/MANIFEST.MF16
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/.project24
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/META-INF/MANIFEST.MF27
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/command/AbstractCommandHandler.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/command/AbstractPapyrusHandler.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/contentoutline/ContentOutlineRegistry.java3
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/contentoutline/IPapyrusContentOutlinePage.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/contentoutline/NestedEditorDelegatedOutlinePage.java4
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/converter/AbstractStringValueConverter.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/converter/ConvertedValueContainer.java5
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/converter/EMFStringValueConverter.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/converter/IStringValueConverter.java3
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/converter/MultiConvertedValueContainer.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/converter/StringValueConverterStatus.java3
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/dnd/PapyrusTransfer.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/ContentProviderServiceFactory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/CoreMultiDiagramEditor.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/DiSashModelManagerServiceFactory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/DiSashModelMngrServiceFactory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/IMultiDiagramEditor.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/IPapyrusPageInput.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/IReloadableEditor.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/PageIconRegistryServiceFactory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/PageMngrServiceFactory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/PapyrusPageInput.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/reload/CompositeReloadContext.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/reload/DelegatingReloadContext.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/reload/EMFSelectionContext.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/reload/EMFTreeViewerContext.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/reload/EditorReloadAdapter.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/reload/EditorReloadEvent.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/reload/IDisposableReloadContext.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/reload/IEditorReloadListener.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/reload/IReloadContextProvider.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/reload/SelectionContext.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editor/reload/TreeViewerContext.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editorsfactory/AbstractGetEditorIconQuery.java5
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editorsfactory/IEditorFactory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editorsfactory/IEditorIconFactory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editorsfactory/IEditorIconFactoryExtended.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editorsfactory/IPageIconsRegistry.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editorsfactory/IPageIconsRegistryExtended.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editorsfactory/PageIconsRegistry.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/editorsfactory/PageModelFactoryRegistry.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/extension/commands/ICreationCondition.java3
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/extension/commands/IModelCreationCommand.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/extension/commands/PerspectiveContextDependence.java5
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/extension/diagrameditor/AbstractEditorFactory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/extension/diagrameditor/EditorDescriptor.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/extension/diagrameditor/EditorDescriptorExtensionFactory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/extension/diagrameditor/EditorFactoryProxy.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/extension/diagrameditor/EditorIconFactory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/extension/diagrameditor/EditorNotFoundException.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/extension/diagrameditor/IPluggableEditorFactory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/extension/diagrameditor/MultiDiagramException.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/extension/diagrameditor/PluggableEditorFactoryReader.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/lifecycleevents/DoSaveEvent.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/lifecycleevents/IEditorInputChangedListener.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/lifecycleevents/ILifeCycleEventsProvider.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/lifecycleevents/ISaveAndDirtyService.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/lifecycleevents/ISaveEventListener.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/lifecycleevents/LifeCycleEventsProvider.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/lifecycleevents/LifeCycleEventsProviderServiceFactory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/lifecycleevents/SaveAndDirtyService.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/multidiagram/actionbarcontributor/ActionBarContributorDescriptor.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/multidiagram/actionbarcontributor/ActionBarContributorExtensionFactory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/multidiagram/actionbarcontributor/ActionBarContributorRegistry.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/multidiagram/actionbarcontributor/CoreComposedActionBarContributor.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/multidiagram/actionbarcontributor/IActionBarContributorFactory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/preferences/AbstractPapyrusPreferencePage.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/preferences/AbstractPapyrusPreferenceStore.java3
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/preferences/AbstractPreferenceGroup.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/preferences/IPapyrusPreferencePage.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/preferences/PapyrusScopedPreferenceStore.java47
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/preferences/VisiblePageSingleton.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/preferences/dialog/AbstractApplyValueOnPreferenceKeyDialog.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/preferences/dialog/AbstractPreferenceKeyDialog.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/providers/CompositePapyrusContentProvider.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/providers/CompositeSemanticContentProviderFactory.java20
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/providers/DelegatingPapyrusContentProvider.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/providers/ISemanticContentProviderFactory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/services/EditorLifecycleEventListener.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/services/EditorLifecycleManager.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/services/ResourceUpdateService.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/services/SaveLayoutBeforeClose.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/AbstractCreateMenuFromCommandCategory.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/DisplayUtils.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/EclipseCommandUtils.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/EditorHelper.java6
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/EditorUtils.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/ICallableWithProgress.java50
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/PapyrusImageUtils.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/SelectionHelper.java13
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/ServiceUtilsForActionHandlers.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/ServiceUtilsForHandlers.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/ServiceUtilsForIEvaluationContext.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/ServiceUtilsForSelection.java1
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/ServiceUtilsForWorkbenchPage.java3
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/TransactionUIHelper.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/UIUtil.java29
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/src/org/eclipse/papyrus/infra/ui/util/WorkbenchPartHelper.java6
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.widgets.toolbox/.project24
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.widgets.toolbox/META-INF/MANIFEST.MF13
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.widgets.toolbox/src/org/eclipse/papyrus/infra/widgets/toolbox/notification/builders/NotificationBuilder.java2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.widgets/.project28
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.widgets/.settings/.api_filters67
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.widgets/META-INF/MANIFEST.MF23
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.widgets/pom.xml2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.widgets/src/org/eclipse/papyrus/infra/widgets/editors/SelectionMenu.java99
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.widgets/src/org/eclipse/papyrus/infra/widgets/providers/CompositeContentProvider.java3
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.widgets/src/org/eclipse/papyrus/infra/widgets/util/INameResolutionHelper.java4
-rwxr-xr-xplugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.configuration.edit/.project74
-rwxr-xr-xplugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.configuration.edit/META-INF/MANIFEST.MF40
-rwxr-xr-xplugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.configuration.editor/.project74
-rwxr-xr-xplugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.configuration.editor/META-INF/MANIFEST.MF40
-rwxr-xr-xplugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.configuration/.project74
-rw-r--r--plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.configuration/META-INF/MANIFEST.MF52
-rwxr-xr-xplugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.iso42010.edit/.project74
-rwxr-xr-xplugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.iso42010.edit/META-INF/MANIFEST.MF30
-rwxr-xr-xplugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.iso42010/.project74
-rwxr-xr-xplugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.iso42010/META-INF/MANIFEST.MF32
-rwxr-xr-xplugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy/.project74
-rwxr-xr-xplugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy/META-INF/MANIFEST.MF62
-rwxr-xr-xplugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.preferences/.project74
-rwxr-xr-xplugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.preferences/META-INF/MANIFEST.MF31
-rw-r--r--plugins/infra/xtypes/org.eclipse.papyrus.infra.extendedtypes.edit/.project24
-rw-r--r--plugins/infra/xtypes/org.eclipse.papyrus.infra.extendedtypes.edit/META-INF/MANIFEST.MF13
-rw-r--r--plugins/infra/xtypes/org.eclipse.papyrus.infra.extendedtypes.edit/pom.xml4
-rw-r--r--plugins/infra/xtypes/org.eclipse.papyrus.infra.extendedtypes.editor/.project6
-rw-r--r--plugins/infra/xtypes/org.eclipse.papyrus.infra.extendedtypes.emf/.project24
-rw-r--r--plugins/infra/xtypes/org.eclipse.papyrus.infra.extendedtypes.emf/META-INF/MANIFEST.MF20
-rw-r--r--plugins/infra/xtypes/org.eclipse.papyrus.infra.extendedtypes.emf/pom.xml4
-rw-r--r--plugins/infra/xtypes/org.eclipse.papyrus.infra.extendedtypes.emf/src-gen/org/eclipse/papyrus/infra/extendedtypes/emf/runtimevalueseditionactionconfiguration/ViewToDisplay.java2
-rw-r--r--plugins/infra/xtypes/org.eclipse.papyrus.infra.extendedtypes.emf/src-gen/org/eclipse/papyrus/infra/extendedtypes/emf/runtimevalueseditionactionconfiguration/impl/ViewToDisplayImpl.java3
-rw-r--r--plugins/infra/xtypes/org.eclipse.papyrus.infra.extendedtypes.ui/.project24
-rw-r--r--plugins/infra/xtypes/org.eclipse.papyrus.infra.extendedtypes.ui/META-INF/MANIFEST.MF11
-rw-r--r--plugins/infra/xtypes/org.eclipse.papyrus.infra.extendedtypes/.project24
-rw-r--r--plugins/infra/xtypes/org.eclipse.papyrus.infra.extendedtypes/META-INF/MANIFEST.MF10
-rw-r--r--plugins/infra/xtypes/org.eclipse.papyrus.infra.extendedtypes/pom.xml4
-rw-r--r--plugins/infra/xtypes/org.eclipse.papyrus.infra.extendedtypes/src/org/eclipse/papyrus/infra/extendedtypes/util/InternalUtils.java2
-rw-r--r--plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.blockdefinition/.project74
-rw-r--r--plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.blockdefinition/META-INF/MANIFEST.MF91
-rw-r--r--plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.common/.project18
-rw-r--r--plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.common/META-INF/MANIFEST.MF125
-rw-r--r--plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.css/.project74
-rw-r--r--plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.css/META-INF/MANIFEST.MF16
-rw-r--r--plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.internalblock/.project74
-rw-r--r--plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.internalblock/META-INF/MANIFEST.MF89
-rw-r--r--plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.parametric/.project18
-rw-r--r--plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.parametric/META-INF/MANIFEST.MF44
-rw-r--r--plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.requirement/.project74
-rw-r--r--plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.requirement/META-INF/MANIFEST.MF70
-rw-r--r--plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.ui/.project74
-rw-r--r--plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.ui/META-INF/MANIFEST.MF32
-rw-r--r--plugins/sysml/modelexplorer/org.eclipse.papyrus.sysml.modelexplorer/.project18
-rw-r--r--plugins/sysml/modelexplorer/org.eclipse.papyrus.sysml.modelexplorer/META-INF/MANIFEST.MF32
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.allocation.config/.project74
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.allocation.config/META-INF/MANIFEST.MF21
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.allocation/.project74
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.allocation/META-INF/MANIFEST.MF25
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.menu/.project74
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.menu/META-INF/MANIFEST.MF25
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.requirement.config/.project74
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.requirement.config/META-INF/MANIFEST.MF36
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.requirement/.project74
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable.requirement/META-INF/MANIFEST.MF20
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable/.project74
-rw-r--r--plugins/sysml/nattable/org.eclipse.papyrus.sysml.nattable/META-INF/MANIFEST.MF23
-rw-r--r--plugins/sysml/org.eclipse.papyrus.sysml.edit/.project74
-rw-r--r--plugins/sysml/org.eclipse.papyrus.sysml.edit/META-INF/MANIFEST.MF68
-rw-r--r--plugins/sysml/org.eclipse.papyrus.sysml.service.types/.project18
-rw-r--r--plugins/sysml/org.eclipse.papyrus.sysml.service.types/META-INF/MANIFEST.MF20
-rw-r--r--plugins/sysml/org.eclipse.papyrus.sysml/.project74
-rw-r--r--plugins/sysml/org.eclipse.papyrus.sysml/META-INF/MANIFEST.MF99
-rw-r--r--plugins/sysml/properties/org.eclipse.papyrus.sysml.properties/.project74
-rw-r--r--plugins/sysml/properties/org.eclipse.papyrus.sysml.properties/META-INF/MANIFEST.MF6
-rw-r--r--plugins/uml/alf/org.eclipse.papyrus.uml.alf.common.ui/.project86
-rw-r--r--plugins/uml/alf/org.eclipse.papyrus.uml.alf.common.ui/META-INF/MANIFEST.MF35
-rw-r--r--plugins/uml/alf/org.eclipse.papyrus.uml.alf.common/.project86
-rw-r--r--plugins/uml/alf/org.eclipse.papyrus.uml.alf.common/META-INF/MANIFEST.MF48
-rw-r--r--plugins/uml/alf/org.eclipse.papyrus.uml.alf.libraries/.project74
-rw-r--r--plugins/uml/alf/org.eclipse.papyrus.uml.alf.libraries/META-INF/MANIFEST.MF32
-rw-r--r--plugins/uml/alf/org.eclipse.papyrus.uml.alf.to.fuml/.project74
-rw-r--r--plugins/uml/alf/org.eclipse.papyrus.uml.alf.to.fuml/META-INF/MANIFEST.MF25
-rw-r--r--plugins/uml/alf/org.eclipse.papyrus.uml.alf.ui/.project18
-rw-r--r--plugins/uml/alf/org.eclipse.papyrus.uml.alf.ui/META-INF/MANIFEST.MF81
-rw-r--r--plugins/uml/alf/org.eclipse.papyrus.uml.alf/.project18
-rw-r--r--plugins/uml/alf/org.eclipse.papyrus.uml.alf/META-INF/MANIFEST.MF106
-rw-r--r--plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.ui/.project18
-rw-r--r--plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator.ui/META-INF/MANIFEST.MF28
-rw-r--r--plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator/.project18
-rw-r--r--plugins/uml/assistants/org.eclipse.papyrus.uml.profile.assistants.generator/META-INF/MANIFEST.MF21
-rw-r--r--plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/.project18
-rw-r--r--plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/META-INF/MANIFEST.MF55
-rw-r--r--plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator/.project18
-rw-r--r--plugins/uml/assistants/org.eclipse.papyrus.uml.profile.types.generator/META-INF/MANIFEST.MF42
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/.project18
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/META-INF/MANIFEST.MF59
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/.project18
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/META-INF/MANIFEST.MF27
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/.project18
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/META-INF/MANIFEST.MF71
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/src/org/eclipse/papyrus/uml/decoratormodel/internal/ui/wizards/DuplicateDecoratorModelWizard.java4
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/.project18
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/META-INF/MANIFEST.MF77
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity/META-INF/MANIFEST.MF84
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/.project86
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/META-INF/MANIFEST.MF76
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.groups/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.groups/META-INF/MANIFEST.MF48
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.palette.customaction/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common.palette.customaction/META-INF/MANIFEST.MF44
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/.project18
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF89
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/META-INF/MANIFEST.MF71
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.component/META-INF/MANIFEST.MF77
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/META-INF/MANIFEST.MF71
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.css.palette/.project18
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.css.palette/META-INF/MANIFEST.MF14
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.css/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.css/META-INF/MANIFEST.MF17
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.deployment/META-INF/MANIFEST.MF55
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.dnd/META-INF/MANIFEST.MF46
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.emftree/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.emftree/META-INF/MANIFEST.MF35
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.icons/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.icons/META-INF/MANIFEST.MF24
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/META-INF/MANIFEST.MF60
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.linklf/.project18
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.linklf/META-INF/MANIFEST.MF25
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.menu/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.menu/META-INF/MANIFEST.MF66
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.modelexplorer/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.modelexplorer/META-INF/MANIFEST.MF47
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.navigation/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.navigation/META-INF/MANIFEST.MF26
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.paletteconfiguration.edit/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.paletteconfiguration.edit/META-INF/MANIFEST.MF46
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.paletteconfiguration/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.paletteconfiguration/META-INF/MANIFEST.MF51
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/META-INF/MANIFEST.MF74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/META-INF/MANIFEST.MF57
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/.project18
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/META-INF/MANIFEST.MF73
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotype.edition/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.stereotype.edition/META-INF/MANIFEST.MF47
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.symbols.properties/.project62
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.symbols.properties/META-INF/MANIFEST.MF6
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.symbols/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.symbols/META-INF/MANIFEST.MF47
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.timing/META-INF/MANIFEST.MF59
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase/.project74
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.usecase/META-INF/MANIFEST.MF76
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards/.project94
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards/META-INF/MANIFEST.MF78
-rw-r--r--plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.widgets/.project74
-rw-r--r--plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.widgets/META-INF/MANIFEST.MF33
-rw-r--r--plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/.project76
-rw-r--r--plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF40
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config/.project74
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.clazz.config/META-INF/MANIFEST.MF18
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.config/.project74
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic.config/META-INF/MANIFEST.MF26
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic/.project74
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.generic/META-INF/MANIFEST.MF31
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.menu/.project74
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.menu/META-INF/MANIFEST.MF21
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display/.project18
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.stereotype.display/META-INF/MANIFEST.MF24
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.xtext.integration/.project74
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.xtext.integration/META-INF/MANIFEST.MF15
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.xtext.valuespecification/.project18
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable.xtext.valuespecification/META-INF/MANIFEST.MF21
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable/.project74
-rw-r--r--plugins/uml/nattable/org.eclipse.papyrus.uml.nattable/META-INF/MANIFEST.MF31
-rw-r--r--plugins/uml/newchild/org.eclipse.papyrus.uml.profile.newchildmenu.generator.ui/.project74
-rw-r--r--plugins/uml/newchild/org.eclipse.papyrus.uml.profile.newchildmenu.generator.ui/META-INF/MANIFEST.MF28
-rw-r--r--plugins/uml/newchild/org.eclipse.papyrus.uml.profile.newchildmenu.generator/.project86
-rw-r--r--plugins/uml/newchild/org.eclipse.papyrus.uml.profile.newchildmenu.generator/META-INF/MANIFEST.MF34
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.appearance/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.appearance/META-INF/MANIFEST.MF36
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.commands/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.commands/META-INF/MANIFEST.MF47
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/META-INF/MANIFEST.MF26
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.documentation.profile/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.documentation.profile/META-INF/MANIFEST.MF38
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.extensionpoints/.project84
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.extensionpoints/META-INF/MANIFEST.MF40
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.filters.edit/.project18
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.filters.edit/META-INF/MANIFEST.MF48
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.filters/.project22
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.filters/META-INF/MANIFEST.MF51
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.icons/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.icons/META-INF/MANIFEST.MF26
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.import/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.import/META-INF/MANIFEST.MF40
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.modelrepair/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF67
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.navigation/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.navigation/META-INF/MANIFEST.MF14
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.oclconstraintevaluation/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.oclconstraintevaluation/META-INF/MANIFEST.MF33
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.perspective/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.perspective/META-INF/MANIFEST.MF33
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.profile/.project84
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.profile/META-INF/MANIFEST.MF80
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.resourceloading.profile/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.resourceloading.profile/META-INF/MANIFEST.MF22
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.search.ui/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.search.ui/META-INF/MANIFEST.MF40
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.service.types.ui/.project18
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.service.types.ui/META-INF/MANIFEST.MF31
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.service.types/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.service.types/META-INF/MANIFEST.MF28
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.service.validation/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.service.validation/META-INF/MANIFEST.MF41
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.services.decoration/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.services.decoration/META-INF/MANIFEST.MF34
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.templaterepository/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.templaterepository/META-INF/MANIFEST.MF30
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.types.core/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.types.core/META-INF/MANIFEST.MF93
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.ui.perspectiveconfiguration/.project74
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.ui.perspectiveconfiguration/META-INF/MANIFEST.MF26
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.ui/.project18
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.ui/META-INF/MANIFEST.MF40
-rw-r--r--plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.documentation/.project74
-rw-r--r--plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/.project78
-rw-r--r--plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/META-INF/MANIFEST.MF36
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.xtext/.project74
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.xtext/META-INF/MANIFEST.MF24
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties/.project76
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties/META-INF/MANIFEST.MF52
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.ui/.project74
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.ui/META-INF/MANIFEST.MF57
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext/.project90
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext/META-INF/MANIFEST.MF73
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.ui/.project74
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.ui/META-INF/MANIFEST.MF60
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext/.project90
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext/META-INF/MANIFEST.MF80
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext.ui/.project74
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext.ui/META-INF/MANIFEST.MF56
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext/.project90
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext/META-INF/MANIFEST.MF70
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.constraintwithessentialocl.xtext/.project74
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.constraintwithessentialocl.xtext/META-INF/MANIFEST.MF43
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.javaconstraint/.project74
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.javaconstraint/META-INF/MANIFEST.MF36
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.ui/.project74
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.ui/META-INF/MANIFEST.MF60
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext/.project90
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext/META-INF/MANIFEST.MF74
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.ui/.project74
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.ui/META-INF/MANIFEST.MF59
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext/.project90
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext/META-INF/MANIFEST.MF73
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.xtext.ui/.project74
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.xtext.ui/META-INF/MANIFEST.MF68
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.xtext/.project86
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.port.xtext/META-INF/MANIFEST.MF74
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.ui/.project74
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.ui/META-INF/MANIFEST.MF68
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/.project90
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/META-INF/MANIFEST.MF75
-rwxr-xr-xplugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.ui/.project74
-rwxr-xr-xplugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.ui/META-INF/MANIFEST.MF55
-rwxr-xr-xplugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/.project90
-rwxr-xr-xplugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/META-INF/MANIFEST.MF72
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.stereotypeproperty.xtext.ui/.project74
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.stereotypeproperty.xtext.ui/META-INF/MANIFEST.MF69
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.stereotypeproperty.xtext/.project86
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.stereotypeproperty.xtext/META-INF/MANIFEST.MF86
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.ui/.project74
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.ui/META-INF/MANIFEST.MF66
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/.project90
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/META-INF/MANIFEST.MF68
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.xtext.ui/.project18
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.xtext.ui/META-INF/MANIFEST.MF63
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.xtext.utils/.project18
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.xtext.utils/META-INF/MANIFEST.MF46
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.xtext/.project18
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.valuespecification.xtext/META-INF/MANIFEST.MF76
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/.project74
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/META-INF/MANIFEST.MF21
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/.project84
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF40
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools/.project74
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools/META-INF/MANIFEST.MF88
-rw-r--r--plugins/uml/xtext/org.eclipse.papyrus.uml.xtext.integration.core/.project74
-rw-r--r--plugins/uml/xtext/org.eclipse.papyrus.uml.xtext.integration.core/META-INF/MANIFEST.MF18
-rw-r--r--plugins/uml/xtext/org.eclipse.papyrus.uml.xtext.integration.ui/.project74
-rw-r--r--plugins/uml/xtext/org.eclipse.papyrus.uml.xtext.integration.ui/META-INF/MANIFEST.MF51
-rw-r--r--plugins/uml/xtext/org.eclipse.papyrus.uml.xtext.integration.validation/.project74
-rw-r--r--plugins/uml/xtext/org.eclipse.papyrus.uml.xtext.integration.validation/META-INF/MANIFEST.MF28
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.newchild/.project74
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.newchild/META-INF/MANIFEST.MF11
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/.project74
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF39
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/.project74
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF34
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/.project76
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF58
-rw-r--r--plugins/views/org.eclipse.papyrus.views.search/.project74
-rw-r--r--plugins/views/org.eclipse.papyrus.views.search/META-INF/MANIFEST.MF50
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/.project74
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF13
-rw-r--r--plugins/views/validation/org.eclipse.papyrus.views.validation/.project18
-rw-r--r--plugins/views/validation/org.eclipse.papyrus.views.validation/META-INF/MANIFEST.MF17
1019 files changed, 34656 insertions, 26978 deletions
diff --git a/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.emf/.project b/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.emf/.project
index c1c9b5ec9f9..7679c02f662 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.emf/.project
+++ b/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.emf/.project
@@ -1,28 +1,46 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<projectDescription>
- <name>org.eclipse.papyrus.customization.extendedtypes.emf</name>
- <comment></comment>
- <projects>
- </projects>
- <buildSpec>
- <buildCommand>
- <name>org.eclipse.jdt.core.javabuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.ManifestBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- </buildSpec>
- <natures>
- <nature>org.eclipse.pde.PluginNature</nature>
- <nature>org.eclipse.jdt.core.javanature</nature>
- </natures>
-</projectDescription>
+<?xml version="1.0" encoding="UTF-8"?>
+<projectDescription>
+ <name>org.eclipse.papyrus.customization.extendedtypes.emf</name>
+ <comment></comment>
+ <projects>
+ </projects>
+ <buildSpec>
+ <buildCommand>
+ <name>org.eclipse.jdt.core.javabuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.ManifestBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.SchemaBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
+ <arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>release.path</key>
+ <value>org.eclipse.papyrus.releng.main.release/release.xml</value>
+ </dictionary>
+ </arguments>
+ </buildCommand>
+ </buildSpec>
+ <natures>
+ <nature>org.eclipse.pde.PluginNature</nature>
+ <nature>org.eclipse.jdt.core.javanature</nature>
+ <nature>org.eclipse.oomph.version.VersionNature</nature>
+ </natures>
+</projectDescription>
diff --git a/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.emf/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.emf/META-INF/MANIFEST.MF
index fa5476b9585..1d587c3cd42 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.emf/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.emf/META-INF/MANIFEST.MF
@@ -1,8 +1,6 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.properties.ui;bundle-version="1.2.0",
- org.eclipse.papyrus.customization.extendedtypes;bundle-version="1.2.0"
+Require-Bundle: org.eclipse.papyrus.infra.properties.ui;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.papyrus.customization.extendedtypes;bundle-version="[1.2.0,2.0.0)"
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
Bundle-Version: 1.2.0.qualifier
diff --git a/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.uml/.project b/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.uml/.project
index 04c2b52c2c3..7d9bff6670c 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.uml/.project
+++ b/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.uml/.project
@@ -1,28 +1,46 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<projectDescription>
- <name>org.eclipse.papyrus.customization.extendedtypes.uml</name>
- <comment></comment>
- <projects>
- </projects>
- <buildSpec>
- <buildCommand>
- <name>org.eclipse.jdt.core.javabuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.ManifestBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- </buildSpec>
- <natures>
- <nature>org.eclipse.pde.PluginNature</nature>
- <nature>org.eclipse.jdt.core.javanature</nature>
- </natures>
-</projectDescription>
+<?xml version="1.0" encoding="UTF-8"?>
+<projectDescription>
+ <name>org.eclipse.papyrus.customization.extendedtypes.uml</name>
+ <comment></comment>
+ <projects>
+ </projects>
+ <buildSpec>
+ <buildCommand>
+ <name>org.eclipse.jdt.core.javabuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.ManifestBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.SchemaBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
+ <arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>release.path</key>
+ <value>org.eclipse.papyrus.releng.main.release/release.xml</value>
+ </dictionary>
+ </arguments>
+ </buildCommand>
+ </buildSpec>
+ <natures>
+ <nature>org.eclipse.pde.PluginNature</nature>
+ <nature>org.eclipse.jdt.core.javanature</nature>
+ <nature>org.eclipse.oomph.version.VersionNature</nature>
+ </natures>
+</projectDescription>
diff --git a/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.uml/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.uml/META-INF/MANIFEST.MF
index 60932311477..3ebe24c5f4e 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.uml/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.extendedtypes.uml/META-INF/MANIFEST.MF
@@ -1,8 +1,6 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.properties.ui;bundle-version="1.2.0",
- org.eclipse.papyrus.customization.extendedtypes;bundle-version="1.2.0"
+Require-Bundle: org.eclipse.papyrus.infra.properties.ui;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.papyrus.customization.extendedtypes;bundle-version="[1.2.0,2.0.0)"
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
Bundle-Version: 1.2.0.qualifier
diff --git a/plugins/customization/org.eclipse.papyrus.customization.extendedtypes/.project b/plugins/customization/org.eclipse.papyrus.customization.extendedtypes/.project
index f75d3c9557e..9b0f9d6d912 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.extendedtypes/.project
+++ b/plugins/customization/org.eclipse.papyrus.customization.extendedtypes/.project
@@ -1,28 +1,46 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<projectDescription>
- <name>org.eclipse.papyrus.customization.extendedtypes</name>
- <comment></comment>
- <projects>
- </projects>
- <buildSpec>
- <buildCommand>
- <name>org.eclipse.jdt.core.javabuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.ManifestBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- </buildSpec>
- <natures>
- <nature>org.eclipse.pde.PluginNature</nature>
- <nature>org.eclipse.jdt.core.javanature</nature>
- </natures>
-</projectDescription>
+<?xml version="1.0" encoding="UTF-8"?>
+<projectDescription>
+ <name>org.eclipse.papyrus.customization.extendedtypes</name>
+ <comment></comment>
+ <projects>
+ </projects>
+ <buildSpec>
+ <buildCommand>
+ <name>org.eclipse.jdt.core.javabuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.ManifestBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.SchemaBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
+ <arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>release.path</key>
+ <value>org.eclipse.papyrus.releng.main.release/release.xml</value>
+ </dictionary>
+ </arguments>
+ </buildCommand>
+ </buildSpec>
+ <natures>
+ <nature>org.eclipse.pde.PluginNature</nature>
+ <nature>org.eclipse.jdt.core.javanature</nature>
+ <nature>org.eclipse.oomph.version.VersionNature</nature>
+ </natures>
+</projectDescription>
diff --git a/plugins/customization/org.eclipse.papyrus.customization.extendedtypes/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.extendedtypes/META-INF/MANIFEST.MF
index 0dbaaf4c19c..f6b37ead789 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.extendedtypes/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.extendedtypes/META-INF/MANIFEST.MF
@@ -1,7 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.properties.ui;bundle-version="1.2.0"
+Require-Bundle: org.eclipse.papyrus.infra.properties.ui;bundle-version="[1.2.0,2.0.0)"
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
Bundle-Version: 1.2.0.qualifier
diff --git a/plugins/customization/org.eclipse.papyrus.customization.palette/.project b/plugins/customization/org.eclipse.papyrus.customization.palette/.project
index cdc3f107099..31cb9051c27 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.palette/.project
+++ b/plugins/customization/org.eclipse.papyrus.customization.palette/.project
@@ -1,28 +1,46 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<projectDescription>
- <name>org.eclipse.papyrus.customization.palette</name>
- <comment></comment>
- <projects>
- </projects>
- <buildSpec>
- <buildCommand>
- <name>org.eclipse.jdt.core.javabuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.ManifestBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- </buildSpec>
- <natures>
- <nature>org.eclipse.pde.PluginNature</nature>
- <nature>org.eclipse.jdt.core.javanature</nature>
- </natures>
-</projectDescription>
+<?xml version="1.0" encoding="UTF-8"?>
+<projectDescription>
+ <name>org.eclipse.papyrus.customization.palette</name>
+ <comment></comment>
+ <projects>
+ </projects>
+ <buildSpec>
+ <buildCommand>
+ <name>org.eclipse.jdt.core.javabuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.ManifestBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.SchemaBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
+ <arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>release.path</key>
+ <value>/org.eclipse.papyrus.releng.main.release/release.xml</value>
+ </dictionary>
+ </arguments>
+ </buildCommand>
+ </buildSpec>
+ <natures>
+ <nature>org.eclipse.pde.PluginNature</nature>
+ <nature>org.eclipse.jdt.core.javanature</nature>
+ <nature>org.eclipse.oomph.version.VersionNature</nature>
+ </natures>
+</projectDescription>
diff --git a/plugins/customization/org.eclipse.papyrus.customization.palette/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.palette/META-INF/MANIFEST.MF
index ce0a4749a96..db16d3489c6 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.palette/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.palette/META-INF/MANIFEST.MF
@@ -1,27 +1,16 @@
-Manifest-Version: 1.0
-Export-Package: org.eclipse.papyrus.customization.palette,
- org.eclipse.papyrus.customization.palette.dialog,
- org.eclipse.papyrus.customization.palette.proxies
-Require-Bundle: org.eclipse.pde;bundle-version="3.6.0",
- org.eclipse.pde.ui;bundle-version="3.6.0",
- org.eclipse.papyrus.uml.diagram.paletteconfiguration;bundle-version="1.2.0",
- org.eclipse.core.runtime;bundle-version="3.8.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="1.2.0",
- org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.200",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
- org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.core.sasheditor;bundle-version="1.2.0",
- org.eclipse.uml2.uml;bundle-version="4.0.0",
- org.eclipse.papyrus.infra.core;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.emf;bundle-version="1.2.0",
- org.eclipse.papyrus.emf.facet.custom.ui;bundle-version="1.2.0",
- org.eclipse.papyrus.emf.facet.custom.core;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="1.2.0"
-Bundle-Vendor: %providerName
-Bundle-ClassPath: .
-Bundle-Version: 1.2.0.qualifier
-Bundle-Localization: plugin
-Bundle-Name: %pluginName
-Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.customization.palette;singleton:=true
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.customization.palette,
+ org.eclipse.papyrus.customization.palette.dialog,
+ org.eclipse.papyrus.customization.palette.proxies
+Require-Bundle: org.eclipse.pde;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.pde.ui;bundle-version="[3.9.0,4.0.0)",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[1.2.0,2.0.0)";visibility:=reexport
+Bundle-Vendor: %providerName
+Bundle-ClassPath: .
+Bundle-Version: 1.2.0.qualifier
+Bundle-Localization: plugin
+Bundle-Name: %pluginName
+Bundle-ManifestVersion: 2
+Bundle-SymbolicName: org.eclipse.papyrus.customization.palette;singleton:=true
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/.project b/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/.project
index e6fc7832d9a..955406ef912 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/.project
+++ b/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/.project
@@ -1,29 +1,47 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<projectDescription>
- <name>org.eclipse.papyrus.customization.paletteconfiguration</name>
- <comment></comment>
- <projects>
- </projects>
- <buildSpec>
- <buildCommand>
- <name>org.eclipse.jdt.core.javabuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.ManifestBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- </buildSpec>
- <natures>
- <nature>org.eclipse.papyrus.emf.facet.common.ProjectNature</nature>
- <nature>org.eclipse.pde.PluginNature</nature>
- <nature>org.eclipse.jdt.core.javanature</nature>
- </natures>
-</projectDescription>
+<?xml version="1.0" encoding="UTF-8"?>
+<projectDescription>
+ <name>org.eclipse.papyrus.customization.paletteconfiguration</name>
+ <comment></comment>
+ <projects>
+ </projects>
+ <buildSpec>
+ <buildCommand>
+ <name>org.eclipse.jdt.core.javabuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.ManifestBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.SchemaBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
+ <arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>release.path</key>
+ <value>/org.eclipse.papyrus.releng.main.release/release.xml</value>
+ </dictionary>
+ </arguments>
+ </buildCommand>
+ </buildSpec>
+ <natures>
+ <nature>org.eclipse.papyrus.emf.facet.common.ProjectNature</nature>
+ <nature>org.eclipse.pde.PluginNature</nature>
+ <nature>org.eclipse.jdt.core.javanature</nature>
+ <nature>org.eclipse.oomph.version.VersionNature</nature>
+ </natures>
+</projectDescription>
diff --git a/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/META-INF/MANIFEST.MF
index 6e7d1118c33..ea75d018a7c 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.paletteconfiguration/META-INF/MANIFEST.MF
@@ -1,20 +1,16 @@
-Manifest-Version: 1.0
-Export-Package: org.eclipse.papyrus.customization.paletteconfiguration,
- org.eclipse.papyrus.customization.paletteconfiguration.queries
-Require-Bundle: org.eclipse.ui;bundle-version="3.7.0",
- org.eclipse.core.runtime;bundle-version="3.7.0",
- org.eclipse.papyrus.uml.diagram.paletteconfiguration;bundle-version="1.2.0",
- org.eclipse.uml2.uml;bundle-version="3.2.0",
- org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.4.0",
- org.eclipse.papyrus.infra.extendedtypes;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.diagram.paletteconfiguration.edit;bundle-version="1.2.0",
- org.eclipse.papyrus.emf.facet.query.java.core;bundle-version="1.2.0"
-Bundle-Vendor: %Bundle-Vendor
-Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.0.qualifier
-Bundle-Localization: plugin
-Bundle-Name: %Bundle-Name
-Bundle-Activator: org.eclipse.papyrus.customization.paletteconfiguration.Activator
-Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.customization.paletteconfiguration;singleton:=true
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.customization.paletteconfiguration,
+ org.eclipse.papyrus.customization.paletteconfiguration.queries
+Require-Bundle: org.eclipse.uml2.uml;bundle-version="[5.2.0,6.0.0)",
+ org.eclipse.papyrus.infra.extendedtypes;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.uml.diagram.paletteconfiguration.edit;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.papyrus.emf.facet.query.java.core;bundle-version="[1.2.0,2.0.0)";visibility:=reexport
+Bundle-Vendor: %Bundle-Vendor
+Bundle-ActivationPolicy: lazy
+Bundle-Version: 1.2.0.qualifier
+Bundle-Localization: plugin
+Bundle-Name: %Bundle-Name
+Bundle-Activator: org.eclipse.papyrus.customization.paletteconfiguration.Activator
+Bundle-ManifestVersion: 2
+Bundle-SymbolicName: org.eclipse.papyrus.customization.paletteconfiguration;singleton:=true
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties.generation/.project b/plugins/customization/org.eclipse.papyrus.customization.properties.generation/.project
index e94613a0d4e..6bd7d558acb 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties.generation/.project
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties.generation/.project
@@ -1,38 +1,56 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<projectDescription>
- <name>org.eclipse.papyrus.customization.properties.generation</name>
- <comment></comment>
- <projects>
- </projects>
- <buildSpec>
- <buildCommand>
- <name>org.eclipse.jdt.core.javabuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.ManifestBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.m2m.qvt.oml.project.QVTOBuilder</name>
- <arguments>
- <dictionary>
- <key>src_container</key>
- <value>transforms</value>
- </dictionary>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- </buildSpec>
- <natures>
- <nature>org.eclipse.m2m.qvt.oml.project.QVTONature</nature>
- <nature>org.eclipse.pde.PluginNature</nature>
- <nature>org.eclipse.jdt.core.javanature</nature>
- </natures>
-</projectDescription>
+<?xml version="1.0" encoding="UTF-8"?>
+<projectDescription>
+ <name>org.eclipse.papyrus.customization.properties.generation</name>
+ <comment></comment>
+ <projects>
+ </projects>
+ <buildSpec>
+ <buildCommand>
+ <name>org.eclipse.jdt.core.javabuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.ManifestBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.m2m.qvt.oml.project.QVTOBuilder</name>
+ <arguments>
+ <dictionary>
+ <key>src_container</key>
+ <value>transforms</value>
+ </dictionary>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.SchemaBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
+ <arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>release.path</key>
+ <value>/org.eclipse.papyrus.releng.main.release/release.xml</value>
+ </dictionary>
+ </arguments>
+ </buildCommand>
+ </buildSpec>
+ <natures>
+ <nature>org.eclipse.m2m.qvt.oml.project.QVTONature</nature>
+ <nature>org.eclipse.pde.PluginNature</nature>
+ <nature>org.eclipse.jdt.core.javanature</nature>
+ <nature>org.eclipse.oomph.version.VersionNature</nature>
+ </natures>
+</projectDescription>
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties.generation/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.properties.generation/META-INF/MANIFEST.MF
index c0d8e21fed1..28272f0cbd3 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties.generation/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties.generation/META-INF/MANIFEST.MF
@@ -1,45 +1,26 @@
-Manifest-Version: 1.0
-Export-Package: org.eclipse.papyrus.customization.properties.generation,
- org.eclipse.papyrus.customization.properties.generation.generators,
- org.eclipse.papyrus.customization.properties.generation.layout,
- org.eclipse.papyrus.customization.properties.generation.wizard,
- org.eclipse.papyrus.customization.properties.generation.wizard.widget
-Require-Bundle: org.eclipse.ui;bundle-version="3.6.1",
- org.eclipse.osgi;bundle-version="3.6.1",
- org.eclipse.core.runtime;bundle-version="3.6.0",
- org.eclipse.papyrus.infra.properties;bundle-version="1.2.0",
- org.eclipse.m2m.qvt.oml;bundle-version="3.0.1",
- org.eclipse.m2m.qvt.oml.common;bundle-version="2.1.0",
- org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.properties.edit;bundle-version="1.2.0",
- org.eclipse.emf.common.ui;bundle-version="2.6.0",
- org.eclipse.core.resources;bundle-version="3.6.0",
- org.eclipse.uml2.uml;bundle-version="3.1.1",
- org.eclipse.papyrus.views.properties;bundle-version="1.2.0",
- org.eclipse.core.databinding;bundle-version="1.3.100",
- org.eclipse.emf.databinding;bundle-version="1.2.0",
- org.eclipse.core.databinding.property;bundle-version="1.3.0",
- org.eclipse.papyrus.customization.properties.model.xwt;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.tools;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.constraints;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.emf;bundle-version="1.2.0",
- org.eclipse.m2m.qvt.oml.project;bundle-version="3.1.0",
- org.eclipse.papyrus.customization.properties;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.widgets;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.emf;bundle-version="1.2.0",
- org.eclipse.jface.databinding;bundle-version="1.6.200",
- org.eclipse.papyrus.emf.facet.custom.core;bundle-version="1.2.0",
- org.eclipse.papyrus.emf.facet.custom.ui;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.ui.emf;bundle-version="1.2.0"
-Bundle-Vendor: %Bundle-Vendor
-Bundle-ActivationPolicy: lazy
-Bundle-ClassPath: .,
- bin
-Bundle-Version: 1.2.0.qualifier
-Eclipse-BuddyPolicy: dependent
-Bundle-Name: %Bundle-Name
-Bundle-ManifestVersion: 2
-Bundle-Activator: org.eclipse.papyrus.customization.properties.generation.Activator
-Bundle-Description: %pluginDescription
-Bundle-SymbolicName: org.eclipse.papyrus.customization.properties.generation;singleton:=true
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.customization.properties.generation,
+ org.eclipse.papyrus.customization.properties.generation.generators,
+ org.eclipse.papyrus.customization.properties.generation.layout,
+ org.eclipse.papyrus.customization.properties.generation.wizard,
+ org.eclipse.papyrus.customization.properties.generation.wizard.widget
+Require-Bundle: org.eclipse.m2m.qvt.oml;bundle-version="[3.6.0,4.0.0)";visibility:=reexport,
+ org.eclipse.papyrus.infra.properties.edit;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.2.0,6.0.0)";visibility:=reexport,
+ org.eclipse.papyrus.views.properties;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.papyrus.customization.properties.model.xwt;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml.project;bundle-version="[3.6.0,4.0.0)",
+ org.eclipse.papyrus.customization.properties;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.jface.databinding;bundle-version="[1.8.0,2.0.0)"
+Bundle-Vendor: %Bundle-Vendor
+Bundle-ActivationPolicy: lazy
+Bundle-ClassPath: .,
+ bin
+Bundle-Version: 1.2.0.qualifier
+Eclipse-BuddyPolicy: dependent
+Bundle-Name: %Bundle-Name
+Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.customization.properties.generation.Activator
+Bundle-Description: %pluginDescription
+Bundle-SymbolicName: org.eclipse.papyrus.customization.properties.generation;singleton:=true
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/.project b/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/.project
index c206f4a22bc..ada41a4b484 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/.project
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/.project
@@ -1,38 +1,60 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<projectDescription>
- <name>org.eclipse.papyrus.customization.properties.model.xwt</name>
- <comment></comment>
- <projects>
- </projects>
- <buildSpec>
- <buildCommand>
- <name>org.eclipse.jdt.core.javabuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.ManifestBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.m2m.qvt.oml.project.QVTOBuilder</name>
- <arguments>
- <dictionary>
- <key>src_container</key>
- <value>Transformation</value>
- </dictionary>
- </arguments>
- </buildCommand>
- </buildSpec>
- <natures>
- <nature>org.eclipse.pde.PluginNature</nature>
- <nature>org.eclipse.jdt.core.javanature</nature>
- <nature>org.eclipse.m2m.qvt.oml.project.QVTONature</nature>
- </natures>
-</projectDescription>
+<?xml version="1.0" encoding="UTF-8"?>
+<projectDescription>
+ <name>org.eclipse.papyrus.customization.properties.model.xwt</name>
+ <comment></comment>
+ <projects>
+ </projects>
+ <buildSpec>
+ <buildCommand>
+ <name>org.eclipse.jdt.core.javabuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.ManifestBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.SchemaBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.m2m.qvt.oml.project.QVTOBuilder</name>
+ <arguments>
+ <dictionary>
+ <key>src_container</key>
+ <value>Transformation</value>
+ </dictionary>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
+ <arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.missing.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>release.path</key>
+ <value>/org.eclipse.papyrus.releng.main.release/release.xml</value>
+ </dictionary>
+ </arguments>
+ </buildCommand>
+ </buildSpec>
+ <natures>
+ <nature>org.eclipse.pde.PluginNature</nature>
+ <nature>org.eclipse.jdt.core.javanature</nature>
+ <nature>org.eclipse.m2m.qvt.oml.project.QVTONature</nature>
+ <nature>org.eclipse.oomph.version.VersionNature</nature>
+ </natures>
+</projectDescription>
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/META-INF/MANIFEST.MF
index 1299b08a90f..e991aa76ae3 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/META-INF/MANIFEST.MF
@@ -1,26 +1,20 @@
-Manifest-Version: 1.0
-Export-Package: org.eclipse.papyrus.customization.properties.model.xwt.resource,
- org.eclipse.papyrus.customization.properties.model.xwt.xwtxml,
- org.eclipse.papyrus.customization.properties.model.xwt.xwtxml.impl,
- org.eclipse.papyrus.customization.properties.model.xwt.xwtxml.util
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.emf.ecore,
- org.eclipse.m2m.qvt.oml;bundle-version="3.1.0",
- org.eclipse.papyrus.views.properties;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.properties;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
- org.eclipse.wst.xml.core;bundle-version="1.1.0",
- org.eclipse.core.resources;bundle-version="3.7.0",
- org.eclipse.m2m.qvt.oml.project;bundle-version="3.1.0",
- com.ibm.icu
-Bundle-Vendor: %Bundle-Vendor
-Bundle-ActivationPolicy: lazy
-Bundle-ClassPath: .
-Bundle-Version: 1.2.0.qualifier
-Bundle-Name: %Bundle-Name
-Bundle-Activator: org.eclipse.papyrus.customization.properties.model.xwt.Activator
-Bundle-ManifestVersion: 2
-Bundle-Description: %pluginDescription
-Bundle-SymbolicName: org.eclipse.papyrus.customization.properties.model.xwt;singleton:=true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.customization.properties.model.xwt.resource,
+ org.eclipse.papyrus.customization.properties.model.xwt.xwtxml,
+ org.eclipse.papyrus.customization.properties.model.xwt.xwtxml.impl,
+ org.eclipse.papyrus.customization.properties.model.xwt.xwtxml.util
+Require-Bundle: org.eclipse.m2m.qvt.oml;bundle-version="[3.6.0,4.0.0)",
+ org.eclipse.papyrus.views.properties;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.wst.xml.core;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml.project;bundle-version="[3.6.0,4.0.0)",
+ com.ibm.icu
+Bundle-Vendor: %Bundle-Vendor
+Bundle-ActivationPolicy: lazy
+Bundle-ClassPath: .
+Bundle-Version: 1.2.0.qualifier
+Bundle-Name: %Bundle-Name
+Bundle-Activator: org.eclipse.papyrus.customization.properties.model.xwt.Activator
+Bundle-ManifestVersion: 2
+Bundle-Description: %pluginDescription
+Bundle-SymbolicName: org.eclipse.papyrus.customization.properties.model.xwt;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties/.project b/plugins/customization/org.eclipse.papyrus.customization.properties/.project
index 8e74255f24f..8a52bef694f 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties/.project
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties/.project
@@ -1,30 +1,48 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<projectDescription>
- <name>org.eclipse.papyrus.customization.properties</name>
- <comment></comment>
- <projects>
- </projects>
- <buildSpec>
- <buildCommand>
- <name>org.eclipse.jdt.core.javabuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.ManifestBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- </buildSpec>
- <natures>
- <nature>org.eclipse.emf.facet.common.ProjectNature</nature>
- <nature>org.eclipse.m2m.qvt.oml.project.QVTONature</nature>
- <nature>org.eclipse.jdt.core.javanature</nature>
- <nature>org.eclipse.pde.PluginNature</nature>
- </natures>
-</projectDescription>
+<?xml version="1.0" encoding="UTF-8"?>
+<projectDescription>
+ <name>org.eclipse.papyrus.customization.properties</name>
+ <comment></comment>
+ <projects>
+ </projects>
+ <buildSpec>
+ <buildCommand>
+ <name>org.eclipse.jdt.core.javabuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.ManifestBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.SchemaBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
+ <arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>release.path</key>
+ <value>/org.eclipse.papyrus.releng.main.release/release.xml</value>
+ </dictionary>
+ </arguments>
+ </buildCommand>
+ </buildSpec>
+ <natures>
+ <nature>org.eclipse.emf.facet.common.ProjectNature</nature>
+ <nature>org.eclipse.m2m.qvt.oml.project.QVTONature</nature>
+ <nature>org.eclipse.jdt.core.javanature</nature>
+ <nature>org.eclipse.pde.PluginNature</nature>
+ <nature>org.eclipse.oomph.version.VersionNature</nature>
+ </natures>
+</projectDescription>
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.properties/META-INF/MANIFEST.MF
index 357df2e8e0e..991b43e4216 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties/META-INF/MANIFEST.MF
@@ -1,37 +1,21 @@
-Manifest-Version: 1.0
-Export-Package: org.eclipse.papyrus.customization.properties.editor,
- org.eclipse.papyrus.customization.properties.modelelement,
- org.eclipse.papyrus.customization.properties.providers,
- org.eclipse.papyrus.customization.properties.storage.actions
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.core.resources;bundle-version="3.6.0",
- org.eclipse.core.databinding.observable;bundle-version="1.3.0",
- org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.100",
- org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.widgets;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="1.2.0",
- org.eclipse.papyrus.views.properties;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.properties;bundle-version="1.2.0",
- org.eclipse.papyrus.customization.properties.model.xwt;bundle-version="1.2.0",
- org.eclipse.emf.ecore.editor;bundle-version="2.6.0",
- org.eclipse.emf.databinding;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.emf;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.constraints;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.core;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.services.labelprovider;bundle-version="1.2.0",
- org.eclipse.papyrus.emf.facet.custom.ui;bundle-version="1.2.0",
- org.eclipse.papyrus.emf.facet.custom.core;bundle-version="1.2.0",
- org.eclipse.papyrus.emf.facet.query.java.core;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.ui.emf;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.constraints.ui;bundle-version="1.2.0"
-Bundle-Vendor: %Bundle-Vendor
-Bundle-ActivationPolicy: lazy
-Bundle-ClassPath: .,
- bin
-Bundle-Version: 1.2.0.qualifier
-Bundle-Name: %Bundle-Name
-Bundle-Activator: org.eclipse.papyrus.customization.properties.Activator
-Bundle-ManifestVersion: 2
-Bundle-Description: %pluginDescription
-Bundle-SymbolicName: org.eclipse.papyrus.customization.properties;singleton:=true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.8
+Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.customization.properties.editor,
+ org.eclipse.papyrus.customization.properties.modelelement,
+ org.eclipse.papyrus.customization.properties.providers,
+ org.eclipse.papyrus.customization.properties.storage.actions
+Require-Bundle: org.eclipse.papyrus.uml.diagram.common;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.papyrus.views.properties;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.papyrus.customization.properties.model.xwt;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.emf.ecore.editor;bundle-version="[2.11.0,3.0.0)";visibility:=reexport,
+ org.eclipse.papyrus.infra.constraints.ui;bundle-version="[1.2.0,2.0.0)"
+Bundle-Vendor: %Bundle-Vendor
+Bundle-ActivationPolicy: lazy
+Bundle-ClassPath: .,
+ bin
+Bundle-Version: 1.2.0.qualifier
+Bundle-Name: %Bundle-Name
+Bundle-Activator: org.eclipse.papyrus.customization.properties.Activator
+Bundle-ManifestVersion: 2
+Bundle-Description: %pluginDescription
+Bundle-SymbolicName: org.eclipse.papyrus.customization.properties;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/plugins/customization/org.eclipse.papyrus.customization/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization/META-INF/MANIFEST.MF
index a70b7b15fc8..fdde98c5b9d 100644
--- a/plugins/customization/org.eclipse.papyrus.customization/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization/META-INF/MANIFEST.MF
@@ -1,23 +1,8 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.ui;bundle-version="3.7.0",
- org.eclipse.emf.ecore,
- org.eclipse.pde;bundle-version="3.6.100",
- org.eclipse.core.resources;bundle-version="3.7.100",
- org.eclipse.pde.core;bundle-version="3.7.0",
- org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.properties.ui;bundle-version="1.2.0",
- org.eclipse.pde.ui;bundle-version="3.6.100",
- org.eclipse.ui.ide;bundle-version="3.7.0",
- org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.200",
- org.eclipse.papyrus.infra.widgets;bundle-version="1.2.0",
- org.eclipse.papyrus.eclipse.project.editors;bundle-version="1.2.0",
- org.eclipse.core.databinding;bundle-version="1.4.0",
- org.eclipse.emf.edit;bundle-version="2.7.0",
- org.eclipse.emf.databinding;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.properties;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.emf;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.constraints;bundle-version="1.2.0"
+Require-Bundle: org.eclipse.pde;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.papyrus.infra.properties.ui;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.pde.ui;bundle-version="[3.9.0,4.0.0)",
+ org.eclipse.papyrus.eclipse.project.editors;bundle-version="[2.0.0,3.0.0)";visibility:=reexport
Export-Package: org.eclipse.papyrus.customization.factory,
org.eclipse.papyrus.customization.generator,
org.eclipse.papyrus.customization.model.customizationplugin,
diff --git a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ConstraintEnvironmentExtensionFactory.java b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ConstraintEnvironmentExtensionFactory.java
index 085556890f3..21524cedd5b 100644
--- a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ConstraintEnvironmentExtensionFactory.java
+++ b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ConstraintEnvironmentExtensionFactory.java
@@ -1,43 +1,43 @@
-/*****************************************************************************
- * Copyright (c) 2011 CEA LIST.
- *
- * All rights reserved. This program and the accompanying materials
- * are made available under the terms of the Eclipse Public License v1.0
- * which accompanies this distribution, and is available at
- * http://www.eclipse.org/legal/epl-v10.html
- *
- * Contributors:
- * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
- *****************************************************************************/
-package org.eclipse.papyrus.customization.factory;
-
-import org.eclipse.emf.ecore.EClass;
-import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
-import org.eclipse.papyrus.customization.model.customizationplugin.CustomizationPluginPackage;
-import org.eclipse.papyrus.customization.model.customizationplugin.FileBasedCustomizableElement;
-import org.eclipse.papyrus.customization.plugin.PluginEditor;
-
-
-public class ConstraintEnvironmentExtensionFactory extends FileBasedExtensionFactory {
-
- public ConstraintEnvironmentExtensionFactory() {
- super("Constraint environment", "org.eclipse.papyrus.infra.constraints.ConstraintEnvironment", "environmentModel", "environment", true); //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$ //$NON-NLS-4$
- }
-
- @Override
- public void addElement(CustomizableElement element, PluginEditor editor) {
- super.addElement(element, editor);
-
- editor.getManifestEditor().addDependency("org.eclipse.papyrus.infra.constraints"); //$NON-NLS-1$
- }
-
- @Override
- protected String getTargetPath(FileBasedCustomizableElement element) {
- return "/constraintEnvironment/" + getFileName(element); //$NON-NLS-1$
- }
-
- public EClass getCustomizableElementClass() {
- return CustomizationPluginPackage.eINSTANCE.getConstraintsEnvironment();
- }
-
-}
+/*****************************************************************************
+ * Copyright (c) 2011 CEA LIST.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
+ *****************************************************************************/
+package org.eclipse.papyrus.customization.factory;
+
+import org.eclipse.emf.ecore.EClass;
+import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
+import org.eclipse.papyrus.customization.model.customizationplugin.CustomizationPluginPackage;
+import org.eclipse.papyrus.customization.model.customizationplugin.FileBasedCustomizableElement;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IPluginEditor;
+
+
+public class ConstraintEnvironmentExtensionFactory extends FileBasedExtensionFactory {
+
+ public ConstraintEnvironmentExtensionFactory() {
+ super("Constraint environment", "org.eclipse.papyrus.infra.constraints.ConstraintEnvironment", "environmentModel", "environment", true); //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$ //$NON-NLS-4$
+ }
+
+ @Override
+ public void addElement(CustomizableElement element, IPluginEditor editor) {
+ super.addElement(element, editor);
+
+ editor.addDependency("org.eclipse.papyrus.infra.constraints"); //$NON-NLS-1$
+ }
+
+ @Override
+ protected String getTargetPath(FileBasedCustomizableElement element) {
+ return "/constraintEnvironment/" + getFileName(element); //$NON-NLS-1$
+ }
+
+ public EClass getCustomizableElementClass() {
+ return CustomizationPluginPackage.eINSTANCE.getConstraintsEnvironment();
+ }
+
+}
diff --git a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ExtensionFactory.java b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ExtensionFactory.java
index 79fe0e89fa2..9f906d6f0fc 100644
--- a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ExtensionFactory.java
+++ b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ExtensionFactory.java
@@ -1,29 +1,31 @@
-/*****************************************************************************
- * Copyright (c) 2011 CEA LIST.
- *
- * All rights reserved. This program and the accompanying materials
- * are made available under the terms of the Eclipse Public License v1.0
- * which accompanies this distribution, and is available at
- * http://www.eclipse.org/legal/epl-v10.html
- *
- * Contributors:
- * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
- *****************************************************************************/
-package org.eclipse.papyrus.customization.factory;
-
-
-import org.eclipse.emf.ecore.EClass;
-import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
-import org.eclipse.papyrus.customization.plugin.PluginEditor;
-
-
-public interface ExtensionFactory {
-
- public static ExtensionFactoryRegistry registry = ExtensionFactoryRegistry.instance;
-
- public void addElement(CustomizableElement element, PluginEditor editor);
-
- public EClass getCustomizableElementClass();
-
- public String getName();
-}
+/*****************************************************************************
+ * Copyright (c) 2011, 2016 CEA LIST, Christian W. Damus, and others.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
+ * Christian W. Damus - bug 485220
+ *
+ *****************************************************************************/
+package org.eclipse.papyrus.customization.factory;
+
+
+import org.eclipse.emf.ecore.EClass;
+import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IPluginEditor;
+
+
+public interface ExtensionFactory {
+
+ public static ExtensionFactoryRegistry registry = ExtensionFactoryRegistry.instance;
+
+ public void addElement(CustomizableElement element, IPluginEditor editor);
+
+ public EClass getCustomizableElementClass();
+
+ public String getName();
+}
diff --git a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/FileBasedExtensionFactory.java b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/FileBasedExtensionFactory.java
index c230b88c1a1..da15790cf49 100644
--- a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/FileBasedExtensionFactory.java
+++ b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/FileBasedExtensionFactory.java
@@ -1,145 +1,147 @@
-/*****************************************************************************
- * Copyright (c) 2011 CEA LIST.
- *
- * All rights reserved. This program and the accompanying materials
- * are made available under the terms of the Eclipse Public License v1.0
- * which accompanies this distribution, and is available at
- * http://www.eclipse.org/legal/epl-v10.html
- *
- * Contributors:
- * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
- *****************************************************************************/
-package org.eclipse.papyrus.customization.factory;
-
-import java.io.File;
-import java.io.FileInputStream;
-import java.io.FileNotFoundException;
-import java.io.FileOutputStream;
-import java.io.IOException;
-import java.io.InputStream;
-import java.io.OutputStream;
-
-import org.eclipse.papyrus.customization.Activator;
-import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
-import org.eclipse.papyrus.customization.model.customizationplugin.FileBasedCustomizableElement;
-import org.eclipse.papyrus.customization.plugin.PluginEditor;
-import org.eclipse.papyrus.infra.widgets.util.FileUtil;
-import org.w3c.dom.Element;
-
-
-public abstract class FileBasedExtensionFactory implements ExtensionFactory {
-
- protected final String extensionPoint;
-
- protected final String fileAttributeName;
-
- protected final String fileElementName;
-
- protected final boolean allowMultiple;
-
- protected final String name;
-
- public FileBasedExtensionFactory(String name, String extensionPoint, String fileAttributeName, String fileElementName, boolean allowMultiple) {
- this.extensionPoint = extensionPoint;
- this.fileAttributeName = fileAttributeName;
- this.fileElementName = fileElementName;
- this.allowMultiple = allowMultiple;
- this.name = name;
- }
-
- public void addElement(CustomizableElement element, PluginEditor editor) {
- createExtension((FileBasedCustomizableElement) element, editor);
- try {
- copyFile((FileBasedCustomizableElement) element, editor);
- } catch (IOException ex) {
- Activator.log.error(ex);
- }
- }
-
- protected Element createExtension(FileBasedCustomizableElement element, PluginEditor editor) {
- Element extensionElement = null;
- if (element instanceof FileBasedCustomizableElement) {
- Element extension = editor.getPluginEditor().addExtension(extensionPoint);
- extensionElement = editor.getPluginEditor().addChild(extension, fileElementName);
- editor.getPluginEditor().setAttribute(extensionElement, fileAttributeName, getTargetPath(element));
- }
- return extensionElement;
- }
-
- protected void copyFile(FileBasedCustomizableElement element, PluginEditor editor) throws FileNotFoundException, IOException {
- copyFile(element.getFile(), getTargetPath(element), editor);
- }
-
- protected void copyFile(String sourcePath, String targetPath, PluginEditor editor) throws FileNotFoundException, IOException {
- File sourceFile = FileUtil.getFile(sourcePath);
- File targetFile = FileUtil.getWorkspaceFile("/" + editor.getProject().getName() + "/" + targetPath); //$NON-NLS-1$ //$NON-NLS-2$
-
- if (sourceFile == null) {
- throw new IllegalArgumentException("The source path " + sourcePath + " is not valid");
- }
-
- if (targetFile == null) {
- throw new IllegalArgumentException("The target path " + targetPath + " is not valid");
- }
-
- if (!targetFile.getParentFile().exists()) {
- targetFile.getParentFile().mkdirs();
- }
-
- copy(new FileInputStream(sourceFile), targetFile);
-
- editor.getBuildEditor().addToBuild(targetPath);
- }
-
- protected String getTargetPath(FileBasedCustomizableElement element) {
- return "/" + getFileName(element); //$NON-NLS-1$
- }
-
- protected String getFileName(FileBasedCustomizableElement element) {
- return getFileName(element.getFile());
- }
-
- protected String getFileName(String path) {
- if (path == null) {
- throw new IllegalArgumentException("File path should not be null");
- }
- String fileName;
- path = path.replace("\\", "/");
- if (path.indexOf("/") < 0) { //$NON-NLS-1$
- fileName = path;
- } else {
- fileName = path.substring(path.lastIndexOf("/") + 1, path.length()); //$NON-NLS-1$
- }
- return fileName;
- }
-
- protected void copy(InputStream source, File target) throws IOException {
- if (!target.getParentFile().exists()) {
- target.getParentFile().mkdirs();
- }
-
- OutputStream out = new FileOutputStream(target);
- try {
- int c;
-
- while ((c = source.read()) != -1) {
- out.write(c);
- }
-
- } catch (IOException ex) {
- throw ex;
- } finally {
- source.close();
- out.close();
- }
- }
-
- public boolean isValidElement(CustomizableElement element) {
- return element instanceof FileBasedCustomizableElement;
- }
-
- public String getName() {
- return name;
- }
-
-}
+/*****************************************************************************
+ * Copyright (c) 2011, 2016 CEA LIST, Christian W. Damus, and others.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
+ * Christian W. Damus - bug 485220
+ *
+ *****************************************************************************/
+package org.eclipse.papyrus.customization.factory;
+
+import java.io.File;
+import java.io.FileInputStream;
+import java.io.FileNotFoundException;
+import java.io.FileOutputStream;
+import java.io.IOException;
+import java.io.InputStream;
+import java.io.OutputStream;
+
+import org.eclipse.papyrus.customization.Activator;
+import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
+import org.eclipse.papyrus.customization.model.customizationplugin.FileBasedCustomizableElement;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IPluginEditor;
+import org.eclipse.papyrus.infra.widgets.util.FileUtil;
+import org.w3c.dom.Element;
+
+
+public abstract class FileBasedExtensionFactory implements ExtensionFactory {
+
+ protected final String extensionPoint;
+
+ protected final String fileAttributeName;
+
+ protected final String fileElementName;
+
+ protected final boolean allowMultiple;
+
+ protected final String name;
+
+ public FileBasedExtensionFactory(String name, String extensionPoint, String fileAttributeName, String fileElementName, boolean allowMultiple) {
+ this.extensionPoint = extensionPoint;
+ this.fileAttributeName = fileAttributeName;
+ this.fileElementName = fileElementName;
+ this.allowMultiple = allowMultiple;
+ this.name = name;
+ }
+
+ public void addElement(CustomizableElement element, IPluginEditor editor) {
+ createExtension((FileBasedCustomizableElement) element, editor);
+ try {
+ copyFile((FileBasedCustomizableElement) element, editor);
+ } catch (IOException ex) {
+ Activator.log.error(ex);
+ }
+ }
+
+ protected Element createExtension(FileBasedCustomizableElement element, IPluginEditor editor) {
+ Element extensionElement = null;
+ if (element instanceof FileBasedCustomizableElement) {
+ Element extension = editor.addExtension(extensionPoint);
+ extensionElement = editor.addChild(extension, fileElementName);
+ editor.setAttribute(extensionElement, fileAttributeName, getTargetPath(element));
+ }
+ return extensionElement;
+ }
+
+ protected void copyFile(FileBasedCustomizableElement element, IPluginEditor editor) throws FileNotFoundException, IOException {
+ copyFile(element.getFile(), getTargetPath(element), editor);
+ }
+
+ protected void copyFile(String sourcePath, String targetPath, IPluginEditor editor) throws FileNotFoundException, IOException {
+ File sourceFile = FileUtil.getFile(sourcePath);
+ File targetFile = FileUtil.getWorkspaceFile("/" + editor.getProject().getName() + "/" + targetPath); //$NON-NLS-1$ //$NON-NLS-2$
+
+ if (sourceFile == null) {
+ throw new IllegalArgumentException("The source path " + sourcePath + " is not valid");
+ }
+
+ if (targetFile == null) {
+ throw new IllegalArgumentException("The target path " + targetPath + " is not valid");
+ }
+
+ if (!targetFile.getParentFile().exists()) {
+ targetFile.getParentFile().mkdirs();
+ }
+
+ copy(new FileInputStream(sourceFile), targetFile);
+
+ editor.addToBuild(targetPath);
+ }
+
+ protected String getTargetPath(FileBasedCustomizableElement element) {
+ return "/" + getFileName(element); //$NON-NLS-1$
+ }
+
+ protected String getFileName(FileBasedCustomizableElement element) {
+ return getFileName(element.getFile());
+ }
+
+ protected String getFileName(String path) {
+ if (path == null) {
+ throw new IllegalArgumentException("File path should not be null");
+ }
+ String fileName;
+ path = path.replace("\\", "/");
+ if (path.indexOf("/") < 0) { //$NON-NLS-1$
+ fileName = path;
+ } else {
+ fileName = path.substring(path.lastIndexOf("/") + 1, path.length()); //$NON-NLS-1$
+ }
+ return fileName;
+ }
+
+ protected void copy(InputStream source, File target) throws IOException {
+ if (!target.getParentFile().exists()) {
+ target.getParentFile().mkdirs();
+ }
+
+ OutputStream out = new FileOutputStream(target);
+ try {
+ int c;
+
+ while ((c = source.read()) != -1) {
+ out.write(c);
+ }
+
+ } catch (IOException ex) {
+ throw ex;
+ } finally {
+ source.close();
+ out.close();
+ }
+ }
+
+ public boolean isValidElement(CustomizableElement element) {
+ return element instanceof FileBasedCustomizableElement;
+ }
+
+ public String getName() {
+ return name;
+ }
+
+}
diff --git a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ModelTemplateExtensionFactory.java b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ModelTemplateExtensionFactory.java
index 6394ddc451d..38ff8e1f3fb 100644
--- a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ModelTemplateExtensionFactory.java
+++ b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ModelTemplateExtensionFactory.java
@@ -1,67 +1,67 @@
-/*****************************************************************************
- * Copyright (c) 2011 CEA LIST.
- *
- * All rights reserved. This program and the accompanying materials
- * are made available under the terms of the Eclipse Public License v1.0
- * which accompanies this distribution, and is available at
- * http://www.eclipse.org/legal/epl-v10.html
- *
- * Contributors:
- * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
- *****************************************************************************/
-package org.eclipse.papyrus.customization.factory;
-
-import org.eclipse.emf.ecore.EClass;
-import org.eclipse.papyrus.customization.messages.Messages;
-import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
-import org.eclipse.papyrus.customization.model.customizationplugin.CustomizationPluginPackage;
-import org.eclipse.papyrus.customization.model.customizationplugin.FileBasedCustomizableElement;
-import org.eclipse.papyrus.customization.model.customizationplugin.ModelTemplate;
-import org.eclipse.papyrus.customization.plugin.PluginEditor;
-import org.w3c.dom.Element;
-
-
-public class ModelTemplateExtensionFactory extends FileBasedExtensionFactory {
-
- public ModelTemplateExtensionFactory() {
- super(Messages.ModelTemplateExtensionFactory_ModelTemplate, "org.eclipse.papyrus.uml.diagram.wizards.templates", "file", "template", true); //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$
- }
-
- @Override
- public void addElement(CustomizableElement element, PluginEditor editor) {
- super.addElement(element, editor);
-
- editor.getManifestEditor().addDependency("org.eclipse.papyrus.uml.diagram.wizards"); //$NON-NLS-1$
- }
-
- @Override
- protected Element createExtension(FileBasedCustomizableElement customizableElement, PluginEditor editor) {
- Element extension = super.createExtension(customizableElement, editor);
- if (customizableElement instanceof ModelTemplate) {
- ModelTemplate element = (ModelTemplate) customizableElement;
-
- extension.setAttribute("id", element.getId()); //$NON-NLS-1$
-
- if (element.getName() != null) {
- extension.setAttribute("name", element.getName()); //$NON-NLS-1$
- }
-
- if (element.getLanguage() != null) {
- extension.setAttribute("language", element.getLanguage()); //$NON-NLS-1$
- }
-
- // TODO: Papyrus now handles *.di and *.notation files
- }
-
- return extension;
- }
-
- @Override
- protected String getTargetPath(FileBasedCustomizableElement element) {
- return "/modelTemplate/" + getFileName(element); //$NON-NLS-1$
- }
-
- public EClass getCustomizableElementClass() {
- return CustomizationPluginPackage.eINSTANCE.getModelTemplate();
- }
-}
+/*****************************************************************************
+ * Copyright (c) 2011 CEA LIST.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
+ *****************************************************************************/
+package org.eclipse.papyrus.customization.factory;
+
+import org.eclipse.emf.ecore.EClass;
+import org.eclipse.papyrus.customization.messages.Messages;
+import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
+import org.eclipse.papyrus.customization.model.customizationplugin.CustomizationPluginPackage;
+import org.eclipse.papyrus.customization.model.customizationplugin.FileBasedCustomizableElement;
+import org.eclipse.papyrus.customization.model.customizationplugin.ModelTemplate;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IPluginEditor;
+import org.w3c.dom.Element;
+
+
+public class ModelTemplateExtensionFactory extends FileBasedExtensionFactory {
+
+ public ModelTemplateExtensionFactory() {
+ super(Messages.ModelTemplateExtensionFactory_ModelTemplate, "org.eclipse.papyrus.uml.diagram.wizards.templates", "file", "template", true); //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$
+ }
+
+ @Override
+ public void addElement(CustomizableElement element, IPluginEditor editor) {
+ super.addElement(element, editor);
+
+ editor.addDependency("org.eclipse.papyrus.uml.diagram.wizards"); //$NON-NLS-1$
+ }
+
+ @Override
+ protected Element createExtension(FileBasedCustomizableElement customizableElement, IPluginEditor editor) {
+ Element extension = super.createExtension(customizableElement, editor);
+ if (customizableElement instanceof ModelTemplate) {
+ ModelTemplate element = (ModelTemplate) customizableElement;
+
+ extension.setAttribute("id", element.getId()); //$NON-NLS-1$
+
+ if (element.getName() != null) {
+ extension.setAttribute("name", element.getName()); //$NON-NLS-1$
+ }
+
+ if (element.getLanguage() != null) {
+ extension.setAttribute("language", element.getLanguage()); //$NON-NLS-1$
+ }
+
+ // TODO: Papyrus now handles *.di and *.notation files
+ }
+
+ return extension;
+ }
+
+ @Override
+ protected String getTargetPath(FileBasedCustomizableElement element) {
+ return "/modelTemplate/" + getFileName(element); //$NON-NLS-1$
+ }
+
+ public EClass getCustomizableElementClass() {
+ return CustomizationPluginPackage.eINSTANCE.getModelTemplate();
+ }
+}
diff --git a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ProfileExtensionFactory.java b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ProfileExtensionFactory.java
index 1b0dec3ae1b..1c31b0e4249 100644
--- a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ProfileExtensionFactory.java
+++ b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/ProfileExtensionFactory.java
@@ -1,108 +1,108 @@
-/*****************************************************************************
- * Copyright (c) 2011 CEA LIST.
- *
- * All rights reserved. This program and the accompanying materials
- * are made available under the terms of the Eclipse Public License v1.0
- * which accompanies this distribution, and is available at
- * http://www.eclipse.org/legal/epl-v10.html
- *
- * Contributors:
- * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
- *****************************************************************************/
-package org.eclipse.papyrus.customization.factory;
-
-import java.io.File;
-import java.io.FileInputStream;
-import java.io.IOException;
-
-import org.eclipse.emf.ecore.EClass;
-import org.eclipse.papyrus.customization.Activator;
-import org.eclipse.papyrus.customization.messages.Messages;
-import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
-import org.eclipse.papyrus.customization.model.customizationplugin.CustomizationPluginPackage;
-import org.eclipse.papyrus.customization.model.customizationplugin.FileBasedCustomizableElement;
-import org.eclipse.papyrus.customization.model.customizationplugin.Profile;
-import org.eclipse.papyrus.customization.plugin.PluginEditor;
-import org.eclipse.papyrus.infra.widgets.util.FileUtil;
-import org.w3c.dom.Element;
-
-
-public class ProfileExtensionFactory extends FileBasedExtensionFactory {
-
- public ProfileExtensionFactory() {
- super(Messages.ProfileExtensionFactory_Profile, "org.eclipse.papyrus.uml.extensionpoints.UMLProfile", "path", "profile", true); //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$
- }
-
- @Override
- public void addElement(CustomizableElement element, PluginEditor editor) {
- super.addElement(element, editor);
-
- editor.getManifestEditor().addDependency("org.eclipse.papyrus.uml.extensionpoints"); //$NON-NLS-1$
- }
-
- @Override
- protected Element createExtension(FileBasedCustomizableElement element, PluginEditor editor) {
- Element extension = super.createExtension(element, editor);
- Profile profile = (Profile) element;
-
- extension.setAttribute("name", profile.getName()); //$NON-NLS-1$
-
- if (profile.getDescription() != null) {
- extension.setAttribute("description", profile.getDescription()); //$NON-NLS-1$
- }
-
- if (profile.getIconpath() != null && !profile.getIconpath().trim().equals("")) {
- //extension.setAttribute("iconpath", profile.getIconpath()); //$NON-NLS-1$
- copyIcon(profile.getIconpath(), editor);
- extension.setAttribute("iconpath", getIconPath(profile.getIconpath())); //$NON-NLS-1$
- }
-
- if (profile.getProvider() != null) {
- extension.setAttribute("provider", profile.getProvider()); //$NON-NLS-1$
- }
-
- return extension;
- }
-
- protected void copyIcon(String path, PluginEditor editor) {
- File sourceFile = FileUtil.getFile(path);
- File targetFile = FileUtil.getWorkspaceFile("/" + editor.getProject().getName() + "/" + getIconPath(path)); //$NON-NLS-1$ //$NON-NLS-2$
- if (!targetFile.getParentFile().exists()) {
- targetFile.getParentFile().mkdirs();
- }
-
- try {
- copy(new FileInputStream(sourceFile), targetFile);
- } catch (IOException ex) {
- Activator.log.error(ex);
- }
-
- editor.getBuildEditor().addToBuild("icons/"); //$NON-NLS-1$
- }
-
- protected String getIconPath(String path) {
- return "icons/" + getFileName(path); //$NON-NLS-1$
- }
-
- @Override
- protected String getFileName(String path) {
- String fileName;
- path = path.replace("\\", "/");
- if (path.indexOf("/") < 0) { //$NON-NLS-1$
- fileName = path;
- } else {
- fileName = path.substring(path.lastIndexOf("/") + 1, path.length()); //$NON-NLS-1$
- }
- return fileName;
- }
-
- @Override
- protected String getTargetPath(FileBasedCustomizableElement element) {
- return "/umlProfile/" + getFileName(element); //$NON-NLS-1$
- }
-
- public EClass getCustomizableElementClass() {
- return CustomizationPluginPackage.eINSTANCE.getProfile();
- }
-
-}
+/*****************************************************************************
+ * Copyright (c) 2011 CEA LIST.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
+ *****************************************************************************/
+package org.eclipse.papyrus.customization.factory;
+
+import java.io.File;
+import java.io.FileInputStream;
+import java.io.IOException;
+
+import org.eclipse.emf.ecore.EClass;
+import org.eclipse.papyrus.customization.Activator;
+import org.eclipse.papyrus.customization.messages.Messages;
+import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
+import org.eclipse.papyrus.customization.model.customizationplugin.CustomizationPluginPackage;
+import org.eclipse.papyrus.customization.model.customizationplugin.FileBasedCustomizableElement;
+import org.eclipse.papyrus.customization.model.customizationplugin.Profile;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IPluginEditor;
+import org.eclipse.papyrus.infra.widgets.util.FileUtil;
+import org.w3c.dom.Element;
+
+
+public class ProfileExtensionFactory extends FileBasedExtensionFactory {
+
+ public ProfileExtensionFactory() {
+ super(Messages.ProfileExtensionFactory_Profile, "org.eclipse.papyrus.uml.extensionpoints.UMLProfile", "path", "profile", true); //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$
+ }
+
+ @Override
+ public void addElement(CustomizableElement element, IPluginEditor editor) {
+ super.addElement(element, editor);
+
+ editor.addDependency("org.eclipse.papyrus.uml.extensionpoints"); //$NON-NLS-1$
+ }
+
+ @Override
+ protected Element createExtension(FileBasedCustomizableElement element, IPluginEditor editor) {
+ Element extension = super.createExtension(element, editor);
+ Profile profile = (Profile) element;
+
+ extension.setAttribute("name", profile.getName()); //$NON-NLS-1$
+
+ if (profile.getDescription() != null) {
+ extension.setAttribute("description", profile.getDescription()); //$NON-NLS-1$
+ }
+
+ if (profile.getIconpath() != null && !profile.getIconpath().trim().equals("")) {
+ // extension.setAttribute("iconpath", profile.getIconpath()); //$NON-NLS-1$
+ copyIcon(profile.getIconpath(), editor);
+ extension.setAttribute("iconpath", getIconPath(profile.getIconpath())); //$NON-NLS-1$
+ }
+
+ if (profile.getProvider() != null) {
+ extension.setAttribute("provider", profile.getProvider()); //$NON-NLS-1$
+ }
+
+ return extension;
+ }
+
+ protected void copyIcon(String path, IPluginEditor editor) {
+ File sourceFile = FileUtil.getFile(path);
+ File targetFile = FileUtil.getWorkspaceFile("/" + editor.getProject().getName() + "/" + getIconPath(path)); //$NON-NLS-1$ //$NON-NLS-2$
+ if (!targetFile.getParentFile().exists()) {
+ targetFile.getParentFile().mkdirs();
+ }
+
+ try {
+ copy(new FileInputStream(sourceFile), targetFile);
+ } catch (IOException ex) {
+ Activator.log.error(ex);
+ }
+
+ editor.addToBuild("icons/"); //$NON-NLS-1$
+ }
+
+ protected String getIconPath(String path) {
+ return "icons/" + getFileName(path); //$NON-NLS-1$
+ }
+
+ @Override
+ protected String getFileName(String path) {
+ String fileName;
+ path = path.replace("\\", "/");
+ if (path.indexOf("/") < 0) { //$NON-NLS-1$
+ fileName = path;
+ } else {
+ fileName = path.substring(path.lastIndexOf("/") + 1, path.length()); //$NON-NLS-1$
+ }
+ return fileName;
+ }
+
+ @Override
+ protected String getTargetPath(FileBasedCustomizableElement element) {
+ return "/umlProfile/" + getFileName(element); //$NON-NLS-1$
+ }
+
+ public EClass getCustomizableElementClass() {
+ return CustomizationPluginPackage.eINSTANCE.getProfile();
+ }
+
+}
diff --git a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/PropertyViewEnvironmentExtensionFactory.java b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/PropertyViewEnvironmentExtensionFactory.java
index 0556f997b09..87925310204 100644
--- a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/PropertyViewEnvironmentExtensionFactory.java
+++ b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/PropertyViewEnvironmentExtensionFactory.java
@@ -16,7 +16,7 @@ import org.eclipse.papyrus.customization.messages.Messages;
import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
import org.eclipse.papyrus.customization.model.customizationplugin.CustomizationPluginPackage;
import org.eclipse.papyrus.customization.model.customizationplugin.FileBasedCustomizableElement;
-import org.eclipse.papyrus.customization.plugin.PluginEditor;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IPluginEditor;
public class PropertyViewEnvironmentExtensionFactory extends FileBasedExtensionFactory {
@@ -26,10 +26,10 @@ public class PropertyViewEnvironmentExtensionFactory extends FileBasedExtensionF
}
@Override
- public void addElement(CustomizableElement element, PluginEditor editor) {
+ public void addElement(CustomizableElement element, IPluginEditor editor) {
super.addElement(element, editor);
- editor.getManifestEditor().addDependency("org.eclipse.papyrus.infra.properties.ui"); //$NON-NLS-1$
+ editor.addDependency("org.eclipse.papyrus.infra.properties.ui"); //$NON-NLS-1$
}
@Override
diff --git a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/PropertyViewExtensionFactory.java b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/PropertyViewExtensionFactory.java
index f8cb820e7d0..0d63ba62360 100644
--- a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/PropertyViewExtensionFactory.java
+++ b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/PropertyViewExtensionFactory.java
@@ -36,7 +36,7 @@ import org.eclipse.papyrus.customization.messages.Messages;
import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
import org.eclipse.papyrus.customization.model.customizationplugin.CustomizationPluginPackage;
import org.eclipse.papyrus.customization.model.customizationplugin.FileBasedCustomizableElement;
-import org.eclipse.papyrus.customization.plugin.PluginEditor;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IPluginEditor;
import org.eclipse.papyrus.infra.emf.utils.EMFHelper;
import org.eclipse.papyrus.infra.properties.contexts.Context;
import org.eclipse.papyrus.infra.widgets.util.FileUtil;
@@ -53,21 +53,21 @@ public class PropertyViewExtensionFactory extends FileBasedExtensionFactory {
}
@Override
- public void addElement(CustomizableElement element, PluginEditor editor) {
+ public void addElement(CustomizableElement element, IPluginEditor editor) {
super.addElement(element, editor);
- editor.getManifestEditor().addDependency("org.eclipse.papyrus.infra.properties.ui"); //$NON-NLS-1$
+ editor.addDependency("org.eclipse.papyrus.infra.properties.ui"); //$NON-NLS-1$
}
@Override
- protected Element createExtension(FileBasedCustomizableElement element, PluginEditor editor) {
+ protected Element createExtension(FileBasedCustomizableElement element, IPluginEditor editor) {
Element extension = super.createExtension(element, editor);
// extension.setAttribute("loadDefault", ((PropertyView)element).isLoadDefault() ? "true" : "false");
return extension;
}
@Override
- protected void copyFile(FileBasedCustomizableElement element, PluginEditor editor) {
+ protected void copyFile(FileBasedCustomizableElement element, IPluginEditor editor) {
String path = element.getFile();
File sourceFile = FileUtil.getFile(path);
URI uri = URI.createFileURI(sourceFile.getAbsolutePath());
@@ -93,7 +93,7 @@ public class PropertyViewExtensionFactory extends FileBasedExtensionFactory {
// Activator.log.error(ex);
// }
//
- editor.getBuildEditor().addToBuild("propertyView/");
+ editor.addToBuild("propertyView/");
}
private void copyAll(final Context source, final File target) {
diff --git a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/UICustomExtensionFactory.java b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/UICustomExtensionFactory.java
index 7b2fa90e872..ee17c2018cb 100644
--- a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/UICustomExtensionFactory.java
+++ b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/UICustomExtensionFactory.java
@@ -1,54 +1,54 @@
-/*****************************************************************************
- * Copyright (c) 2011 CEA LIST.
- *
- * All rights reserved. This program and the accompanying materials
- * are made available under the terms of the Eclipse Public License v1.0
- * which accompanies this distribution, and is available at
- * http://www.eclipse.org/legal/epl-v10.html
- *
- * Contributors:
- * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
- *****************************************************************************/
-package org.eclipse.papyrus.customization.factory;
-
-import org.eclipse.emf.ecore.EClass;
-import org.eclipse.papyrus.customization.messages.Messages;
-import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
-import org.eclipse.papyrus.customization.model.customizationplugin.CustomizationPluginPackage;
-import org.eclipse.papyrus.customization.model.customizationplugin.FileBasedCustomizableElement;
-import org.eclipse.papyrus.customization.model.customizationplugin.UICustom;
-import org.eclipse.papyrus.customization.plugin.PluginEditor;
-import org.w3c.dom.Element;
-
-
-
-public class UICustomExtensionFactory extends FileBasedExtensionFactory {
-
- public UICustomExtensionFactory() {
- super(Messages.UICustomExtensionFactory_UICustom, "org.eclipse.emf.facet.infra.browser.custom.core.registration", "file", "browserCustomization", true); //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$
- }
-
- @Override
- public void addElement(CustomizableElement element, PluginEditor editor) {
- super.addElement(element, editor);
-
- editor.getManifestEditor().addDependency("org.eclipse.emf.facet.infra.browser.custom"); //$NON-NLS-1$
- }
-
- @Override
- protected Element createExtension(FileBasedCustomizableElement element, PluginEditor editor) {
- Element extension = super.createExtension(element, editor);
- extension.setAttribute("loadByDefault", ((UICustom) element).isLoadByDefault() ? "true" : "false"); //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$
- return extension;
- }
-
- @Override
- protected String getTargetPath(FileBasedCustomizableElement element) {
- return "/uiCustom/" + getFileName(element); //$NON-NLS-1$
- }
-
- public EClass getCustomizableElementClass() {
- return CustomizationPluginPackage.eINSTANCE.getUICustom();
- }
-
-}
+/*****************************************************************************
+ * Copyright (c) 2011 CEA LIST.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
+ *****************************************************************************/
+package org.eclipse.papyrus.customization.factory;
+
+import org.eclipse.emf.ecore.EClass;
+import org.eclipse.papyrus.customization.messages.Messages;
+import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
+import org.eclipse.papyrus.customization.model.customizationplugin.CustomizationPluginPackage;
+import org.eclipse.papyrus.customization.model.customizationplugin.FileBasedCustomizableElement;
+import org.eclipse.papyrus.customization.model.customizationplugin.UICustom;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IPluginEditor;
+import org.w3c.dom.Element;
+
+
+
+public class UICustomExtensionFactory extends FileBasedExtensionFactory {
+
+ public UICustomExtensionFactory() {
+ super(Messages.UICustomExtensionFactory_UICustom, "org.eclipse.emf.facet.infra.browser.custom.core.registration", "file", "browserCustomization", true); //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$
+ }
+
+ @Override
+ public void addElement(CustomizableElement element, IPluginEditor editor) {
+ super.addElement(element, editor);
+
+ editor.addDependency("org.eclipse.emf.facet.infra.browser.custom"); //$NON-NLS-1$
+ }
+
+ @Override
+ protected Element createExtension(FileBasedCustomizableElement element, IPluginEditor editor) {
+ Element extension = super.createExtension(element, editor);
+ extension.setAttribute("loadByDefault", ((UICustom) element).isLoadByDefault() ? "true" : "false"); //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$
+ return extension;
+ }
+
+ @Override
+ protected String getTargetPath(FileBasedCustomizableElement element) {
+ return "/uiCustom/" + getFileName(element); //$NON-NLS-1$
+ }
+
+ public EClass getCustomizableElementClass() {
+ return CustomizationPluginPackage.eINSTANCE.getUICustom();
+ }
+
+}
diff --git a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/UMLModelExtensionFactory.java b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/UMLModelExtensionFactory.java
index 3e9015b40ee..df7b3359ee5 100644
--- a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/UMLModelExtensionFactory.java
+++ b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/factory/UMLModelExtensionFactory.java
@@ -1,69 +1,69 @@
-/*****************************************************************************
- * Copyright (c) 2011 CEA LIST.
- *
- * All rights reserved. This program and the accompanying materials
- * are made available under the terms of the Eclipse Public License v1.0
- * which accompanies this distribution, and is available at
- * http://www.eclipse.org/legal/epl-v10.html
- *
- * Contributors:
- * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
- *****************************************************************************/
-package org.eclipse.papyrus.customization.factory;
-
-import org.eclipse.emf.ecore.EClass;
-import org.eclipse.papyrus.customization.messages.Messages;
-import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
-import org.eclipse.papyrus.customization.model.customizationplugin.CustomizationPluginPackage;
-import org.eclipse.papyrus.customization.model.customizationplugin.FileBasedCustomizableElement;
-import org.eclipse.papyrus.customization.model.customizationplugin.UMLModel;
-import org.eclipse.papyrus.customization.plugin.PluginEditor;
-import org.w3c.dom.Element;
-
-
-public class UMLModelExtensionFactory extends FileBasedExtensionFactory {
-
- public UMLModelExtensionFactory() {
- super(Messages.UMLModelExtensionFactory_UMLModel, "org.eclipse.papyrus.uml.extensionpoints.UMLLibrary", "path", "library", false); //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$
- }
-
- @Override
- public void addElement(CustomizableElement element, PluginEditor editor) {
- super.addElement(element, editor);
-
- editor.getManifestEditor().addDependency("org.eclipse.papyrus.uml.extensionpoints"); //$NON-NLS-1$
- }
-
- @Override
- protected Element createExtension(FileBasedCustomizableElement element, PluginEditor editor) {
- Element extension = super.createExtension(element, editor);
- UMLModel model = (UMLModel) element;
-
- if (model.getDescription() != null) {
- extension.setAttribute("description", model.getDescription()); //$NON-NLS-1$
- }
-
- if (model.getIconpath() != null) {
- extension.setAttribute("iconpath", model.getIconpath()); //$NON-NLS-1$
- }
-
- if (model.getName() != null) {
- extension.setAttribute("name", model.getName()); //$NON-NLS-1$
- }
-
- if (model.getProvider() != null) {
- extension.setAttribute("provider", model.getProvider()); //$NON-NLS-1$
- }
-
- return extension;
- }
-
- @Override
- protected String getTargetPath(FileBasedCustomizableElement element) {
- return "/umlLibrary/" + getFileName(element); //$NON-NLS-1$
- }
-
- public EClass getCustomizableElementClass() {
- return CustomizationPluginPackage.eINSTANCE.getUMLModel();
- }
-}
+/*****************************************************************************
+ * Copyright (c) 2011 CEA LIST.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
+ *****************************************************************************/
+package org.eclipse.papyrus.customization.factory;
+
+import org.eclipse.emf.ecore.EClass;
+import org.eclipse.papyrus.customization.messages.Messages;
+import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
+import org.eclipse.papyrus.customization.model.customizationplugin.CustomizationPluginPackage;
+import org.eclipse.papyrus.customization.model.customizationplugin.FileBasedCustomizableElement;
+import org.eclipse.papyrus.customization.model.customizationplugin.UMLModel;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IPluginEditor;
+import org.w3c.dom.Element;
+
+
+public class UMLModelExtensionFactory extends FileBasedExtensionFactory {
+
+ public UMLModelExtensionFactory() {
+ super(Messages.UMLModelExtensionFactory_UMLModel, "org.eclipse.papyrus.uml.extensionpoints.UMLLibrary", "path", "library", false); //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$
+ }
+
+ @Override
+ public void addElement(CustomizableElement element, IPluginEditor editor) {
+ super.addElement(element, editor);
+
+ editor.addDependency("org.eclipse.papyrus.uml.extensionpoints"); //$NON-NLS-1$
+ }
+
+ @Override
+ protected Element createExtension(FileBasedCustomizableElement element, IPluginEditor editor) {
+ Element extension = super.createExtension(element, editor);
+ UMLModel model = (UMLModel) element;
+
+ if (model.getDescription() != null) {
+ extension.setAttribute("description", model.getDescription()); //$NON-NLS-1$
+ }
+
+ if (model.getIconpath() != null) {
+ extension.setAttribute("iconpath", model.getIconpath()); //$NON-NLS-1$
+ }
+
+ if (model.getName() != null) {
+ extension.setAttribute("name", model.getName()); //$NON-NLS-1$
+ }
+
+ if (model.getProvider() != null) {
+ extension.setAttribute("provider", model.getProvider()); //$NON-NLS-1$
+ }
+
+ return extension;
+ }
+
+ @Override
+ protected String getTargetPath(FileBasedCustomizableElement element) {
+ return "/umlLibrary/" + getFileName(element); //$NON-NLS-1$
+ }
+
+ public EClass getCustomizableElementClass() {
+ return CustomizationPluginPackage.eINSTANCE.getUMLModel();
+ }
+}
diff --git a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/generator/PluginGenerator.java b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/generator/PluginGenerator.java
index d8976a7ad97..62dd9141f0c 100644
--- a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/generator/PluginGenerator.java
+++ b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/generator/PluginGenerator.java
@@ -1,94 +1,98 @@
-/*****************************************************************************
- * Copyright (c) 2011 CEA LIST.
- *
- * All rights reserved. This program and the accompanying materials
- * are made available under the terms of the Eclipse Public License v1.0
- * which accompanies this distribution, and is available at
- * http://www.eclipse.org/legal/epl-v10.html
- *
- * Contributors:
- * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
- *****************************************************************************/
-package org.eclipse.papyrus.customization.generator;
-
-import java.io.IOException;
-import java.util.Collections;
-import java.util.HashSet;
-import java.util.Set;
-
-import javax.xml.parsers.ParserConfigurationException;
-
-import org.eclipse.core.resources.IProject;
-import org.eclipse.core.runtime.CoreException;
-import org.eclipse.emf.common.util.URI;
-import org.eclipse.emf.ecore.resource.Resource;
-import org.eclipse.emf.ecore.resource.ResourceSet;
-import org.eclipse.emf.ecore.resource.impl.ResourceSetImpl;
-import org.eclipse.papyrus.customization.Activator;
-import org.eclipse.papyrus.customization.factory.ExtensionFactory;
-import org.eclipse.papyrus.customization.messages.Messages;
-import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
-import org.eclipse.papyrus.customization.model.customizationplugin.CustomizationConfiguration;
-import org.eclipse.papyrus.customization.plugin.PluginEditor;
-import org.eclipse.papyrus.eclipse.project.editors.interfaces.IPluginProjectEditor;
-import org.xml.sax.SAXException;
-
-public class PluginGenerator {
-
- public static PluginGenerator instance = new PluginGenerator();
-
- private final static String PLUGIN_NATURE_ID = "org.eclipse.pde.PluginNature"; //$NON-NLS-1$
-
- public void generate(IProject project, CustomizationConfiguration configuration) throws CoreException, IOException, SAXException, ParserConfigurationException {
- PluginEditor editor;
-
- editor = new PluginEditor(project);
-
- // editor.addNature("org.eclipse.jdt.core.javanature");
-
- Set<String> natures = new HashSet<String>();
- natures.add(PLUGIN_NATURE_ID);
- editor.addNatures(natures);
- editor.setSingleton(true);
-
- for (CustomizableElement element : configuration.getElements()) {
- ExtensionFactory factory = getFactory(element);
- if (factory != null) {
- factory.addElement(element, editor);
- } else {
- Activator.log.warn(Messages.PluginGenerator_factoryNotFound + element.eClass());
- }
- }
-
- editor.save();
-
-
- if (editor.getPluginEditor().exists()) {
- editor.getBuildEditor().addToBuild(IPluginProjectEditor.PLUGIN_XML_FILE);
- editor.getBuildEditor().save();
- }
-
- String pluginId = configuration.getPlugin();
- Resource resource = configuration.eResource();
- URI uri = URI.createPlatformResourceURI(pluginId + "/customizationConfiguration.xmi", true); //$NON-NLS-1$
- if (resource == null) {
- ResourceSet resourceSet = new ResourceSetImpl();
- resource = resourceSet.createResource(uri);
- resource.getContents().add(configuration);
- } else {
- configuration.eResource().setURI(uri);
- }
-
- configuration.eResource().save(Collections.EMPTY_MAP);
-
- editor.getProject().refreshLocal(0, null);
- }
-
- private ExtensionFactory getFactory(CustomizableElement element) {
- ExtensionFactory factory = ExtensionFactory.registry.getFactory(element.eClass());
- return factory;
- }
-
- private PluginGenerator() {
- }
-}
+/*****************************************************************************
+ * Copyright (c) 2011 CEA LIST.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
+ *****************************************************************************/
+package org.eclipse.papyrus.customization.generator;
+
+import java.io.IOException;
+import java.util.Collections;
+import java.util.HashSet;
+import java.util.Set;
+
+import javax.xml.parsers.ParserConfigurationException;
+
+import org.eclipse.core.resources.IProject;
+import org.eclipse.core.runtime.CoreException;
+import org.eclipse.emf.common.util.URI;
+import org.eclipse.emf.ecore.resource.Resource;
+import org.eclipse.emf.ecore.resource.ResourceSet;
+import org.eclipse.emf.ecore.resource.impl.ResourceSetImpl;
+import org.eclipse.papyrus.customization.Activator;
+import org.eclipse.papyrus.customization.factory.ExtensionFactory;
+import org.eclipse.papyrus.customization.messages.Messages;
+import org.eclipse.papyrus.customization.model.customizationplugin.CustomizableElement;
+import org.eclipse.papyrus.customization.model.customizationplugin.CustomizationConfiguration;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IPluginEditor;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IPluginProjectEditor;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.ProjectEditors;
+import org.xml.sax.SAXException;
+
+public class PluginGenerator {
+
+ public static PluginGenerator instance = new PluginGenerator();
+
+ private final static String PLUGIN_NATURE_ID = "org.eclipse.pde.PluginNature"; //$NON-NLS-1$
+
+ public void generate(IProject project, CustomizationConfiguration configuration) throws CoreException, IOException, SAXException, ParserConfigurationException {
+ IPluginEditor editor;
+
+ editor = ProjectEditors.getPluginEditor(project);
+ if (!editor.exists()) {
+ editor.create();
+ }
+ editor.init();
+
+ // editor.addNature("org.eclipse.jdt.core.javanature");
+
+ Set<String> natures = new HashSet<String>();
+ natures.add(PLUGIN_NATURE_ID);
+ editor.addNatures(natures);
+ editor.setSingleton(true);
+
+ for (CustomizableElement element : configuration.getElements()) {
+ ExtensionFactory factory = getFactory(element);
+ if (factory != null) {
+ factory.addElement(element, editor);
+ } else {
+ Activator.log.warn(Messages.PluginGenerator_factoryNotFound + element.eClass());
+ }
+ }
+
+ editor.save();
+
+ if (editor.pluginManifestExists()) {
+ editor.addToBuild(IPluginProjectEditor.PLUGIN_XML_FILE);
+ editor.save();
+ }
+
+ String pluginId = configuration.getPlugin();
+ Resource resource = configuration.eResource();
+ URI uri = URI.createPlatformResourceURI(pluginId + "/customizationConfiguration.xmi", true); //$NON-NLS-1$
+ if (resource == null) {
+ ResourceSet resourceSet = new ResourceSetImpl();
+ resource = resourceSet.createResource(uri);
+ resource.getContents().add(configuration);
+ } else {
+ configuration.eResource().setURI(uri);
+ }
+
+ configuration.eResource().save(Collections.EMPTY_MAP);
+
+ editor.getProject().refreshLocal(0, null);
+ }
+
+ private ExtensionFactory getFactory(CustomizableElement element) {
+ ExtensionFactory factory = ExtensionFactory.registry.getFactory(element.eClass());
+ return factory;
+ }
+
+ private PluginGenerator() {
+ }
+}
diff --git a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/plugin/PluginEditor.java b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/plugin/PluginEditor.java
index eb61d0b73e5..8c6abf404a4 100644
--- a/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/plugin/PluginEditor.java
+++ b/plugins/customization/org.eclipse.papyrus.customization/src/org/eclipse/papyrus/customization/plugin/PluginEditor.java
@@ -1,217 +1,40 @@
-/*****************************************************************************
- * Copyright (c) 2011 CEA LIST.
- *
- * All rights reserved. This program and the accompanying materials
- * are made available under the terms of the Eclipse Public License v1.0
- * which accompanies this distribution, and is available at
- * http://www.eclipse.org/legal/epl-v10.html
- *
- * Contributors:
- * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
- *****************************************************************************/
-package org.eclipse.papyrus.customization.plugin;
-
-import java.io.IOException;
-
-import javax.xml.parsers.ParserConfigurationException;
-
-import org.eclipse.core.resources.IProject;
-import org.eclipse.core.runtime.CoreException;
-import org.eclipse.papyrus.eclipse.project.editors.file.BuildEditor;
-import org.eclipse.papyrus.eclipse.project.editors.file.ManifestEditor;
-import org.eclipse.papyrus.eclipse.project.editors.interfaces.IBuildEditor;
-import org.eclipse.papyrus.eclipse.project.editors.interfaces.IManifestEditor;
-import org.eclipse.papyrus.eclipse.project.editors.interfaces.IPluginProjectEditor;
-import org.eclipse.papyrus.eclipse.project.editors.project.PluginProjectEditor;
-import org.xml.sax.SAXException;
-
-public class PluginEditor extends PluginProjectEditor implements IPluginProjectEditor, IManifestEditor, IBuildEditor {
-
- protected IManifestEditor manifest;
-
- protected IBuildEditor build;
-
- public PluginEditor(IProject project) throws CoreException, IOException, SAXException, ParserConfigurationException {
- super(project);
- manifest = new ManifestEditor(project);
- build = new BuildEditor(project);
-
- manifest.init();
- build.init();
- if (!exists()) {
- create();
- }
- init();
- }
-
- public PluginProjectEditor getPluginEditor() {
- return this;
- }
-
- public IManifestEditor getManifestEditor() {
- return manifest;
- }
-
- public IBuildEditor getBuildEditor() {
- return build;
- }
-
- public void registerSourceFolder(String source) {
- build.registerSourceFolder(source);
- }
-
- public void addToBuild(String path) {
- build.addToBuild(path);
- }
-
- public String[] getSourceFolders() {
- return build.getSourceFolders();
- }
-
- public void addDependency(String dependency) {
- manifest.addDependency(dependency);
- }
-
- public void addDependency(String dependency, String version) {
- manifest.addDependency(dependency, version);
- }
-
- /**
- * @see org.eclipse.papyrus.eclipse.project.editors.interfaces.IManifestEditor#hasDependency(java.lang.String)
- *
- * @param dependency
- * @return
- */
- public boolean hasDependency(String dependency) {
- return manifest.hasDependency(dependency);
- }
-
- public void setValue(String key, String value) {
- manifest.setValue(key, value);
- }
-
- public void setValue(String key, String name, String value) {
- manifest.setValue(key, name, value);
- }
-
- public void removeValue(String key, String value) {
- manifest.removeValue(key, value);
- }
-
- public void removeValue(String key) {
- manifest.removeValue(key);
- }
-
- public void setBundleName(String name) {
- manifest.setBundleName(name);
- }
-
- public String getSymbolicBundleName() {
- return manifest.getSymbolicBundleName();
- }
-
- public String getBundleVersion() {
- return manifest.getBundleVersion();
- }
-
- public void setBundleVersion(String version) {
- manifest.setBundleVersion(version);
- }
-
- @Override
- public void save() {
- super.save();
- manifest.save();
- build.save();
- }
-
- public void registerBinFolder(String binFolder) {
- build.registerBinFolder(binFolder);
- }
-
- public void removeFromBuild(String path) {
- build.removeFromBuild(path);
- }
-
- public boolean isRegisteredSourceFolder(String path) {
- return build.isRegisteredSourceFolder(path);
- }
-
- public boolean isRegisteredBinFolder(String binFolder) {
- return build.isRegisteredBinFolder(binFolder);
- }
-
- public String[] getElementsInBuild() {
- return build.getElementsInBuild();
- }
-
- public String getBundleVendor() {
- return manifest.getBundleVendor();
- }
-
- public void setBundleVendor(String vendor) {
- manifest.setBundleVendor(vendor);
- }
-
- public String getValue(String key) {
- return manifest.getValue(key);
- }
-
- public void setSymbolicBundleName(String name) {
- manifest.setSymbolicBundleName(name);
- }
-
- public String getBundleName() {
- return manifest.getBundleName();
- }
-
- public String getBundleLocalization() {
- return manifest.getBundleLocalization();
- }
-
- public void setSingleton(boolean singleton) {
- manifest.setSingleton(singleton);
- }
-
- public void setDependenciesVersion(String dependencyPattern, String newVersion) {
- manifest.setDependenciesVersion(dependencyPattern, newVersion);
- }
-
- /**
- * @see org.eclipse.papyrus.eclipse.project.editors.interfaces.IManifestEditor#addImportPackage(java.lang.String)
- *
- * @param packageName
- */
- public void addImportPackage(String packageName) {
- manifest.addImportPackage(packageName);
- }
-
- /**
- * @see org.eclipse.papyrus.eclipse.project.editors.interfaces.IManifestEditor#addImportPackage(java.lang.String, java.lang.String)
- *
- * @param packageName
- * @param version
- */
- public void addImportPackage(String packageName, String version) {
- manifest.addImportPackage(packageName, version);
- }
-
- /**
- * @see org.eclipse.papyrus.eclipse.project.editors.interfaces.IManifestEditor#addExportPackage(java.lang.String)
- *
- * @param packageName
- */
- public void addExportPackage(String packageName) {
- manifest.addExportPackage(packageName);
- }
-
- /**
- * @see org.eclipse.papyrus.eclipse.project.editors.interfaces.IManifestEditor#addExportPackage(java.lang.String, java.lang.String)
- *
- * @param packageName
- * @param version
- */
- public void addExportPackage(String packageName, String version) {
- manifest.addExportPackage(packageName, version);
- }
-}
+/*****************************************************************************
+ * Copyright (c) 2011, 2016 CEA LIST, Christian W. Damus, and others.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Camille Letavernier (CEA LIST) camille.letavernier@cea.fr - Initial API and implementation
+ * Christian W. Damus - bug 485220
+ *
+ *****************************************************************************/
+package org.eclipse.papyrus.customization.plugin;
+
+import java.io.IOException;
+
+import javax.xml.parsers.ParserConfigurationException;
+
+import org.eclipse.core.resources.IProject;
+import org.eclipse.core.runtime.CoreException;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.ProjectEditors;
+import org.xml.sax.SAXException;
+
+/**
+ * @deprecated Use the {@link ProjectEditors#getPluginEditor(IProject)} API, instead.
+ */
+@Deprecated
+public class PluginEditor extends org.eclipse.papyrus.eclipse.project.editors.project.PluginEditor {
+
+ public PluginEditor(IProject project) throws CoreException, IOException, SAXException, ParserConfigurationException {
+ super(project);
+
+ if (!exists()) {
+ create();
+ }
+
+ init();
+ }
+}
diff --git a/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.edit/.project b/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.edit/.project
index f3f5d526a87..6c9a959a7fb 100644
--- a/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.edit/.project
+++ b/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.edit/.project
@@ -1,28 +1,46 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<projectDescription>
- <name>org.eclipse.papyrus.infra.gmfdiag.expansion.edit</name>
- <comment></comment>
- <projects>
- </projects>
- <buildSpec>
- <buildCommand>
- <name>org.eclipse.jdt.core.javabuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.ManifestBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- </buildSpec>
- <natures>
- <nature>org.eclipse.jdt.core.javanature</nature>
- <nature>org.eclipse.pde.PluginNature</nature>
- </natures>
-</projectDescription>
+<?xml version="1.0" encoding="UTF-8"?>
+<projectDescription>
+ <name>org.eclipse.papyrus.infra.gmfdiag.expansion.edit</name>
+ <comment></comment>
+ <projects>
+ </projects>
+ <buildSpec>
+ <buildCommand>
+ <name>org.eclipse.jdt.core.javabuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.ManifestBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.SchemaBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
+ <arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>release.path</key>
+ <value>/org.eclipse.papyrus.releng.main.release/release.xml</value>
+ </dictionary>
+ </arguments>
+ </buildCommand>
+ </buildSpec>
+ <natures>
+ <nature>org.eclipse.jdt.core.javanature</nature>
+ <nature>org.eclipse.pde.PluginNature</nature>
+ <nature>org.eclipse.oomph.version.VersionNature</nature>
+ </natures>
+</projectDescription>
diff --git a/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.edit/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.edit/META-INF/MANIFEST.MF
index edde45f37f3..188997cd46a 100644
--- a/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.edit/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.edit/META-INF/MANIFEST.MF
@@ -1,17 +1,15 @@
-Manifest-Version: 1.0
-Export-Package: org.eclipse.papyrus.infra.gmfdiag.common.expansionmodel.provider,
- org.eclipse.papyrus.infra.gmfdiag.expansion.expansionmodel.provider
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.gmfdiag.common;visibility:=reexport,
- org.eclipse.emf.edit;visibility:=reexport,
- org.eclipse.uml2.common.edit;visibility:=reexport
-Bundle-Vendor: %providerName
-Bundle-ActivationPolicy: lazy
-Bundle-ClassPath: .
-Bundle-Version: 1.2.0.qualifier
-Bundle-Name: %pluginName
-Bundle-Localization: plugin
-Bundle-ManifestVersion: 2
-Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.expansion.expansionmodel.provider.ExpandModelEditPlugin$Implementation
-Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.expansion.edit;singleton:=true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.infra.gmfdiag.common.expansionmodel.provider,
+ org.eclipse.papyrus.infra.gmfdiag.expansion.expansionmodel.provider
+Require-Bundle: org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
+ org.eclipse.uml2.common.edit;bundle-version="[2.1.0,3.0.0)";visibility:=reexport
+Bundle-Vendor: %providerName
+Bundle-ActivationPolicy: lazy
+Bundle-ClassPath: .
+Bundle-Version: 1.2.0.qualifier
+Bundle-Name: %pluginName
+Bundle-Localization: plugin
+Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.expansion.expansionmodel.provider.ExpandModelEditPlugin$Implementation
+Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.expansion.edit;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.editor/.project b/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.editor/.project
index 28ffbba4a5a..9224a1d644d 100644
--- a/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.editor/.project
+++ b/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.editor/.project
@@ -1,28 +1,46 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<projectDescription>
- <name>org.eclipse.papyrus.infra.gmfdiag.expansion.editor</name>
- <comment></comment>
- <projects>
- </projects>
- <buildSpec>
- <buildCommand>
- <name>org.eclipse.jdt.core.javabuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.ManifestBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- </buildSpec>
- <natures>
- <nature>org.eclipse.jdt.core.javanature</nature>
- <nature>org.eclipse.pde.PluginNature</nature>
- </natures>
-</projectDescription>
+<?xml version="1.0" encoding="UTF-8"?>
+<projectDescription>
+ <name>org.eclipse.papyrus.infra.gmfdiag.expansion.editor</name>
+ <comment></comment>
+ <projects>
+ </projects>
+ <buildSpec>
+ <buildCommand>
+ <name>org.eclipse.jdt.core.javabuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.ManifestBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.SchemaBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
+ <arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>release.path</key>
+ <value>/org.eclipse.papyrus.releng.main.release/release.xml</value>
+ </dictionary>
+ </arguments>
+ </buildCommand>
+ </buildSpec>
+ <natures>
+ <nature>org.eclipse.jdt.core.javanature</nature>
+ <nature>org.eclipse.pde.PluginNature</nature>
+ <nature>org.eclipse.oomph.version.VersionNature</nature>
+ </natures>
+</projectDescription>
diff --git a/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.editor/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.editor/META-INF/MANIFEST.MF
index 79d57e3029e..c59799a1b5f 100644
--- a/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.editor/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.editor/META-INF/MANIFEST.MF
@@ -1,20 +1,14 @@
-Manifest-Version: 1.0
-Export-Package: org.eclipse.papyrus.infra.gmfdiag.common.expansionmodel.presentation,
- org.eclipse.papyrus.infra.gmfdiag.expansion.expansionmodel.presentation
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.core.resources;visibility:=reexport,
- org.eclipse.papyrus.infra.gmfdiag.expansion.edit;visibility:=reexport,
- org.eclipse.emf.ecore.xmi;visibility:=reexport,
- org.eclipse.emf.edit.ui;visibility:=reexport,
- org.eclipse.ui.ide;visibility:=reexport,
- org.eclipse.papyrus.infra.gmfdiag.common
-Bundle-Vendor: %providerName
-Bundle-ActivationPolicy: lazy
-Bundle-ClassPath: .
-Bundle-Version: 1.2.0.qualifier
-Bundle-Name: %pluginName
-Bundle-Localization: plugin
-Bundle-ManifestVersion: 2
-Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.expansion.expansionmodel.presentation.ExpandModelEditorPlugin$Implementation
-Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.expansion.editor;singleton:=true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.infra.gmfdiag.common.expansionmodel.presentation,
+ org.eclipse.papyrus.infra.gmfdiag.expansion.expansionmodel.presentation
+Require-Bundle: org.eclipse.papyrus.infra.gmfdiag.expansion.edit;bundle-version="[1.2.0,2.0.0)";visibility:=reexport
+Bundle-Vendor: %providerName
+Bundle-ActivationPolicy: lazy
+Bundle-ClassPath: .
+Bundle-Version: 1.2.0.qualifier
+Bundle-Name: %pluginName
+Bundle-Localization: plugin
+Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.expansion.expansionmodel.presentation.ExpandModelEditorPlugin$Implementation
+Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.expansion.editor;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/developer/org.eclipse.papyrus.codegen/.project b/plugins/developer/org.eclipse.papyrus.codegen/.project
index b64a36a87a7..baf242b17b7 100644
--- a/plugins/developer/org.eclipse.papyrus.codegen/.project
+++ b/plugins/developer/org.eclipse.papyrus.codegen/.project
@@ -1,34 +1,47 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<projectDescription>
- <name>org.eclipse.papyrus.codegen</name>
- <comment></comment>
- <projects>
- </projects>
- <buildSpec>
- <buildCommand>
- <name>org.eclipse.jdt.core.javabuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.ManifestBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.openarchitectureware.base.oawBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- </buildSpec>
- <natures>
- <nature>org.eclipse.pde.PluginNature</nature>
- <nature>org.eclipse.jdt.core.javanature</nature>
- <nature>org.openarchitectureware.base.oawNature</nature>
- </natures>
-</projectDescription>
+<?xml version="1.0" encoding="UTF-8"?>
+<projectDescription>
+ <name>org.eclipse.papyrus.codegen</name>
+ <comment></comment>
+ <projects>
+ </projects>
+ <buildSpec>
+ <buildCommand>
+ <name>org.eclipse.jdt.core.javabuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.ManifestBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.openarchitectureware.base.oawBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
+ <arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>release.path</key>
+ <value>/org.eclipse.papyrus.releng.dev.release/release.xml</value>
+ </dictionary>
+ </arguments>
+ </buildCommand>
+ </buildSpec>
+ <natures>
+ <nature>org.eclipse.pde.PluginNature</nature>
+ <nature>org.eclipse.jdt.core.javanature</nature>
+ <nature>org.openarchitectureware.base.oawNature</nature>
+ <nature>org.eclipse.oomph.version.VersionNature</nature>
+ </natures>
+</projectDescription>
diff --git a/plugins/developer/org.eclipse.papyrus.codegen/META-INF/MANIFEST.MF b/plugins/developer/org.eclipse.papyrus.codegen/META-INF/MANIFEST.MF
index 4b70d2d62ee..b899aaefdd3 100644
--- a/plugins/developer/org.eclipse.papyrus.codegen/META-INF/MANIFEST.MF
+++ b/plugins/developer/org.eclipse.papyrus.codegen/META-INF/MANIFEST.MF
@@ -1,21 +1,19 @@
-Manifest-Version: 1.0
-Export-Package: org.eclipse.papyrus.codegen;x-internal:=true,
- org.eclipse.papyrus.codegen.actions;x-internal:=true
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.gmf.codegen;bundle-version="2.1.0",
- org.eclipse.gmf.codegen.ui;bundle-version="1.1.0",
- org.eclipse.gmf.codegen.xtend;bundle-version="1.0.0",
- org.eclipse.gmf.codegen.xtend.ui;bundle-version="1.0.0",
- org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
- org.eclipse.papyrus.def;bundle-version="1.2.0",
- org.eclipse.papyrus.gmfgenextension;bundle-version="1.2.0"
-Bundle-Vendor: %providerName
-Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.0.qualifier
-Bundle-Name: %pluginName
-Bundle-Localization: plugin
-Bundle-Activator: org.eclipse.papyrus.codegen.Activator
-Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.codegen;singleton:=true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.8
+Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.codegen;x-internal:=true,
+ org.eclipse.papyrus.codegen.actions;x-internal:=true
+Require-Bundle: org.eclipse.ui;bundle-version="[3.107.0,4.0.0)",
+ org.eclipse.gmf.codegen.ui;bundle-version="[1.3.0,2.0.0)",
+ org.eclipse.gmf.codegen.xtend;bundle-version="[1.0.0,2.0.0)",
+ org.eclipse.gmf.codegen.xtend.ui;bundle-version="[1.0.0,2.0.0)",
+ org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.papyrus.def;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.papyrus.gmfgenextension;bundle-version="[1.2.0,2.0.0)"
+Bundle-Vendor: %providerName
+Bundle-ActivationPolicy: lazy
+Bundle-Version: 1.2.0.qualifier
+Bundle-Name: %pluginName
+Bundle-Localization: plugin
+Bundle-Activator: org.eclipse.papyrus.codegen.Activator
+Bundle-ManifestVersion: 2
+Bundle-SymbolicName: org.eclipse.papyrus.codegen;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/plugins/developer/org.eclipse.papyrus.def/.project b/plugins/developer/org.eclipse.papyrus.def/.project
index c70c4b4fa47..60684c34fbb 100644
--- a/plugins/developer/org.eclipse.papyrus.def/.project
+++ b/plugins/developer/org.eclipse.papyrus.def/.project
@@ -1,56 +1,69 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<projectDescription>
- <name>org.eclipse.papyrus.def</name>
- <comment></comment>
- <projects>
- </projects>
- <buildSpec>
- <buildCommand>
- <name>org.eclipse.xtext.ui.shared.xtextBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.jdt.core.javabuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.ManifestBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.openarchitectureware.base.oawBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.gmf.xpand.oawBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.gmf.xpand.xpandBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.xtend.shared.ui.xtendBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- </buildSpec>
- <natures>
- <nature>org.eclipse.jdt.core.javanature</nature>
- <nature>org.eclipse.pde.PluginNature</nature>
- <nature>org.openarchitectureware.base.oawNature</nature>
- <nature>org.eclipse.xtend.shared.ui.xtendXPandNature</nature>
- <nature>org.eclipse.xtext.ui.shared.xtextNature</nature>
- </natures>
-</projectDescription>
+<?xml version="1.0" encoding="UTF-8"?>
+<projectDescription>
+ <name>org.eclipse.papyrus.def</name>
+ <comment></comment>
+ <projects>
+ </projects>
+ <buildSpec>
+ <buildCommand>
+ <name>org.eclipse.xtext.ui.shared.xtextBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.jdt.core.javabuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.ManifestBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.openarchitectureware.base.oawBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.gmf.xpand.oawBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.gmf.xpand.xpandBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.xtend.shared.ui.xtendBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
+ <arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>release.path</key>
+ <value>/org.eclipse.papyrus.releng.dev.release/release.xml</value>
+ </dictionary>
+ </arguments>
+ </buildCommand>
+ </buildSpec>
+ <natures>
+ <nature>org.eclipse.jdt.core.javanature</nature>
+ <nature>org.eclipse.pde.PluginNature</nature>
+ <nature>org.openarchitectureware.base.oawNature</nature>
+ <nature>org.eclipse.xtend.shared.ui.xtendXPandNature</nature>
+ <nature>org.eclipse.xtext.ui.shared.xtextNature</nature>
+ <nature>org.eclipse.oomph.version.VersionNature</nature>
+ </natures>
+</projectDescription>
diff --git a/plugins/developer/org.eclipse.papyrus.def/META-INF/MANIFEST.MF b/plugins/developer/org.eclipse.papyrus.def/META-INF/MANIFEST.MF
index c5b4c74a36f..6508a073938 100644
--- a/plugins/developer/org.eclipse.papyrus.def/META-INF/MANIFEST.MF
+++ b/plugins/developer/org.eclipse.papyrus.def/META-INF/MANIFEST.MF
@@ -1,22 +1,17 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.2.0,4.0.0)",
- org.eclipse.core.resources;bundle-version="[3.2.0,4.0.0)",
- org.eclipse.emf.ecore;bundle-version="[2.4.0,3.0.0)";visibility:=reexport,
- org.eclipse.emf.codegen.ecore;bundle-version="[2.4.0,3.0.0)";visibility:=reexport,
- org.eclipse.draw2d;bundle-version="[3.2.0,4.0.0)",
- org.eclipse.gmf.runtime.notation,
- org.eclipse.gmf.common;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
- org.eclipse.gmf.validate;bundle-version="[1.1.0,2.0.0)",
- org.eclipse.gmf.codegen;bundle-version="[2.0.0,3.1.0)",
- org.eclipse.gmf.graphdef;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.xtext;bundle-version="2.3.1",
- org.eclipse.xtext.builder;bundle-version="2.3.1",
- org.eclipse.xtend.lib,
- org.eclipse.ocl.ecore,
- com.google.guava;bundle-version="11.0.0",
- org.eclipse.xtext.xbase.lib,
- org.eclipse.gmf.codegen.xtend;bundle-version="1.0.0",
- org.eclipse.papyrus.gmfgenextension;bundle-version="1.2.0"
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.emf.ecore;bundle-version="[2.12.0,3.0.0)";visibility:=reexport,
+ org.eclipse.emf.codegen.ecore;bundle-version="[2.12.0,3.0.0)";visibility:=reexport,
+ org.eclipse.draw2d;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.gmf.runtime.notation;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.gmf.common;bundle-version="[1.3.0,2.0.0)";visibility:=reexport,
+ org.eclipse.gmf.validate;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.gmf.graphdef;bundle-version="[2.9.0,3.0.0)",
+ org.eclipse.xtext;bundle-version="[2.10.0,3.0.0)",
+ org.eclipse.xtext.builder;bundle-version="[2.10.0,3.0.0)",
+ org.eclipse.xtend.lib;bundle-version="[2.10.0,3.0.0)",
+ org.eclipse.gmf.codegen.xtend;bundle-version="[1.0.0,2.0.0)",
+ org.eclipse.papyrus.gmfgenextension;bundle-version="[1.2.0,2.0.0)"
Bundle-Vendor: %providerName
Bundle-ClassPath: .
Bundle-Version: 1.2.0.qualifier
diff --git a/plugins/developer/org.eclipse.papyrus.dev.assistants.codegen/.project b/plugins/developer/org.eclipse.papyrus.dev.assistants.codegen/.project
index 0f4baa86bfe..3aa1fd0795f 100644
--- a/plugins/developer/org.eclipse.papyrus.dev.assistants.codegen/.project
+++ b/plugins/developer/org.eclipse.papyrus.dev.assistants.codegen/.project
@@ -21,8 +21,20 @@
</arguments>
</buildCommand>
<buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
<arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>release.path</key>
+ <value>/org.eclipse.papyrus.releng.dev.release/release.xml</value>
+ </dictionary>
</arguments>
</buildCommand>
</buildSpec>
@@ -30,5 +42,6 @@
<nature>org.eclipse.pde.PluginNature</nature>
<nature>org.eclipse.jdt.core.javanature</nature>
<nature>org.eclipse.xtext.ui.shared.xtextNature</nature>
+ <nature>org.eclipse.oomph.version.VersionNature</nature>
</natures>
</projectDescription>
diff --git a/plugins/developer/org.eclipse.papyrus.dev.assistants.codegen/META-INF/MANIFEST.MF b/plugins/developer/org.eclipse.papyrus.dev.assistants.codegen/META-INF/MANIFEST.MF
index bc0d0de5aa9..2bb63750a93 100644
--- a/plugins/developer/org.eclipse.papyrus.dev.assistants.codegen/META-INF/MANIFEST.MF
+++ b/plugins/developer/org.eclipse.papyrus.dev.assistants.codegen/META-INF/MANIFEST.MF
@@ -1,31 +1,16 @@
-Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.uml2.uml;bundle-version="5.0.0",
- org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.7.0",
- org.eclipse.papyrus.infra.types.core;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.core;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
- com.google.guava;bundle-version="11.0.0",
- com.google.inject;bundle-version="3.0.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.8.0",
- org.eclipse.xtend.lib;bundle-version="2.8.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.8.0",
- org.eclipse.ui.workbench;bundle-version="3.107.0",
- org.eclipse.ui.ide;bundle-version="3.10.100",
- org.eclipse.papyrus.infra.gmfdiag.assistant;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.profile.assistants.generator;bundle-version="1.2.0",
- org.eclipse.papyrus.uml.profile.types.generator;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.emf;bundle-version="1.2.0",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.8.0",
- org.eclipse.gmf.codegen;bundle-version="2.11.0"
-Bundle-Vendor: %providerName
-Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.0.qualifier
-Bundle-Name: %pluginName
-Bundle-Localization: plugin
-Bundle-ManifestVersion: 2
-Bundle-Activator: org.eclipse.papyrus.dev.assistants.codegen.internal.Activator
-Bundle-Description: %description
-Bundle-SymbolicName: org.eclipse.papyrus.dev.assistants.codegen;singleton:=true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.7
+Manifest-Version: 1.0
+Require-Bundle: com.google.inject;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.xtend.lib;bundle-version="[2.10.0,3.0.0)",
+ org.eclipse.papyrus.uml.profile.assistants.generator;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.gmf.codegen;bundle-version="[2.11.0,3.0.0)"
+Bundle-Vendor: %providerName
+Bundle-ActivationPolicy: lazy
+Bundle-Version: 1.2.0.qualifier
+Bundle-Name: %pluginName
+Bundle-Localization: plugin
+Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.dev.assistants.codegen.internal.Activator
+Bundle-Description: %description
+Bundle-SymbolicName: org.eclipse.papyrus.dev.assistants.codegen;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/.classpath b/plugins/developer/org.eclipse.papyrus.dev.project.management/.classpath
index 64c5e31b7a2..eca7bdba8f0 100644
--- a/plugins/developer/org.eclipse.papyrus.dev.project.management/.classpath
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/.project b/plugins/developer/org.eclipse.papyrus.dev.project.management/.project
index f7bd68fe1d4..7aec7f23e53 100644
--- a/plugins/developer/org.eclipse.papyrus.dev.project.management/.project
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/.project
@@ -16,13 +16,26 @@
</arguments>
</buildCommand>
<buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
<arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>release.path</key>
+ <value>/org.eclipse.papyrus.releng.dev.release/release.xml</value>
+ </dictionary>
</arguments>
</buildCommand>
</buildSpec>
<natures>
<nature>org.eclipse.pde.PluginNature</nature>
<nature>org.eclipse.jdt.core.javanature</nature>
+ <nature>org.eclipse.oomph.version.VersionNature</nature>
</natures>
</projectDescription>
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/.settings/org.eclipse.jdt.core.prefs b/plugins/developer/org.eclipse.papyrus.dev.project.management/.settings/org.eclipse.jdt.core.prefs
index c585cc455ae..b3aa6d60f94 100644
--- a/plugins/developer/org.eclipse.papyrus.dev.project.management/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/.settings/org.eclipse.jdt.core.prefs
@@ -1,10 +1,10 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
org.eclipse.jdt.core.formatter.align_type_members_on_columns=false
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_allocation_expression=16
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_annotation=0
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/META-INF/MANIFEST.MF b/plugins/developer/org.eclipse.papyrus.dev.project.management/META-INF/MANIFEST.MF
index 31ac5c90774..d9d0c94d5a8 100644
--- a/plugins/developer/org.eclipse.papyrus.dev.project.management/META-INF/MANIFEST.MF
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/META-INF/MANIFEST.MF
@@ -1,17 +1,22 @@
-Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.core.commands,
- org.eclipse.core.resources;bundle-version="3.8.0",
- org.eclipse.papyrus.eclipse.project.editors;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
- org.eclipse.pde.ui,
- org.eclipse.ui.ide;bundle-version="3.10.0"
-Bundle-Vendor: %Bundle-Vendor
-Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.0.qualifier
-Bundle-Name: %Bundle-Name
-Bundle-ManifestVersion: 2
-Bundle-Activator: org.eclipse.papyrus.dev.project.management.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.dev.project.management;singleton:=true
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Manifest-Version: 1.0
+Require-Bundle: org.eclipse.ui;bundle-version="[3.107.0,4.0.0)",
+ org.eclipse.core.resources;bundle-version="[3.11.0,4.0.0)";visibility:=reexport,
+ org.eclipse.papyrus.eclipse.project.editors;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.tools;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.pde.ui;bundle-version="[3.9.0,4.0.0)",
+ org.eclipse.ui.ide;bundle-version="[3.12.0,4.0.0)";visibility:=reexport
+Bundle-Vendor: %Bundle-Vendor
+Bundle-ActivationPolicy: lazy
+Bundle-Version: 1.2.0.qualifier
+Bundle-Name: %Bundle-Name
+Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.dev.project.management.Activator
+Bundle-SymbolicName: org.eclipse.papyrus.dev.project.management;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
+Export-Package: org.eclipse.papyrus.dev.project.management,
+ org.eclipse.papyrus.dev.project.management.dialog,
+ org.eclipse.papyrus.dev.project.management.handlers,
+ org.eclipse.papyrus.dev.project.management.handlers.features,
+ org.eclipse.papyrus.dev.project.management.handlers.plugins,
+ org.eclipse.papyrus.dev.project.management.internal.operations;x-internal:=true,
+ org.eclipse.papyrus.dev.project.management.utils
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/plugin.xml b/plugins/developer/org.eclipse.papyrus.dev.project.management/plugin.xml
index c56c5431a7a..a48f8b8effd 100644
--- a/plugins/developer/org.eclipse.papyrus.dev.project.management/plugin.xml
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/plugin.xml
@@ -4,24 +4,6 @@
<extension
point="org.eclipse.ui.commands">
<command
- defaultHandler="org.eclipse.papyrus.dev.project.management.handlers.plugins.ChangePluginVersionHandler"
- description="Change Plugin Version"
- id="org.eclipse.papyrus.dev.project.management.command.plugin.change.version"
- name="Change Plugin Version">
- </command>
- <command
- defaultHandler="org.eclipse.papyrus.dev.project.management.handlers.features.ChangeFeatureVersionHandler"
- description="Change Feature Version"
- id="org.eclipse.papyrus.dev.project.management.command.feature.change.version"
- name="Change Feature Version">
- </command>
- <command
- defaultHandler="org.eclipse.papyrus.dev.project.management.handlers.plugins.ChangeDependencyVersionNumberHandler"
- description="Change Dependencies Version"
- id="org.eclipse.papyrus.dev.project.management.command.plugin.change.dependency.version"
- name="Change Dependencies Version">
- </command>
- <command
defaultHandler="org.eclipse.papyrus.dev.project.management.handlers.plugins.AddProjectAboutFileHandler"
id="org.eclipse.papyrus.dev.project.management.command.plugin.add.about"
name="Add the file about.html to the project">
@@ -45,9 +27,22 @@
name="Set Feature Copyright">
</command>
<command
- defaultHandler="org.eclipse.papyrus.dev.project.management.handlers.features.ExternalizeFeatureStringHandler"
- id="org.eclipse.papyrus.dev.project.management.command.feature.externalize"
- name="Externalize String for Feature">
+ defaultHandler="org.eclipse.papyrus.dev.project.management.handlers.plugins.UpdateDependencyRangesHandler"
+ description="Update bundle/package dependency ranges according to the current PDE target"
+ id="org.eclipse.papyrus.dev.project.management.command.updateDependencyRanges"
+ name="Update Dependency Ranges">
+ </command>
+ <command
+ defaultHandler="org.eclipse.papyrus.dev.project.management.handlers.plugins.OptimizeDependenciesHandler"
+ description="Optimize bundle dependencies by removing redundancies and adding re-exports to cover the API"
+ id="org.eclipse.papyrus.dev.project.management.command.optimizeDependencies"
+ name="Optimize Bundle Dependencies">
+ </command>
+ <command
+ defaultHandler="org.eclipse.papyrus.dev.project.management.handlers.SyncManifestAndPOMVersions"
+ description="Ensure that POM versions match their plug-in/feature manifest"
+ id="org.eclipse.papyrus.dev.project.management.command.syncPOMVersions"
+ name="Synchronize POM Versions">
</command>
</extension>
<extension
@@ -74,22 +69,11 @@
style="push">
</command>
<command
- commandId="org.eclipse.papyrus.dev.project.management.command.feature.change.version"
- icon="icons/version.png"
- label="Change Feature Version (no undo)"
- style="push">
- </command>
- <command
commandId="org.eclipse.papyrus.dev.project.management.command.feature.set.copyright"
icon="icons/copyright_icon.png"
label="Set Copyright (doesn&apos;t erase existing value)"
style="push">
</command>
- <command
- commandId="org.eclipse.papyrus.dev.project.management.command.feature.externalize"
- label="Externalize String"
- style="push">
- </command>
</menu>
<menu
icon="icons/plugin_obj.gif"
@@ -100,21 +84,64 @@
label="Add about.html file (no undo)"
style="push">
</command>
- <command
- commandId="org.eclipse.papyrus.dev.project.management.command.plugin.change.dependency.version"
- icon="icons/plugin_mf_obj.gif"
- label="Change Dependencies Versions (no undo)"
- style="push">
- </command>
- <command
- commandId="org.eclipse.papyrus.dev.project.management.command.plugin.change.version"
- icon="icons/version.png"
- label="Change Plugin Version (no undo)"
- style="push">
- </command>
</menu>
+ <command
+ commandId="org.eclipse.papyrus.dev.project.management.command.syncPOMVersions"
+ icon="icons/version.png"
+ label="Synchronize POM Versions (no undo)"
+ style="push">
+ </command>
</menu>
</menuContribution>
+ <menuContribution
+ locationURI="popup:org.eclipse.pde.ui.tools?after=additions">
+ <command
+ commandId="org.eclipse.papyrus.dev.project.management.command.updateDependencyRanges"
+ icon="icons/version.png">
+ <visibleWhen
+ checkEnabled="false">
+ <iterate>
+ <reference
+ definitionId="org.eclipse.papyrus.dev.project.management.isPluginProjectOrManifest">
+ </reference>
+ </iterate>
+ </visibleWhen>
+ </command>
+ <command
+ commandId="org.eclipse.papyrus.dev.project.management.command.optimizeDependencies"
+ icon="icons/plugin_mf_obj.gif">
+ <visibleWhen
+ checkEnabled="false">
+ <iterate>
+ <reference
+ definitionId="org.eclipse.papyrus.dev.project.management.isPluginProjectOrManifest">
+ </reference>
+ </iterate>
+ </visibleWhen>
+ </command>
+ </menuContribution>
</extension>
+ <extension
+ point="org.eclipse.core.expressions.definitions">
+ <definition
+ id="org.eclipse.papyrus.dev.project.management.isPluginProjectOrManifest">
+ <or>
+ <adapt
+ type="org.eclipse.core.resources.IFile">
+ <test
+ property="org.eclipse.core.resources.name"
+ value="MANIFEST.MF">
+ </test>
+ </adapt>
+ <adapt
+ type="org.eclipse.core.resources.IProject">
+ <test
+ property="org.eclipse.core.resources.projectNature"
+ value="org.eclipse.pde.PluginNature">
+ </test>
+ </adapt>
+ </or>
+ </definition>
+ </extension>
</plugin>
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/AbstractChangeProjectVersionHandler.java b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/AbstractChangeProjectVersionHandler.java
deleted file mode 100644
index b55ad7cf452..00000000000
--- a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/AbstractChangeProjectVersionHandler.java
+++ /dev/null
@@ -1,129 +0,0 @@
-package org.eclipse.papyrus.dev.project.management.handlers;
-
-import java.lang.reflect.InvocationTargetException;
-
-import org.eclipse.core.commands.AbstractHandler;
-import org.eclipse.core.commands.ExecutionEvent;
-import org.eclipse.core.commands.ExecutionException;
-import org.eclipse.core.resources.IProject;
-import org.eclipse.core.resources.ResourcesPlugin;
-import org.eclipse.core.runtime.CoreException;
-import org.eclipse.core.runtime.IProgressMonitor;
-import org.eclipse.core.runtime.IStatus;
-import org.eclipse.core.runtime.Status;
-import org.eclipse.jface.dialogs.IInputValidator;
-import org.eclipse.jface.window.Window;
-import org.eclipse.osgi.util.NLS;
-import org.eclipse.papyrus.dev.project.management.Activator;
-import org.eclipse.papyrus.dev.project.management.dialog.InputDialogWithCheckBox;
-import org.eclipse.swt.widgets.Display;
-import org.eclipse.ui.PlatformUI;
-import org.eclipse.ui.actions.WorkspaceModifyOperation;
-import org.eclipse.ui.progress.IProgressService;
-import org.eclipse.ui.statushandlers.StatusManager;
-
-
-public abstract class AbstractChangeProjectVersionHandler extends AbstractHandler {
-
- private static final String TITLE = "Enter the new version number for Papyrus plugin.";
-
- private static final String MESSAGE = "Enter the new version number.";
-
- private static final String INITIAL_VALUE = "0.0.0.qualifier";
-
- private static final String CHECKBOX_MESSAGE = "Only projects beginning with 'org.eclipse.papyrus.*'";
-
- private static final String WARNING_DIALOG_TITLE = "Change Version Name Report";
-
- private static final String WARNING_DIALOG_MESSAGE = "The following project were NOT managed : ";
-
- private static final String WARNING_DIALOG_MESSAGE2 = "Done.";
-
- private static final String PAPYRUS_NAME = "org.eclipse.papyrus";
-
-
- public Object execute(final ExecutionEvent event) throws ExecutionException {
-
- final IInputValidator validator = new IInputValidator() {
-
- public String isValid(final String newText) {
- final boolean match = newText.matches("[0-9]+\\.[0-9]+\\.[0-9]+\\.qualifier");
- if(!match) {
- return NLS.bind("The version number should be : something like this : {0}.", INITIAL_VALUE);
- }
- return null;
- }
- };
-
-
- final InputDialogWithCheckBox dialog = new InputDialogWithCheckBox(Display.getCurrent().getActiveShell(), TITLE, MESSAGE, INITIAL_VALUE, CHECKBOX_MESSAGE, true, validator);
- if(dialog.open() == Window.OK) {
- WorkspaceModifyOperation workspaceOperation = new WorkspaceModifyOperation(){
- protected void execute(IProgressMonitor monitor) throws CoreException ,InvocationTargetException ,InterruptedException {
- IStatus result = runAsJob(dialog.getValue(), dialog.isChecked(), monitor);
- StatusManager.getManager().handle(result, StatusManager.SHOW);
- }
- };
-
- try {
- IProgressService service = PlatformUI.getWorkbench().getProgressService();
- service.run(true, true, workspaceOperation);
- } catch (InvocationTargetException e) {
- Activator.log.error(e);
- } catch (InterruptedException e) {
- Activator.log.error(e);
- }
-
- }
-
- return null;
- }
-
- protected IStatus runAsJob(final String newVersion, final boolean papyrusProjectsOnly, IProgressMonitor monitor) {
- String notManagedProjectNames = "";
- final IProject[] projects = ResourcesPlugin.getWorkspace().getRoot().getProjects();
-
- monitor.beginTask("Update version numbers", projects.length);
-
- for(final IProject current : projects) {
-
- if (monitor.isCanceled()){
- return new Status(IStatus.CANCEL, Activator.PLUGIN_ID, "Operation canceled");
- }
-
- final String name = current.getName();
- if(papyrusProjectsOnly) {
- if(name.startsWith(PAPYRUS_NAME)) {//we test the project name
- setVersionNumber(current, newVersion, notManagedProjectNames);
- } else {
- notManagedProjectNames += NLS.bind("- {0} \n", current.getName());
- }
- } else {
- setVersionNumber(current, newVersion, notManagedProjectNames);
- }
-
- monitor.worked(1);
- }
-
- if ("".equals(notManagedProjectNames)){
- return Status.OK_STATUS;
- } else {
- return new Status(IStatus.WARNING, Activator.PLUGIN_ID, WARNING_DIALOG_MESSAGE + "\n" + notManagedProjectNames);
- }
-
- }
-
- /**
- *
- * @param project
- * the project to manage
- * @param newVersion
- * the new version for the project
- * @param notManagedProjectNames
- * a String used to build the message with the not managed projects
- */
- protected abstract void setVersionNumber(final IProject project, final String newVersion, String notManagedProjectNames);
-
-
-
-}
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/SyncManifestAndPOMVersions.java b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/SyncManifestAndPOMVersions.java
new file mode 100644
index 00000000000..8c1a3aa7e19
--- /dev/null
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/SyncManifestAndPOMVersions.java
@@ -0,0 +1,271 @@
+/*****************************************************************************
+ * Copyright (c) 2016 Christian W. Damus and others.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Christian W. Damus - Initial API and implementation
+ *
+ *****************************************************************************/
+
+package org.eclipse.papyrus.dev.project.management.handlers;
+
+import java.io.BufferedReader;
+import java.io.ByteArrayInputStream;
+import java.io.IOException;
+import java.io.InputStream;
+import java.io.InputStreamReader;
+import java.io.StringWriter;
+import java.nio.CharBuffer;
+import java.nio.charset.Charset;
+import java.util.Arrays;
+import java.util.HashMap;
+import java.util.List;
+import java.util.Map;
+import java.util.regex.Matcher;
+import java.util.regex.Pattern;
+import java.util.stream.Stream;
+
+import javax.xml.parsers.DocumentBuilder;
+import javax.xml.parsers.DocumentBuilderFactory;
+import javax.xml.transform.OutputKeys;
+import javax.xml.transform.Result;
+import javax.xml.transform.Transformer;
+import javax.xml.transform.TransformerFactory;
+import javax.xml.transform.dom.DOMSource;
+import javax.xml.transform.stream.StreamResult;
+
+import org.eclipse.core.commands.AbstractHandler;
+import org.eclipse.core.commands.ExecutionEvent;
+import org.eclipse.core.commands.ExecutionException;
+import org.eclipse.core.resources.IFile;
+import org.eclipse.core.resources.IProject;
+import org.eclipse.core.resources.IProjectDescription;
+import org.eclipse.core.resources.ResourcesPlugin;
+import org.eclipse.core.runtime.CoreException;
+import org.eclipse.core.runtime.IProgressMonitor;
+import org.eclipse.core.runtime.IStatus;
+import org.eclipse.core.runtime.OperationCanceledException;
+import org.eclipse.core.runtime.Status;
+import org.eclipse.core.runtime.SubMonitor;
+import org.eclipse.core.runtime.jobs.ISchedulingRule;
+import org.eclipse.core.runtime.jobs.Job;
+import org.eclipse.core.runtime.jobs.MultiRule;
+import org.eclipse.papyrus.dev.project.management.Activator;
+import org.eclipse.ui.IWorkbenchWindow;
+import org.eclipse.ui.handlers.HandlerUtil;
+import org.eclipse.ui.progress.IProgressService;
+import org.eclipse.ui.statushandlers.StatusManager;
+import org.w3c.dom.Document;
+import org.w3c.dom.Element;
+import org.w3c.dom.Node;
+import org.w3c.dom.NodeList;
+
+/**
+ * Ensures that <tt>pom.xml</tt> files have the same version number as their
+ * corresponding <tt>MANIFEST.MF</tt> or <tt>feature.xml</tt> file.
+ */
+public class SyncManifestAndPOMVersions extends AbstractHandler {
+ private static final Pattern BUNDLE_VERSION = Pattern.compile("^Bundle-Version:\\s*(\\S+)\\s*$", Pattern.MULTILINE); //$NON-NLS-1$
+ private static final Pattern POM_FIXUP = Pattern.compile("^(<\\?xml\\s.*?\\?>)\\s*(<project>)\\s*$", Pattern.MULTILINE);
+
+ public SyncManifestAndPOMVersions() {
+ super();
+ }
+
+ @Override
+ public Object execute(ExecutionEvent event) throws ExecutionException {
+ Map<IFile, IFile> pomsByManifest = getAllPOMsByManifest();
+
+ ISchedulingRule[] rules = Stream.concat(
+ pomsByManifest.keySet().stream(),
+ pomsByManifest.values().stream()).toArray(ISchedulingRule[]::new);
+ MultiRule jobRule = new MultiRule(rules);
+
+ Job updateJob = new Job("Synchronize POM versions") {
+
+ {
+ setRule(jobRule);
+ }
+
+ @Override
+ protected IStatus run(IProgressMonitor monitor) {
+ SubMonitor sub = SubMonitor.convert(monitor, "Updating POMs...", pomsByManifest.size());
+
+ pomsByManifest.forEach((manifest, pom) -> {
+ try {
+ if (sub.isCanceled()) {
+ throw new OperationCanceledException();
+ }
+
+ String version = getVersion(manifest);
+ if (version != null) {
+ version = version.replace(".qualifier", "-SNAPSHOT"); //$NON-NLS-1$//$NON-NLS-2$
+ Document xml = slurpXML(pom);
+ Element versionElement = findVersion(xml);
+ if (versionElement != null) {
+ if (!version.equals(versionElement.getTextContent())) {
+ versionElement.setTextContent(version);
+ write(xml, pom);
+ }
+ }
+ }
+
+ sub.worked(1);
+ } catch (CoreException e) {
+ StatusManager.getManager().handle(e.getStatus(), StatusManager.SHOW);
+ }
+ });
+
+ sub.done();
+
+ return Status.OK_STATUS;
+ }
+ };
+ updateJob.schedule();
+
+ IWorkbenchWindow window = HandlerUtil.getActiveWorkbenchWindow(event);
+ IProgressService progress = window.getWorkbench().getProgressService();
+ progress.showInDialog(window.getShell(), updateJob);
+
+ return null;
+ }
+
+ Map<IFile, IFile> getAllPOMsByManifest() {
+ Map<IFile, IFile> result = new HashMap<>();
+
+ Stream.of(ResourcesPlugin.getWorkspace().getRoot().getProjects())
+ .filter(this::hasPluginOrFeatureNature)
+ .forEach(project -> {
+ IFile pom = project.getFile("pom.xml"); //$NON-NLS-1$
+ if (pom != null) {
+ IFile manifest = project.getFile("feature.xml");
+ if (!manifest.isAccessible()) {
+ manifest = project.getFile("META-INF/MANIFEST.MF");
+ }
+
+ if (manifest.isAccessible()) {
+ result.put(manifest, pom);
+ }
+ }
+ });
+
+ return result;
+ }
+
+ String slurpText(IFile file) throws CoreException {
+ StringBuilder result = new StringBuilder();
+ CharBuffer buf = CharBuffer.allocate(4096);
+
+ try (BufferedReader reader = new BufferedReader(new InputStreamReader(file.getContents(), Charset.forName(file.getCharset())))) {
+ for (;;) {
+ if (reader.read(buf) < 0) {
+ break; // Done
+ }
+ buf.flip();
+ result.append(buf);
+ buf.rewind();
+ }
+ } catch (IOException e) {
+ throw new CoreException(new Status(IStatus.ERROR, Activator.PLUGIN_ID, "Failed to read manifest", e));
+ }
+
+ return result.toString();
+ }
+
+ Document slurpXML(IFile xmlFile) throws CoreException {
+ try {
+ DocumentBuilder builder = DocumentBuilderFactory.newInstance().newDocumentBuilder();
+ try (InputStream input = xmlFile.getContents()) {
+ return builder.parse(input);
+ }
+ } catch (Exception e) {
+ throw new CoreException(new Status(IStatus.ERROR, Activator.PLUGIN_ID, "Failed to read manifest file", e)); //$NON-NLS-1$
+ }
+ }
+
+ void write(Document xml, IFile xmlFile) throws CoreException {
+ try (StringWriter writer = new StringWriter()) {
+ Transformer transformer = TransformerFactory.newInstance().newTransformer();
+
+ transformer.setOutputProperty(OutputKeys.ENCODING, "UTF-8"); //$NON-NLS-1$
+ xml.setXmlStandalone(true);
+ xml.setXmlVersion("1.0");
+
+ Result result = new StreamResult(writer);
+ transformer.transform(new DOMSource(xml), result);
+ String text = writer.toString();
+
+ // Fix up the transformer's sometime failure to put a newline after the XML declaration
+ Matcher fixup = POM_FIXUP.matcher(text);
+ if (fixup.find()) {
+ StringBuffer fixed = new StringBuffer(text.length() + 2);
+ fixup.appendReplacement(fixed, fixup.group(1) + '\n' + fixup.group(2));
+ fixup.appendTail(fixed);
+ text = fixed.toString();
+ }
+
+ // Write it out
+ ByteArrayInputStream input = new ByteArrayInputStream(text.getBytes(Charset.forName("UTF-8"))); //$NON-NLS-1$
+ xmlFile.setContents(input, false, true, null);
+ } catch (Exception e) {
+ throw new CoreException(new Status(IStatus.ERROR, Activator.PLUGIN_ID, "Failed to update POM", e));
+ }
+ }
+
+ String getVersion(IFile manifest) throws CoreException {
+ String result = null;
+
+ switch (manifest.getName()) {
+ case "MANIFEST.MF": //$NON-NLS-1$
+ String text = slurpText(manifest);
+ Matcher m = BUNDLE_VERSION.matcher(text);
+ if (m.find()) {
+ result = m.group(1);
+ }
+ break;
+ case "feature.xml": //$NON-NLS-1$
+ Document xml = slurpXML(manifest);
+ result = xml.getDocumentElement().getAttribute("version"); //$NON-NLS-1$
+ }
+
+ return result;
+ }
+
+ Element findVersion(Document pom) {
+ Element project = pom.getDocumentElement();
+ return stream(project.getChildNodes())
+ .filter(n -> "version".equals(n.getNodeName()))
+ .filter(Element.class::isInstance).map(Element.class::cast)
+ .findFirst().orElse(null);
+ }
+
+ Stream<Node> stream(NodeList nodes) {
+ Stream.Builder<Node> result = Stream.builder();
+ for (int i = 0; i < nodes.getLength(); i++) {
+ result.add(nodes.item(i));
+ }
+ return result.build();
+ }
+
+ boolean hasPluginOrFeatureNature(IProject project) {
+ boolean result = false;
+
+ if (project.isAccessible()) {
+ try {
+ IProjectDescription desc = project.getDescription();
+ List<String> natures = Arrays.asList(desc.getNatureIds());
+ result = natures.contains("org.eclipse.pde.PluginNature") //$NON-NLS-1$
+ || natures.contains("org.eclipse.pde.FeatureNature"); //$NON-NLS-1$
+ } catch (CoreException e) {
+ // Guess it's not an interesting project
+ Activator.log.log(e.getStatus());
+ }
+ }
+
+ return result;
+ }
+}
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/features/ChangeFeatureVersionHandler.java b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/features/ChangeFeatureVersionHandler.java
deleted file mode 100644
index f87c81754da..00000000000
--- a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/features/ChangeFeatureVersionHandler.java
+++ /dev/null
@@ -1,59 +0,0 @@
-package org.eclipse.papyrus.dev.project.management.handlers.features;
-
-import java.io.IOException;
-
-import javax.xml.parsers.ParserConfigurationException;
-
-import org.eclipse.core.resources.IProject;
-import org.eclipse.core.runtime.CoreException;
-import org.eclipse.osgi.util.NLS;
-import org.eclipse.papyrus.dev.project.management.Activator;
-import org.eclipse.papyrus.dev.project.management.handlers.AbstractChangeProjectVersionHandler;
-import org.eclipse.papyrus.dev.project.management.utils.Utils;
-import org.eclipse.papyrus.eclipse.project.editors.interfaces.IFeatureProjectEditor;
-import org.eclipse.papyrus.eclipse.project.editors.project.FeatureProjectEditor;
-import org.xml.sax.SAXException;
-
-
-public class ChangeFeatureVersionHandler extends AbstractChangeProjectVersionHandler {
-
-
- @Override
- protected void setVersionNumber(final IProject project, final String newVersion, String notManagedProjectNames) {
- if (project.isOpen()) {
- try {
- if (project.hasNature(Utils.FEATURE_NATURE)) {// for features
- try {
- final IFeatureProjectEditor editor = new FeatureProjectEditor(project);
- editor.init();
- // This test is necessary to bypass the plugins tagged 0.*.*
- if (editor.getVersion().matches("[1-9]+\\.[0-9]+\\.[0-9]+\\.qualifier")) {
- editor.setVersion(newVersion);
- editor.save();
- }
- } catch (final ParserConfigurationException e) {
- Activator.log.error(e);
- notManagedProjectNames += NLS.bind("- {0} \n", project.getName());
- } catch (final SAXException e) {
- Activator.log.error(e);
- notManagedProjectNames += NLS.bind("- {0} \n", project.getName());
- } catch (final IOException e) {
- Activator.log.error(e);
- notManagedProjectNames += NLS.bind("- {0} \n", project.getName());
- } catch (final Throwable e) {
- Activator.log.error(e);
- notManagedProjectNames += NLS.bind("- {0} \n", project.getName());
- }
-
- } else {
- notManagedProjectNames += NLS.bind("- {0} \n", project.getName());
- }
- } catch (final CoreException e) {
- Activator.log.error(e);
- }
- } else {
- notManagedProjectNames += NLS.bind("- {0} \n", project.getName());
- }
- }
-
-}
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/AbstractManifestUpdateHandler.java b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/AbstractManifestUpdateHandler.java
new file mode 100644
index 00000000000..4ff98fe50fc
--- /dev/null
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/AbstractManifestUpdateHandler.java
@@ -0,0 +1,140 @@
+/*****************************************************************************
+ * Copyright (c) 2016 Christian W. Damus and others.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Christian W. Damus - Initial API and implementation
+ *
+ *****************************************************************************/
+
+package org.eclipse.papyrus.dev.project.management.handlers.plugins;
+
+import java.lang.reflect.InvocationTargetException;
+import java.util.Collection;
+import java.util.HashMap;
+import java.util.List;
+import java.util.Map;
+import java.util.Objects;
+import java.util.stream.Collectors;
+import java.util.stream.Stream;
+
+import org.eclipse.core.commands.AbstractHandler;
+import org.eclipse.core.commands.ExecutionEvent;
+import org.eclipse.core.commands.ExecutionException;
+import org.eclipse.core.commands.operations.IOperationHistory;
+import org.eclipse.core.commands.operations.IUndoableOperation;
+import org.eclipse.core.resources.IFile;
+import org.eclipse.core.resources.IResource;
+import org.eclipse.core.runtime.CoreException;
+import org.eclipse.core.runtime.IAdaptable;
+import org.eclipse.core.runtime.IProgressMonitor;
+import org.eclipse.core.runtime.Path;
+import org.eclipse.jface.operation.IRunnableWithProgress;
+import org.eclipse.jface.viewers.IStructuredSelection;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IManifestEditor;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.ProjectEditors;
+import org.eclipse.ui.IWorkbench;
+import org.eclipse.ui.IWorkbenchWindow;
+import org.eclipse.ui.actions.WorkspaceModifyDelegatingOperation;
+import org.eclipse.ui.handlers.HandlerUtil;
+import org.eclipse.ui.operations.IWorkbenchOperationSupport;
+import org.eclipse.ui.progress.IProgressService;
+
+/**
+ * Handler for the "update dependency ranges" command, which updates all dependencies
+ * in the selected <tt.MANIFEST.MF</tt> file(s) to be version ranges lower-bounded
+ * by the current PDE Target version, except for certain 3rd-party Orbit bundles
+ * (such as Guava, ICU4J) that are known to increase major versions frequently without
+ * breaking compatibility.
+ */
+abstract class AbstractManifestUpdateHandler extends AbstractHandler {
+
+ public AbstractManifestUpdateHandler() {
+ super();
+ }
+
+ protected abstract IUndoableOperation createUpdateOperation(Map<? extends IFile, ? extends IManifestEditor> manifests);
+
+ @Override
+ public Object execute(ExecutionEvent event) throws ExecutionException {
+ List<IFile> manifests = Stream.of(((IStructuredSelection) HandlerUtil.getCurrentSelection(event)).toArray())
+ .map(this::getManifestFile)
+ .filter(Objects::nonNull)
+ .filter(IResource::isAccessible)
+ .distinct()
+ .collect(Collectors.toList());
+
+ Map<IFile, IManifestEditor> editors = new HashMap<>();
+ try {
+ getEditors(manifests, editors);
+ } catch (CoreException e) {
+ throw new ExecutionException("Failed to open manifest(s) for editing", e);
+ }
+
+ IWorkbenchWindow window = HandlerUtil.getActiveWorkbenchWindow(event);
+ IWorkbench workbench = window.getWorkbench();
+ IWorkbenchOperationSupport support = workbench.getOperationSupport();
+
+ IUndoableOperation operation = createUpdateOperation(editors);
+ IOperationHistory history = support.getOperationHistory();
+ operation.addContext(support.getUndoContext());
+
+ IProgressService progress = workbench.getProgressService();
+
+ try {
+ IRunnableWithProgress run = new IRunnableWithProgress() {
+
+ @Override
+ public void run(IProgressMonitor monitor) throws InvocationTargetException, InterruptedException {
+ try {
+ history.execute(operation, monitor, null);
+
+ // Save the manifests
+ for (IManifestEditor next : editors.values()) {
+ if (next.isDirty()) {
+ next.save();
+ }
+ }
+ } catch (ExecutionException e) {
+ throw new InvocationTargetException(e);
+ }
+
+ }
+ };
+
+ progress.busyCursorWhile(new WorkspaceModifyDelegatingOperation(run));
+ } catch (Exception e) {
+ if (e instanceof InvocationTargetException) {
+ Throwable wrapped = ((InvocationTargetException) e).getTargetException();
+ if (wrapped instanceof ExecutionException) {
+ throw ((ExecutionException) wrapped);
+ }
+ }
+ throw new ExecutionException("Failed to execute manifest update operation", e);
+ }
+
+ return null;
+ }
+
+ private IFile getManifestFile(Object object) {
+ IFile result = (object instanceof IFile) ? (IFile) object : ((IAdaptable) object).getAdapter(IFile.class);
+ if (result == null) {
+ IResource resource = (object instanceof IResource) ? (IResource) object : ((IAdaptable) object).getAdapter(IResource.class);
+ if (resource != null) {
+ result = resource.getProject().getFile(new Path("META-INF/MANIFEST.MF"));
+ }
+ }
+
+ return result;
+ }
+
+ private void getEditors(Collection<? extends IFile> manifests, Map<? super IFile, ? super IManifestEditor> editors) throws CoreException {
+ for (IFile next : manifests) {
+ editors.put(next, ProjectEditors.getManifestEditor(next.getProject()));
+ }
+ }
+}
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/ChangeDependencyVersionNumberHandler.java b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/ChangeDependencyVersionNumberHandler.java
deleted file mode 100644
index 6b95d1b135c..00000000000
--- a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/ChangeDependencyVersionNumberHandler.java
+++ /dev/null
@@ -1,257 +0,0 @@
-package org.eclipse.papyrus.dev.project.management.handlers.plugins;
-
-import java.io.ByteArrayOutputStream;
-import java.io.IOException;
-import java.io.InputStream;
-import java.io.StringReader;
-import java.lang.reflect.InvocationTargetException;
-import java.util.concurrent.atomic.AtomicReference;
-import java.util.jar.Manifest;
-import java.util.jar.Attributes.Name;
-
-import org.eclipse.core.commands.AbstractHandler;
-import org.eclipse.core.commands.ExecutionEvent;
-import org.eclipse.core.commands.ExecutionException;
-import org.eclipse.core.resources.IFile;
-import org.eclipse.core.resources.IProject;
-import org.eclipse.core.resources.ResourcesPlugin;
-import org.eclipse.core.runtime.CoreException;
-import org.eclipse.core.runtime.IProgressMonitor;
-import org.eclipse.core.runtime.IStatus;
-import org.eclipse.core.runtime.Status;
-import org.eclipse.core.runtime.jobs.Job;
-import org.eclipse.jface.dialogs.IInputValidator;
-import org.eclipse.jface.dialogs.MessageDialog;
-import org.eclipse.jface.window.Window;
-import org.eclipse.osgi.util.NLS;
-import org.eclipse.papyrus.dev.project.management.Activator;
-import org.eclipse.papyrus.dev.project.management.dialog.TwoInputDialog;
-import org.eclipse.papyrus.dev.project.management.utils.Utils;
-import org.eclipse.papyrus.eclipse.project.editors.file.ManifestEditor;
-import org.eclipse.papyrus.eclipse.project.editors.interfaces.IManifestEditor;
-import org.eclipse.pde.core.project.IBundleProjectDescription;
-import org.eclipse.pde.core.project.IBundleProjectService;
-import org.eclipse.pde.core.project.IRequiredBundleDescription;
-import org.eclipse.swt.widgets.Display;
-import org.eclipse.ui.actions.WorkspaceModifyOperation;
-import org.osgi.framework.BundleContext;
-import org.osgi.framework.FrameworkUtil;
-import org.osgi.framework.ServiceReference;
-
-//TODO should be covered with JUnit test
-public class ChangeDependencyVersionNumberHandler extends AbstractHandler {
-
- private static final String TITLE = "Enter the new version number for Papyrus plugin.";
-
-
- private static final String INITIAL_VALUE = "0.0.0";
-
- private static final String WARNING_DIALOG_TITLE = "Change Version Name Report";
-
- private static final String WARNING_DIALOG_MESSAGE = "The following project were NOT managed : ";
-
- private static final String WARNING_DIALOG_MESSAGE2 = "Done.";
-
- private static final String PAPYRUS_NAME = "org.eclipse.papyrus";
-
- public Object execute(final ExecutionEvent event) throws ExecutionException {
-
- final IInputValidator validator = new IInputValidator() {
-
- public String isValid(final String newText) {
- final boolean match = newText.matches("[0-9]+\\.[0-9]+\\.[0-9]");
- if (!match) {
- return NLS.bind("The version number should be : something like this : {0}.", INITIAL_VALUE);
- }
- return null;
- }
- };
- final TwoInputDialog dialog = new TwoInputDialog(Display.getCurrent().getActiveShell(), TITLE, "Enter the new version for the Papyrus dependencies", "pattern plugin name", INITIAL_VALUE, PAPYRUS_NAME, validator);
-
- if (dialog.open() == Window.OK) {
- final String newVersion = dialog.getValue();
- final String pattern = dialog.getValue_2();
-
- Job job = new Job("Update dependency versions") {
-
- @Override
- protected IStatus run(IProgressMonitor monitor) {
-
- final AtomicReference<IStatus> result = new AtomicReference<IStatus>();
-
- WorkspaceModifyOperation operation = new WorkspaceModifyOperation() {
-
- @Override
- protected void execute(IProgressMonitor monitor) throws CoreException, InvocationTargetException, InterruptedException {
- result.set(runAsJob(newVersion, pattern, monitor));
- }
-
- };
-
- try {
- operation.run(monitor);
- } catch (InvocationTargetException e) {
- return new Status(IStatus.ERROR, Activator.PLUGIN_ID, e.getMessage());
- } catch (InterruptedException e) {
- return new Status(IStatus.ERROR, Activator.PLUGIN_ID, e.getMessage());
- }
-
- return result.get();
- }
-
- };
- job.setUser(true);
- job.schedule();
- }
- return null;
- }
-
- protected IStatus runAsJob(final String newVersion, final String pattern, IProgressMonitor monitor) {
- String notManagedProjectNames = "";
-
- final IProject[] projects = ResourcesPlugin.getWorkspace().getRoot().getProjects();
-
- monitor.beginTask("Update dependency versions", projects.length);
-
- for (final IProject current : projects) {
- final String name = current.getName();
-
- if (name.startsWith(PAPYRUS_NAME)) {// TODO : add the possibility to manage other plugins
- setVersionNumber(current, pattern, newVersion, notManagedProjectNames);
- } else {
- notManagedProjectNames += NLS.bind("- {0} \n", current.getName());
- }
-
- monitor.worked(1);
- }
-
-
- final String textResult = notManagedProjectNames;
- Display.getDefault().asyncExec(new Runnable() {
-
- public void run() {
- if (textResult.equals("")) {
- final MessageDialog informationDialog = new MessageDialog(Display.getCurrent().getActiveShell(), WARNING_DIALOG_TITLE, null, WARNING_DIALOG_MESSAGE2, MessageDialog.INFORMATION, new String[] { "OK" }, 0);
- informationDialog.open();
- } else {
- final MessageDialog informationDialog = new MessageDialog(Display.getCurrent().getActiveShell(), WARNING_DIALOG_TITLE, null, WARNING_DIALOG_MESSAGE + "\n" + textResult, MessageDialog.INFORMATION, new String[] { "OK" }, 0);
- informationDialog.open();
- }
- }
- });
-
- return Status.OK_STATUS;
- }
-
- /**
- *
- * @param project
- * the project to manage
- * @param dependencyPattern
- * the pattern used to find the dependency to update
- * @param newVersion
- * the new version for the project
- * @param notManagedProjectNames
- * a String used to build the message with the not managed projects
- */
- private void setVersionNumber(final IProject project, final String dependencyPattern, final String newValue, String notManagedProjectNames) {
- if (project.isOpen()) {
- try {
- final boolean pluginnature = project.hasNature(Utils.PLUGIN_NATURE);
- if (pluginnature) {
- try {
- MyManifestEditor editor = new MyManifestEditor(project);
- editor.init();
- editor.setDependenciesVersion(dependencyPattern, newValue);
- editor.save();
- } catch (final IOException e) {
- Activator.log.error(e);
- notManagedProjectNames += NLS.bind("- {0} \n", project.getName());
- } catch (final Throwable e) {
- Activator.log.error(e);
- notManagedProjectNames += NLS.bind("- {0} \n", project.getName());
- }
-
- }
- } catch (final CoreException e) {
- Activator.log.error(e);
- }
- } else {
- notManagedProjectNames += NLS.bind("- {0} \n", project.getName());
- }
- }
-
-
- private class MyManifestEditor extends ManifestEditor {
-
- private static final String SEMICOLON = ";"; //$NON-NLS-1$
-
- private static final String COMMA = ","; //$NON-NLS-1$
-
- private static final String ASSIGN = "="; //$NON-NLS-1$
-
- private static final String BUNDLE_VERSION = "bundle-version"; //$NON-NLS-1$
-
- private static final String REQUIRED_BUNDLE = "Require-Bundle"; //$NON-NLS-1$
-
- private Manifest manifest;
-
- private IFile manifestFile;
-
- /**
- * Constructor.
- *
- * @param project
- * @throws IOException
- * @throws CoreException
- */
- public MyManifestEditor(IProject project) throws IOException, CoreException {
- super(project);
- manifestFile = project.getFile("META-INF/MANIFEST.MF");
- manifest = new Manifest(manifestFile.getContents());
- }
-
- /**
- * @see org.eclipse.papyrus.eclipse.project.editors.file.ManifestEditor#setDependenciesVersion(java.lang.String, java.lang.String)
- *
- * @param dependencyPattern
- * @param newVersion
- */
- @Override
- public void setDependenciesVersion(String dependencyPattern, String newVersion) {
- final Name rqBundle = new Name(REQUIRED_BUNDLE);
- final String requireBundles = manifest.getMainAttributes().getValue(rqBundle);
- final String[] bundles = requireBundles.split(COMMA);
- String newRequiredBundles = ""; //$NON-NLS-1$
- for (int ii = 0; ii < bundles.length; ii++) {// we iterate on the declared dependencies
- final String currentDependency = bundles[ii];
- final String[] dependencyValue = currentDependency.split(SEMICOLON);
- if (dependencyValue[0].contains(dependencyPattern)) {
- String[] test = dependencyValue[1].split("[0-9]+\\.[0-9]+\\.[0-9]");
- String oldVersion = dependencyValue[1].substring(test[0].length(), test[0].length() + 5);
- // This test is necessary to take into account the versions tagged 0.*.*
- String newBundleVersion = BUNDLE_VERSION + ASSIGN + '"' + newVersion + '"';
- if (!oldVersion.matches("[1-9]+\\.[0-9]+\\.[0-9]")) {
- newBundleVersion = BUNDLE_VERSION + ASSIGN + '"' + oldVersion + '"';
- }
- newRequiredBundles += dependencyValue[0] + SEMICOLON + newBundleVersion;
- for (int i = 1; i < dependencyValue.length; i++) {
- final String declaration = dependencyValue[i];
- if (declaration.contains(BUNDLE_VERSION + ASSIGN)) {
- // we ignore it
- } else {
- newRequiredBundles += SEMICOLON + dependencyValue[i];// we add the others declaration
- }
- }
- } else {
- newRequiredBundles += currentDependency;// we copy the existing declaration
- }
- if (ii < (bundles.length - 1)) {
- newRequiredBundles += COMMA;
- }
- }
- setValue(REQUIRED_BUNDLE, newRequiredBundles);
- }
- }
-
-}
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/ChangePluginVersionHandler.java b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/ChangePluginVersionHandler.java
deleted file mode 100644
index 223fa7a30f1..00000000000
--- a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/ChangePluginVersionHandler.java
+++ /dev/null
@@ -1,50 +0,0 @@
-package org.eclipse.papyrus.dev.project.management.handlers.plugins;
-
-import java.io.IOException;
-
-import org.eclipse.core.resources.IProject;
-import org.eclipse.core.runtime.CoreException;
-import org.eclipse.osgi.util.NLS;
-import org.eclipse.papyrus.dev.project.management.Activator;
-import org.eclipse.papyrus.dev.project.management.handlers.AbstractChangeProjectVersionHandler;
-import org.eclipse.papyrus.dev.project.management.utils.Utils;
-import org.eclipse.papyrus.eclipse.project.editors.file.ManifestEditor;
-import org.eclipse.papyrus.eclipse.project.editors.interfaces.IManifestEditor;
-
-
-public class ChangePluginVersionHandler extends AbstractChangeProjectVersionHandler {
-
-
- @Override
- protected void setVersionNumber(final IProject project, final String newVersion, String notManagedProjectNames) {
- if (project.isOpen()) {
- try {
- if (project.hasNature(Utils.PLUGIN_NATURE)) {
- try {
- final IManifestEditor editor = new ManifestEditor(project);
- editor.init();
- // This test is necessary to bypass the plugins tagged 0.*.*
- if (editor.getBundleVersion().matches("[1-9]+\\.[0-9]+\\.[0-9]+\\.qualifier")) {
- editor.setBundleVersion(newVersion);
- editor.save();
- }
- } catch (final IOException e) {
- Activator.log.error(e);
- notManagedProjectNames += NLS.bind("- {0} \n", project.getName());
- } catch (final Throwable e) {
- Activator.log.error(e);
- notManagedProjectNames += NLS.bind("- {0} \n", project.getName());
- }
-
- } else {
- notManagedProjectNames += NLS.bind("- {0} \n", project.getName());
- }
- } catch (final CoreException e) {
- Activator.log.error(e);
- }
- } else {
- notManagedProjectNames += NLS.bind("- {0} \n", project.getName());
- }
- }
-
-}
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/OptimizeDependenciesHandler.java b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/OptimizeDependenciesHandler.java
new file mode 100644
index 00000000000..d9a501e25ea
--- /dev/null
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/OptimizeDependenciesHandler.java
@@ -0,0 +1,38 @@
+/*****************************************************************************
+ * Copyright (c) 2016 Christian W. Damus and others.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Christian W. Damus - Initial API and implementation
+ *
+ *****************************************************************************/
+
+package org.eclipse.papyrus.dev.project.management.handlers.plugins;
+
+import java.util.Map;
+
+import org.eclipse.core.commands.operations.IUndoableOperation;
+import org.eclipse.core.resources.IFile;
+import org.eclipse.papyrus.dev.project.management.internal.operations.OptimizeDependenciesOperation;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IManifestEditor;
+
+/**
+ * Handler for the "optimize dependencies" command, which ensures re-exports of dependencies
+ * that contribute types to the exported API and removes redundancies (except where they are
+ * re-exported).
+ */
+public class OptimizeDependenciesHandler extends AbstractManifestUpdateHandler {
+
+ public OptimizeDependenciesHandler() {
+ super();
+ }
+
+ @Override
+ protected IUndoableOperation createUpdateOperation(Map<? extends IFile, ? extends IManifestEditor> manifests) {
+ return new OptimizeDependenciesOperation(manifests);
+ }
+}
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/UpdateDependencyRangesHandler.java b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/UpdateDependencyRangesHandler.java
new file mode 100644
index 00000000000..048ef1cc953
--- /dev/null
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/handlers/plugins/UpdateDependencyRangesHandler.java
@@ -0,0 +1,40 @@
+/*****************************************************************************
+ * Copyright (c) 2016 Christian W. Damus and others.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Christian W. Damus - Initial API and implementation
+ *
+ *****************************************************************************/
+
+package org.eclipse.papyrus.dev.project.management.handlers.plugins;
+
+import java.util.Map;
+
+import org.eclipse.core.commands.operations.IUndoableOperation;
+import org.eclipse.core.resources.IFile;
+import org.eclipse.papyrus.dev.project.management.internal.operations.UpdateDependencyRangesOperation;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IManifestEditor;
+
+/**
+ * Handler for the "update dependency ranges" command, which updates all dependencies
+ * in the selected <tt.MANIFEST.MF</tt> file(s) to be version ranges lower-bounded
+ * by the current PDE Target version, except for certain 3rd-party Orbit bundles
+ * (such as Guava, ICU4J) that are known to increase major versions frequently without
+ * breaking compatibility.
+ */
+public class UpdateDependencyRangesHandler extends AbstractManifestUpdateHandler {
+
+ public UpdateDependencyRangesHandler() {
+ super();
+ }
+
+ @Override
+ protected IUndoableOperation createUpdateOperation(Map<? extends IFile, ? extends IManifestEditor> manifests) {
+ return new UpdateDependencyRangesOperation(manifests);
+ }
+}
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/AbstractManifestUpdateOperation.java b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/AbstractManifestUpdateOperation.java
new file mode 100644
index 00000000000..a1252300016
--- /dev/null
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/AbstractManifestUpdateOperation.java
@@ -0,0 +1,68 @@
+/*****************************************************************************
+ * Copyright (c) 2016 Christian W. Damus and others.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Christian W. Damus - Initial API and implementation
+ *
+ *****************************************************************************/
+
+package org.eclipse.papyrus.dev.project.management.internal.operations;
+
+import java.util.Map;
+
+import org.eclipse.core.commands.ExecutionException;
+import org.eclipse.core.commands.operations.AbstractOperation;
+import org.eclipse.core.resources.IFile;
+import org.eclipse.core.runtime.IAdaptable;
+import org.eclipse.core.runtime.IProgressMonitor;
+import org.eclipse.core.runtime.IStatus;
+import org.eclipse.core.runtime.Status;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IManifestEditor;
+
+abstract class AbstractManifestUpdateOperation extends AbstractOperation {
+
+ private Map<? extends IFile, ? extends IManifestEditor> manifests;
+
+ public AbstractManifestUpdateOperation(String label, Map<? extends IFile, ? extends IManifestEditor> manifests) {
+ super(label);
+
+ this.manifests = manifests;
+ }
+
+ @Override
+ public final IStatus execute(IProgressMonitor monitor, IAdaptable info) throws ExecutionException {
+ try {
+ return doExecute(monitor, manifests);
+ } finally {
+ // Don't need these any longer
+ manifests = null;
+ }
+ }
+
+ protected abstract IStatus doExecute(IProgressMonitor monitor, Map<? extends IFile, ? extends IManifestEditor> manifests) throws ExecutionException;
+
+ @Override
+ public boolean canUndo() {
+ return false;
+ }
+
+ @Override
+ public IStatus undo(IProgressMonitor monitor, IAdaptable info) throws ExecutionException {
+ return Status.CANCEL_STATUS;
+ }
+
+ @Override
+ public boolean canRedo() {
+ return false;
+ }
+
+ @Override
+ public IStatus redo(IProgressMonitor monitor, IAdaptable info) throws ExecutionException {
+ return Status.CANCEL_STATUS;
+ }
+}
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/DependencyAnalysisContext.java b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/DependencyAnalysisContext.java
new file mode 100644
index 00000000000..d268b650432
--- /dev/null
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/DependencyAnalysisContext.java
@@ -0,0 +1,705 @@
+/*****************************************************************************
+ * Copyright (c) 2016 Christian W. Damus and others.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Christian W. Damus - Initial API and implementation
+ *
+ *****************************************************************************/
+
+package org.eclipse.papyrus.dev.project.management.internal.operations;
+
+import java.util.ArrayList;
+import java.util.Collection;
+import java.util.Collections;
+import java.util.Comparator;
+import java.util.Deque;
+import java.util.HashMap;
+import java.util.HashSet;
+import java.util.Iterator;
+import java.util.LinkedHashSet;
+import java.util.LinkedList;
+import java.util.List;
+import java.util.Map;
+import java.util.Objects;
+import java.util.Set;
+import java.util.TreeSet;
+import java.util.stream.Collectors;
+import java.util.stream.Stream;
+
+import org.eclipse.core.resources.IFile;
+import org.eclipse.core.resources.IProject;
+import org.eclipse.core.resources.IResource;
+import org.eclipse.core.runtime.IProgressMonitor;
+import org.eclipse.core.runtime.NullProgressMonitor;
+import org.eclipse.core.runtime.SubMonitor;
+import org.eclipse.osgi.service.resolver.BundleDescription;
+import org.eclipse.osgi.service.resolver.BundleSpecification;
+import org.eclipse.osgi.service.resolver.ExportPackageDescription;
+import org.eclipse.pde.core.plugin.IPluginModelBase;
+import org.eclipse.pde.core.plugin.PluginRegistry;
+import org.osgi.framework.VersionRange;
+
+/**
+ * A context in which bundle dependency analysis is computed. It maintains
+ * shared state for analysis of the dependencies of any number of bundles
+ * in the workspace and PDE target.
+ */
+public class DependencyAnalysisContext {
+
+ private final Map<String, BundleAnalysis> bundles = new HashMap<>();
+ private final Map<String, BundleAnalysis> packageProviders = new HashMap<>();
+
+ private final VersionRules versionRules = new VersionRules();
+
+ private final Deque<SubMonitor> monitorStack = new LinkedList<SubMonitor>();
+ private SubMonitor currentMonitor;
+
+ private final Set<BundleAnalysis> roots;
+
+ public DependencyAnalysisContext(Collection<? extends IFile> bundleManifests) {
+ super();
+
+ pushMonitor(new NullProgressMonitor());
+
+ roots = Collections.unmodifiableSet(init(bundleManifests));
+ }
+
+ private Set<BundleAnalysis> init(Collection<? extends IFile> bundleManifests) {
+ return bundleManifests.stream()
+ .map(this::getBundleID)
+ .filter(Objects::nonNull)
+ .map(this::internalGetBundle)
+ .map(BundleAnalysis::checkCycle) // Bombs the analysis if there's any dependency cycle
+ .collect(Collectors.toSet());
+ }
+
+ private String getBundleID(IFile manifest) {
+ IPluginModelBase model = PluginRegistry.findModel(manifest.getProject());
+ return (model == null) ? null : model.getPluginBase().getId();
+ }
+
+ public Set<BundleAnalysis> getAnalysisRoots() {
+ return roots;
+ }
+
+ public boolean isAnalysisRoot(String bundleID) {
+ return roots.contains(internalGetBundle(bundleID));
+ }
+
+ public BundleAnalysis getBundle(String bundleID) {
+ return internalGetBundle(bundleID).analyze();
+ }
+
+ private BundleAnalysis internalGetBundle(String bundleID) {
+ return bundles.computeIfAbsent(bundleID, BundleAnalysis::new);
+ }
+
+ public BundleAnalysis getProvidingBundle(String packageName) {
+ return packageProviders.computeIfAbsent(packageName, this::findPackageProvider);
+ }
+
+ private BundleAnalysis findPackageProvider(String packageName) {
+ // Protect against concurrent modification
+ return new ArrayList<>(bundles.values()).stream()
+ .map(BundleAnalysis::getAPIExports)
+ .filter(api -> api.exports(packageName))
+ .findAny().map(APIExports::getBundle).orElse(null);
+ }
+
+ public final void pushMonitor(IProgressMonitor monitor) {
+ currentMonitor = (monitor instanceof SubMonitor) ? (SubMonitor) monitor : SubMonitor.convert(monitor);
+ monitorStack.push(currentMonitor);
+ }
+
+ public final void popMonitor() {
+ monitorStack.pop();
+ currentMonitor = monitorStack.peek();
+ }
+
+ //
+ // Nested types
+ //
+
+ /**
+ * An analysis of the transitive dependencies (by <tt>Require-Bundle</tt>) and public
+ * API exports of a bundle. Bundles sort dependencies before dependents.
+ */
+ public class BundleAnalysis {
+ private final String bundleID;
+
+ private DependencyGraph dependencyGraph;
+ private APIExports apiExports;
+
+ private BundleAnalysis(String bundleID) {
+ super();
+
+ this.bundleID = bundleID;
+ }
+
+ public String getBundleID() {
+ return bundleID;
+ }
+
+ public BundleAnalysis checkCycle() throws IllegalStateException {
+ getDependencyGraph().checkCycle();
+ return this;
+ }
+
+ public VersionRange getCompatibleVersionRange() {
+ return getAPIExports().getCompatibleVersionRange();
+ }
+
+ public DependencyGraph getDependencyGraph() {
+ analyze();
+ return dependencyGraph;
+ }
+
+ public APIExports getAPIExports() {
+ analyze();
+ return apiExports;
+ }
+
+ public BundleAnalysis getDependency(String bundleID) {
+ return getDependencyGraph().getDependency(bundleID);
+ }
+
+ public boolean isReexported(String bundleID) {
+ return getDependencyGraph().isReexported(bundleID);
+ }
+
+ /**
+ * Queries whether I express a dependency directly on the given bundle.
+ * Equivalent to {@link #hasDependency(String, boolean) hasDependency(bundleID, false)}.
+ *
+ * @param bundleID
+ * a bundle identifier
+ * @return whether my bundle directly requires it
+ */
+ public boolean hasDependency(String bundleID) {
+ return getDependencyGraph().hasDependency(bundleID);
+ }
+
+ /**
+ * Queries whether I express a dependency directly or, optionally,
+ * indirectly on the given bundle.
+ *
+ * @param bundleID
+ * a bundle identifier
+ * @param recursive
+ * whether to consider transitive (indirect) dependencies
+ *
+ * @return whether my bundle directly requires it
+ */
+ public boolean hasDependency(String bundleID, boolean recursive) {
+ return getDependencyGraph().hasDependency(bundleID, recursive);
+ }
+
+ /**
+ * Obtains the set of bundles that should be re-exported that are not
+ * explicitly required (they mmust be implicitly required because some
+ * other dependency re-exports them).
+ *
+ * @return the missing re-exported dependency declarations
+ */
+ public Set<BundleAnalysis> getMissingReexports() {
+ return getAPIExports().getMissingReexports();
+ }
+
+ private BundleAnalysis analyze() {
+ if (dependencyGraph == null) {
+ dependencyGraph = new DependencyGraph(bundleID);
+ }
+ if (apiExports == null) {
+ apiExports = new APIExports(bundleID);
+ }
+
+ return this;
+ }
+
+ public String toReexportDeclaration() {
+ return String.format("%s;bundle-version=\"%s\";visibility:=reexport",
+ getBundleID(),
+ getCompatibleVersionRange());
+ }
+
+ /**
+ * For bundles that are workspace projects, gets the manifest file.
+ *
+ * @return the workspace bundle's manifest, or {@code null} if I am
+ * a target bundle
+ */
+ public IFile getManifest() {
+ IFile result = null;
+
+ IPluginModelBase model = PluginRegistry.findModel(getBundleID());
+ IResource resource = (model == null) ? null : model.getUnderlyingResource();
+ if (resource != null) {
+ switch (resource.getType()) {
+ case IResource.FILE:
+ if ("MANIFEST.MF".equals(resource.getName())) {
+ result = (IFile) resource;
+ }
+ break;
+ case IResource.PROJECT:
+ IFile manifest = ((IProject) resource).getFile("META-INF/MANIFEST.MF"); //$NON-NLS-1$
+ if ((manifest != null) && manifest.isAccessible()) {
+ result = manifest;
+ }
+ break;
+ }
+ }
+
+ return result;
+ }
+
+ /**
+ * Queries whether I am an analysis root, which is a bundle selected
+ * by the user for optimization.
+ *
+ * @return whether I am an analysis root
+ */
+ public boolean isAnalysisRoot() {
+ return DependencyAnalysisContext.this.isAnalysisRoot(getBundleID());
+ }
+
+ /**
+ * A partial-ordering analoque of the {@link Comparable#compareTo(Object)} API.
+ * Bundles are only partially orderable by dependency relationships, so
+ * they are not actually {@link Comparable}.
+ *
+ * @param o
+ * another analysis bundle
+ *
+ * @return my partial ordering relative to {@code o}
+ */
+ public int partialCompare(BundleAnalysis o) {
+ int result;
+
+ if (o == this) {
+ // Trivial case
+ result = 0;
+ } else if (this.hasDependency(o.getBundleID(), true)) {
+ result = +1;
+ } else if (o.hasDependency(this.getBundleID(), true)) {
+ result = -1;
+ } else {
+ result = 0;
+ }
+
+ return result;
+ }
+
+ @Override
+ public String toString() {
+ return "Analysis of " + bundleID;
+ }
+
+ public final void pushMonitor(IProgressMonitor monitor) {
+ DependencyAnalysisContext.this.pushMonitor(monitor);
+ }
+
+ public final void popMonitor() {
+ DependencyAnalysisContext.this.popMonitor();
+ }
+ }
+
+ /**
+ * An analysis of the dependency graph (by <tt>Require-Bundle</tt>) of a bundle.
+ */
+ public class DependencyGraph {
+ private final String bundleID;
+
+ private final Map<String, BundleAnalysis> dependencies = new HashMap<>();
+ private final Map<String, BundleAnalysis> reexports = new HashMap<>();
+
+ private Set<BundleAnalysis> cycle;
+ private Set<String> transitiveDependencies;
+
+ private DependencyGraph(String bundleID) {
+ super();
+
+ this.bundleID = bundleID;
+
+ IPluginModelBase model = PluginRegistry.findModel(bundleID);
+ if (model == null) {
+ throw new IllegalArgumentException("No such bundle: " + bundleID);
+ }
+
+ BundleDescription desc = model.getBundleDescription();
+
+ if (desc != null) {
+ for (BundleSpecification next : desc.getRequiredBundles()) {
+ // Optional dependencies may as well not be defined. If they are
+ // exposed by the API, they cannot be optional
+
+ if (next.isResolved() && !next.isOptional()
+ // The org.eclipse.utp.upr bundle actually does this!
+ && !bundleID.equals(next.getName())) {
+ BundleAnalysis dep = internalGetBundle(next.getSupplier().getName());
+
+ dependencies.put(dep.getBundleID(), dep);
+ if (next.isExported()) {
+ reexports.put(dep.getBundleID(), dep);
+ }
+ }
+ }
+ }
+ }
+
+ public BundleAnalysis getBundle() {
+ return internalGetBundle(bundleID);
+ }
+
+ public BundleAnalysis getDependency(String bundleID) {
+ BundleAnalysis result = dependencies.get(bundleID);
+
+ if (result == null) {
+ // Maybe it's a transitive dependency
+ result = dependencies.values().stream()
+ .map(bundle -> bundle.getDependency(bundleID))
+ .filter(Objects::nonNull)
+ .findAny().orElse(null);
+ }
+
+ return result;
+ }
+
+ public boolean isReexported(String bundleID) {
+ // I trivially "re-export" myself
+ boolean result = this.bundleID.equals(bundleID) || reexports.containsKey(bundleID);
+
+ if (!result) {
+ // Maybe it's a transitive re-export
+ result = reexports.values().stream()
+ .anyMatch(bundle -> bundle.isReexported(bundleID));
+ }
+
+ return result;
+ }
+
+ /**
+ * Queries whether I express a dependency directly on the given bundle.
+ * Equivalent to {@link #hasDependency(String, boolean) hasDependency(bundleID, false)}.
+ *
+ * @param bundleID
+ * a bundle identifier
+ * @return whether my bundle directly requires it
+ */
+ public boolean hasDependency(String bundleID) {
+ return dependencies.containsKey(bundleID);
+ }
+
+ /**
+ * Queries whether I express a dependency directly or, optionally,
+ * indirectly on the given bundle.
+ *
+ * @param bundleID
+ * a bundle identifier
+ * @param recursive
+ * whether to consider transitive (indirect) dependencies
+ *
+ * @return whether my bundle directly requires it
+ */
+ public boolean hasDependency(String bundleID, boolean recursive) {
+ boolean result = hasDependency(bundleID);
+
+ if (!result && recursive) {
+ result = transitiveDependencies.contains(bundleID);
+ }
+
+ return result;
+ }
+
+ public boolean isRedundant(String bundleID) {
+ boolean result;
+
+ if (isReexported(bundleID)) {
+ // If it's re-exported, then it's only redundant if it is also re-exported
+ // by some other bundle that I re-export. Account for re-exports that we
+ // would be adding
+ result = Stream.concat(reexports.values().stream(), getBundle().getMissingReexports().stream())
+ .filter(bundle -> !bundleID.equals(bundle.getBundleID())) // Excluding the bundle itself, of course!
+ .anyMatch(bundle -> bundle.isReexported(bundleID));
+ } else {
+ // Otherwise, it's redundant if it's re-exported by any of our dependencies
+ result = dependencies.values().stream()
+ .filter(bundle -> !bundle.getBundleID().equals(bundleID))
+ .anyMatch(bundle -> bundle.isReexported(bundleID));
+ }
+
+ return result;
+ }
+
+ public void checkCycle() throws IllegalStateException {
+ if (cycle == null) {
+ cycle = computeCycle(new LinkedHashSet<>());
+ }
+
+ if (!cycle.isEmpty()) {
+ List<String> list = cycle.stream()
+ .map(BundleAnalysis::getBundleID)
+ .collect(Collectors.toList());
+ list.add(cycle.iterator().next().getBundleID()); // Close the cycle
+ throw new IllegalStateException("Dependency cycle detected: " + list);
+ }
+ }
+
+ // use a LinkedHashSet specifically because the cycle has a defined order
+ private Set<BundleAnalysis> computeCycle(LinkedHashSet<BundleAnalysis> trace) {
+ if (cycle != null) {
+ // I've already been validated, so there's no possibility of finding
+ // a new cycle in me
+ return cycle;
+ }
+
+ BundleAnalysis self = getBundle();
+
+ if (!trace.add(self)) {
+ // We closed the cycle. Trim up to the first occurrence of myself
+ for (Iterator<BundleAnalysis> iter = trace.iterator(); iter.hasNext();) {
+ if (iter.next() == self) {
+ break;
+ } else {
+ iter.remove();
+ }
+ }
+ cycle = trace;
+ } else {
+ // Take this opportunity when we are exhaustively looking for a cycle, anyways,
+ // to compute everybody's transitive dependencies
+ transitiveDependencies = new HashSet<>();
+
+ // We didn't close the cycle, so keep looking
+ for (BundleAnalysis next : dependencies.values()) {
+ DependencyGraph child = next.getDependencyGraph();
+ cycle = child.computeCycle(trace);
+ if (!cycle.isEmpty()) {
+ // Got a cycle
+ break;
+ } else {
+ // Collect its dependencies and its transitive dependencies
+ transitiveDependencies.addAll(child.dependencies.keySet());
+ transitiveDependencies.addAll(child.transitiveDependencies);
+ }
+ }
+
+ // Cycle could be null if I had no dependencies
+ if ((cycle == null) || cycle.isEmpty()) {
+ // Some of my direct dependencies could be dependencies of some of
+ // my transitive dependencies, but they are direct to me
+ transitiveDependencies.removeAll(dependencies.keySet());
+
+ // Backtrack
+ trace.remove(self);
+
+ // And mark me cycle-free
+ cycle = Collections.emptySet();
+ }
+ }
+
+ return cycle;
+ }
+
+ public void removeDependency(String bundleID) {
+ dependencies.remove(bundleID);
+
+ // It's now just a transitive dependency because it was redundant
+ transitiveDependencies.add(bundleID);
+
+ // And it obviously can't be reexported
+ reexports.remove(bundleID);
+ }
+
+ public void reexport(String bundleID) {
+ reexports.put(bundleID, internalGetBundle(bundleID));
+
+ // This information is now stale
+ getBundle().getAPIExports().recomputeMissingReexports();
+ }
+
+ @Override
+ public String toString() {
+ return "Dependencies of " + bundleID;
+ }
+ }
+
+ /**
+ * An analysis of the public API exports of a bundle.
+ */
+ public class APIExports {
+ private final String bundleID;
+ private VersionRange compatibleVersionRange;
+
+ private Set<String> exports;
+ private Map<String, BundleAnalysis> exposedDependencies;
+ private Set<BundleAnalysis> missingReexports;
+
+ private APIExports(String bundleID) {
+ super();
+
+ this.bundleID = bundleID;
+ }
+
+ public BundleAnalysis getBundle() {
+ return internalGetBundle(bundleID);
+ }
+
+ public VersionRange getCompatibleVersionRange() {
+ return compatibleVersionRange;
+ }
+
+ public boolean exports(String packageName) {
+ analyze();
+
+ return exports.contains(packageName);
+ }
+
+ public boolean isExposed(String bundleID) {
+ analyze();
+
+ return exposedDependencies.containsKey(bundleID);
+ }
+
+ public Set<BundleAnalysis> getExposedDependencies() {
+ analyze();
+
+ return new HashSet<>(exposedDependencies.values());
+ }
+
+ /**
+ * Obtains the set of bundles that should be re-exported that are not
+ * explicitly required (they mmust be implicitly required because some
+ * other dependency re-exports them).
+ *
+ * @return the missing re-exported dependency declarations
+ */
+ public Set<BundleAnalysis> getMissingReexports() {
+ if (missingReexports == null) {
+ missingReexports = getExposedDependencies().stream()
+ .filter(bundle -> !getBundle().isReexported(bundle.getBundleID()))
+ .filter(bundle -> !getBundle().hasDependency(bundle.getBundleID()))
+ .filter(bundle -> !isReexportedByExposedDependency(bundle))
+ .collect(Collectors.toCollection(
+ () -> new TreeSet<>(Comparator.comparing(BundleAnalysis::getBundleID))));
+ }
+
+ return missingReexports;
+ }
+
+ void recomputeMissingReexports() {
+ missingReexports = null;
+ }
+
+ private APIExports analyze() {
+ if (exposedDependencies == null) {
+ exposedDependencies = new HashMap<>();
+
+ IPluginModelBase model = PluginRegistry.findModel(bundleID);
+ BundleDescription desc = model.getBundleDescription();
+ IProject project = (model.getUnderlyingResource() == null)
+ ? null
+ : model.getUnderlyingResource().getProject();
+ BundleAnalysis self = getBundle();
+
+ if (desc == null) {
+ // No exports if no bundle description
+ exports = Collections.emptySet();
+ compatibleVersionRange = VersionRange.valueOf("0.0.0"); //$NON-NLS-1$
+ } else {
+ compatibleVersionRange = versionRules.getDependencyVersionRange(
+ DependencyKind.REQUIRE_BUNDLE, bundleID);
+
+ if ((project == null) || !isAnalysisRoot(bundleID)) {
+ // It's a PDE target bundle. We don't need to compute uses constraints
+ // for it because we won't be attempting to edit its dependencies
+ exports = Stream.of(desc.getExportPackages())
+ .filter(this::isPublicExport)
+ .map(ExportPackageDescription::getName)
+ .collect(Collectors.toSet());
+ } else {
+ // It's a workspace bundle that is selected for optimization.
+ // We need to compute uses constraints for it
+ Map<String, ? extends Set<String>> uses = new MyCalculateUsesOperation(project, model).calculate();
+
+ currentMonitor.setTaskName("Computing re-exported dependencies...");
+ exports = new HashSet<>(uses.keySet());
+ Set<String> allUsedPackages = uses.values().stream()
+ .flatMap(Collection::stream)
+ .distinct()
+ .collect(Collectors.toSet());
+
+ // Don't consider my own exported packages, of course
+ allUsedPackages.removeAll(exports);
+
+ for (String next : allUsedPackages) {
+ BundleAnalysis provider = getProvidingBundle(next);
+ if ((provider != null) && (provider != self) && !exposedDependencies.containsKey(provider.getBundleID())) {
+ exposedDependencies.put(provider.getBundleID(), provider);
+ }
+ }
+ }
+ }
+
+ exports.forEach(x -> packageProviders.put(x, self));
+ }
+
+ return this;
+ }
+
+ private boolean isPublicExport(ExportPackageDescription exportPackage) {
+ Map<String, String> directives = exportPackage.getDeclaredDirectives();
+ return !"true".equals(directives.get("x-internal"))
+ && !directives.containsKey("x-friends");
+ }
+
+ /**
+ * Queries whether a {@code bundle} is re-exported by some existing dependency
+ * that is exposed in the API. Such a bundle would not have to be added as
+ * a missing re-export.
+ *
+ * @param bundle
+ * an exposed bundle
+ *
+ * @return whether it is re-exported by some other bundle that I expose
+ */
+ private boolean isReexportedByExposedDependency(BundleAnalysis bundle) {
+ return exposedDependencies.values().stream()
+ .anyMatch(dep -> dep.isReexported(bundle.getBundleID()));
+ }
+
+ @Override
+ public String toString() {
+ return "API of " + bundleID;
+ }
+
+ //
+ // Nested types
+ //
+
+ @SuppressWarnings("restriction")
+ private final class MyCalculateUsesOperation extends org.eclipse.pde.internal.ui.search.dependencies.CalculateUsesOperation {
+ MyCalculateUsesOperation(IProject project, IPluginModelBase model) {
+ // This cast is safe if the model if the model is a workspace bundle project
+ super(project, (org.eclipse.pde.internal.core.ibundle.IBundlePluginModelBase) model);
+ }
+
+ Map<String, ? extends Set<String>> calculate() {
+ Map<String, ? extends Set<String>> result;
+
+ Collection<String> packages = getPublicExportedPackages();
+ if (packages.isEmpty()) {
+ result = Collections.emptyMap();
+ } else {
+ result = findPackageReferences(packages, currentMonitor.split(1)); // Split doesn't matter for unknown total work
+ }
+
+ return result;
+ }
+ }
+ }
+}
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/DependencyKind.java b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/DependencyKind.java
new file mode 100644
index 00000000000..b391273474b
--- /dev/null
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/DependencyKind.java
@@ -0,0 +1,81 @@
+/*****************************************************************************
+ * Copyright (c) 2016 Christian W. Damus and others.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Christian W. Damus - Initial API and implementation
+ *
+ *****************************************************************************/
+
+package org.eclipse.papyrus.dev.project.management.internal.operations;
+
+import java.util.List;
+import java.util.function.Function;
+
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IManifestEditor;
+import org.eclipse.pde.core.project.IPackageImportDescription;
+import org.eclipse.pde.core.project.IRequiredBundleDescription;
+import org.osgi.framework.VersionRange;
+
+public enum DependencyKind {
+ /** A <tt>Require-Bundle</tt> type of dependency. */
+ REQUIRE_BUNDLE(IRequiredBundleDescription.class, IManifestEditor::getRequiredBundles, IRequiredBundleDescription::getName, IManifestEditor::addDependency),
+
+ /** An <tt>Import-Package</tt> type of dependency. */
+ IMPORT_PACKAGE(IPackageImportDescription.class, IManifestEditor::getImportedPackages, IPackageImportDescription::getName, IManifestEditor::addImportPackage);
+
+ private final Function<IManifestEditor, List<?>> dependenciesFunction;
+
+ private final Function<?, String> dependencyNameFunction;
+
+ private final DependencyUpdater dependencyUpdater;
+
+ private <T> DependencyKind(Class<T> dependencyType, Function<IManifestEditor, List<?>> dependenciesFunction, Function<T, String> dependencyNameFunction, DependencyUpdater dependencyUpdater) {
+ this.dependenciesFunction = dependenciesFunction;
+ this.dependencyNameFunction = dependencyNameFunction;
+ this.dependencyUpdater = dependencyUpdater;
+ }
+
+ String getVersionAttribute() {
+ return (this == REQUIRE_BUNDLE)
+ ? "bundle-version" //$NON-NLS-1$
+ : "version"; //$NON-NLS-1$
+ }
+
+ static DependencyKind forHeader(String headerName) {
+ switch (headerName) {
+ case "Require-Bundle":
+ return REQUIRE_BUNDLE;
+ case "Import-Package":
+ return IMPORT_PACKAGE;
+ default:
+ throw new IllegalArgumentException(headerName);
+ }
+ }
+
+ public List<?> getDependencies(IManifestEditor manifest) {
+ return dependenciesFunction.apply(manifest);
+ }
+
+ @SuppressWarnings("unchecked")
+ public String getDependencyName(Object dependency) {
+ return ((Function<Object, String>) dependencyNameFunction).apply(dependency);
+ }
+
+ public void setDependencyRange(IManifestEditor manifest, String dependencyName, VersionRange range) {
+ dependencyUpdater.setDependencyRange(manifest, dependencyName, range.toString());
+ }
+
+ //
+ // Nested types
+ //
+
+ @FunctionalInterface
+ private interface DependencyUpdater {
+ void setDependencyRange(IManifestEditor manifest, String dependencyName, String versionRange);
+ }
+} \ No newline at end of file
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/OptimizeDependenciesOperation.java b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/OptimizeDependenciesOperation.java
new file mode 100644
index 00000000000..87aed84f133
--- /dev/null
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/OptimizeDependenciesOperation.java
@@ -0,0 +1,104 @@
+/*****************************************************************************
+ * Copyright (c) 2016 Christian W. Damus and others.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Christian W. Damus - Initial API and implementation
+ *
+ *****************************************************************************/
+
+package org.eclipse.papyrus.dev.project.management.internal.operations;
+
+import java.util.List;
+import java.util.Map;
+
+import org.eclipse.core.commands.ExecutionException;
+import org.eclipse.core.resources.IFile;
+import org.eclipse.core.runtime.IProgressMonitor;
+import org.eclipse.core.runtime.IStatus;
+import org.eclipse.core.runtime.OperationCanceledException;
+import org.eclipse.core.runtime.Status;
+import org.eclipse.core.runtime.SubMonitor;
+import org.eclipse.papyrus.dev.project.management.internal.operations.DependencyAnalysisContext.APIExports;
+import org.eclipse.papyrus.dev.project.management.internal.operations.DependencyAnalysisContext.BundleAnalysis;
+import org.eclipse.papyrus.dev.project.management.internal.operations.DependencyAnalysisContext.DependencyGraph;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IManifestEditor;
+import org.eclipse.papyrus.infra.tools.util.Iterables2;
+import org.eclipse.pde.core.project.IRequiredBundleDescription;
+
+/**
+ * Undoable "optimize dependencies" operation, which ensures re-exports of dependencies
+ * that contribute types to the exported API and removes redundancies (except where they are
+ * re-exported).
+ */
+public class OptimizeDependenciesOperation extends AbstractManifestUpdateOperation {
+
+ public OptimizeDependenciesOperation(Map<? extends IFile, ? extends IManifestEditor> manifests) {
+ super("Optimize Bundle Dependencies", manifests);
+ }
+
+ @Override
+ protected IStatus doExecute(IProgressMonitor monitor, Map<? extends IFile, ? extends IManifestEditor> manifests) throws ExecutionException {
+ SubMonitor sub = SubMonitor.convert(monitor, "Analyzing ...", manifests.size() + 1);
+
+ sub.split(1).beginTask("Initializing", IProgressMonitor.UNKNOWN);
+
+ DependencyAnalysisContext analysisContext = new DependencyAnalysisContext(manifests.keySet());
+
+ // This map is sorted from root to leaves of the dependency tree
+ List<BundleAnalysis> bundles = Iterables2.topoSort(
+ analysisContext.getAnalysisRoots(),
+ BundleAnalysis::partialCompare);
+
+ for (BundleAnalysis bundle : bundles) {
+ IManifestEditor editor = manifests.get(bundle.getManifest());
+
+ SubMonitor step = sub.split(1);
+
+ if (step.isCanceled()) {
+ throw new OperationCanceledException();
+ }
+
+ editor.init();
+ optimizeDependencies(bundle, editor, step);
+ }
+
+ return Status.OK_STATUS;
+ }
+
+ private void optimizeDependencies(BundleAnalysis bundle, IManifestEditor manifest, IProgressMonitor monitor) {
+ monitor.beginTask(bundle.getBundleID(), IProgressMonitor.UNKNOWN);
+ bundle.pushMonitor(monitor);
+
+ try {
+ DependencyGraph graph = bundle.getDependencyGraph();
+ APIExports api = bundle.getAPIExports();
+
+ for (IRequiredBundleDescription requireBundle : manifest.getRequiredBundles()) {
+ String required = requireBundle.getName();
+
+ if (graph.isRedundant(required)) {
+ // Remove it from the manifest
+ manifest.removeRequiredBundle(required);
+
+ // Update the graph
+ graph.removeDependency(required);
+ } else if (api.isExposed(required) && !requireBundle.isExported()) {
+ // We need to retain this dependency and ensure that it is re-exported,
+ // unless it is already re-exported by some other dependency that we re-export
+ // (which would be the redundant case, above)
+ manifest.setRequiredBundleExported(required, true);
+
+ // Update the graph
+ graph.reexport(required);
+ } // else just retain this dependency as is
+ }
+ } finally {
+ bundle.popMonitor();
+ }
+ }
+}
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/UpdateDependencyRangesOperation.java b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/UpdateDependencyRangesOperation.java
new file mode 100644
index 00000000000..4a87f700b2a
--- /dev/null
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/UpdateDependencyRangesOperation.java
@@ -0,0 +1,81 @@
+/*****************************************************************************
+ * Copyright (c) 2016 Christian W. Damus and others.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Christian W. Damus - Initial API and implementation
+ *
+ *****************************************************************************/
+
+package org.eclipse.papyrus.dev.project.management.internal.operations;
+
+import java.util.Map;
+
+import org.eclipse.core.commands.ExecutionException;
+import org.eclipse.core.resources.IFile;
+import org.eclipse.core.runtime.IProgressMonitor;
+import org.eclipse.core.runtime.IStatus;
+import org.eclipse.core.runtime.OperationCanceledException;
+import org.eclipse.core.runtime.Status;
+import org.eclipse.core.runtime.SubMonitor;
+import org.eclipse.papyrus.eclipse.project.editors.interfaces.IManifestEditor;
+import org.osgi.framework.VersionRange;
+
+/**
+ * Undoable "update dependency ranges" operation, which updates all dependencies
+ * in the selected <tt.MANIFEST.MF</tt> file(s) to be version ranges lower-bounded
+ * by the current PDE Target version, except for certain 3rd-party Orbit bundles
+ * (such as Guava, ICU4J) that are known to increase major versions frequently without
+ * breaking compatibility.
+ */
+public class UpdateDependencyRangesOperation extends AbstractManifestUpdateOperation {
+
+ private final VersionRules versionRules = new VersionRules();
+
+ public UpdateDependencyRangesOperation(Map<? extends IFile, ? extends IManifestEditor> manifests) {
+ super("Update Dependency Ranges", manifests);
+ }
+
+ @Override
+ protected IStatus doExecute(IProgressMonitor monitor, Map<? extends IFile, ? extends IManifestEditor> manifests) throws ExecutionException {
+ SubMonitor sub = SubMonitor.convert(monitor, "Updating manifests...", manifests.size() * 2);
+
+ for (IManifestEditor editor : manifests.values()) {
+ if (sub.isCanceled()) {
+ throw new OperationCanceledException();
+ }
+
+ editor.init();
+
+ updateDependencies(editor, DependencyKind.REQUIRE_BUNDLE);
+ sub.worked(1);
+
+ if (sub.isCanceled()) {
+ throw new OperationCanceledException();
+ }
+
+ updateDependencies(editor, DependencyKind.IMPORT_PACKAGE);
+ sub.worked(1);
+ }
+
+ sub.done();
+
+ return Status.OK_STATUS;
+ }
+
+ private void updateDependencies(IManifestEditor manifest, DependencyKind kind) {
+ // The API interfaces for dependencies have no common supertype
+ for (Object dependency : kind.getDependencies(manifest)) {
+ String dependencyName = kind.getDependencyName(dependency);
+
+ VersionRange range = versionRules.getDependencyVersionRange(kind, dependencyName);
+ if (range != null) {
+ kind.setDependencyRange(manifest, dependencyName, range);
+ } // else this bundle needs no update
+ }
+ }
+}
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java
new file mode 100644
index 00000000000..cf700faecae
--- /dev/null
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java
@@ -0,0 +1,221 @@
+/*****************************************************************************
+ * Copyright (c) 2016 Christian W. Damus and others.
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * Christian W. Damus - Initial API and implementation
+ *
+ *****************************************************************************/
+
+package org.eclipse.papyrus.dev.project.management.internal.operations;
+
+import java.util.Objects;
+import java.util.function.BiFunction;
+import java.util.function.BiPredicate;
+import java.util.function.Predicate;
+import java.util.stream.Stream;
+
+import org.eclipse.osgi.service.resolver.BundleDescription;
+import org.eclipse.osgi.service.resolver.ExportPackageDescription;
+import org.eclipse.pde.core.plugin.IPluginModelBase;
+import org.eclipse.pde.core.plugin.PluginRegistry;
+import org.osgi.framework.Version;
+import org.osgi.framework.VersionRange;
+
+/**
+ * Utility for management of bundle dependency version ranges, defining rules
+ * governing how various specific dependencies are to be managed.
+ */
+public class VersionRules {
+
+ private final VersionRule rule = VersionRule.composeAll(
+ new CurrentVersionRule(), // The default behaviour
+ new FixedRangeRule(dep -> dep.startsWith("org.apache.batik"), "[1.6.0,1.7.0)"), //$NON-NLS-1$//$NON-NLS-2$
+ new SkipRule("com.ibm.icu"), //$NON-NLS-1$
+ new FixedRangeRule("com.google.guava", "11.0.0") //$NON-NLS-1$
+ );
+
+ public VersionRules() {
+ super();
+ }
+
+ /**
+ * Queries the version range that should constraint a dependency of the given {@code kind}
+ * on a bundle or package.
+ *
+ * @param kind
+ * the dependency kind
+ * @param dependency
+ * the bundle or package dependency
+ *
+ * @return the appropriate version range, or {@code null} if unknown or the range
+ * currently specified in the manfiest can be retained as is
+ */
+ public VersionRange getDependencyVersionRange(DependencyKind kind, String dependency) {
+ return rule.apply(kind, dependency);
+ }
+
+ static Version getCurrentMinorVersion(String dependencyName, boolean isPackageImport) {
+ Version result = Version.emptyVersion;
+
+ if (!isPackageImport) {
+ IPluginModelBase model = PluginRegistry.findModel(dependencyName);
+ if (model != null) {
+ result = Version.valueOf(model.getPluginBase().getVersion());
+ }
+ } else {
+ // Look for a bundle that exports the package
+ result = Stream.of(PluginRegistry.getActiveModels(false))
+ .filter(p -> exports(p, dependencyName))
+ // TODO: Sort by longest prefix match to the package name
+ .map(p -> getExportedVersion(p, dependencyName))
+ .findFirst()
+ .orElse(Version.emptyVersion);
+ }
+
+ if (!result.equals(Version.emptyVersion)) {
+ // 'Minorize' it
+ result = new Version(result.getMajor(), result.getMinor(), 0);
+ }
+
+ return result;
+ }
+
+ private static boolean exports(IPluginModelBase pluginModel, String packageName) {
+ boolean result = false;
+
+ BundleDescription desc = pluginModel.getBundleDescription();
+ if (desc != null) {
+ result = Stream.of(desc.getExportPackages())
+ .anyMatch(ep -> packageName.equals(ep.getName()));
+ }
+
+ return result;
+ }
+
+ private static Version getExportedVersion(IPluginModelBase pluginModel, String packageName) {
+ // In case there is no bundle description, which would be odd at this point
+ Version result = Version.emptyVersion;
+
+ BundleDescription desc = pluginModel.getBundleDescription();
+ if (desc != null) {
+ result = Stream.of(desc.getExportPackages())
+ .filter(ep -> packageName.equals(ep.getName()))
+ .map(ExportPackageDescription::getVersion)
+ .filter(Objects::nonNull)
+ .findAny().orElse(Version.emptyVersion);
+ }
+
+ return result;
+ }
+
+ //
+ // Nested types
+ //
+
+ private interface VersionRule extends BiPredicate<DependencyKind, String>, BiFunction<DependencyKind, String, VersionRange> {
+ default VersionRule compose(VersionRule other) {
+ return new VersionRule() {
+
+ @Override
+ public VersionRange apply(DependencyKind kind, String dependencyName) {
+ return VersionRule.this.test(kind, dependencyName)
+ ? VersionRule.this.apply(kind, dependencyName)
+ : other.apply(kind, dependencyName);
+ }
+
+ @Override
+ public boolean test(DependencyKind kind, String dependencyName) {
+ return VersionRule.this.test(kind, dependencyName) || other.test(kind, dependencyName);
+ }
+ };
+ }
+
+ static VersionRule composeAll(VersionRule default_, VersionRule... rules) {
+ VersionRule result = default_;
+ for (VersionRule next : rules) {
+ result = next.compose(result);
+ }
+ return result;
+ }
+ }
+
+ private static abstract class AbstractRule implements VersionRule {
+ private final BiPredicate<DependencyKind, String> predicate;
+
+ AbstractRule(BiPredicate<DependencyKind, String> predicate) {
+ super();
+
+ this.predicate = predicate;
+ }
+
+ AbstractRule(Predicate<String> predicate) {
+ this((kind, dep) -> predicate.test(dep));
+ }
+
+ @Override
+ public boolean test(DependencyKind kind, String dependencyName) {
+ return predicate.test(kind, dependencyName);
+ }
+ }
+
+ private static final class FixedRangeRule extends AbstractRule {
+ private final VersionRange range;
+
+ FixedRangeRule(String bundleID, String range) {
+ this(bundleID::equals, VersionRange.valueOf(range));
+ }
+
+ FixedRangeRule(Predicate<String> predicate, String range) {
+ this(predicate, VersionRange.valueOf(range));
+ }
+
+ FixedRangeRule(Predicate<String> predicate, VersionRange range) {
+ super(predicate);
+
+ this.range = range;
+ }
+
+ @Override
+ public VersionRange apply(DependencyKind kind, String dependencyName) {
+ return range;
+ }
+ }
+
+ private static final class SkipRule extends AbstractRule {
+ SkipRule(String dependencyName) {
+ this(dependencyName::equals);
+ }
+
+ SkipRule(Predicate<String> predicate) {
+ super(predicate);
+ }
+
+ @Override
+ public VersionRange apply(DependencyKind kind, String dependencyName) {
+ return null;
+ }
+ }
+
+ private static class CurrentVersionRule extends AbstractRule {
+ private CurrentVersionRule() {
+ super((kind, dep) -> true);
+ }
+
+ @Override
+ public VersionRange apply(DependencyKind kind, String dependencyName) {
+ Version current = getCurrentMinorVersion(dependencyName, kind == DependencyKind.IMPORT_PACKAGE);
+ Version next = ((current == null) || current.equals(Version.emptyVersion))
+ ? null
+ : new Version(current.getMajor() + 1, 0, 0);
+
+ return (next == null)
+ ? null
+ : new VersionRange(VersionRange.LEFT_CLOSED, current, next, VersionRange.RIGHT_OPEN);
+ }
+ }
+}
diff --git a/plugins/developer/org.eclipse.papyrus.dev.tests.framework.ui/.project b/plugins/developer/org.eclipse.papyrus.dev.tests.framework.ui/.project
index 5fd10003319..9659dc74a02 100644
--- a/plugins/developer/org.eclipse.papyrus.dev.tests.framework.ui/.project
+++ b/plugins/developer/org.eclipse.papyrus.dev.tests.framework.ui/.project
@@ -16,13 +16,29 @@
</arguments>
</buildCommand>
<buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
+ <name>org.eclipse.pde.api.tools.apiAnalysisBuilder</name>
<arguments>
</arguments>
</buildCommand>
<buildCommand>
- <name>org.eclipse.pde.api.tools.apiAnalysisBuilder</name>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
<arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.missing.dependency.ranges</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>release.path</key>
+ <value>/org.eclipse.papyrus.releng.dev.release/release.xml</value>
+ </dictionary>
</arguments>
</buildCommand>
</buildSpec>
@@ -30,5 +46,6 @@
<nature>org.eclipse.pde.PluginNature</nature>
<nature>org.eclipse.jdt.core.javanature</nature>
<nature>org.eclipse.pde.api.tools.apiAnalysisNature</nature>
+ <nature>org.eclipse.oomph.version.VersionNature</nature>
</natures>
</projectDescription>
diff --git a/plugins/developer/org.eclipse.papyrus.dev.tests.framework.ui/META-INF/MANIFEST.MF b/plugins/developer/org.eclipse.papyrus.dev.tests.framework.ui/META-INF/MANIFEST.MF
index 2d47ce802ef..91543975946 100644
--- a/plugins/developer/org.eclipse.papyrus.dev.tests.framework.ui/META-INF/MANIFEST.MF
+++ b/plugins/developer/org.eclipse.papyrus.dev.tests.framework.ui/META-INF/MANIFEST.MF
@@ -1,16 +1,16 @@
-Manifest-Version: 1.0
-Require-Bundle: org.eclipse.core.runtime,
- com.google.guava;bundle-version="11.0.0",
- org.eclipse.core.resources;bundle-version="3.10.0",
- org.eclipse.papyrus.dev.tests.framework;bundle-version="1.2.0",
- org.eclipse.ui;bundle-version="3.107.0",
- org.eclipse.core.expressions;bundle-version="3.5.0"
-Export-Package: org.eclipse.papyrus.dev.tests.framework.internal.ui;x-internal:=true
-Bundle-Vendor: %Bundle-Vendor
-Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.0.qualifier
-Bundle-Name: %Bundle-Name
-Bundle-ManifestVersion: 2
-Bundle-Activator: org.eclipse.papyrus.dev.tests.framework.internal.ui.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.dev.tests.framework.ui;singleton:=true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.7
+Manifest-Version: 1.0
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
+ com.google.guava;bundle-version="11.0.0",
+ org.eclipse.core.resources;bundle-version="[3.11.0,4.0.0)",
+ org.eclipse.papyrus.dev.tests.framework;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.ui;bundle-version="[3.107.0,4.0.0)",
+ org.eclipse.core.expressions;bundle-version="[3.5.0,4.0.0)"
+Export-Package: org.eclipse.papyrus.dev.tests.framework.internal.ui;x-internal:=true
+Bundle-Vendor: %Bundle-Vendor
+Bundle-ActivationPolicy: lazy
+Bundle-Version: 1.2.0.qualifier
+Bundle-Name: %Bundle-Name
+Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.dev.tests.framework.internal.ui.Activator
+Bundle-SymbolicName: org.eclipse.papyrus.dev.tests.framework.ui;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
diff --git a/plugins/developer/org.eclipse.papyrus.dev.tests.framework/.project b/plugins/developer/org.eclipse.papyrus.dev.tests.framework/.project
index 8b08e018ffe..47c5b02925a 100644
--- a/plugins/developer/org.eclipse.papyrus.dev.tests.framework/.project
+++ b/plugins/developer/org.eclipse.papyrus.dev.tests.framework/.project
@@ -16,19 +16,30 @@
</arguments>
</buildCommand>
<buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.api.tools.apiAnalysisBuilder</name>
+ <name>org.eclipse.oomph.version.VersionBuilder</name>
<arguments>
+ <dictionary>
+ <key>check.maven.pom</key>
+ <value>true</value>
+ </dictionary>
+ <dictionary>
+ <key>ignore.lower.bound.dependency.ranges</key>
+ <value>true</value><