Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcletavernie2011-12-09 10:18:02 -0500
committercletavernie2011-12-09 10:18:02 -0500
commite79a29bc4e8b21c139fd623abd8cd4fbc2796b90 (patch)
tree1914380f515c62b09a230eb0670ddc9377b10542 /plugins/views
parent06c97945804ef6fec4a1b1baa51fa9f0b7983080 (diff)
downloadorg.eclipse.papyrus-e79a29bc4e8b21c139fd623abd8cd4fbc2796b90.tar.gz
org.eclipse.papyrus-e79a29bc4e8b21c139fd623abd8cd4fbc2796b90.tar.xz
org.eclipse.papyrus-e79a29bc4e8b21c139fd623abd8cd4fbc2796b90.zip
365919: [Architecture - SVN - Build] Rewrite the Build
https://bugs.eclipse.org/bugs/show_bug.cgi?id=365919 Removed some reexported dependencies.
Diffstat (limited to 'plugins/views')
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/META-INF/MANIFEST.MF3
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF3
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF6
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF8
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/META-INF/MANIFEST.MF3
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/META-INF/MANIFEST.MF3
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/META-INF/MANIFEST.MF3
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/META-INF/MANIFEST.MF3
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF3
9 files changed, 26 insertions, 9 deletions
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/META-INF/MANIFEST.MF b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/META-INF/MANIFEST.MF
index 6660b62d9b5..5ef73f72989 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/META-INF/MANIFEST.MF
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/META-INF/MANIFEST.MF
@@ -2,7 +2,8 @@ Manifest-Version: 1.0
Require-Bundle: org.eclipse.papyrus.views.documentation.view;bundle-version="0.9.0",
org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0",
org.eclipse.papyrus.infra.core.adaptor.gmf;bundle-version="0.9.0",
- org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0"
+ org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0"
Bundle-Vendor: %providerName
Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF
index ac8506849ac..754c85068c9 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF
@@ -9,7 +9,8 @@ Require-Bundle: org.eclipse.emf.converter;bundle-version="2.5.0",
org.eclipse.emf.facet.infra.facet;bundle-version="0.1.0",
org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0",
org.eclipse.papyrus.infra.services.controlmode.history;bundle-version="0.9.0",
- org.eclipse.papyrus.infra.services.resourceloading;bundle-version="0.9.0"
+ org.eclipse.papyrus.infra.services.resourceloading;bundle-version="0.9.0",
+ org.eclipse.emf.transaction;bundle-version="1.4.0"
Export-Package: org.eclipse.papyrus.views.modelexplorer.resourceloading.hand
ler
Bundle-Vendor: %providerName
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF
index b789a093590..42f59eb1ab4 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF
@@ -6,7 +6,11 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.emf.facet.infra.browser;bundle-version="0.1.0";visibility:=reexport,
org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0";visibility:=reexport,
org.eclipse.papyrus.infra.services.edit;bundle-version="0.9.0",
- org.eclipse.emf.facet.infra.facet;bundle-version="0.1.0"
+ org.eclipse.emf.facet.infra.facet;bundle-version="0.1.0",
+ org.eclipse.gmf.runtime.notation;bundle-version="1.5.0",
+ org.eclipse.gmf.runtime.emf.core;bundle-version="1.4.1",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.4.0",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0"
Export-Package: org.eclipse.papyrus.views.modelexplorer.widgets
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF
index a116ad993b3..f9e75a08f66 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF
@@ -24,7 +24,13 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.emf.facet.infra.query.ui;bundle-version="0.1.0",
org.eclipse.papyrus.infra.widgets.toolbox;bundle-version="0.9.0",
org.eclipse.papyrus.infra.services.decoration;bundle-version="0.9.0",
- org.eclipse.emf.facet.infra.query.core
+ org.eclipse.emf.transaction;bundle-version="1.4.0",
+ org.eclipse.gmf.runtime.notation;bundle-version="1.5.0",
+ org.eclipse.gmf.runtime.common.core;bundle-version="1.4.1",
+ org.eclipse.gmf.runtime.emf.commands.core;bundle-version="1.4.0",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.4.0",
+ org.eclipse.emf.facet.infra.query.core,
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0"
Export-Package: org.eclipse.papyrus.views.modelexplorer,
org.eclipse.papyrus.views.modelexplorer.actionprovider,
org.eclipse.papyrus.views.modelexplorer.actions,
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/META-INF/MANIFEST.MF
index 0340c12d895..d3e517bba1b 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/META-INF/MANIFEST.MF
@@ -27,7 +27,8 @@ Require-Bundle: org.eclipse.ui;bundle-version="3.5.1",
org.eclipse.emf.edit.ui;bundle-version="2.6.0",
org.eclipse.uml2.uml;bundle-version="3.1.0",
org.eclipse.papyrus.infra.core;bundle-version="0.9.0",
- org.eclipse.papyrus.infra.services.edit;bundle-version="0.9.0"
+ org.eclipse.papyrus.infra.services.edit;bundle-version="0.9.0",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.4.0"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-Version: 0.9.0.qualifier
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/META-INF/MANIFEST.MF
index c5007a6aa86..b5471afea2a 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/META-INF/MANIFEST.MF
@@ -8,7 +8,8 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.gmf.runtime.common.ui;bundle-version="1.3.0",
org.eclipse.papyrus.infra.core;bundle-version="0.9.0",
org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
- org.eclipse.papyrus.infra.core.log;bundle-version="0.9.0"
+ org.eclipse.papyrus.infra.core.log;bundle-version="0.9.0",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0"
Export-Package: org.eclipse.papyrus.views.properties.tabbed.core,
org.eclipse.papyrus.views.properties.tabbed.core.provider,
org.eclipse.papyrus.views.properties.tabbed.core.view,
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/META-INF/MANIFEST.MF
index 83a7cb6c9bf..b2ca362e9e5 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/META-INF/MANIFEST.MF
@@ -17,7 +17,8 @@ Require-Bundle: org.eclipse.ui,
org.apache.xml.resolver;bundle-version="1.2.0",
org.eclipse.emf.facet.infra.browser.custom;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.browser.custom.core;bundle-version="0.1.0",
- org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0"
+ org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0"
Export-Package: org.eclipse.papyrus.views.properties.tabbed.customization,
org.eclipse.papyrus.views.properties.tabbed.customization.dialog,
org.eclipse.papyrus.views.properties.tabbed.customization.dialog.actions,
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/META-INF/MANIFEST.MF
index 3600cf00220..9a75a9a211d 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/META-INF/MANIFEST.MF
@@ -1,6 +1,7 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.emf.edit.ui;bundle-version="2.4.0",
- org.eclipse.papyrus.infra.core;bundle-version="0.9.0"
+ org.eclipse.papyrus.infra.core;bundle-version="0.9.0",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0"
Export-Package: org.eclipse.papyrus.views.properties.tabbedproperties.core,
org.eclipse.papyrus.views.properties.tabbedproperties.core.providers
Bundle-Vendor: %providerName
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF
index bf0206be1b2..d05d8f37a7e 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF
@@ -42,7 +42,8 @@ Require-Bundle: com.ibm.icu,
org.eclipse.emf.facet.infra.query;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.query.core;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.common.core;bundle-version="0.1.0",
- org.eclipse.papyrus.views.modelexplorer.widgets;bundle-version="0.9.0"
+ org.eclipse.papyrus.views.modelexplorer.widgets;bundle-version="0.9.0",
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0"
Bundle-Vendor: %Bundle-Vendor
Bundle-Version: 0.9.0.qualifier
Eclipse-BuddyPolicy: dependent

Back to the top