Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaged Elaasar2018-04-04 23:16:09 +0000
committerQuentin Le Menez2018-05-31 19:48:16 +0000
commit83a61595154affeb0085144c21df270f0923e705 (patch)
tree2633b7a815dc701dd153f3a875ffa14eb1a87af3 /plugins/views
parent5b741694e83316ae55fccfa5b950e636d47d4a87 (diff)
downloadorg.eclipse.papyrus-83a61595154affeb0085144c21df270f0923e705.tar.gz
org.eclipse.papyrus-83a61595154affeb0085144c21df270f0923e705.tar.xz
org.eclipse.papyrus-83a61595154affeb0085144c21df270f0923e705.zip
Bug 532101: [AFViewpoints] Make AF editor faster
Bug 532104: [AFViewpoints] Transform your Workspace reference to platform reference - Simplified the AF model wizard by defaulting the root to be Architecture Domain. - Extended the Load Resource action in the AF editor to allow loading AF models from the running platfom. - Added a Resolve All action that can be used on any object in the editor to quickly resolve related references. This can be used on a loaded AF model (from workspace or running platform) to also load its dependencies like elementtypeconfigurtion and palleteconfiguration files. - Made the architecture, elementtypesetconfigurtion, nattableconfiguration, and paletteconfiguration resources extend of a common base class that supports default load/save options. This base class also makes the cross references persist using platform:/platform URIs but upon load, they may resolve to platform:/resource if the resource is available in the workspace. - Refactored uml.architecture, all the elementtypeconfiguration, all palletteconfiguration, and all nattableconfiguration models by changing their cross references to platform:/plugin URI format. - Fixed PasteEObjectConfigurationItemProvider to make the containment reference axisIdentifier show in the editor/property sheet as a containment reference (was necessary to convert its cross references properly) Change-Id: I69b82f53670cbb81e9117ce82c61d7c898080c93 Signed-off-by: Maged Elaasar <melaasar@gmail.com>
Diffstat (limited to 'plugins/views')
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation/META-INF/MANIFEST.MF2
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.newchild/META-INF/MANIFEST.MF4
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.newchild/pom.xml2
3 files changed, 4 insertions, 4 deletions
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation/META-INF/MANIFEST.MF b/plugins/views/documentation/org.eclipse.papyrus.views.documentation/META-INF/MANIFEST.MF
index f68dd0ac0fc..0d2721dae37 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation/META-INF/MANIFEST.MF
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation/META-INF/MANIFEST.MF
@@ -16,7 +16,7 @@ Require-Bundle: org.eclipse.papyrus.infra.services.navigation;bundle-version="[3
org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.tools;bundle-version="[4.0.0,5.0.0)",
org.eclipse.papyrus.uml.documentation.profile;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.uml.types.core;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.uml.types.core;bundle-version="[4.0.0,5.0.0)",
org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.newchild/META-INF/MANIFEST.MF b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.newchild/META-INF/MANIFEST.MF
index 2c8d6385f57..b9607eaf449 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.newchild/META-INF/MANIFEST.MF
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.newchild/META-INF/MANIFEST.MF
@@ -1,9 +1,9 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.infra.newchild;bundle-version="[3.0.0,4.0.0)",
+Require-Bundle: org.eclipse.papyrus.infra.newchild;bundle-version="[4.0.0,5.0.0)",
org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 1.2.100.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.views.modelexplorer.newchild.Activator
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.newchild/pom.xml b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.newchild/pom.xml
index 64c3a781aeb..9fec4337228 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.newchild/pom.xml
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.newchild/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.views.modelexplorer.newchild</artifactId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>1.2.100-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>

Back to the top