Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcletavernie2012-09-17 13:28:15 +0000
committercletavernie2012-09-17 13:28:15 +0000
commitb00718aa2138c1ce5a34eb592d91d178a9803f8e (patch)
tree7bb9144a6f21f862334f6a495f809b122ca99fbd /plugins/infra/org.eclipse.papyrus.infra.extendedtypes.emf
parentbd209383ecf3ad359021d1c9e8633201afc36f17 (diff)
downloadorg.eclipse.papyrus-b00718aa2138c1ce5a34eb592d91d178a9803f8e.tar.gz
org.eclipse.papyrus-b00718aa2138c1ce5a34eb592d91d178a9803f8e.tar.xz
org.eclipse.papyrus-b00718aa2138c1ce5a34eb592d91d178a9803f8e.zip
380517: [Papyrus] We should use explicit plug-in dependencies whenever possible
https://bugs.eclipse.org/bugs/show_bug.cgi?id=380517 + removed some unused dependencies and imports
Diffstat (limited to 'plugins/infra/org.eclipse.papyrus.infra.extendedtypes.emf')
-rw-r--r--plugins/infra/org.eclipse.papyrus.infra.extendedtypes.emf/META-INF/MANIFEST.MF12
1 files changed, 7 insertions, 5 deletions
diff --git a/plugins/infra/org.eclipse.papyrus.infra.extendedtypes.emf/META-INF/MANIFEST.MF b/plugins/infra/org.eclipse.papyrus.infra.extendedtypes.emf/META-INF/MANIFEST.MF
index 431ee881724..c6a8d18f0ff 100644
--- a/plugins/infra/org.eclipse.papyrus.infra.extendedtypes.emf/META-INF/MANIFEST.MF
+++ b/plugins/infra/org.eclipse.papyrus.infra.extendedtypes.emf/META-INF/MANIFEST.MF
@@ -12,14 +12,16 @@ Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: org.eclipse.core.runtime;bundle-version="3.7.0",
org.eclipse.emf.ecore;bundle-version="2.7.0";visibility:=reexport,
org.eclipse.emf.ecore.xmi;bundle-version="2.6.0";visibility:=reexport,
- org.eclipse.papyrus.infra.queries.core.configuration;bundle-version="0.9.0";visibility:=reexport,
- org.eclipse.papyrus.infra.extendedtypes;bundle-version="0.9.0";visibility:=reexport,
- org.eclipse.emf.facet.infra.query;bundle-version="0.1.0";visibility:=reexport,
- org.eclipse.uml2.uml;bundle-version="3.2.0";visibility:=reexport,
+ org.eclipse.papyrus.infra.queries.core.configuration;bundle-version="0.9.0",
+ org.eclipse.papyrus.infra.extendedtypes;bundle-version="0.9.0",
+ org.eclipse.emf.facet.infra.query;bundle-version="0.1.0",
+ org.eclipse.uml2.uml;bundle-version="3.2.0",
org.eclipse.papyrus.infra.core.log;bundle-version="0.9.0",
org.eclipse.ui;bundle-version="3.7.0",
org.eclipse.papyrus.infra.services.edit;bundle-version="0.9.0",
- org.eclipse.papyrus.infra.queries.core;bundle-version="0.9.0"
+ org.eclipse.papyrus.infra.queries.core;bundle-version="0.9.0",
+ org.eclipse.gmf.runtime.common.core;bundle-version="1.4.1",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.4.0"
Bundle-Vendor: %providerName
Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2

Back to the top