Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian W. Damus2016-01-05 22:18:11 +0000
committerGerrit Code Review @ Eclipse.org2016-01-06 15:25:33 +0000
commit1dbd408ab7427b161e0ee1e02ab9413a646bd178 (patch)
treef9f73c0d4e2fc16dae81a9ce59e25905752153ce /plugins/infra/emf
parent9ea592c056e4782a66b38f9941d3797af2dfb956 (diff)
downloadorg.eclipse.papyrus-1dbd408ab7427b161e0ee1e02ab9413a646bd178.tar.gz
org.eclipse.papyrus-1dbd408ab7427b161e0ee1e02ab9413a646bd178.tar.xz
org.eclipse.papyrus-1dbd408ab7427b161e0ee1e02ab9413a646bd178.zip
Bug 485220: Remove some unused dependencies in infra layer
https://bugs.eclipse.org/bugs/show_bug.cgi?id=485220 Simple removal of dependencies declared in the manifests of infra layer bundles that aren't used by those bundles. Some of these dependencies are invalid (UI dependencies in core bundles, misplaced UML or GMF/GEF dependencies, etc.) that confuse the architectural analysis.
Diffstat (limited to 'plugins/infra/emf')
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF13
2 files changed, 1 insertions, 16 deletions
diff --git a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF b/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF
index fb44ff7d726..54b2a39e6c8 100644
--- a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF
+++ b/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF
@@ -3,12 +3,8 @@ Export-Package: org.eclipse.papyrus.infra.emf.readonly,
org.eclipse.papyrus.infra.emf.readonly.handlers
Require-Bundle: org.eclipse.papyrus.infra.onefile;bundle-version="1.2.0",
org.eclipse.core.expressions;bundle-version="3.4.300",
- org.eclipse.core.resources;bundle-version="3.7.0",
- org.eclipse.core.runtime;bundle-version="3.7.0",
- org.eclipse.emf.transaction;bundle-version="1.4.0",
org.eclipse.emf.workspace;bundle-version="1.4.0",
org.eclipse.gmf.runtime.common.core;bundle-version="1.4.1",
- org.eclipse.jface;bundle-version="3.8.0",
org.eclipse.ui,
org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="1.2.0",
diff --git a/plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF b/plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF
index a8f0a3d3eca..6df6c79fa58 100644
--- a/plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF
+++ b/plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF
@@ -12,26 +12,15 @@ Export-Package: org.eclipse.papyrus.infra.emf,
org.eclipse.papyrus.infra.emf.resource,
org.eclipse.papyrus.infra.emf.resource.index,
org.eclipse.papyrus.infra.emf.utils
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.emf.ecore;bundle-version="2.7.0",
- org.eclipse.emf.edit;bundle-version="2.7.1",
- org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
+Require-Bundle: org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
org.eclipse.papyrus.infra.widgets;bundle-version="1.2.0",
org.eclipse.emf.edit.ui;bundle-version="2.8.0",
- org.eclipse.core.databinding;bundle-version="1.4.1",
- org.eclipse.core.databinding.property;bundle-version="1.4.0",
org.eclipse.emf.databinding;bundle-version="1.2.0",
org.eclipse.papyrus.infra.tools;bundle-version="1.2.0",
- org.eclipse.emf.transaction;bundle-version="1.4.0",
- org.eclipse.emf.ecore.xmi,
- com.ibm.icu;bundle-version="4.4.2",
org.eclipse.papyrus.infra.core;bundle-version="1.2.0",
org.eclipse.papyrus.infra.services.labelprovider;bundle-version="1.2.0",
org.eclipse.gmf.runtime.notation;bundle-version="1.5.0",
org.eclipse.core.expressions;bundle-version="3.4.400",
- org.eclipse.gmf.runtime.common.core;bundle-version="1.7.0",
- org.eclipse.gmf.runtime.emf.commands.core;bundle-version="1.4.0",
org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.7.0",
com.google.guava;bundle-version="11.0.0",
org.eclipse.papyrus.emf.facet.custom.ui;bundle-version="1.2.0",

Back to the top