Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian W. Damus2015-02-10 15:34:02 +0000
committerChristian W. Damus2015-02-11 14:31:33 +0000
commit0b8eef8e59cb91fb3b0348e3f82a474bf06e4ad4 (patch)
treed3196c2cd734d2bf4e683a1b3bc3a756c81114a2 /plugins/editor/org.eclipse.papyrus.editor/META-INF/MANIFEST.MF
parent47a579d759aa402fc63cde46060488164a4b5a44 (diff)
downloadorg.eclipse.papyrus-0b8eef8e59cb91fb3b0348e3f82a474bf06e4ad4.tar.gz
org.eclipse.papyrus-0b8eef8e59cb91fb3b0348e3f82a474bf06e4ad4.tar.xz
org.eclipse.papyrus-0b8eef8e59cb91fb3b0348e3f82a474bf06e4ad4.zip
Bug 459566: [Releng] Consider letting Tycho use JDT's project settings for compilation
https://bugs.eclipse.org/bugs/show_bug.cgi?id=459566 Add Tycho compiler's <useProjectSettings> to the plug-in management in the main top POM to ensure that each project's build preferences are respected. This does require removing a few {@link}/@see references to restricted API in doc comments to work around a bug in Tycho (459554). A great many plug-in projects using 1.6 source constructs (mostly @Override of abstract methods) failed to declare 1.6 requirement either in the BREE, or the classpath/compiler settings, or both. Change-Id: Ia73b592fff8d46eaf0bc628b6e21d1e758ff0c64
Diffstat (limited to 'plugins/editor/org.eclipse.papyrus.editor/META-INF/MANIFEST.MF')
-rw-r--r--plugins/editor/org.eclipse.papyrus.editor/META-INF/MANIFEST.MF2
1 files changed, 1 insertions, 1 deletions
diff --git a/plugins/editor/org.eclipse.papyrus.editor/META-INF/MANIFEST.MF b/plugins/editor/org.eclipse.papyrus.editor/META-INF/MANIFEST.MF
index 0fb21be4f30..c233d353a00 100644
--- a/plugins/editor/org.eclipse.papyrus.editor/META-INF/MANIFEST.MF
+++ b/plugins/editor/org.eclipse.papyrus.editor/META-INF/MANIFEST.MF
@@ -16,5 +16,5 @@ Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.editor.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.editor;singleton:=true
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6

Back to the top