Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortlandre2009-10-15 17:37:00 +0000
committertlandre2009-10-15 17:37:00 +0000
commitfd1899f4bb8669f58e6932a367bdd8b2f1534979 (patch)
tree4cf92a9749987f8b10b70604f50049ebd304368d /features
parent8992e27d39c9e52f560594510487dcd03a6c444e (diff)
downloadorg.eclipse.papyrus-fd1899f4bb8669f58e6932a367bdd8b2f1534979.tar.gz
org.eclipse.papyrus-fd1899f4bb8669f58e6932a367bdd8b2f1534979.tar.xz
org.eclipse.papyrus-fd1899f4bb8669f58e6932a367bdd8b2f1534979.zip
update feature
Diffstat (limited to 'features')
-rw-r--r--features/org.eclipse.papyrus-feature/feature.xml351
1 files changed, 29 insertions, 322 deletions
diff --git a/features/org.eclipse.papyrus-feature/feature.xml b/features/org.eclipse.papyrus-feature/feature.xml
index 72d0d33cdeb..f81ec8920ff 100644
--- a/features/org.eclipse.papyrus-feature/feature.xml
+++ b/features/org.eclipse.papyrus-feature/feature.xml
@@ -1,349 +1,56 @@
<?xml version="1.0" encoding="UTF-8"?>
<feature
- id="org.eclipse.papyrus-feature"
+ id="org.eclipse.papyrus_feature"
label="MDT Papyrus"
version="0.7.0.qualifier"
provider-name="Eclipse">
<description url="http://www.example.com/description">
- Papyrus 0.7 M1 Version
+ MDT Papyrus editor
</description>
<copyright url="http://www.example.com/copyright">
[Enter Copyright Description here.]
</copyright>
- <license url="http://www.example.com/license">
- [Enter License Description here.]
+ <license url="http://www.eclipse.org/legal/epl/notice.php">
+ September 23, 2009
+
+The Eclipse Foundation makes available all content in this plug-in (&quot;Content&quot;). Unless otherwise indicated below, the Content is provided to you under the terms and conditions of the Eclipse Public License Version 1.0 (&quot;EPL&quot;). A copy of the EPL is available at http://www.eclipse.org/legal/epl-v10.html. For purposes of the EPL, &quot;Program&quot; will mean the Content.
+
+If you did not receive this Content directly from the Eclipse Foundation, the Content is being redistributed by another party (&quot;Redistributor&quot;) and different terms and conditions may apply to your use of any object code in the Content. Check the Redistributor&apos;s license that was provided with the Content. If no such license exists, contact the Redistributor. Unless otherwise indicated below, the terms and conditions of the EPL still apply to any source code in the Content and such source code may be obtained at http://www.eclipse.org.
</license>
<url>
<discovery label="MDT Papyrus" url="http://www.eclipse.org/modeling/mdt/?project=papyrus#papyrus"/>
</url>
- <requires>
- <import plugin="org.eclipse.ui"/>
- <import plugin="org.eclipse.core.runtime"/>
- <import plugin="org.eclipse.emf.ecore" version="2.4.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.codegen.ecore" version="2.4.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.gmf.codegen" version="2.1.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.gmf.codegen.ui" version="1.1.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.m2m.qvt.oml" version="2.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.papyrus.sasheditor" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ui.ide" version="3.4.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui" version="1.1.0" match="greaterOrEqual"/>
- <import plugin="org.junit"/>
- <import plugin="org.eclipse.papyrus.sasheditor.di" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.papyrus.core" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.gef" version="3.4.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.uml2.uml" version="2.2.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.edit" version="2.4.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.uml2.uml.edit" version="2.2.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.core.resources" version="3.4.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.ecore.xmi" version="2.4.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.papyrus.di" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.papyrus.core.adaptor.gmf" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.papyrus.diagram.common" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.gmf.runtime.common.ui.services.action"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.providers" version="1.1.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ocl.ecore" version="1.2.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ui.navigator" version="3.3.100" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ui.navigator.resources" version="3.3.100" match="greaterOrEqual"/>
- <import plugin="org.eclipse.core.expressions" version="3.4.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.printing" version="1.1.2" match="greaterOrEqual"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.printing.render" version="1.1.2" match="greaterOrEqual"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.properties" version="1.2.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.jface"/>
- <import plugin="org.eclipse.ui.views"/>
- <import plugin="org.eclipse.gmf.runtime.emf.core"/>
- <import plugin="org.eclipse.gmf.runtime.emf.commands.core"/>
- <import plugin="org.eclipse.gmf.runtime.emf.ui.properties"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.providers.ide"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.render"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.resources.editor.ide"/>
- <import plugin="org.eclipse.gmf.runtime.draw2d.ui"/>
- <import plugin="org.eclipse.gmf" version="1.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.validation"/>
- <import plugin="org.eclipse.papyrus.editor" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.draw2d"/>
- <import plugin="org.eclipse.gmf.codegen" version="2.1.1" match="greaterOrEqual"/>
- <import plugin="org.eclipse.uml2.uml.resources" version="3.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.papyrus.umlutils" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.query.ocl"/>
- <import plugin="org.eclipse.papyrus.extensionpoints.editors" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.papyrus.core.adaptor.emf" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.transaction" version="1.2.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.papyrus.preferences" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.papyrus.ui.toolbox" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ui.editors" version="3.4.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.edit.ui" version="2.4.0" match="greaterOrEqual"/>
- <import plugin="org.antlr.runtime" version="3.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ui.views.properties.tabbed" version="3.4.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.mapping.ecore2xml"/>
- <import plugin="org.eclipse.ui" version="3.5.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ui.navigator" version="3.3.101" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.ecore.editor" version="2.4.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.uml2.uml.editor" version="2.2.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.render" version="1.2.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.jface.text"/>
- <import plugin="org.eclipse.papyrus.extensionpoints.uml2" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.properties" version="1.1.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.ecore.xmi" version="2.5.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.transaction" version="1.3.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.swt" version="3.5.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.eef.runtime"/>
- <import plugin="org.eclipse.jface" version="3.4.1" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.transaction" version="1.2.1" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.ecore.edit" version="2.4.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.edit.ui" version="2.5.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.emf.ecore.edit" version="2.5.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.resources.editor" version="1.2.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.papyrus.wizards" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.uml2.uml.editor" version="3.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.uml2.diagram.common.notation" version="0.9.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.uml2.diagram.common" version="0.9.0" match="greaterOrEqual"/>
- <import plugin="org.junit4"/>
- <import plugin="org.eclipse.emf.ecore.editor" version="2.5.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.uml2.uml.edit" version="3.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.papyrus.navigator" version="0.7.0" match="greaterOrEqual"/>
- </requires>
+ <includes
+ id="org.eclipse.papyrus.backbone_feature"
+ version="0.0.0"/>
- <plugin
- id="org.eclipse.papyrus.codegen"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
+ <includes
+ id="org.eclipse.papyrus.diagram.clazz_feature"
+ version="0.0.0"/>
- <plugin
- id="org.eclipse.papyrus.core"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
+ <includes
+ id="org.eclipse.papyrus.diagram.composite_feature"
+ version="0.0.0"/>
- <plugin
- id="org.eclipse.papyrus.core.adaptor.emf"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
+ <includes
+ id="org.eclipse.papyrus.diagram.sequence_feature"
+ version="0.0.0"/>
- <plugin
- id="org.eclipse.papyrus.core.adaptor.gmf"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
+ <includes
+ id="org.eclipse.papyrus.diagram.usecase_feature"
+ version="0.0.0"/>
- <plugin
- id="org.eclipse.papyrus.def"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
+ <includes
+ id="org.eclipse.papyrus.layouttool_feature"
+ version="0.0.0"/>
- <plugin
- id="org.eclipse.papyrus.di"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.di.edit"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.di.editor"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.diagram.activity"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.diagram.clazz"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.diagram.common"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.diagram.composite"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.diagram.emftree"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.diagram.sequence"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.diagram.usecase"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.editor"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.extensionpoints.editors"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.extensionpoints.uml2"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.gmfgenextension"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.navigator"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.outline"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.outline.emftree"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.parsers"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.preferences"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.profile"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.sasheditor"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.sasheditor.di"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.tabbedproperties.appearance"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.tabbedproperties.core"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.tabbedproperties.uml"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.ui.toolbox"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.umlutils"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.wizards"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
- id="org.eclipse.papyrus.perspective"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
+ <includes
+ id="org.eclipse.papyrus.uml_feature"
+ version="0.0.0"/>
</feature>

Back to the top