Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancois Le Fevre2016-12-12 12:35:13 +0000
committerPatrick Tessier2017-01-24 09:09:53 +0000
commitc17f31093db8affdbb1514e477a2e59e6830b224 (patch)
treeb8c147a3ffea01c026d105f46070955106607883 /extraplugins
parent8018f968401e39eb3b2a03ab22391e9a22b369a0 (diff)
downloadorg.eclipse.papyrus-c17f31093db8affdbb1514e477a2e59e6830b224.tar.gz
org.eclipse.papyrus-c17f31093db8affdbb1514e477a2e59e6830b224.tar.xz
org.eclipse.papyrus-c17f31093db8affdbb1514e477a2e59e6830b224.zip
Bug 508843 - [Toolsmiths] migrate expansion model into its own plugin
-just moving exapnasion model into its own plugin -reexporting the different package -updating manifest.mf with this new plugin -package renaming with genmodel update -moving to right bundle version in a manifest.mf -adding it into its feature -retrigger after merge conflict resolution -dispatching class in their own package Change-Id: If81918a014ca46e67a9e6fb60b1e0bf21c5645ab Signed-off-by: Francois Le Fevre <francois.le-fevre@cea.fr>
Diffstat (limited to 'extraplugins')
-rw-r--r--extraplugins/EFFBD/org.eclipse.papyrus.effbd/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/bmm/org.eclipse.papyrus.bmm.diagram/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram.collaboration/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram.common/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram.process/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/cdo/org.eclipse.papyrus.cdo.ui.hyperlink/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/cdo/org.eclipse.papyrus.cdo.ui/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/diagram-definition/org.eclipse.papyrus.notation.qvt/META-INF/MANIFEST.MF4
-rw-r--r--extraplugins/diagramtemplate/org.eclipse.papyrus.diagramtemplate.editor/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/layers/org.eclipse.papyrus.layers.integrationtests/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/layers/org.eclipse.papyrus.layers.runtime/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/migration/org.eclipse.papyrus.migration.rsa/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/migration/rhapsody/org.eclipse.papyrus.migration.rhapsody.blackboxes/META-INF/MANIFEST.MF2
-rwxr-xr-xextraplugins/migration/rhapsody/org.eclipse.papyrus.migration.rhapsody/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/refactoring/org.eclipse.papyrus.uml.refactoring.mutation/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/revision/org.eclipse.papyrus.revisiontool/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/tablemigration/org.eclipse.papyrus.infra.emf.nattable.converter/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/uml/org.eclipse.papyrus.uml.diagram.dnd.smart/META-INF/MANIFEST.MF2
20 files changed, 21 insertions, 21 deletions
diff --git a/extraplugins/EFFBD/org.eclipse.papyrus.effbd/META-INF/MANIFEST.MF b/extraplugins/EFFBD/org.eclipse.papyrus.effbd/META-INF/MANIFEST.MF
index 28ea296cb59..2c4eaa8f83a 100644
--- a/extraplugins/EFFBD/org.eclipse.papyrus.effbd/META-INF/MANIFEST.MF
+++ b/extraplugins/EFFBD/org.eclipse.papyrus.effbd/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.types.core;bundle-version="1.1.0",
org.eclipse.papyrus.uml.diagram.common;bundle-version="1.1.0",
org.eclipse.papyrus.uml.diagram.composite;bundle-version="1.1.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.1.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.gef,
org.eclipse.papyrus.infra.gmfdiag.commands,
org.eclipse.papyrus.infra.core;bundle-version="1.1.3",
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/META-INF/MANIFEST.MF b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/META-INF/MANIFEST.MF
index aa339514ef8..84668ba18f2 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/META-INF/MANIFEST.MF
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/META-INF/MANIFEST.MF
@@ -17,7 +17,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.adl4eclipse.profile,
org.eclipse.papyrus.uml.diagram.common;bundle-version="1.2.0",
org.eclipse.papyrus.uml.diagram.clazz;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.2.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.osgi.profile,
org.eclipse.core.expressions;bundle-version="3.5.0",
org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
diff --git a/extraplugins/bmm/org.eclipse.papyrus.bmm.diagram/META-INF/MANIFEST.MF b/extraplugins/bmm/org.eclipse.papyrus.bmm.diagram/META-INF/MANIFEST.MF
index e79a2ea4b18..44f60ff9382 100644
--- a/extraplugins/bmm/org.eclipse.papyrus.bmm.diagram/META-INF/MANIFEST.MF
+++ b/extraplugins/bmm/org.eclipse.papyrus.bmm.diagram/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.uml.tools.utils;bundle-version="1.2.0",
org.eclipse.papyrus.uml.diagram.common;bundle-version="1.2.0",
org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.2.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.diagram.composite;bundle-version="1.2.0",
org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
org.eclipse.papyrus.uml.tools;bundle-version="1.2.0",
diff --git a/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram.collaboration/META-INF/MANIFEST.MF b/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram.collaboration/META-INF/MANIFEST.MF
index 9614d91e96a..527d3c3d210 100644
--- a/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram.collaboration/META-INF/MANIFEST.MF
+++ b/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram.collaboration/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.bpmn;bundle-version="0.7.0",
org.eclipse.papyrus.bpmn.diagram.common;bundle-version="0.7.0",
org.eclipse.papyrus.bpmn.diagram.ui;bundle-version="0.7.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="0.7.0",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.gmf.runtime.notation.edit,
org.eclipse.gmf.runtime.diagram.core,
org.eclipse.papyrus.uml.diagram.activity,
diff --git a/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram.common/META-INF/MANIFEST.MF b/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram.common/META-INF/MANIFEST.MF
index 5fc43152c06..7c8f9c3864e 100644
--- a/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram.common/META-INF/MANIFEST.MF
+++ b/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram.common/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Require-Bundle: org.eclipse.papyrus.uml.tools.utils;bundle-version="1.2.0",
org.eclipse.papyrus.bpmn;bundle-version="0.7.0",
org.eclipse.papyrus.uml.diagram.common;bundle-version="1.2.0",
org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.2.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.diagram.composite;bundle-version="1.2.0",
org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
org.eclipse.papyrus.uml.tools;bundle-version="1.2.0",
diff --git a/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram.process/META-INF/MANIFEST.MF b/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram.process/META-INF/MANIFEST.MF
index b81b68210ed..7cdb5fa6f11 100644
--- a/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram.process/META-INF/MANIFEST.MF
+++ b/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram.process/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.bpmn;bundle-version="0.7.0",
org.eclipse.papyrus.bpmn.diagram.common;bundle-version="0.7.0",
org.eclipse.papyrus.bpmn.diagram.ui;bundle-version="0.7.0",
- org.eclipse.papyrus.uml.diagram.common;bundle-version="0.7.0",
+ org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.gmf.runtime.notation.edit,
org.eclipse.gmf.runtime.diagram.core,
org.eclipse.papyrus.uml.diagram.activity,
diff --git a/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram/META-INF/MANIFEST.MF b/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram/META-INF/MANIFEST.MF
index 2015d4aae88..63bfdea930d 100644
--- a/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram/META-INF/MANIFEST.MF
+++ b/extraplugins/bpmn/org.eclipse.papyrus.bpmn.diagram/META-INF/MANIFEST.MF
@@ -10,7 +10,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.uml.tools.utils;bundle-version="1.2.0",
org.eclipse.papyrus.uml.diagram.common;bundle-version="1.2.0",
org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.2.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.diagram.composite;bundle-version="1.2.0",
org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
org.eclipse.papyrus.uml.tools;bundle-version="1.2.0",
diff --git a/extraplugins/cdo/org.eclipse.papyrus.cdo.ui.hyperlink/META-INF/MANIFEST.MF b/extraplugins/cdo/org.eclipse.papyrus.cdo.ui.hyperlink/META-INF/MANIFEST.MF
index 52fa7225715..2555e8d7db8 100644
--- a/extraplugins/cdo/org.eclipse.papyrus.cdo.ui.hyperlink/META-INF/MANIFEST.MF
+++ b/extraplugins/cdo/org.eclipse.papyrus.cdo.ui.hyperlink/META-INF/MANIFEST.MF
@@ -17,7 +17,7 @@ Require-Bundle: org.eclipse.ui;bundle-version="3.105.0",
2.0.0)",
org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.7.0,
2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.2.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
com.google.guava;bundle-version="11.0.0"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
diff --git a/extraplugins/cdo/org.eclipse.papyrus.cdo.ui/META-INF/MANIFEST.MF b/extraplugins/cdo/org.eclipse.papyrus.cdo.ui/META-INF/MANIFEST.MF
index 8344552be2b..210ff3d361e 100644
--- a/extraplugins/cdo/org.eclipse.papyrus.cdo.ui/META-INF/MANIFEST.MF
+++ b/extraplugins/cdo/org.eclipse.papyrus.cdo.ui/META-INF/MANIFEST.MF
@@ -34,7 +34,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.papyrus.cdo.core;bundle-version="1.2.0";visibility:=reexport,
org.eclipse.emf.cdo.ui;bundle-version="[4.3.0,5.0.0)";visibility:=reexport,
org.eclipse.emf.cdo.explorer.ui;bundle-version="[4.3.0,5.0.0)";visibility:=reexport,
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.2.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.emf.cdo.dawn;bundle-version="[2.0.0,3.0.0)",
org.eclipse.emf.cdo.dawn.gmf;bundle-version="[2.1.0,3.0.0)",
org.eclipse.emf.cdo.dawn.ui;bundle-version="[2.0.0,3.0.0)",
diff --git a/extraplugins/diagram-definition/org.eclipse.papyrus.notation.qvt/META-INF/MANIFEST.MF b/extraplugins/diagram-definition/org.eclipse.papyrus.notation.qvt/META-INF/MANIFEST.MF
index 79356085bca..4c3678bdf75 100644
--- a/extraplugins/diagram-definition/org.eclipse.papyrus.notation.qvt/META-INF/MANIFEST.MF
+++ b/extraplugins/diagram-definition/org.eclipse.papyrus.notation.qvt/META-INF/MANIFEST.MF
@@ -1,6 +1,6 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.uml.diagram.common;bundle-version="0.7.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="0.7.0"
+Require-Bundle: org.eclipse.papyrus.uml.diagram.common;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)"
Bundle-Vendor: %providerName
Bundle-Version: 0.7.0.qualifier
Bundle-Name: %pluginName
diff --git a/extraplugins/diagramtemplate/org.eclipse.papyrus.diagramtemplate.editor/META-INF/MANIFEST.MF b/extraplugins/diagramtemplate/org.eclipse.papyrus.diagramtemplate.editor/META-INF/MANIFEST.MF
index 856f969ce45..2eb16832fec 100644
--- a/extraplugins/diagramtemplate/org.eclipse.papyrus.diagramtemplate.editor/META-INF/MANIFEST.MF
+++ b/extraplugins/diagramtemplate/org.eclipse.papyrus.diagramtemplate.editor/META-INF/MANIFEST.MF
@@ -15,7 +15,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.6.0",
org.eclipse.papyrus.infra.core.sasheditor;bundle-version="1.2.0",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.2.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.ui;bundle-version="1.2.0",
org.eclipse.papyrus.infra.core.sashwindows.di;bundle-version="1.2.0"
Export-Package: org.eclipse.papyrus.diagramtemplate.editor,
diff --git a/extraplugins/layers/org.eclipse.papyrus.layers.integrationtests/META-INF/MANIFEST.MF b/extraplugins/layers/org.eclipse.papyrus.layers.integrationtests/META-INF/MANIFEST.MF
index b6a967b6771..fe353413ba1 100644
--- a/extraplugins/layers/org.eclipse.papyrus.layers.integrationtests/META-INF/MANIFEST.MF
+++ b/extraplugins/layers/org.eclipse.papyrus.layers.integrationtests/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Require-Bundle: org.eclipse.papyrus.layers.runtime;bundle-version="1.2.0",
org.eclipse.papyrus.integrationtests.editor;bundle-version="1.2.0",
org.eclipse.emf.ecore;bundle-version="2.10.0",
org.eclipse.papyrus.infra.core;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.2.0"
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)"
Bundle-Vendor: %providerName
Bundle-Version: 1.2.0.qualifier
Bundle-Name: %pluginName
diff --git a/extraplugins/layers/org.eclipse.papyrus.layers.runtime/META-INF/MANIFEST.MF b/extraplugins/layers/org.eclipse.papyrus.layers.runtime/META-INF/MANIFEST.MF
index 00c5afc6eb8..ed1640923b9 100644
--- a/extraplugins/layers/org.eclipse.papyrus.layers.runtime/META-INF/MANIFEST.MF
+++ b/extraplugins/layers/org.eclipse.papyrus.layers.runtime/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.junit,
org.eclipse.papyrus.infra.core;bundle-version="1.2.0",
org.eclipse.core.resources;bundle-version="3.8.100",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.2.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0"
Export-Package: org.eclipse.papyrus.layers.runtime,
org.eclipse.papyrus.layers.runtime.model,
diff --git a/extraplugins/migration/org.eclipse.papyrus.migration.rsa/META-INF/MANIFEST.MF b/extraplugins/migration/org.eclipse.papyrus.migration.rsa/META-INF/MANIFEST.MF
index d1a8baae7f3..e5d9c53acce 100644
--- a/extraplugins/migration/org.eclipse.papyrus.migration.rsa/META-INF/MANIFEST.MF
+++ b/extraplugins/migration/org.eclipse.papyrus.migration.rsa/META-INF/MANIFEST.MF
@@ -24,7 +24,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.core;bundle-version="1.2.0",
org.eclipse.papyrus.infra.properties.ui;bundle-version="1.2.0",
org.eclipse.papyrus.infra.widgets;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.2.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.constraints;bundle-version="1.2.0",
org.eclipse.papyrus.infra.services.labelprovider;bundle-version="1.2.0",
org.eclipse.swt,
diff --git a/extraplugins/migration/rhapsody/org.eclipse.papyrus.migration.rhapsody.blackboxes/META-INF/MANIFEST.MF b/extraplugins/migration/rhapsody/org.eclipse.papyrus.migration.rhapsody.blackboxes/META-INF/MANIFEST.MF
index 266e8c55ee9..a60d586273c 100644
--- a/extraplugins/migration/rhapsody/org.eclipse.papyrus.migration.rhapsody.blackboxes/META-INF/MANIFEST.MF
+++ b/extraplugins/migration/rhapsody/org.eclipse.papyrus.migration.rhapsody.blackboxes/META-INF/MANIFEST.MF
@@ -16,7 +16,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.migration.rhapsody.geometry;bundle-version="0.7.0",
org.eclipse.gmf.runtime.draw2d.ui;bundle-version="1.9.0",
org.eclipse.draw2d;bundle-version="3.10.100",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="3.0.0"
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Bundle-Description: This plugin contains only blackboxes. We don't store them in the QVTO transformations plugin to ease development of them and solve local compilation troubles.
diff --git a/extraplugins/migration/rhapsody/org.eclipse.papyrus.migration.rhapsody/META-INF/MANIFEST.MF b/extraplugins/migration/rhapsody/org.eclipse.papyrus.migration.rhapsody/META-INF/MANIFEST.MF
index 5aab2e7143e..8b9434a8a7d 100755
--- a/extraplugins/migration/rhapsody/org.eclipse.papyrus.migration.rhapsody/META-INF/MANIFEST.MF
+++ b/extraplugins/migration/rhapsody/org.eclipse.papyrus.migration.rhapsody/META-INF/MANIFEST.MF
@@ -31,7 +31,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.migration.rhapsody.metamodel;bundle-version="0.7.0",
org.eclipse.gmf.runtime.emf.type.core,
org.eclipse.gmf.runtime.diagram.core,
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="3.0.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.core;bundle-version="2.3.0",
org.eclipse.papyrus.infra.tools;bundle-version="2.0.100",
org.eclipse.papyrus.infra.widgets;bundle-version="3.0.0",
diff --git a/extraplugins/refactoring/org.eclipse.papyrus.uml.refactoring.mutation/META-INF/MANIFEST.MF b/extraplugins/refactoring/org.eclipse.papyrus.uml.refactoring.mutation/META-INF/MANIFEST.MF
index 683ce845cf2..a5c90152a07 100644
--- a/extraplugins/refactoring/org.eclipse.papyrus.uml.refactoring.mutation/META-INF/MANIFEST.MF
+++ b/extraplugins/refactoring/org.eclipse.papyrus.uml.refactoring.mutation/META-INF/MANIFEST.MF
@@ -9,7 +9,7 @@ Require-Bundle: org.eclipse.ui;bundle-version="3.107.0",
org.eclipse.ltk.core.refactoring;bundle-version="3.6.200",
org.eclipse.ltk.ui.refactoring;bundle-version="3.7.200",
org.eclipse.uml2.uml;bundle-version="5.1.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.1.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.core;bundle-version="1.1.0",
org.eclipse.papyrus.infra.services.edit;bundle-version="1.1.0",
org.eclipse.papyrus.uml.service.types;bundle-version="2.0.0",
diff --git a/extraplugins/revision/org.eclipse.papyrus.revisiontool/META-INF/MANIFEST.MF b/extraplugins/revision/org.eclipse.papyrus.revisiontool/META-INF/MANIFEST.MF
index 92442be4432..fe28bbd03e1 100644
--- a/extraplugins/revision/org.eclipse.papyrus.revisiontool/META-INF/MANIFEST.MF
+++ b/extraplugins/revision/org.eclipse.papyrus.revisiontool/META-INF/MANIFEST.MF
@@ -30,7 +30,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.emf.facet.query.java.core;bundle-version="1.1.0",
org.eclipse.gmf.runtime.diagram.ui,
org.eclipse.papyrus.uml.diagram.common;bundle-version="1.1.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.1.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="1.1.0",
org.eclipse.papyrus.infra.services.edit,
org.eclipse.papyrus.infra.ui;bundle-version="1.2.0",
diff --git a/extraplugins/tablemigration/org.eclipse.papyrus.infra.emf.nattable.converter/META-INF/MANIFEST.MF b/extraplugins/tablemigration/org.eclipse.papyrus.infra.emf.nattable.converter/META-INF/MANIFEST.MF
index 873b30f8949..bcb3d28c249 100644
--- a/extraplugins/tablemigration/org.eclipse.papyrus.infra.emf.nattable.converter/META-INF/MANIFEST.MF
+++ b/extraplugins/tablemigration/org.eclipse.papyrus.infra.emf.nattable.converter/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.gmf.runtime.emf.type.core,
org.eclipse.papyrus.infra.services.edit;bundle-version="1.2.0",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.2.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.nattable.common;bundle-version="1.2.0"
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
diff --git a/extraplugins/uml/org.eclipse.papyrus.uml.diagram.dnd.smart/META-INF/MANIFEST.MF b/extraplugins/uml/org.eclipse.papyrus.uml.diagram.dnd.smart/META-INF/MANIFEST.MF
index 6a4ed5e164c..98994b91e6a 100644
--- a/extraplugins/uml/org.eclipse.papyrus.uml.diagram.dnd.smart/META-INF/MANIFEST.MF
+++ b/extraplugins/uml/org.eclipse.papyrus.uml.diagram.dnd.smart/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.services.labelprovider;bundle-version="1.2.0",
org.eclipse.papyrus.uml.diagram.composite;bundle-version="1.2.0",
org.eclipse.papyrus.emf.facet.custom.ui;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.2.0",
+ org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.services.edit;bundle-version="1.2.0"
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy

Back to the top