Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnsgar Radermacher2013-11-20 14:17:17 +0000
committerAnsgar Radermacher2013-11-20 14:17:17 +0000
commit0febd80da812a5a9915f5f79fe7a09a06cf628b7 (patch)
tree0a5fc648a53b756b3b9fdc6a69e85c27e7986bc1 /extraplugins
parentfe89f71d84cecf0e2fd8ce5ac17ebf49ea17222d (diff)
downloadorg.eclipse.papyrus-0febd80da812a5a9915f5f79fe7a09a06cf628b7.tar.gz
org.eclipse.papyrus-0febd80da812a5a9915f5f79fe7a09a06cf628b7.tar.xz
org.eclipse.papyrus-0febd80da812a5a9915f5f79fe7a09a06cf628b7.zip
- Re-added org.eclipse.emf.facet.infra.browser.uicore, since it was indirectly required (trivial).
- Cleaned warnings by removing non-existing icons folder in oep.qompass.designer.core (context: bug 420280: [QDesigner] separation of user interface and transformation plugin)
Diffstat (limited to 'extraplugins')
-rw-r--r--extraplugins/qompass-designer/org.eclipse.papyrus.qompass.designer.core/build.properties1
-rw-r--r--extraplugins/qompass-designer/org.eclipse.papyrus.qompass.designer.ui/META-INF/MANIFEST.MF1
-rw-r--r--extraplugins/qompass-designer/org.eclipse.papyrus.qompass.designer.validation/.settings/org.eclipse.jdt.core.prefs7
3 files changed, 8 insertions, 1 deletions
diff --git a/extraplugins/qompass-designer/org.eclipse.papyrus.qompass.designer.core/build.properties b/extraplugins/qompass-designer/org.eclipse.papyrus.qompass.designer.core/build.properties
index ac38eb76e73..ad54fffc889 100644
--- a/extraplugins/qompass-designer/org.eclipse.papyrus.qompass.designer.core/build.properties
+++ b/extraplugins/qompass-designer/org.eclipse.papyrus.qompass.designer.core/build.properties
@@ -3,7 +3,6 @@ output.. = bin/
bin.includes = META-INF/,\
.,\
plugin.xml,\
- icons/,\
build.properties,\
about.properties,\
build.acceleo,\
diff --git a/extraplugins/qompass-designer/org.eclipse.papyrus.qompass.designer.ui/META-INF/MANIFEST.MF b/extraplugins/qompass-designer/org.eclipse.papyrus.qompass.designer.ui/META-INF/MANIFEST.MF
index 3d78a64c0d3..a9377d65017 100644
--- a/extraplugins/qompass-designer/org.eclipse.papyrus.qompass.designer.ui/META-INF/MANIFEST.MF
+++ b/extraplugins/qompass-designer/org.eclipse.papyrus.qompass.designer.ui/META-INF/MANIFEST.MF
@@ -34,6 +34,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.widgets;bundle-version="1.0.0",
org.eclipse.papyrus.infra.emf;bundle-version="1.0.0",
org.eclipse.papyrus.acceleo;bundle-version="1.0.0",
+ org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.3.0",
org.eclipse.papyrus.infra.services.labelprovider;bundle-version="1.0.0",
org.eclipse.papyrus.uml.tools.utils;bundle-version="1.0.0",
org.eclipse.papyrus.infra.widgets.toolbox;bundle-version="1.0.0",
diff --git a/extraplugins/qompass-designer/org.eclipse.papyrus.qompass.designer.validation/.settings/org.eclipse.jdt.core.prefs b/extraplugins/qompass-designer/org.eclipse.papyrus.qompass.designer.validation/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 00000000000..af0f20f97a5
--- /dev/null
+++ b/extraplugins/qompass-designer/org.eclipse.papyrus.qompass.designer.validation/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
+org.eclipse.jdt.core.compiler.source=1.5

Back to the top