Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCamille Letavernier2014-04-03 17:00:58 +0000
committerCamille Letavernier2014-04-03 17:00:58 +0000
commit122ea68d4171acac15d0445d51113976840e5a77 (patch)
treeb4d2c97cec09baba461f9f40fd4116fee0f58145 /extraplugins
parentb88e0a99c563764b0d3bfabefd9941fc1f1e50de (diff)
downloadorg.eclipse.papyrus-122ea68d4171acac15d0445d51113976840e5a77.tar.gz
org.eclipse.papyrus-122ea68d4171acac15d0445d51113976840e5a77.tar.xz
org.eclipse.papyrus-122ea68d4171acac15d0445d51113976840e5a77.zip
[Releng] Remove unused dependencies to EMF Facet
Diffstat (limited to 'extraplugins')
-rw-r--r--extraplugins/dsml.validation/org.eclipse.papyrus.dsml.validation.model.ui/META-INF/MANIFEST.MF1
-rw-r--r--extraplugins/dsml.validation/org.eclipse.papyrus.dsml.validation/META-INF/MANIFEST.MF3
-rw-r--r--extraplugins/dsml.validation/org.eclipse.papyrus.dsml.validation/plugin.xml14
-rw-r--r--extraplugins/robotml/org.eclipse.papyrus.robotml.diagram.common/META-INF/MANIFEST.MF1
4 files changed, 16 insertions, 3 deletions
diff --git a/extraplugins/dsml.validation/org.eclipse.papyrus.dsml.validation.model.ui/META-INF/MANIFEST.MF b/extraplugins/dsml.validation/org.eclipse.papyrus.dsml.validation.model.ui/META-INF/MANIFEST.MF
index d04f87971a5..a41c16b7328 100644
--- a/extraplugins/dsml.validation/org.eclipse.papyrus.dsml.validation.model.ui/META-INF/MANIFEST.MF
+++ b/extraplugins/dsml.validation/org.eclipse.papyrus.dsml.validation.model.ui/META-INF/MANIFEST.MF
@@ -3,7 +3,6 @@ Export-Package: org.eclipse.papyrus.dsml.validation.generation.ui
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.uml2.uml;bundle-version="3.1.0",
- org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.1",
org.eclipse.papyrus.dsml.validation.wizard;bundle-version="1.0.0",
org.eclipse.papyrus.dsml.validation.model;bundle-version="1.0.0",
org.eclipse.papyrus.infra.core;bundle-version="1.0.0",
diff --git a/extraplugins/dsml.validation/org.eclipse.papyrus.dsml.validation/META-INF/MANIFEST.MF b/extraplugins/dsml.validation/org.eclipse.papyrus.dsml.validation/META-INF/MANIFEST.MF
index 847b35d4af2..e6657944925 100644
--- a/extraplugins/dsml.validation/org.eclipse.papyrus.dsml.validation/META-INF/MANIFEST.MF
+++ b/extraplugins/dsml.validation/org.eclipse.papyrus.dsml.validation/META-INF/MANIFEST.MF
@@ -1,7 +1,8 @@
Manifest-Version: 1.0
Export-Package: org.eclipse.papyrus.dsml.validation
Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime
+ org.eclipse.core.runtime,
+ org.eclipse.uml2.uml;bundle-version="5.0.0"
Bundle-Vendor: %pluginProvider
Bundle-ActivationPolicy: lazy
Bundle-Version: 1.0.0.qualifier
diff --git a/extraplugins/dsml.validation/org.eclipse.papyrus.dsml.validation/plugin.xml b/extraplugins/dsml.validation/org.eclipse.papyrus.dsml.validation/plugin.xml
index 7318917a64e..6096a87449d 100644
--- a/extraplugins/dsml.validation/org.eclipse.papyrus.dsml.validation/plugin.xml
+++ b/extraplugins/dsml.validation/org.eclipse.papyrus.dsml.validation/plugin.xml
@@ -18,4 +18,18 @@
provider="Eclipse Modeling Project">
</profile>
</extension>
+ <extension
+ point="org.eclipse.uml2.uml.dynamic_package">
+ <profile
+ location="pathmap://DSMLValidation_PROFILES/PapyrusValidationRuleDSML.uml#_0"
+ uri="pathmap://DSMLValidation_PROFILES/PapyrusValidationRuleDSML">
+ </profile>
+ </extension>
+ <extension
+ point="org.eclipse.emf.ecore.dynamic_package">
+ <resource
+ location="pathmap://DSMLValidation_PROFILES/PapyrusValidationRuleDSML.uml#_0"
+ uri="pathmap://DSMLValidation_PROFILES/PapyrusValidationRuleDSML">
+ </resource>
+ </extension>
</plugin>
diff --git a/extraplugins/robotml/org.eclipse.papyrus.robotml.diagram.common/META-INF/MANIFEST.MF b/extraplugins/robotml/org.eclipse.papyrus.robotml.diagram.common/META-INF/MANIFEST.MF
index 99851fd2b52..6b679c1d713 100644
--- a/extraplugins/robotml/org.eclipse.papyrus.robotml.diagram.common/META-INF/MANIFEST.MF
+++ b/extraplugins/robotml/org.eclipse.papyrus.robotml.diagram.common/META-INF/MANIFEST.MF
@@ -18,7 +18,6 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.papyrus.infra.emf;bundle-version="1.0.0",
org.eclipse.papyrus.uml.tools;bundle-version="1.0.0",
org.eclipse.papyrus.uml.diagram.communication;bundle-version="1.0.0",
- org.eclipse.emf.facet.infra.browser.uicore,
org.eclipse.ui.ide;bundle-version="3.9.0",
org.eclipse.gmf.runtime.notation.edit,
org.eclipse.papyrus.uml.diagram.clazz;bundle-version="1.0.0"

Back to the top