Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlorenzo2012-10-10 14:32:35 +0000
committervlorenzo2012-10-10 14:32:35 +0000
commitf0bf0ae717b49ef9736fc0e77e4ddc41667b41bd (patch)
tree4a47d009da3fe4427c92588bb1ab42d2d56bb14d /extraplugins/uml
parent74e29f88f1239c2084cea169e51b8324a79747e1 (diff)
downloadorg.eclipse.papyrus-f0bf0ae717b49ef9736fc0e77e4ddc41667b41bd.tar.gz
org.eclipse.papyrus-f0bf0ae717b49ef9736fc0e77e4ddc41667b41bd.tar.xz
org.eclipse.papyrus-f0bf0ae717b49ef9736fc0e77e4ddc41667b41bd.zip
391064: Unable to install Papyrus Compare editor in my workspace
https://bugs.eclipse.org/bugs/show_bug.cgi?id=391064 set the dependency on org.eclipse.ui to 3.8
Diffstat (limited to 'extraplugins/uml')
-rw-r--r--extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.common/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.diff/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.instance/META-INF/MANIFEST.MF3
-rw-r--r--extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.ui/META-INF/MANIFEST.MF1
-rw-r--r--extraplugins/uml/compare/org.eclipse.papyrus.uml.compare.diff/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/uml/compare/org.eclipse.papyrus.uml.compare.file/META-INF/MANIFEST.MF2
-rw-r--r--extraplugins/uml/compare/org.eclipse.papyrus.uml.compare/META-INF/MANIFEST.MF2
7 files changed, 8 insertions, 6 deletions
diff --git a/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.common/META-INF/MANIFEST.MF b/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.common/META-INF/MANIFEST.MF
index 2a5688f01a0..786191f5962 100644
--- a/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.common/META-INF/MANIFEST.MF
+++ b/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.common/META-INF/MANIFEST.MF
@@ -11,7 +11,7 @@ Require-Bundle: org.eclipse.papyrus.infra.emf.compare.instance;bundle-version="0
org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.2.0",
org.eclipse.papyrus.infra.emf;bundle-version="0.10.0",
org.eclipse.papyrus.infra.core.sasheditor;bundle-version="0.10.0",
- org.eclipse.ui,
+ org.eclipse.ui;bundle-version="3.8.0",
org.eclipse.papyrus.infra.core.log;bundle-version="0.10.0",
org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="0.10.0",
org.eclipse.papyrus.infra.core.sasheditor.di;bundle-version="0.10.0"
diff --git a/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.diff/META-INF/MANIFEST.MF b/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.diff/META-INF/MANIFEST.MF
index 6cee97758c5..31d171a990d 100644
--- a/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.diff/META-INF/MANIFEST.MF
+++ b/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.diff/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
+Require-Bundle: org.eclipse.ui;bundle-version="3.8.0",
org.eclipse.core.runtime,
org.eclipse.emf.ecore,
org.eclipse.emf.compare,
diff --git a/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.instance/META-INF/MANIFEST.MF b/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.instance/META-INF/MANIFEST.MF
index 34090d0977d..d0385f895cf 100644
--- a/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.instance/META-INF/MANIFEST.MF
+++ b/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.instance/META-INF/MANIFEST.MF
@@ -2,7 +2,8 @@ Manifest-Version: 1.0
Export-Package: org.eclipse.papyrus.infra.emf.compare.instance.papyrusemfcompareinstance,
org.eclipse.papyrus.infra.emf.compare.instance.papyrusemfcompareinstance.impl,
org.eclipse.papyrus.infra.emf.compare.instance.papyrusemfcompareinstance.util
-Require-Bundle: org.eclipse.core.runtime,
+Require-Bundle: org.eclipse.ui;bundle-version="3.8.0",
+ org.eclipse.core.runtime,
org.eclipse.emf.ecore;visibility:=reexport
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
diff --git a/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.ui/META-INF/MANIFEST.MF b/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.ui/META-INF/MANIFEST.MF
index 767c5df4c56..a32178574f6 100644
--- a/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.ui/META-INF/MANIFEST.MF
+++ b/extraplugins/uml/compare/org.eclipse.papyrus.infra.emf.compare.ui/META-INF/MANIFEST.MF
@@ -1,5 +1,6 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.compare,
+ org.eclipse.ui;bundle-version="3.8.0",
org.eclipse.emf.compare.ui;bundle-version="1.3.1",
org.eclipse.emf.facet.infra.browser.custom,
org.eclipse.emf.facet.infra.browser.custom.core,
diff --git a/extraplugins/uml/compare/org.eclipse.papyrus.uml.compare.diff/META-INF/MANIFEST.MF b/extraplugins/uml/compare/org.eclipse.papyrus.uml.compare.diff/META-INF/MANIFEST.MF
index 5e84aaa7fe2..e7b3cbbad9a 100644
--- a/extraplugins/uml/compare/org.eclipse.papyrus.uml.compare.diff/META-INF/MANIFEST.MF
+++ b/extraplugins/uml/compare/org.eclipse.papyrus.uml.compare.diff/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
+Require-Bundle: org.eclipse.ui;bundle-version="3.8.0",
org.eclipse.core.runtime,
org.eclipse.emf.compare.diff;bundle-version="1.3.1",
org.eclipse.papyrus.infra.core.log;bundle-version="0.10.0",
diff --git a/extraplugins/uml/compare/org.eclipse.papyrus.uml.compare.file/META-INF/MANIFEST.MF b/extraplugins/uml/compare/org.eclipse.papyrus.uml.compare.file/META-INF/MANIFEST.MF
index 63c4bf73f20..ab8cb319515 100644
--- a/extraplugins/uml/compare/org.eclipse.papyrus.uml.compare.file/META-INF/MANIFEST.MF
+++ b/extraplugins/uml/compare/org.eclipse.papyrus.uml.compare.file/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
+Require-Bundle: org.eclipse.ui;bundle-version="3.8.0",
org.eclipse.core.runtime,
org.eclipse.papyrus.uml.compare;bundle-version="0.10.0",
org.eclipse.emf.compare;bundle-version="1.3.1",
diff --git a/extraplugins/uml/compare/org.eclipse.papyrus.uml.compare/META-INF/MANIFEST.MF b/extraplugins/uml/compare/org.eclipse.papyrus.uml.compare/META-INF/MANIFEST.MF
index 0f1411df304..34b279a55a0 100644
--- a/extraplugins/uml/compare/org.eclipse.papyrus.uml.compare/META-INF/MANIFEST.MF
+++ b/extraplugins/uml/compare/org.eclipse.papyrus.uml.compare/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui,
+Require-Bundle: org.eclipse.ui;bundle-version="3.8.0",
org.eclipse.core.runtime,
org.eclipse.papyrus.infra.core.log;bundle-version="0.10.0",
org.eclipse.papyrus.infra.emf.compare.common;bundle-version="0.10.0",

Back to the top